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Tutorial 

Geometrical modelling functions: 
getting started with TRISCO 

TRC Tutorial a 

  
TRISCO 

 

 Introduction             building_corner_a.trc  

This first tutorial deals with the object modelling functions in TRISCO. The overall modelling 

philosophy via a coordinate system and blocks will be illustrated for a simple room corner. 

Thereafter, the obtained model will be used to show how to quickly combine and adjust existing 

models via block transformations. 

Key elements: 

- Creating a geometrical model from scratch 
- Coordinate system and blocks 

- Block transformation functions 

 Case study data 

The example concerns a simplified three-dimensional room corner consisting of: 

• insulated cavity wall 
o outer leaf: λ = 0.9 W/(m.K), d = 10 cm 

o insulation: λ = 0.030 W/(m.K), d = 5 cm 

o inner leaf: λ = 0.32 W/(m.K), d = 15 cm 

• insulated roof 
o a concrete roof slab: λ = 2.5 W/(m.K), d = 15 cm 

o insulated at the upper side: λ = 0.030 W/(m.K), d = 5 cm 

• a concrete column in the corner of the inner leaf : λ = 2.5 W/(m.K), section 45 cm x 15 cm 

The boundary conditions imposed are:  

- Indoors: temperature i = 20 °C, wall surface heat transfer coefficient = 5 W/m2K 

- Outdoors: temperature e = 0 °C, wall surface heat transfer coefficient = 25 W/m2K 

 

 

project_files/building_corner_a.trc
project_files/building_corner_a.trc
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  Data preparation     

Step 1: Choose a coordinate system 

- By default TRISCO will use the classic concept of a Cartesian coordinate system XYZ to 
define the position of geometrical blocks. However, an alternative system defining 

geometrical blocks via rows, columns and layers as in a 3D matrix is also available. At 
any time it is possible to switch between both systems (Settings → Show RCL and 

Settings → Show XYZ). 

Note: the Z axis should point upwards to the sky (left figure), and layers should be 
numbered downwards (right figure), to get a normal natural behaviour of the rotate 
function (Image → Rotate). 

     

Step 2: Drawings of relevant sections 

- It is useful to make a (hand-drawn) sketch of all relevant horizontal and vertical sections 
of the object. 

 
Step 3: Creation of the minium grid 

- Mark all relevant coordinates on the section drawings to define the minimum grid of the 
object model. 

- The minimum grid must contain all material boundaries and boundary condition 
boundaries.  At the outside of the object additional grid planes may be necessary to 
define boundary conditions. 

- The minimum grid has to be created using the following rules: 
o Each material border is a grid plane of the minimum grid. 

o On each axis the position of the minimum grid planes have to be marked and 
numbered. 

o In case of the XYZ coordinate system, a numbering with base 0 is used: 0,1,2,3, …. 
o If a material border coincides with the first or last grid plane, an adiabatic 

boundary condition (i.e. without any heat transfer) will be assumed. 
o An additional grid plane is necessary if there is a non-adiabatic boundary 

condition at such material border. 
- For our example see the cross section drawings on the next page: 

o At grid border X = 5 (row 11), Y = 6 (column 13) and Z = 0 (layer 9) an adiabatic 

boundary condition is assumed. 
o Grid border X = 0 (row 1), Y = 0 (column 1) and Z = 4 (layer 1) are added in order to 

allow an outer boundary condition in X = 1 (row 3), Y = 1 (column 3) and Z = 3 (layer 

3). 
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Coordinate system (XYZ) (default) Coordinate system (RCL) 
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  Entering the data  

Step 4: Open a new data file 

- Open a new file using the command File → New to start the data input.  A default block 
(cube with side 1 m) with colour number 5 is shown as starting data.   

 

                   

Step 5: Enter the minimum  

- The minimum grid are dimensions needed to create the object.  

This data is entered in the Grid window. 

Make this window active by clicking on its title bar using the left mouse button, or by 
selecting the menu command Edit → Grid.   

- Enter the scale of the drawing: choose the command Grid → Grid Unit… and enter 0.01 m 

to switch the measurements in the Grid window to centimeters.   

 

 
 

- Answer the prompt “Transform grid widths ?” with Yes. 
Enter the first grid mesh width in the Grid window by typing its value (i.e. 10) and pressing 

<Enter>. 

 
 

- Add a new grid cell using the command Edit → Insert After or press <Insert>.  

By default the new mesh width equals 1 (cm). 
Change the inserted mesh width into 10 (i.e. the thickness of the outer leaf of the cavity 
wall). 
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Insert new mesh widths by repeating the command Edit → Insert After and fill in the right 
mesh widths.  The resulting minimum grid is shown below (right). 

To see the minimum grid in the XY plane, the view can be changed to Zmax (Projection → 
6: Zmax). 

 

 

 
- It is a good pratice to save the (intermediate) data. 

Choose the command File → Save As… and enter a file name. 

Now the blocks can be entered using the grid coordinates as border specifications. 

Step 6: Adding material properties and boundary conditions to the minium grid 

- Materials and boundary conditions can now be defined via blocks in reference to the 

minimum grid. This block data have to be entered in the Blocks window.  

- Each block contains a colour reference and border coordinates.  The colour reference will 

be used to identify the thermal property or boundary condition.  
The border coordinates are expressed in grid numbers. 
Note: The user can overwrite colour properties in a project file and/or use predefined 
colours from the Colour database (see ‘How to modify the Colour database?’ (Help → 
How to’s…). To see all predefined colours select in the menu command Colours → List 
defined).   

- Change the colour reference number and coordinates of the default block, as in the figure 
below. 
 

   
 

- The Image window shows a perspective view of the created block.  The viewpoint can be 

changed using the commands in the Zoom submenu and mouse dragging within the 

Image window.   
- Enter a new block by selecting Edit → Insert After.   

- Enter the values as in the figure below. 
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- This second block overwrites partially the first block. 
The superposition principle is crucial in the (optimal) definition of blocks: a block with 
higher sequence number overwrites the common parts of blocks with lower sequence 
numbers. 

- Insert new blocks using Edit → Insert After or Edit → Insert Before, and adjust the colour 

and coordinate values as in the list below.  
 

  
 

- A block is hollow when its colour corresponds to a boundary condition type in the Colours 

window. In this example colour 174 and 170  have a colour type BC_SIMPL, which stands 
for a (simplified) boundary condition.   

- In this example we make use of the predefined colours in the Colour database (File → 

Open Colour database…) corresponding to following colour types:  
 

          

- For the Type MATERIAL a thermal conductivity and name are defined. 
- For the Type BC_SIMPL following elements are defined: 

o Subtype 
o Physical flow direction 

o Geometrical flow direction 
o Name 
o Temperature 
o Global heat transfer coefficient 
o Standard 

- It is possible to adjust the data in the Colour window; this will only be stored in the current 

TRISCO project file and does not affect the Colour database. Changing the fields in the 

first 4 columns and the last column in the Colour window is done by activating the cell with 
the cursor and pressing <Enter>. 

- Now the final object is visible in the Image window 
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- It is possible to display the object transparently by selecting Image → Show Transparent. 
- The contact surfaces of the boundary conditions on the object can be made visible by 

selecting the command Image → Show BCs.  
- As illustatrated in the above (right) picture, one global surface coefficient (7.7 W/m².K) has 

been defined in the current configuration. To be fully in line with EN ISO 10211 the inner 
boundary condition should be split between a heat transfer coefficient for horizontal heat 

transfer (7.7 W/m².K) and vertical upwards heat transfer (10 W/m².K). 
- To add the vertical upward heat tranfer coefficient to the object: 

o Select the grid mesh in Z from 0 to 1 (grid mesh Z 0-1) in the Grid window 

o Select Grid → Split… or press the shortcut key <Ctrl+I> 
o “Method”: Select “Border 2” 
o “Mesh width”: Define a small distance (e.g. 0.5 cm) 

o Add in the Blocks window a new block with colour 190 which is the predefined 

colour for upward heat flow (h=10 W/m².K) and coordinates X:4-5, Y:4-6 and Z:1-2. 
 

   

- In the Image window two different boundary conditions are visualised. 
 

  

- Restore the previous view by selecting Image → Show Materials. 
- Now all basic data are ready for a thermal calculation. 

However the grid meshes should be refined to get reliable results. 
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Step 7: Refine the grid 

- All grid meshes are split into smaller meshes of width = 2.5 cm. 
- Select all meshes using the command Grid → Select All (3 x).  The selected meshes in the 

Grid window are coloured (light or dark) turquoise. 

  

- Then open the Split dialog box using the command Grid → Split… (or press shortcut key 

<Ctrl+I>) and set the parameters as in the figure above right. 
- These settings cause that all selected meshes are split into equal subparts of width 2.5 cm. 

(In case an original selected mesh is not a multiple of the new mesh width, also one 
smaller mesh is created containing the remainder of the division.) 

- To go back to the minimum grid: Grid → Create Minimum Grid… 

- Other mesh functions (e.g. Grid → Auto Split…) can be used to obtain a more balanced 
grid (with less calculation nodes and yet a good solution quality): building_corner_b.trc 
 

  System calculation  

- Start the calculation: Calc → Calc System.  

- The calculated temperatures are shown in the Image window. 
 

 
 

- Move the mouse cursor over the object in the Image window to see (in the status bar, at 

the bottom of the screen) the temperature at the mouse cursor position.  (This requires the 

Image window is active.) 

project_files/building_corner_b.trc
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- Detailed output results can be explored in the Graphic Output window and Text Output 

window. 

  Object cut operation using automatic block arrangement                building_corner_c.trc  

- By default the block arrangement in TRISCO is using a superposition principle as 
illustrated in the previous examples. 

- When a part of an object must be cut, automatic block arrangement with juxtaposition 
can be used to remove all overlapping parts in the object.   

- First mark out the cutout region with a new block (using a new colour) over the object.   

o Add grid meshes in X and Z to obtain the Grid window depicted below (left) 

o Insert a new block for the cutout region: see block no. 10 with colour no. 7 in the 

picture below middle.  The picture below right shows the corresponding 3D image. 

   

- Use the command Blocks → Arrange Blocks… and select “Use juxtaposition” to remove all 
superposition of blocks (in particular under the new block). 
 

 
 

- The blocks are remodelled in the Blocks window (with 18 blocks, all adjacent to each other 

without any superposition), but resulting in the same 3D object (i.e. the Image window 
does not alter).   

- Position the active cell in the Blocks window in block no. 1 (which was added with colour 7) 

and delete this block using Edit → Delete to clear the wanted cutout.  The figures below 
show the result. 

  

- The space of the cutout is now void, neither containing any boundary condition (and 
consequently adiabatic).  Use the command View → BCs to view the boundary conditions 
active on the object surfaces.   

project_files/building_corner_c.trc
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  Block transformations                                                                   building_corner_d.trc  
            steelbeam.trc  

- Starting from the first example in this tutorial (building_corner_a.trc) and another simple 
object detail (steelbeam.trc) a composite object is constructed to show the possibilities of 

block transformations and file insertion. 

 

Step 1: Copy and mirror functions 

- Open the file building_corner_a.trc from File → Open… 
- Save under a new file name Compose.trc via File → Save As… 

- Make the Blocks window active by clicking with the left mouse button in this window 

- Select all blocks (Edit → Select All or via shortcut key <Ctrl+A>). 
- Copy the selected blocks (Blocks → Copy). 

- The copied blocks (no. 10-18) remain selected (marked in turquoise). 
- Mirror the selected blocks against the coordinate face XZ: 

Blocks → Transform Coordinates… (or press <Ctrl+F>) with the following parameters: 

o “Transformation”: select “scaling”. 
o “Scaling factors”: define X = 1, Y = -1, Z = 1. 
o This coordinate scaling corresponds to the wanted mirror operation. 

 

  

project_files/building_corner_d.trc
project_files/SteelBeam.trc
project_files/building_corner_a.trc
project_files/building_corner_a.trc
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Note the grid is changed into a minimum grid (only grid planes through object block borders). 

The transition to a minimum grid is done automatically after each block operation that affects 

the grid (Blocks → Transform Coordinates…, Blocks → Insert File…). 

− Translate the selected blocks to the maximum Y position. 
Blocks → Transform Coordinates… ( <Ctrl+F>)  

o “Transformation”: select “Translation”. 
o “Translation vector”: define X = 0, Y = 280 cm, Z = 0. 

 

− End the current block selection: Edit → Deselect All. 
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Step 2: Import the steel beam 

- The steel beam will be loaded from a separate file which was prepared in advance. 
- Set a new coordinate origin as anchor point for the file insertion. 

o Split the grid mesh X 4-5: 

o Set the current grid cell on this grid mesh in the Grid window. 
o Then do Grid → Split… with the default parameters (Number of subdivisions = 2, 

Method = geometric, Split ratio = 1). 
- Split the grid mesh Z 0-1 into two equal parts using the same method. 
- Insert a new mesh before Y 0-1: 

o Set the current grid cell on the mesh Y 0-1. 
Edit → Insert Before. 
Type the new mesh width: 50 (cm). 

- Load the Coordinates window (with absolute coordinates of grid borders): 

Edit → Coordinates. 
- Set the new origin on the X axis: 

Set the current grid cell on coordinate X 5 (= 90.000). 
Execute Coord → Set Origin. 
All coordinates on the X axis are moved so that X 5 becomes the new origin (= 0.000). 

- Set the new origin on the Z axis equal to Z 1 (= 49.750). 

- The Image window shows the new origin: i.e. the point where X axis (in red), Y axis (in 

green) and Z axis (in blue) cross. 

   

- Import the file steelbeam.trc using Blocks → Insert File… 

- The blocks in this file are inserted into the Blocks window after the current position (here 

the end of the list of blocks).  The inserted blocks are translated to the current origin.  The 
inserted blocks are selected (marked in turquoise).  The thermal properties related to 
colours of the inserted blocks that are not yet present in the current project, are loaded 

from the inserted file into the Colours window (see colour 13). 

 

project_files/steelbeam.trc
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- Transform the beam into the desired position: 
o Rotate the beam around the current Z axis (in blue). 

Blocks → Transform Coordinates… 
“Transformation”: select “rotation”. 
“Rotation axis”: select “Z”. 

“Rotation angle”: select “90°”. 
o Adjust the length (= 100 cm) of the horizontal beam to be 200 cm. 

Blocks → Transform Coordinates… 
“Transformation”: select “scaling”. 
“Scaling factors”: define X = 1, Y = 2, Z = 1. 
 

 
 

- The vertical beam is set as follows: 
o Move the coordinate origin on the Y axis onto coordinate Y 8 (= 200.00) using 

Coord → Set Origin. 

o Copy the selected blocks (corresponding to the horizontal beam). 

Blocks → Copy. 
o Rotate the selected blocks (which form a copy of the horizontal beam) around the 

(new) X axis over 90° using Blocks → Transform Coordinates… 

o Adjust the length (= 200 cm) of the vertical beam to be 50 cm using coordinate 

scaling. 
Blocks → Transform Coordinates… 
Transformation = scaling. 

Scaling factors: scale X = 1, scale Y = 1, scale Z = 0.25. 
o End the current block selection: Edit → Deselect All. 
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Step 3: System calculation 

- Adjust the outside boundary condition block: 
- Change Ymin (= 1) of block no. 1 (colour 2) in the Blocks window into Ymin = 0 to cover the 

exterior part of the beam with outer boundary conditions (colour 170). 

 

- Refine the grid. 
Here a simple grid refinement is used starting from the current minimum grid: 

o Activate Grid window (Edit → Grid) 
o Refine grid via automatic split function: 

Grid → Auto Split… with following parameters. 

 

 
 

- Solve the system: Calc → Calc System. 
- The system contains 268 995 nodes and is solved in a few seconds. 

 

 


