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1. Introduction 

T_VTR_a_solar_double_skin_facade_a.vtr 

T_VTR_a_solar_double_skin_facade_b.vtr 

This tutorial introduces the transient simulation modelling workflow in VOLTRA, demonstrated 

through a double-skin façade case study using the solar processor. The focus is on VOLTRA-specific 

functions and parameters. Most of the general geometrical modelling procedures are covered in 

TRISCO, so it is recommended to complete the TRISCO tutorials beforehand. 

Key elements: 

- Weather data (EPW-format) as boundary conditions 

- Defining glazing properties 

- Definition of solar data and sun obstacles 

- Defining ventilation flow 

- Graphic output, text output and report definitions 

2. Model geometry, material properties, boundary conditions  

In the 2D room model considered (Figure 1) the frame section is simplified to reduced the simulation 

time for the purpose of this tutorial. More complex geometrical models are possible.  

We start the tutorial with T_VTR_a_solar_double_skin_facade_a.vtr add step-by-step elements in the 

following sections. The final result will be  T_VTR_a_solar_double_skin_facade_b.vtr. 

 

In the first step, a coarse grid is used. It is generally good practice to begin with transient simulations 

on a coarse grid to evaluate the model’s initial behaviour, identify potential issues, and make 

necessary adjustments before investing time in a refined mesh. In this tutorial, the initial coarse grid 

is shown in Figure 2. Later, in section 11, the results obtained using a finer grid are presented 

(T_VTR_a_solar_double_skin_facade_b.vtr). 

Project_Files/T_VTR_a_solar_double_skin_facade_a.vtr
Project_Files/T_VTR_a_solar_double_skin_facade_b.vtr
Project_Files/T_VTR_a_solar_double_skin_facade_a.vtr
Project_Files/T_VTR_a_solar_double_skin_facade_b.vtr
Project_Files/T_VTR_a_solar_double_skin_facade_b_fine_grid.vtr
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Figure 1 2D room model 

 

Figure 2 Coarse grid 

 

Figure 3 Material properties and boundary conditions 
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Figure 3 shows the colour definitions used in VOLTRA model. There are 4 different types used here.  

- BC_SIMPL  for the boundary conditions in outdoors and in neighbouring rooms. Locations 

   of BC_SIMPL colours are presented in Figure 4 

- MATERIAL  for all solid materials 

- BC_FREE   for the room, indoors ceiling cavity and façade cavity 

- TRANSMAT  for the double glazing argon cavity 

 

 

 

Figure 4 BC_SIMPL positions and colours 

Particularities about the input data (Figure 3) 

- The outdoor (colour 2) is a ‘solar’ zone. 

- The outdoor global surface heat transfer coefficient he = 13.5 W/m2K (summer conditions, low 

wind) 

- Material properties (including density and specific heat) are adjusted for this case study. User 

can use existing materials from the material database with corresponding colour number or 

overwrite new properties manually.  

- The infrared emissivity is 0.9 for all materials except glass for which 0.837 is used according to 

EN 673.  

Glass 2 – colour 3 has a low emissivity coating with 𝜀 = 0.05 

All materials, except the glazing, are opaque (τs=0) for solar radiation. 

All materials, except the glazing, have a solar absorption αs=0.5 (light colour) 

The glazing solar properties are discussed in section 4.  

- Room, ceiling, façade cavity are modelled as BC_FREE and argon cavity of the DGU is 

modelled as TRANSMAT. For these types detailed infrared radiation is considered.  

Upper zone (20°C) 
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3. Weather data 

- Open the Functions window (Edit → Functions). 

- Add a new Function: Edit → Insert Row.  

- For this tutorials we will create 3 functions for which we use the Type EPW: 

o G01: horizontal global solar radiation 

o D01: horizontal diffuse solar radiation 

o T01 : temperature 

 

Figure 5 Weather data functions 

- The first function with reference G01 refers to the horizontal global solar radiation data for 

Brussels. 

- A function reference consists of a letter which refers to the function type (here “G” = horizontal 

global solar radiation) and a two-digit sequence number. 

- The Function Graph window shows the current function G01. 

The time axis shows all days of the year with the origin (abscissa 0) at day number 220 (= 

August 8th), as defined in the Calculation Parameters dialog box (Edit → Calc Parameters…, 

day number at start of calculation = 220, see section 5). 

 

Figure 6 Function G01 graph (function scope) 

- Functions → X Scale… and select “Calculation time” as scope.  
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Figure 7 Function G01 graph (calculation time scope) 

 

- The function “D01” is used for the creation of the horizontal diffuse solar radiation data of 

Brussels (see Figure 8 left). The function “T01” shows the air temperature of Brussels (see Figure 

8 right).  

  

Figure 8 Function D01 (left) and T01 (right) 

- After adding the temperature function, it is essential to link it to the external boundary 

condition. This is done by referencing the function name (e.g., T01) in the temperature value 

field of the boundary condition settings. 

 

Figure 9 Temperature function assigned to colour 2 (outside boundary condition) 

4. Glazing properties 

The glazing properties need some special attention, especially because the solar transmission factor 

to be entered is defined not in the classic way. In VOLTRA, the solar transmission factor expresses 

the solar transmission fraction after deduction of reflection (which can be dependent on the angle 

of incidence).  

For more information refer to H14-How to define glazing in BISTRA & VOLTRA. 

Physibel online toolbox can be used to prepare the glazing characteristics. 

https://www.physibel.be/en/knowledge#h14-how-to-define-a-glazing-system-in-bistra-voltra
https://apps.physibel.be/glass/
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Figure 10 Glazing properties 

As shown in Figure 10 each pane is divided into two colours. This allows different parameters to be 

assigned to the front and back surfaces of each glass layer. In this specific case, however, there is 

no difference between the properties of colours 1 and 2, nor between 5 and 6. Therefore, these 

pairs can be treated as a single colour. However, for the first pane, the reflectance of the exterior 

surface depends on the angle of incidence. Since this angle‑dependent reflectivity must be 

defined as a function in VOLTRA, colours 1 and 2 must remain separate. When using Physibel 

Toolbox to determine the correct 𝜏𝑝ℎ𝑦𝑠𝑖𝑏𝑒𝑙 value, the reflectivity at 0° incidence (normal incidence) 

should be entered using the manufacturer’s data. 

Figure 11 shows the angle dependency of solar reflection used for the external glazing surface. This 

angle dependent reflection factor at the solar zone, defined by a function referred to by “R01” (cf. 

Function window). 

The function R01 is defined by the following points ρ0 = ρ15 = ρ30 = 0.070, ρ45 = 0.089, ρ60 =

0.144, ρ75 = 0.377, ρ90 = 1.0. All other properties are linearly interpolated (as shown in the function 

graph (Figure 11)). The function file ‘glass.FRF’ is a simple text file (see Figure 11). The 

angle‑dependent reflection function is linked to the material property colour 66 glass 1 - colour1 by 

entering the function reference (e.g., R01) in the ρs section. Figure 12 illustrates how this function is 

linked to colour 66. 

The cavity between pane 1 and pane 2 is filled with argon, which has a conductivity of 0.017 W/mK. 

In the model this cavity is represented using TRANSMAT (colour 243. The façade cavity between 

pane 2 and pane 3 is filled with air and is modelled using BC_FREE(colour 242). 
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Figure 11 Glazing angle dependent solar reflection 

 

Figure 12 Updated glazing properties 

Note: it is important to define the gas cavity of the DGU as type TRANSMAT and not as EQUIMAT. 

EQUIMAT would consider this cavity as an equivalent material, thus not considering detailed 

radiation properties 
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5. Solar data and calculation parameters 

 

Figure 13 Solar data 

Upon opening the Solar Data dialog box (Edit → Solar Data…), the user can choose to simulate a 

real sun path or perform a simplified simulation with a fixed sun position. A real sun path is selected 

for this tutorial. The geographical location (latitude, longitude and time zone) are copied from the 

EPW file, and the input is not required in the Solar Data dialog box (the corresponding input fields 

are greyed). 

The orientation angle was adjusted by –90°, resulting in a west‑facing façade. August 8 (Day 220) 

was selected because the west façade on this date experiences the highest thermal load, not only 

compared to all other days of the year, but also relative to façades facing other orientations. For 

more information how to select the worst day for simulation please refer to Physibel Knowledge 

base document: H16 – How to determine the day with the highest outdoor climate load as a 

function of the façade orientation in BISTRA & VOLTRA 

The simulation is performed for one day, preceded by a three‑day start‑up (initialization) period to 

ensure thermal stabilization of the model with a time step of 10 minutes. These dynamic calculation 

parameters are set in the Calculation Parameters dialog box (opened with Edit → Calc 

Parameters…). Figure 14 shows the calculation parameters.  

https://www.physibel.be/en/knowledge#h16-how-to-determine-the-day-with-the-highest-outdoor-climate-load-as-a-function-of-the-fa%C3%A7ade-orientation-in-bistra-voltra
https://www.physibel.be/en/knowledge#h16-how-to-determine-the-day-with-the-highest-outdoor-climate-load-as-a-function-of-the-fa%C3%A7ade-orientation-in-bistra-voltra
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Figure 14 Calculation parameters 

6. Sun obstacles 

A sun obstacle is a spherical region on the sky hemisphere in the horizontal coordinate system in 

which the sun is blocked by other objects. Sun obstacles are defined in the Sun Obstacles window 

(Edit → Sun Obstacles). 

A new row can be inserted in the Sun Obstacles window via Edit → Insert Row . 

 

Figure 15 Sun obstacles window 

The first sun obstacle shown in Figure 15 is a zone around the horizon up to 5° high. This obstacle is 

by default present for each new VOLTRA data file to avoid numerical rounding errors for low sun 

positions. 

The sun obstacles can be seen via Output → Graphic Output → View → Sun Position & Sun 

Obstacles 
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Figure 16 Sun obstacles in Graphic Output 

7. Output nodes and report definition 

In VOLTRA, output nodes can be defined to report the temperature values in the corresponding 

node for the calculation period.  

First these nodes defined through Edit → Output Nodes. Figure 17 illustrates the defined output 

nodes positions and grid numbers. 

 

Figure 17 Output nodes 

 

The Report Definition window (Edit → Report Definition) contains the report items that will be 

included in the text report output. Adding a new row to define an output: Edit → Insert Row  

The text report tabulates the report values at a regular time step interval (here every time step, cf. 

setting in Calc → Report Frequency…). 
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Figure 18 Report definition 

Following items are reported in the text report: 

- Time, using date format 

- Outdoor temperature (colour 2) 

- Air temperature inside the room (colour 240) 

- Air temperature inside the façade cavity (colour 242) 

- Single glazing temperature (output node 1) 

- Floor temperature close to the façade (output node 2) 

- Floor temperature close to the wall (output node 3) 

8. VOLTRA calculation 

Before starting the calculation, request that step solutions (.sol files and .sfx files) are saved during 

the calculation, so that afterwards graphic animations can be made in the graphic output section 

(Output → Graphic Output).  

Open the Save Frequency dialog box with Calc → Save Frequency… to view the settings. 

 

Figure 19 Save frequency settings 

Solution is saved for every 6 time steps which means for every hour.  

Calculation starts with Calc → Calc System.  

During the calculation a calculation monitor is displayed showing the progress (with current time 

step, current iteration step, stopping criteria, number of nodes, view factors). 

After the calculation, output is available through the submenus via Output → Graphic Output or 

Output → Text Output.  
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9. Graphic output 

- Go to Output → Graphic Output  

- Select the view option View → Fill Temperatures.  

The temperature range (15°C – 55°C) and the temperature increment (1°C) can be changed in 

the Temperature Range dialog box, opened with Settings → Temperature Range….  

- Get the results at the time step at 5 p.m. (Animate → Go To…, enter 0000:17:00:00). We get 

highest temperature on the west façade at 5 p.m. 

 

Figure 20 Temperature contour at 5 p.m. 

- Move the mouse over the image to get the temperature at the mouse point displayed in the 

status bar at the bottom of the VOLTRA window.  

The absorbed solar radiation contour can be obtained through View → Absorped Solar Fluxes  
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Figure 21 Absorbed solar fluxes at 5 p.m. 

These two contours can also be viewed with sun position. View → Sun Position & Fill Temperatures 

or View → Fill Absorbed Solar Fluxes produce the graphics shown in Figure 22. 

 

Figure 22 Sun position and temperature (left), sun position and absorbed solar fluxes (right) 

 

To make an animation of the field temperatures with Microsoft Clipchamp 

- Prepare the animation images in VOLTRA:  

o View → Fill Temperatures.  

o File → Save Animation Images…  

- Open Microsoft Clipchamp, start new Blank Video (e.g. Temperature_August 8)   

o Add the generated Animation Images to the My media via Import media. 
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o Click Sort → Select Name, and Ascending to have the correct order of the 

images. 

o Select all images, drag and drop them thereafter to the main window. 

o Right click → Edit duration → 0.3s (You may choose it different). 

o Right click on gap between two image → Delete all visual gaps. 

o Finish video to export in .mp4. 

10. Text output 

- Go to Output → Text Output  

- Select View → Time Step Results, and Edit → Go To…, enter 0000:12:00:00. The text window 

shows the time step results at 12 a.m.  

 

Figure 23 Calculation results at 12 a.m. 
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- Select View → Report Output to get the report item values per time step for the report items 

defined in the Report Definition window (cf. section 7) 

 

Figure 24 Report output 

The data can be exported to any spreadsheet application to visualize the results.  

 

Figure 25 Temperature for specified points 
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11. Grid refinement and results 

T_VTR_a_solar_double_skin_facade_fine_grid_corrected.vtr 

In the previous steps a coarse grid was assumed. The grid was refined in both the X and Z directions.  

X‑direction refinement 

All cells (except those with a width of 500 mm) were subdivided into two equal parts using: 

Grid → Split → Method: Geometric → Number of subdivisions: 2 

Cells with a width of 500 mm were instead subdivided into five equal parts. 

Z‑direction refinement 

In the vertical direction, all cells with a height greater than 25 mm were subdivided into cells 

of maximum 25 mm using: 

Grid → Split → Method: Maximum → Mesh width: 25 mm 

Figure 26 shows the temperature contour at 5 p.m. for finer grid. Because of the too rough grid used 

in previous steps (Figure 20) the temperature values are inaccurate. It can be seen that in the 

facade highest temperature is changed. Also the absorbed solar fluxes of finer grid are shown in 

Figure 27, this can be compared with Figure 21.  

 

Figure 26 Temperature contour at 5 p.m. (finer grid) 

Project_Files/T_VTR_a_solar_double_skin_facade_b_fine_grid.vtr
Project_Files/T_VTR_a_solar_double_skin_facade_b_fine_grid.vtr
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Figure 27 Absorbed solar fluxes at 5 p.m. (finer grid) 

A rough grid is interesting during the data preparation (allowing quick test simulations) but for a final 

simulation a fine grid is required. Figure 28 shows the temperature for specified points throughout 

the simulation. 

 

Figure 28 Temperature for specified points (finer grid) 


