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CHAPTER A INTRODUCTION 

A.1. Short description of VOLTRA & SECTRA 

VOLTRA is a thermal analysis program for transient heat transfer in three-dimensional rectangular 

objects.  VOLTRA is an extension for time-dependent boundary conditions of TRISCO (for  

steady-state heat transfer). 

 

VOLTRA can be used to carry out fire simulations (with use of the RADCON module).  Radiative 

heat transfer becomes more important when temperature differences increase.  The RADCON 

module allows to include the simulation of non-linear radiation based on geometric view factors.  

The thermal conductivity and specific heat of materials may be temperature dependent.  Latent heat 

is modelled through an increase of specific heat within a small temperature interval around the 

change of phase temperature. 

Heat transfer to objects via (time dependent) ventilation between zones at different temperatures 

can be studied. 

Dynamic solar heat gains can be studied (since version 6).  To this end a solar processor is built in 

(which requires the use of the RADCON module).  An object image with shadows cast by direct 

sun light at any time and any geographic location can be viewed.  The direct and diffuse solar 

radiation from climate data (e.g. as given in the European Test Reference Years) is cast on the 

material surfaces.  The absorbed solar radiation is converted to time dependent node powers, as 

additional boundary conditions to the system.  Transmission of solar radiation is possible via 

transparent materials to simulate heat gains through windows.  The reflected solar radiation is 

diffuse and distributed according to the view factors (calculated with the RADCON module) to 

other material surfaces.  Direct radiation is reflected (as diffuse radiation) using a reflection factor 

which may be function of the angle of incidence. 

Controls are available (since version 8) to replace boundary condition functions or material property 

functions with other functions, based on sensor temperature target functions. 

 

The object modelling is completely identical as in TRISCO.  A TRISCO data file, BISTRA data 

file, BISCO data file or bitmap (BMP file) can be taken as starting data in VOLTRA. 

This manual is an extension of the TRISCO manual.  First read the TRISCO manual before reading 

the VOLTRA manual. 

 

The time-dependent boundary conditions are described with functions, either built-in functions 

based on parameters, or external user-defined functions based on function values given at a fixed 

time interval. 

The thermal conductivity, specific heat and reflection factor of a material can refer to functions 

described in external text files: thermal conductivity as a function of temperature, specific heat as a 

function of temperature, solar reflection factor as a function of angle of incidence. 

 

VOLTRA allows creating time-dependent graphic animations of moving shadow patterns, 

calculated temperature field and heat flux field in the studied object.  Alphanumeric lists of time 

functions of temperatures in individual nodes or heat flows through given surfaces through the 

object can be made.  Graphs using the text output data can be drawn e.g. in Microsoft Excel. 

 

SECTRA (or VOLTRA-2D) is a two-dimensional reduced version of VOLTRA.  It is the transient 

counterpart of the program KOBRU86 (or TRISCO-2D) for 2D steady-state heat transfer. 
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The RADCON module, which allows a better simulation of radiation (using view factors) and 

convection, is available in VOLTRA (from version 3), and is required for fire simulation and use of 

the solar processor. 

A.2. Program releases history 

VOLTRA v1.0 dates from May 1993. 

 

VOLTRA v3.0w (December 2001) is the first Windows version: 

 Developed for Microsoft Windows (Windows 95, Windows 98, Windows NT, Windows 2000, 

and upwards).  

 Through another system solution technique, much larger systems can be solved. The node 

capacity is of the same order of magnitude as in TRISCO: 1 000 000 nodes and more.  

 The calculation is at least 50 times faster.  

 The RADCON module can be used.  

 Most of the functionality of the Windows version of TRISCO (i.e. from version 8 up) is also 

available in VOLTRA (e.g. choice of language, 3D preview of the geometry when selecting data 

files, image feedback window, zoom functions, block transformations, automatic calculation of 

equivalent thermal conductivities of cavities and convective heat transfer coefficients in air 

cavities, batch calculation, output bitmaps with user-defined resolution). 

 Built-in converter to import data from previous SECTRA and VOLTRA versions and from 

TRISCO (from version 8 up).  

 A graphic preview of the internal function definitions is possible.  

 The concept of line and plane definitions is changed into the definition of output blocks.  

 Intermediate solution files can be saved on hard disk, and are useful for the production of 

animation sequences from different points of view.  

 *.avi files of graphic animations with a user defined resolution can be written.  These .avi files 

can be viewed using Windows Media Player or another tool.  

 Graphs of temperature or heat flow courses as a function of time are not directly possible within 

VOLTRA, but can be made e.g. using Microsoft Excel.  

 

VOLTRA v3.1w (December 2002) contains the following extensions (to be compatible with 

TRISCO v10.0w): 

 Two new types of boundary conditions:  

1. Enclosures with unknown temperature and global surface heat transfer coefficient 

  (type BC_FRE_S). 

2. Border faces between colours having a fixed temperature function course or heat flux 

  function course (“borderface BCs”). 

 New split mesh functions (Grid > Split Mesh max… and Grid > Split All max…). 

 Graphical feedback in the Image window of a selected item in another edit window can be 

toggled on or off (Image > Hide Selection Outline). 

 

VOLTRA v4.0w (April 2003) contains the following additions: 

 Temperature dependent material properties (thermal conductivity, specific heat), which are 

useful in e.g. fire simulations. 

 Simulation of ventilation flows through different air zones following one or more user-defined 

paths.  The ventilation flow rates can change in time as defined in ventilation time functions.  

The simulation of ventilation flows allows the study of heating and cooling of objects due to 

ventilation systems. 

 Possibility of different convection nodes (related to different colours) in one air cavity, useful 

e.g. for the simulation of a ventilation flow through a chimney. 
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VOLTRA v5.0w (September 2005) 

 Contains functionality of TRISCO v11.0w (easier input editing & better graphic feedback). 

 New type of material (requires RADCON module): transparent material (conduction + 

radiation), useful for small air cavities of irregular shape (instead of materials of type 

EQUIMAT). 

 New type of boundary condition: material with given temperature (function) or heat power 

density. 

 No function references required for constant numeric input values. 

 Function Graph window as visual feedback of the input in the Functions window, with zoom 

facilities. 

 Image window: interactive view of temperature value (after calculation) at cursor location per 

time step. 

 Undo/redo edit actions. 

 View factors calculation: view factors in a fine grid can be obtained through interpolation of 

view factors in a coarser grid (to overcome the quadratic proliferation of view factors in a fine 

calculation grid). 

 Graphic output: 

clip colours (to hide certain material layers, to get a better inside view of the object); 

view heat fluxes in material cutoff planes. 

 

VOLTRA v6.0w (September 2006) contains the solar processor. 

 Same solar radiation boundary condition data files as in CAPSOL (global and diffuse radiation 

on a horizontal surface). 

 Input required of north orientation. 

 Calculation of sun position and visualisation of shadows cast by direct sun light. 

Creation of AVI animation file of shadows over calculation period. 

 Additional material properties required: reflection factor (may be a function of the angle of 

incidence), transmission factor (to indicate a transparent material). 

 Calculation and visualisation of absorbed solar fluxes on material surfaces due to solar radiation 

(requires the use of the RADCON module). 

Direct solar radiation on an exterior material surface depends on geographical location, solar 

radiation climate data, day of year, clock time, surface orientation. 

Diffuse solar radiation on an exterior material surface depends on the view factor to the open sky 

and is calculated using Muneer’s radiation model (also used in CAPSOL). 

Reflected radiation (of direct and diffuse incident radiation) at an exterior material surface is lost 

(as in CAPSOL).  An input parameter (“ground reflection factor”) allows to take into account the 

reflected radiation from the environment. 

Radiation on transparent materials are transmitted to internal zones. 

Direct radiation is projected on internal walls following the solar rays. 

Diffuse radiation is distributed on all internal walls proportional to the view factors. 

All reflected radiation at an interior material surface is diffuse and is redistributed to the other 

interior surfaces proportional to the view factors. 

The scheme of successive internal reflections and transmissions is solved using a radiosity 

method. 

The view factors can be obtained from a prior view factor calculation using a coarser grid (to 

speed up the processing time and reduce the required memory space). 

The absorbed solar fluxes can be output to an AVI animation file or output to a text file. 

 The absorbed solar fluxes can be used as boundary conditions for a thermal simulation 

(calculation of temperatures).  In this way solar heat gains on the thermal behaviour of a 

construction can be studied. 
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 The format of view factor file is modified. 

 

VOLTRA v6.1w (April 2008) 

 Solar processor adapted to use of 2D geometries (SECTRA). 

 Adjust coordinates of output nodes and output blocks after any grid operation. 

 

VOLTRA v6.2w (May 2009) 

 Diffuse solar reflection also possible in solar zone (of type BC_SKY). 

 Sun obstacles (as in CAPSOL and BISTRA), defined as sky hemisphere regions, which block 

direct solar irradiation and decrease diffuse solar irradiation. 

 Import BISTRA data. 

 

VOLTRA v6.3w (December 2009) 

 Improved more stable calculation of systems with ventilation flows. 

 

VOLTRA v7.0w (March 2012) 

 Default data file Voltra.vtr with initialisation values for thermal properties per colour. 

 Time dependent functions for thermal conductivity, total surface heat transfer coefficient and 

convective heat transfer coefficient. 

 Functions compatible with TRISCO v12.0w: automatic split for grid refinement; 

equivalent thermal conductivities for cavities with different surface emissivities. 

 Show temperature or heat flux under the cursor in the graphic output. 

 3D visualisation of sun position at any time step. 

 Show temperature profile along a grid line at any time step. 

 

VOLTRA v8.0w (May 2017) 

 Functions compatible with TRISCO v14.0w: recalculation of blocks (Blocks > Arrange 

Blocks…); clip blocks (Blocks > Reduce to Clip…); detect void space (Blocks > Convert Void to 

Blocks); show materials as transparent blocks (Image > Show Transparent), display grid unit; 

simulation of adiabatic surface of transparent material (type TRANSMAT), graphic output of 

single isothermal line. 

 Show north direction and sun paths (function Image > Show North from main menu) and sun 

position (function View > Sun Position from graphic output window). 

 Controls which allow to replace boundary condition functions (temperature, heat power, heat 

flux, heat transfer coefficient, ventilation) or material property functions (thermal conductivity, 

infrared emissivity, solar reflection factor, solar transmission factor) with other functions (of the 

same type), dependent on the temperature in a sensor node compared to a temperature target 

function (of time) and desired heating or cooling. 

The replacement of a ventilation function can also be dependent on a minimum required 

temperature difference between two ventilation zones. 

 Control functions can also refer to constant functions. 

The constant function is reintroduced as function type in the Functions window. 

 The infrared emissivity of a material surface and the solar transmission factor of a material can 

be a function of time (intended for use with controls, e.g. for the simulation of solar screens). 

A.3. Minimum system requirements 

 VOLTRA is a 32-bit Windows program (which can also be run from Windows 64-bit). 

VOLTRA 32-bit is installed (on Windows 7) in C:\Program Files (x86)\Physibel\Voltra. 

In this folder the executable file is Voltra.exe. 
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 512 Mb RAM allows to solve a system of about 1,000,000 nodes. 

1 Gb RAM allows to solve about 3,000,000 nodes. 

The maximum usable memory space of the 32-bit program is limited to 2 Gb (even if more RAM 

is installed). 

 VOLTRA relies on OpenGL for use of hardware accelerated graphics. 

 A software licence of VOLTRA is protected by a hardware key, provided by Physibel to the end 

user.  The demo version of VOLTRA is not protected. 

A.4. VOLTRA 64-bit 

A 64-bit version of VOLTRA is available as an option. 

VOLTRA 64-bit is installed in C:\Program Files (x86)\Physibel\Voltra64. 

In this folder the executable file is Voltra64.exe. 

The memory space of the 64-bit program is limited to the installed RAM (which may be larger than 

2 Gb). 

 

The Physibel 64-bit programs need several shared libraries (.dll files) from Microsoft. 

The Microsoft Visual C++ 2017 Redistributable Package (x64) can be downloaded from 

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads. 

This package installs mfc140.dll and other files in the directory C:\Windows\SysWOW64, required 

by 64-bit applicatons developed with Microsoft Visual C++ 2017. 

 

Data folder (from Windows 7) 

From Windows 7 it is strongly recommended to move the installed data folder 

(C:\Program Files (x86)\Physibel\Voltra\Data) to a location out of C:\Program Files (x86), e.g. 

C:\Physibel\Voltra\Data. 

Otherwise for new or modified data files a virtual folder (invisible within VOLTRA) will be used, 

e.g. C:\Users\User\AppData\Local\VirtualStore\Program Files (x86)\Physibel\Voltra\Data. 

 

Differences of VOLTRA64 compared to the 32-bit program VOLTRA 

 During file selection in the File Open dialog box (using File > Open…) no graphic data preview 

is available. 

 From the the Graphic Output menu only PNG files can be saved (using File > Save As…). 

No BMP files can be saved as in the 32-bit program. 

 No graphic output can be printed directly from the the Graphic Output menu 

(there is no function File > Print…). 

 No AVI files can be created from the Graphic Output menu 

(i.e. there is no function File > Write AVI File…). 

A.5. Overview of delivered files and file structure 

VOLTRA is installed (when the user has accepted the default destination) in the folder 

C:\Program Files (x86)\Physibel. 

 

The following files are installed, or created when using VOLTRA: 

Folder File Description 

…\Physibel\Voltra Voltra.exe VOLTRA (32-bit) program 

 Sectra.exe SECTRA (32-bit) program 

 Funcedit.exe Function editor 

 Voltra.prm Program parameters 

 Voltra.vtr Template data file read at start up of VOLTRA 

 *.dll, *.pat, *.rgb Program resources 

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
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…\Physibel\Voltra\Data *.vtr VOLTRA data files 

 *.fte, *.fem, *.fir, *.ffh, *.fvr, *.fsg, *.fsd, *.fht, *.fco, *.fla, *.fce, 

 *.frf, *.ftr Function files 

 *.vwf Calculated viewfactors (with RADCON) 

 *.sfd, *.sfx Calculated absorbed solar fluxes (RADCON) 

 *.sol Calculated node temperatures 

 *.flx Calculated fluxes (with RADCON) 

 *.png, *.bmp, *.avi Graphic output files 

 *.txt, *.doc Text output files 

…\Physibel\Voltra64 Voltra64.exe VOLTRA 64-bit program 

 *.dll, *.pat, *.rgb Program resources 

…\Physibel\Materials *.phm Material databases 

 MatEdit.exe Material editor 

 MatEdit.prm Material editor program parameters 

 *.dll, *.pat Material editor resources 

…\Physibel\Manuals VoltraManual.pdf VOLTRA manual 

 MatEditManual.pdf Material editor manual 
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CHAPTER B INPUT DATA 

B.1. Program example 

Data file: PilotexVoltra.vtr (installed in the directory …\Physibel\Voltra\Data). 

(In SECTRA: PilotexSectra.vtr – which is a 2D example, but analogous to the VOLTRA example 

treated here.) 

 

Construction 

The program example “Pilotex” from the TRISCO manual (data file Pilotex.trc) is taken as starting 

data for this program example of VOLTRA (with final version in PilotexVoltra.vtr). 

The TRISCO data can be entered into VOLTRA using the command File > Open…. 

Choose the file type: TRISCO Data Files (*.trc). 

Look in the directory …\Physibel\Voltra\Data. 

Then open Pilotex.trc. 

The screen shows a windows layout (with Image window, Grid window, Blocks window and 

Colours window) similar as in TRISCO. 

 

The Colours window (with thermal properties of materials and boundary conditions) shows two 

new columns for dynamic material properties: 

 material density ρ in kg/m3 

 specific heat c in J/(kg.K) 

The initial default values (1000 kg/m3 and 1000 J/(kg.K)) should be modified by the user to the true 

values as in the figure below. 

 

 
 

At the right border of the Colours window (not visible in the above figure; use the horizontal scroll 

bar) also three new columns are present for use of the solar processor (not relevant in this example). 

 

Dynamic boundary conditions 

The inside and outside temperatures are supposed to vary with time: 

 The outside temperature is a sine with mean value 0°C, amplitude 10°C, period 1 day and start at 

7 h. 

 The inside temperature also has a period of 1 day: 

a constant value of 20°C between 7 h and 19 h; 

a constant value of 10°C between 20 h and 6 h; 

linearly interpolated temperatures in the transition periods (from 6 h till 7 h, and from 19 h till 

20 h). 

Below are the graphic representations of both temperature functions (showing 2 days). 
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The function courses are defined in the Functions window (opened with Edit > Functions). 

Add the first function via the command Edit > Insert After. 

The function reference (2nd column) is initialised as “T01”, which is OK (the letter “T” refers to a 

temperature function; “01” is a sequence number). 

The function type must be modified into “SINE” (via several double clickings upon the cell, or 

pressing <Enter> when the cell is active).  Then enter the function parameters in the following 

columns (the specific meaning of each value is explained in the status bar) as in the figure below.  

All time parameters must be entered in minutes (e.g. 1 day = 24 h x 60 min/h =  1440 min). 

A graphic representation of the edited function is shown in the Function Graph window (cf. picture 

above left). 

Then add the second function via Edit > Insert After. 

The function reference “T02” is OK. 

The function type must be modified into “STEP2”, which is the generic name for the wanted 

periodic step function.  Enter the parameters according to their meaning as explained in the status 

bar.  (Note the same function can be defined using other parameters, exchanging level 1 and 2; the 

parameters are then: 20, 10, 1440, 720, 60, 420.) 

 

 
 

Function references 

The temperature fields of the inside and outside boundary conditions (i.e. colours 2 and 3) in the 

Colours window must be modified to refer to the just defined functions via the given function 

references (“T01” and “T02”). 
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The following calculation parameters are set in the Calculation Parameters dialog box 

(opened with Edit > Calc Parameters…): 

 Time step interval: 15 minutes. 

 Start-up calculation duration (to get “dynamic” start values): 0 seconds. 

 Calculation duration: 3 days. 

 Day number at start of calculation: 1 (i.e. the default value).  This item is only relevant when 

climatic data files (e.g. test reference years) are used. 

 

 
 

The calculation is started using the command Calc > Calc System.  The input data is saved 

automatically (under the name Pilotex.vtr).  During the calculation the temperature field of the 

previous calculated time step is shown in the Image window, and updated every new time step. 

 

At the end of the calculation the calculation results as in TRISCO are available for the last time 

step.  The graphic output can be found via Output > Graphic Output, the text output via Output > 

Text Output.  Intermediate time step solutions can be examined if the option “Save step solutions to 

disk” was enabled before starting the calculation, in the dialog box opened with Calc > Save 

Frequency….  Be careful that your PC disk has got enough free memory: every solution file has a 

file length of about 195 Kbytes (for the given input data).  If you save the solution files every time 

step, all solution files together take about 55 Mbytes.  When a set of solution files is saved on disk, 

also graphic animations can be produced.  An animation file PilotexVoltra.avi as created with 

VOLTRA is available on the distribution disk, and can be viewed using e.g. Microsoft Media 
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Player. 

 

In the Text Output window (result of Output > Text Output) a report table can be shown using the 

command View > Report Output, containing temperatures or other thermal properties in given 

locations at given time step intervals.  The report items are defined in the Report Definition 

window, opened in the main program menu via Edit > Report Definition.  Some report items may 

refer to output nodes as defined in the Output Nodes window (opened using Edit > Output Nodes), 

or to output blocks as defined in the Output Blocks window (opened using Edit > Output Blocks).  

The file PilotexVoltra.vtr contains a report definition, for which a text report can be produced (after 

calculation) at a given report frequency time interval space (defined in the dialog box opened with 

Calc > Report Frequency…). 

 

This example has given a quick tour around some input and output possibilities of VOLTRA.  Other 

example data files (containing other topics as e.g. ventilation flows) can be found in the data folder. 

B.2. VOLTRA start up 

When VOLTRA is launched, the parameter file Voltra.prm is read (if present) to load global 

program settings. 

Then the default data file Voltra.vtr is read (if present) to initialise material and surface boundary 

condition properties of the Colours window, which is useful to minimise the input for new data 

files. 

At installation Voltra.vtr is a copy of the template data file “template_general_v2015_vtr.vtr”. 

The files Voltra.prm and Voltra.vtr must be in the same directory of the program Voltra.exe 

(…\Physibel\Voltra). 

There is no visual feedback in the initial screen of VOLTRA to indicate that Voltra.prm and/or 

Voltra.vtr are loaded. 

B.3. The Functions window 

For the time dependent boundary conditions VOLTRA refers to time functions: either an internal 

function, or an external function. 

An internal time function is a built-in program function, defined by one or more parameters.  

VOLTRA contains 6 built-in functions, which are described further in this section. 

An external time function is defined in a separate data file, with extension: 

 .fte (temperature function) 

 .fht (surface heat transfer coefficient function) 

 .ffh (power function) 

 .fir (imposed flux function) 

 .fco (time dependent thermal conductivity function). 

 .fem (infrared emissivity function) 

 .ftr (solar transmission factor function) 

 .fsg (horizontal global solar radiation function) 

 .fsd (horizontal diffuse solar radiation function) 

 .fvr (ventilation function) 

The program FUNCEDIT (cf. Chapter F) allows to edit these files. 

 

Some material properties (thermal conductivity, specific heat, solar reflection factor) may be 

dependent on another property (temperature, angle of incidence). 

These temperature functions (thermal conductivity, specific heat) or angular functions (solar 

reflection factor) are defined in separate data files, with extension: 

 .fla (temperature dependent thermal conductivity function) 
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 .fce (temperature dependent specific heat function) 

 .frf (angular dependent solar reflection factor function). 

These function data files are text files consisting of two or more text lines: 

 

 x0  y0 

 x1  y1 

 x2  y2 

 … 

 xn  yn 

 

with x0 ≤ x1 ≤ x2 ≤ … ≤ xn. 

Each text line consists of two float numbers, the abscissa (i.e. a temperature value or an angle of 

incidence) and the ordinate (i.e. the corresponding thermal conductivity, specific heat value or solar 

reflection factor) of a characteristic point of the function.  The function is linearly interpolated 

between the characteristic points.  If x < x0, then y = y0.  If x > xn, then y = yn. 

The user can define these functions with a text editor (e.g. Windows Notepad). 

 

All functions that are used in a VOLTRA data file, are defined in the Functions window, opened 

with the command Edit > Functions. 

Each function is defined by: 

 

 A function reference name: 

C01 up to C99 for a specific heat function (in J/(kg.K)) *.fce 

 (temperature dependent) 

D01 up to D99 for a horizontal diffuse solar radiation function (in W/m2) *.fsd 

  (only D01 is used in the Solar Data dialog box) 

E01 up to E99 for an infrared emissivity function (dimensionless) *.fem 

G01 up to G99 for a horizontal global solar radiation function (in W/m2) *.fsg 

  (only G01 is used in the Solar Data dialog box) 

H01 up to H99 for a surface heat transfer coefficient function (in W/(m².K)) *.fht 

I01 up to I99 for an imposed flux function (in W/m2) *.fir 

L01 up to L99 for a thermal conductivity function (in W/(m.K)) *.fla 

  (temperature dependent) 

M01 up to M99 for a thermal conductivity function (in W/(m.K)) *.fco 

  (time dependent) 

P01 up to P99 for a power function (in W) *.ffh 

R01 up to R99 for a solar reflection factor function (dimensionless) *.frf 

 (angular dependent) 

S01 up to S99 for a solar transmission factor function (dimensionless) *.ftr 

T01 up to T99 for a temperature function (in °C) *.fte 

V01 up to V99 for a ventilation function (in m3/s) *.fvr 

Function reference names can be used in: 

the Colours window (columns with header λ, , c, θ, h, q, θa, hc, Pc, θr, ρs, s), 

the Node BCs window (columns with header θ and P), 

the Borderface BCs window (columns with header θ and q), 

the Material BCs window (column with header θ and p), 

the Ventilation Flows window (column with header “Flow”), 

the Controls window (columns with header “θ target”, “Function from”, “Function to”). 

 

 A function type: a toggle with values FILE, CONST, STEP0, STEP1, STEP2, SINE and 

SINPOS. 

Temperature functions (L## and C##) and solar reflection factor functions (R##) can only have 
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type FILE. 

 

FILE for a function defined in an external function file 

 

CONST for a constant function, defined by 1 parameter 

  (P1 = constant function value) 

 

STEP0 for a step function defined by 4 parameters (P1,P2,P3,P4) 

 
STEP1 for a step function defined by 5 parameters (P1, P2, P3, P4, P5) 
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STEP2 for a (periodic) step function defined by 6 parameters (P1, P2, …, P6) 

 
SINE for a sine function, defined by 4 parameters (P1, P2, P3, P4) 

 
SINPOS for a positive sine function, defined by 4 parameters (P1, P2, P3, P4) 

 
 A function filename for an external function file (i.e. of type FILE). 

When this field is double clicked (or when <Enter> is pressed), a file path can be chosen in the 

Open dialog box. 

It is recommended to store the external files in the same directory as the VOLTRA data file 
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(because then only the function file name is saved in the .vtr file, so that copying of the .vtr file 

together with the function files to another directory has the desired result that the new .vtr file 

refers to the function files in the same new data directory). 

 

 Function parameters for internal functions (of type CONST, STEP0, STEP1, STEP2, SINE or 

SINPOS).  The meaning of each parameter per function type is explained in the status bar (cf. 

also the figures above). 

 

A new function can be inserted via Edit > Insert Before or Edit > Insert After. 

The current function can be deleted via Edit > Delete. 

B.4. The Function Graph window 

The Function Graph window shows a graph of the current function in the Functions window. 

The Function Graph window is automatically opened when the Functions window is activated, and 

automatically closed when another window is activated (e.g. Grid window or Colours window). 

 

The first figure below shows the initial Function Graph window for a temperature function that 

refers to the external file UCL.FTE (test reference year with hourly temperatures for Uccle, 

Belgium). 

 

Zoom functions (via the Image submenu: Image > Pan, Image > Zoom Window, Image > Zoom In, 

Image > Zoom Out, Image > Zoom Total, Image > Previous View) are available to view function 

details.  The second figure below shows an example (fragment from UCL.FTE). 

 

The X and Y axis tic marks and labels can be redefined via the commands Functions > X Scale… 

and Functions > Y Scale….  The third and fourth figures below show the opened dialog boxes.  The 

quantities defined by the X axis (time, temperature, angle of incidence) and Y axis (temperature, 

flux, power, ventilation rate, lambda, infrared emissivity, specific heat, surface heat transfer 

coefficient, solar reflection factor, solar transmission factor) are determined by the current function 

in the Functions window. 

The origin of the X axis of a time function (i.e. time = 0) corresponds to the day number at the start 

of the calculation duration, as defined in the Calculation Parameters dialog box. 
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The scope of the time scale on the X axis can be chosen between fixed values, function scope 

(corresponding to the definition of the function) and calculation time (corresponding to the 

calculation duration as defined in the Calculation Parameters dialog box). 

When fixed values are chosen, the minimum and maximum value (with plus or minus sign), and the 

major and minor tick distances can be set.  Also the label unit can be chosen (seconds, minutes, 

hours or days). 

For the figure above (X axis: Time Scale), the time scope goes from day number –159 up to day 

number 206.  There is a major tick every 30 days, and a minor tick every 10 days.  The labels are 

expressed in days. 

 

 

B.5. The Colours window 

Compared to the Colours window in TRISCO the following differences occur in VOLTRA: 

 Two material properties concerning the thermal capacity are added: the material density ρ in 

kg/m3, and the specific heat c in J/(kg.K). 

These properties are also loaded when a material is selected from the material database (via 

Colours > Load Material…). 

 Three columns concerning solar radiation are added (at the right border): 

 Sun active status (YES or NO) for a colour of type BC_SIMPL or BC_SKY (to define a 

solar zone, cf. sections C.5 and C.7). 

 Solar reflection factor (for a colour of type MATERIAL): a constant value (between 0 and 1), 

or a function reference (R##) when the solar reflection factor is a function of the angle of 

incidence. 

 Solar transmission factor (for a colour of type MATERIAL): a constant value (between 0 and 

1), or a function reference (S##) when the solar reflection factor is a function of time. 

The solar transmission factor is applied after subtraction of reflection (which can be 

dependent on the angle of incidence). 
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 The properties λ, , c, θ, h, q, θa, hc, Pc, θr, ρs and s can refer to functions (defined in the 

Functions window) via function reference names. 

B.6. Node boundary conditions 

Node boundary conditions are edited in the Node BCs window, opened with Edit > Node BCs. 

New node boundary conditions are added using the command Edit > Insert Before or Edit > Insert 

After. 

The X,Y,Z position refers to a grid node. 

The boundary condition properties θ and P can be a numeric value (for a constant property) or can 

refer to a function (defined in the Functions window) via the function reference name.  

 

 

B.7. Border face boundary conditions 

In the border face between two different colours (identified by their colour numbers) user-defined 

temperatures or heat fluxes (as constant values or functions of time) can be imposed.  These border 

face boundary conditions are edited in the Borderface BCs window, opened with Edit > Borderface 

BCs.  A new border face boundary condition is added via Edit > Insert After. 

The type can be “TEMP” (known temperature) or “FLUX” (known heat flux). 

The boundary condition properties θ and q can refer to functions (defined in the Functions window) 

via function reference names (respectively T## and I##, with ## a number from 01 to 99). 

 

 

B.8. Material boundary conditions 

The volume occupied by a material (identified by the corresponding colour number) can have a 

given temperature or power density.  Such a material boundary condition is defined in the Material 

BCs window, opened with Edit > Material BCs. 

A new material boundary condition is added via Edit > Insert After. 

The type is either “TEMP” (known temperature) or “POWER” (known heat power density). 

The temperature θ and power density p can be a constant numeric value or a function reference 

(defined in the Functions window, respectively T## and P##, with ## a number between 01 and 99).  

A power density function refers to a power function (defined as .ffh file with unit W), but the unit 

should be read as W/m3. 
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B.9. Unlinked air temperatures in air cavities of type BC_FRE_S or BC_FREE 

An air cavity can be modelled using several (adjacent) blocks having different colours.  These 

colours can have different thermal properties (e.g. surface heat transfer coefficient), but must be of 

the same type (i.e. all BC_FRE_S or all BC_FREE).  Otherwise the calculation is immediately 

stopped, showing the error message “BC (colour …) touches other BC of different type”. 

 

Suppose the air cavity is modelled with colours all of type BC_FRE_S.  Then all colours get the 

same (unknown) environmental temperature, which is calculated solving the system.  Possible 

convective heat powers for the individual colours in the same air cavity (column Pc in the Colours 

window) are added up and allocated to the central convection node (having the unique 

environmental temperature). 

 

Suppose the air cavity is modelled with colours all of type BC_FREE (only possible with the 

RADCON module).  The radiative heat transfer is calculated taking together all these colours 

forming one global zone in which all view factors are calculated.  The convective heat transfer is 

calculated with reference to one central convection node (having an unknown air temperature). 

 

This default behaviour can be changed.  An air cavity can contain more than 1 convection node by 

using several colours in that cavity and unlinking those colours.  For each unlinked colour and for 

the remaining block of not unlinked colours in the same air cavity a separate convection 

temperature will be calculated using separate convective heat balances (based on the one hand on 

the surface temperatures of the adjacent material surfaces and the corresponding convective heat 

transfer coefficients, and on the other hand on the convective heat powers related to the colours).  

The radiative heat balance (in case of BC_FREE cavity) remains unchanged, i.e. considering the 

global air cavity in which all view factors are determined. 

 

A colour is made unlinked manually by adding per colour (that you want to unlink) a text line at the 

end of the VOLTRA data file (with extension .vtr) using a text editor (e.g. Windows Notepad).  The 

syntax of this line is: 

 

unlk=c 

 

where c = colour number (0..255) for unlinked colour. 

 

When considering ventilation flows through different air zones (cf. section B.10), the air 

temperatures of these zones are automatically made unlinked. 

B.10. Ventilation flows 

Ventilation flow paths can be defined in the Ventilation Flows window, opened with Edit > 

Ventilation Flows.  Add new ventilation flows with the command Edit > Insert After. 
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For each ventilation flow definition line a ventilation source and ventilation destination must be 

entered.  Both are identified by colour numbers to the corresponding boundary conditions. 

The ventilation source (in the column with header “From Col. 1”) can be any type of boundary 

condition (BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY or BC_NOSKY).  The ventilation 

destination (in the column with header “To Col. 2”) must be a boundary condition of type 

BC_FRE_S or BC_FREE. 

The ventilation flow (last column) is a constant value or a reference to a ventilation function (V##) 

as defined in the Functions window. 

The user should take care that all defined ventilation flows refer to a realistic ventilation scheme.  A 

ventilation path can originate from an outside environment, pass through some internal zones and 

leave to another outside environment.  But a ventilation path can also pass through a closed circuit 

of only internal zones. 

 

All air cavities of type BC_FRE_S and BC_FREE that occur as ventilation source or ventilation 

destination in the Ventilation Flows window are automatically unlinked without the need of explicit 

definition as explained in section B.9. 

B.11. Calculation parameters 

The Calculation Parameters dialog box is opened with Edit > Calc Parameters.  Compared to 

TRISCO some new parameters concerning the time dimension occur: 

 Time step: this is the time distance between two successive dynamic system calculations.  

(About the time format: days, hours, minutes and seconds are separated by colons.) 

 Start-up calculation duration: this is the time duration before the actual start of the calculation 

(where reporting starts) with the purpose to get good dynamic start values. 

The boundary condition values of time-dependent functions are taken before the time origin of 

those functions, so that the actual calculation (at the end of the start-up calculation duration) 

starts at time 0.  Internal functions which are not periodic (i.e. functions of type STEP0 and 

STEP1), get the function value at time 0 during the entire start-up calculation duration.  Periodic 

functions are extended for negative time values with the same periodic function course.  For 

external functions the “previous function” is taken, as defined in the function editor FUNCEDIT 

(cf. Chapter F). 

 Calculation duration: duration of the dynamic calculation during which time step results and 

report items can be saved (e.g. to produce a graphic animation).  The calculation start is always 

at time 0000:00:00:00 (i.e. 0 days, 0 hours, 0 minutes, 0 seconds). 

 Day number at start of calculation: number (between 1 and 365) to indicate the day in the year 

where the calculation starts.  This is important when the used (external) function is related to a 

calendar date: e.g. a test reference year, with hourly climatic data of a typical year in a given 

location.  The start date of the external function may be different from the start date of the 

calculation. 

The button “i” near the input field gives, when pressed, the day numbers for the first day of each 

month. 
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The other calculation parameters in the Calculation Parameters dialog box are valid for each time 

step calculation, and are explained in the TRISCO manual. 

The given number of iteration cycles is only applied for the first time step (i.e. solution of the initial 

steady-state system, cf. section C.2).  If the initial temperature differences are rather high, the 

number of iteration cycles should also be high (to get reliable start values of temperature dependent 

thermal properties). 

For the next time steps (when no ventilation flows are active) the number of iteration cycles is 

always automatically reset to 1 (independent of the given number of iteration cycles in the 

Calculation Parameters dialog box). 

B.12. Solar data 

When the effect of solar radiation on an object model must be calculated, some additional input 

parameters must be defined in the Solar Data dialog box (Edit > Solar Data…). 

 

The parameters are: 

 North orientation: three consecutive rotations define the position of the horizontal coordinate 

system XYZ, with new XY plane equal to the local horizon plane, new X axis pointing to the 

north, new Y axis pointing to the west and new Z axis pointing to the zenith. 

 The first rotation is around the Z axis, so that the new X axis is parallel to the local horizon 

plane. 

 The second rotation is around the X axis, so that the new XY plane is parallel to the local 

horizon plane (and new Z axis points to the zenith). 

 The third rotation is around the Z axis, so that the new X axis points to the north (and new Y 

axis points to the west). 

 Geographical location: latitude (°N), longitude (°E) and time zone (h E). 

The input fields are disabled when these parameters are present in the climate files (with 

extension .fsg or .fsd) containing solar radiaton data, defined in the Functions window (G01 and 

D01).  The geographical coordinates are then loaded from the solar radiation climate file (.fsg or 

.fsd). 

 Solar radiation functions: the function reference names of horiziontal direct and diffuse solar 

radiation functions are always G01 and D01.  The solar radiation functions must be defined in 

the Functions window. 

 Ground reflection factor: reflection factor of (horizontal) ground surface around the object 

model.  The reflected solar radiation is projected on the external object surfaces using an 

isotropic diffuse model. 

The input value must be between 0 and 1.  A normal value is 0.2.  For very reflective grounds a 

higher value can be used (e.g. snow: 0.8). 
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B.13. Show north orientation 

Toggle command: Image > Show North 

Above the object the horizontal plane is shown as a light blue disk (from the top side) or a dark blue 

disk (from the underside). 

The red axis points to the north, the green axis points to the west, the blue axis points to the zenith. 

The sun paths are shown for winter solstice (21 December), vernal equinox (20 March) and summer 

solstice (21 June). 

To hide the north orientation, call Image > Show North again. 

B.14. Sun obstacles 

Sun obstacles around the object are defined in the Sun Obstacles window, opened with Edit > Sun 

Obstacles.  Each sun obstacle is a spherical rectangle defined by azimuth and altitude coordinates, 

on the sky hemisphere within which the sun is invisible. 

The azimuth and altitude coordinates are defined in the horizontal coordinate system (cf. Image > 

Show North). 

Each sun obstacle is defined by four parameters: minimum and maximum azimuth (clockwise angle 

between –180° and 180°, 0° = south, 90° = west) in the plane of the local horizon (containing the 

north direction), and minimum and maximum altitude (between 0° at the horizon and 90° at the 

zenith). 
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By default one sun obstacle (defined by a zone up to 5° high above the horizon in all directions 

around) is present for each new VOLTRA file (cf. figure above right). 

A new sun obstacle is added using Edit > Insert Row. 

A sun obstacle is deleted using Edit > Delete Row. 

B.15. Controls 

A control is a method to steer the thermal system, based on a sensor temperature which should 

follow a time dependent target temperature by heating or cooling, obtained by replacing a boundary 

condition or material property function (used in the Colours window, Node BCs window, 

Borderface BCs window, Material BCs window or Ventilation Flows window) with another 

function (of the same type).  In this way e.g. a higher power or ventilation flow can be imposed, to 

achieve better the goal of the control. 

Controls are defined in the Controls window, opened with the command Edit > Controls. 

A new control can be added with Edit > Insert Before or Edit > Insert After, and deleted with 

Edit > Delete. 

 

 
 

A control is defined by the following elements (corresponding to the different columns): 

 Sensor node, where at each calculation time step the temperature is compared to the desired 

target temperature.  The sensor node is defined by the reference number of an output node in the 

Output Nodes window (cf. section B.16). 

 Target temperature: function reference of a temperature function (T01up to T99) defined in the 

Functions window (cf. section B.3). 

 Thermostat sensitivity upward [°C]: 

While a heating control is active, a necessary condition to switch off the control is that the sensor 

temperature is greater than the target temperature plus the upward sensitivity. 

While a cooling control is not active, a necessary condition to switch on the control is that the 

sensor temperature is greater than the target temperature plus the upward sensitivity. 

 Thermostat sensitivity downward [°C]: 

While a heating control is not active, a necessary condition to switch on the control is that the 

sensor temperature is less than the target temperature minus the downward sensitivity. 

While a cooling control is active, a necessary condition to switch off the control is that the sensor 

temperature is less than the target temperature minus the downward sensitivity. 

 Purpose: a control can be intended for either heating or cooling. 

 Minimum time on: minimum duration that the control must continously remain switched on. 

 Minimum time off: minimum duration that the control must continously remain switched off. 

 Function from: function reference (E##, H##, I##, M##, P##, R##, S##, T## or V##, with ## = 

01 up to 99) to a function defined in the Functions window and referred to in the Colours 
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window, Node BCs window, Borderface BCs window, Material BCs window or Ventilation 

Flows window. 

The “function from” is valid when the control is switched off. 

 Function to: function reference (E##, H##, I##, M##, P##, R##, S##, T## or V##, with ## = 01 

up to 99) to a function defined in the Functions window, which must replace the “function from” 

while the control is switched on. 

The “function from” and “function to” must both be of the same type (i.e. both function 

references must begin with the same letter). 

 Test : test the temperature difference between two zones (of a ventilation path), which must be 

greater than a minimum required temperature difference, as (additional) condition to switch on a 

ventilation control (for which “function from” and “function to” start with the letter V). 

 Minimum required temperature difference [°C] between two zones (of a ventilation path). 

 Source zone (or zone 1) for temperature difference test, which is defined by its colour number 

(between 0 and 255) in the Colours window. 

 Destination zone (or zone 2) for temperature difference test, which is defined by its colour 

number (between 0 and 255) in the Colours window. 

B.16. Output Nodes 

Output nodes are points to which reference is made in a report text output (cf. section E.4) to show 

the course of temperatures in those points as a function of time. 

Output nodes can also be used as sensor points in controls (cf. section B.15). 

Output nodes are defined in the Output Nodes window, opened with the command Edit > Output 

Nodes.  The definition of an output node consists of a sequence number and the point coordinates 

(X,Y,Z or R,C,L depending on the active coordinate system).  The position of the current output 

node is represented in the Image window by the intersection of three lines parallel to the coordinate 

axes (coloured red, green and blue). 

Output nodes can be inserted (using Edit > Insert Before or Edit > Insert After) and deleted (using 

Edit > Delete). 

 

 

B.17. Output Blocks 

Output blocks can be used in a report text output (cf. section B.18) to show the course of incoming 

heat flows (in W) through conduction through the boundary faces of those output blocks.  The heat 

flows by radiation or convection are not taken into account.  So only the intersection parts of the 

boundary faces of an output block with the object material is important. 

Output blocks are defined in the Output Blocks window, opened with the command Edit > Output 

Blocks.  A new output block can be added using Edit > Insert Before or Edit > Insert After.  The 

definition of an output block consists of a sequence number and 6 coordinates. 
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The boundary faces of an output block always lie in between the grid coordinates as defined in the 

Grid window.  In this way the boundary faces can be broken down in elementary boundary faces of 

control volumes around material nodes, through which the energy flows through conduction can 

easily be calculated. 

In the RCL coordinate system the coordinates of output blocks are represented by even numbers 

(0,2,4,…). 

In the XYZ coordinate system an output block coordinate ends with .5 to indicate that its position is 

halfway between two consecutive grid locations (as defined in the Grid window).  

The outline of the current output block is shown in the Image window. 

Object clipping (with Edit > Clip Object) has no effect on the calculation of heat flows into the 

output blocks; it has only a visual effect in the Image window. 

 

Remarks for users of SECTRA and VOLTRA up to version 2. 

1. The concept of output blocks replaces the concepts of line and plane definitions. 

2. Line and plane definitions of an old SECTRA or VOLTRA file 

are skipped when such a file is imported using File > Import Data…. 

 

B.18. Report Definition 

The contents of a report in the Text Output window (first select Output > Text Output, then View > 

Report Output) after a calculation has been executed, is determined by the report definition (treated 

in this section) and the report frequency (cf. section B.19). 

The input of the report definition is done in the Report Definition window, opened with the 

command Edit > Report Definition. 

The report definition consists of several report items, one per line in the Report Definition window. 

A new report item is added via Edit > Insert Before or Edit > Insert After. 

A report item can be deleted using Edit > Delete. 

During the generation of a report in the Text Output window, a report line is written per report step 

(which equals the calculation time step or a multiple of it, as defined by the report frequency). 

The report line consists of the actual values of the report items (separated by tabs) at the current 

time step. 
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A report item is defined by the following elements (corresponding to the different columns): 

 Object: a toggle with values TIME, COLOUR, NODE BC, BORDER BC, MATERIAL BC, 

OUTPUT NODE, OUTPUT BLOCK, CONTROL, SUN. 

 Object Number, which meaning is dependent on the selected object: 

TIME: not applicable. 

COLOUR: colour number (cf. first column in Colours window). 

NODE BC: node boundary condition number (cf. first column in Node BCs window). 

BORDER BC: border face boundary condition number (cf. first column in Borderface BCs 

window). 

MATERIAL BC: material boundary condition number (cf. first column in Material BCs 

window). 

OUTPUT NODE: output node number (cf. first column in Output Nodes window). 

OUTPUT BLOCK: output block number (cf. first column in Output Blocks window). 

CONTROL: control number (cf. first column in Controls window). 

SUN: not applicable. 

 Type, a toggle with values dependent on the selected object: 

TIME [s] time in seconds of the current time step 

  [dddd:hh:mm:ss] 

   time in days, hours, minutes and seconds of the current time step 

COLOUR λeq equivalent thermal conductivity [W/(m.K)] 

   (for colour of type EQUIMAT) 

  θ boundary condition temperature [°C] 

   (for colour of type BC_SIMPL or BC_FRE_S) 

  h total surface heat transfer coefficient [W/(m2.K)] 

  (for colour of type BC_SIMPL or BC_FRE_S) 

  q boundary condition heat flux [W/m2] 

  (for colour of type BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY or 

   BC_NOSKY) 

  θa boundary condition air temperature [°C] 

  (for colour of type BC_FREE, BC_SKY or BC_NOSKY) 

  hc convective heat transfer coefficient [W/(m2.K)] 

  (for colour of type BC_FREE, BC_SKY or BC_NOSKY) 

  Pc convective power into air cavity [W] 

  (for colour of type BC_FREE or BC_FRE_S) 

  θr boundary condition radiation temperature [°C] 

   (for colour of type BC_SKY) 

  Qin heat flow from boundary condition into object [W] 

  (for colour of type BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY, 

   BC_NOSKY or TRANSMAT) 

  Qout heat flow out of object into boundary condition [W] 

  (for colour of type BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY, 

   BC_NOSKY or TRANSMAT) 

  qsol Xmin 
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   (area weighted average) absorbed solar flux on all faces oriented to 

   Xmin (including faces that do not receive any solar radiation) [W/m2] 

   (for colour of type MATERIAL or EQUIMAT) 

 qsol Xmax 

  (area weighted average) absorbed solar flux on all faces oriented to 

   Xmax (including faces that do not receive any solar radiation) [W/m2] 

   (for colour of type MATERIAL or EQUIMAT) 

 qsol Ymin 

  (area weighted average) absorbed solar flux on all faces oriented to 

   Ymin (including faces that do not receive any solar radiation) [W/m2] 

   (for colour of type MATERIAL or EQUIMAT) 

 qsol Ymax 

  (area weighted average) absorbed solar flux on all faces oriented to 

   Ymax (including faces that do not receive any solar radiation) [W/m2] 

   (for colour of type MATERIAL or EQUIMAT) 

 qsol Zmin 

  (area weighted average) absorbed solar flux on all faces oriented to 

   Zmin (including faces that do not receive any solar radiation) [W/m2] 

   (for colour of type MATERIAL or EQUIMAT) 

 qsol Zmax 

  (area weighted average) absorbed solar flux on all faces oriented to 

   Zmax (including faces that do not receive any solar radiation) [W/m2] 

   (for colour of type MATERIAL or EQUIMAT) 

NODE BC θ temperature [°C] 

  P power [W] 

BORDER BC θ temperature [°C] 

  q heat flux [W/m²] 

MATERIAL BC θ temperature [°C] 

 p power density [W/m3] 

OUTPUT NODE θ temperature [°C] 

OUTPUT BLOCK P heat flow through conduction into output block [W] 

CONTROL ON control on/off status (0=off, 1=on) 

SUN AZIMUTH   sun azimuth [°] (0:south, 90:west, -90:east) 

  ALTITUDE   sun altitude [°] (0:horizon, 90:zenith) 

 Width: (minimum) number of characters for formatting the output values in the output report 

 Decimals: number of digits after the decimal point, to which the output values are rounded. 

 

If a report item definition is logically impossible, this item is skipped in the output report. 

B.19. Report Frequency 

A report line in the report output is written for every time step or every fixed number of time steps.  

This number is set, before the calculation is started, in the Report Frequency dialog box, opened 

with the command Calc > Report Frequency…. 

When a calculation is started, the amount of memory is allocated to save the report records during 

the calculation.  At the end of the calculation the report records are all available in memory and can 

be output in the Text Output window.  The report records are lost from memory when the active 

VOLTRA document is closed. 
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B.20. Save Frequency 

During a calculation intermediate solutions (i.e. the calculated temperatures in all calculation nodes, 

calculated heat fluxes using RADCON, absorbed solar fluxes) at a fixed number of time steps can 

be saved to disk to use later in graphic output or text output (to view the solutions at those time 

steps). 

The save frequency must be set, before the calculation is started, in the Save Frequency dialog box, 

opened with the command Calc > Save Frequency…. 

 

 
 

The solutions are saved in .sol files, .flx files and .sfx files with the same file name of the .vtr input 

data file appended with a 4-digit serial number.  For example if the input data file is 

PilotexVoltra.vtr, then the solution files are PilotexVoltra0001.sol, PilotexVoltra0002.sol, 

PilotexVoltra0003.sol etc. 

The format of the .sol and .flx files is identical to that of the TRISCO solution files. 

B.21. Importing data 

The command File > Import Data… allows to create a new VOLTRA data file starting from a 

BISTRA data file, a BISCO data file, a bitmap or an old VOLTRA & SECTRA data file format. 

Choose the wanted file type in the File Open dialog box. 

 

When a BISTRA data file (with extension .bst) is imported, the north orientation must be redefined 

in VOLTRA (i.e. azimuth and altitude of north direction in the Solar Data dialog box, opened with 

Edit > Solar Data…).  Also the report definition must be redefined (Edit > Report Definition). 

 

Remarks when importing an old VOLTRA & SECTRA data file (with extension .dat, created using 

VOLTRA/SECTRA version 1 or 2 in MS-DOS): 

 The directory of function files is not known (because directory paths are not read any more from 

Voltra.prm), although the right file names (without directory) are shown in the Functions 

window.  Install the right directory by editing the function name of external files (press <Enter> 

or double click on the Filename cell in the Functions window) and selecting the correct file path 

in the Open dialog box. 

 Always check the surface boundary conditions.  The surface boundary conditions of old 

SECTRA data files are not imported, because their definition is not compatible with the 

definition in the new version. 

 Node definitions, line and plane definitions, alphanumeric and graphic output definitions are not 

imported. 
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CHAPTER C SYSTEM CALCULATION 

C.1. Start calculation 

After the input of data is finished, a calculation can be started with the command Calc > Calc 

System.  First the view factors are calculated (if required, as in TRISCO).  During the system 

calculation a monitor is shown containing the current time step, the iteration parameters (as in 

TRISCO) for the current time step, the number of system nodes and the number of calculated view 

factors. 

After completion of each time step the Image window is updated showing the temperatures of the 

last time step.  If necessary the temperature range scale can be modified (before the calculation is 

started) in the Graphic Output window (Output > Graphic Output) using the command Settings > 

Temperature Range…. 

 

 
 

If there is a start-up calculation requested, first the start-up time steps are shown (from time 

0000:00:00:00 up to the total start-up duration).  Neither reporting nor solution saving is done 

during the start-up duration.  After finishing the start-up calculation, the normal calculation duration 

commences.  The time steps of the normal calculation duration are shown again starting from time 

0000:00:00:00.  During the normal calculation, reporting and solution saving are possible. 

 

During the calculation a report file is written, when at least 1 report item is defined in the Report 

Definition window (cf. section B.18).  The content is the same as in the Report output (cf. section 

E.4).  The report file has the same file name as the data file, and has the extension .txt. 

 

A calculation can be interrupted at any time by pressing the <Esc>-key.  The calculation results of 

the last executed time step can be examined in the Graphics Output window and Text Output 

window.  If the “Save step solutions to disk” option is enabled in the Save Frequency dialog box 

(cf. section B.20), the solution files up to the last calculated time step are present.  If a report 

definition is given (cf. section B.18), the report records up to the last calculated time step can be 

viewed in the Text Output window. 

 

If a calculation is restarted after it has been interrupted, the calculation restarts from the very 

beginning without reuse of the already calculated time step solutions. 
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C.2. Calculation principles 

For the first time step (of the start-up calculation duration if requested, else of the normal 

calculation duration) a steady-state system (as in TRISCO) based on the boundary condition 

function values evaluated at the initial time is set up and solved.  Multiple iteration cycles (as 

defined as calculation parameter) are used to get good initial temperature dependent properties.  If 

the initial temperature differences of the steady-state system are high, the number of iteration cycles 

should also be high (so that the temperature dependent thermal properties converge to stable 

values). 

If a start solution (defined as .sol file) should be adopted at the first time step, this solution should 

be renamed to the fixed file name StartVoltra.sol in the directory of the .vtr input data file. 

The start solution is only used if this solution is compatible with the input data (i.e. same number of 

nodes, same number of object nodes, same number of blocks, same number of node boundary 

conditions). 

Delete the file StartVoltra.sol after the calculation, otherwise it will be reused as start solution (if 

compatible with the input data) in all following calculations. 

 

For the next time steps the boundary condition function values are updated and the material volume 

capacity is taken into account.  The Cranck-Nicolson finite difference method is used to formulate 

the energy balance for all control volumes around material nodes.  For all other nodes without 

capacity (e.g. black surface nodes, radiation nodes of a boundary condition) the energy balance at 

the current time step is formulated. 

Only 1 iteration cycle per next time step is considered (except when ventilation flows are treated), 

even if the calculation parameter “number of iteration cycles” has a higher value.  This supposes 

fluent boundary condition changes (no abrupt discontinuities) during the calculation period. 

 

When the thermal conductivity and/or specific heat of some materials are defined as temperature 

dependent functions, those properties are adapted before each new iteration cycle (of the steady-

state system for the first time step) and each next iteration step based on the obtained temperatures 

in the previous iteration cycle or previous time step. 

 

CEN-values are recalculated (if required by the corresponding setting in the Calculation Parameters 

dialog box) before each iteration cycle or time step, and can be reported in the output report (see 

variables of type λeq and hc in the report definition; cf. section B.18), but the initial values in the 

Colours window are not updated (as opposed to what happens in TRISCO). 

C.3. Processing ventilation flows 

When ventilation flows are present in the input data, the system matrix is not symmetrical any 

longer, and therefore each iteration cycle is split in two successive subtasks: 

 First the solution of a small subsystem of only convection nodes into which ventilation flows 

arrive.  The number of these ventilation nodes is always less than or equal to the number of 

colours of type BC_FRE_S or BC_FREE (so  256).  The surface temperatures that affect the 

convection nodes are considered as fixed boundary condition values (as obtained by the solution 

of the second subtask). 

The ventilation subsystem has an unsymmetrical system matrix, but has a limited number of 

unknowns (i.e. the temperatures of the ventilation nodes), and is solved using a direct solution 

method. 

 Second the solution of the ventilation replaced system, i.e. the whole system in which the 

calculated temperatures of the ventilation nodes are considered as fixed boundary conditions.  

This system has a symmetrical system matrix, and can be solved using an optimised iterative 

method. 
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The calculated surface temperatures adjacent to ventilation zones are taken as fixed boundary 

condition values in the next ventilation subsystem to solve (cf. first subtask). 

 

In the very first iteration cycle (i.e. of the first time step) no initial values of the surface 

temperatures are known (as required by the first subtask).  Then the complete system is solved 

without any ventilation flows to get start values for the surface temperatures for the first subtask of 

the next iteration cycle. 

 

When ventilation flows are present, a variable number of iteration cycles is executed per iteration 

step independent of the given maximum number of iteration cycles as defined in the Calculation 

Parameters dialog box.  The number of iteration cycles per iteration step is automatically stopped 

when all temperature differences between the calculated temperatures in the ventilation nodes of the 

current and previous iteration cycle are smaller than the given maximum temperature difference in 

the Calculation Parameters dialog box (a typical value is 0.0001°C).  However it may be possible 

(dependent on the input data) that there will be no convergence.  For this case the iteration cycles 

are also stopped when any temperature difference of a ventilation node between the current and 

previous iteration cycle is greater than 1000000°C.  Then the program resets all node temperatures 

of the whole system to 0°C, so that the user can see the solution of the system has failed, and that he 

should inspect and alter the input data. 

 

The following error messages may occur when doing a calculation: 

 “Syntax error in ventilation flow N”: 

The ventilation flow in the Ventilation Flows window at line N contains a syntax error. 

Either the ventilation source is not a boundary condition (i.e. a colour of type BC_SIMPL, 

BC_FRE_S, BC_FREE, BC_SKY or BC_NOSKY), or the ventilation destination is not a 

boundary condition of type BC_FRE_S or BC_FREE. 

 “Error in ventilation system”: 

The combination of all ventilation flows as defined in the Ventilation Flows window does not 

correspond to a physically correct ventilation system.  This error occurs when the ventilation 

system has not a unique solution (undetermined system). 

C.4. Calculation of solar fluxes 

Menu command: Calc > Calc Solar Fluxes 

 

This command is enabled when a solar zone is present in the input data.  This is a colour of type 

BC_SIMPL or BC_SKY with sun toggle set to YES. 

 

Before executing this command be sure to define a text report (cf. section B.18), the report 

frequency (cf. section B.19) and/or the save frequency (cf. section B.20), otherwise no results of 

calculated solar fluxes are saved for text output (cf. section E.4) and/or graphic output (cf. section 

D.8). 

  

First the view factors are calculated, if not yet present. 

It is recommended to calculate first the view factors using a coarser grid, so that the number of view 

factors will be lower.  Simplify the grid, and execute Calc > Calc View Factors.  Then refine the 

grid, and start Calc > Calc Solar Fluxes.  A prompt appears with the question “Recalculate view 

factors ?”.  Answer “No”.  Then it follows that the distribution of diffuse radiation and diffuse 

reflection will be much faster (cf. section C.9). 

Note that the syntax of the created view factor file (with extension .vwf) from VOLTRA v6.0w is 

modified against the format of the .vwf file of previous versions of VOLTRA. 
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The solar fluxes are calculated upon all surfaces exposed to the sun.  This includes direct solar 

radiation as well as diffuse solar radiation.  Also (direct and diffuse) solar radiation through 

transparent walls (glazings) is calculated.  The calculation process is explained in detail in the next 

sections (cf. sections C.5 - C.9). 

 

When solar flux records are defined the Report Definition window (e.g. “qsol Xmin”) these results  

are saved in memory every N1 time steps (as defined in the Report Frequency dialog box) of the 

calculation duration (as defined in the Calculation Parameters dialog box), ready for use in the Text 

Output window (cf. section E.4). 

The absorbed solar fluxes are saved every N2 time steps (as defined in the Save Frequency dialog 

box) of the calculation duration in the files with extension .sfx.  Also a header file with extension 

.sfd is created.  These files are loaded when viewing absorbed solar fluxes in the Graphic Output 

window (cf. section D.8). 

 

A system calculation (Calc > Calc System) includes automatically the solar fluxes calculation, 

when required.  The absorbed solar fluxes on each surface are converted to node powers, which are 

used as additional boundary conditions of the thermal problem.  The absorbed solar flux on a 

surface node of a transparent material is uniformly distributed over the system nodes on the grid 

line perpendicular to the surface inside the material (i.e. mass absorption).  The conversion to node 

powers is also further treated in sections C.6 - C.9. 

 

The absorbed solar fluxes on each elementary surface are saved per time step in a file with 

extension .sfx.  Global header information is saved at the start of the calculation in a file with 

extension .sfd.  These files are read from the Text Output window and Graphic Output window 

when needed. 

C.5. Solar processor input data 

The solar processor is activated when: 

1. A solar zone is present: i.e. a colour of type BC_SIMPL or BC_SKY with sun flag activated 

(defined in Colours window, column “Sun”, toggle value set to YES). 

2. Solar radiation data are present: both a function G01 and a function D01 must be defined in the 

Functions window. 

G01 refers to a climate file with extension .fsg, containing the global solar radiation (in W/m2) 

on a horizontal surface. 

D01 refers to a climate file with extension .fsd, containing the diffuse solar radiation (in W/m2) 

on a horizontal surface. 

The climate files .fsg and .fsd are the same as those used in CAPSOL and BISTRA. 

Climate files are available for different locations in the world (e.g. European Test Reference 

Years).  The function data can be viewed (in the Function Graph window) and edited (using the 

program Funcedit.exe in the directory …\Physibel\Voltra, see Chapter F). 

 

Input parameters with respect to the solar processor: 

 North orientation in the geometric model. 

The position of the horizontal coordinate system (with axes pointing to the north, west and 

zenith) with respect to the object coordinate system must be defined (Edit > Solar Data…, cf. 

section B.12). 

 Geographic position of the object model, defined by north latitude (°N), eastern longitude (°E) 

and time zone (h E) (Edit > Solar Data…, cf. section B.12). 

 Ground reflection factor (Edit > Solar Data…, cf. section B.12). 

 Per material: solar reflection factor (may be dependent on the angle of incidence, defined by a 

solar reflection factor function in the Functions window) and solar transmission factor (equals 0 
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for a nontransparent material). 

These material properties are defined in the Colours window (last two columns). 

A solar reflection factor function is referenced by R##, with ## = 01 to 99, and refers to the 

Functions window. 

 Year day number (between 1 and 365) of the start of a calculation period (Edit > Calc 

Parameters…, cf. section B.11).  A calculation period always starts at midnight (= 0 h) of this 

day, but may be preceded by a pre-calculation period (to get dynamic start values of the node 

temperatures). 

 Sun obstacles: shadow zones defined by angular coordinates in the sky hemisphere (Edit > Sun 

Obstacles, cf. section B.13). 

 

At every time step the solar load on the object model is calculated.  The solar load is expressed as a 

calculated node power per system node.  These node powers are used as supplementary boundary 

conditions of the system besides other boundary conditions (e.g. the external temperature). 

C.6. Solar transmission factor in VOLTRA 

The solar transmission factor  in VOLTRA is applied after subtraction of the solar reflection 

(which can be dependent on the angle of incidence of solar radiation, when a solar reflection 

function is used). 

Normally (out of the scope of VOLTRA) the solar reflection, transmission and absorption are 

defined for solar radiation at normal incidence (angle of incidence = 0°): 0, 0, 0, with 

0 + 0 + 0 = 1. 

 

After subtraction of reflection (as for the input value of  in VOLTRA):  +  = 1. 

 

The input value of  in VOLTRA can be calculated from 0 and 0: 

  )1( 00     or    
0

0

1 





 . 

 

Suppose for an angle of incidence of e.g. 30° that the solar reflection factor 30 is known from a 

solar reflection function as defined in the Functions window. 

Then the actual solar transmission factor 30 and solar absorption factor 30 can be calculated from 

the constant value of  as input in VOLTRA: 

  )1( 3030  

)1()1( 3030        or     303030 1    

C.7. Solar load to external surfaces 

An external surface is a surface of an object (with colour type MATERIAL) in direct contact with a 

solar zone (colour type BC_SIMPL or BC_SKY, and sun flag set in the Colours window). 

 

The position of the sun is calculated out of the time of the current time step (day of year, clock time) 

and the geographical location (latitude, longitude, time zone).  Summer time is not taken into 

account.  The position of the sun is located by two angular measures: azimuth (horizontal clockwise 

angle between the sun position and south) and altitude (angle between the sun position and the 

horizon).  The azimuth of the sun at a fixed clock time may differ for different days of the year due 

to the irregular movement of the sun (defined by the equation of time): e.g. the azimuth at 12 a.m. 

solar mean time fluctuates around 0° (= south direction). 
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For the current time step the actual global solar radiation and diffuse solar radiation (in W/m2) on 

a horizontal surface are derived from the corresponding climate data files.  Normally these climate 

files contain hourly values.  The current values are derived through linear interpolation from the 

closest hourly values.  For the first and last daylight hour of the day, the (estimated) times of sunrise 

and sunset are considered. 

The user should verify the precise definition of the hourly values in the solar radiation climate data 

files.  Just after sunrise or just before sunset the global (and diffuse) solar radiation should be small 

enough.  We found that the files UCL.FSG and UCL.FSD, derived from the European Test 

Reference Year (weather data set for computer simulations of solar energy systems and energy 

consumption in buildings) for Uccle (Brussels, Belgium), issued by the Commission of the 

European Communities in 1985, should be corrected.  The new files UCL_C1.FTE, UCL_C1.FSG 

and UCL_C1.FSD are based on solar mean time values. 

 

For each external surface the angular position against the north direction is computed: orientation 

(compass direction) and tilt (height above horizon).  From the global and diffuse solar radiation on a 

horizontal surface, the direct and diffuse solar irradiation on the area around each node of the 

external surface is calculated.  A partition of the surface area is made into elementary areas around 

the nodes on the surface (defined by the calculation grid, as input in the Grid window).  The 

elementary areas are separated by the perpendicular bisectors of the line segments between the node 

and its neighbouring nodes. 

The direct solar irradiation is derived from the direct solar radiation on a horizontal surface and the 

position of the sun.  If the sun is not hidden by any sun obstacle (as defined in the Sun Obstacles 

window), a test ray from the surface node towards the sun is inspected on possible intersections 

with other (non-transparent) object surfaces.  When there are no intersections, the node is sunlit.  

Otherwise the node is shaded and the direct solar irradiation on the area around the node is 

cancelled. 

 

The estimation of the diffuse solar irradiation on the area around the node of the external surface is 

more complex. 

First the sky visibility from the elementary area around the node is used as reduction factor of the 

diffuse radiation.  The sky visibility is calculated using 10000 test rays from the node with random 

direction on the hemisphere above horizon.  For all directions at the front side of the surface, the 

sky visibility is estimated as the fraction of the test rays not shaded by any sun obstacle or other 

(non-transparent) object.  This is a good estimation of the view factor to the open sky from the 

elementary area around the node. 

Secondly the diffuse radiation depends on the tilt of the surface. 

In an isotropic diffuse model the diffuse radiation on a sloped surface is proportional to the square 

of the cosine of half the tilt angle.  E.g. the diffuse radiation on a vertical surface is half the diffuse 

radiation on a horizontal surface (i.e. the surface only sees half of the sky dome). 

We use the more correct anisotropic diffuse model developed by Muneer1, which also distinguishes 

between shaded and sunlit surfaces and between overcast and non-overcast conditions of the sunlit 

surfaces.  The required parameters can be derived from sun position, slope, orientation, day of year, 

sunlit status, sky visibility, global and diffuse solar radiation data on a horizontal surface. 

Finally radiation reflected from the ground in front of the surface, must be added.  This radiation is 

assumed isotropic, and is a function of the global solar radiation on a horizontal surface, the tilt of 

the surface, and the ground reflection factor, which is an input parameter in the Solar Data dialog 

box (normal value = 0.2).  The ground reflected radiation on a vertical surface is half the ground 

reflected radiation on a horizontal downward surface. 

 

                                                 
1 Muneer T., Algorithms for estimating hourly solar irradiation on slopes, Building Serv. Eng. Res. Technol. 10(2), p. 

81-83 (1989) 
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Now we return to the direct radiation incident on the surface.  If the reflection factor of the surface 

is angle dependent (cf. definition of the material colour in the Colours window), then this factor is 

determined through interpolation between the values in the solar reflection function file for the 

actual angle of incidence (angle between direct solar radiation and surface normal).  If the solar 

zone is of type BC_SIMPL, then the reflected direct solar radiation from an external surface is 

further ignored.  If the solar zone is of type BC_SKY, this reflected solar radiation is further 

processed as diffuse solar radiation (cf. section C.9). 

The reflection factor for diffuse radiation is the weighted mean value of the reflection factors for all 

possible angles of incidence.  If the solar zone is of type BC_SIMPL, then the reflected diffuse solar 

radiation from an external surface is ignored.  If the solar zone is of type BC_SKY, this reflected 

solar radiation is further processed as diffuse solar radiation (cf. section C.9). 

 

After reflection some part of the solar radiation may be transmitted to internal zones (when the solar 

transmission factor of the surface material, as defined in the Colours window, is greater than 0).  

The remainder of the solar radiation is absorbed.  For an opaque surface (solar transmission factor 

equals 0) the absorbed solar radiation is converted to node powers in the surface nodes. 

For a transparent surface (solar transmission factor greater than 0) the absorbed solar radiation is 

uniformly distributed (proportionally to the mesh distances) along the grid line through the surface 

node and perpendicular to the external surface (up to this grid line reaches an opposite material 

surface or a non-transparent material).  This means that all nodes of the (transparent) wall behind a 

transparent surface node are assumed to have equivalent mass absorption.  Only the solar 

transmission factor of the wall surface in contact to the solar zone is considered. 

C.8. Solar load to internal surfaces 

The transmitted solar radiation of the radiation on an elementary area of a material surface around a 

surface node is first transferred to the elementary material surface area at the other side of the wall 

behind the surface wall.  The wall is considered along the grid line through the original surface 

node, that is perpendicular to the surface, until the opposite surface is reached (that borders the 

boundary condition at the other side).  This wall may consist of different materials (colours of type 

MATERIAL or EQUIMAT) having different material properties.  In fact the transmission factor of 

a material surface (as input in the Colours window) is the transmittance (after deduction of 

reflectance) of the wall behind the surface.  This means that the given transmission factor is not a 

pure material property, but it is the combined result of the transmission factors of all materials 

behind the surface of the given material (i.e. a wall property). 

The program VOLTRA requires (for logical results) that when the transmission factor of a material 

is greater than zero, also the transmission factor of the material at the other side of the wall in the 

object geometry is greater than zero. 

 

When the zone at the other side of the wall has a colour of type BC_FREE, TRANSMAT, BC_SKY 

or BC_NOSKY (which requires the RADCON module), then that zone is an internal zone, through 

which the solar radiation is further propagated.  The material surfaces bordering an internal zone are 

internal surfaces. 

A zone of type BC_FREE has view factor based radiation, and convection with a balanced 

unknown air temperature.  This type is normally used for rooms or larger air cavities. 

A zone of type TRANSMAT has view factor based radiation, and conduction using a given thermal 

conductivity (of still air or another gas).  This type is normally used for smaller cavities, e.g. the 

cavity of a double glazing. 

 

In general a view factor grid should be used that is less detailed (i.e. with a smaller number of wider 

meshes) than the calculation grid.  The view factors in the calculation grid are derived from the 

view factors in the view factor grid through scaling with the areas of the elementary surfaces.  The 
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precision is nearly the same, but the calculation speed can be enormously improved.  This is 

especially true, because we will see (cf. section C.9) that every time step a linear system of 

equations must be solved in which the number of unknowns equals the number of view factor 

surfaces (of the view factor grid). 

From VOLTRA v6.0w the format of the view factor file (with extension .vwf) is modified 

compared to the previous versions. 

 

The transmitted direct solar radiation in a node of an internal surface is projected along the 

direction of direct sun light upon the closest internal surface (of the same internal zone opposite to 

the emitter internal surface).  The power of the transmitted direct solar radiation corresponding to 

the elementary grid surface around the emitter node is attributed to the elementary grid surface 

containing the intersection point of the projected solar beam.  When this power would cause a flux 

(i.e. power divided by area) that is greater than the solar radiation on an external surface with the 

same orientation, then this power is widerly spread over adjacent elementary grid surfaces with the 

same orientation.  This smoothing occurs when the area of the receiver surface is (much) smaller 

than the area of the emitter surface.  Therefore it is recommended to use a (more or less) equidistant 

grid. 

The direct solar radiation through transparent materials (e.g. window glass) causes a sunlit spot on 

the internal surfaces of an internal zone.  This spot will be sharper when the calculation grid is finer. 

Part of the incident direct solar radiation on an internal surface is reflected, using the reflection 

factor of the surface material colour (defined in the Colours window).  This reflection factor may be 

dependent on the angle of incidence (when the reflection factor is defined by a reflection factor 

function).  The reflected radiation is assumed to be diffuse, and will be treated further (cf. section 

C.9). 

The remainder of the incident direct solar radiation on the internal surface is transmitted (when the 

transmission factor of the surface material colour is greater than zero, as defined in the Colours 

window) and absorbed.  The transmitted and absorbed radiation are treated in the same way as 

transmitted and absorbed direct solar radiation on an external surface. 

 

The transmitted diffuse solar radiation of an elementary grid surface (of an internal surface) is 

projected upon the other elementary grid surfaces (of the same internal zone) proportional to the 

view factors from the emitter surface to the receiver surfaces. 

Part of the incident diffuse solar radiation on an internal surface is reflected, using the reflection 

factor for diffuse radiation (which is the mean value of the reflection factors for direct radiation for 

all possible angles of incidence).  The reflected diffuse radiation is treated further (cf. section C.9). 

The remainder of the incident diffuse solar radiation on an internal surface is transmitted and 

absorbed analogously to transmitted and absorbed diffuse solar radiation on an external surface. 

C.9. Processing of diffuse solar reflection 

The reflected radiation (originating from either direct or diffuse solar radiation) is always diffuse 

and causes additional radiation upon all surfaces, that is again reflected, transmitted and absorbed.  

The final contributions of additional absorption on all internal surfaces are calculated using the 

radiosity method based on the view factor grid. 

The radiosity of each elementary surface of the view factor grid equals the amount of energy that is 

given off.  The energy incident on the surface (which we consider as unknown of the system) equals 

the sum of all reflected and transmitted energy from other surfaces, multiplied by the view factors 

from those surfaces to the first surface.  The reflected energy from another surface equals the 

energy incident on that surface (which is an unknown of the system) multiplied by the (diffuse) 

reflection factor plus the known reflected energy (at the initial state of the radiosity system).  The 

transmitted energy equals the energy incident on the opposite side of the wall (which is an unknown 

of the system) multiplied by the transmission factor at that side.  The transmission factor must first 
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be corrected for the reflection at that side (because the transmission factor in VOLTRA is defined 

after subtraction of reflection).  Finally this leads to a set of linear equations.  

The radiosity method implies that every time step a supplementary linear system of equations must 

be formulated and solved with the number of unknowns equal to the number of view factor surfaces 

of the view factor grid.  This system is global for the solar zone and all internal zones, because these 

zones may be linked with one another via transparent walls. 

C.10. Batch calculation 

The user can launch a batch calculation for several data files (with extension .vtr) in the same 

folder.  The calculations are executed one after the other without any intervention of the user. 

To start a batch calculation call the command File > Batch Calculation…, select the data files in the 

Batch Calculation dialog box (hold down the <Ctrl>-key to select more than one file) and press the 

Start button.  It is not possible to select several data files located in different directories. 

 

Per data file a report file is written to disk, containing the output report corresponding to the report 

definition of the data file (cf. sections B.18, B.19 and E.4).  The report file has the same file name 

as the data file, and has the extension .txt. 

When graphic output (i.e. snapshots at given time points and/or animation files of given time 

periods) is wanted afterwards, the data file should specify that step solutions must be saved to disk 

(cf. section B.20 and Chapter D). 

 

 

C.11. Command line program execution 

VOLTRA can be run from another application with a data file path (including directory and file 

extension .vtr) as parameter. 

Then no further user action is required.  The program starts and ends automatically, and the output 

is a report file and/or a series of graphic snapshots (as in a batch calculation, cf. section C.10). 

The switch “/Automation” is required to activate the batch calculation. 

 

Example of command line launch: 

 

Run >  

“c:\…\Physibel\Voltra\Voltra.exe” “c:\…\Physibel\Voltra\Data\PilotexVoltra.vtr” /Automation 
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CHAPTER D GRAPHIC OUTPUT 

D.1. Graphic Output window 

The Graphic Output window (which covers the complete VOLTRA application window) is opened 

with the command Output > Graphic Output. 

To return to the main VOLTRA window, choose the command File > Exit. 

The <Esc>-key is reserved here for stopping the current view visualisation or stopping animation 

functions (cf. section D.2). 

 

 
 

The material colour, boundary condition colour, temperature or heat flux (dependent on the current 

view option) under the mouse cursor point is shown in the status bar at the bottom of the Graphic 

Output window. 

D.2. Animation functions 

The animation functions are available through the Animate submenu. 

 

First Time Step Go to time 0000:00:00:00 and load the first solution file. 

Next Time Step Go to the next time step and load the next solution file. 

Previous Time Step Go to the previous time step and load the previous solution file. 
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Go To… Go to the time step entered by the user and load the corresponding 

solution file. 

Play Shows successively all solution files starting from the current time step. 

After the last solution the files are replayed continuously from the first 

solution.  The playing can be stopped by pressing the <Esc>-key. 

 

The next functions do not change the current time step: 

Rotate Left Continuously rotate left around the object. 

Rotate Right Continuously rotate right around the object. 

Rotate Up Continuously rotate upwards around the object. 

Rotate Down Continuously rotate downwards around the object. 

All rotation animations move in steps of 5° and can be stopped by pressing the <Esc>-key. 

The relative movement of viewpoint and object is directed by the current drag mode (Settings > 

Drag Mode…). 

D.3. Save animation images 

Menu command: File > Save Animation Images… 

A sequence of all animation images (as a result of the command Animate > Play) can be saved on 

disk as separate .png or .bmp files. 

 

A Save As dialog box is opened to prompt for a file name. 

The file type (PNG or BMP), image size of saved bitmap and font size of legend text are defined via 

Settings > Image Size…. 

 

The solution files are loaded consecutively (started with the first solution at time 0000:00:00:00), 

shown in the Graphics Output window and saved as bitmap.  A 4 digit number (starting from 0000) 

is appended to the chosen file name to generate the different bitmap files. 

Saving animation images can be interrupted by pressing the <Esc>-key. 

D.4. Write an .avi file 

Menu command: File > Write AVI File… 

Instead of creating a series of animation bitmap files, you can create a single compressed .avi file 

(“audio-video interleaved” file) to store an animation on disk.  An .avi file can be played with e.g. 

Windows Media Player. 

 

First a Save As dialog box is opened to prompt for a file name. 

The bitmap size and font size (for text in the legend) are defined via Settings > Image Size…. 

Then the first solution is loaded on the screen. 

The frame rate must be entered (Write AVI File dialog box) and the video compression (Video 

Compression dialog box).  Choose “Microsoft Video 1” as compressor. 
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Now all solution files are loaded consecutively and the .avi file is written. 

 

 
 

 
 

In all images of an animation the legend at the right border is always present (because each frame 

picture must contain all available colours, which is valid when the legend bar is visible). 

D.5. View submenu 

 
 

Remark 

For the checked view options in the figure above of the View submenu (i.e. View > Fill Materials 

and View > Legend) the legend shows the thermal conductivities of the different materials.  If those 

thermal conductivities are defined by temperature dependent functions, the shown values in the 

legend are taken at 10°C. 

D.6. Sun position 

The command View > Sun Position shows the sun position at the current time step (yellow if 

visible, or gray if hidden by sun obstacles), the horizon circle, the horizon coordinate system (north, 

west, zenith directions as resp. red, green, blue lines) and the sun path of the current day.  The 

legend shows the calculation time step, date, sun azimuth (horizontal angle from the south positive 

to the west) and sun altitude (vertical angle above the horizon plane). 
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The object is always shown in total zoom (i.e. zooming in is disabled). 

The animation functions (Animate > Play and File > Write AVI File…) allow to view the sun path 

(sun position changing with time).  The time step used is the calculation time step (as defined in 

Edit > Calc Parameters… from the main menu). 

All other view commands are disabled until you choose the toggle command View > Sun Position 

again (which quits the sun position view). 

 

The parameters that define the sun position are: 

 North orientation (Edit > Solar Data…). 

 Geographic position (Edit > Solar Data…). 

 Day of year at start of calculation (Edit > Calculation Parameters…). 

 Time setting (Animate > Go To…). 

The start of calculation corresponds with time 0000:00:00:00. 

D.7. Sun shaded image 

When the sun is present in the object model (which requires the presence of a solar zone, i.e. a 

colour of type BC_SIMPL or BC_SKY with sun input parameter set), a sun shaded image can be 

generated. 

 

Menu command: View > Shadow 

 

A sun shaded image can be generated before the system calculation is done. 

Sun obstacles (as defined in the Sun Obstacles window) are ignored. 

 

Sunlit surfaces are shown on external surfaces bordering a solar zone, and on material surfaces of 

internal zones through transparent walls.  If wanted, the object may be clipped, using Edit > Clip 

Object (as in the second figure below, which is a top view with the ceiling clipped off). 
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An animation with sun shaded images can be made using Animate > Play or File > Write AVI 

File….  The time step defined in the Calculation Parameters dialog box (Edit > Calculation 

Parameters…) is used as animation time step. 

D.8. View absorbed solar fluxes 

Menu command: View > Fill Absorbed Solar Fluxes 

 

When the solar fluxes are calculated (i.e. after Calc > Calc Solar Fluxes or Calc > Calc System) 

and the calculation step solutions (.sfd and .sfx files) are saved on disk (cf. setting in Calc > Save 

Frequency…), this option allows to visualise the absorbed solar fluxes on the object surfaces. 
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These absorbed solar fluxes are converted to node powers, which are the boundary conditions due 

to solar radiation, that are used in the system calculation. 

For transparent surfaces the total absorbed solar flux is shown, before subdividing the absorbed 

solar power into node powers within the wall behind the transparent surface (cf. section C.7, last 

paragraph). 

The flux scale can be set via Settings > Heat Flux Range…. 

 

 

D.9. Temperature profile along a grid line 

For any user defined grid line a temperature graph through the intersected material layers can be 

drawn per calculation time step. 

First the desired grid line must be defined using the command View > Temperature Profile Line 

Definition… 

 

 
 

In the dialog box choose the grid line direction: 

 X, Y or Z (in the XYZ coordinate system), or 

 R, C or L (in the RCL coordinate system). 

Then define the grid coordinates of the starting node (“from”) and ending node (“to”) of the line. 

 

The toggle command View > Temperature Profile shows the temperature graph. 
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The horizontal axis shows the grid coordinates along the chosen grid direction. 

The current calculation time step is displayed at the bottom right (and can be modified, e.g. using 

Animate > Go To…). 

The vertical axis shows the temperature scale (conform to the settings in Settings > Temperature 

Range…). 

The blue function line corresponds to the temperature solution at the current time step. 

Except the animation functions all other menu commands are disabled until the temperature profile 

is removed by pressing the toggle command View > Temperature Profile again. 
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CHAPTER E TEXT OUTPUT 

E.1. Text Output window 

The Text Output window (which covers the complete VOLTRA application window) is opened 

with the command Output > Text Output. 

To return to the main VOLTRA window, press the <Esc>-key or choose the command File > Exit. 

 

 
 

Text in the Text Output window is limited to 200 000 characters, which corresponds to 2500 lines 

of 80 characters. 

E.2. Input data 

The input data is shown in the Text Output window using the command View > Input Data. 

Below is a print-out for the example PilotexVoltra.vtr. 

 
VOLTRA - Input Data 

 

 Pilot example of the VOLTRA manual 

 Three-dimensional corner of a room 

 

 

VOLTRA data file: PilotexVoltra.vtr 

 

GRID 

Grid unit = 0.01 m 

No.            R         C         L   _ 

1-3           10.000    10.000    10.000 

3-5            2.500     2.500     2.500 

5-7            2.500     2.500     2.500 

7-9            2.500     2.500     2.500 

9-11           2.500     2.500     2.500 

11-13          2.500     2.500     2.500 

13-15          2.500     2.500     2.500 

15-17          2.500     2.500     2.500 

17-19          2.500     2.500     2.500 

19-21          2.500     2.500     2.500 

21-23          2.500     2.500     2.500 

23-25          2.500     2.500     2.500 

25-27          2.500     2.500     2.500 

27-29          2.500     2.500     5.000 

29-31          2.500     2.500     5.000 
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31-33          5.000     2.500    10.000 

33-35          5.000     2.500    10.000 

35-37          5.000     5.000    10.000 

37-39          5.000     5.000    10.000 

39-41          5.000     5.000    10.000 

41-43          5.000     5.000    10.000 

43-45          5.000     5.000    20.000 

45-47         10.000     5.000 

47-49         10.000    10.000 

49-51         10.000    10.000 

51-53         10.000    10.000 

53-55         20.000    10.000 

55-57                   20.000 

Sum          140.000   140.000   130.000 

 

BLOCKS 

No.   Col.    Rmin  Rmax  Cmin  Cmax  Lmin  Lmax 

1       1        1    55     1    57     1    45 

2       4        3    55     3    57    19    45 

3       5       11    55    11    57    19    45 

4       6       15    55    15    57    19    45 

5       7       15    27    15    43    19    45 

6       2       27    55    27    57    19    45 

7       8        3    55     3    57     3     7 

8       7        3    55     3    57     7    19 

 

No.   Col.        Rmin      Rmax      Cmin      Cmax      Lmin      Lmax 

1       1        0.000   140.000     0.000   140.000     0.000   130.000 

2       4       10.000   140.000    10.000   140.000     0.000   100.000 

3       5       20.000   140.000    20.000   140.000     0.000   100.000 

4       6       25.000   140.000    25.000   140.000     0.000   100.000 

5       7       25.000    40.000    25.000    70.000     0.000   100.000 

6       2       40.000   140.000    40.000   140.000     0.000   100.000 

7       8       10.000   140.000    10.000   140.000   115.000   120.000 

8       7       10.000   140.000    10.000   140.000   100.000   115.000 

 

FUNCTIONS 

T01: SINE 

  Mean value = 0°C 

  Amplitudo = 10°C 

  Period = 1440 min 

  Offset = 420 min 

T02: STEP2 

  Level 1 = 20°C 

  Level 2 = 10°C 

  Period = 1440 min 

  Duration level 1 = 720 min 

  Transition = 60 min 

  Start level 1 = 420 min 

 

COLOURS 

Col. Type      CEN-rule  Name             lambda     eps    rho       c       t       h       q 

                                          [W/mK]     [-] [kg/m3] [J/kgK]    [°C] [W/m²K]  [W/m²] 

  1  BC_SIMPL  NIHIL     outside                                             T01   25.00       0 

  2  BC_SIMPL  NIHIL     inside                                              T02    5.00       0 

  4  MATERIAL            brickwork         1.000          1750.0   840.0                         

  5  MATERIAL            insulation        0.035            40.0   840.0                         

  6  MATERIAL            brickwork         0.700          1400.0   840.0                         

  7  MATERIAL            concrete          2.500          2200.0   840.0                         

  8  MATERIAL            insulation        0.030            40.0   840.0                         

 

Col.    ta      hc      Pc      tr         C1        C2        C3    Sun         rs      ts 

       [°C] [W/m²K]     [W]    [°C]       [-]       [-]       [-]               [-]     [-] 

  1                                                                  NO                     

  2                                                                  NO                     

  4                                                                            0.10    0.00 

  5                                                                            0.10    0.00 

  6                                                                            0.10    0.00 

  7                                                                            0.10    0.00 

  8                                                                            0.10    0.00 

 

OUTPUT NODES 

No.      R     C     L 

1       27    27    19 

2       27    57    19 

3       27    57    45 

4        3    57    45 

 

Calculation parameters 

Time step interval = 0000:00:15:00 
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Start-up calculation duration = 0000:00:00:00 

Calculation duration = 0003:00:00:00 

Day number at start of calculation = 1 

Maximum number of iterations = 10000 

Maximum temperature difference = 0.0001°C 

Heat flow divergence for total object = 0.001 % 

Heat flow divergence for worst node = 1 % 

E.3. Time step results 

Calculation results for a specific time step are shown using the commands View > Time Step 

Results, View > Corner Nodes and View > Node BC’s.  These commands are also present in 

TRISCO.  The time step can be set using one of the first four commands in the Edit submenu, 

which are analogous to the corresponding commands of the Animate submenu in the Graphic 

Output window (cf. section D.2). 

 

 
 

The Edit > Copy function allows to copy a selected text part in the Text Output window into the 

Windows Clipboard, to use it in another program. 

 

Below is a print-out of the View > Time Step Results command for the example PilotexVoltra.vtr at 

time 0002:16:00:00 (set with the command Edit > Go To…). 

 
VOLTRA - Calculation Results 

 

VOLTRA data file: PilotexVoltra.vtr 

Number of nodes = 13902 

 

Time step 0002:16:00:00 

 

Col. Type      Name                 tmin    R    C    L      tmax    R    C    L 

                                    [°C]                     [°C]              _ 

  1  BC_SIMPL  outside              7.00    3    3    5      7.87    3   57   15 

  2  BC_SIMPL  inside               8.69   27   27   19     16.06   55   27   45 

  4  MATERIAL  brickwork            7.47    3    3   23      8.36   11   13   45 

  5  MATERIAL  insulation           7.52   27   13   19     13.42   55   15   45 

  6  MATERIAL  brickwork            7.55   27   15   19     16.06   55   27   45 

  7  MATERIAL  concrete             7.32   23   19    7     14.91   55   57   19 

  8  MATERIAL  insulation           7.00    3    3    5     14.02   55   57    7 

 

Col. Type      Name                   ta   Flow in  Flow out 

                                    [°C]       [W]       [W] 

  1  BC_SIMPL  outside                        0.06     52.51 

  2  BC_SIMPL  inside                        86.97      0.00 

 

Below is a print-out of the View > Corner Nodes command for the example PilotexVoltra.vtr at 

time 0002:16:00:00. 

 
VOLTRA - Temperatures in corner nodes 

 
VOLTRA data file: PilotexVoltra.vtr 

Number of nodes = 13902 

 

Time step 0002:16:00:00 

 

     R     C     L         t 

                        [°C] 

     3     3     3      7.09 

     3     3    45      7.50 

     3    57     3      7.08 

     3    57    45      7.73 

    27    27    19      8.69 
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    27    27    45     13.07 

    27    57    19     10.90 

    27    57    45     16.05 

    55     3     3      7.08 

    55     3    45      7.73 

    55    27    19     10.90 

    55    27    45     16.06 

    55    57     3      7.25 

    55    57    19     14.91 

E.4. Report output 

For the items defined in the Report Definition (cf. section B.18) a report can be output with records 

at a given frequency of time steps (cf. section B.19).  The command View > Report Output shows 

the contents of the .txt file written during the calculation (up to maximum 200 000 characters). 

Per report time step one line of report values is written.  The report values are separated with tab 

characters (which is useful for export to Microsoft Excel).  Each column in the table corresponds to 

a report item.  The meaning of the columns is explained in the header.  If a report item is logically 

impossible, it is skipped. 

 

Be careful with absorbed solar flux results (qsol Xmin, …, qsol Zmax).  Area weighted average 

results are shown for the areas of a material colour oriented to a given direction.  Also the areas 

having the desired orientation, but not bordering a zone in which solar radiation is distributed (i.e. 

for which qsol = 0 W/m2), are included in the average value (so the shown result will be lower than 

what is expected).  A possible solution is to split the material blocks into several blocks having 

different colours (with the same material properties). 

 

Below is a print-out for the example PilotexVoltra.vtr. 

 
VOLTRA - Report Output 

 

VOLTRA data file: PilotexVoltra.vtr 

 

Column 1: Time [dddd:hh:mm:ss] 

Column 2: Colour 1, BC temperature [°C] 

Column 3: Colour 2, BC temperature [°C] 

Column 4: Output node 1, temperature [°C] 

Column 5: Output node 2, temperature [°C] 

Column 6: Output node 3, temperature [°C] 

Column 7: Output node 4, temperature [°C] 

Column 8: Colour 1, sum of heat flows into object [W] 

Column 9: Colour 1, sum of heat flows out of object [W] 

Column 10: Colour 2, sum of heat flows into object [W] 

Column 11: Colour 2, sum of heat flows out of object [W] 

 

0000:00:00:00   -9.66   10.00   -0.79    2.11    7.99   -9.26    0.26   57.64   57.37    0.00 

0000:01:00:00  -10.00   10.00   -0.79    2.11    7.99   -9.45    0.29   69.51   57.37    0.00 

0000:02:00:00   -9.66   10.00   -0.80    2.11    7.99   -9.36    0.35   50.12   57.38    0.00 

0000:03:00:00   -8.66   10.00   -0.81    2.11    7.99   -8.83   12.40   24.76   57.40    0.00 

0000:04:00:00   -7.07   10.00   -0.80    2.11    7.99   -7.84   49.01   13.33   57.38    0.00 

0000:05:00:00   -5.00   10.00   -0.76    2.14    7.99   -6.42   93.55    5.66   57.29    0.00 

0000:06:00:00   -2.59   10.00   -0.66    2.21    8.00   -4.62  142.43    3.95   57.06    0.00 

0000:07:00:00    0.00   20.00   -0.05    3.05    9.96   -2.55  184.90    2.48  184.52    0.00 

0000:08:00:00    2.59   20.00    0.58    3.80   11.32   -0.33  216.85    1.49  168.39    0.00 

0000:09:00:00    5.00   20.00    1.20    4.41   12.01    1.89  235.03    0.90  159.15    0.00 

0000:10:00:00    7.07   20.00    1.90    5.04   12.54    3.98  237.44    0.59  151.36    0.00 

0000:11:00:00    8.66   20.00    2.67    5.71   13.00    5.80  223.36    0.49  144.10    0.00 

0000:12:00:00    9.66   20.00    3.49    6.40   13.43    7.23  193.31    0.44  137.10    0.00 

0000:13:00:00   10.00   20.00    4.35    7.11   13.83    8.17  149.00    0.40  130.29    0.00 

0000:14:00:00    9.66   20.00    5.19    7.80   14.21    8.57   93.33    0.47  123.68    0.00 

0000:15:00:00    8.66   20.00    6.00    8.46   14.58    8.39   30.36    1.12  117.33    0.00 

0000:16:00:00    7.07   20.00    6.74    9.07   14.92    7.66    0.24   38.34  111.30    0.00 

0000:17:00:00    5.00   20.00    7.38    9.61   15.25    6.41    0.14  104.91  105.68    0.00 

0000:18:00:00    2.59   20.00    7.89   10.06   15.54    4.75    0.29  166.66  100.53    0.00 

0000:19:00:00    0.00   20.00    8.26   10.41   15.82    2.78    0.43  219.28   95.94    0.00 

0000:20:00:00   -2.59   10.00    8.04    9.93   14.11    0.64    0.55  259.30    0.50   36.47 

0000:21:00:00   -5.00   10.00    7.76    9.51   12.97   -1.53    0.64  283.90    1.10   25.01 

0000:22:00:00   -7.07   10.00    7.45    9.19   12.49   -3.58    0.70  291.41    1.68   20.08 

0000:23:00:00   -8.66   10.00    7.04    8.83   12.15   -5.36    0.73  281.38    2.43   16.51 
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0001:00:00:00   -9.66   10.00    6.54    8.42   11.86   -6.76    0.71  254.61    3.43   13.46 

0001:01:00:00  -10.00   10.00    5.99    7.97   11.59   -7.68    0.65  213.03    4.66   10.71 

0001:02:00:00   -9.66   10.00    5.41    7.51   11.33   -8.06    0.57  159.54    6.13    8.22 

0001:03:00:00   -8.66   10.00    4.84    7.06   11.08   -7.87    0.52   97.88    7.80    6.00 

0001:04:00:00   -7.07   10.00    4.32    6.64   10.84   -7.13    8.16   39.94    9.65    4.12 

0001:05:00:00   -5.00   10.00    3.89    6.28   10.62   -5.88   55.12   21.77   11.57    2.54 

0001:06:00:00   -2.59   10.00    3.56    6.00   10.41   -4.21  102.51    8.93   13.56    1.36 

0001:07:00:00   -0.00   20.00    3.79    6.52   12.17   -2.23  149.64    4.84  142.87    0.00 

0001:08:00:00    2.59   20.00    4.07    6.97   13.35   -0.08  186.62    3.26  129.74    0.00 

0001:09:00:00    5.00   20.00    4.38    7.31   13.87    2.09  208.70    2.17  123.31    0.00 

0001:10:00:00    7.07   20.00    4.80    7.70   14.24    4.14  214.19    1.44  118.15    0.00 

0001:11:00:00    8.66   20.00    5.31    8.14   14.56    5.93  202.64    1.03  113.32    0.00 

0001:12:00:00    9.66   20.00    5.91    8.64   14.86    7.34  174.80    0.85  108.59    0.00 

0001:13:00:00   10.00   20.00    6.56    9.16   15.14    8.27  132.52    0.88  103.88    0.00 

0001:14:00:00    9.66   20.00    7.22    9.69   15.41    8.65   78.74    1.15   99.23    0.00 

0001:15:00:00    8.66   20.00    7.86   10.20   15.68    8.46   17.61    2.19   94.68    0.00 

0001:16:00:00    7.07   20.00    8.45   10.67   15.93    7.72    0.06   50.73   90.33    0.00 

0001:17:00:00    5.00   20.00    8.94   11.08   16.16    6.47    0.20  116.43   86.26    0.00 

0001:18:00:00    2.59   20.00    9.33   11.41   16.38    4.80    0.35  177.19   82.55    0.00 

0001:19:00:00    0.00   20.00    9.58   11.65   16.58    2.82    0.48  228.93   79.28    0.00 

0001:20:00:00   -2.59   10.00    9.26   11.08   14.81    0.68    0.60  268.15    0.02   51.41 

0001:21:00:00   -5.00   10.00    8.88   10.57   13.62   -1.49    0.69  292.03    0.10   38.28 

0001:22:00:00   -7.07   10.00    8.48   10.17   13.08   -3.54    0.74  298.88    0.24   31.88 

0001:23:00:00   -8.66   10.00    7.99    9.73   12.69   -5.33    0.76  288.26    0.57   26.91 

0002:00:00:00   -9.66   10.00    7.42    9.24   12.35   -6.73    0.74  260.95    1.21   22.59 

0002:01:00:00  -10.00   10.00    6.79    8.73   12.04   -7.66    0.69  218.87    2.12   18.68 

0002:02:00:00   -9.66   10.00    6.15    8.21   11.74   -8.04    0.60  164.92    3.32   15.14 

0002:03:00:00   -8.66   10.00    5.52    7.71   11.46   -7.85    0.53  102.84    4.70   11.92 

0002:04:00:00   -7.07   10.00    4.95    7.25   11.19   -7.11    6.96   43.29    6.26    9.08 

0002:05:00:00   -5.00   10.00    4.47    6.84   10.94   -5.86   53.42   24.28    7.92    6.63 

0002:06:00:00   -2.59   10.00    4.10    6.51   10.70   -4.19  100.38   10.69    9.56    4.54 

0002:07:00:00   -0.00   20.00    4.29    6.99   12.44   -2.21  146.50    5.29  136.22    0.00 

0002:08:00:00    2.59   20.00    4.53    7.41   13.59   -0.07  183.67    3.63  123.58    0.00 

0002:09:00:00    5.00   20.00    4.80    7.72   14.10    2.10  205.93    2.46  117.60    0.00 

0002:10:00:00    7.07   20.00    5.19    8.07   14.45    4.16  211.59    1.68  112.85    0.00 

0002:11:00:00    8.66   20.00    5.67    8.49   14.75    5.94  200.21    1.21  108.42    0.00 

0002:12:00:00    9.66   20.00    6.25    8.96   15.03    7.35  172.53    1.01  104.04    0.00 

0002:13:00:00   10.00   20.00    6.87    9.46   15.30    8.28  130.44    1.03   99.67    0.00 

0002:14:00:00    9.66   20.00    7.51    9.96   15.56    8.66   76.84    1.32   95.32    0.00 

0002:15:00:00    8.66   20.00    8.13   10.45   15.81    8.47   15.92    2.42   91.06    0.00 

0002:16:00:00    7.07   20.00    8.69   10.90   16.05    7.73    0.06   52.51   86.97    0.00 

0002:17:00:00    5.00   20.00    9.17   11.30   16.28    6.48    0.21  118.08   83.14    0.00 

0002:18:00:00    2.59   20.00    9.54   11.61   16.49    4.81    0.35  178.72   79.66    0.00 

0002:19:00:00    0.00   20.00    9.77   11.84   16.68    2.83    0.49  230.35   76.60    0.00 

0002:20:00:00   -2.59   10.00    9.43   11.25   14.90    0.68    0.60  269.46    0.01   53.88 

0002:21:00:00   -5.00   10.00    9.04   10.73   13.70   -1.49    0.69  293.24    0.06   40.55 

0002:22:00:00   -7.07   10.00    8.63   10.32   13.15   -3.54    0.75  300.01    0.17   33.94 

0002:23:00:00   -8.66   10.00    8.13    9.87   12.76   -5.33    0.77  289.30    0.43   28.74 

0003:00:00:00   -9.66   10.00    7.55    9.37   12.41   -6.73    0.75  261.91    0.99   24.20 

E.5. Drawing graphs 

From a report in the Text Output window a graph of time functions of report items can be drawn, 

e.g. in Microsoft Excel.  Here is a procedure that can be used: 

 For the time axis it is best to have time values in seconds (type [s] in the Report Definition 

window) instead of values in days, hours, minutes and seconds (type [dddd:hh:mm:ss]).  This is 

because the seconds can easily be rescaled in Microsoft Excel to a more suitable unit (e.g. hours, 

as in the figure below). 

 Select the wanted area in the Text Output window (with the report output), and copy it into the 

clipboard (using Edit > Copy).  For the figure below we selected the time column (but 

recalculated with unit in seconds) and the columns with temperature data (select columns in 

Microsoft Word using <Alt+Shift>). 

 Paste the contents of the clipboard in Microsoft Excel. 

 Insert a new row on top of the data (Insert > Rows) and add names as column headers for the 

different output items.  These names will be printed in the chart legend. 

 Select all data and use the Chart wizard (menu command Insert > Chart…) with chart type: XY 

(Scatter) to make a graph. 
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CHAPTER F PROGRAM FUNCEDIT 

F.1. Introduction 

The program FUNCEDIT is a utility program to edit and visualise function files for use in the non-

steady state Physibel programs (VOLTRA, SECTRA, BISTRA, CAPSOL), where these functions 

are used as dynamic boundary condition specifications. 

 

After starting FUNCEDIT, or creating a new function using the command File > New, a null 

temperature function of length 24 hours (with hourly values of 0°C) is displayed. 

 

 
 

An existing function file on disk is read using the command File > Open….  The function type can 

be chosen in the Open dialog box. 

F.2. Function type 

The following function types are available: 

  unit extension use in VOLTRA & SECTRA 

temperature [°C] .fte boundary condition temperature 

horizontal global solar radiation [W/m2] .fsg boundary condition solar zone 

horizontal diffuse solar radiation [W/m2] .fsd boundary condition solar zone 

direct solar radiation [W/m2] .fsb not used 

solar radiation [W/m2] .fse not used 

infrared radiation [W/m2] .fir boundary condition heat flux 

power [W] .ffh boundary condition power 

thermal conductivity [W/(m.K)] .fco material property 

     time-dependent thermal conductivity 

surface heat transfer coefficient[W/(m².K)] .fht boundary condition 

     total surface heat transfer coefficient or 
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     convective heat transfer coefficient 

ventilation rate [/h] .fvr ventilation volume flow rate [m3/s] 

 

Remark 

The ventilation rate in FUNCEDIT is shown with unit /h, which is used in the Physibel program 

CAPSOL.  However in VOLTRA the same function type is used for ventilation volume flow rates, 

with unit m3/s.  So for VOLTRA ventilation functions the unit specifier [/h] in FUNCEDIT should be 

read as [m3/s]. 

F.3. Function parameters 

General header information of a function file is edited via the command Edit > Parameters. 

 

 
 

A dialog box is opened where the following parameters can be edited: 

 Function type: see section F.2. 

 Comment: text description of the function. 

 Previous function and next function: file name of a function that precedes the current function 

(previous function) or comes next to the current function (next function).  The previous and/or 

next function may be the same as the current function, in which case the check box “the same” is 

marked. 

If the time space of a VOLTRA data file is larger than the time space of the function definition, 

it is necessary to know which function comes next to the current one.  In case a start-up 

calculation is used, a previous function is required.  If the previous and the next function are 
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checked as the same, then the current function corresponds to the definition of an infinite 

periodic function, with period the length of the current function. 

 Interpolation: linear or step.  Intermediate function values are either obtained by linear 

interpolation (linear function) or remain constant during the whole time step interval (step 

function). 

 Time step [dddd:hh:mm:ss]: time interval between two successive function values in the function 

data window (see section F.4). 

 Total steps: number of time steps required to span the total function length.  This number is 

equal to the number of function values minus 1.  The function length or duration equals the time 

step multiplied by the total number of steps. 

 Number of decimals: number of digits after the decimal point, for all function values in the 

function data window (see section F.4) and in the function file. 

 Number of columns: used in the function data window (see section F.4) and in the function file. 

 Day number at function start [1..365]: day number in the year on which the function starts.  The 

“i” button gives information about the start days of each month. 

 

 
 

 Latitude [°N], longitude [°E] and time zone [h]: to position a function climate station on the 

globe. 

 Chart time unit and chart time format: labelling information for the time axis in the function 

chart.  This information is not stored in the function file. 

 

F.4. Function data 

The function values at regular time step intervals can be edited in the function data window, opened 

with the command Edit > Data.  The table format is controlled by the function parameters (see 

section F.3). 

 

In the left (grey) column a time indication of the first value in the row is given.  The table can be 

navigated by the mouse or by the arrow keys. 

A new value can be inserted after the current one using the command Edit > Insert After or the 

<Insert>-key.  The “total steps” parameter in the function parameters dialog box is adapted 

accordingly. 

A value can be deleted using the command Edit > Delete Value or the <Delete>-key. 

Individual table cells can be copied and pasted by using the commands Edit > Copy (or <Ctrl+C>) 

and Edit > Paste (or <Ctrl+V>). 
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F.5. Graphic parameters 

The window that is opened when a new function is created or an existing function file is read, 

contains a graphic representation of the numerical function data entered in the data window. 

The red point in the graph corresponds to the function value in the current cell of the data window. 

 

 
 

The parameters about the graph can be edited in the Graphic submenu. 

 

 
 

The command Graphic > Set Scale… opens a dialog box containing scale parameters. 

The view range for both axes and tick mark distances can be set. 
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When a rectangle is drawn in the graph, with mouse dragging holding down the left mouse button, a 

zoom rectangle is defined.  The corresponding zoom view is drawn when the left mouse button is 

released.  The initial total view (with view range as defined in the Set Scale dialog box) can be 

restored by using the command Graphic > Zoom All or pressing the <Home>-key. 

 

The commands Graphic > Primary Grid X and Graphic > Primary Grid Y enable to show grid 

lines through the primary tick marks on both axes X and Y. 

 

The command Graphic > Right Axis allows to draw also a vertical axis with tick marks at the right 

side of the chart border. 

 

The command Graphic > Save As Bitmap (PNG) opens a dialog box where you can enter the file 

name and size of the .png file, which will be saved in the same directory as where the function is 

stored. 

 

F.6. Using a spreadsheet program to create functions 

A function file can also be created using Microsoft Excel or another spreadsheet program. 

The spreadsheet contains 6 header rows (starting with the keywords COM, PRV, NXT, TIM, FMT 

and DAT) followed by data rows with function values.  The syntax of the input data is given in the 

table below.  Save the file (as text) in the function files directory, with the extension corresponding 

to the function type (cf. section F.2). 

If an existing function file, created with FUNCEDIT, has to be modified using a spreadsheet 

program, it is recommended first to set the parameter “number of columns” in the Function 

Parameters dialog box equal to 1.  Then there will be only 1 column with function values in the 

spreadsheet (as in the figure below). 
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row number code input data 

 column A column B column C column D column E column F 

1 COM comment     

2 PRV name of the 

previous function * 

    

3 NXT name of the next 

function * 

    

4 TIM interpolation: 

0 = linear / 1 = step 

time step 

(in seconds) 

total number of steps   

5 FMT total number of 

characters of the 

function values 

number of 

digits after 

decimal point 

number of columns of 

function values 

minimum 

ordinate 

maximum 

ordinate 

6 DAT date number at 

function start 

latitude longitude time zone  

7  -  ...  -  

(7 + total steps) 

function 

type** 

function 

value 

(function 

value) 

(function 

value) 

(function 

value) 

(function 

value) 

* The extension of the file name may be omitted;  use the name *same* to specify the same previous / next function. 

** The function type as described in section F.2. 
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