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CHAPTER A INTRODUCTION 

A.1. Program overview 

VOLTRA is a thermal analysis program for transient heat transfer in three-dimensional 
rectangular objects. VOLTRA is an extension for time-dependent boundary conditions of TRISCO 
(for steady-state heat transfer).  
As in TRISCO, the geometry is described with a list of rectangular blocks, the vertices of which lie 

on grid points of a rectangular grid. Materials and surface boundary conditions with different 

thermal properties are identified using separate colours. Each geometry block is part of either a 
material or a surface boundary condition region, and has a reference to one of these colours. 
Node boundary conditions with fixed or time-dependent temperature or power are possible and 
can be placed in grid point locations. Also border face boundary conditions in the interface 
between two colour regions with fixed ort time-dependent temperature or heat flux, or material 
boundary conditions with fixed or time-dependent temperature or heat power density are 
possible. 
A TRISCO data file, BISTRA data file, BISCO data file or bitmap (BMP file) can be taken as starting 
data in VOLTRA. 
 
The time-dependent boundary conditions are described with functions, either built-in functions 

based on parameters, external user-defined functions (saved as separate files) based on function 
values given at a fixed time interval, or standardised weather files. 
The thermal conductivity, specific heat and reflection factor of a material can refer to functions 
described in external text files: thermal conductivity as a function of temperature, specific heat as 
a function of temperature, solar reflection factor as a function of angle of incidence. 
 
Dynamic solar heat gains can be studied. To this end a solar processor is built in (which requires 
the use of the RADCON module, see Chapter I). An object image with shadows cast by direct sun 
light at any time and any geographic location can be viewed. The direct and diffuse solar 
radiation from climate data (e.g. as given in the European Test Reference Years) is cast on the 
material surfaces. The absorbed solar radiation is converted to time-dependent node powers, as 
additional boundary conditions to the system. Transmission of solar radiation is possible via 

transparent materials to simulate heat gains through windows. The reflected solar radiation is 
diffuse and distributed according to the view factors (calculated with the RADCON module) to 
other material surfaces. Direct radiation is reflected (as diffuse radiation) using a reflection factor 
which may be function of the angle of incidence. 
 

VOLTRA can be used to carry out fire simulations (with use of the RADCON module, see Chapter 
I). Radiative heat transfer becomes more important when temperature differences increase. The 

RADCON module allows to include the simulation of non-linear radiation based on geometric 
view factors. The thermal conductivity and specific heat of materials may be temperature 
dependent. Latent heat is modelled through an increase of specific heat within a small 

temperature interval around the change of phase temperature. 
 
Heat transfer to objects via (time-dependent) ventilation between zones at different 
temperatures can be studied. 

 
Controls are available to replace boundary condition functions or material property functions 
with other functions, based on sensor temperature target functions. 
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VOLTRA allows creating time-dependent graphic animations of moving shadow patterns, 
calculated temperature field and heat flux field in the studied object. Alphanumeric lists of time 
functions of temperatures in individual nodes or heat flows through given surfaces through the 

object can be made. 
 
The RADCON module (see Chapter I), which allows a better simulation of radiation (using view 
factors) and convection, is available in VOLTRA, and is required for fire simulation and use of the 
solar processor. 

A.2. VOLTRA brief history 

VOLTRA was first developed in 1993 based on the steady-state program TRISCO. 
 

• Version 1.0 was ready in May 1993. 
• Version 3.0 (December 2001) was the first Windows version. 
• Version 4.0 (April 2003) included temperature dependent material properties and 

simulation of ventilation flows through different zones. 
• Version 6.0 (September 2006) included the solar processor based on direct and diffuse 

solar radiation weather data files. 
• Controls were introduced in version 8.0 (May 2017). 

 

The detailed version history can be found on the website: 
www.physibel.be/en/products/voltra/versions . 

A.3. Technical specifications 

- VOLTRA is a 64-bit Windows program. VOLTRA is installed in C:\Program Files 
(x86)\Physibel\VOLTRA9. 
In this folder the executable file is VOLTRA.exe. 

- The standard version of VOLTRA allows a maximum of 5,000,000 nodes. An add-on 
feature to calculate an unlimited amount of nodes is available for purchase (feature 
Unlimited Nodes). The maximum number of nodes then depends on the RAM installed. 

- VOLTRA relies on OpenGL for use of hardware accelerated graphics. 
- VOLTRA is protected by either a hardware key, provided by Physibel, or a software licence 

(A.4). 
 

The Physibel 64-bit programs need several shared libraries (.dll files) from Microsoft. 
The Microsoft Visual C++ 2017 Redistributable Package (x64) is included in the installation files of 
VOLTRA, but can also be downloaded from https://support.microsoft.com/en-
us/help/2977003/the-latest-supported-visual-c-downloads. 
This package installs mfc140.dll and other files in the directory C:\Windows\SysWOW64, required 

by 64-bit applications developed with Microsoft Visual C++ 2017. 

A.4. Licence 

The Physibel applications are protected by a licence, to prevent illegal use of the software. This 
can be either a hardware licence (Sentinel USB key) or a software licence. 

http://www.physibel.be/en/products/voltra/versions
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
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A.4.1. Hardware licence 

Perpetual licences are protected by a hardware licence (Sentinel USB key). The licence is locked 
to this dongle. It is strongly recommended to take a financial assurance for loss of the key by theft 
or any other incidence. 
 
Before VOLTRA can be used, the driver (delivered with purchase) for the hardware key needs to 

be installed. Administrator rights are needed for this installation. It might be necessary to restart 
your computer after installing the driver. 
 
During use of VOLTRA, the dongle needs to be attached to the computer at all times. 

A.4.2. Software licence 

Subscription licences are protected by a software licence. After first installation of VOLTRA, the 
user needs to activate the licence using the activation code received upon purchase of the 
software. When first opening VOLTRA, the Software Licence Manager will open automatically 

and prompt the user to activate the licence, or to register in the network floating database, 
depending on the licence type. The computer needs to be connected to the internet for this 
licence activation. Cloud-based floating licences are activated every time when opening the 
application. 

 
After activation, the Software Licence Manager is available from the menu for stand-alone 

licences: 
Help → Software Licence Manager… 
 
Users with a floating network licence can check out a licence from the database for a maximum 
period of 3 days. 
Help → Check out/in floating licence… 

 
The software licence key for VOLTRA is linked to the computer where it was activated. When you 
want to move the application with a stand-alone licence to another computer, you can 

deactivate the licence in the Software Licence Manager. The licence can then be reactivated on 
a new computer. 
 
If the Software Licence Manager is unavailable from the application itself, you can also open it 
from the command prompt. You need to first change directory to the Program Files folder where 
the application is installed. Then, open the Software Licence Manager with the following 
command: 

QlmLicenseWizard.exe /settings “VOLTRA 9.0.lw.xml”  

A.5. User Account Control (UAC) 

Administrator rights are necessary to install VOLTRA on a computer. 
 

The installation of the application is machine-level, meaning all user accounts can access the 
application after installation. 
 

Each user account has its own copy of the colour database (see G.2), to work with. These files can 
be found in the user’s application data directory 
(C:/Users/username/Appdata/Roaming/Physibel/VOLTRA9/). 
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In case of a software licence, the licence for VOLTRA is linked to the computer, but is stored at the 

user level. Each user account on a computer has to activate the licence in order to have access to 
the licence. 

A.6. Overview of delivered files and file structure 

VOLTRA is installed (when the user has accepted the default destination) in the folder 
C:\Program Files (x86)\Physibel. 

 
The following files are installed 
Folder File Description 

…\Physibel\VOLTRA VOLTRA.exe VOLTRA (64-bit) program 

 *.dll, *.pat, *.rgb Program resources 
 QlmLicenseWizard Software Licence Manager files 

…\Physibel\Materials *.phm Material databases 
…\Physibel\Manuals VOLTRAManual.pdf BISTRA manual 
 
The colour database file ColourDatabase.vtr (see G.2), together with the parameter file 
VOLTRA.prm (see A.9), are installed in C:/ProgramData/Physibel/VOLTRA9 (machine-level), and 
copied to each user account’s application data folder when first opening VOLTRA 
(C:/Users/username/AppData/Roaming/Physibel/VOLTRA9). 

A.7. Text convention 

Menu paths are printed in italic, with format Submenu → Command. 
E.g. File → Open (Open command in File submenu). 

A.8. Program settings 

Global program settings are available via the Settings submenu. 
 

  
 

- Settings → Show RCL: to change the coordinate system from XYZ (right-handed Cartesian 
coordinate system, using axes X, Y en Z) to RCL (coordinate system using rows, columns 
and layers – as defined in the initial version of VOLTRA). 
The XYZ system is the default system for new VOLTRA data (from File → New). 

 Settings → Show XYZ: to change the coordinate system from RCL to XYZ. 
- Settings → Thermal Palette…: to select the thermal palette used to visualize the 

temperature gradient in the solution. 
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The user can choose between the traditional Physibel ‘Rainbow’ thermal colour palette, or 

the ‘Ironbow’ thermal colour palette, which is often used by IR camera’s. 

   
- Settings → Drag Mode...: to define how the view of an object (in the Image window or the 

Graphic Output window) changes as a result of a rotate or pan command (using the 

mouse or an arrow key). 

 
”Drag object” moves the viewpoint position with respect to the object. ”Drag viewpoint” 

moves the object with respect to the viewpoint. 

The selected drag mode is saved in the program parameter file (see A.9). 
- Settings → Zoom Factor…: to customise the zooming factor of the mouse scroll wheel. The 

selected zoom factor is saved in the program parameter file (see A.9). 

 
- Settings → Default Standard…: set EN ISO 10077-2, EN ISO 6946 or NIHIL as default 

standard for the definition of colour types. 

 
 

- Settings → Toolbar: presence of the toolbar giving access to menu commands through 
icons. 

- Settings → Status Bar: presence of the status bar at the bottom of the VOLTRA application 
window, containing context depending information. 

- Settings → Language: the selected language (English, Dutch, French, German) becomes 
effective the next time the program is started. 

A.9. General editing commands 

Copy – paste 
- Edit → Copy Value: copies the value from the active input cell into the clipboard. 

- Edit → Paste Value: copies the value from the clipboard into the active input cell. 
 

Undo – redo 

- Edit → Undo 

Undoes the last edit action (e.g. to cancel a mistake). 
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This command can be repeated to undo more previous edit actions. 

Only the last 100 edit actions are stored for undo. 
The undo command is impossible after saving a file, closing the current file or starting a 
calculation. 

- Edit → Redo 

Restores the previous edit action that was made undone using Edit → Undo. 
In other words: "redo" undoes "undo". 
This command can be repeated to restore more edit actions that were made undone. 

A.10. Program parameters 

The global default values (calculation parameters, output parameters, interface language, 

graphic report definition, grid unit etc.) are saved in the file VOLTRA.prm in the application data 
folder (C:/Users/username/Appdata/Roaming/Physibel/VOLTRA9). When the program VOLTRA is 
started, the program parameters are loaded from the parameter file. 
 
The program parameter default values can be changed from several input dialog boxes. When 
the button “Set As Default” in an input dialog box is clicked, the corresponding program 
parameters are saved in the program parameter file VOLTRA.prm at exiting VOLTRA. 
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CHAPTER B INPUT DATA 

B.1. VOLTRA start up 

When VOLTRA is launched, the parameter file VOLTRA.prm is read (see A.10) to load global 
program settings. 
Then the colour database ColourDatabase.vtr is read (see G.2) to initialise material and surface 

boundary condition properties of the Colours window. 

There is no visual feedback in the initial screen of VOLTRA to indicate if VOLTRA.prm and/or 

ColourDatabase.vtr are not found and thus not read. 

B.2. File commands 

 
 
File → New… 
Opens a new project, after closing the current project (if present). The new project starts off with 
a single cubic block with sides equal to the grid unit (see B.6.3). 
All parameters are reset to their default values (as stored in the parameter file TRISCO.prm), 
except for the colour definitions. This allows to reuse the colour definitions of the previous open 
file. 
 

File → Open… 
Opens an existing VTR, TRC or TR2 file by selecting it in the File Open dialog box. When a file is 

opened, all parameters are reset to their default values (as stored in the parameter file 
TRISCO.prm), except for the colour definitions. This allows to reuse the colour definitions of the 
previous open file (cf. File → New). Then all data from the chosen TRISCO data file are read and 
loaded into memory. Colour definitions that are not present in the data file, remain untouched. 
 
File → Open Colour Database… 

The colour database contains predefined material and boundary condition properties (stored in 

the file ColourDatabase.vtr in the application data folder, see G.2), which is loaded at every 
VOLTRA start-up (see B.1). It is advisable to add frequently used materials and boundary 
conditions to the colour database. 
These predefined colours of the colour database are then available for new colours in any 
document. 
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File → Import Data… 

This command allows to create a new VOLTRA data file starting from a BISTRA data file, a BISCO 
data file, or a bitmap. 
Choose the wanted file type in the File Open dialog box. 
 

BSC files and BST files contain a link to a bitmap file (256 colours BMP file). The bitmap is 
extruded (to get a third dimension) and converted into a list of blocks defined in a minimum grid 
(i.e. having grid planes only at pixel changes in the bitmap). The grid unit corresponds to the pixel 
size of the bitmap, as determined in BISCO or BISTRA. The bitmap can be set in XY, XZ or YZ. The 
third dimension is made of 1 grid mesh, the size of which is a user input (Object depth). 
The grid unit, object width and height are read from the BISCO or BISTRA data file and shown for 

information. 
 

 
 

The new blocks can use either superposition (with possible overlaps of blocks, which normally 
minimises the number of blocks) or juxtaposition (without any overlap of blocks), dependent on 
the user’s answer to the prompt “Use superposition of blocks?”. 
The thermal properties of the colours in the bitmap are copied from the data in the BSC or BST 
file. 
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When a BISTRA data file (with extension .bst) is imported, the report definition is not read and 

must thus be redefined in VOLTRA (see B.24). The north orientation (see B.18.1) or fixed sun 
position (see B.18.2) is read, though in the former case the angles defined in BISTRA cannot 
always be converted to the angle definitions in VOLTRA. In this case a warning message is shown 
prompting the user to redefine the north orientation. 

B.3. VOLTRA program layout and input windows 

The input in VOLTRA is organised in several windows. When a VOLTRA document is opened, the 
following windows are opened: 

- Image window (top left) with a graphical representation of the model. In this window the 
object can be interactively rotated and zoomed in. 

- The Grid window, with the distances between the successive grid planes in three 

dimensions. 

- The Blocks window, with a list of all building blocks of the geometry. 

All coordinates refer to the grid numbers in the Grid window. 

- The Colours window, with the thermal data of all materials and surface boundary 

conditions. Each block in the Blocks window refers to a colour in the Colours window. 

 
A window can be activated by clicking with the left mouse button on its title bar or in its client 
area (when the window is already open and visible on the screen), or the window can be opened 
and activated by selecting the corresponding command in the Edit submenu. 

 
Upper part of Edit submenu 

   
 

Other input windows are: 

- The Coordinates window, to view the absolute coordinates of the grid planes (which are 
orthogonal to the coordinate axes). 

- The Minimum Grid window, for the definition of minimum grid mesh widths. 

- The Node BCs window, for the definition of node boundary conditions. 
- The Borderface BCs window, for the definition of boundary conditions in border faces 

between two colours (fixed or time-dependent temperature or heat flux). 
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- The Material BCs window, for the definition of boundary conditions inside material colours 

(fixed or time-dependent temperature or volumetric heat power density). 

- Ventilation Flows window with ventilation flow paths. 

- Functions window with functions. 

- The Clip Object window, for the definition of cut-off planes to get a clipped detail (of the 

total object) in the Image window. 

- The Clip Colours window, for the definition of colours to cut away in the Image window. 

- The Sun Obstacles window with definition of obstacles around the model. 

- The Report Definition window with selection of reported outputs. 

- The Output Nodes window with coordinates of the nodes for which a time-dependent 

output is required, or which are used as sensor points in controls. 

- The Output Blocks window with coordinates of the blocks for which the time-dependent 

conduction heat flowing through its faces is to be reported. 

- The Controls window, for the definition of a temperature control (heating or cooling). 

B.4. Document notes  

In the Notes dialog box (via Edit → Notes… ) some comments can be written for the current 
document, e.g. project description, operator, date. These notes are saved in the VTR file. 
 

 

B.5. Grid window 

Menu command: Edit → Grid 

The Grid window is the input window for grid mesh sizes of a rectangular 3D grid. 

 

   
 

The grid 
The three orthogonal directions of the grid correspond to the axes of the coordinate system. 

This is either XYZ (a right-handed Cartesian coordinate system) or RCL (consisting of rows, 
columns and layers, as in a 3D matrix). Use the commands Settings → Show XYZ and Settings → 
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Show RCL to switch between both systems (see A.8). Always choose the Z axis (or the layer 

direction) along the physical vertical direction (because otherwise the function Image → Rotate 
works unnaturally). 
The positions of the object blocks (cf. section B.8) are expressed in integer numbers referring to 
the sequence numbers of the grid planes in the three main directions. 

- In XYZ the grid plane positions are numbered 0,1,2,… 
- In RCL the grid plane positions are numbered 1,3,5,… (the even numbers refer to space 

intervals between two consecutive grid planes). 
The intersection points of three orthogonal grid planes inside or at the surface of material blocks 
are nodes of the system with unknown temperature. 
 

Grid meshes 

The meshes, or distances between successive grid planes in any of the three axis directions, are 

editable in the Grid window. 

The background colours of the grid meshes editable in the Grid window alternate, indicating the 

underlying minimum grid (cf. section B.7). 
The grid unit is set in the dialog box opened with the command Grid → Grid Unit… (see B.6.3). 

B.6. Grid functions 

Lower part of Edit submenu 

 

Grid submenu 

 

B.6.1. Insert mesh 

- Edit → Insert Before 

Insert a new mesh (with size = 1 grid unit) before the active mesh. 

- Edit → Insert After 
Insert a new mesh (with size = 1 grid unit) after the active mesh. 

B.6.2. Grid mesh selections 

Individual grid meshes can be selected to perform global actions (split, merge). 
The selected meshes are marked in turquoise (light or dark dependent on the underlying 
minimum grid). 
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Meshes can be selected by clicking (left mouse button) the cell while holding the <Ctrl> key. A 
selection range can be defined by holding the <Shift> key. All meshes within the same column ΔX 

or ΔY can by selected by clicking (left mouse button) the column header.  

Alternatively, menu functions can be used to select meshes.  

 
From the Edit submenu: 

- Edit → Switch Select 
Switch on/off the selection for the active mesh. 

- Edit → Switch Select Downward 

Switch on/off the selection of the active mesh and all next meshes (on the same axis) with 
equal selection mode. 

- Edit → Switch Select Upward 

Switch on/off the selection of the active mesh and all previous meshes (on the same axis) 
with equal selection mode. 

- Edit → Select All 
Select all meshes on the same axis as the active mesh. 

- Edit → Deselect All  
Deselect all meshes (on all three axes). 

From the Grid submenu: 

- Grid → Select All (3x) 
Select all meshes (on all three axes). 

B.6.3. Grid unit 

Menu command: Grid → Grid Unit… 

 

    
 

The grid unit can be set in the dialog box. When the unit is altered, the user has the option to 
transform the grid widths, i.e. to keep the same physical dimensions of the model, or to keep the 
grid widths and thus scale the model according to the change in grid unit. 
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B.6.4. Create minimum grid 

Menu command: Grid → Create Minimum Grid… 

 

 
 

Creates a minimum grid in the indicated directions. 
All grid coordinates (and grid meshes) are rounded off to three decimal places. 

The meshes of the minimum grid only pass through borders of blocks (as defined in the Blocks 

window) and points in which node boundary conditions are defined (in the Node BCs window). 
 

The functions Blocks → Transform Coordinates… and Blocks → Insert File… (see B.8) automatically 
create a minimum grid in all three axis directions. 

B.6.5. Split (selected) mesh(es) 

Menu command: Grid → Split... 

 
Split either the selected meshes or the active mesh (when no selection is defined) into smaller 
parts according to the given method. 

Method: Geometric 

Each mesh is split into the specified number of subdivisions using a geometric series (i.e. a series 
with a constant ratio between successive terms) with specified split ratio. 

- When the split ratio = 1, then all created submeshes are equal. 
- When the split ratio < 1, then the submeshes have decreasing mesh widths. 
- When the split ratio > 1, then the submeshes have increasing mesh widths. 
A negative or zero split ratio is not allowed. 

 
Method: Maximum 

All submeshes have a constant mesh width (as defined by the parameter Mesh width in the 
dialog box), except for the last submesh, for which the width equals the remainder after division. 

This last submesh can however never be smaller than 0.1 % of the maximum mesh width. 
 
Method: Border 1 
Each mesh is split into two parts, when the original mesh size is greater than the given mesh 
width (parameter Mesh width in dialog box). The first submesh (border 1) gets the size of the 

given mesh width, the second submesh gets the size of the remainder. 
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Method: Border 2 

Each mesh is split into two parts, when the original mesh size is greater than the given mesh 
width (parameter Mesh width in dialog box). The second submesh (border 2) gets the size of the 

given mesh width, the first submesh gets the size of the remainder. 
 
Method: Border 1 & 2 

Calls successively: split using border 2, then split using border 1. 
So each mesh is split into three parts (when the original mesh size is large enough): both outer 
submeshes get the size of the given mesh width, the middle submesh gets the size of the 
remainder. 

B.6.6. Auto split 

Menu command: Grid → Auto Split… 

 

 
 

Split all meshes in the specified directions (X, Y, Z) into smaller parts. 

For originally smaller meshes (up to a given mesh size), the mesh is split into submeshes having a 
given split distance, and possibly a last submesh with width equal to the remainder after division 

(cf. Method: Maximum in section B.6.5). 

The other (larger) meshes are split using a geometric subdivision using a given split ratio (cf. 
Method: Geometric in section B.6.5) starting with the split distance used for smaller meshes at 
both ends of the original mesh. 

The function “Auto Split” is intended to achieve a reliable grid refinement suitable for calculation 
using only one function call (with well-chosen parameters in the dialog box) starting from the 
minimum grid. 

B.6.7. Merge selected meshes 

Menu command: Grid → Merge 

Merge each group of consecutive selected meshes into larger meshes (which width equals the 
sum of the widths of the original meshes). Meshes at both sides of a block border (or a node BC) 
cannot be merged. The grid planes of the minimum grid are always preserved. 

B.7. Minimum Grid window 

Menu command: Edit → Minimum Grid 

The Minimum Grid window shows the meshes of the minimum grid (through block borders and 

node BCs) without touching the actual grid (defined in the Grid window). This is thus not to be 
confused with creating a minimum grid (see B.6.4). 
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When a mesh size in the Minimum Grid window is edited, all underlying meshes of the Grid 

window are resized proportionally. 

B.8. Blocks window 

Menu command: Edit → Blocks 

 

 
 

 
 

The object geometry is defined by blocks in the Blocks window. 

 

Each block has the following parameters: 
 

Colour number (between 0 and 255) referring to the Colours window. 

The parameter “type” in the Colours window determines whether the block is massive or hollow. 
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- A material block (colour type MATERIAL, EQUIMAT or TRANSMAT) is massive and is 

added to the object geometry. 

- A boundary condition block (colour type BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY or 
BC_NOSKY) is hollow and is subtracted from the object geometry. 
 

6 coordinates of block borders (i.e. minimum and maximum coordinate per axis). 

The coordinates are grid plane numbers, which positions are defined in the Grid window. 
In the coordinate system XYZ the grid plane numbers are integers starting from 0. 
In the coordinate system RCL the grid plane numbers are odd numbers starting from 1. 
The background colour is light red, light green or light blue for a material block, and white for a 
boundary condition block. 

 

The size of the active block (width x depth x height) is visible in the status bar. 
 
Blocks with higher sequence number have priority over (i.e. overwrite the common parts of) 
blocks with lower sequence number. This is called the superposition rule. 

B.9. Block functions 

Lower part of Edit submenu 

 

Blocks submenu 

 

B.9.1. Insert block 

- Edit → Insert Before 

Insert a new block before the active block. 

- Edit → Insert After 
Insert a new block after the active block. 

 

The new block gets the following initial values: 
- The colour of the last edited block colour. 
- Block coordinates: 

o In XYZ: Xmin = 0, Xmax = 1, Ymin = 0, Ymax = 1, Zmin = 0, Zmax = 1. 
o In RCL: Rmin = 1, Rmax = 3, Cmin = 1, Cmax = 3, Lmin = 1, Lmax = 3. 
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B.9.2. Block selections 

 
 

Individual blocks can be selected to perform global actions (delete, copy, move, transform). 
The selected blocks are marked in (light or dark) turquoise. 
Blocks can be selected by clicking (left mouse button) the row number. Holding the <Shift> and 
<Ctrl> keys, a selection range can be defined.  
Alternatively, menu functions can be used to select blocks. 
 

Block selection functions: 

- Edit → Switch Select 

Switch on/off the selection for the active block. 

- Edit → Switch Select Downward 

Switch on/off the selection of the active block and all next blocks with equal selection 

mode. 

- Edit → Switch Select Upward 

Switch on/off the selection of the active block and all previous blocks with equal selection 
mode. 

- Edit → Select All 
Select all blocks. 

- Edit → Deselect All 
Deselect all blocks. 

 

A useful function to make block selections is the view option: 

- Blocks → List Same Colour 

This function only shows in the Blocks window all blocks having the same colour as the 

active block. 
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o The block sequence numbers are the original sequence numbers (as in the normal 

view option Blocks → List All). 
o The colour number cannot be edited. 
o The block coordinates can be edited. 
o Block selection is possible (but restricted to the displayed blocks, e.g. for Edit → 

Select All). 
o All other block functions are disabled. 

To enable these functions again, return to Blocks → List All. (All active block 
selections remain preserved.) 
 

- Blocks → List All 
List all blocks again, to terminate the view option Blocks → List Same Colour. 

B.9.3. Delete, copy, move 

The following functions have no effect on the active grid (as defined in the Grid window). 
 

- Edit → Delete 

Delete selected block(s), otherwise (in absence of a block selection) delete the active block. 
 

- Blocks → Copy After 

Copy selected block(s) to a new position in the blocks list. 
If there is no block selection, the active block is copied after itself. 

If there is a block selection, the selected blocks are copied immediately after the active 
block. 
After the copy operation the copied blocks become the new block selection. 

 

- Blocks → Move Selection Before 

Move selected block(s) to a new position in the blocks list. 
If there is no block selection, this function is disabled 
If there is a block selection, the selected blocks are moved immediately before the active 
block. 
After the move operation the selected blocks remain selected. 

 

- Blocks → Move Selection After 
Move selected block(s) to a new position in the blocks list. 

If there is no block selection, this function is disabled 
If there is a block selection, the selected blocks are moved immediately after the active 
block. 
After the move operation the selected blocks remain selected. 

B.9.4. Transform; insert file 

The following functions create new coordinates, and so have an effect on the current grid. 

After the block operation, a minimum grid is automatically created (with grid planes through the 
block borders). 
 

- Blocks → Transform Coordinates… 

Transform selected block(s), otherwise (in absence of a block selection) transform the 
active block. 
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There are three types of transformations: 

− Translation: over a given translation vector. 
− Rotation: over a right angle (90°, 180° or 270°) around a rotation axis parallel to X, Y or 

Z through the current origin (Coord → Set Origin, see C.12). 
− Scaling: using given scaling factors. 

The origin (Coord → Set Origin, see C.12) is the centre of the scaling. 
A mirror transformation is possible using a negative scaling factor. 
E.g. mirror X corresponds to the scaling factors –1, 1, 1. 
 

- Blocks → Insert File… 

The blocks of a VOLTRA or TRISCO data file (extensions .vtr or .trc) are inserted after the 

active block. 
The new blocks are positioned from the current origin (Coord → Set Origin, see C.12). 

Colour definitions for not yet present colours (in the Colours window) are also read from 

the imported data file. 
After the operation the inserted blocks are selected. 

B.9.5. Revolve 

Menu command: Blocks → Revolve 90°… 

Only enabled for a 2D geometry (i.e. with only 1 mesh in X, Y or Z). 
 

Turns the 2D geometry around an axis parallel to X, Y or Z over 90° to form a 3D corner joint with 

the 2D geometry as profile section. This corresponds to a rectangular revolution around the axis. 
The axis lies at the negative or positive end of the bounding box of the 2D geometry (specified as 

axis position X- or X+, Y- or Y+, Z- or Z+ in the dialog box). 
The grid is extended in the third dimension (with originally 1 mesh) as a copy of the grid meshes in 
the direction perpendicular to the axis of revolution. 
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B.9.6. Arrange blocks 

Menu command: Blocks → Arrange Blocks… 

 

 
 

This function recalculates the list of blocks in the Blocks window based on the final object 

geometry and boundary conditions geometry in the Image window (viewed with Image → Show 

Materials and Image → Show BCs). The grid data in the Grid window remain unchanged. 

The blocks are generated using an algorithm that tries to minimise the number of blocks. 
The new list of blocks may be longer than the original list of blocks. 
There are two options: 

- Superposition of blocks: with possible overlaps of successive blocks in order to minimise 
the number of new blocks. 

- Juxtapostion of blocks: all new blocks are positioned adjacent to one another, without any 

overlaps of blocks. 

B.9.7. Reduce blocks to clipped object and colours 

Menu command: Blocks → Reduce to Clip… 

 

 
 

The answer “No” cancels the operation. “Yes” confirms the operation. 

The blocks are recalculated (using block arrangement with superposition; cf. section B.9.6) for the 

object and boundary condition geometry (as visible in the Image window) restricted to the active 
object clipping (cf. section C.10) and colours clipping (cf. section C.11). 
Afterwards clip object and clip colours are reset. 
A minimum grid is automatically created (with grid planes through the new block borders). 
The node boundary conditions, borderface boundary conditions, material boundary conditions, 

areas in Areas window, and U values in U Values window are cleared. 

B.9.8. Detect void (adiabatic) spaces within object 

Menu command: Blocks → Convert Void to Blocks… 

This function is only enabled if there are void spaces (not covered by object or boundary 

condition blocks) present in the 3D grid space. Void spaces are not directly visible in the Image 

window. Void spaces should normally be avoided in the grid space, because they imply implicitly 

adiabatic boundary conditions for all adjacent object surfaces. 
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This function allows to make them visible in the Image window and convert the voids to blocks 

with a certain colour number. 
It is advisable to choose a colour number not yet present in the model (B.11.1). 
 

 
 

All void spaces in the 3D grid space are converted to blocks having the chosen (new) colour 

number. All blocks are then recalculated using block arrangement with superposition (cf. section 

B.9.6). If the active cell is moved to the new colour in the Colours window (use type = MATERIAL), 

the outline of the void spaces becomes visible in the Image window. 

B.9.9. Redefine colour globally 

Menu command: Blocks → Change Colour… 

 

 
 

All blocks having the same colour number as the active block (with the active cell in the Blocks 

window) get a new colour number (as defined in the dialog box). 

B.10. Colours window 

Menu command: Edit → Colours 

 

 
 

The Colours window defines of the colours associated to the blocks in the Blocks window. 
Via the colours the thermal properties of the blocks are set. 

B.10.1. Colour number 

Each colour is identified by a colour number or colour index: an integer between 0 and 255. 
Thus a maximum of 256 colours can occur in a TRISCO data file. 
 

The fill colour belonging to each colour number can be changed. Position the active cell 
(surrounded by thick black lines) onto the second column (showing the actual colour), and double 
click (with the left mouse button) or press Enter. Choose a new colour in the standard Colour 
dialog box. 
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When VOLTRA is started up, the default colour values are loaded from the file MatColor.rgb. 
This file contains the red, green and blue components (as numbers between 0 and 255) for all 

256 colour numbers. 
The (edited) colours for a specific VOLTRA data file are stored in the file data (as RGB values), and 
are automatically loaded when the file is read. 

B.10.2. Colour type 

Each colour stands for a material or a surface boundary condition dependent on the colour type. 

 
The following types are always available (with or without the RADCON module): 

- MATERIAL: material defined by thermal conductivity. 
- EQUIMAT: equivalent material defined by a single equivalent thermal conductivity (e.g. 

air cavity). The equivalent conductivity is typically calculated from standard rules (D.1.1). 

- BC_SIMPL: simplified surface boundary condition, defined by a global surface heat 
transfer coefficient (for combined convection and radiation), environmental temperature 

and possible additional surface heat flux. 

- BC_FRE_S: enclosure with unknown (free-floating) internal temperature, possible 
additional internal heat power, simplified surface heat transfer defined by a global 

surface heat transfer coefficient and possible additional surface heat flux. 
 

With the RADCON module (which supposes separate convection and radiation based on view 
factors, see Chapter I) also: 

- BC_FREE: surface boundary condition modelled as enclosure with unknown (free-

floating) air temperature, radiation between the surfaces (using the infrared emissivities of 
the adjacent materials) and convective heat transfer coefficient. 

- BC_SKY: surface boundary condition modelled as an environment with defined air and 

radiation temperature (the sky) and convective heat transfer coefficient. 
- BC_NOSKY: surface boundary condition modelled as an environment with defined air 

temperature, no radiation to the environment (no sky) and convective heat transfer 
coefficient. 

- TRANSMAT: transparent material defined by thermal conductivity, and radiation between 
the surfaces (using the infrared emissivities of the adjacent materials). 
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B.10.3. Standard (last column) 

Standard used for the automatic calculation of eq or hc (cf. section D.1). 
- NIHIL: no automatic calculation of thermal properties. 
- EN10077: standard EN ISO 10077-2. 
- EN6946: standard EN ISO 6946. 

Within each standard different subtypes can be chosen. 

 

B.10.4. Colour subtype 

Subtype toggle value to define automatic calculation of equivalent thermal conductivity (type 
EQUIMAT and TRANSMAT) or convective heat transfer coefficient (BC_FREE, BC_SKY and 
BC_NOSKY). The accessible subtypes are dependent on the actual type (3rd column) and 
standard (last column). 
For type EQUIMAT: 

- NIHIL: user defined thermal conductivity (no automatic calculation). 

- CAVITY: calculated equivalent thermal conductivity for unventilated air cavity (EN10077 or 
EN6946). 

- CAVITY_E: calculated equivalent thermal conductivity for slightly ventilated air cavity 
(EN10077). 

- LAYER: calculated equivalent thermal conductivity for unventilated air layer (EN6946). 
For type BC_SIMPL: 

- NIHIL: user defined global heat surface coefficient. 
- HI_NORML: normal internal heat transfer (EN10077). 
- HI_REDUC: reduced internal heat transfer (EN10077). 

- HI: internal heat transfer (EN6946). 
- HE: external heat transfer (EN10077 or EN6946). 
- HI_CAV_E: slightly ventilated air cavity at the internal surface (EN10077 – radiosity 

method). 
- HE_CAV_E: slightly ventilated air cavity at the external surface (EN10077 – radiosity 

method). 

For type BC_FREE: 
- NIHIL: user defined convective heat transfer coefficient (no automatic calculation). 
- CAVITY: calculated convective heat transfer coefficient for unventilated air cavity. 
- CONVEC: calculated convective heat transfer coefficient for large air space. 

For type BC_SKY or BC_NOSKY: 
- NIHIL: user defined convective heat transfer coefficient (no automatic calculation). 
- CONVEC: calculated convective heat transfer coefficient for natural convection. 

For type TRANSMAT: 
- NIHIL: user defined thermal conductivity (no automatic calculation). 
- CAVITY: calculated equivalent thermal conductivity for unventilated air cavity. 

For more details on the corresponding calculation procedures see D.1. 

B.10.5. Colour physical heat flow direction 

Heat flow direction with reference to the physical reality: 
- HOR: horizontal heat flow. 
- UP: upward heat flow. 

- DOWN: downward heat flow. 
- ANY: user-defined heat flow direction (by defining the inclination angle of the construction 

element and assuming a heat flow perpendicular to the construction element) 
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B.10.6. Colour geometric heat flow direction 

Heat flow direction with reference to the grid XYZ coordinate system (see B.5): 
- X: heat flow parallel to the X axis. 
- Y: heat flow parallel to the Y axis. 
- Z: heat flow parallel to the Z axis. 
- Xy: heat flow parallel to the X axis and cavity width parallel to the Y axis. 

- Xz: heat flow parallel to the X axis and cavity width parallel to the Z axis. 
- Yx: heat flow parallel to the Y axis and cavity width parallel to the X axis. 
- Yz: heat flow parallel to the Y axis and cavity width parallel to the Z axis. 
- Zx: heat flow parallel to the Z axis and cavity width parallel to the X axis. 
- Zy: heat flow parallel to the Z axis and cavity width parallel to the Y axis. 

B.10.7. Colour name 

Enter a name for the material or boundary condition. The name should not exceed 25 characters. 
The status bar shows the volume of all blocks having this colour. 

B.10.8. Physical properties 

The relevant thermal properties for each colour type (that are used in a calculation) are shown in 

the Colours window. Values on a white background can be edited. Values on a yellow 
background are automatically calculated. Empty cells refer to irrelevant properties for the active 

colour type. 
 
Thermal properties: 

- ε1 / ε2 [- / -]: infrared emissivities (values between 0.001 and 1) at warm and cold sides of 

cavity (type EQUIMAT). 
Editing opens a dialog box for definition of the values. 

 

  
 
If any emissivity differs from 0.9 (the default value), the corresponding grid cell in the 

Colours window is highlighted in blue. 
- λ [W/(m.K)]: thermal conductivity of material (MATERIAL), equivalent material (EQUIMAT) 

or transparent material (TRANSMAT). 
- ε [-]: infrared emissivity (value between 0 and 1) of material surfaces (MATERIAL, 

EQUIMAT) adjacent to boundary condition or cavity with radiative heat transfer. 
- ρ [kg/m3]: density of material (MATERIAL), equivalent material (EQUIMAT), transparent 

material (TRANSMAT) or enclosure (BC_FREE and BC_FRE_S). 
- c [J/(kg.K)]: specific heat of material (MATERIAL), equivalent material (EQUIMAT), 

transparent material (TRANSMAT) or enclosure (BC_FREE and BC_FRE_S). 
- θ [°C]: temperature of simplified boundary condition (BC_SIMPL). 

- h [W/(m2.K)]: global surface heat transfer coefficient (BC_SIMPL, BC_FRE_S). 
- q [W/m2]: heat flux dissipated onto adjacent material surfaces (BC_SIMPL, BC_FRE_S, 

BC_FREE, BC_SKY, BC_NOSKY). 
- θa [°C]: air temperature (BC_SKY, BC_NOSKY). 

- hc [W/(m2.K)]: convective heat transfer coefficient (BC_FREE, BC_SKY, BC_NOSKY). 
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- Pc [W]: convective power dissipated in the environment (BC_FRE_S, BC_FREE). 
- θr [°C]: radiation temperature (BC_SKY). 

 
Solar data (four columns with header Sun, ρs, Specular and s): 

− Sun: sun active status (YES or NO) to define a solar zone, for a colour of type BC_SIMPL or 
BC_SKY. 

− ρs [-]: solar reflection factor (for a colour of type MATERIAL), a constant value (between 0 

and 1), or a function reference (R##) when the solar reflection factor is a function of the 
angle of incidence (see also section B.12.2). See D.9.1 for a detailed explanation of the 
definition of ρs. 

− s [-]: solar transmission factor (for a colour of type MATERIAL), a number between 0 and 1 
representing the resulting transmission factor – after reflection - of the MATERIAL layer 

and all transparent material layers (MATERIAL or EQUIMAT) behind it until another zone or 

an opaque material (s equals 0) is reached. See D.9.1 for a detailed explanation of the 
definition of s. 

 
The properties λ, c, θ, h, q, θa, hc, Pc, θr and ρs can each either have a constant value (as in 

TRISCO) or refer to a function (defined in the Functions window) via the function reference name: 
L## (for λ), C## (for c), T## (for θ, θa, θr), H## (for h, hc), I## (for q), P## (for Pc), R## (for s). 

B.11. Colour functions 

The colour functions are available through the Colours submenu. 

 

  
 

B.11.1. List colours 

Colours → List All 
List all available 256 colours. 

The edit fields for colour numbers not referenced from the Blocks window are disabled (grey 

text). 

The list is useful in choosing new colour numbers for blocks in the Blocks window. 
 

Colours → List Defined 
List all defined colours. 

This option displays besides all present colours (i.e. referenced from the Blocks window), the 

colour definitions from the colour database and from files previously opened in the current 

VOLTRA session, which are still present in memory. 

The edit fields for colour numbers not referenced from the Blocks window are disabled (grey 

text). 
 
Colours → List Present 

List all colours referenced from the Blocks window. 

This is the default setting when a new project file is opened.  
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B.11.2. Load material properties 

Menu command: Colours → Load Material... 
 

The Material Database dialog box allows to select a material from a group of materials in a 
selected database. 

The available databases contain the thermal conductivities of different materials according to 
several European standards, and are stored in the files with extension .phm in the data folder 
...\Physibel\Materials (see A.6). The files can be edited using the program MatEdit.exe in the 
same folder. 
 

After selecting a material and pressing the OK button, the corresponding properties are loaded 
for the active colour number. 
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B.11.3. Split zones 

Menu command: Colours → Split Zones… 

(Only enabled from the active Colours window) 

 

Split all blocks of the active colour (i.e. where the cursor is located in the Colours window) into 

blocks of different new colours, so that each new colour represents a single zone (i.e. united and 
not separated by any other colour). 
The first new colour must be entered in the dialog box. 

 

 
 

Only colours not yet present in the Colours window are used. 
The new colours get the thermal properties from the original active colour. 
The original active colour is not reused as new colour. 

A warning appears when there are not enough free colours for all zones. 
The function is useful for colours (e.g. of type BC_FRE_S, BC_FREE, TRANSMAT) which require 
single-zone colours to be valid in the calculation model. 

B.11.4. Copy - paste 

The functions Colours → Copy Row and Colours → Paste Row allow to copy all properties from 
one colour number to another colour number. 
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B.12. Functions window 

For the variable boundary conditions and material properties VOLTRA refers to functions: either 

an internal function (parameters defined in the Functions window), or an external function (data 
read from a file). 
 

All functions that are used in a VOLTRA data file, are defined in the Functions window, opened 
with the command Edit → Functions. 

The picture below shows an example of Functions window. 

 

  
 
Each function is uniquely defined by a function reference name: 
 

Reference Description Units Date file formats 

T01 up to T99 Temperature function [°C] *.fte, *.epw, *.csv 

H01 up to H99 Surface heat transfer coefficient function [W/(m².K)] *.fht 

P01 up to P99 Power function [W] *.ffh 

I01 up to I99 Imposed flux function 

(I01 is used in the Solar Data dialog box) 

[W/m²] *.fir 

G01 up to G99 Horizontal global solar radiation function 
(only G01 is used in the Solar Data dialog 
box) 

[W/m²] *.fsg, *.epw, *.csv 

D01 up to D99 Horizontal diffuse solar radiation function 

(only D01 is used in the Solar Data dialog 
box) 

[W/m²] *.fsd, *.epw, *.csv 

V01 up to V99 ventilation function [m³/s] *.fvr 

E01 up to E99 Emissivity function [-] *.fem 

M01 up to M99 thermal conductivity function  
(time-dependent) 

[W/(m.K)] *.fco 

L01 up to L99 thermal conductivity function  
(temperature dependent) 

[W/(m.K)] *.fla 

C01 up to C99 specific heat function 

(temperature dependent) 

[J/(kg.K)] *.fce 

R01 up to R99 solar reflection factor function 
(angular dependent) 

[-] *.frf 

S01 up to S99 Solar transmission factor function [-] *.ftr 

 

Function reference names can be used in: 

the Colours window (columns with header λ, ε, c, θ, h, q, θa, hc, Pc, θr, ρs, τs), 

the Node BCs window (columns with header θ and P), 

the Borderface BCs window (columns with header θ and q), 

the Material BCs window (columns with header θ and p) 

the Ventilation Flows window (column with header “Flow”), 

The Controls window (columns with header “θ target”, “Function from”, “Function to”). 
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Temperature functions (L## and C##) and solar reflection factor functions (R##) can only have 

type FILE (see B.12.2). 
 
All function values are used in VOLTRA as average values over the simulation time step, where 
the simulation time is understood as the middle of the simulation time step (see D.9.2). 

 
A new function can be inserted via Edit → Insert Row. 

The current function can be deleted via Edit → Delete Row. 

B.12.1. Internal time functions (types STEP0, STEP1, STEP2, SINE, and SINPOS) 

An internal time function is a built-in program function, defined by one or more parameters. 
VOLTRA contains 5 built-in function templates. 

 
The meaning of each parameter per function type is explained in the status bar (cf. figures 
below). 
All time parameters must be entered in minutes (e.g. 1 day = 24 h x 60 min/h = 1440 min). 
 

- STEP0 for a step function defined by 4 parameters (P1, P2, P3, P4) 

 
- STEP1 for a step function defined by 5 parameters (P1, P2, P3, P4, P5) 
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- STEP2 for a step function defined by 6 parameters (P1, P2, P3, P4, P5, P6) 

 
- SINE for a sine function, defined by 4 parameters (P1, P2, P3, P4) 

 
- SINPOS for a positive sine function, defined by 4 parameters (P1, P2, P3, P4) 
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B.12.2. External functions (type FILE) 

An external time function is defined in a separate data file, with extension: 
- .fte (temperature function) 
- .fht (surface heat transfer coefficient function) 
- .ffh (power function) 
- .fir (imposed flux function) 

- .fsg (horizontal global solar radiation function) 
- .fsd (horizontal diffuse solar radiation function) 
- .fvr (ventilation function) 
- .fco (time-dependent thermal conductivity function) 
- .fem (time-dependent emissivity) 
- .ftr (time-dependent solar transmission factor). 

The program FUNCEDIT (cf. Chapter H) allows to edit these files. 
 
External data as a source for an external time function can either be formatted as a linear 
function, or as a step function (see H.3).  
In case of a linear function format, function values at simulation times in between external data 
timestamps are obtained by simple linear interpolation between the external data timestamps.  
In case of a step function format, the values in the external data file are interpreted as the 

average value during the data interval preceding the external data timestamp and are thus 
assumed constant and equal to the value at the data interval’s end timestamp for any simulation 

times in between external data timestamps1. An exception is made for solar radiation functions 

(G## and D##), in which case external data formatted as a step function are converted to 
instantaneous values at simulation times using a mathematical algorithm (see D.9.2)2. For this 
algorithm to work, the simulation start time and time step have to be defined in such a way that 
the simulation hits the hours precisely (see D.2.1). 
 
Some material properties (thermal conductivity, specific heat, solar reflection factor) may be 
dependent on another property (temperature, angle of incidence). 
These temperature functions (thermal conductivity, specific heat) or angular functions (solar 
reflection factor) are defined in separate data files, with extension: 

- .fla (temperature dependent thermal conductivity function) 
- .fce (temperature dependent specific heat function) 

- .frf (angular dependent solar reflection factor function). 
These function data files are text files consisting of two or more text lines: 
 
 x0  y0 

 x1  y1 

 x2  y2 

 … 

 xn  yn 

 
with x0 ≤ x1 ≤ x2 ≤ … ≤ xn. 
Each text line consists of two float numbers, the abscissa (i.e. a temperature value or an angle of 
incidence) and the ordinate (i.e. the corresponding thermal conductivity, specific heat value or 

 
1 Note that in older versions of VOLTRA (v8.1 and before), step function formatted external data were 

interpreted differently, namely as the average value during the data interval following the external data 

timestamp and thus assumed constant and equal to the value at the data interval’s begin timestamp for 

any simulation times in between external data timestamps. 
2 This algorithm was not included in older versions VOLTRA (v8.1 and before). 
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solar reflection factor) of a characteristic point of the function. The function is linearly interpolated 

between the characteristic points. If x < x0, then y = y0. If x > xn, then y = yn. 
The user can define these functions with a text editor (e.g. Windows Notepad). 
 
When the function filename field is double clicked (or when Enter is pressed), a file path can be 

chosen in the Open dialog box. If the external files are stored in the same directory (or a 
subdirectory of this directory) as the VOLTRA data file, the file paths are relative (so that copying 
of the .vtr file together with the function files to another directory has the desired result that the 
new .vtr file refers to the function files in the same new data directory). If the external files are not 
stored in the same directory as the VOLTRA data file, the absolute file paths are saved in the .vtr 
file. 

B.12.3. Weather data files (types EPW and TMY3) 

A weather data file is a data file containing observations of weather variables such as 
temperature, relative humidity, solar radiation, wind speed, etc. for a specific location. Two 
different data file formats can be imported into BISTRA: EPW or EnergyPlus Weather (extension 
.epw), and TMY3 or Typical Meteorological Year (extension .csv). 
 
The weather data files can only be used as functions in VOLTRA if they (i) contain data for a 

complete year, (ii) are defined in local time (not solar time), (iii) do not contain lines with more 
than 512 characters, and (iv) start at hour 1 after midnight, January 1st.3 
Weather data files can be used as source for the functions: 

- Temperature (T##): the dry-bulb temperature of the weather file is read and interpreted 
as instantaneous values occurring at the timestamps denoted in the weather data file. 

- Global horizontal radiation (G##): the total horizontal radiation is read and interpreted as 
the total amount of radiation (Wh/m²) received in the interval preceding each timestamp. 

- Horizontal diffuse radiation (D##): the diffuse horizontal radiation is read and interpreted 
as the total amount of diffuse radiation (Wh/m²) received in the interval preceding each 
timestamp. 

 
The temperature values from the weather data file are linearly interpolated between the 
instantaneous values occurring at the data file timestamps. The radiation values from the 
weather data file are converted to instantaneous values at simulation times using a mathematical 
algorithm (see D.9.2). For this algorithm to work, the simulation start time and time step have to 
be defined in such a way that the simulation hits the hours precisely (see D.2.1). 
 
If function G01 for global horizontal radiation is a weather data file, the geographical location is 
automatically read and used in the solar processor (see B.18.1). 

 
When the function filename field is double clicked (or when Enter is pressed), a file path can be 
chosen in the Open dialog box. 
If the weather data files are stored in the same directory (or a subdirectory of this directory) as 
the VOLTRA data file, the file paths are relative (so that copying of the .vtr file together with the 

weather data files to another directory has the desired result that the new .vtr file refers to the 

weather data files in the same new data directory). If the weather data files are not stored in the 
same directory as the VOLTRA data file, the absolute file paths are saved in the .vtr file. 

 
3 In case the simulation start time is hour 0 (midnight), January 1st, the values from the weather data file for 

hour 1 are copied for hour 0. 
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B.13. Function Graph window 

The Function Graph window shows a graph of the current function in the Functions window. 

The Function Graph window is automatically opened when the Functions window is activated, 

and automatically closed when another window is activated (e.g. Measures window or Colours 

window). 

 
Zoom functions (via the Zoom submenu) allow to view function details. 
 
The quantities defined by the X axis (time, temperature, angle of incidence) and Y axis 
(temperature, surface heat transfer coefficient, flux, power, lambda, emissivity, specific heat, solar 

transmission factor, solar reflection factor) are determined by the current function in the Functions 

window. 
The origin of the X axis of a time function (i.e. time = 0) corresponds to the calculation start time, 
as defined in the Calculation Parameters dialog box. 

 
In case of solar radiation functions (G## and D##) using an external data file with data 
formatted as a step function (B.12.2) or a weather file (B.12.3) the source data are visualised in the 

Function Graph window, not the converted function values used in the simulation (see D.9.2). 

B.14. Function commands 

The X and Y axis tick marks and labels from the graph shown in the Function Graph window can 

be redefined via the commands Functions → X Scale… and Functions → Y Scale….  
 

  
 
The scope of the time scale on the X axis can be chosen between fixed values, function scope 
(corresponding to the definition of the function) and calculation time (corresponding to the 
calculation duration as defined in the Calculation Parameters dialog box). 
When fixed values are chosen, the minimum and maximum value (with plus or minus sign), and 
the major and minor tick distances can be set. Also the label unit can be chosen (seconds, 

minutes, hours or days). 
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B.15. Node BCs window 

Menu command: Edit → Node BCs 

 

 
 

A node boundary condition (“node BC”) is a grid node inside the object (defined by three grid 
number coordinates) with either a temperature value (type TEMP) or a heat power (type 

POWER). Both can be a numeric value (for a constant property) or can refer to a function 

(defined in the Functions window), T## or P##. 

Add a new node BC using Edit → Insert Before or Edit → Insert After. 

Delete a node BC using Edit → Delete. 

B.16. Borderface BCs window 

Menu command: Edit → Borderface BCs 

 

 
 

A border face boundary condition (“borderface BC”) imposes either a temperature (type TEMP) 
or a heat flux (type FLUX) in all interfaces between object blocks (in the final object composition 

as shown in the Image window) having different fixed colours. 

The position of the interfaces for the active borderface BC is highlighted in the Image window (if 

the option Image → Hide Outline is not active). 
 

Edit fields 
- Col.1: colour number (between 0 and 255) of object blocks at one side of the interface. 
- Col.2: colour number (between 0 and 255) of object blocks at the other side of the 

interface. 
- Type: TEMP or FLUX. 
- θ: temperature (in °C), numeric value (for a constant property) or can refer to a function 

T## (defined in the Functions window). 

- q: heat flux (in W/m2), numeric value (for a constant property) or can refer to a function 

I## (defined in the Functions window). 

 

Remarks 

- When a colour number is entered that does not occur in the Colours window, then this 
input is not accepted (the input field is cleared). 

- To be valid at least one of both colour numbers must reference a material (type 
MATERIAL, EQUIMAT or TRANSMAT). 
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Edit commands 

- Edit → Insert After: add a new borderface BC. 

- Edit → Delete: delete a borderface BC. 

B.17. Material BCs window 

Menu command: Edit → Material BCs  

 

 
 

A material boundary condition (“material BC”) imposes either a temperature (type TEMP) or a 
heat power density (type POWER) in all object blocks (in the final object composition as shown in 
the Image window) having a given colour number, either as constant values or as functions of 
time (T## or P##). 

The outline of the object blocks related to the active material BC are highlighted in the Image 

window (if the option Image → Hide Outline is not active). 

 

Edit commands 

- Edit > Insert After: add a new material BC. 

- Edit > Delete: delete a material BC. 
 

Remark 
A drawback of this kind of boundary condition is that the total heat flow into all object blocks of 

the given colour number cannot be output (in the Text window). 

B.18. Solar data 

The solar processor requires the definition of parameters in the Solar Data dialog box (Edit → 
Solar Data…). 

 
First, a choice can be made between a Real sun path or a simplified calculation with a Fixed sun 
position. 
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B.18.1. Real sun path 

North orientation4: The modelled object must be positioned into the horizontal coordinate system 
of the physical reality (see C.8) by defining three rotation angles. 
If all three angles are set to 0°, the object’s XYZ coordinate system (as shown in the bottom left 

corner of the Image Window) coincides exactly with the horizontal coordinate system, i.e. the X 

axis points to the north, the Y axis points to the west and the Z axis points to the zenith. 

  
The three angles to be defined by the user position the object by rotating the object around it’s 

own coordinate axes. As a visual aid, the object’s position is updated in the Image Window (as 

with Show North activated, see C.8). 
 

• The first rotation is around the Z-axis. 
This rotation happens within the object’s XY plane (i.e. a rotation around the object’s Z 

axis). 
The object is rotated counterclockwise. A rotation angle of 90°, for example, points the 

object’s X-axis to the west orientation. 
• The second rotation is around its X-axis to define the object’s inclination. 

 
4 Note that the definition of these angles has changed since version 9.0. 
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• The third rotation is around its Y-axis to define the object’s tilt. 

 
Geographical location (“earth position”): latitude (°N), longitude (°E) and time zone (h E). 
The input fields are disabled when these parameters are present in the weather data file 

containing the global solar radiation data, as defined in the Functions window (G01). The 

coordinates are then loaded from the solar radiation weather data file. 
Solar radiation functions: the function reference names of the horizontal global and diffuse solar 
radiation functions are always G01 and D01. These solar radiation functions must be defined in 

the Functions window. 

Ground reflection factor: reflection factor of (horizontal) ground surface around the object model. 
The reflected solar radiation is projected on the external object surfaces using an isotropic diffuse 

model. 
The input value must be between 0 and 1. A typical value is 0.2. For very reflective grounds a 
higher value can be used (e.g. snow: 0.8). 

B.18.2. Fixed sun position 

An alternative to a Real sun path is to impose a fixed sun position for a simplified calculation. In 
this case, the user can choose between a function or a constant value for the total solar radiation. 
The total solar radiation is treated as direct radiation in the calculation (see D.9.2). 
In case a function is selected, the function reference name I01 is always used and should be 

defined in the Functions window. This function I01 contains time-dependent data for the total 

solar radiation.  

 
The user can select one of six directions from which the radiation originates, namely along the 
main coordinate axes. 

B.19. Sun obstacles window 

Sun obstacles around the 3D object are defined in the Sun Obstacles window, opened with Edit 

→ Sun Obstacles. Each sun obstacle is a spherical rectangle defined by azimuth and altitude 
coordinates on the sky hemisphere within which the sun is invisible. 

 
The azimuth and altitude coordinates are defined in the horizontal coordinate system (see B.18.1 

and B.15). Each sun obstacle is defined by four parameters: minimum and maximum azimuth 
(clockwise angle between –180° and 180°, 0° = south, 90° = west), and minimum and maximum 
altitude (between 0° at the horizon and 90° at the zenith). 

 
By default, one sun obstacle (defined by a zone up to 5° high above the horizon in all directions 
around) is present for each new VOLTRA file (cf. figure below). 
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A new sun obstacle is added using Edit → Insert Row. 
A sun obstacle is deleted using Edit → Delete Row. 
 
Note that the Sun Obstacles window is disabled in case a fixed sun position is defined in the Solar 

Data dialog box (see B.18), as sun obstacles are not taken into account in that case. 
 
Remark 
If the solar zone does not surround the complete object, the explicit definition of sun obstacles is 
necessary to prevent that the sun hits the object from unwanted angles. 
An example is shown below. The object represents part of a double façade, facing south. 

 
 
In order to avoid unwanted solar radiation on the mullion when the sun would actually be behind 
the building on which this façade is installed, solar obstacles have to be defined.   

 

 
 
The first figure below shows unwanted solar radiation due to the lack of solar obstacles. The 
second figure shows the desired effect. 
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B.20. Controls window 

VOLTRA includes temperature controls mimicking the working of a thermostat, defined in the 

Controls window. A control decides between the application of two functions based on a sensor 

temperature, target temperature and purpose.  
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Two functions, used as boundary condition or material property function, need to be defined in 

the Functions window and referred to in the Colours window, Node BCs window, Borderface BCs 

window, Material BCs window or Ventilation Flows window.  

 

The sensor temperature refers to the temperature at the output node specified in the Output 

Nodes window. At each time step, this value is compared to the target temperature to determine 

whether the control should be activated or deactivated. 
 
A time dependent target temperature for heating or cooling is imposed. These controls thus allow 
e.g. applying a higher power or ventilation flow if heating or cooling is required. 
 
To avoid rapid fluctuations of this on/off system, a hysteresis control can be defined using the 
upward and downward thermostat sensitivities.  
 
Moreover, a minimum operational duration of control action after activation or deactivation can 

be defined via time on (minimum time (in minutes) after control action is activated) or time off 
(minimum time (in minutes) after control action is deactivated) parameters.   
 

A new control can be added using Edit → Insert Before or Edit → Insert After, and deleted with 

Edit → Delete. 
 

 
 

A control is defined by the following elements (corresponding to the different columns): 

- Sensor node, where at each calculation time step the temperature is compared to the 
desired target temperature. The sensor node is defined by the reference number of an 

output node in the Output Nodes window (cf. section B.21). 

- Target temperature: function reference of a temperature function (T01 up to T99) defined 

in the Functions window (cf. section B.12). 

- Thermostat sensitivity upward [°C]: 

When a heating control is active, a necessary condition to switch off the control is that the 
sensor temperature is greater than the target temperature plus the upward sensitivity. 

When a cooling control is not active, a necessary condition to switch on the control is that 
the sensor temperature is greater than the target temperature plus the upward sensitivity. 

- Thermostat sensitivity downward [°C]: 
When a heating control is not active, a necessary condition to switch on the control is that 
the sensor temperature is less than the target temperature minus the downward 
sensitivity. 
When a cooling control is active, a necessary condition to switch off the control is that the 
sensor temperature is less than the target temperature minus the downward sensitivity. 

- Purpose: a control can be intended for either heating or cooling. 
- Minimum time on: minimum duration that the control must continuously remain switched 

on. A control will be checked and a change in functions might occur at the beginning of 
each calculation time step based on the results of the preceding time calculation time 
step. Therefore, the actual time the control remains on will be rounded up to the nearest 
integer multiple of the time step that meets or exceeds the specified minimum time on 
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- Minimum time off: minimum duration that the control must continuously remain switched 

off. The actual time the control remains off will be rounded up to the nearest integer 
multiple of the time step that meets or exceeds the specified minimum time off. 

- Function from: the function reference (E##, H##, I##, M##, P##, R##, S##, T## or V##, 

with ## = 01 up to 99) to a function defined in the Functions window and referred to in the 

Colours window, Node BCs window, Borderface BCs window, Material BCs window or 

Ventilation Flows window. 

The “function from” is applied when the control is switched off. 
- Function to: function reference (E##, H##, I##, M##, P##, R##, S##, T## or V##, with 

## = 01 up to 99) to a function defined in the Functions window, which replaces the 

“function from” while the control is switched on. 
The “function from” and “function to” must both be of the same type (i.e. both function 
references must begin with the same letter). 

- Test : switch to test the temperature difference between two zones (of a ventilation 
path), as (additional) condition to switch on a ventilation control (only available if “function 

from” and “function to” start with the letter V). 
For heating: The zone 1 temperature (1) must exceed the zone 2 temperature (2) by at 
least the minimum required temperature difference for control to be enabled. 
For cooling: The zone 1 temperature (1) must be lower than the zone 2 temperature (2) 

by at least the minimum required temperature difference for control to be enabled. 
- : minimum required temperature difference [°C] between two zones (of a ventilation 

path). 

- Zone 1 for temperature difference test, which is defined by its colour number (between 0 

and 255) in the Colours window. The colour must be defined in the ventilation path. 

- Zone 2 for temperature difference test, which is defined by its colour number (between 0 

and 255) in the Colours window. The colour must be defined in the ventilation path. 

B.21. Output nodes 

Output nodes are points to which reference is made in a report text output (cf. section F.3.3) to 
show the course of temperatures in those points as a function of time. 

Output nodes can also be used as sensor points in controls (cf. section B.20). 

Output nodes are defined in the Output Nodes window. The definition of an output node consists 

of a sequence number and the point coordinates (X,Y,Z or R,C,L depending on the active 

coordinate system). The position of the current output node is represented in the Image window 
by the intersection of three lines parallel to the coordinate axes (coloured red, green and blue). 
Output nodes can be inserted (using Edit → Insert Before or Edit → Insert After) and deleted 

(using Edit → Delete). 

 

 

B.22. Output blocks 

Output blocks can be used in a report text output (cf. section F.3.3) to show the course of 
incoming heat flows (in W) through conduction through the boundary faces of those output 
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blocks. The heat flows by radiation or convection are not taken into account. So only the 

intersection parts of the boundary faces of an output block with the object material is important. 

Output blocks are defined in the Output Blocks window. 

 

A new output block can be added using Edit → Insert Before or Edit → Insert After. The definition 
of an output block consists of a sequence number and 6 coordinates. 
 

 
 

 
 
The boundary faces of an output block always lie in between the grid coordinates as defined in 

the Grid window. In this way the boundary faces can be broken down in elementary boundary 
faces of control volumes around material nodes, through which the energy flows through 
conduction can easily be calculated. 

In the RCL coordinate system the coordinates of output blocks are represented by even numbers 
(0,2,4,…). 

In the XYZ coordinate system an output block coordinate ends with .5 to indicate that its position 

is halfway between two consecutive grid locations (as defined in the Grid window).  

The outline of the current output block is shown in the Image window. 

Note that object clipping (C.10) has no effect on the calculation of heat flows into the output 

blocks; it has only a visual effect in the Image window. 

B.23. Ventilation flows window 

Ventilation flow paths can be defined in the Ventilation Flows window, opened with Edit → 

Ventilation Flows. Add new ventilation flows with the command Edit → Insert After. 

 

   
 

For each ventilation flow definition line a ventilation source and ventilation destination must be 
entered. Both are identified by colour numbers to the corresponding boundary conditions. 
The ventilation source (in the column with header “From Col. 1”) can be any type of boundary 
condition (BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY or BC_NOSKY). The ventilation destination 
(in the column with header “To Col. 2”) must be a boundary condition of type BC_FRE_S or 
BC_FREE (with unknown air temperature influenced by the incoming ventilation flow). Ventilation 
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flows with destination a zone with fixed air temperature can not be entered, because they have 

no effect on the system. 
The ventilation flow (last column) is a constant value or a reference to a ventilation function (V##) 

as defined in the Functions window. 

The user should take care that all defined ventilation flows refer to a realistic ventilation scheme. 
A ventilation path can originate from an outside environment, pass through some internal zones 
and leave to another outside environment. But a ventilation path can also pass through a closed 
circuit of only internal zones. 

 
All air cavities of type BC_FRE_S and BC_FREE that occur as ventilation source or ventilation 

destination in the Ventilation Flows window are automatically unlinked without the need of explicit 

definition as explained in section D.7. 
 
The following error messages may occur when doing a calculation: 

- “Syntax error in ventilation flow N”: 

The ventilation flow in the Ventilation Flows window at line N contains a syntax error. 

Either the ventilation source is not a boundary condition (i.e. a colour of type BC_SIMPL, 

BC_FRE_S, BC_FREE, BC_SKY or BC_NOSKY), or the ventilation destination is not a 
boundary condition of type BC_FRE_S or BC_FREE, or the specific heat (c) and/or the 
density (ρ) of the ventilation source and destination are not equal (see B.10). 

- “Error in ventilation system”: 

The combination of all ventilation flows as defined in the Ventilation Flows window does 

not correspond to a physically correct ventilation system. This error occurs when the 
ventilation system has no unique solution (undetermined system). 

B.24. Report Definition window 

The contents of a report in the Text Output window (see Chapter F) after a calculation has been 

executed, is determined by the report definition and the report frequency (cf. section B.25). 

The input of the report definition is done in the Report Definition window, opened with Edit → 

Report Definition. 

The report definition consists of several report items, one per line in the Report Definition window. 
A new report item is added via Edit → Insert Before or Edit → Insert After. 

During the generation of a report in the Text Output window, a report line is written per report 

step (which equals the calculation time step or a multiple of it, as defined by the report 
frequency). 

The report line consists of the actual values of the report items (separated by tabs) at the current 
time step. 
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A report item is defined by the following elements (corresponding to the different columns): 
- Object: a toggle with values TIME, DATE TIME, COLOUR, 2 COLOURS, NODE BC, BORDER 

BC, MATERIAL BC, OUTPUT NODE, OUTPUT BLOCK, CONTROL, SUN. 
- Object No., which meaning is dependent on the selected object: 

o TIME: not applicable. 
o DATE TIME: not applicable. 

o COLOUR: colour number (cf. first column in Colours window). 

o 2 COLOURS: 2 colour numbers (cf. first column in Colours window). 

o NODE BC: node boundary condition number (cf. first column in Node BCs window) 

o BORDER BC: borderface boundary condition number (cf. first column in 

Borderface BCs window). 

o MATERIAL BC: material boundary condition number (cf. first column in Material 
BCs window). 

o OUTPUT NODE: output node number (cf. first column in Output Nodes window). 

o OUTPUT BLOCK: output block number (cf. first column in Output Blocks window). 

o CONTROL: control number (cf. first column in Controls window). 

o SUN: not applicable. 

- Type, a toggle with values dependent on the selected object: 
 

Object Type Meaning 

TIME [s] time in seconds of the current time step 

DATE TIME [dddd:hh:
mm:ss] 

time in days, hours, minutes and seconds of the current time 
step 

COLOUR θmin minimum temperature [°C] (for colour of type MATERIAL or 
EQUIMAT) 

θmax maximum temperature [°C] (for colour of type MATERIAL or 

EQUIMAT) 

Δθmax maximum temperature difference (θmax - θmin) [°C] (for colour 

of type MATERIAL or EQUIMAT) 

θmean mean temperature ((θmin + θmax)/2) [°C] (for colour of type 

MATERIAL or EQUIMAT) 

Qin heat flow into object out of boundary condition [W] 

(for colour of type BC_SIMPL, BC_FRE_S, BC_FREE, 
BC_SKY, BC_NOSKY or TRANSMAT) 
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Qout heat flow out of object into boundary condition [W] 

(for colour of type BC_SIMPL, BC_FRE_S, BC_FREE, 
BC_SKY, BC_NOSKY or TRANSMAT) 

λ (equivalent) thermal conductivity [W/(m.K)] 
(for colour of type MATERIAL, EQUIMAT or TRANSMAT) 

θ boundary condition temperature [°C] 

(for colour of type BC_SIMPL or BC_FRE_S) 

h total surface heat transfer coefficient [W/(m².K)] 
(for colour of type BC_SIMPL or BC_FRE_S) 

q heat flux into boundary condition [W/m2] 
(for colour of type BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY 
or BC_NOSKY) 

θa air temperature [°C] 
(for colour of type BC_FREE, BC_SKY or BC_NOSKY) 

hc convective heat transfer coefficient [W/(m2.K)] 
(for colour of type BC_FREE, BC_SKY or BC_NOSKY) 

Pc convective power into boundary condition [W/m] 
(for colour of type BC_FREE or BC_FRE_S) 

θr radiation temperature [°C] (for colour of type BC_SKY) 

qsol (area weighted average) absorbed solar flux on all faces 
oriented to Xmin/Xmax/Ymin/Ymax/Zmin/Zmax (including 
faces that do not receive any solar radiation) [W/m²] 

(for colour of type MATERIAL or EQUIMAT) 

Etot Total solar irradiance in interface with solar zone [W/m²] 

Edir Direct solar irradiance in interface with solar zone [W/m²] 

Edif Diffuse solar irradiance in interface with solar zone [W/m²] 

Egr Ground reflected solar irradiance in interface with solar zone 

[W/m²] 

2 COLOURS θmin minimum temperature [°C] occurring in set of 2 colours 

θmax maximum temperature [°C] occurring in set of 2 colours 

Δθmax maximum temperature difference (θmax - θmin) [°C] occurring 

in set of 2 colours 

θmean mean temperature ((θmin + θmax)/2) [°C] of set of 2 colours 

NODE BC θ temperature [°C] 

P power [W] 

BORDER BC θ temperature [°C] 

q heat flux [W/m²] 

MATERIAL 
BC 

θ temperature [°C] 

p Power density [W/m³] 

OUTPUT 
NODE 

θ temperature [°C] 

OUTPUT 
BLOCK 

Q heat flow through conduction into output block [W] 

CONTROL ON control on/off status (0=off, 1=on) 

SUN AZIMUTH sun azimuth [°] (0:south, 90:west, -90:east) 

ALTITUDE sun altitude [°] (0:horizon, 90:zenith) 

 

- Width: (maximum) number of characters for formatting the output values in the output 
report 
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- Decimals: number of digits after the decimal point, to which the output values are 

rounded. 
 

If a report item definition is logically impossible, no values are given in the report (-). 

B.25. Report Frequency 

A report line in the report output is written for every time step or every fixed number of time steps. 

This number is set, before the calculation is started, in the Report Frequency dialog box, opened 
with Calc → Report Frequency…. 

When a calculation is started, the amount of memory is allocated to save the report records 
during the calculation. At the end of the calculation the report records are saved in a text file and 
a CSV file (with same name and file folder as input data file, and extensions .txt and .csv). This 
report file can be viewed in the text output. 
 

 

B.26. Save Frequency 

During a calculation, time step solutions (i.e. the calculated temperatures in all calculation nodes 
and the absorbed solar fluxes) at every fixed number of time steps can be saved to disk to use 
later in graphic output or text output (to view the solutions at those time steps). 

The save frequency must be set, before the calculation is started, in the Save Frequency dialog 

box, opened with Calc → Save Frequency…. 

 

 
 
The node temperature solutions are saved in .sol files, .flx files and .sfx files with the same file 
name of the input data file appended with a 4-digit serial number. For example if the input data 
file is PilotexVoltra.vtr, then the solution files are PilotexVoltra0000.sol, PilotexVoltra0001.sol, 
PilotexVoltra0002.sol etc. 
The format of the .sol and .flx files is identical to that of the TRISCO solution files. 
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CHAPTER C VIEWING THE MODEL 

C.1. Image submenu 

The object model as defined in the Blocks window and Colours window is shown in the Image 

window. The view of the object in the Image window can be altered using image functions. In the 

bottom left corner of the Image window, the 3 main coordinate axes are shown for reference 

(red for X or R, green for Y or C, and blue for Z or L). 
 

     
 

The active view mode (Rotate, Pan, Zoom Window or Zoom In) and active object appearance 
(Show Materials, Show Transparent, Show BCs, Show Temperatures or Show Single 

Temperature) are checked in the Image submenu (see check mark in front of menu commands). 

C.2. Viewpoint 

The viewpoint can be rotated or panned (i.e. moved laterally). 

- Image → Rotate 

Enters rotate mode. Mouse dragging or pressing arrow keys (left, right, up, down, with 

Image window active) rotates the relative position of the viewpoint with respect to the 

object centre. 
The Z axis of the XYZ coordinate system should point upwards to the sky (or the layer axis 
of the RCL system should point downwards) to get a good behaviour of the rotate 
function. 
Rotate mode is activated automatically by holding down the mouse wheel when the 

Image window perspective (3D) projection is active (C.4). 

- Image → Pan 

Enters pan mode (only possible when the current view is already zoomed in). Mouse 

dragging or pressing arrow keys (with Image window active) moves the relative position 

of viewpoint and object centre parallel to the projection plane. 

Pan mode is activated automatically by holding down the mouse wheel when the Image 

window 2D orthogonal projection is active (C.4). 
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The command Settings → Drag Mode allows to define the relative movement of viewpoint and 
object (as either “drag viewpoint” or “drag object”, cf. section A.8). 

C.3. Zoom commands 

- Image → Zoom Window 

Enters “zoom window” mode. This allows to draw a zoom rectangle using the mouse in 

the Image window, which defines the borders of a zoomed view. 

Press Esc to cancel the current zoom rectangle (before releasing the left mouse button). 

- Image → Zoom In 

Enters “zoom in” mode. A following click using the left mouse button in the Image window 
defines the centre point of the next zoomed view. The zoom factor can be defined with 
Settings → Zoom Factor… (see A.8). 

Zooming in is also possible using forward scrolling with the mouse wheel (when the Image 

window is active). 
- Image → Zoom Out 

Zooms out. The zoom factor can be defined with Settings → Zoom Factor… (see A.8). 
Zooming out is also possible using backward scrolling with the mouse wheel (when the 

Image window is active). 

- Image → Zoom Total 
Shows total object. 

- Image → Previous View 

Shows the previous zoom view. (More than one previous view cannot be recalled.) 

- Image → Zoom Numbers… 

Opens a dialog box with the current zoom parameters. 
Enter new parameters to change the view. Use preferably rounded numbers to facilitate 

restoring the same view at a later moment. 
 

 

C.4. Projection 

Projection submenu 
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The projection of the model in the Image window can be toggled between  

- Projection → Perspective: perspective view of the 3D model. 

- Projection → Xmin…: 2D orthogonal view of the model onto the YZ plane with minimum X 
coordinates, looking in the positive X direction. 

- Projection → Xmax…: 2D orthogonal view of the model onto the YZ plane with maximum 
X coordinates, looking in the negative X direction. 

- Projection → Ymin…: 2D orthogonal view of the model onto the XZ plane with minimum Y 
coordinates, looking in the positive Y direction. 

- Projection → Ymax…: 2D orthogonal view of the model onto the XZ plane with maximum 
Y coordinates, looking in the negative Y direction. 

- Projection → Zmin…: 2D orthogonal view of the model onto the XY plane with minimum Z 
coordinates, looking in the positive Z direction. 

- Projection → Zmax…: 2D orthogonal view of the model onto the XY plane with maximum 
Z coordinates, looking in the negative Z direction. 

C.5. Object appearance 

Object compilation 

The object appearing in the Image window is the result of processing the blocks list in the Blocks 

window. 

Each block has a colour. The colour (defined in the Colours window) refers to either a material 

(type MATERIAL, EQUIMAT or TRANSMAT) or a boundary condition (type BC_SIMPL, BC_FRE_S, 

BC_FREE, BC_SKY or BC_NOSKY). 

A material block (which refers to a material colour) is added to the resulted object. 
A boundary condition block (which refers to a boundary condition block) is subtracted from the 
resulted object. The boundary condition is active on all object surfaces adjacent to the boundary 

condition block. 

The superposition rule in the Blocks window makes that blocks with higher sequence number 

overwrite the common parts of blocks with lower sequence number. 
 

View options 

The colour of the surfaces of the material blocks of the object in the Image window can be 

modified: 

- Image → Show Materials 
Shows the material colours of the material blocks in the object. 

- Image → Show Transparent 
Shows the object with transparent materials, so that the inside of the object can be 

viewed. 

    
- Image → Show BCs 

Shows the colours of the boundary conditions which are active on the material blocks in 
the object. 
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When there are no explicit boundary conditions active on a material block surface, then 

an adiabatic boundary condition (i.e. without any heat transfer) is supposed. This implicit 
adiabatic boundary condition is coloured light yellow on the material blocks. 

- Image → Show Temperatures 

Shows the calculated temperatures on the material blocks in the object. 
This option is only available if a calculation solution is present. 
The thermal palette making up the colours of the temperature scale are interpolated from 
values defined in a .rgb file (see A.8). This is a text file containing red, green and blue 
components (values from 0 up to 255) for increasing temperature values. 

The legend of used colours can only be made visible in the Graphics Output window 

(cf. section 0). 
The temperature scale is defined in Image → Temperature Range…. 

- Image → Temperature Range… 

Opens a dialog box to define the parameters of a temperature view. 
The first increment is used as step value in Image → Temperature Range…. 

(The second increment is only used with isothermal lines in the Graphics Output window) 

This command is only enabled when the menu option “Show Temperatures” is checked. 
 

 
 

Remark 
Before starting a calculation, it is advised to check carefully the surface boundary conditions 

active on the object surface using the command Image → Show BCs. 

C.6. Quick block selection using the mouse 

It is possible to select a block in the Blocks window from the Image window using the mouse. 

The current object appearance mode should be: 
-  “Show Materials” (activated through Image → Show Materials) to select a material block; 
-  “Show BCs” (Image → Show BCs) to select a boundary condition block. 

Point to the desired surface in the Image window and click (double click with left mouse button, or 

single click with right mouse button) to move to the underlying block in the Blocks window. 

C.7. Active item feedback in the Image window 

The active item of the current input window is highlighted in the Image window: 

- From the Blocks window: edges of current block (in wireframe). 
Example: see figure below left. 

- From the Colours window: object parts corresponding to the current colour (in wireframe).  

Example: see figure below centre. 
The volume of all blocks having the current colour is shown in the status bar when the 
active cell is upon the colour name.  

- From the Grid window: edges of box surrounding the current mesh (in wireframe). 

Example: see figure below right. 
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The colours of object surfaces not intersecting the grid mesh box are dimmed. 

The edges of the surrounding box of the entire grid space closest to the coordinate axes 
are coloured red (X or R), green (Y or C) and blue (Z or L). 

    
 

Analogous feedback for the current item in the Image window is available from the other input 
windows. 

The feedback lines can be removed by clicking the toggle Image → Hide Outline. Click this 
command again to show the feedback again. 

C.8. Show North 

Menu command: Image → Show North 
Above the object the horizontal plane is shown as a light blue disk (from the top side) or a dark 

blue disk (from the underside). The full line points to the North. 
The sun paths are shown for winter solstice (21 December), vernal equinox (20 March) and 
summer solstice (21 June). 

To hide the north orientation, call Image → Show North again. 

 

C.9. Pick temperature using the mouse 

When the Image window is active (i.e. its title bar is blue) and the temperatures are shown (Image 

→ Show Temperatures), then the surface temperature at the mouse cursor is displayed in the 

status bar (bottom left of the screen). 

The number of decimals can be modified via the Decimals dialog box from the Text Output 

window (cf. section F.4.1). 

C.10. Object clipping 

Menu command: Edit → Clip Object 
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Part of the object can be shown in the Image window by clipping off all object parts outside a 

grid interval in any of the three coordinate directions. In this way cross-sections through all grid 
planes can be shown. 
 

The clip borders are defined in the Clip Object window (opened with Edit → Clip Object). Editing 

the clip borders is immediately reflected in the Image window. 

 
Clipping can be reset (to view the total object) with the command Image → Clip Off. 
 
The object clip settings have no effect on the calculation. The calculation is always executed on 
the total object. 

It is possible to reduce the object to the current clip settings with the command Blocks → Reduce 
to Clip… (cf. section B.9.7). 

C.11. Colour clipping 

Menu command: Edit → Clip Colours 

 

  
 

Object parts of each colour can be clipped off in the Image window. The visibility status is 

defined in the Clip Colours window (opened with Edit → Clip Colours). This function can come in 

handy for example to visualise the temperatures in parts of the model which are otherwise 

hidden. 
 

The colour clip settings are also applied in the Graphic Output window. 

 
Colour clipping has no effect on the calculation. The calculation is always executed on the total 
object. 
It is possible to reduce the object to the current clip settings with the command Blocks → Reduce 
to Clip… (cf. section B.9.7). 
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C.12. Coordinates window 

Menu command: Edit → Coordinates 

 

The Coordinates window shows the absolute coordinates for all grid planes. 
The coordinate system is XYZ or RCL (see A.8). 
The origin on each axis can be moved to any grid plane position via Coord → Set Origin. The 
origin is used as anchor point for coordinate transformations (Blocks → Transform Coordinates…: 

rotation, scaling) and file insertion (Blocks → Insert File…). 

The coordinate values cannot be edited in the Coordinates window. Coordinates are modified 

via the Grid window (Edit → Grid). 

The background colours of the coordinates modify according to the underlying minimum grid (cf. 

section B.7). 
 
The position of the origin and coordinate axes (X or R in red, Y or C in green, Z or L in blue) are 

shown in the Image window. The position of the current coordinate is at the transition to the 

dimmed block colours (using Image → Show Materials or Image → Show BCs). 
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CHAPTER D SYSTEM CALCULATION 

D.1. Automatic calculation of thermal properties 

In the Colours window colour types and subtypes can be selected which contain an automatic 

calculation of thermal properties in accordance with international standards (equivalent thermal 
conductivity or convective heat transfer coefficient). 
 

During the input of new data the calculation is based on the default temperature values from the 

relevant standards, or on the default temperature difference across airspace as defined by the 
user in the Calculation Parameters dialog box (see D.2.4) if the calculated thermal property is not 
standardized. 
 

During a system calculation the thermal properties are recalculated based on the real 
temperature values, obtained by the global thermal calculation. The non-linear calculation is split 
in several iteration cycles. Each iteration cycle solves a linear system. The linear system is based 
on updated thermal properties derived from the temperatures available from the solution of the 

previous iteration cycle. 

D.1.1. Colour type EQUIMAT 

Colour modelled as equivalent material (with single equivalent thermal conductivity 𝜆𝑒𝑞 for 

combined convective and radiation heat transfer) 
 

Type Subtype Meaning Standard 

EQUIMAT NIHIL Thermal conductivity 𝜆 defined by user  

CAVITY 
Unventilated (internal) air cavity with given heat flow 
direction 

EN10077 
EN6946 

CAVITY_E 
Ventilated (external) air cavity with given heat flow 

direction 

EN10077 

 LAYER Unventilated air layer with given heat flow direction EN6946 

 
Characteristic dimensions of an air cavity 
Consider a characteristic 2D section of the air cavity, containing the heat flow direction (parallel 
to a coordinate axis) and the smaller of the other two directions of the cavity. The characteristic 
dimensions in the 2D section are called depth (parallel to the heat flow direction) and width 
(orthogonal to the heat flow direction). 
 

If the air cavity is not a rectangular parallelepiped (or cuboid) shape, the depth and width are 

calculated from an equivalent rectangular parallelepiped with the same aspect ratio: 

𝑑′ = size of surrounding box of air cavity in depth direction 
𝑏′ = size of surrounding box of air cavity in width direction 
𝑉′ = volume of surrounding box of air cavity 
𝑉 = real volume of air cavity 
𝑑 =  𝑑′ ∙ 𝑠 
𝑏 =  𝑏′ ∙  𝑠 

𝑠 =  √
𝑉

𝑉′
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If the air cavity has a uniform length in the third dimension (perpendicular to depth and width), 
then the calculation corresponds to the 2D calculation rule in EN ISO 10077-2. 
 

 
The calculated dimensions d and b are further used in the formulas below. 
 
Equivalent thermal conductivity of unventilated air cavity (subtype CAVITY) 
𝜆𝑒𝑞 = (ℎ𝑐 + ℎ𝑟) ∙ 𝑑 

- ℎ𝑐 = convective heat transfer coefficient (from warm surface to cold surface) 
if 𝑏 < 0.005 m (EN ISO 10077-2), then 

ℎ𝑐 =
𝐶1

𝑑
 

if 𝑏 ≥ 0.005 m (EN ISO 10077-2) or for any 𝑏 (EN ISO 6946), then 

ℎ𝑐 = 𝑚𝑎𝑥 {
𝐶1

𝑑
, 𝐶2 ⋅ (𝛥𝜃𝑠𝑠)𝐶3} 

𝛥𝜃𝑠𝑠 = maximum surface temperature difference in air cavity (𝛥𝜃𝑠𝑠 ≥ 5°C for EN ISO 6946) 
or 𝛥𝜃𝑠𝑠  = 𝛥𝜃𝑠𝑠,𝑑𝑒𝑓𝑎𝑢𝑙𝑡 

 

Standard Heat flow direction C1 C2 C3  𝛥𝜃𝑠𝑠,𝑑𝑒𝑓𝑎𝑢𝑙𝑡 

EN ISO 10077-2 horizontal 0.025 0.73 0.333333 10°C 

EN ISO 6946 horizontal 0.025 0.73 0.333333 5°C 

upward 0.025 1.14 0.333333 5°C 

downward 0.025 0.09 ⋅ 𝑑−0.44 0.187 5°C 

 
- ℎ𝑟 = radiative heat transfer coefficient 

EN ISO 10077-2: ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 ∙ 𝐸 ∙ 𝐹 

EN ISO 6946: ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 (
1

𝐸
+

1

𝐹
− 1)⁄  

𝐸 =
1

1
𝜀1

+
1
𝜀2

− 1
 

𝐹 = (1 + √1 + (
𝑑

𝑏
)

2

−
𝑑

𝑏
) 2⁄  

𝜃𝑚 =
𝜃𝑠,𝑚𝑖𝑛 + 𝜃𝑠,𝑚𝑎𝑥

2
 

𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in air cavity [°C] 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in air cavity [°C] 

or 𝜃𝑚 = 10°C (default mean temperature, see D.2.4) 
 1 , 2 = emissivities at warm and cold sides of air cavity (default values: 1 = 2 = 0.9) 
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Equivalent thermal conductivity of slightly ventilated air cavity (subtype CAVITY_E, standard 
EN10077) 
An air cavity is considered to be slightly ventilated when there is an open connection to an 
exterior or interior boundary condition with a slit between 2 and 10 mm, and 𝑑  𝑏. 

𝜆𝑒𝑞 = 2 ∙ (𝜆𝑒𝑞 of unventilated air cavity). 

 

Equivalent thermal conductivity of air layer (subtype LAYER) 
Standard EN ISO 6946: in the formula above for subtype CAVITY, set d/b = 0 for hr. 
 
Adiabatic boundaries 
An adiabatic boundary (i.e. a boundary through which there is no heat transfer) can be 

considered as a symmetry axis (with symmetric heat flow pattern). 
When there is an adiabatic boundary at one side of the width direction, the equivalent width b is 
automatically doubled for subtype CAVITY. 

When there are adiabatic boundaries at both sides of the width direction, the equivalent width b 
is automatically considered to be infinite for subtype CAVITY (so d/b = 0, as for subtype LAYER). 

D.1.2. Colour type BC_SIMPL or BC_FRE_S 

Purpose: simplified surface boundary condition (using a global surface heat transfer coefficient). 

For BC_SIMPL, the environment temperature is defined by the user. For BC_FRE_S, the 
environment temperature is unknown (free-floating). 
 

Type Standard Subtype 
Physical  

heat flow 
Meaning 

BC_SIMPL 

NIHIL NIHIL 

 Global surface heat transfer  
coefficient h and temperature θ defined 

by user 

EN10077 

HI_NORML horizontal 
Normal h at interior surface:  
h = 7.7 W/(m2.K), θi = 20°C 

HI_REDUC horizontal 
Reduced h at interior surface:  
h = 5 W/(m2.K) , θi = 20°C 

HE  
h at exterior surface:  
h = 25 W/(m2.K), θe = 0°C 

HI_CAV_E horizontal 
Slightly ventilated air cavity: 
h = 3.33 W/(m2.K), θi = 20°C 

HE_CAV_E horizontal 
Slightly ventilated air cavity: 
h = 3.33 W/(m2.K), θe = 0°C 

EN6946 

HI 

horizontal 
h at interior surface:  

h = 7.7 W/(m2.K) 

upward 
h at interior surface:  
h = 10 W/(m2.K) 

downward 
h at interior surface:  

h = 5.9 W/(m2.K) 

HE 
 h at exterior surface:  

h = 25 W/(m2.K) 
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D.1.3. Colour type BC_FREE 

(This type requires the RADCON module, see Chapter I) 

Purpose: enclosure with unknown (free-floating) air temperature (single thermal node) to be 
calculated from convective heat balance, and radiation based on view factors. 

Type Subtype Meaning 

BC_FREE NIHIL Thermal conductivity 𝜆 defined by user 

CONVEC Large air space, without preferential heat flow direction* 

CAVITY Unventilated (internal) air cavity with given heat flow direction 

*typically larger than 0.3m 

 
CAVITY : 
The CAVITY subtype is to be used when a global heat flow direction is assumed (surface-to-
surface heat transfer with an air temperature in between temperature of ‘hot’ and ‘cold’ surface 
temperatures, e.g. typically used for a cavity in a façade). 
The characteristic dimensions of the air cavity, d (= depth, parallel to heat flow) and b (= width), 

are calculated as for colour type EQUIMAT (see D.1.1). 
The convective surface heat transfer coefficient ℎ𝑐 is calculated as for colour type EQUIMAT (see 
D.1.1). The values calculated according to the different standards in D.1.1 are defined however as 
surface-to-surface. Since the convective surface heat transfer coefficient ℎ𝑐 for BC_FREE is 

surface-to-air, the values calculated in D.1.1 are doubled. 
ℎ𝑐 = convective surface heat transfer coefficient (surface-to-air) 
ℎ𝑐 = 2 ∙ (ℎ𝑐,𝐸𝑄𝑈𝐼𝑀𝐴𝑇) 

 
CONVEC: 
The subtype CONVEC must be used when no global heat flow direction can be assumed in the 

enclosure (surface-to-air heat transfer with an air temperature higher or lower than surface 
temperatures, e.g. typically used for a room). 
ℎ𝑐= convective surface heat transfer coefficient (surface to air) 
ℎ𝑐 = 2 ∙ 𝐶2 ∙ (𝛥𝜃𝑠𝑎)𝐶3 
𝛥𝜃𝑠𝑎= greatest difference between air temperature and surface temperature 

𝛥𝜃𝑠𝑎 = max (|𝜃𝑎 − 𝜃𝑠,𝑚𝑖𝑛|, |𝜃𝑎 − 𝜃𝑠,𝑚𝑎𝑥|) 

𝜃𝑎 = air temperature 
𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in contact with given boundary condition colour 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in contact with given boundary condition colour 

or 𝛥𝜃𝑠𝑎= calculation parameter “Default temperature difference for hc calculation (subtype 
CONVEC)” (see D.2.4) 
 

Heat flow direction C2 C3 

horizontal 0.73 0.333333 

upward 1.14 0.333333 

downward 0.09 0.187 
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D.1.4. Colour type BC_SKY or BC_NOSKY 

(This type requires the RADCON module, see Chapter I) 

Purpose: environment with known air temperature and either user defined radiation temperature 
(BC_SKY) and radiation based on view factors or no radiation exchange (BC_NOSKY). 

Type Subtype Meaning 

BC_SKY 
or 
BC_NOSKY 

NIHIL Convective surface heat transfer coefficient hc defined by user 

CONVEC 
Natural convection surface-air  
(calculation of hc: cf. above BC_FREE - CONVEC, see D.1.3) 

D.1.5. Colour type TRANSMAT 

(This type requires the RADCON module, see Chapter I) 

Purpose: air cavity modelled as transparent material (radiation based on view factors, cf. 
radiosity method (EN ISO 10077-2), and equivalent thermal conductivity 𝜆𝑒𝑞 for convective heat 

transfer) 

 

Type Subtype Meaning 

TRANSMAT NIHIL Thermal conductivity 𝜆 defined by user 

CAVITY 
Unventilated air cavity (calculation of eq: cf. above EQUIMAT, 
CAVITY with hr = 0, because radiation is calculated using view 
factors) 

D.2. Calculation parameters 

A system calculation (Calc → Calc System) is controlled by calculation parameters. 
The menu command Edit → Calc Parameters… opens a dialog box in which the calculation 
parameters can be edited. The parameters not relevant to the current VOLTRA document are 
disabled (greyed in the dialog box). 
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D.2.1. Time 

- Time step: this is the time distance between two successive dynamic system calculations 

(time format: days, hours, minutes and seconds separated by colons). 

- Start-up calculation duration: this is the time duration before the actual start of the 
calculation (where reporting starts) with the purpose to get good dynamic start values. 
The boundary condition values of time-dependent functions are taken before the time 

origin of those functions, so that the actual calculation (at the end of the start-up 
calculation duration) starts at time 0. Internal functions which are not periodic (i.e. 

functions of type STEP0 and STEP1), get the function value at time 0 during the entire 
start-up calculation duration. Periodic functions are extended for negative time values 
with the same periodic function course. For external functions the “previous function” is 
taken, as defined in the function editor FUNCEDIT (cf. Chapter G). 

- Calculation duration: duration of the dynamic calculation during which time step results 

and report items can be saved (e.g. to produce a graphic animation). 
- Calculation start: definition of the day number (between 1 and 365) and exact time of day 

to indicate the moment in the year where the calculation starts. This is important when the 
used (external) function is related to a calendar date: e.g. a test reference year, with 
hourly climatic data of a typical year in a given location. The start date of the external 
function or weather data file may be different from the start date of the calculation. 
The button “i” near the input field gives, when pressed, the day numbers for the first day of 
each month for information. 
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In case of solar radiation functions (G## and D##) using an external data file with data 

formatted as a step function (B.12.2) or a weather file (B.12.3), the time step and calculation start 
have to be defined in such a way that the simulation hits the hours precisely. If this condition is not 
met, an error message is shown when starting the calculation. 

D.2.2. Iterations 

Iteration cycles 

An iteration cycle is part of a system calculation (cf. section -) and involves building and solving a 
linear system of equations. A non-linear system is solved by stepwise linearisation. Each step 
using new linearised coefficients corresponds to an iteration cycle. This is needed for automatic 

refinement of calculated thermal properties (equivalent thermal conductivities and convective 
heat transfer coefficients) or non-linear infrared radiation. Before each new iteration cycle the 
linearised thermal resistances are recalculated based on the last available solution (i.e. from the 

previous iteration cycle). 
The given number of iteration cycles is only applied for the first time step (i.e. solution of the initial 
steady-state system, cf. section D.6). If the initial temperature differences are rather high, the 

number of iteration cycles should also be high (to get reliable start values of temperature 
dependent thermal properties). For the next time steps there is always only one single iteration 

cycle (independent of the given number of iteration cycles in the Calculation Parameters dialog 
box). 
 
Iteration stopping criteria 
The linear system of each iteration cycle is solved using an iterative method. 
The iteration process is stopped when the maximum number of iterations (given as calculation 
parameter; by default 10000) is reached, or more likely when all three following conditions are 
fulfilled: 

- Temperature difference condition 
For every system node the absolute value of the difference between the temperatures 

obtained in the current and previous iteration step must be smaller than the parameter 

maximum temperature difference (by default 0.0001°C). 
- Energy heat balance for the total object 

The residual heat flow into or outside the object compared to the total heat flow passing 

through the object must be less than the parameter maximum heat flow divergence for 
total object (by default 0.001 %). 

- Worst energy heat balance for all control volumes 

For all system nodes the residual heat flow into or outside the control volume compared 
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to total heat flow passing through the control volume must be less than the parameter 

maximum heat flow divergence for any node (by default 1 %). 
Definition of heat flow divergences: see section D.10. 

D.2.3. Radiation 

(see Chapter I for more on view factor based radiation heat transfer) 
 

Linear radiation 
The linear radiation between two black surfaces is: 
𝑞𝑟 = 𝐹𝑖𝑗 ⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑖 − 𝜃𝑗) 

𝑞𝑟 = radiation heat flux [W/m2] 
𝐹𝑖𝑗  = view factor from surface i to surface j (= fraction of radiation leaving surface i that is 

intercepted by surface j) 
ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 
𝜃𝑖 = temperature of surface i [°C] 
𝜃𝑗 = temperature of surface j [°C] 

The linear radiation between grey surfaces, having an emissivity (as defined in the Colours 

window), is derived from the radiation between the black surfaces by adding supplementary 
resistances between the grey and black surface nodes (cf. section I.2). 
The black radiation heat transfer coefficient is a calculation parameter. The default value is  
5.1 W/(m2.K) (as in EN 673). 

 
Non-linear radiation 

When non-linear radiation is wanted, the coefficient ℎ𝑟𝑏 is locally adjusted in function of the 
surface temperatures, before each new iteration cycle. The surface temperatures are known 
from the previous iteration cycle, or else from the previous existing solution file (when a 

calculation is restarted). For the first iteration cycle when no solution file is present, the calculation 
parameter “black radiation heat transfer coefficient” is used. 

The non-linear radiation model is physically more precise than the linear model (cf. section I.2). 
 
Calculation of view factors 

The view factors calculation between elementary surfaces is affected by the parameter 
Maximum number of view factor faces (per view factor zone): radiative surfaces are clustered 
into larger view factors if the number of surfaces in a view factor zone exceeds this parameter. 

D.2.4. Automatic calculation of thermal properties 

(See section D.1 for an overview of all automatically calculated thermal properties) 

- Recalculate before each iteration cycle: the automatically calculated thermal properties 
(equivalent thermal conductivities and convective heat transfer coefficients) are 
recalculated before each iteration cycle (see D.2.2). 

- Default temperature difference across airspace: parameter used in automatic calculation 
of thermal properties when no temperature solution and no default temperature 

difference according to the relevant standard are available (see D.1). 

D.3. Calculation of view factors 

Menu command: Calc → Calc View Factors 
 
(This requires the RADCON module, see Chapter I) 
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A monitor shows the progress of the calculation. 

 
 

The view factor boundary condition blocks (of colour type BC_FREE, BC_SKY, BC_NOSKY, 

TRANSMAT) are classified in separate zones. Adjacent boundary condition blocks of different 
colours must have the same type and are combined in the same view factor zone. 
The same colour (of a view factor BC) is not allowed to occur in different zones (otherwise an 
error message appears when starting the calculation). 

In each zone the number of elementary surfaces (defined by the grid meshes in the Grid window) 
is determined. The number of view factors in that zone is proportional to the square of the 
number of faces.  
 
The geometric view factors between two (elementary) surfaces are calculated using analytic 
formulas.  
 

The visibility between the surfaces (i.e. possible obstruction by other surfaces) is checked by a 
number of test rays between random points on both surfaces. 
The calculated unobstructed view factors are reduced proportional to the number of obstructed 

test rays. 
Afterwards the view factors are rebalanced so that the geometric laws are satisfied: 

∑ 𝐹𝑖𝑗

𝑖

= 1 

𝐴𝑖𝐹𝑖𝑗 = 𝐴𝑗𝐹𝑗𝑖 

The view factors are saved in a (text) file with the same name as the input data file, extension 

.vwf, and in the same file folder as the input data file. 
 

View factor grid and system grid 
In general, the view factor grid may be less fine than the system grid without loss of accuracy. 
Very small grid meshes do not bring significantly better results when the surfaces are at a 

relatively large distance from one another, although the calculation time is much larger. By 
setting the maximal number of view factors per view factor zone (see D.2.3), this is achieved 

automatically. 
 
Alternatively, the user can define a grid manually specifically for the view factor calculation which 
is less refined than the grid for the system calculation (Calc → Calc System). It is however very 
important that the system grid is a refinement of the view factor grid, i.e. all grid coordinates of 
the view factor grid must also be present in the system grid. 

The required view factors in the system calculation (using the system grid) are interpolated from 

the view factors obtained from the view factor calculation (using the view factor grid). The view 
factors (from the view factor calculation) are read from the file with extension .vwf5 and with the 
same name as the input data file (used for the system calculation). This means that the same file 
name is used for both calculations: 

 
5 Note that the syntax of the created view factor file (with extension .vwf) from VOLTRA v6.0w is modified 

compared to the format of the .vwf file of previous versions of VOLTRA. 
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- First the view factor calculation with a rough grid (results stored in .vwf file). 

- Then grid refinement as required for the system calculation. 
(Of course this step is not obligatory, when the user accepts that view factor grid and 
system grid are equal.) 

- Finally the system calculation (using the fine grid and view factor interpolation). 

D.4. Calculation of solar fluxes 

Menu command: Calc → Calc Solar Fluxes 
 

This command is enabled when a solar zone is present in the input data. This is a colour of type 
BC_SIMPL or BC_SKY with sun toggle set to YES (B.10.8). 
 
Before executing this command be sure to define a text report (cf. section B.24), the report 
frequency (cf. section B.25) and/or the save frequency (cf. section B.26), otherwise no results of 
calculated solar fluxes are saved for text output (F.3.3) and/or graphic output (E.6.2). 
  

First the view factors are calculated, if not yet present (see D.3). 
 

The solar fluxes are calculated upon all surfaces exposed to the sun. This includes direct solar 
radiation as well as diffuse solar radiation. Also (direct and diffuse) solar radiation through 
transparent walls is calculated. See D.9 for more details on solar radiation calculations. 
 

The absorbed solar fluxes on each elementary surface are saved per time step in a file with 
extension .sfx. Global header information is saved at the start of the calculation in a file with 

extension .sfd. These files are read from the Text Output window and Graphic Output window 

when needed. 

D.5. System calculation 

After the input of data is finished, a calculation can be started with the command Calc → Calc 

System. First the view factors are calculated (if required, as in TRISCO), then the dynamic system 

calculation is started. During the system calculation a monitor is shown containing the current 
time step, the iteration parameters for the current time step, the number of system nodes, 

triangles and view factors. 

After completion of each time step the Image window is updated showing the temperatures of 

the last time step.   

 

  
 
If a start-up calculation is requested, first the start-up time steps are shown (from time 
0000:00:00:00 up to the total start-up duration). Neither reporting nor solution saving is done 



Manual VOLTRA v9.0 67 

during the start-up duration. After finishing the start-up calculation, the normal calculation 

duration begins. The time steps of the normal calculation duration are shown again starting from 
time 0000:00:00:00. During the normal calculation, reporting and solution saving are possible. 
 
At the end of the calculation a report file is written, when at least 1 report item is defined in the 

Report Definition window (cf. sections B.24 and B.25). The content is the same as in the Report 
output (cf. section F.3.3). The report file has the same file name as the data file, and has the 
extension .txt. 

 
A calculation can be interrupted at any time by pressing the <Esc> key. If the “Save step solutions 
to disk” option is enabled in the Save Frequency dialog box (cf. section B.26), the solution files up 

to the last calculated time step can be viewed in the Graphics Output window and Text Output 

window. If a report definition is given (cf. section B.24), the report records up to the last calculated 

time step can be viewed in the Text Output window. 
 

If a calculation is restarted after it has been interrupted, the calculation restarts from the very 
beginning without reuse of the already calculated time step solutions. 
It is possible to start from a predefined solution file StartVoltra.sol (cf. next section), to get an initial 
temperature distribution. 

D.6. Calculation principles 

For the first time step (of the start-up calculation duration if requested, else of the normal 
calculation duration) a steady-state system (as in TRISCO) based on the boundary condition 
function values evaluated at the initial time is set up and solved. Multiple iteration cycles (as 

defined as calculation parameter) are used to get good initial temperature dependent 
properties. If the initial temperature differences of the steady-state system are high, the number 
of iteration cycles should also be high (so that the temperature dependent thermal properties 

converge to stable values). 
 

If a start solution (defined as .sol file) should be adopted at the first time step (of the start-up 
calculation duration if requested, else of the normal calculation duration), this solution should be 
renamed to the fixed file name StartVoltra.sol in the directory of the .vtr input data file. 
The start solution is only used if this solution is compatible with the input data (i.e. same number 
of nodes, same number of object nodes, same number of blocks, same number of node 
boundary conditions). 

Delete the file StartVoltra.sol after the calculation, otherwise it will be reused as start solution (if 
compatible with the input data) in all following calculations. 
 
For the next time steps the boundary condition function values are updated and the material 
volume capacity is taken into account. The Cranck-Nicolson finite difference method is used to 
formulate the energy balance for all control volumes around material nodes. For all other nodes 
without capacity (e.g. black surface nodes, radiation and convection nodes of a boundary 

condition) the energy balance at the current time step is formulated. 

Only 1 iteration cycle per next time step is considered, even if the calculation parameter “number 
of iteration cycles” has a higher value. This supposes fluent boundary condition changes (no 
abrupt discontinuities) during the calculation period. 
 
When the thermal conductivity and/or specific heat of some materials are defined as 
temperature dependent functions, those properties are adapted before each new iteration cycle 

(of the steady-state system for the first time step) and each next iteration step based on the 
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obtained temperatures in the previous iteration cycle or previous time step. 

 
Automatically calculated thermal properties are recalculated (if required by the corresponding 
setting in the Calculation Parameters dialog box, see D.2.4) before each iteration cycle or time 
step, and can be reported in the output report (see variables of type λeq and hc in the report 

definition; cf. section B.24), but the initial values in the Colours window are not updated (as 

opposed to what happens in TRISCO, where the recalculated values are refreshed in the Colours 

window). 

D.7. Unlinking air temperatures in cavities of type BC_FRE_S or BC_FREE 

A cavity or layer (filled with air or any other fluid) can be modelled using several (adjacent) blocks 
having different colours. These colours can have different thermal properties (e.g. surface heat 
transfer coefficient), but must have the same type (i.e. all BC_FRE_S or all BC_FREE). Otherwise 
the calculation is immediately stopped, with the error message “BC (colour …) touches other BC of 
different type”. 
 

The default implementation is to assume that all these adjacent colours making up the cavity or 
layer are linked. 

- If the cavity is modelled with colours all of type BC_FRE_S, then this means that all colours 
get the same (unknown) environmental temperature, which is calculated solving the 
system. Possible convective heat powers for the individual colours in the same air cavity 

(column Pc in the Colours window) are cumulated and allocated to the central convection 

node (having the single environmental temperature). 
- If the cavity is modelled with colours all of type BC_FREE (only possible with the RADCON 

module), then the radiative heat transfer is calculated taking together all these colours 

forming one zone in which all view factors are calculated. The convective heat transfer is 
calculated with reference to one central convection node (having an unknown air 
temperature). 

 
This default behaviour can be changed. An air cavity can contain more than 1 convection node by 
using several colours in that cavity and unlinking those colours. For each unlinked colour and for 

the remaining block of not unlinked colours in the same air cavity a separate convection 

temperature will be calculated using separate convective heat balances (based on the surface 
temperatures and convective heat transfer coefficients of the adjacent material surfaces, and on 
the injected convective heat power). The radiative heat balance (in case of BC_FREE cavity) 

remains unchanged, i.e. considering the global air cavity in which all view factors are 
determined. 
 
A colour can be manually unlinked by adding per colour (that you want to unlink) a text line at the 
end of the VOLTRA data file (with extension .vtr) using a text editor (e.g. Windows Notepad). The 

syntax of this line is: 
 
unlk=c 

 
where c = colour number (0..255) for unlinked colour. 
 
When considering ventilation flows through different air zones (cf. section B.23 and D.8), the air 
temperatures of these zones are automatically made unlinked. 
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D.8. Processing ventilation flows 

When ventilation flows are present in the input data, the system matrix is not symmetrical 
anymore, and therefore each iteration cycle is split in two successive subtasks: 

- First the solution of a small subsystem of only convection nodes into which ventilation 
flows are injected. The number of these ventilation nodes is always less than or equal to 

the number of colours of type BC_FRE_S or BC_FREE (so  256). The surface 
temperatures that affect the convection nodes are considered as fixed boundary 
condition values (as obtained by the solution of the second subtask). 
The ventilation subsystem has an unsymmetrical system matrix, but has a limited number 
of unknowns (i.e. the temperatures of the ventilation nodes, always  256), and is solved 

using a direct solution method. 

- Secondly the solution of the ventilation replaced system, i.e. the whole system in which the 
calculated temperatures of the ventilation nodes are considered as fixed boundary 

conditions. This system has a symmetrical system matrix, and can be solved using an 
optimised iterative method. 
The calculated surface temperatures adjacent to ventilation zones are taken as fixed 
boundary condition values in the next ventilation subsystem to solve. 

 
In the very first iteration cycle (i.e. of the first time step) no initial values of the surface 
temperatures are known (as required by the first subtask). The complete system is then solved 

without any ventilation flows to get start values for the surface temperatures for the first subtask 
of the next iteration cycle. 
 
When ventilation flows are present, a variable number of iteration cycles is executed per iteration 
step independent of the given maximum number of iteration cycles as defined in the Calculation 
Parameters dialog box. The number of iteration cycles per iteration step is automatically stopped 
when all temperature differences between the calculated temperatures in the ventilation nodes 
of the current and previous iteration cycle are smaller than the given maximum temperature 
difference in the Calculation Parameters dialog box (a typical value is 0.0001°C, see D.2.2). 
However it may be possible (dependent on the input data) that there will be no convergence. In 
this case the iteration cycles are also stopped when any temperature difference of a ventilation 
node between the current and previous iteration cycle is greater than 1000000°C. The program 

resets all node temperatures of the whole system to 0°C, and the user is prompted to inspect and 

alter the input data. 

D.9. Solar radiation processing 

The solar processor is activated when: 
1. A solar zone is present: i.e. a colour of type BC_SIMPL or BC_SKY with sun flag set (defined in 

Colours window, column “Sun”, toggle value set to YES). 

2. Solar radiation data are present: both a function G01 and a function D01 must be defined in 

the Functions window (B.12) in case of a real sun path (B.18.1); and a function I01 must be 

defined in the Functions window (B.12) in case of a fixed sun position with variable radiation 

(see B.18.2). 
G01 refers to a function for the global solar radiation (in W/m2) on a horizontal surface. 
D01 refers to a function for the diffuse solar radiation (in W/m2) on a horizontal surface. 
I01 refers to a function for the total solar radiation (in W/m²) in a user-defined direction. 

 
Input parameters with respect to the solar processor: 

- The solar data as defined in the Solar Data dialog box (see B.15) 
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- Per material: solar reflection factor and solar transmission factor (see D.9.1).  

These material properties are defined in the last two columns of the Colours 

window (see B.10). 

A solar reflection factor function is referenced by R##, with ## = 01 to 99, and 

refers to the Functions window (see B.12.2). 

- Calculation start day and time (Edit → Calc Parameters…, cf. section D.2.1). A 
calculation may be preceded by a pre-calculation period (to get dynamic start 
values of the node temperatures). 

- Sun obstacles: shadow zones of other objects around the input bitmap, defined by 
spherical angular coordinates in the horizontal coordinate system (Edit → Sun 
Obstacles, cf. section B.19). 

 
At every time step the solar load on the object model is calculated (see D.9.2 for external 
surfaces, D.9.5 for internal surfaces, and D.9.6 for opaque surfaces behind transparent 
materials). The solar load is expressed as a calculated node power (in W) per system node. These 
node powers are used as supplementary boundary conditions of the thermal system besides the 
other boundary conditions (e.g. the external temperature). 

D.9.1. Definition of solar properties ρs and τs for MATERIAL 

For each colour of type MATERIAL, the solar reflection factor (𝜌𝑠) and the solar transmission 

factor (𝑠) need to be defined in the Colours window (see B.10). 

 
For incident direct solar radiation the actual value of 𝜌𝑠 may be dependent on the angle of 

incidence, if defined by a solar reflection factor function referenced by R## (see B.12.2). 
 
There are two important calculation aspects to consider when quantifying these solar properties 

as inputs for a colour of type MATERIAL: 

1. The solar reflection factor (𝜌𝑠) and solar transmission factor (𝑠) are applied at the contact 

of a surface with a zone. 
A zone in this context is either a solar zone (BC_SIMPL or BC_SKY) or an internal zone 
with detailed radiation calculation (BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT). 

 

If a colour of type MATERIAL in contact to the source zone from which the radiation enters 

has a solar transmission factor 𝑠 equal to 0, it is an opaque material (see D.9.5). 

 
A transparent construction element in VOLTRA consists of a single colour of type 

MATERIAL with 𝑠 > 0 or a system of adjacent transparent colour layers of type MATERIAL 

with 𝑠 > 0 or of type EQUIMAT (always assumed 𝑠 = 1).  
 
Within a system of adjacent transparent colour layers from a zone up to the next zone, 

only 𝜌𝑠 and 𝑠 at the outer surface of the first colour layer (in contact to the source zone 

from which the radiation enters) are considered. 𝑠 can thus be understood as a property 

of the entire system of adjacent material layers and not just the material layer in contact 

to the source zone, it is good practice to give all adjacent enclosed material layers the 

same 𝑠 value in the Colours window. 
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A system of adjacent transparent material layers can alternatively be placed between a 

source zone from which the radiation enters and an opaque material (𝑠 = 0). This is 

discussed in D.9.6. 
 

2. The solar transmission factor 𝑠 in VOLTRA is applied after subtraction of the solar 

reflection (which can be dependent on the angle of incidence of solar radiation). 
 
Typically, the solar reflection, transmission and absorption are defined relative to the total 

incoming radiation, so 
𝜌 +  𝜏 +  𝛼 = 1 
Or for normal incidence (angle of incidence 0°): 
𝜌0 + 𝜏0 +  𝛼0 = 1 

 

However, for the input value of 𝜏𝑠 in VOLTRA, after subtraction of reflection 𝜌𝑠, applies: 

𝜏𝑠 +  𝛼𝑠 = 1. 
 
The input value of 𝜏𝑠 in VOLTRA can be calculated from the typical solar properties at 

normal incidence (angle of incidence 0°) 𝜌0 and 𝜏0: 

𝜏0 = (1 − 𝜌0) ∙ 𝜏𝑠    or    𝜏𝑠 =
𝜏0

1−𝜌0
 

D.9.2. Irradiance: solar load to external surfaces 

An external surface is a surface of an object (with colour type MATERIAL) in direct contact with a 

solar zone (colour type BC_SIMPL or BC_SKY, and sun flag set in column “Sun” in the Colours 

window). 

 
The position of the sun is calculated at the current simulation time (day of year, clock time) and 

the geographical location (latitude, longitude, time zone) 6. Daylight savings time is not taken into 
account. The position of the sun is located by two angular measures: azimuth (horizontal 
clockwise angle between the sun position and south) and altitude (angle between the sun position 

and the horizon). The azimuth of the sun at a fixed clock time may differ for different days of the 
year due to the irregular movement of the sun (defined by the equation of time): e.g. the azimuth 
at 12 a.m. solar mean time for every day fluctuates around 0° (= south direction). 

 

For the current time step the actual global solar radiation and diffuse solar radiation (in W/m2) on 
a horizontal surface are derived from the corresponding external data files (see B.12.2) or 
weather data files (see B.12.3). Typically these weather data files contain hourly values. 

 
6 Roy G. et al., A note on solar declination and the equation of time, Architectural Science Review, Vol. 32, p. 

43-51 (1989) 
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Values at simulation times are derived through simple linear interpolation in case of an external 

data file with linear function format (see B.12.2). 
 
In case of an external data file with step function format (see B.12.2) or a weather data file (see 
B.12.3), the values in the external data file are converted to instantaneous values at simulation 

times using a mathematical algorithm7. This algorithm takes the empirically calculated times of 
sunrise and sunset into account and produces instantaneous solar radiation values for any 
defined time step. The resulting solar radiation profiles ensure that the total solar radiation 
received matches the information in the data file, and have ‘realistic’ (though obviously 
estimated) shapes without discontinuities. 

 
All produced instantaneous solar radiation values at simulation times are used in VOLTRA as 

average values over the simulation time step, where the simulation time is understood as the 
middle of the simulation time step (since the solar angles are calculated at each simulation time). 
 

For each external surface the angular position against the north direction is computed: 
orientation (compass direction) and tilt (height above horizon). From the global and diffuse solar 
radiation on a horizontal surface, the direct and diffuse solar irradiance on the area around each 

node of the external surface is calculated. 
 
The direct solar irradiance is derived from the direct solar radiation on a horizontal surface and 

the position of the sun. If the sun is not hidden by any sun obstacle (as defined in the Sun 

Obstacles window), a test ray from the surface node towards the sun is inspected on possible 

intersections with other (non-transparent) object surfaces (present in the bitmap). When there are 

no intersections, the node is sunlit. Otherwise the node is shaded and the direct solar irradiance 
on the area around the node is cancelled. 

 
The estimation of the diffuse solar irradiance on the area around the node of the external surface 
is more complex. 

- First the sky visibility from the elementary area around the node is used as 
reduction factor of the diffuse radiation. The sky visibility is calculated using a fixed 
number of test rays from the node with random direction on the hemisphere 

above horizon. This number of test rays is defined by the calculation parameter 

"Number of visibility rays between radiative surfaces" (see D.2.3). For all directions 
at the front side of the surface, the sky visibility is estimated as the fraction of the 
test rays not shaded by any sun obstacle or other (non-transparent) object in the 

 
7 McDowell T. et al., A new method for determining sub-hourly solar radiation from hourly data, 

Proceedings of the 2018 Building Performance Analysis Conference and Simbuild, p. 518-252 (2018) 
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bitmap. This is a good estimation of the view factor to the open sky from the 

elementary area around the node. 
- Secondly the diffuse radiation depends on the tilt of the surface. 

 In an isotropic diffuse model the diffuse radiation on a sloped surface is 
 proportional to the square of the cosine of half the tilt angle. E.g. the diffuse 

 radiation on a vertical surface is half the diffuse radiation on a horizontal surface 
 (i.e. the surface only sees half of the sky dome). 
 VOLTRA uses the more correct anisotropic diffuse model developed by Muneer8, 
 which also distinguishes between shaded and sunlit surfaces and between 
 overcast and non-overcast conditions of the sunlit surfaces. The required 
 parameters can be derived from sun position, slope, orientation, day of year, sunlit 

 status, sky visibility, global and diffuse solar radiation data on a horizontal surface. 
- Finally radiation reflected from the ground in front of the surface, must be added. 

This radiation is assumed isotropic, and is a function of the global solar radiation 

on a horizontal surface, the tilt of the surface, and the ground reflection factor, 
which is an input parameter in the Solar Data dialog box (normal value = 0.2). The 
ground reflected radiation on a vertical surface is half the ground reflected 
radiation on a horizontal downward surface. 

 
If the solar zone is of type BC_SIMPL, then the reflected (direct or diffuse) solar radiation from an 

external surface is further ignored. If the solar zone is of type BC_SKY, this reflected solar 
radiation is further processed (see D.9.4). 

D.9.3. Absorption of solar radiation 

For an opaque external surface (with solar transmission factor equal to 0, see D.9.1), the radiation 
that is not reflected is absorbed. The absorbed solar radiation is converted to node powers in the 
surface nodes. 
For a transparent external surface (with solar transmission factor greater than 0, see D.9.1), some 
part of the solar radiation is transmitted to internal zones (see D.9.5) or to an opaque surface 
behind the transparent construction (see D.9.6). The remainder of the solar radiation is absorbed. 
The absorbed solar radiation is uniformly distributed (proportionally to the mesh distances) along 
the grid line through the surface node and perpendicular to the external surface, up to the 
opposite contact surface with an internal zone or opaque surface. 

 
The report output qsol or absorbed solar flux (see B.24) is always given for the colour for which 

the relevant solar property 𝑠 is defined (see D.9.1). In case of a transparent construction element 

consisting of a number of adjacent transparent colour layers, only the colours in contact to the 
source zone from which the radiation enters thus will have non-zero qsol output, even though the 
absorbed radiation is distributed over the entire thickness of the transparent construction element 
consisting of a number of adjacent transparent colour layers for the thermal solution. 

D.9.4. Processing of reflection 

Reflection is only processed in zones with detailed radiation calculation (BC_FREE, BC_SKY, 

BC_NOSKY or TRANSMAT), so not in solar zones of type BC_SIMPL. 
 

For direct radiation, if the reflection factor 𝜌𝑠 of the surface is angle dependent (cf. definition of 

the material colour in the Colours window, see B.10), then this factor is determined through 

 
8 Muneer T., Algorithms for estimating hourly solar irradiation on slopes, Building Serv. Eng. Res. Technol. 

10(2), p. 81-83 (1989) 
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interpolation between the values in the solar reflection function file for the actual angle of 

incidence (angle between direct solar radiation and surface normal). 
The reflection factor for diffuse radiation is the weighted mean value of the reflection factors for 
all possible angles of incidence. 
 

Diffusely reflected radiation originates from either incoming diffuse radiation or incoming direct 
radiation. This reflected radiation is ideal diffuse (following Lambert’s cosine law) and is again 
reflected, transmitted and absorbed. The final contributions of additional absorption on all 
surfaces are calculated using the radiosity method. 
The radiosity of each elementary surface of the view factor grid equals the amount of energy 
that is given off. The energy incident on the surface (which we consider as unknown of the 

system) equals the sum of all reflected and transmitted energy from other surfaces, multiplied by 
the view factors from those surfaces to the first surface. The reflected energy from another 
surface equals the energy incident on that surface (which is an unknown of the system) multiplied 

by the (diffuse) reflection factor plus the known reflected energy (at the initial state of the radiosity 
system). The transmitted energy equals the energy incident on the opposite side of that wall 
(which is an unknown of the system) multiplied by the transmission factor at that side. The 
transmission factor must first be corrected for the reflection at that side (because the transmission 
factor in VOLTRA is defined after deduction of reflection, see D.9.1). Finally this leads to a set of 
linear equations.  

The radiosity method implies that every time step a supplementary linear system of equations 
must be formulated and solved with the number of unknowns equal to the number of view factor 
surfaces of the view factor grid. This system is global for all zones (based on view factors), 

because these zones may be linked with one another via transparent walls. 

D.9.5. Transmission to internal zone: solar load to internal surfaces 

If the transmitted solar radiation reaches a boundary condition of type BC_FREE, BC_SKY, 
BC_NOSKY or TRANSMAT, then the corresponding zone is called an internal zone, through which 
the solar radiation is further propagated9. The material surfaces bordering an internal zone are 
internal surfaces. A zone of type BC_FREE has view factor based radiation and convection with a 
balanced unknown air temperature. This type is normally used for rooms or larger air cavities. 
A zone of type TRANSMAT has view factor based radiation and conduction using a given thermal 
conductivity (of still air or another gas). This type is normally used for smaller cavities, e.g. the 
cavity of a double glazing. 
 
In general it is recommended to use a view factor grid that is less detailed (i.e. with a smaller 
number of wider meshes) than the calculation grid. The view factors in the calculation grid are 
derived from the view factors in the view factor grid through scaling with the areas of the 

elementary surfaces. The precision is nearly the same, but the calculation speed can be 
enormously improved (see -). 
 
The transmitted direct solar radiation in a node of an internal surface is projected along the 
direction of direct sun light (without refraction) upon the closest internal surface (of the same 

internal zone opposite to the emitter internal surface), forming the solar spot. The power of the 

transmitted direct solar radiation corresponding to the elementary grid surface around the 
emitter node is attributed to the elementary grid surface containing the intersection point of the 
projected solar beam. When this power would cause a flux (i.e. power divided by area) that is 
greater than the solar radiation on an external surface with the same orientation, then this power 

 
9 Note that if the colour behind the transparent construction is of type BC_SIMPL, the transmitted solar 

radiation cannot be accounted for because BC_SIMPL is not a view factor zone. The amount of solar 

radiation that would be transmitted is thus disregarded in the thermal calculation. 
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excess is spread over adjacent elementary grid surfaces with the same orientation. This 

smoothing occurs when the area of the receiver surface is (much) smaller than the area of the 
emitter surface. Therefore, it is recommended to use a (more or less) equidistant grid. 
The direct solar radiation through transparent materials (e.g. window glass) causes a sunlit spot 
on the internal surfaces of an internal zone. This spot will be sharper when the calculation grid is 

finer. 
Part of the incident direct solar radiation on an internal surface is reflected, using the reflection 
factor of the surface material colour (see D.9.1). This reflection factor may be dependent on the 
angle of incidence (when the reflection factor is defined by a reflection factor function). The 
reflected radiation is treated as described in section D.9.4. 
The remainder of the incident direct solar radiation on the internal surface is transmitted and 

absorbed. The transmitted and absorbed direct radiation are treated in the same way as 
transmitted and absorbed direct solar radiation on an external surface (cf. section D.9.2 and 
D.9.3). 

 
The transmitted diffuse solar radiation of an elementary grid surface is projected upon the other 
elementary grid surfaces (of the same internal zone) proportional to the view factors from the 
emitter surface to the receiver surfaces. 
Part of the incident diffuse solar radiation on an internal surface is reflected, using the reflection 
factor for diffuse radiation. The reflected diffuse radiation is treated as described in section D.9.4. 

The remainder of the incident diffuse solar radiation on an internal surface is transmitted and 
absorbed analogously to transmitted and absorbed diffuse solar radiation on an external surface 
(cf. section D.9.2 and D.9.3). 

D.9.6. Solar load to opaque surfaces behind transparent materials 

In previous versions of VOLTRA (VOLTRA v8.1 and before), in case a transparent construction 
element was placed in front of an opaque colour (𝑠 = 0), the radiation transmitted through the 
transparent construction element was ignored. If the user wanted to account for absorption and 
reflection of radiation by the opaque surface behind a transparent construction element, a very 
thin layer representing a virtual zone needed to be drawn manually between the transparent 
construction element and the opaque surface. From VOLTRA v9, this manual work-around is no 
longer necessary, as it is integrated in the calculation. 
 
An infinitely thin gap is assumed in the calculation between a transparent construction element 
and an opaque material surface, with view factor between both opposite surfaces (which is the 
contact surface) equal to 1. 
These infinitely thin gaps are treated as additional view factor zones, thus similar to internal 
zones, as described in section D.9.5. 

The direct and diffuse transmitted solar radiation that hits an opaque material behind a 
transparent material is added to the radiosity system for redistribution of diffuse radiation, based 
on diffuse reflection, absorption and transmission coefficients of the two opposite surfaces. The 
direct transmitted solar radiation is thus considered as additional diffuse transmitted solar 
radiation, so that it can be included in the radiosity system. 

The absorbed radiation at the opaque material surface, resulting from the solution of the 

radiosity system, is then converted to system node powers on the opaque material surface. 

D.10. Heat flow divergences 

The quality of the solution is mainly determined by the heat flow divergence of the total object, 
called in short object divergence. It is defined as the sum of all heat flows (positive and negative) 
entering the object, divided by half the sum of the absolute values of all these heat flows: 
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𝑂𝐷 =
|𝛷𝑖𝑛,𝑜 − 𝛷𝑜𝑢𝑡,𝑜|

0.5 ⋅ (|𝛷𝑖𝑛,𝑜| + |𝛷𝑜𝑢𝑡,𝑜|)
⋅ 100 

with 𝑂𝐷  = object divergence [%] 
𝛷𝑖𝑛,𝑜 = total incoming heat flow for the object [W] 

𝛷𝑜𝑢𝑡,𝑜 = total outgoing heat flow for the object [W] 

 
By using the factor 0.5 in the denominator, the denominator can be interpreted as the heat flow 
"passing" the object. 
The maximum possible object divergence is 200 %, i.e. when there are only incoming heat flows 

and no outgoing heat flows: 𝛷𝑖𝑛,𝑜 > 0 and 𝛷𝑜𝑢𝑡,𝑜 = 0 (or vice versa 𝛷𝑖𝑛,𝑜 = 0 and 𝛷𝑜𝑢𝑡,𝑜 > 0). 

An object divergence tolerance (cf. calculation parameter “Maximum heat flow divergence for 

total object”, see D.2.2) of 0.001 % is recommended as reliable stopping criterion. According to EN 

ISO 10211 the object divergence should be less than 0.1 %. 
 
In VOLTRA also a second heat flow divergence is used as stopping criterion: the maximum heat 
flow divergence for all nodes, called in short node divergence. It is defined in a similar way as the 
object divergence: 

𝑁𝐷 = 𝑚𝑎𝑥𝑛(
|𝛷𝑖𝑛,𝑛 − 𝛷𝑜𝑢𝑡,𝑛|

0.5 ⋅ (|𝛷𝑖𝑛,𝑛| + |𝛷𝑜𝑢𝑡,𝑛|)
⋅ 100) 

with 𝑁𝐷  = node divergence [%] 
𝛷𝑖𝑛,𝑛 = total incoming heat flow for the control volume around node n [W] 

𝛷𝑜𝑢𝑡,𝑛 = total outgoing heat flow for the control volume around node n [W] 

 
In VOLTRA the default node divergence tolerance is 1 % (cf. calculation parameter “Maximum 

heat flow divergence for any node”). 

Sometimes it happens that the node divergence does not decrease during the calculation. This is 
caused by an “unlucky” node, that is connected to its neighbouring nodes in an “unfavourable” 
way (due to obtuse triangles and/or strongly different thermal conductivities). Then a higher node 

divergence tolerance should be set. 
Cancel the node divergence test by using a node divergence tolerance of 201 % (which is higher 
than the theoretical 200 %, to be safe for possible numerical rounding errors). 

D.11. Batch calculation 

Menu command: File → Batch Calculation… 
 

The user can launch a batch calculation for several data files (with extension .vtr) in the same 
folder. The calculations are executed one after the other without any intervention of the user. 
To start a batch calculation call the command File → Batch Calculation…, select the data files in 

the Batch Calculation dialog box (hold down the <Ctrl> key to select more than one file) and 
press the Start button. It is not possible to select several data files located in different directories. 

 
Per data file a report file is written to disk, containing the output report corresponding to the 

report definition of the data file (cf. sections B.24 and B.25). The report file has the same file name 
as the data file, and has the extension .txt. 
When graphic output (i.e. snapshots at given time points and/or animation files of given time 
periods) is wanted afterwards, the data file should specify that step solutions must be saved to 
disk (cf. section B.26). 
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D.12. Command line program execution 

VOLTRA can be run from another application with a data file path (including directory and file 
extension .vtr) as parameter. 
Then no further user action is required. The program starts and ends automatically, and the 
output is a report file and/or a series of graphic snapshots (as in a batch calculation, cf. section 

D.10). 
The switch “/Automation” is required to activate the batch calculation. 
 
Example of command line launch: 
 

Run → “c:\...\Physibel\VOLTRA9\VOLTRA.exe” “..\Documents\Physibel\VOLTRA9\Demofiles\1 – 

SUMMER – SOLAR\flat_roof_solar.vtr” /Automation 
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CHAPTER E GRAPHIC OUTPUT 

E.1. Graphic Output window 

The Graphic Output window (which covers the complete VOLTRA application window) is opened 

with the command Output → Graphic Output. 

To return to the main VOLTRA window, choose the command File → Exit. 

 

   
 

The material colour, boundary condition colour, temperature or heat flux (dependent on the 
current view option) under the mouse cursor point is shown in the status bar at the bottom of the 

Graphic Output window. 

E.2. Animate functions 

The animate functions are available through the Animate submenu. 

 

   
 
The next functions are only available when solution files (*.sol) of a calculation are present on disk 
(see section B.26): 
First Time Step Loads the first solution file (for the start of the calculation duration, after 

the precalculation duration). 
Next Time Step Loads the next solution file. 
Previous Time Step Loads the previous solution file. 
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Go To… Loads the solution file of a time step (of the calculation duration) 

entered by the user. 
Play Shows successively all solution files starting from the current time step. 

The playing can be stopped by pressing the <Esc> key. 

E.3. Save animation images 

Menu command: File → Save Animation Images… 

A sequence of all animation images (as a result of the command Animate → Play) can be saved 

on disk as separate .png files. 
 
A Save As dialog box is opened to prompt for a file name. 
The image size of saved bitmap and font size of legend text are defined via Settings → Image 

Size…. 
 
The solution files are loaded consecutively (started with the first solution at time 0000:00:00:00), 

shown in the Graphics Output window and saved. A 4 digit number (starting from 0000) is 

appended to the chosen file name to generate the different PNG files. 
Saving animation images can be interrupted by pressing the <Esc> key. 

E.4. Projections and clip object 

Projection submenu 

 

Clip submenu 

 

 

− Projection → Perspective: same 3D perspective view as in Image window (see C.4). 

− Projection → Section …: section view through object along grid coordinate. 

 

The clip object boundaries as defined in either the Clip Object window from the main window (cf. 

section C.10) or the Clip Object dialog box (Clip → Clip Object… from the Graphics Output 

window) are used as section definitions. 

The view directions for the sections through the minimum and maximum clip coordinates are 

facing each other (i.e. viewing towards the clipped object). 
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By editing the clip coordinates, cross sections through all grid planes are possible. 

If a clipping plane does not intersect the object, then the corresponding section view is empty. 
Individual colours can also be clipped from the object (Clip → Clip Colour), similarly as in the 
main window (C.11). 
 

Reset all clip coordinates using Clip → Clip Off. 

E.5. Zoom commands 

Zoom submenu 

 
 

The zoom commands are identical to those of the Image window in the main menu (see C.3). 

However a mouse drag movement in rotate or pan mode works not dynamically as in the Image 

window (because the Graphic Output window does not make use of OpenGL hardware 

acceleration). A rubber-band vector is drawn, and after releasing the left mouse button the new 
view is painted. 
Zooming in and out is also possible via scrolling forward and backward of the mouse wheel. 

E.6. View submenu 

 
 
View → Legend: show a legend bar at the right side of the figure 
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Remark 
For temperature dependent thermal conductivities the values that are shown in the legend (when 
the view option View → Fill Materials is chosen), are all taken at 10°C. 

E.6.1. Lines 

The first 4 options can be switched on or off independently: 
− View → Object Lines: show object contour lines. 

− View → Grid Lines: show grid lines on object surfaces. 
− View → Isothermal Lines: show isothermal lines conform to the temperature range 

parameters (cf. section E.7). 
Only possible when a calculation solution is available. 

− View → Isoflux Lines: show isoflux lines conform to the flux range parameters (see E.7). 
Only possible when a calculation solution is available. 

E.6.2. Fill modes 

One of the following fill modes is to be selected: 

− View → Fill Materials: fill material surfaces using the object block colours (as defined in the 

Colours window). 

The status bar shows the colour number and name of the material surface under the 
mouse cursor point. 

− View → Fill BCs: fill material surfaces using the adjacent surface boundary condition block 

colours (as defined in the Colours window). 

If no surface boundary condition is active on a material surface (i.e. an implicit adiabatic 
boundary condition is assumed), then the fill colour is light yellow. 
The status bar shows the colour number and name of the boundary condition imposed on 

the material surface under the mouse cursor point. 
− View → Fill Temperatures: fill material surfaces using temperature colours conform to the 

temperature range parameters (see E.7) and of the selected thermal palette (see A.8 and 

E.7). 
The status bar shows the temperature of the material surface under the mouse cursor 
point. 

Only possible when a calculation solution is available. 

− View → Fill Isofluxes: fill material surfaces using isoflux colours conform to the flux range 
parameters (see E.7). 

Only possible when a calculation solution is available. 

− View → Fill Absorbed Solar Fluxes: when the solar fluxes are calculated (i.e. after Calc → 

Calc Solar Fluxes or Calc → Calc System) and the calculation step solutions (.sfd and .sfx 
files) are saved on disk (B.26), this option allows to visualise the absorbed solar fluxes on 
the object surfaces, conform the flux range (see E.7). 
For transparent surfaces the total absorbed solar flux is shown, before distributing the 
absorbed solar power into node powers within the wall behind the transparent surface 
(D.9.3). 
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− View → Fill Off: switch off filling. 

E.6.3. Sun position and obstacles 

View → Sun Position 

 
The sun position (azimuth and altitude) in the horizontal coordinate system (in which the plane XY 
coincides with the horizon, the X axis points to the north, the Y axis points to the west, and the Z 

axis points to the zenith) at any time can be viewed with View → Sun Position. 
 
The parameters that define the position of the sun are: 

- North orientation (Edit → Solar Data…). 
- Geographic position (Edit → Solar Data…). 
- Day of year at start of calculation (Edit → Calculation Parameters…). 
- Time setting (Animate → Go To…). 

The start of calculation corresponds with time 0000:00:00:00. 
 

If the toggle View → Sun Obstacles is on, the sun obstacles as defined in the Sun Obstacles 

window (B.19) are shown in grey. 
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The 3D image can be rotated with Zoom → Rotate (Rotate mode is activated automatically by 
holding down the mouse wheel). 

The perspective viewpoint (azimuth and altitude from the midpoint of the bitmap to the observer 
in the horizontal coordinate system) is entered with Zoom → Perspective View…. 

All other zoom functions are suppressed while the option View → Sun Position is used. 
 

           
 
Use the function Animate → Play to show the sun position changing with time. 
The time step defined in the Calculation Parameters dialog box (Edit → Calc Parameters…) is 
used as animation time step. 

E.6.4. Sun shaded image 

View → Shadow 

 
When the sun is present in the object model (which requires the presence of a solar zone, i.e. a 
colour of type BC_SIMPL or BC_SKY with sun input parameter set, see B.10.8), a sun shaded 

image can be generated. 
 

A sun shaded image can be generated before the system calculation is done. Sun obstacles (as 

defined in the Sun Obstacles window, B.19) are ignored. 
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Sunlit surfaces are shown on external surfaces bordering a solar zone, and on material surfaces 

of internal zones through transparent walls. If wanted, the object may be clipped, using Edit → 
Clip Object (as in the second figure below, which is a top view with the ceiling clipped off). 
 

 

 
An animation with sun shaded images can be made using Animate → Play. The time step defined 

in the Calculation Parameters dialog box (D.2.1) is used as animation time step. 

E.6.5. Temperature profile along a grid line 

For any user defined grid line a temperature graph through the intersected material layers can 
be drawn per calculation time step. 

First the desired grid line must be defined using the command View → Temperature Profile Line 
Definition… 
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In the dialog box choose the grid line direction: 
- X, Y or Z (in the XYZ coordinate system), or 
- R, C or L (in the RCL coordinate system). 

Then define the grid coordinates of the starting node (“from”) and ending node (“to”) of the line. 
 

The toggle command View → Temperature Profile shows the temperature graph. 
 

 
 

The horizontal axis shows the grid coordinates along the chosen grid direction. 
The current calculation time step is displayed at the bottom right (and can be modified, e.g. using 
Animate → Go To …). 

The vertical axis shows the temperature scale conform to the temperature range parameters 
(see E.7). 

The blue function line corresponds to the temperature solution at the current time step. 
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E.7. Settings 

 
 

Settings → Temperature Range… 

- Minimum temperature [°C] in graphic output. 

- Maximum temperature [°C] in graphic output. 
- First (or minor) increment [°C].  

Used for temperature filling (View → Fill Temperatures) and isothermal lines  
(View → Isothermal Lines). 

- Second (or major) increment [°C] (must be a multiple of first increment).  
Only used with isothermal lines (View → Isothermal Lines). 

- Single temperature value [°C] (e.g. dew point).  
Only used with isothermal lines (View → Isothermal Lines). 

 

 
 

Settings → Flux Range…  
 

 
 
Settings → Line Styles…  
A colour field can be edited by double clicking with the left mouse button, which opens a Colour 
dialog box in which the colour value (RGB components) can be defined. 
 

The width of isothermal lines can be set to 0 pixels to hide them. This is useful when e.g. only the 

second isothermal lines are desired in the figure. 
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Settings → Fill Colours… 

 

  
 

Colours with automatically calculated properties (see D.1) are clustered thematically in the 

Graphic Output window according to the categories of the Fill Colours dialog box, to avoid a 

potentially long list of colours of the same type (and subtype and standard) with small variations 
in the calculated thermal property. The fill colour of the clusters can be edited by double clicking 

on it with the left mouse button, which opens a Colour dialog box in which the colour can be 
defined. 
 
Settings → Thermal palette… 
 

 
 

The selection of the thermal palette is synchronised with that selected in the main window (see 
A.8). 
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Settings → Image Size… 

Set bitmap size for saving PNG files (File → Save Image... and File → Save Animation Images…). 
 

   
 
The font size refers to text characters in the legend or labels. 
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CHAPTER F TEXT OUTPUT 

F.1. Text Output window 

The Text Output window (which covers the complete VOLTRA application window) is opened with 

the command Output → Text Output. 

To return to the main VOLTRA window, press the <Esc> key or choose the command File → Exit. 

 

 
 

The text within the Text Output window can be edited. 

F.2. File commands 

File submenu 

 
 

- File → Save As… 

Save the whole text in the current Text Output window into a Microsoft Word document 

(extension .docx) on disk. 

- File → Save to CSV Files 

Save the text output to CSV files for use in a spreadsheet program (e.g. Microsoft Excel). 

- File → Exit 

Return to main VOLTRA window. 
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F.3. View options 

F.3.1. Input data 

The input data is shown in the Text Output window using the command View → Input Data. 
 

 
VOLTRA - Input Data 

 

VOLTRA data file: 3D_room_corner.vtr 

 

GRID 

No.            R         C         L 

              [cm]      [cm]      [cm]   

1-3           10.000     5.000     2.500 

3-5            5.000     5.000     2.500 

5-7            5.000     5.000     2.500 

7-9            2.500     2.500     2.500 

9-11           2.500     2.500     2.500 

11-13          2.500     2.500     2.500 

13-15          2.500     2.500     5.000 

15-17          2.500     2.500     5.000 

17-19          2.500     2.500     5.000 

19-21          2.500     7.500     5.000 

21-23          2.500     7.500     5.000 

23-25          2.500    15.000     5.000 

25-27          2.500    15.000     5.000 

27-29          2.500    15.000    10.000 

29-31          2.500              10.000 

31-33          5.000              10.000 

33-35          5.000              10.000 

35-37         10.000           

37-39         10.000           

39-41         10.000           

41-43         10.000           

Sum          100.000    90.000    90.000 

 

BLOCKS 

No.   Col.    Rmin  Rmax  Cmin  Cmax  Lmin  Lmax 

1     170        1     3     1    29     1    35 

2     174       23    43     1    29     1    35 

3     180        3     7     7    29     9    35 

4     151        7    11     7    29     9    35 

5     164       11    23     7    29     9    35 

6     136        3    43     1    29     1     9 

7     136        3    43     1     7     9    23 

8     136        3    23     1     7    23    35 

 

No.   Col.        Rmin      Rmax      Cmin      Cmax      Lmin      Lmax 

1     170        0.000    10.000     0.000    90.000     0.000    90.000 

2     174       40.000   100.000     0.000    90.000     0.000    90.000 

3     180       10.000    20.000    15.000    90.000     0.000    80.000 

4     151       20.000    25.000    15.000    90.000     0.000    80.000 

5     164       25.000    40.000    15.000    90.000     0.000    80.000 

6     136       10.000   100.000     0.000    90.000    80.000    90.000 

7     136       10.000   100.000     0.000    15.000    50.000    80.000 

8     136       10.000    40.000     0.000    15.000     0.000    50.000 

 

FUNCTIONS 

T01: SINE 

  Mean value = 5°C 

  Amplitudo = 5°C 

  Period = 1440 min 

  Offset = 360 min 

T02: STEP2 

  Level 1 = 20°C 

  Level 2 = 10°C 

  Period = 1440 min 

  Duration level 1 = 720 min 

  Transition = 120 min 

  Start level 1 = 480 min 

 

COLOURS 

Col. Type      Subtype   Phys.     Geom.     Name                       eps1 / eps2  lambda   eps 

                         flow      flow                                 [- / -]      [W/mK]   [-] 

136  MATERIAL                                reinforced_concrete_(stee                2.500       

151  MATERIAL                                insulation_0.035_W/mK                    0.035       

164  MATERIAL                                masonry_semi-heavy                       0.600       

170  BC_SIMPL  HE                            exterior                                             

174  BC_SIMPL  NIHIL                         interior_(normal)                                    

180  MATERIAL                                masonry_heavy                            0.900       

 

Col.    rho       c       t       h       q      ta      hc        Pc      tr   Sun      rs      ts  Standard 

     [kg/m3] [J/kgK]   [°C] [W/m²K]  [W/m²]    [°C] [W/m²K]     [W/m]    [°C]           [-]     [-]           

136  2500.0  1000.0                                                                    0.10  0.00           
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151    30.0  1000.0                                                                    0.10  0.00           

164  1350.0   840.0                                                                    0.10  0.00           

170                     T01   25.00       0                                     NO                 EN6946   

174                     T02    7.70       0                                     NO                 NIHIL    

180  1850.0   840.0                                                                    0.10  0.00           

 

OUTPUT NODES 

No.      R     C     L 

1       23     1    35 

2       23     1    23 

3       23     7    23 

4       23     7     9 

5       23    29     9 

6       23    29    35 

 

Calculation parameters 

Time step interval = 0000:00:10:00 

Start-up calculation duration = 0000:00:00:00 

Calculation duration = 0002:00:00:00 

Start of calculation = 0000:00:00:00 

Iteration cycles = 5 

Maximum number of iterations (within each iteration cycle) = 10000 

Maximum temperature difference (within each iteration cycle) = 0.0001°C 

Heat flow divergence for total object = 0.001 % 

Heat flow divergence for worst node = 1 % 

Automatic recalculation of CEN-values 

Default temperature difference across airspace = 10°C 

F.3.2. Results per time step 

Main calculation results for a specific time step are shown using the command View → Time Step 

Results. This is only available for the time steps for which the solution is saved to disk (see B.26). 
The time step can be set using one of the first four commands in the Edit submenu, which are 

analogous as in the Animate submenu in the Graphic Output window (cf. section E.2). 

 

 
 
First Time Step Loads the first solution file (for the start of the calculation duration,  
    after the precalculation duration). 
Next Time Step Loads the next solution file. 
Previous Time Step Loads the previous solution file. 
Go To…  Loads the solution file of a time step (of the calculation duration)   
    entered by the user. 

 
 
VOLTRA - Calculation Results 

 

VOLTRA data file: 3D_room_corner.vtr 

Number of nodes = 4000 

 

Time step 0002:00:00:00 

 

Heat flow divergence for total object = 1.55984e-11 % 

Heat flow divergence for worst node = 5.41413e-09 % 

 

Col. Type      Name                 tmin    R    C    L      tmax    R    C    L 

                                    [°C]                     [°C]              _ 

136  MATERIAL  reinforced_concrete_(stee      3.30    3   21    9     16.28   43    1    1 

151  MATERIAL  insulation_0.035_W/mK          3.74    7   25   27     14.82   11   29   35 

164  MATERIAL  masonry_semi-heavy             9.42   11    7    9     15.03   13   29   35 

170  BC_SIMPL  exterior                       1.29    3   25   27      4.11    3    1   35 

174  BC_SIMPL  interior_(normal)             10.93   23    1   35     15.36   43    7    9 

180  MATERIAL  masonry_heavy                  1.29    3   25   27      7.66    7    7    9 

 

Col. Type      Name                   ta   Flow in  Flow out 

                                    [°C]       [W]       [W] 

170  BC_SIMPL  exterior                                 0.00     43.65 

174  BC_SIMPL  interior_(normal)                        0.00     35.15 
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The temperature in the corner nodes for a specific time step are shown using the command 
View → Corner Nodes. 

 
VOLTRA - Temperatures in corner nodes 

 

VOLTRA data file: PilotexVoltra.vtr 

Number of nodes = 13902 

 

Time step 0002:16:00:00 

 

     R     C     L         t 

                        [°C] 

     3     3     3      7.09 

     3     3    45      7.50 

     3    57     3      7.08 

     3    57    45      7.73 

    27    27    19      8.69 

    27    27    45     13.07 

    27    57    19     10.90 

    27    57    45     16.05 

    55     3     3      7.08 

    55     3    45      7.73 

    55    27    19     10.90 

    55    27    45     16.06 

    55    57     3      7.25 

    55    57    19     14.91 

 

The temperature in the node BC’s of type POWER for a specific time step are shown using the 
command View → Node BCs. 

 
Hint 
To get the temperature in a specific grid point, add a dummy node BC with fixed power = 0 W. 

F.3.3. Report output 

For the items defined in the Report Definition window (cf. section B.24) a report can be output 
with records at a given frequency of time steps (cf. section B.25). The command View → Report 

Output shows the contents of the report written during the calculation. This report is automatically 
written to both a TXT file and CSV file in the VOLTRA data file directory. 
 
In the report, per report time step one line of values is written (no value (‘-‘) is given for logically 
impossible report items). The report values are separated with tab characters in the TXT file. Each 
column in the table corresponds to a report item. The meaning of the columns is explained in the 

header. 

 
VOLTRA - Report Output 

 

VOLTRA data file: PilotexVoltra.vtr 

 

Column 1: Time [dddd:hh:mm:ss] 

Column 2: Colour 1, BC temperature [°C] 

Column 3: Colour 2, BC temperature [°C] 

Column 4: Output node 1, temperature [°C] 

Column 5: Output node 2, temperature [°C] 

Column 6: Output node 3, temperature [°C] 

Column 7: Output node 4, temperature [°C] 

Column 8: Colour 1, sum of heat flows into object [W] 

Column 9: Colour 1, sum of heat flows out of object [W] 

Column 10: Colour 2, sum of heat flows into object [W] 

Column 11: Colour 2, sum of heat flows out of object [W] 

 

0000:00:00:00   -9.66   10.00   -0.79    2.11    7.99   -9.26    0.26   57.64   57.37    0.00 

0000:01:00:00  -10.00   10.00   -0.79    2.11    7.99   -9.45    0.29   69.51   57.37    0.00 

0000:02:00:00   -9.66   10.00   -0.80    2.11    7.99   -9.36    0.35   50.12   57.38    0.00 

0000:03:00:00   -8.66   10.00   -0.81    2.11    7.99   -8.83   12.40   24.76   57.40    0.00 

0000:04:00:00   -7.07   10.00   -0.80    2.11    7.99   -7.84   49.01   13.33   57.38    0.00 

0000:05:00:00   -5.00   10.00   -0.76    2.14    7.99   -6.42   93.55    5.66   57.29    0.00 

0000:06:00:00   -2.59   10.00   -0.66    2.21    8.00   -4.62  142.43    3.95   57.06    0.00 

0000:07:00:00    0.00   20.00   -0.05    3.05    9.96   -2.55  184.90    2.48  184.52    0.00 

0000:08:00:00    2.59   20.00    0.58    3.80   11.32   -0.33  216.85    1.49  168.39    0.00 

0000:09:00:00    5.00   20.00    1.20    4.41   12.01    1.89  235.03    0.90  159.15    0.00 

0000:10:00:00    7.07   20.00    1.90    5.04   12.54    3.98  237.44    0.59  151.36    0.00 

0000:11:00:00    8.66   20.00    2.67    5.71   13.00    5.80  223.36    0.49  144.10    0.00 

0000:12:00:00    9.66   20.00    3.49    6.40   13.43    7.23  193.31    0.44  137.10    0.00 

0000:13:00:00   10.00   20.00    4.35    7.11   13.83    8.17  149.00    0.40  130.29    0.00 

0000:14:00:00    9.66   20.00    5.19    7.80   14.21    8.57   93.33    0.47  123.68    0.00 
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0000:15:00:00    8.66   20.00    6.00    8.46   14.58    8.39   30.36    1.12  117.33    0.00 

0000:16:00:00    7.07   20.00    6.74    9.07   14.92    7.66    0.24   38.34  111.30    0.00 

0000:17:00:00    5.00   20.00    7.38    9.61   15.25    6.41    0.14  104.91  105.68    0.00 

0000:18:00:00    2.59   20.00    7.89   10.06   15.54    4.75    0.29  166.66  100.53    0.00 

0000:19:00:00    0.00   20.00    8.26   10.41   15.82    2.78    0.43  219.28   95.94    0.00 

0000:20:00:00   -2.59   10.00    8.04    9.93   14.11    0.64    0.55  259.30    0.50   36.47 

0000:21:00:00   -5.00   10.00    7.76    9.51   12.97   -1.53    0.64  283.90    1.10   25.01 

0000:22:00:00   -7.07   10.00    7.45    9.19   12.49   -3.58    0.70  291.41    1.68   20.08 

0000:23:00:00   -8.66   10.00    7.04    8.83   12.15   -5.36    0.73  281.38    2.43   16.51 

0001:00:00:00   -9.66   10.00    6.54    8.42   11.86   -6.76    0.71  254.61    3.43   13.46 

0001:01:00:00  -10.00   10.00    5.99    7.97   11.59   -7.68    0.65  213.03    4.66   10.71 

0001:02:00:00   -9.66   10.00    5.41    7.51   11.33   -8.06    0.57  159.54    6.13    8.22 

0001:03:00:00   -8.66   10.00    4.84    7.06   11.08   -7.87    0.52   97.88    7.80    6.00 

0001:04:00:00   -7.07   10.00    4.32    6.64   10.84   -7.13    8.16   39.94    9.65    4.12 

0001:05:00:00   -5.00   10.00    3.89    6.28   10.62   -5.88   55.12   21.77   11.57    2.54 

0001:06:00:00   -2.59   10.00    3.56    6.00   10.41   -4.21  102.51    8.93   13.56    1.36 

0001:07:00:00   -0.00   20.00    3.79    6.52   12.17   -2.23  149.64    4.84  142.87    0.00 

0001:08:00:00    2.59   20.00    4.07    6.97   13.35   -0.08  186.62    3.26  129.74    0.00 

0001:09:00:00    5.00   20.00    4.38    7.31   13.87    2.09  208.70    2.17  123.31    0.00 

0001:10:00:00    7.07   20.00    4.80    7.70   14.24    4.14  214.19    1.44  118.15    0.00 

0001:11:00:00    8.66   20.00    5.31    8.14   14.56    5.93  202.64    1.03  113.32    0.00 

0001:12:00:00    9.66   20.00    5.91    8.64   14.86    7.34  174.80    0.85  108.59    0.00 

0001:13:00:00   10.00   20.00    6.56    9.16   15.14    8.27  132.52    0.88  103.88    0.00 

0001:14:00:00    9.66   20.00    7.22    9.69   15.41    8.65   78.74    1.15   99.23    0.00 

0001:15:00:00    8.66   20.00    7.86   10.20   15.68    8.46   17.61    2.19   94.68    0.00 

0001:16:00:00    7.07   20.00    8.45   10.67   15.93    7.72    0.06   50.73   90.33    0.00 

0001:17:00:00    5.00   20.00    8.94   11.08   16.16    6.47    0.20  116.43   86.26    0.00 

0001:18:00:00    2.59   20.00    9.33   11.41   16.38    4.80    0.35  177.19   82.55    0.00 

0001:19:00:00    0.00   20.00    9.58   11.65   16.58    2.82    0.48  228.93   79.28    0.00 

0001:20:00:00   -2.59   10.00    9.26   11.08   14.81    0.68    0.60  268.15    0.02   51.41 

0001:21:00:00   -5.00   10.00    8.88   10.57   13.62   -1.49    0.69  292.03    0.10   38.28 

0001:22:00:00   -7.07   10.00    8.48   10.17   13.08   -3.54    0.74  298.88    0.24   31.88 

0001:23:00:00   -8.66   10.00    7.99    9.73   12.69   -5.33    0.76  288.26    0.57   26.91 

0002:00:00:00   -9.66   10.00    7.42    9.24   12.35   -6.73    0.74  260.95    1.21   22.59 

0002:01:00:00  -10.00   10.00    6.79    8.73   12.04   -7.66    0.69  218.87    2.12   18.68 

0002:02:00:00   -9.66   10.00    6.15    8.21   11.74   -8.04    0.60  164.92    3.32   15.14 

0002:03:00:00   -8.66   10.00    5.52    7.71   11.46   -7.85    0.53  102.84    4.70   11.92 

0002:04:00:00   -7.07   10.00    4.95    7.25   11.19   -7.11    6.96   43.29    6.26    9.08 

0002:05:00:00   -5.00   10.00    4.47    6.84   10.94   -5.86   53.42   24.28    7.92    6.63 

0002:06:00:00   -2.59   10.00    4.10    6.51   10.70   -4.19  100.38   10.69    9.56    4.54 

0002:07:00:00   -0.00   20.00    4.29    6.99   12.44   -2.21  146.50    5.29  136.22    0.00 

0002:08:00:00    2.59   20.00    4.53    7.41   13.59   -0.07  183.67    3.63  123.58    0.00 

0002:09:00:00    5.00   20.00    4.80    7.72   14.10    2.10  205.93    2.46  117.60    0.00 

0002:10:00:00    7.07   20.00    5.19    8.07   14.45    4.16  211.59    1.68  112.85    0.00 

0002:11:00:00    8.66   20.00    5.67    8.49   14.75    5.94  200.21    1.21  108.42    0.00 

0002:12:00:00    9.66   20.00    6.25    8.96   15.03    7.35  172.53    1.01  104.04    0.00 

0002:13:00:00   10.00   20.00    6.87    9.46   15.30    8.28  130.44    1.03   99.67    0.00 

0002:14:00:00    9.66   20.00    7.51    9.96   15.56    8.66   76.84    1.32   95.32    0.00 

0002:15:00:00    8.66   20.00    8.13   10.45   15.81    8.47   15.92    2.42   91.06    0.00 

0002:16:00:00    7.07   20.00    8.69   10.90   16.05    7.73    0.06   52.51   86.97    0.00 

0002:17:00:00    5.00   20.00    9.17   11.30   16.28    6.48    0.21  118.08   83.14    0.00 

0002:18:00:00    2.59   20.00    9.54   11.61   16.49    4.81    0.35  178.72   79.66    0.00 

0002:19:00:00    0.00   20.00    9.77   11.84   16.68    2.83    0.49  230.35   76.60    0.00 

0002:20:00:00   -2.59   10.00    9.43   11.25   14.90    0.68    0.60  269.46    0.01   53.88 

0002:21:00:00   -5.00   10.00    9.04   10.73   13.70   -1.49    0.69  293.24    0.06   40.55 

0002:22:00:00   -7.07   10.00    8.63   10.32   13.15   -3.54    0.75  300.01    0.17   33.94 

0002:23:00:00   -8.66   10.00    8.13    9.87   12.76   -5.33    0.77  289.30    0.43   28.74 

0003:00:00:00   -9.66   10.00    7.55    9.37   12.41   -6.73    0.75  261.91    0.99   24.20 

F.4. Settings 

Settings submenu 

 

F.4.1. Output precision 

Menu command: Settings → Decimals… 
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CHAPTER G VOLTRA TEMPLATE FILES 

G.1. General 

VOLTRA makes use of template files containing default information for a number of functions. 
These template files are each saved in the application data folder or personal folder (see A.6) of 
the user account on the computer where VOLTRA is installed. The path to the application data 
folder is C:/Users/username/Appdata/Roaming/Physibel/VOLTRA9 (AppData is a hidden folder 

by default in Windows). 

 
The template files used by VOLTRA are: 

- ColourDatabase.vtr (G.2) 
 

The use of these template files in different VOLTRA functions has been outlined throughout the 
manual. In the following sections, handling and customization of these template files is briefly 
discussed. 

G.2. Colour database 

The colour database file ColourDatabase.vtr is saved in the application data folder 

(C:/Users/username/Appdata/Roaming/Physibel/VOLTRA9). The colour database contains 
predefined material and boundary condition properties and is loaded at every VOLTRA start-up 
(see B.1). 

 
It is advisable to add frequently used materials and boundary conditions to the colour database. 
These predefined colours of the colour database are then available for new colours in any 

document. 
The command File → Open Colour Database… allows to modify the 256 available predefined 
colours of the colour database. After editing the colour data, the file should be saved (File → 

Save) to adapt the colour database on disk. 
 
Alternatively, if a user wants to save a custom file as colour database, this is possible by saving it 

with the name ColourDatabase.vtr in the application data folder (File → Save as…) thus 
overwriting the default file. In the application data folder, the default colour database is present 
as ColourDatabase_PhysibelDefault.vtr. This file can be saved as ColourDatabase.vtr to restore 
the original colour database. 
 
The ColourDatabase.vtr file replaces the Voltra.vtr file in older versions of VOLTRA. Users who had 
been working with a customised Voltra.vtr file, can thus easily transfer to the new system by 

opening Voltra.vtr and saving it with the name ColourDatabase.vtr in the application data folder. 
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CHAPTER H PROGRAM FUNCEDIT 

H.1. Introduction 

The program FUNCEDIT is a utility program to edit and visualise external function files for use in 
non-steady state Physibel programs (BISTRA, VOLTRA), where they are used as dynamic 
boundary condition specifications (see B.12.2). 
 
After starting FUNCEDIT or creating a new function using the command File → New, a null 

temperature function of length 24 hours (with hourly values of 0°C) is displayed. 
 

 
 
An existing function file on disk is read using the command File → Open…. The function type can 

be chosen in the Open dialog box. 
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H.2. Function type 

The following function types are available: 

Function type Unit ext. Use in VOLTRA 

temperature [°C] .fte boundary condition temperature 

horizontal global solar radiation [W/m2] .fsg boundary condition solar zone 

horizontal diffuse solar radiation [W/m2] .fsd boundary condition solar zone 

direct solar radiation [W/m2] .fsb not used 

solar radiation [W/m2] .fse not used 

infrared radiation [W/m2] .fir boundary condition heat flux 

power [W] .ffh boundary condition power 

thermal conductivity [W/(m.K)] .fco material property 
time-dependent thermal conductivity 

surface heat transfer coefficient [W/(m².K)] .fht boundary condition 
total surface heat transfer coefficient or 
convective heat transfer coefficient 

ventilation rate [/h] .fvr ventilation volume flow rate [m3/s] 

 
Remark 
The ventilation rate in FUNCEDIT is shown with unit /h, which is used in the (now deprecated) 
Physibel program CAPSOL. However in VOLTRA the same function type is used for ventilation 

volume flow rates, with unit m3/s. So for VOLTRA ventilation functions the unit specifier [/h] in 

FUNCEDIT should be read as [m3/s]. 

H.3. Function parameters 

General header information of a function file is edited via the command Edit → Parameters…. 

 

 
 
A dialog box is opened where the following parameters can be edited: 

- Function type: see section H.2. 
- Comment: text description of the function. 
- Previous function and next function: file name of a function that precedes the current 

function (previous function) or comes next to the current function (next function). The 
previous and/or next function may be the same as the current function, in which case the 
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check box “the same” is marked. 

If the time span of a VOLTRA simulation is larger than the time span of the function 
definition, it is necessary to know which function comes next to the current one. In case a 
start-up calculation is used, a previous function is required. If the previous and the next 
function are checked as the same, then the current function corresponds to the definition 

of an infinite periodic function, with period the length of the current function. 
- Interpolation: linear or step. Intermediate function values are either obtained by linear 

interpolation (linear function) or remain constant during the whole time step interval (step 
function). 

- Time step [dddd:hh:mm:ss]: time interval between two successive function values in the 
function data window (see section H.4). 

- Total steps: number of time steps required to span the total function length. This number is 
equal to the number of function values minus 1. The function length or duration equals the 
time step multiplied by the total number of steps. 

- Number of decimals: number of digits after the decimal point, for all function values in the 
function data window (see section H.4) and in the function file. 

- Number of columns: used in the function data window (see section H.4) and in the function 
file. 

- Day number at function start [1..365]: day number in the year on which the function starts. 
The “i” button gives information about the start days of each month. 

 

 
 

- Latitude [°N], longitude [°E] and time zone [h]: to position a function climate station on the 

globe. 
- Chart time unit and chart time format: labelling information for the time axis in the 

function chart. This information is not stored in the function file. 

H.4. Function data 

The function values at regular time step intervals can be edited in the function data window, 
opened with the command Edit → Data. The table format is controlled by the function 

parameters (see section H.3). 

 
In the left (grey) column a time indication of the first value in the row is given. The table can be 
navigated by the mouse or by the arrow keys. 
A new value can be inserted after the current one using the command Edit → Insert After or the 

Insert key. The “total steps” parameter in the function parameters dialog box is adapted 
accordingly. 
A value can be deleted using the command Edit → Delete Value or the Delete key. 

Individual table cells can be copied and pasted by using the commands Edit → Copy (or 

<Ctrl+C>) and Edit → Paste (or <Ctrl+V>). 
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H.5. Graphic parameters 

The window that is opened when a new function is created or an existing function file is read, 
contains a graphic representation of the numerical function data entered in the data window. 
The red point in the graph corresponds to the function value in the current cell of the data 
window. 

 

 
 
The parameters about the graph can be edited in the Graphic submenu. 
 

 
 
The command Graphic → Set Scale… opens a dialog box containing scale parameters. 

The view range for both axes and tick mark distances can be set. 
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When a rectangle is drawn in the graph with mouse dragging (holding down the left mouse 

button), a zoom rectangle is defined. The corresponding zoom view is drawn when the left 
mouse button is released. The initial total view (with view range as defined in the Set Scale dialog 
box) can be restored by using the command Graphic → Zoom All or pressing the Home key. 

 
The commands Graphic → Primary Grid X and Graphic → Primary Grid Y enable to show grid 

lines through the primary tick marks on both axes X and Y. 
 
The command Graphic → Right Axis allows to draw also a vertical axis with tick marks at the right 

side of the chart border. 
 
The command Graphic → Save As Bitmap (PNG) opens a dialog box where you can enter the file 

name and size of the .png file, which will be saved in the same directory as where the function is 

stored. 

H.6. Using a spreadsheet program to create functions 

A function file can also be created using Microsoft Excel or another spreadsheet program. 
The spreadsheet contains 6 header rows (starting with the keywords COM, PRV, NXT, TIM, FMT 

and DAT) followed by data rows with function values. The syntax of the input data is given in the 
table below. Save the file (as text) in the function files directory, with the extension corresponding 
to the function type (cf. section H.2). 

If an existing function file, created with FUNCEDIT, has to be modified using a spreadsheet 
program, it is recommended first to set the parameter “number of columns” in the Function 

Parameters dialog box equal to 1. Then there will be only 1 column with function values in the 
spreadsheet (as in the figure below). 
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row number code input data 

 column A column B column C column D column 

E 

column F 

1 COM comment     

2 PRV name of the 

previous function 

* 

    

3 NXT name of the next 

function * 

    

4 TIM interpolation: 

0 = linear / 1 = 

step 

time step 

(in seconds) 

total number of steps   

5 FMT total number of 

characters of the 

function values 

number of 

digits after 

decimal 

point 

number of columns 

of function values 

minimu

m 

ordinate 

maximum 

ordinate 

6 DAT date number at 

function start 

latitude longitude time 

zone 

 

7  -  ...  -  

(7 + total steps) 

function 

type** 

function 

value 

(function 

value) 

(function 

value) 

(function 

value) 

(function 

value) 

* The extension of the file name may be omitted; Omit this line to specify the same previous / next function (or use the 

name *same*). 

** The function type as described in section H.2. 
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CHAPTER I RADCON MODULE 

I.1. Purpose 

The RADCON module is a program add-on feature to simulate more realistically the heat 
transfer between material surfaces and the adjacent environments. 
The heat transfer has the following components: 
• Radiation: based on view factors and material surface emissivities. 

• Convection: based on a (calculated) convective heat transfer coefficient applied to the contact 

surface between material and environment. 
• Conduction: in a (transparent) material with given thermal conductivity. 
 
The RADCON module offers a physically more correct alternative for: 
• The global surface heat transfer coefficient. 
• The equivalent thermal conductivity of an air cavity. 
 

  
principle of view factor based radiation heat transfer 

using BC_SKY (at a surface) 
principle of view factor based radiation 

heat transfer using TRANSMAT (in a cavity) 
 

I.2. Implementation 

The following colour types require the use of the RADCON module in VOLTRA: 
• TRANSMAT for a transparent material with known (or calculated) thermal conductivity 

(normally of still air or another gas) according to EN ISO 10077-2) 

Additionally to the gas conduction there is radiative heat transfer between the adjacent 
material surfaces (using their emissivities). 
If the transparent material is not fully surrounded by material surfaces, then the open side at 
the bitmap border is considered as an adiabatic surface, i.e. a radiation mirror with emissivity 
 = 0. 

If there is convection within the cavity, the thermal conductivity for still gas should be 
multiplied by the Nusselt number. 

• BC_FREE for an enclosure (normally fully surrounded by material surfaces, e.g. a cavity or a 
room) with unknown air temperature (free-floating air temperature), known surface heat flux 

(positive or negative), known (or calculated) convective heat transfer coefficient and known 
injected convective heat power (positive or negative). 
The unknown air temperature is calculated from the convective heat balance equation: 
Σ (convective heat transfer from environment to surface) = injected convective heat power. 

The radiation between the different surfaces bordering the environment are calculated based 
on view factors and surface emissivities. 
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When the environment is not completely surrounded by material surfaces, the open end (at 

the bitmap border) is considered to be a symmetry plane for heat transfer. The symmetry 
plane is simulated as a radiation mirror (with emissivity  = 0). 

• BC_SKY for an environment (normally not fully surrounded by material surfaces, i.e. open to 
the sky) with known air temperature, known radiation temperature, known surface heat flux 

(positive or negative) and known (or calculated) convective heat transfer coefficient. 
This implies there can be a resultant radiative heat flow and a resultant convective heat flow 
from the environment to the material surfaces. 

• BC_NOSKY for an environment with known air temperature, known surface heat flux (positive 
or negative) and known (or calculated) convective heat transfer coefficient. 
There is no radiation exchange with the environment (i.e. no sky radiation). The surfaces 

bordering the environment exchange radiation based on view factors and surface 
emissivities. 
The known air temperature implies there can be a resultant convective heat flow from the 

environment to the material surfaces. 
 
For use with RADCON the colour types MATERIAL and EQUIMAT also have a surface emissivity 

(defined in the Colours window), which is applied to the radiative heat transfer for the RADCON 
boundary conditions bordering the material. 
 
Combined convective and radiative heat transfer (BC_SIMPL, BC_FRE_S) 
The global (combined convective and radiative) heat flow is: 
𝑄 = ℎ ⋅ (𝜃𝑠 − 𝜃𝑏𝑐) ⋅ 𝐴 
𝑄  = global heat flow [W] 

ℎ = global heat transfer coefficient [W/(m2.K)] 
𝜃𝑠 = surface temperature [°C] 
𝜃𝑏𝑐 = environmental temperature [°C] 

𝐴 = surface area [m²] 
In this formula the environmental temperature is not defined precisely. It can be the air 
temperature, the dry resultant temperature or an interpolated value. Depending on that choice, 

an appropriate value for the global heat transfer coefficient must be chosen. 
 

Convective heat transfer (BC_FREE, BC_SKY, BC_NOSKY) 
The convective heat flow is: 
𝑄𝑐 = ℎ𝑐 ⋅ (𝜃𝑠 − 𝜃𝑎) ⋅ 𝐴 
𝑄𝑐 = convective heat flow [W] 
ℎ𝑐 = convective heat transfer coefficient [W/(m2.K)] 
𝜃𝑠 = surface temperature [°C] 
𝜃𝑎 = air temperature [°C] 
𝐴 = surface area [m²] 

The convective heat transfer coefficient ℎ𝑐 can be calculated based on the given subtype. 
 
Black radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
The radiative heat flow between two black surfaces is: 
𝑄𝑖𝑗 = 𝐴𝑖 ⋅ 𝐹𝑖𝑗 ⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑠𝑏𝑖 − 𝜃𝑠𝑏𝑗) 

𝑄𝑖𝑗 = radiative heat flow between black surface i and black surface j [W] 

𝐴𝑖 = area of surface i [m2] 
𝐹𝑖𝑗 = view factor from surface i to surface j (between 0 and 1) 

ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 
𝜃𝑠𝑏𝑖 = black surface temperature of surface i [°C] 
𝜃𝑠𝑏𝑗 = black surface temperature of surface j [°C] 
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For linear radiation the black radiation heat transfer coefficient is constant, defined as a 

calculation parameter (default value 5.1 W/(m2.K)). The value depends on the temperature range 
of the problem considered. Section I.3 contains a table with values of ℎ𝑟𝑏, depending on the 
mean temperature 𝑚 [°C] of the surfaces i and j and the temperature difference between the 
surfaces 𝑖𝑗 [°C]. The table shows that the ℎ𝑟𝑏-value mainly depends on the mean surface 

temperature 𝑚. 

The default value 5.1 W/(m2.K) is the ℎ𝑟𝑏-value at 10°C.  
 
For non-linear radiation: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑠𝑏𝑖

2 + 𝑇𝑠𝑏𝑗
2 ) ⋅ (𝑇𝑠𝑏𝑖 + 𝑇𝑠𝑏𝑗) 

𝜎 = 5.67 10-8 W(m2.K4) (Stefan-Boltzmann constant) 
𝑇𝑠𝑏𝑖 = 𝜃𝑠𝑏𝑖 + 273.16 [K] (absolute temperature of black surface i) 
𝑇𝑠𝑏𝑗 = 𝜃𝑠𝑏𝑗 + 273.16 [K] (absolute temperature of black surface j) 

The black radiation heat transfer coefficients are recalculated at the start of each new iteration 
cycle based on the temperatures obtained in the last iteration cycle. 

 
Grey radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
Real surfaces are not black (emissivity  = 1) but grey (emissivity  < 1). 

In the RADCON module each grey surface is connected to a black surface node. All black surface 

nodes are connected to each other in a star diagram. 
The radiative heat flow between the grey surface with given emissivity and the corresponding 
black surface is: 

𝑄𝑟 = 𝐴 ⋅
𝜀

1 − 𝜀
⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑠𝑏 − 𝜃𝑠) 

𝑄𝑟 = radiative heat flow between grey surface and black surface [W] 

𝐴 = surface area [m2] 
 = surface emissivity (0 ≤ ε < 1) 

ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 
𝜃𝑠𝑏 = black surface temperature [°C] 

𝜃𝑠 = (real) surface temperature [°C] 
For non-linear radiation: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑠𝑏

2 + 𝑇𝑠
2) ⋅ (𝑇𝑠𝑏 + 𝑇𝑠) 

𝑇𝑠𝑏 = 𝜃𝑠𝑏 + 273.16  [K] 
𝑇𝑠 = 𝜃𝑠 + 273.16 [K] 

The black radiation heat transfer coefficients are recalculated at the start of each new iteration 
cycle based on the temperatures obtained in the last iteration cycle. 

 
Iteration cycles for non-linear radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
Iteration cycles are used to calculate non-linear radiative heat transfer. At the start of each 
iteration cycle the black radiation heat transfer coefficients are updated using the local 
temperatures available at that moment. 

For the first iteration cycle the black radiation heat transfer coefficients have a constant value as 
defined in the Calculation Parameters dialog box. 

The total number of iteration cycles is defined in the Calculation Parameters dialog box. Normally 
5 iteration cycles are sufficient. A low number of iteration steps in the last iteration cycle ensures 
that the number of iteration cycles is OK. 
 
View factors (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
The view factors are calculated for all elementary surfaces (corresponding to edges in the mesh 
triangulation) bordering the environment (type BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT). 

Several environments of the same type (e.g. with different convective heat transfer coefficients) 
may touch one another. The view factors are calculated for the union space of these adjacent 
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environments. 

Adjacent environments of different type are not allowed. Then an error message is displayed at 
the start of the system calculation (Calc → Calc System). 
A boundary condition of type BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT is not allowed to 
occur in different zones (separated by a material). Each zone must be considered as a separate 

environment (having a different colour). An error message is displayed at the start of the system 
calculation, when this condition is not satisfied. 
First the view factor between two (elementary) surfaces, not obstructed by other surfaces, is 
calculated using an exact analytic formula. A very small view factor (i.e. smaller than the 
calculation parameter smallest accepted view factor) is neglected (rounded to 0). Then possible 
obstruction by other surfaces is estimated using several test rays between random points of both 

surfaces. The number of test rays is proportional to the unobstructed view factor. The maximum 
number of test rays (i.e. when the unobstructed view factor = 1) is defined as the calculation 
parameter number of visibility rays between radiative surfaces). 

After calculation of all view factors a correction is made to smooth away possible errors (e.g. due 
to the limited number of visibility test rays), so that the sum of view factors always equals 1, and 
the view factor reciprocities are respected. 
The total number of calculated view factors (and hence the calculation time and required 
memory space) is a quadratic function of the number of elementary surfaces (= triangulation 
edges) in the largest view factor zone. 
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I.3. Table for black radiation heat transfer coefficient 

The following table shows the black radiation heat transfer coefficient. 
The values are obtained using the formula: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑖

2 + 𝑇𝑗
2) ⋅ (𝑇𝑖 + 𝑇𝑗) 

with 𝜎 =  5.67*10-8 W/(m2.K4) (Stefan-Boltzmann constant) 

 

black radiation temperature difference between the surfaces i and j 
heat transfer 

coeff. 
ij [°C] 

hrb [W/m2K] 0.00 5.00 10.00 15.00 20.00 25.00 30.00 35.00 40.00 45.00 50.00 
 -20.00 3.68 3.68 3.68 3.68 3.69 3.69 3.69 3.70 3.70 3.71 3.72 
 -15.00 3.90 3.90 3.90 3.91 3.91 3.91 3.92 3.92 3.93 3.93 3.94 
 -10.00 4.13 4.13 4.13 4.14 4.14 4.14 4.15 4.15 4.16 4.16 4.17 

 -5.00 4.37 4.37 4.37 4.38 4.38 4.38 4.39 4.39 4.40 4.40 4.41 
mean 0.00 4.62 4.62 4.62 4.63 4.63 4.63 4.64 4.64 4.65 4.65 4.66 
temp. 5.00 4.88 4.88 4.88 4.88 4.89 4.89 4.90 4.90 4.91 4.91 4.92 
m [°C] 10.00 5.15 5.15 5.15 5.15 5.16 5.16 5.16 5.17 5.17 5.18 5.19 

 15.00 5.43 5.43 5.43 5.43 5.43 5.44 5.44 5.45 5.45 5.46 5.47 
 20.00 5.71 5.71 5.72 5.72 5.72 5.72 5.73 5.73 5.74 5.75 5.76 
 25.00 6.01 6.01 6.01 6.02 6.02 6.02 6.03 6.03 6.04 6.05 6.05 
 30.00 6.32 6.32 6.32 6.32 6.33 6.33 6.33 6.34 6.35 6.35 6.36 
 35.00 6.64 6.64 6.64 6.64 6.64 6.65 6.65 6.66 6.66 6.67 6.68 
 40.00 6.96 6.97 6.97 6.97 6.97 6.98 6.98 6.99 6.99 7.00 7.01 
 45.00 7.30 7.30 7.31 7.31 7.31 7.32 7.32 7.33 7.33 7.34 7.35 
 50.00 7.65 7.65 7.66 7.66 7.66 7.67 7.67 7.68 7.68 7.69 7.70 
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I.4. Table for emissivities 

The table below contains values of the long-wave emissivity  of some building materials taken 
from: 
• H.C. Hottel, Heat Transmission, 1954 
• J.S. Cammerer, Wärme- und Kälteschutz in der Industrie, 1962 
• Stichting Bouwresearch, Eigenschappen van bouw- en isolatiematerialen, rapport 9, 1974 

 
building material long-wave emissivity at T = 300K 

 [-] 

black surface 1 

aluminium, polished < 0.07 

aluminium, oxidised 0.11 à 0.3 

brass, polished 0.038 

copper, smoothed 0.09 

copper, oxidised 0.78 - 0.79 

cast iron 0.44 

iron, oxidised and rusted red 0.61 

lead, gray oxidised 0.28 

tin 0.043 - 0.064 

zinc, galvanised 0.23 

zinc, oxidised > 0.11 

asbestos board 0.96 

bitumen 0.92 

brick, red, rough but no gross 

irregularities 

0.92 - 0.93 

concrete 0.88 

glass 0.94 

cement-tiles > 0.85 

roofing-tiles, red 0.85 

roofing paper 0.91 

rubber, hard and glossy 0.94 

wood 0.86 

aluminium painting 0.42 

enamel, white >0.90 

metal paint, black 0.88 

water 0.95 - 0.96 

other materials (approximation) 

white, yellow, green, red, blue, grey, 

black 

0.85 à 0.95 

 
The table below contains values of the long-wave emissivity  from EN ISO 10077-2:2017: 
 

description  

 [-] 

Untreated aluminium surfaces 0.1 

Slightly oxidized aluminium surface (up 

to 5 µm) 

0.3 

Metallic surfaces (general, including 

galvanized) 

0.3 

Anodized, painted or powder coated 

surfaces 

0.9 
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I.5. Tables for convective heat transfer coefficient 

The convective heat flow density is calculated using the following formula: 

𝑞𝑐 = ℎ𝑐 ⋅ (𝜃𝑎 − 𝜃𝑠) with 𝑞𝑐= convective heat flow density [W/m2] 
ℎ𝑐 = convective heat transfer coefficient [W/(m2.K)] 
𝜃𝑎= air temperature [°C] 

𝜃𝑠 = surface temperature [°C] 

Table 1 lists values of ℎ𝑐 for air cavities according to EN ISO 10077-2, depending on the 

temperature difference  over the cavity and the depth d of the cavity. Above the bold line, the 
ℎ𝑐-value depends only on the cavity depth (same hc-values on each row), while underneath the 

bold line the ℎ𝑐-value depends only on the temperature difference over the cavity (same ℎ𝑐-
values in each column). Above the bold line there is in fact only conduction (still air). Below the line 
natural convection is considered. 

 
Table 1: convective heat transfer coefficient (surface-to-surface) for air cavities (EN ISO 10077-2) 

convective heat temperature difference over the cavity 

transfer 

coefficient 

 [°C] 

hc [W/(m2.K)] 0.500 1.000 1.500 2.000 3.000 4.000 5.000 6.000 8.000 10.000 

 0.001 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 

 0.002 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 

 0.003 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 

 0.004 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 

 0.005 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 

depth 0.006 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 

of the 0.007 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 

cavity 0.008 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 

d [m] 0.009 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 

 0.010 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 

 0.011 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 

 0.012 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 

 0.013 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 

 0.014 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 

 0.015 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 

 0.016 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.145 

 0.017 2.941 2.941 2.941 2.941 2.941 2.941 2.941 2.941 2.941 3.145 

 0.018 2.778 2.778 2.778 2.778 2.778 2.778 2.778 2.778 2.920 3.145 

 0.019 2.632 2.632 2.632 2.632 2.632 2.632 2.632 2.653 2.920 3.145 

 0.020 2.500 2.500 2.500 2.500 2.500 2.500 2.500 2.653 2.920 3.145 

 0.025 2.000 2.000 2.000 2.000 2.106 2.318 2.497 2.653 2.920 3.145 

 0.030 1.667 1.667 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.035 1.429 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.040 1.250 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.045 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.050 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.060 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.070 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.080 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.090 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.100 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 
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Table 2 lists values of ℎ𝑐 for exterior surfaces, depending on the air velocity v and the 

temperature difference  between surface and environment (from “Informatiemap voor 
bouwfysici”, 1991). 
 
Table 2: the convective heat transfer coefficient for exterior environments 

convective heat temperature difference object -

environment transfer 

coefficient 

 [°C] 

hc [W/(m2.K)] 5 10 20 40 

 0.5 7 8 9 11 

air 1 9 10 11 13 

velocity 2 12 13 15 16 

v [m/s] 3 19 20 21 23 

 4 25 26 27 28 

 5 30 31 32 34 

The following formulas define the convective heat transfer coefficient for interior environments 
(from “Element 29: Wärmeschutz und Energie im Hochbau”, 1990). Table 3 lists the ℎ𝑐-values 
according to these formulas. 

ℎ𝑐 = 1.31 ⋅ √𝛥𝜃
3

 for vertical constructions (walls) with a horizontal heat flow 

ℎ𝑐 = 1.77 ⋅ √𝛥𝜃
4

 for vertical constructions (window) with a horizontal heat flow 

ℎ𝑐 = 1.52 ⋅ √𝛥𝜃
3

 for horizontal constructions (walls) with an upward heat flow 

ℎ𝑐 = 0.59 ⋅ √𝛥𝜃
4

𝐿⁄  for horizontal constructions (walls) with a downward heat flow 

with  ℎ𝑐  = convective heat transfer coefficient [W/(m2.K)] 
 = temperature difference object - environment [°C] 
𝐿 = ½ (length x width) of the construction [m2] 

 
Table 3: the convective heat transfer coefficient for interior environments 

convective heat vertical constructions horizontal constructions 

transfer coefficient horizontal heat flow upgoing downgoing 

hc [W/(m2.K)] walls windows heat flow heat flow 

 1 1.31 1.77 1.52 0.39 

 2 1.65 2.10 1.92 0.47 

 3 1.89 2.33 2.19 0.52 

temperature 4 2.08 2.50 2.41 0.56 

difference 5 2.24 2.65 2.60 0.59 

object -  6 2.38 2.77 2.76 0.62 

environment 7 2.51 2.88 2.91 0.64 

 [°C] 8 2.62 2.98 3.04 0.66 

 9 2.72 3.07 3.16 0.68 

 10 2.82 3.15 3.27 0.70 

 11 2.91 3.22 3.38 0.72 

 12 3.00 3.29 3.48 0.73 

 13 3.08 3.36 3.57 0.75 

 14 3.16 3.42 3.66 0.76 

 15 3.23 3.48 3.75 0.78 

* using L = 5 m 
 


