
Manual BISTRA v5.0 1 

 

 
BISTRA 

 

computer program to calculate 

two-dimensional transient heat transfer 
in free-form objects 

  

version 5.0 

 

© 2023 PHYSIBEL 

 
 
 
 
 
 

 
 

This manual is intended as a complete reference for the BISTRA application. 
 
Documented software application examples, tutorials & exercises, short practical guides 

(How To’s) and validation cases are accessible via the Physibel Knowledge base 
(www.physibel.be/en/knowledge). 

 

  

http://www.physibel.be/en/knowledge


2 Manual BISTRA v5.0 

Table of contents 

 

CHAPTER A INTRODUCTION ............................................. 3 
A.1. Program overview ................................................................ 3 

A.1.1. Bitmap (BMP) file .......................................................... 3 
A.1.2. Triangulation .................................................................. 4 

A.2. BISTRA brief history .............................................................. 5 
A.3. Technical specifications ....................................................... 5 
A.4. Licence ..................................................................................... 6 

A.4.1. Hardware licence .......................................................... 6 
A.4.2. Software licence ............................................................ 6 

A.5. User Account Control (UAC) ................................................ 6 
A.6. Overview of delivered files and file structure ................ 7 
A.7. Logging ................................................................................... 7 
A.8. Text convention ..................................................................... 7 
A.9. Program settings ................................................................... 7 
A.10. Program parameters ........................................................... 8 

CHAPTER B INPUT DATA ................................................... 9 
B.1. BISTRA input data file .......................................................... 9 
B.2. BISTRA start up ...................................................................... 9 
B.3. File commands ...................................................................... 9 
B.4. BISTRA program layout and input windows ................ 10 
B.5. Document notes ................................................................... 11 
B.6. Bitmap window .................................................................... 11 
B.7. Bitmap editing functions ................................................... 12 
B.8. Zoom commands................................................................ 14 
B.9. Measures window .............................................................. 16 
B.10. Colours window .................................................................. 16 
B.11. Colour functions ................................................................. 20 
B.12. Functions window ............................................................... 21 

B.12.1. Internal time functions (types STEP0, STEP1, 

STEP2, SINE, and SINPOS) ......................................... 22 
B.12.2. External functions (type FILE) ................................... 24 
B.12.3. Weather data files (types EPW and TMY3) .......... 25 

B.13. Function Graph window ....................................................26 
B.14. Function commands ........................................................... 27 
B.15. Solar data ............................................................................. 27 

B.15.1. Real sun path ............................................................... 28 
B.15.2. Fixed sun position ........................................................29 

B.16. Sun obstacles window ...................................................... 30 
B.17. Border U Values window.................................................. 30 
B.18. Borderline boundary conditions window ...................... 31 
B.19. Ventilation flows window .................................................. 31 
B.20. Report Definition window ................................................. 32 
B.21. Report Frequency .............................................................. 34 
B.22. Save Frequency .................................................................. 34 
B.23. General editing commands ............................................ 35 

CHAPTER C SYSTEM CALCULATION .............................. 36 
C.1. Automatic calculation of thermal properties .............. 36 

C.1.1. Colour type EQUIMAT ............................................... 36 
C.1.2. Colour type BC_SIMPL or BC_FRE_S ...................39 
C.1.3. Colour type BC_FREE ................................................. 41 
C.1.4. Colour type BC_SKY or BC_NOSKY ...................... 42 
C.1.5. Colour type TRANSMAT ............................................ 42 

C.2. Calculation parameters ................................................... 42 
C.2.1. Time ............................................................................... 43 
C.2.2. Triangulation ............................................................... 44 
C.2.3. Iterations ....................................................................... 44 
C.2.4. Radiation ...................................................................... 45 

C.2.5. Automatic calculation of thermal properties ....... 45 
C.3. System calculation ............................................................. 46 
C.4. Calculation principles ........................................................ 47 
C.5. Automatic triangulation .................................................... 48 

C.5.1. Contouring .................................................................... 48 
C.5.2. Straightening contours .............................................. 48 
C.5.3. Calculation of inner nodes ........................................ 49 
C.5.4. Creation of the triangulation mesh ........................ 49 

C.6. Unlinking air temperatures in cavities of type 
BC_FRE_S or BC_FREE .................................................... 49 

C.7. Processing ventilation flows ............................................ 50 
C.8. Solar radiation processing ................................................ 51 

C.8.1. Definition of solar properties ρs and τs for 

MATERIAL ...................................................................... 51 
C.8.2. Irradiance: solar load to external surfaces .......... 52 
C.8.3. Absorption of solar radiation ................................... 54 
C.8.4. Processing of reflection ............................................. 55 
C.8.5. Transmission to internal zone: solar load to 

internal surfaces .......................................................... 56 
C.8.6. Solar load to opaque surfaces behind transparent 

materials ....................................................................... 56 
C.9. Heat flow divergences ...................................................... 57 
C.10. Batch calculation ................................................................ 58 
C.11. Command line program execution ............................... 58 

CHAPTER D GRAPHIC OUTPUT ...................................... 59 
D.1. Graphic Output window ................................................... 59 
D.2. Animate functions............................................................... 59 
D.3. Save animation images .................................................... 60 
D.4. Zoom commands ............................................................... 60 
D.5. View submenu ..................................................................... 60 
D.6. Settings .................................................................................. 61 
D.7. Sun position ......................................................................... 64 

CHAPTER E TEXT OUTPUT .............................................. 65 
E.1. Text Output window .......................................................... 65 
E.2. Input data ............................................................................ 66 
E.3. Time step results ................................................................. 67 
E.4. Report output ...................................................................... 68 

CHAPTER F BISTRA TEMPLATE FILES ............................ 69 
F.1. General ................................................................................. 69 
F.2. Colour database ................................................................ 69 

CHAPTER G PROGRAM FUNCEDIT ................................. 70 
G.1. Introduction ......................................................................... 70 
G.2. Function type ........................................................................ 71 
G.3. Function parameters .......................................................... 71 
G.4. Function data ...................................................................... 72 
G.5. Graphic parameters .......................................................... 73 
G.6. Using a spreadsheet program to create functions .... 74 

CHAPTER H RADCON MODULE ...................................... 76 
H.1. Purpose ................................................................................ 76 
H.2. Implementation .................................................................. 76 
H.3. Table for black radiation heat transfer coefficient .... 80 
H.4. Table for emissivities .......................................................... 81 
H.5. Tables for convective heat transfer coefficient ........... 82 

 



Manual BISTRA v5.0 3 

CHAPTER A INTRODUCTION 

A.1. Program overview 

BISTRA is a thermal analysis program for transient heat transfer in two-dimensional free-form 
objects. BISTRA is the extension for time-dependent boundary conditions of the steady-state 
program BISCO. 
As in BISCO, the geometry is defined by a coloured picture in bitmap format (A.1.1). BISTRA 

requires data input for the association of the bitmap colours with the physical properties of 

materials and boundary conditions. 
BISTRA calculates a triangulation for the material colours (A.1.2). The system nodes are located in 
the triangle vertices. The temperatures in the nodes are calculated, from which all heat flows can 
be derived. 
BISCO data files can be taken as starting data in BISTRA. 
 
The time-dependent boundary conditions are described with functions, which can be built-in 
functions based on variable parameters, external user-defined functions (saved as separate files) 
based on function values given at a fixed time interval, or standardised weather files 
The thermal conductivity and specific heat of any material can refer to temperature dependent 
functions, which is useful in fire simulations where broad ranges of temperatures can occur. 

These functions are described in external text files using node points (abscissa: temperature, 
ordinate: thermal property value), between which linear interpolation is used. 
 
BISTRA contains a solar processor based on direct and diffuse solar radiation weather data. The 
sun path can be visualised in relation to the object. Solar absorption powers in all nodes per time 
step are calculated based on solar properties (reflection and transmission factor) of the materials 
and the solar irradiation data. The effect of shadowing and diffuse and specular reflection can 
be examined in detail. 
 
BISTRA allows the calculation of ventilation. 
 
BISTRA allows creating time-dependent graphic animations of the temperature field in the 

studied object. Alphanumeric lists of time functions of temperatures, heat flows, and other 
variables can be made. 
 
BISTRA always includes the RADCON module (which allows separate calculation of radiation 
using view factors and convection, see Chapter H), because it is essential for fire simulation or 

when using the solar processor. 

A.1.1. Bitmap (BMP) file 

The input of BISTRA needs a 2D raster image (also called bitmap) in colour. 
The pixels of this bitmap can have 256 (= 28) different colours. 

The bitmap is stored in a 256-colours (or 8-bit) BMP file (Microsoft Windows Bitmap). 
Each colour in the bitmap will be linked to a different (homogeneous) material or boundary 
condition, having its own thermal properties. 
Each pixel of the bitmap is a square with side equal to a fixed physical length (= pixel size), to be 

defined in the Measures window of BISTRA. 

 
A 256-colours BMP file contains a header section and an image data section. 
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The header section contains the definition of the 256 possible colour values in the bitmap (called 
the colour palette). Each colour of the colour palette is defined by its red, green and blue 
components (or RGB values). Each colour component is an integer between 0 and 255 (having 
the range of 1 byte), which defines the intensity of that colour (0 = dark, 255 = full intensity). Using 

this colour system 256 x 256 x 256 different colour values can be created. From this colour space 
only a subset of 256 colours can be saved in the colour palette. 
 

In BISTRA the individual colour values are shown in the Colours window. Each row in this window 

shows a colour number (between 0 and 255), which is the index into the colour palette, followed 
by the corresponding colour value from the colour palette. 
By default BISTRA shows only the colours present in the actual loaded bitmap (which number is 
normally smaller than 256). To show all 256 possible colour values of the colour palette execute 

the command Colours → List All (which is only enabled when the Colours window is active). 

The colour value for each colour number can be edited from the Colours window (by editing the 

RGB values). 
A BMP file generated in BiscoDxf or BISCO by default uses the colour palette of the 

ColourPalette.bmp file of BISCO. BISTRA can load the colour palette of another bitmap into the 
current bitmap (see B.6, Bitmap → Load Palette…).  
 
The image data section of a 256-colours BMP file contains the pixel values of the bitmap, row by 
row (or scanline by scanline). Each pixel value is a colour number (between 0 and 255), which is 

an index into the colour palette. 

BISCO can read either uncompressed or (run-length encoded) compressed 256-colours BMP 
files. An uncompressed BMP file contains the pixel values of all individual pixels, while a 
compressed BMP file clusters pixel intervals of equal pixel value. 

 

In BISCO the image data are shown in the Bitmap window. When the Bitmap window is active, 

the bitmap coordinates (X and Y) and corresponding pixel value (colour number) of the pixel 

under the mouse cursor are displayed in the program status bar (at the bottom of the BISTRA 
application window). 

A.1.2. Triangulation 

BISTRA has a set of functions to clean up the bitmap up for a thermal calculation (see B.7). The 
raster image is then converted into a vector image, in which the staircase pixel boundaries are 
converted to approximated contour lines. The space besides the contour lines are triangulated 
using a balanced mesh with preferably equilateral triangles.  

The desired triangulation mesh size per material colour (defined in the Measures window) can be 

modified to improve the calculation quality without increasing too much the total number of 
nodes. 
In most cases a uniform triangulation mesh size for all materials will yield satisfactory results. 

The smaller the triangulation mesh size, the better the final calculation precision. 
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The vector representation of the triangulation is also better suited to account for the convective 

heat transfer, because the length of the contact surface between a material and a boundary 
condition is more precise than the measurements along the rectangular pixel boundaries. 
 
The complete triangulation information (vertices coordinates, triangle definitions per material 
colour, edge definitions per boundary condition) is saved into a text file (with same file name as 
BISTRA file and extension .tri). 

 
The vertices of the triangulation mesh are the nodes of the thermal system. 

A.2. BISTRA brief history 

BISTRA was first developed in 2005 based on the steady-state program BISCO. 
 

• Version 1.0 was ready in December 2005. 
• Version 2.0 (March 2009) included the solar processor based on direct and diffuse solar 

radiation weather data files. 
• Simulation of ventilation flows through different zones following user-defined ventilation 

paths is possible since version 3.0 (January 2011). The ventilation volume flow rates refer to 

time dependent functions. 
• Further development in version 4.0 (July 2017) to harmonise functions with BISCO v11.0. 

 

The detailed version history can be found on the website: 
www.physibel.be/en/products/bistra/versions . 

A.3. Technical specifications 

- BISTRA is a 64-bit Windows program. BISTRA is installed in C:\Program Files 
(x86)\Physibel\BISTRA5. 
In this folder the executable file is BISTRA.exe. 

- The standard version of BISTRA allows a maximum of 500,000 nodes. An add-on feature 

to calculate an unlimited amount of nodes is available for purchase (feature Unlimited 
Nodes). The maximum number of nodes then depends on the RAM installed. 

- BISTRA relies on OpenGL for use of hardware accelerated graphics. 
- BISTRA is protected by either a hardware key, provided by Physibel, or a software licence 

(A.4). 
 

The Physibel 64-bit programs need several shared libraries (.dll files) from Microsoft. 
The Microsoft Visual C++ 2017 Redistributable Package (x64) is included in the installation files of 
BISTRA, but can also be downloaded from https://support.microsoft.com/en-
us/help/2977003/the-latest-supported-visual-c-downloads. 

http://www.physibel.be/en/products/bistra/versions
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads


6 Manual BISTRA v5.0 

This package installs mfc140.dll and other files in the directory C:\Windows\SysWOW64, required 

by 64-bit applications developed with Microsoft Visual C++ 2017. 

A.4. Licence 

The Physibel applications are protected by a licence, to prevent illegal use of the software. This 
can be either a hardware licence (Sentinel USB key) or a software licence. 

A.4.1. Hardware licence 

Perpetual licences are protected by a hardware licence (Sentinel USB key). The licence is locked 
to this dongle. It is strongly recommended to take a financial assurance for loss of the key by theft 
or any other incidence. 
 
Before BISTRA can be used, the driver (delivered with purchase) for the hardware key needs to 
be installed. Administrator rights are needed for this installation. It might be necessary to restart 
your computer after installing the driver. 

 
During use of BISTRA, the dongle needs to be attached to the computer at all times. 

A.4.2. Software licence 

Subscription licences are protected by a software licence. After first installation of BISTRA, the 

user needs to activate the licence using the activation code received upon purchase of the 
software. When first opening BISTRA, the Software Licence Manager will open automatically and 
prompt the user to activate the licence, or to register in the network floating database, depending 
on the licence type. The computer needs to be connected to the internet for this licence activation. 
Cloud-based floating licences are activated every time when opening the application. 
 
After activation, the Software Licence Manager is available from the menu for stand-alone 
licences: 
Help → Software Licence Manager… 
 
Users with a floating network licence can check out a licence from the database for a maximum 

period of 3 days. 
Help → Check out/in floating licence… 
 
The software licence key for BISTRA is linked to the computer where it was activated. When you 
want to move the application with a stand-alone licence to another computer, you can 
deactivate the licence in the Software Licence Manager. The licence can then be reactivated on 

a new computer. 
 

If the Software Licence Manager is unavailable from the application itself, you can also open it 
from the command prompt. You need to first change directory to the Program Files folder where 
the application is installed. Then, open the Software Licence Manager with the following 

command: 
QlmLicenseWizard.exe /settings “BISTRA 5.0.lw.xml”  

A.5. User Account Control (UAC) 

Administrator rights are necessary to install BISTRA on a computer. 
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The installation of the application is machine-level, meaning all user accounts can access the 

application after installation. 
 
Each user account has its own copy of the colour database and accompanying BMP file (see F.2), 
to work with. These files can be found in the user’s application data directory 

(C:/Users/username/Appdata/Roaming/Physibel/BISTRA5/). 
 
In case of a software licence, the licence for BISTRA is linked to the computer, but is stored at the 
user level. Each user account on a computer has to activate the licence in order to have access to 
the licence. 

A.6. Overview of delivered files and file structure 

BISTRA is installed (when the user has accepted the default destination) in the folder 
C:\Program Files (x86)\Physibel. 

 
The following files are installed 
Folder File Description 
…\Physibel\BISTRA5 BISTRA.exe BISTRA (64-bit) program 
 *.dll, *.pat, *.rgb Program resources 
 QlmLicenseWizard Software Licence Manager files 

…\Physibel\Materials *.phm Material databases 
…\Physibel\Manuals BISTRAManual.pdf BISTRA manual 

 
The colour database file ColourDatabase.bst and accompanying BMP file (see F.2), together with 
the parameter file BISTRA.prm (see A.10), are installed in C:/ProgramData/Physibel/BISTRA5 

(machine-level), and copied to each user account’s application data folder when first opening 
BISTRA (C:/Users/username/AppData/Roaming/Physibel/BISTRA5). 

A.7. Logging 

When using BISTRA, information is continuously written to a log file located in the user account’s 

application data folder (C:/Users/username/AppData/Roaming/Physibel/BISTRA5). This file 
contains information that can help for debugging when something went wrong, and also to 
clarify or elaborate on error or warning messages shown in the application. 

A.8. Text convention 

Menu paths are printed in italic, with format Submenu → Command. 
E.g. File → Open (Open command in File submenu). 

A.9. Program settings 

Global program settings are available via the Settings submenu. 
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- Settings → Toolbar: presence of the toolbar giving access to menu commands through 

icons. 
- Settings → Status Bar: presence of the status bar at the bottom of the BISTRA application 

window, containing context depending information. 
- Settings → Default Standard…: set EN ISO 10077-2, EN ISO 6946 or NIHIL as default 

standard for the definition of colour types. 

 
- Settings → Default Measures…: set the default bitmap pixel size and global triangulation 

size (see B.9). 

 
- Settings → Language: the selected language (English, Dutch, French, German) becomes 

effective the next time the program is started. 

A.10. Program parameters 

The global default values (calculation parameters, output parameters, pixel size, triangulation 

measures, interface language, etc.) are saved in the file BISTRA.prm in the application data 
folder (C:/Users/username/Appdata/Roaming/Physibel/BISTRA5). When the program BISTRA is 
started, the program parameters are loaded from the parameter file. 

 
The program parameter default values can be changed from several input dialog boxes. When 
the button “Set As Default” in an input dialog box is clicked, the corresponding program 

parameters are saved in the program parameter file BISTRA.prm at exiting BISTRA. 
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CHAPTER B INPUT DATA 

B.1. BISTRA input data file 

The input data are stored in a BISTRA data file with extension .bst (since BISTRA v2.0) and a 
Bitmap file with extension .bmp, both in the same directory. 
The file syntax of a .bst file is based on the syntax of a BISCO file (extension .bsc), but extended 
for BISTRA specific features (dynamic material properties, functions, dynamic calculation 

parameters, report definition). 

The BMP file is a 256-colours (uncompressed or run-length encoded compressed) Microsoft 
Windows Bitmap. 
Because the BST file only stores the file name of the corresponding BMP file, both BST and BMP 
files must be in the same directory. It is a good practice to give both files the same file name. 
 
BISTRA can read BST files and BSC files (using File → Open… and choosing the file type). 
If a BST file should be read in BISCO, first rename its extension to .bsc, then open the BSC file in 
BISCO. But all BISTRA properties are lost after saving the (edited) BSC file in BISCO. 

B.2. BISTRA start up 

When BISTRA is launched, the parameter file BISTRA.prm is read (see A.10) to load global 
program settings. 
Then the colour database ColourDatabase.bst is read (see F.2) to initialise material and surface 

boundary condition properties of the Colours window. 

There is no visual feedback in the initial screen of BISTRA to indicate if BISTRA.prm and/or 
ColourDatabase.bst are not found and thus not read. 

B.3. File commands 

 
 

File → Open… 
Opens an existing BST or BSC file by selecting it in the File Open dialog box. The thermal 
properties, triangulation mesh size, pixel size, calculation parameters and output settings from 

the selected file are read. The linked BMP file is loaded and displayed in the Bitmap window. 
Thermal properties from a previous open document (of the current BISTRA session) for colours 
not present in the new loaded bitmap, remain loaded in memory. 
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File → Open Bitmap… 

Creates a new BISTRA document by selecting an existing bitmap (BMP file). 
The new document gets the same file name as the file name of the selected bitmap. 
If no document has previously been opened, the default data from ColourDatabase.bst and 
BISTRA.prm (see B.2) are used, both of which can be customized (see F.2 and A.10). 

As an alternative, a customized BST template file could be opened before opening the BMP file, 
as the thermal properties from the previous open document remain active in memory. Use the 
same colour palette, and the same colour numbers in the new bitmap to retrieve the existing 
thermal properties. Only the thermal properties for colours not occurring in the BST template file, 
must be defined. 
The pixel size and triangulation meshes are set according to the user-defined values in Settings 

→ Default Measures…. (see A.9). 
 
File → Open Colour Database… 

The colour database contains predefined material and boundary condition properties (stored in 
the file ColourDatabase.bst in the application data folder, see F.2), which is loaded at every 
BISTRA start-up (see B.2). It is advisable to add frequently used materials and boundary 
conditions to the colour database. 
These predefined colours of the colour database are then available for new colours in any 
document. 

 
File → Close 
Closes the active document (after a prompt to save it), but the thermal properties, pixel size and 

calculation parameters remain present in memory, for further use in the next opened document  
(File → Open Bitmap… or File → Open… ). 
 

File → Save 
Saves the current document (BMP file and BST or BSC file). The file names are displayed in the 

BISTRA application title bar (BST file) and in the Bitmap window title bar (BMP file). The files are 

only written when they were modified, which is indicated by an asterisk after the respective file 
names. 
 

File → Save As… 
Allows to save the open document as new files (BMP file and BST or BSC file). The file paths of 

the new BMP and BST or BSC files can be entered in two successive File Save dialog boxes (first 
for the BMP file, then for the BST or BSC file). Use the same data file folder for both BMP and BST 
or BSC files (because the BST or BSC file does not save the directory of the BMP file, but only the 
file name). 
 
File → Batch Calculation…: run multiple simulation files (BST) successively, see section C.10. 
 
File → Exit 
Quits the current session of BISTRA. 
Global program parameters are saved into the parameter file BISTRA.prm. 

B.4. BISTRA program layout and input windows 

The input in BISTRA is organised in several windows. When a BISTRA document is opened (e.g. 
with File → Open Bitmap… or File → Open…), the following windows are opened: 

- Bitmap window (top left) with an image of the BMP file. 

The BMP file name is displayed in the title bar. 

- Measures window (top right) with measurements per colour present in the BMP file. 
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- Colours window (bottom) with thermal properties per colour present in the BMP file. 

The name of the current document (BST file name) is displayed in the BISTRA application title bar. 
 

The Edit submenu  (or corresponding buttons in the toolbar) allows to open and activate an input 
window. The active input window has a blue title bar. 
 

   
 
Other input windows are: 

- Borderline BCs window with borderline boundary conditions. 

- Functions window with functions. 

- Ventilation Flows window with ventilation flow paths. 

- Report Definition window with selection of reported outputs. 

- Sun Obstacles window with definition of obstacles around the model. 

- Border U Values window with U-values of wall sections at the bitmap borders. 

B.5. Document notes  

In the Notes dialog box (via Edit → Notes… ) some comments can be written for the current 

document, e.g. project description, operator, date. These notes are saved in the BST file. 
 

 

B.6. Bitmap window  

The Bitmap window is automatically loaded when opening a document. 
The title bar shows the corresponding BMP file name. An asterisk after the file name indicates 
that the bitmap is modified (after a bitmap edit operation) and should be saved. 
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The Bitmap window shows a view of the bitmap image. 

When the Bitmap window is made active (e.g. by clicking on its title bar), the coordinates of the 

mouse point in the bitmap are shown in the status bar (at the left bottom of the BISTRA 
application). 
 

    
 
The following coordinates are displayed: 

- Pixel coordinates (xp,yp). 
The pixel coordinate xp is measured from the left bitmap border. 
The pixel coordinate yp is measured from the top bitmap border. 
The pixel coordinates always have integer values. 

- Colour number of the current bitmap pixel. 
- Scaled coordinates (xs,ys). 

The coordinates are scaled using the pixel size, as defined in the Measures window. 

The scaled coordinate xs is the distance from the left bitmap border. 
The scaled coordinate ys is the distance from the top bitmap border. 

The scaled coordinates have of a resolution of 0.0001 m. 
 
When the <Shift> key is held down, relative coordinates are displayed in the status bar (after a 
mouse move). 

Relative coordinates are measured against a new origin defined by the last clicked point. 
 

If another input window is active, the Bitmap window highlights the current item with dotted lines. 

B.7. Bitmap editing functions 

 
 

The active drawing colour is defined by the row of the current cell in the Colours window. 
 

Bitmap → Draw : enter “draw mode”. 
In draw mode pixels and lines can be drawn using the active drawing colour. 
Drawing a pixel: set the mouse point on the pixel and click the left mouse button.  
Drawing a line: hold down the <Shift> key, move the mouse (now the status bar shows the 
relative coordinates from the last painted pixel) to the end pixel of the line and click the left 
mouse button. A line is drawn from the last clicked pixel to the new clicked pixel. 
 

Bitmap → Line : enter “line mode”. 
A line is drawn from the start point to the end point using click and drag with the left mouse 
button. 
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Bitmap → Rectangle : enter “rectangle mode”. 
A rectangle is filled using click and drag with the left mouse button. 
 
Bitmap → Fill : enter “fill mode”. 

When the left mouse button is clicked, the colour zone around the pixel under the mouse point is 
filled. The flood fill stops at the border with any other colour. 
 
Bitmap → Bisect : enter “bisect mode”. 
When the left mouse button is clicked, the circumscribed rectangle of the colour zone around the 
pixel under the mouse point is bisected. 

The colour number of the newly created zone and the direction of the split are defined by the 
user. 
 

 
 
Bitmap → Size…  
Allows to expand or shrink the bitmap at the borders. 

In the Bitmap Size dialog box, enter the new width and height (in pixels or in metres). 
Then adjust the image placement by entering the top, bottom, left and right margins.  

These margins can be positive or negative. 
New margins are adjusted at the opposite side if the check box “Keep total dimensions when 
editing margins” is marked; otherwise the total dimension is adjusted. 

Press the command button “Apply” to update the other values after editing. Using the <tab> key 
has the same result. 
When the bitmap is extended at a border (top, bottom, left and/or right), the pixels at that border 
are copied if the check box “Use border colours” is marked. Otherwise colour number 1 is used for 
the new border margin. 
 

  
 
Bitmap → Rotate 90°  
Rotates the entire bitmap over 90° in clockwise orientation. 
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Bitmap → Load Palette…  

Import the colour palette of another BMP file (to select in the File Open dialog box). 
All colour numbers of the original bitmap get new colour values from the imported colour palette 
(see A.1.1). 
 

Bitmap → Change Colour… 

Assigns a new colour number to the active colour (selected in the Colours window or Measures 

window). 
 

  
 

Bitmap → Split Zones… 
The function Split Zones works differently in BISTRA than in BISCO (e.g. detection of grooves and 
interconnections is not possible). 
The function allows to split a multi-zone colour into a set of single-zone colours with different 
colour numbers. First select the multi-zone colour (using Zoom → Select and clicking upon the 

colour in the bitmap). 

The function Bitmap → Split Zones… is enabled from the Colours window or the Measures 

window if the selected colour contains more than one zone and enough free colours are 

available. 

The function is useful for colours of type BC_FRE_S, BC_FREE, BC_SKY, BC_NOSKY or 
TRANSMAT, which require single-zone colours to be valid. 

When the function is called, a Split Zones dialog box is opened to prompt for the first new colour 
number. The function then takes all successive colour numbers of the colours not yet present in 
the bitmap. The original colour number can also be reused. 

 

 
 
Bitmap → Fill Line Drawing (enabled if exactly two colours are present in the bitmap) 
Splits a 2-colours bitmap (formatted as 256-colours BMP file), consisting of a foreground colour 
(line drawing) and a background colour, into a multi-coloured image. The original lines are 
removed by thinning. 
In a first step all zones surrounded by lines are filled with free colours (different from the line 
colour of the line drawing). It is important that the lines in the line drawing are closed, because a 
flood fill technique is used. In a second step the original lines (with foreground colour) are 

removed by thinning. 
This function is useful when the available DXF has only 1 layer containing all different materials 

(e.g. output from Sketchup → Export → 2D Graphic). From such a DXF file a 2-colours bitmap can 
be generated by BiscoDxf. 

B.8. Zoom commands 

Zoom submenu 
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Zoom in/out via the mouse wheel 

The commands Zoom → Zoom In and Zoom → Zoom Out can also be carried out using mouse 

wheel scrolling (when the Bitmap window is active). 
Rotating forward (away from the user) zooms in with the mouse point as zoom centre. 
Rotating back (toward the user) zooms out. 
 
Zoom → Select 

Enters “select mode”. A following click with the left mouse button on the bitmap selects the colour 

under the mouse point as current colour in the Colours window and Measures window. 
Colour selection can also be obtained by a right mouse button click from “pan mode”. 

 

Zoom → Pan 
Enters “pan mode” (only possible for a zoomed view). A following arrow key stroke (left, right, up, 

down) or mouse drag using the left mouse button recentres the view. 
 
Zoom → Zoom Window 

Enters “zoom window mode”. Then a zoom rectangle can be drawn on the bitmap with click and 
drag, that defines the next zoom view. The zoom operation can be cancelled by pressing <Esc> 
before releasing the left mouse button. 

 
Zoom → Zoom In 
Enters “zoom in mode”. A following click using the left mouse button on the bitmap defines the 
centre point of the next zoomed view. The zoom factor is 50 %. 
Zooming in can also be obtained by rotating forward using the mouse wheel. 

 
Zoom → Zoom Out 

Zooms out using a zoom factor of 200 %, or calls Zoom → Zoom Total if the image becomes too 
small. 
Zooming out can also be obtained by a right mouse button click from “zoom window mode” or 
“zoom in mode”, or by rotating back using the mouse wheel. 
 
Zoom → Zoom Total 
Shows total bitmap (the original view). 

 
Zoom → Previous View 

Shows the previous zoom view. (More than one previous view cannot be recalled.) 
 
Zoom → Numbers… 
Opens a dialog box with the pixel coordinates of the current zoom view. By editing the 
coordinates the zoom view can be changed. A zoom view can be restored later (i.e. reset to the 
same zoom factor and position) via these zoom numbers. 
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B.9. Measures window 

The Measures window is the input window for the pixel size and triangulation mesh sizes per 

colour. The triangulation mesh sizes are used in generating the automatic triangulation grid as 
part of a thermal system calculation. 

The current colour (defined by the row of the current cell) is highlighted in the Bitmap window by 

dotted contour lines. 
 

  
 
Dimensions 

The first line of the Measures window shows the size of 1 pixel (width = height) in the bitmap. The 

default value can be set in Settings → Default Measures…. 
The second line shows the width and height of the total bitmap. 
The following lines list the width and height of the surrounding rectangle for each colour (defined 

by colour index in the colour palette) in the bitmap, and the area (= number of pixels in the 
bitmap having this colour). 
The measures are shown both in pixels (not editable) and in metres (editable). 

When any width or height is changed, all other widths and heights are modified proportionally. 
 
Colour zones 

The number of zones per colour is displayed in the column “Zones”. 
A colour zone is a connected pixel area of the same colour in the bitmap. Each colour in the 

bitmap can occur in one or more zones. The different zones of the same colour are separated 

from one another by other colours. 
Colours of type BC_FRE_S, BC_FREE, BC_SKY, BC_NOSKY and TRANSMAT must consist of only 

one zone. Use the function Bitmap → Split Zones… to split multi-zone colours. 
 
Triangulation mesh sizes 
Per colour a triangulation mesh size can be edited. 
Only the triangulation mesh sizes of material colours (type MATERIAL, EQUIMAT or TRANSMAT) 

are enabled and used in a triangulation mesh generation. 
Editing the triangulation mesh size on the second line (for the total bitmap) modifies the 
triangulation mesh sizes of all colours. The default value can be set in Settings → Default 

Measures…. 
The purpose of different mesh sizes is to influence the calculation accuracy and speed. 

B.10. Colours window 

The Colours window is the input window for thermal properties of materials and boundary 
conditions. Each row refers to the properties of one colour. 
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The selected colour (defined by the row of the selected cell) is highlighted in the Bitmap window 

by dotted contour lines. 
 

 
 

Colour number (1st column) 
Index (between 0 and 255) in the colour palette of the bitmap. 

 
Colour value (2nd column) 
Select a cell and press Enter (or double click) to edit the colour value. 
If a colour value is changed, then the colour palette of the bitmap is modified, which requires to 
save the modified BMP file. 
The colour value is edited in a Colour dialog box. 

 

  
 
Type (3rd column) 
Toggle value having one of the following values (press Enter to switch), which defines the 

meaning of the colour: 
- MATERIAL: material defined by thermal conductivity. 
- EQUIMAT: equivalent material defined by a single equivalent thermal conductivity (e.g. 

air cavity). The equivalent conductivity is typically calculated from standard rules (C.1). 
- BC_SIMPL: simplified boundary condition (with known temperature and global surface 

heat transfer coefficient for combined convection and radiation). 
- BC_FRE_S: enclosure with unknown (free-floating) internal temperature, possible 

additional internal heat power, simplified surface heat transfer defined by a global 
surface heat transfer coefficient and possible additional surface heat flux. 
The unknown environmental temperature is calculated from the heat balance equation: 
Σ (convective heat transfer from environment to surface) = injected convective heat 

power. 
With the RADCON module (which supposes separate convection and radiation based on view 
factors, see Chapter H) also: 
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- BC_FREE: surface boundary condition modelled as enclosure with unknown (free-

floating) air temperature, radiation between the surfaces (using the infrared emissivities of 
the adjacent materials) and convective heat transfer coefficient. 

- BC_SKY: surface boundary condition modelled as an environment with defined air and 
radiation temperature (the sky) and convective heat transfer coefficient. 

- BC_NOSKY: surface boundary condition modelled as an environment with defined air 
temperature, no radiation to the environment (no sky) and convective heat transfer 
coefficient. 

- TRANSMAT: transparent material defined by thermal conductivity, and radiation between 
the surfaces (using the infrared emissivities of the adjacent materials). 

 

Standard (last column) 

Standard used for the automatic calculation of eq or hc (cf. section C.1). 
- NIHIL: no automatic calculation of thermal properties. 

- EN10077: standard EN ISO 10077-2. 
- EN6946: standard EN ISO 6946. 
- EN673: standard EN 673. 

Within each standard different subtypes can be chosen. 
 
Subtype (4th column) 

Subtype toggle value to define automatic calculation of equivalent thermal conductivity (type 

EQUIMAT and TRANSMAT) or convective heat transfer coefficient (BC_FREE, BC_SKY and 
BC_NOSKY). The accessible subtypes are dependent on the actual type (3rd column) and 

standard (last column). 
For type EQUIMAT: 

- NIHIL: user defined thermal conductivity (no automatic calculation). 

- CAVITY: calculated equivalent thermal conductivity for unventilated air cavity (EN10077 or 
EN6946). 

- CAVITY_E: calculated equivalent thermal conductivity for slightly ventilated air cavity 

(EN10077). 
- LAYER: calculated equivalent thermal conductivity for unventilated gas layer (EN6946 or 

EN673). 

For type BC_SIMPL: 
- NIHIL: user defined global heat surface coefficient. 
- HI_NORML: normal internal heat transfer (EN10077). 
- HI_REDUC: reduced internal heat transfer (EN10077). 

- HI: internal heat transfer (EN6946). 
- HE: external heat transfer (EN10077 or EN6946). 
- HI_CAV_E: slightly ventilated air cavity at the internal surface (EN10077 – radiosity 

method). 
- HE_CAV_E: slightly ventilated air cavity at the external surface (EN10077 – radiosity 

method). 
For type BC_FREE: 

- NIHIL: user defined convective heat transfer coefficient (no automatic calculation). 
- CAVITY: calculated convective heat transfer coefficient for unventilated air cavity 

(EN6946). 
- LAYER: calculated convective heat transfer coefficient for unventilated gas layer (EN6946 

or EN673). 
- CONVEC: calculated convective heat transfer coefficient for large air space. 

For type BC_SKY or BC_NOSKY: 
- NIHIL: user defined convective heat transfer coefficient (no automatic calculation). 
- CONVEC: calculated convective heat transfer coefficient for natural convection. 
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For type TRANSMAT: 

- NIHIL: user defined thermal conductivity (no automatic calculation). 
- CAVITY: calculated equivalent thermal conductivity for unventilated air cavity (EN10077 or 

EN6946). 
- LAYER: calculated equivalent thermal conductivity for unventilated gas layer (EN6946 or 

EN673). 
For more details on the corresponding calculation procedures see C.1. 
 
Physical heat flow direction (5th column) 
Heat flow direction with reference to the physical reality: 

- HOR: horizontal heat flow. 

- UP: upward heat flow. 
- DOWN: downward heat flow. 
- ANY: user-defined heat flow direction (by defining the inclination angle of the construction 

element and assuming a heat flow perpendicular to the construction element) 
 
Geometric heat flow direction (6th column) 
Heat flow direction with reference to the X and Y directions of the screen: 

- X: heat flow parallel to the X axis of the screen. 
- Y: heat flow parallel to the Y axis of the screen. 

- DIR: heat flow following the local temperature gradient. 
 
Name (7th column) 

Name of material or boundary condition. 
 
Thermal properties (next columns): 

- ε1 / ε2 [- / -]: infrared emissivities (values between 0.001 and 1) at warm and cold sides of 

cavity (type EQUIMAT). 
Editing opens a dialog box for definition of the values. 
 

  
 
If any emissivity differs from 0.9 (the default value), the corresponding grid cell in the 

Colours window is highlighted in blue. 

- λ [W/(m.K)]: thermal conductivity of material (MATERIAL), equivalent material (EQUIMAT) 

or transparent material (TRANSMAT). 
- ε [-]: infrared emissivity (value between 0 and 1) of material surfaces (MATERIAL, 

EQUIMAT) adjacent to boundary condition or cavity with radiative heat transfer. 
- ρ [kg/m3]: density of material (MATERIAL), equivalent material (EQUIMAT), transparent 

material (TRANSMAT) or enclosure (BC_FREE and BC_FRE_S). 
- c [J/(kg.K)]: specific heat of material (MATERIAL), equivalent material (EQUIMAT), 

transparent material (TRANSMAT) or enclosure (BC_FREE and BC_FRE_S). 
- θ [°C]: temperature of simplified boundary condition (BC_SIMPL). 

- h [W/(m2.K)]: global surface heat transfer coefficient (BC_SIMPL, BC_FRE_S). 
- q [W/m2]: heat flux dissipated onto adjacent material surfaces (BC_SIMPL, BC_FRE_S, 

BC_FREE, BC_SKY, BC_NOSKY). 
- θa [°C]: air temperature (BC_SKY, BC_NOSKY). 

- hc [W/(m2.K)]: convective heat transfer coefficient (BC_FREE, BC_SKY, BC_NOSKY). 
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- Pc [W]: convective power dissipated in the environment (BC_FRE_S, BC_FREE). 
- θr [°C]: radiation temperature (BC_SKY). 

 
Solar data (four columns with header Sun, ρs, Specular and s): 

− Sun: sun active status (YES or NO) to define a solar zone, for a colour of type BC_SIMPL or 
BC_SKY. 

− ρs [-]: solar reflection factor (for a colour of type MATERIAL), a constant value (between 0 

and 1), or a function reference (R##) when the solar reflection factor is a function of the 
angle of incidence (see also section B.12.2). See C.8.1 for a detailed explanation of the 
definition of ρs. 

− Specular [%]: specular part of the direct solar radiation reflection (for a colour of type 
MATERIAL), a constant value (between 0% and 100%). The other part is diffuse reflection. 

− s [-]: solar transmission factor (for a colour of type MATERIAL), a number between 0 and 1 

representing the resulting transmission factor – after reflection - of the MATERIAL layer 
and all transparent material layers (MATERIAL or EQUIMAT) behind it until another zone or 
an opaque material (s equals 0) is reached. See C.8.1 for a detailed explanation of the 
definition of s. 

 
The properties λ, c, θ, h, q, θa, hc, Pc, θr and ρs can each either have a constant value (as in 

BISCO) or refer to a function (defined in the Functions window) via the function reference name: 

L## (for λ), C## (for c), T## (for θ, θa, θr), H## (for h, hc), I## (for q), P## (for Pc), R## (for s). 

B.11. Colour functions 

The colour functions are available through the Colours submenu. 
 

   
 
Colours → List All 

List all 256 colours of the colour palette of the bitmap. 
The properties of colours not present in the bitmap are greyed. 
 
Colours → List Defined 
List all colours present in the bitmap and colours having defined thermal properties. 
Defined thermal properties of colours not present in the bitmap are greyed, and originate from 
the colour database or previous loaded BST files. 

 
Colours → List Present (default option when opening a BISTRA document) 
List only the colours present in the bitmap. 

 
Colours → Load Material… 
Load predefined material properties. 
From the Material Database dialog box choose a database file (file with extension .phm from the 
directory …\Physibel\Materials, see A.6), a material group and then a material. 
The database files (with extension .phm) can be edited using the program MatEdit.exe, also in the 
directory …\Physibel\Materials. 
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Colours → Copy Row and Colours → Paste Row 
Copy all properties from one colour to another colour. 

B.12. Functions window 

For the variable boundary conditions and material properties BISTRA refers to functions: either 

an internal function (parameters defined in the Functions window), or an external function (data 
read from a file). 
 

All functions that are used in a BISTRA data file, are defined in the Functions window, opened with 
the command Edit → Functions. 

The picture below shows an example of Functions window. 
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Each function is uniquely defined by a function reference name: 
 

Reference Description Units Date file formats 

T01 up to T99 Temperature function [°C] *.fte, *.epw, *.csv 

H01 up to H99 Surface heat transfer coefficient function [W/(m².K)] *.fht 

P01 up to P99 Power function [W] *.ffh 

I01 up to I99 Imposed flux function 

(I01 is used in the Solar Data dialog box) 

[W/m²] *.fir 

G01 up to G99 Horizontal global solar radiation function 
(only G01 is used in the Solar Data dialog 

box) 

[W/m²] *.fsg, *.epw, *.csv 

D01 up to D99 Horizontal diffuse solar radiation function 
(only D01 is used in the Solar Data dialog 

box) 

[W/m²] *.fsd, *.epw, *.csv 

V01 up to V99 ventilation function [m³/s] *.fvr 

M01 up to M99 thermal conductivity function  
(time dependent) 

[W/(m.K)] *.fco 

L01 up to L99 thermal conductivity function  

(temperature dependent) 

[W/(m.K)] *.fla 

C01 up to C99 specific heat function 
(temperature dependent) 

[J/(kg.K)] *.fce 

R01 up to R99 solar reflection factor function 
(angular dependent) 

[-] *.frf 

 
Function reference names can be used in: 

the Colours window (columns with header λ, c, θ, h, q, θa, hc, Pc, θr, ρs), 

the Borderline BCs window (columns with header θ and q), 

the Ventilation Flows window (column with head “Flow”). 

 
Temperature functions (L## and C##) and solar reflection factor functions (R##) can only have 
type FILE (see B.12.2). 
 
All function values are used in BISTRA as average values over the simulation time step, where the 

simulation time is understood as the middle of the simulation time step (see C.8.2). 
 
A new function can be inserted via Edit → Insert Row. 

The current function can be deleted via Edit → Delete Row. 

B.12.1. Internal time functions (types STEP0, STEP1, STEP2, SINE, and SINPOS) 

An internal time function is a built-in program function, defined by one or more parameters. 
BISTRA contains 5 built-in function templates. 
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The meaning of each parameter per function type is explained in the status bar (cf. figures 

below). 
All time parameters must be entered in minutes (e.g. 1 day = 24 h x 60 min/h = 1440 min). 
 

- STEP0 for a step function defined by 4 parameters (P1, P2, P3, P4) 

 
- STEP1 for a step function defined by 5 parameters (P1, P2, P3, P4, P5) 

 
- STEP2 for a step function defined by 6 parameters (P1, P2, P3, P4, P5, P6) 
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- SINE for a sine function, defined by 4 parameters (P1, P2, P3, P4) 

 
- SINPOS for a positive sine function, defined by 4 parameters (P1, P2, P3, P4) 

 
 

B.12.2. External functions (type FILE) 

An external time function is defined in a separate data file, with extension: 
- .fte (temperature function) 
- .fht (surface heat transfer coefficient function) 
- .ffh (power function) 
- .fir (imposed flux function) 
- .fsg (horizontal global solar radiation function) 
- .fsd (horizontal diffuse solar radiation function) 
- .fvr (ventilation function) 

- .fco (time dependent thermal conductivity function). 
The program FUNCEDIT (cf. Chapter G) allows to edit these files. 
 

External data as a source for an external time function can either be formatted as a linear 
function, or as a step function (see G.3).  
In case of a linear function format, function values at simulation times in between external data 
timestamps are obtained by simple linear interpolation between the external data timestamps.  
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In case of a step function format, the values in the external data file are interpreted as the 

average value during the data interval preceding the external data timestamp and are thus 
assumed constant and equal to the value at the data interval’s end timestamp for any simulation 
times in between external data timestamps1. An exception is made for solar radiation functions 
(G## and D##), in which case external data formatted as a step function are converted to 

instantaneous values at simulation times using a mathematical algorithm (see C.8.2)2. For this 
algorithm to work, the simulation start time and time step have to be defined in such a way that 
the simulation hits the hours precisely (see C.2.1). 
 
Some material properties (thermal conductivity, specific heat, solar reflection factor) may be 
dependent on another property (temperature, angle of incidence). 

These temperature functions (thermal conductivity, specific heat) or angular functions (solar 
reflection factor) are defined in separate data files, with extension: 

- .fla (temperature dependent thermal conductivity function) 

- .fce (temperature dependent specific heat function) 
- .frf (angular dependent solar reflection factor function). 

These function data files are text files consisting of two or more text lines: 
 
 x0  y0 

 x1  y1 

 x2  y2 

 … 

 xn  yn 

 
with x0 ≤ x1 ≤ x2 ≤ … ≤ xn. 

Each text line consists of two float numbers, the abscissa (i.e. a temperature value or an angle of 
incidence) and the ordinate (i.e. the corresponding thermal conductivity, specific heat value or 
solar reflection factor) of a characteristic point of the function. The function is linearly interpolated 

between the characteristic points. If x < x0, then y = y0. If x > xn, then y = yn. 
The user can define these functions with a text editor (e.g. Windows Notepad). 
 

When the function filename field is double clicked (or when Enter is pressed), a file path can be 
chosen in the Open dialog box. If the external files are stored in the same directory (or a 
subdirectory of this directory) as the BISTRA data file, the file paths are relative (so that copying of 

the .bst file together with the function files to another directory has the desired result that the new 
.bst file refers to the function files in the same new data directory). If the external files are not 
stored in the same directory as the BISTRA data file, the absolute file paths are saved in the .bst 
file. 

B.12.3. Weather data files (types EPW and TMY3) 

A weather data file is a data file containing observations of weather variables such as 
temperature, relative humidity, solar radiation, wind speed, etc. for a specific location. Two 
different data file formats can be imported into BISTRA: EPW or EnergyPlus Weather (extension 
.epw), and TMY3 or Typical Meteorological Year (extension .csv). 

 

 
1 Note that in older versions of BISTRA (v4.2 and before), step function formatted external data were 

interpreted differently, namely as the average value during the data interval following the external data 

timestamp and thus assumed constant and equal to the value at the data interval’s begin timestamp for 

any simulation times in between external data timestamps. 
2 This algorithm was not included in older versions BISTRA (v4.2 and before). 
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The weather data files can only be used as functions in BISTRA if they (i) contain data for a 

complete year, (ii) are defined in local time (not solar time), (iii) do not contain lines with more 
than 512 characters, and (iv) start at hour 1 after midnight, January 1st.3 
Weather data files can be used as source for the functions: 

- Temperature (T##): the dry-bulb temperature of the weather file is read and interpreted 

as instantaneous values occurring at the timestamps denoted in the weather data file. 
- Global horizontal radiation (G##): the total horizontal radiation is read and interpreted as 

the total amount of radiation (Wh/m²) received in the interval preceding each timestamp. 
- Horizontal diffuse radiation (D##): the diffuse horizontal radiation is read and interpreted 

as the total amount of diffuse radiation (Wh/m²) received in the interval preceding each 
timestamp. 

 
The temperature values from the weather data file are linearly interpolated between the 
instantaneous values occurring at the data file timestamps4. The radiation values from the 

weather data file are converted to instantaneous values at simulation times using a mathematical 
algorithm (see C.8.2). For this algorithm to work, the simulation start time and time step have to 
be defined in such a way that the simulation hits the hours precisely (see C.2.1). 
 
If function G01 for global horizontal radiation is a weather data file, the geographical location is 
automatically read and used in the solar processor (see B.15.1). 

 
When the function filename field is double clicked (or when Enter is pressed), a file path can be 
chosen in the Open dialog box. 

If the weather data files are stored in the same directory (or a subdirectory of this directory) as 
the BISTRA data file, the file paths are relative (so that copying of the .bst file together with the 
weather data files to another directory has the desired result that the new .bst file refers to the 

weather data files in the same new data directory). If the weather data files are not stored in the 
same directory as the BISTRA data file, the absolute file paths are saved in the .bst file. 

B.13. Function Graph window 

The Function Graph window shows a graph of the current function in the Functions window. 

The Function Graph window is automatically opened when the Functions window is activated, 

and automatically closed when another window is activated (e.g. Measures window or Colours 

window). 
 

Zoom functions (via the Zoom submenu) allow to view function details. 
 
The quantities defined by the X axis (time, temperature, angle of incidence) and Y axis 
(temperature, surface heat transfer coefficient, flux, power, lambda, specific heat, solar reflection 

factor) are determined by the current function in the Functions window. 

The origin of the X axis of a time function (i.e. time = 0) corresponds to the calculation start time, 
as defined in the Calculation Parameters dialog box. 
 

 
3 In case the simulation start time is hour 0 (midnight), January 1st, the values from the weather data file for 

hour 1 are copied for hour 0. 
4 Note that in the .epw file format valid values for the ‘hour’ field run from 1 to 24 (hour 1 is 00:01 to 01:00 in 

local time) and values for the ‘minute’ field run from 1 to 60. This means that e.g. the combination of hour 2 

and minute 60 indicates a time stamp of 02:00 in local time. If the ‘minute’ field is undefined in the .epw file 

(typically with value 0), it is interpreted as having value 60. 
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In case of solar radiation functions (G## and D##) using an external data file with data 

formatted as a step function (B.12.2) or a weather file (B.12.3) the source data are visualised in the 

Function Graph window, not the converted function values used in the simulation (see C.8.2). 

B.14. Function commands 

The X and Y axis tick marks and labels from the graph shown in the Function Graph window can 

be redefined via the commands Functions → X Scale… and Functions → Y Scale….  
 

  
 

The scope of the time scale on the X axis can be chosen between fixed values, function scope 
(corresponding to the definition of the function) and calculation time (corresponding to the 

calculation duration as defined in the Calculation Parameters dialog box). 
When fixed values are chosen, the minimum and maximum value (with plus or minus sign), and 

the major and minor tick distances can be set. Also the label unit can be chosen (seconds, 
minutes, hours or days). 
 

  
 

B.15. Solar data 

The solar processor requires the definition of parameters in the Solar Data dialog box (Edit → 
Solar Data…). 
 
First, a choice can be made between a Real sun path or a simplified calculation with a Fixed sun 
position. 
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B.15.1. Real sun path 

North orientation: The bitmap must be positioned into the horizontal coordinate system. This is a 

3D coordinate system with the local horizon as fundamental plane XY. The X axis points to the 
north, the Y axis points to the west, the Z axis points to the zenith. 
The coordinate transformation (from 2D bitmap XbYb into 3D horizontal coordinate system XYZ) is 

defined by three rotation angles. The first two angles define the transformation from the bitmap 
XbYb into a horizontal coordinate system XYZ without paying attention to the north direction within 
the local horizon plane. 
  
 
 

 
 
 
 
  

 
 

 
 
 
 

• The first rotation brings the Xb axis in a horizontal position. 
This rotation happens within the bitmap XbYb plane (i.e. a rotation around the Zb axis, 
perpendicular to the bitmap). 
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After the rotation the original system XbYbZb becomes the new system X’Y’Z’ (with Z’ = Zb). 

The rotation angle is chosen so that after rotation the new X’ axis is set in the horizontal 
plane XY. 
The rotation angle is clockwise oriented (i.e. the angle which moves Yb to Xb is +90°). 
For a horizontal or vertical bitmap this first rotation is not required (angle = 0°, because 

the Xb axis is already in a horizontal position), but for a slanted bitmap (e.g. cross section 
of a slanted roof) it may be required. 

• The second rotation brings the Y’ axis too in a horizontal position (while X’ remains 
horizontal). 
This rotation turns the bitmap (located in the X’Y’ plane = XbYb plane) around the X’ axis 
(i.e. within the Y’Z’ plane). 

After the second rotation the system X’Y’Z’ is transformed to the new system X”Y”Z” (with 
X” = X’). 
The rotation angle is counterclockwise oriented (i.e. the angle which moves Y’ to Z’ is 

+90°). 
This rotation angle is equal to the angle between the normal (Zb axis) on the bitmap XbYb 
plane and the zenith (Z-axis), i.e. the elevation angle. 
For a bitmap representing a horizontal section view the second rotation angle equals 0°. 
For a bitmap representing a vertical section view the second rotation angle equals 90°. 

• The third rotation let the X” axis point to the north (while the X”Y” plane remains 

horizontal). 
This rotation around the Z” axis turns the system X”Y”Z” into the final horizontal system XYZ 
(with Z = Z”). The rotation angle is clockwise oriented (i.e. the angle which moves Y” to X” is 

+90°). 
 
The position of the bitmap in the 3D horizontal coordinate system XYZ after these rotations is 

shown in the dialog box as a visual aid for defining the rotation angles. 
 
Geographical location (“earth position”): latitude (°N), longitude (°E) and time zone (h E). 

The input fields are disabled when these parameters are present in the weather data file 

containing the global solar radiation data, as defined in the Functions window (G01). The 

coordinates are then loaded from the solar radiation weather data file. 

Solar radiation functions: the function reference names of the horizontal global and diffuse solar 
radiation functions are always G01 and D01. These solar radiation functions must be defined in 

the Functions window. 

Ground reflection factor: reflection factor of (horizontal) ground surface around the object model. 
The reflected solar radiation is projected on the external object surfaces using an isotropic diffuse 

model. 
The input value must be between 0 and 1. A typical value is 0.2. For very reflective grounds a 
higher value can be used (e.g. snow: 0.8). 

B.15.2. Fixed sun position 

An alternative to a Real sun path is to impose a fixed sun position for a simplified calculation. In 
this case, the user can choose between a function or a constant value for the total solar radiation. 

The total solar radiation is treated as direct radiation in the calculation (see C.8.2). 
In case a function is selected, the function reference name I01 is always used and should be 

defined in the Functions window. This function I01 contains time dependent data for the total solar 

radiation.  
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This direct radiation originates from a user-defined angle around the bitmap. An angle of 90° for 

example means the solar radiation comes from the top border of the bitmap, in a direction 
perpendicular to that bitmap border. 

B.16. Sun obstacles window 

Sun obstacles around the 3D object obtained by extrusion of the bitmap are defined in the Sun 

Obstacles window, opened with Edit → Sun Obstacles. Each sun obstacle is a spherical rectangle 
defined by azimuth and altitude coordinates within which the sun is invisible. If the solar zone 
does not surround the complete object defined in the bitmap, the explicit definition of sun 
obstacles is necessary to prevent that the sun hits the object from unwanted angles. 
The azimuth and altitude coordinates are defined in the coordinate system XYZ (see B.15). 

Each sun obstacle is defined by four parameters: minimum and maximum azimuth (clockwise 
angle between –180° and 180°, 0° = south, 90° = west), and minimum and maximum altitude 
(between 0° at the horizon and 90° at the zenith). 

 
By default one sun obstacle (defined by a zone up to 5° high above the horizon in all directions 

around) is present for each new BISTRA file (cf. figure below). 
 

 
 
A new sun obstacle is added using Edit → Insert Row. 

A sun obstacle is deleted using Edit → Delete Row. 
 

Note that the Sun Obstacles window is disabled in case a fixed sun position is defined in the Solar 
Data dialog box (see B.15), as sun obstacles are not taken into account in that case. 

B.17. Border U Values window 

The Border U Values window allows to derive 1D U-values at the bitmap’s borders, which are 

shown for information. 
 

The Border U Values window automatically calculates the U-values at the bitmap borders based 

on 1D heat transfer through material layers of type MATERIAL, EQUIMAT or TRANSMAT, or cavity 
layers of type BC_FREE between two different boundary conditions of type BC_SIMPL (or 
BC_FRE_S) or BC_SKY along the outermost pixel strip at the bitmap borders. 

For MATERIAL and EQUIMAT layers, the lambda value as shown in the Colours window is used in 

the U-value calculation. 
For TRANSMAT and BC_FREE layers, the U-value shown is calculated assuming linear radiation 
using the black linear radiation coefficient ℎ𝑟𝑏 as defined in the Calculation Parameters dialog 
box (C.2.4).  
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For BC_SKY boundary conditions, the U-value shown is calculated assuming a constant radiation 

surface heat transfer coefficient ℎ𝑟 of 5.2 W/m²K. 
The field is blank if the U-value calculation fails. 

B.18. Borderline boundary conditions window 

In the borderline between two different colours (identified by their colour numbers) user-defined 

temperatures or heat fluxes (as constant values or functions of time) can be imposed. 

The borderline boundary conditions are defined in the Borderline BCs window, opened with Edit 

→ Borderline BCs. 

 
A new borderline boundary condition is added using Edit → Insert Row. 

A borderline boundary condition is deleted using Edit → Delete Row. 
 
For each borderline boundary condition, enter: 

- Colour numbers of two adjacent colours. 
Invalid colour numbers (not present or not adjacent in the bitmap) cannot be entered. 

- Type: “TEMP” (fixed temperature) or “FLUX” (fixed heat flux). 
- Temperature θ (if type = TEMP), either a constant value or a function reference (defined in 

the Functions window): T##, with ## a number from 01 to 99. 

- Heat flux q (if type = FLUX), either a constant value or a function reference (defined in the 

Functions window): I##, with ## a number from 01 to 99. 

 

 

B.19. Ventilation flows window 

Ventilation flow paths can be defined in the Ventilation Flows window, opened with Edit → 
Ventilation Flows. Add new ventilation flows with the command Edit → Insert After. 
 

  
 
For each ventilation flow definition line a ventilation source and ventilation destination must be 

entered. Both are identified by colour numbers to the corresponding boundary conditions. 
The ventilation source (in the column with header “From Col. 1”) can be any type of boundary 
condition (BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY or BC_NOSKY). The ventilation destination 

(in the column with header “To Col. 2”) must be a boundary condition of type BC_FRE_S or 
BC_FREE (with unknown air temperature influenced by the incoming ventilation flow). Ventilation 
flows with destination a zone with fixed air temperature can not be entered, because they have 
no effect on the system. 

The ventilation flow (last column) is a constant value or a reference to a ventilation function (V##) 

as defined in the Functions window. 

The user should take care that all defined ventilation flows refer to a realistic ventilation scheme. 

A ventilation path can originate from an outside environment, pass through some internal zones 
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and leave to another outside environment. But a ventilation path can also pass through a closed 

circuit of only internal zones. 
 
All air cavities of type BC_FRE_S and BC_FREE that occur as ventilation source or ventilation 

destination in the Ventilation Flows window are automatically unlinked without the need of explicit 

definition as explained in section C.6. 
 
The following error messages may occur when doing a calculation: 

- “Syntax error in ventilation flow N”: 

The ventilation flow in the Ventilation Flows window at line N contains a syntax error. 

Either the ventilation source is not a boundary condition (i.e. a colour of type BC_SIMPL, 

BC_FRE_S, BC_FREE, BC_SKY or BC_NOSKY), or the ventilation destination is not a 
boundary condition of type BC_FRE_S or BC_FREE, or the specific heat (c) and/or the 
density (ρ) of the ventilation source and destination are not equal (see B.10). 

- “Error in ventilation system”: 

The combination of all ventilation flows as defined in the Ventilation Flows window does 

not correspond to a physically correct ventilation system. This error occurs when the 
ventilation system has no unique solution (undetermined system). 

B.20. Report Definition window 

The contents of a report in the Text Output window (see E.4) after a calculation has been 

executed, is determined by the report definition and the report frequency (cf. section B.21). 

The input of the report definition is done in the Report Definition window, opened with Edit → 

Report Definition. 

The report definition consists of several report items, one per line in the Report Definition window. 
A new report item is added via Edit → Insert Row. 

During the generation of a report in the Text Output window, a report line is written per report 

step (which equals the calculation time step or a multiple of it, as defined by the report 
frequency). 
The report line consists of the actual values of the report items (separated by tabs) at the current 

time step. 
 

  
 
A report item is defined by the following elements (corresponding to the different columns): 

- Object: a toggle with values TIME, DATE TIME, COLOUR, 2 COLOURS, BORDER BC, SUN. 
- Object No., which meaning is dependent on the selected object: 
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o TIME: not applicable. 

o DATE TIME: not applicable. 

o COLOUR: colour number (cf. first column in Colours window). 

o 2 COLOURS: 2 colour numbers (cf. first column in Colours window). 

o BORDER BC: borderline boundary condition number (cf. first column in Borderline 

BCs window). 

o SUN: not applicable. 
- Type, a toggle with values dependent on the selected object: 

 

Object Type Meaning 

TIME [s] time in seconds of the current time step 

DATE TIME [dddd:hh:
mm:ss] 

time in days, hours, minutes and seconds of the current time 
step 

COLOUR θmin minimum temperature [°C] (for colour of type MATERIAL or 
EQUIMAT) 

θmax maximum temperature [°C] (for colour of type MATERIAL or 

EQUIMAT) 

Δθmax maximum temperature difference (θmax - θmin) [°C] (for colour 

of type MATERIAL or EQUIMAT) 

θmean mean temperature ((θmin + θmax)/2) [°C] (for colour of type 

MATERIAL or EQUIMAT) 

Qin heat flow per unit length into object [W/m] 

(for colour of type BC_SIMPL, BC_FRE_S, BC_FREE, 
BC_SKY, BC_NOSKY or TRANSMAT) 

Qout heat flow per unit length out of object [W/m] 
(for colour of type BC_SIMPL, BC_FRE_S, BC_FREE, 

BC_SKY, BC_NOSKY or TRANSMAT) 
λ (Equivalent) thermal conductivity [W/(m.K)] 

(for colour of type MATERIAL, EQUIMAT or TRANSMAT) 
θ boundary condition temperature [°C] 

(for colour of type BC_SIMPL or BC_FRE_S) 

h total surface heat transfer coefficient [W/(m².K)] 

(for colour of type BC_SIMPL or BC_FRE_S) 

q heat flux into boundary condition [W/m2] 
(for colour of type BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY 
or BC_NOSKY) 

θa air temperature [°C] 
(for colour of type BC_FREE, BC_SKY or BC_NOSKY) 

hc convective heat transfer coefficient [W/(m2.K)] 
(for colour of type BC_FREE, BC_SKY or BC_NOSKY) 

Pc convective power into boundary condition [W/m] 
(for colour of type BC_FREE or BC_FRE_S) 

θr radiation temperature [°C] (for colour of type BC_SKY) 

Qsol absorbed solar heat flow per unit length [W/m] in all 

interface(s) with zone(s) of the colour (See C.8.3) and in the 
contact surface behind transparent materials for opaque 
colours (see C.8.6) 
(for colour of type MATERIAL or EQUIMAT) 
A zone in this context is either a solar zone (BC_SIMPL or 
BC_SKY) or an internal zone with detailed radiation 
calculation (BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT). 
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qsol absorbed solar flux [W/m²] in all interface(s) with zone(s) of 

the colour (See C.8.3) and in the contact surface behind 
transparent materials for opaque colours (see C.8.6) 
(for colour of type MATERIAL or EQUIMAT) 

A zone in this context is either a solar zone (BC_SIMPL or 
BC_SKY) or an internal zone with detailed radiation 
calculation (BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT). 

Etot Total solar irradiance in interface with solar zone [W/m²] 

Edir Direct solar irradiance in interface with solar zone [W/m²] 

Edif Diffuse solar irradiance in interface with solar zone [W/m²] 

Egr Ground reflected solar irradiance in interface with solar zone 
[W/m²] 

2 COLOURS θmin minimum temperature [°C] occurring in set of 2 colours 

θmax maximum temperature [°C] occurring in set of 2 colours 

Δθmax maximum temperature difference (θmax - θmin) [°C] occurring 

in set of 2 colours 

θmean mean temperature ((θmin + θmax)/2) [°C] of set of 2 colours 

BORDER BC θ temperature [°C] 

q heat flux [W/m²] 

SUN AZIMUTH sun azimuth [°] (0:south, 90:west, -90:east) 

ALTITUDE sun altitude [°] (0:horizon, 90:zenith) 

 

- Width: (maximum) number of characters for formatting the output values in the output 
report 

- Decimals: number of digits after the decimal point, to which the output values are 

rounded. 
 

If a report item definition is logically impossible, no values are given in the report (-). 

B.21. Report Frequency 

A report line in the report output is written for every time step or every fixed number of time steps. 

This number is set, before the calculation is started, in the Report Frequency dialog box, opened 

with Calc → Report Frequency…. 

When a calculation is started, the amount of memory is allocated to save the report records 
during the calculation. At the end of the calculation the report records are saved in a text file and 
a CSV file (with same name and file folder as input data file, and extensions .txt and .csv). This 
report file can be viewed in the text output. 
 

 

B.22. Save Frequency 

During a calculation, time step solutions (i.e. the calculated temperatures in all calculation nodes 
and the absorbed solar fluxes) at every fixed number of time steps can be saved to disk to use 
later in graphic output or text output (to view the solutions at those time steps). 

The save frequency must be set, before the calculation is started, in the Save Frequency dialog 

box, opened with Calc → Save Frequency…. 
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The node temperature solutions are saved in .sol files with the same file name of the input data 
file appended with a 4-digit serial number. For example if the input data file is PilotexBistra.bst, 

then the solution files are PilotexBistra0000.sol, PilotexBistra0001.sol, PilotexBistra0002.sol etc. 
The absorbed solar fluxes are saved in .sfx files with the same file name of the input data file 

appended with a 4-digit serial number in the same way as the .sol files. 

B.23. General editing commands 

Copy – paste 
Edit → Copy Cell: copies the value from the current input cell into the clipboard. 
Edit → Paste Cell: copies the value from the clipboard into the current input cell. 
 
Undo – redo 

Edit → Undo 
Undoes the last edit action (to cancel a mistake). 
This command can be repeated to undo more edit actions. 
Only the last 100 edit actions are stored for possible later recovery using Edit → Redo. 
The undo command is impossible after saving a file (File → Save and File → Save As…), closing 
the current file (File → Close, also File → Open Bitmap…, File → Open…) or starting a calculation 
(Calc → Calc System and File → Batch Calculation… ). 
Edit → Redo 
Restores the previous edit action that was made undone using Edit → Undo. 
This command can be repeated to restore more edit actions that were made undone. 
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CHAPTER C SYSTEM CALCULATION 

C.1. Automatic calculation of thermal properties 

In the Colours window colour types and subtypes can be selected which contain an automatic 

calculation of thermal properties. 
Whenever this automatic calculation (or definition) of thermal properties is according to an 

international standard, the relevant standard is denoted in the Standard column in the Colours 

window. 

Some standards explain how to determine the thermal resistance of air/gas cavities and layers, 
but not how to model them (EN ISO 6946 and EN 673, namely5). In this case, modelling them as 
equivalent materials (EQUIMAT, TRANSMAT) or modelling them as an enclosure with a single 
convective air/gas node (BC_FREE) are both possible in BISCO. 
Conversely, standard EN ISO 10077-2 explicitly states that air cavities should be modelled as an 

equivalent material, either including convection and radiation (EQUIMAT) or only including 
convection and modelling radiation explicitly (TRANSMAT). 

C.1.1. Colour type EQUIMAT 

Colour modelled as equivalent material (with single equivalent thermal conductivity 𝜆𝑒𝑞 for 

combined convective and radiation heat transfer) 
 

Type Subtype Meaning Standard 

EQUIMAT NIHIL Thermal conductivity 𝜆 defined by user  

CAVITY 
Unventilated (internal) air cavity with given heat flow 
direction 

EN10077 
EN6946 

CAVITY_E 
Ventilated (external) air cavity with given heat flow 
direction 

EN10077 

 LAYER Unventilated air/gas layer with given heat flow direction 
EN6946 

EN673 

 
Characteristic dimensions of an air cavity 

The characteristic dimensions for a rectangular air cavity are its depth (parallel to the heat flow 
direction) and width (perpendicular to the heat flow direction). 
A non-rectangular air cavity is transformed into a rectangular air cavity, using the same ratio of 
depth to width for the surrounding rectangle of the non-rectangular air cavity and the new 
rectangular air cavity (both oriented along the heat flow direction):  

 
5 Note that standard EN ISO 10211 states that air/gas cavities and layers should be considered as 

homogeneous materials with an equivalent thermal conductivity based on the thermal resistance 

determined by EN ISO 6946 or EN 673, i.e. type EQUIMAT. 
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The characteristic dimensions 𝑑 and 𝑏 (of the rectangular air cavity) are further used in the 
formulas below. 
 
Equivalent thermal conductivity of unventilated air cavity (subtype CAVITY) 
𝜆𝑒𝑞 = (ℎ𝑐 + ℎ𝑟) ∙ 𝑑 

- ℎ𝑐 = convective heat transfer coefficient (from warm surface to cold surface) 

if 𝑏 < 0.005 m (EN ISO 10077-2), then 

ℎ𝑐 =
𝐶1

𝑑
 

if 𝑏 ≥ 0.005 m (EN ISO 10077-2) or for any 𝑏 (EN ISO 6946), then 

ℎ𝑐 = 𝑚𝑎𝑥 {
𝐶1

𝑑
, 𝐶2 ⋅ (𝛥𝜃𝑠𝑠)𝐶3} 

𝛥𝜃𝑠𝑠 = maximum surface temperature difference in air cavity (𝛥𝜃𝑠𝑠 ≥ 5°C for EN ISO 6946) 
or 𝛥𝜃𝑠𝑠  = 𝛥𝜃𝑠𝑠,𝑑𝑒𝑓𝑎𝑢𝑙𝑡 (see C.2.5) 

 

Standard Heat flow direction C1 C2 C3  𝛥𝜃𝑠𝑠,𝑑𝑒𝑓𝑎𝑢𝑙𝑡 

EN ISO 10077-2 horizontal 0.025 0.73 0.333333 10°C 

EN ISO 6946 horizontal 0.025 0.73 0.333333 5°C 

upward 0.025 1.14 0.333333 5°C 

downward 0.025 0.09 ⋅ 𝑑−0.44 0.187 5°C 

 

- ℎ𝑟 = radiative heat transfer coefficient 
EN ISO 10077-2: ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 ∙ 𝐸 ∙ 𝐹 

EN ISO 6946: ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 (
1

𝐸
+

1

𝐹
− 1)⁄  

𝐸 =
1

1
𝜀1

+
1
𝜀2

− 1
 

𝐹 = (1 + √1 + (
𝑑

𝑏
)

2

−
𝑑

𝑏
) 2⁄  

𝜃𝑚 =
𝜃𝑠,𝑚𝑖𝑛 + 𝜃𝑠,𝑚𝑎𝑥

2
 

𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in air cavity [°C] 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in air cavity [°C] 

or 𝜃𝑚 = 10°C (default mean temperature, see C.2.5) 
 1 , 2 = emissivities at warm and cold sides of air cavity (default values: 1 = 2 = 0.9) 
 
Equivalent thermal conductivity of slightly ventilated air cavity (subtype CAVITY_E, standard 
EN10077) 
An air cavity is considered to be slightly ventilated when there is an open connection to an 

exterior or interior boundary condition with a slit between 2 and 10 mm, and 𝑑  𝑏. 
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𝜆𝑒𝑞 = 2 ∙ (𝜆𝑒𝑞 of unventilated air cavity). 

 
Equivalent thermal conductivity of air/gas layer (subtype LAYER) 

- Standard EN ISO 6946: in the formula above for subtype CAVITY, set d/b = 0 for hr. 
- Standard EN 673: 

𝜆𝑒𝑞 = (ℎ𝑐 + ℎ𝑟) ∙ 𝑑 

• ℎ𝑐 = convective heat transfer coefficient 

ℎ𝑐 = 𝑁𝑢
𝜆

𝑑
  

With: 
 𝑁𝑢 = max (1, 𝐴 ∙ (𝐺𝑟 ∙ 𝑃𝑟)𝑛) or 𝑁𝑢 = 0 in case of vacuum 

 𝐺𝑟 =
9.81𝑑3𝛥𝜃𝑠𝑠𝜌2

𝑇𝑚𝜇²
 

 𝑃𝑟 =
𝜇𝑐

𝜆
 

𝛥𝜃𝑠𝑠 = maximum surface temperature difference in layer 
or 𝛥𝜃𝑠𝑠  = 15°C (see C.2.5) 

𝑇𝑚 =
𝜃𝑠,𝑚𝑖𝑛 + 𝜃𝑠,𝑚𝑎𝑥

2
+ 273.16 

𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in layer [°C] 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in layer [°C] 

or 𝜃𝑚 = 10°C (default mean temperature, see C.2.5) 
 

Heat flow direction Inclination angle 𝐴 𝑛 

Downward >90° 0 N.A. 
Horizontal 90° 0.035 0.38 

 45° 0.10 0.31 

Upward 0° 0.16 0.28 

 (Values for ℎ𝑐 are interpolated for intermediate heat flow directions) 
  

Gas 𝜌 𝜇 𝜆 𝑐 

Air 1.232 1.761·10-5 2.496·10-2 1.008·10³ 

Argon 1.699 2.164·10-5 1.684·10-2 0.519·10³ 

SF6 6.360 1.459·10-5 1.275·10-2 0.614·10³ 

Xenon 5.689 2.226·10-5 0.529·10-2 0.161·10³ 

Krypton 3.560 2.400·10-5 0.900·10-2 0.245·10³ 

 (In case of a gas mix, the gas properties are proportioned in the ratio of the 
 user-defined volume fractions)
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• ℎ𝑟 = radiative heat transfer coefficient 
ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 ∙ 𝐸 

𝐸 =
1

1
𝜀1

+
1
𝜀2

− 1
 

1 , 2 = emissivities at warm and cold sides of layer (default values: 1 = 2 = 0.9) 

 
Adiabatic boundaries 
An adiabatic boundary (i.e. a boundary through which there is no heat transfer) can be 

considered as a symmetry axis (with symmetric heat flow pattern). 
When there is an adiabatic boundary at one side of the width direction, the equivalent width b is 
automatically doubled for subtype CAVITY. 

When there are adiabatic boundaries at both sides of the width direction, the equivalent width b 
is automatically considered to be infinite for subtype CAVITY (so d/b = 0, as for subtype LAYER). 
If the air cavity touches a bitmap border, then the calculation parameter “Bitmap border is axis of 

symmetry” decides whether it is an adiabatic boundary (see C.2.5). 

 

C.1.2. Colour type BC_SIMPL or BC_FRE_S 

Purpose: simplified surface boundary condition (using a global surface heat transfer coefficient). 
For BC_SIMPL, the environment temperature is defined by the user. For BC_FRE_S, the 

environment temperature is unknown (free-floating). 
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Type Standard Subtype 
Physical  

heat flow 
Meaning 

BC_SIMPL 

NIHIL 

NIHIL 

 Global surface heat transfer  
coefficient h and temperature θ defined 

by user 

HI 

 Global surface heat transfer  
coefficient h and temperature θ at 

interior surface defined by user 

EN10077 

HI_NORML horizontal 
Normal h at interior surface:  
h = 7.7 W/(m2.K), θi = 20°C 

HI_REDUC horizontal 
Reduced h at interior surface:  
h = 5 W/(m2.K) , θi = 20°C 

HE  
h at exterior surface:  
h = 25 W/(m2.K), θe = 0°C 

HI_CAV_E horizontal 
Slightly ventilated air cavity: 
h = 3.33 W/(m2.K), θi = 20°C 

HE_CAV_E horizontal 
Slightly ventilated air cavity: 
h = 3.33 W/(m2.K), θe = 0°C 

EN6946 

HI 

horizontal 
h at interior surface:  
h = 7.7 W/(m2.K) 

upward 
h at interior surface:  
h = 10 W/(m2.K) 

downward 
h at interior surface:  
h = 5.9 W/(m2.K) 

HE 
 h at exterior surface:  

h = 25 W/(m2.K) 
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C.1.3. Colour type BC_FREE 

(This type requires the RADCON module, see Chapter H) 

Purpose: enclosure with unknown (free-floating) air temperature (single thermal node) to be 
calculated from convective heat balance, and radiation based on view factors. 

Type Subtype Meaning Standard 

BC_FREE NIHIL Thermal conductivity 𝜆 defined by user NIHIL 

CONVEC Large air space, without preferential heat flow direction* NIHIL 

CAVITY 
Unventilated (internal) air cavity with given heat flow 
direction 

EN6946 

 LAYER Unventilated air layer with given heat flow direction 
EN6946 
EN673 

*typically larger than 0.3m 

 
CAVITY and LAYER: 
The CAVITY and LAYER subtypes are to be used when a global heat flow direction is assumed 
(surface-to-surface heat transfer with an air temperature in between temperature of ‘hot’ and 
‘cold’ surface temperatures, e.g. typically used for a cavity in a façade). 
The characteristic dimensions of the air cavity, d (= depth, parallel to heat flow) and b (= width), 
are calculated as for colour type EQUIMAT (see C.1.1). 

The convective surface heat transfer coefficient ℎ𝑐 is calculated as for colour type EQUIMAT (see 
C.1.1). The values calculated according to the different standards in C.1.1 are defined however as 
surface-to-surface. Since the convective surface heat transfer coefficient ℎ𝑐 for BC_FREE is 
surface-to-air, the values calculated in C.1.1 are doubled. 
ℎ𝑐 = convective surface heat transfer coefficient (surface-to-air) 
ℎ𝑐 = 2 ∙ (ℎ𝑐,𝐸𝑄𝑈𝐼𝑀𝐴𝑇) 

 

CONVEC: 
The subtype CONVEC must be used when no global heat flow direction can be assumed in the 

enclosure (surface-to-air heat transfer with an air temperature higher or lower than surface 
temperatures, e.g. typically used for a room). 
ℎ𝑐= convective surface heat transfer coefficient (surface to air) 
ℎ𝑐 = 2 ∙ 𝐶2 ∙ (𝛥𝜃𝑠𝑎)𝐶3 
𝛥𝜃𝑠𝑎= greatest difference between air temperature and surface temperature 

𝛥𝜃𝑠𝑎 = max (|𝜃𝑎 − 𝜃𝑠,𝑚𝑖𝑛|, |𝜃𝑎 − 𝜃𝑠,𝑚𝑎𝑥|) 

𝜃𝑎 = air temperature 
𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in contact with given boundary condition colour 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in contact with given boundary condition colour 

or 𝛥𝜃𝑠𝑎= calculation parameter “Default temperature difference for hc calculation (subtype 

CONVEC)” (see C.2.5) 
 

Heat flow direction C2 C3 

horizontal 0.73 0.333333 

upward 1.14 0.333333 

downward 0.09 0.187 
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C.1.4. Colour type BC_SKY or BC_NOSKY 

(This type requires the RADCON module, see Chapter H) 

Purpose: environment with known air temperature and either user defined radiation temperature 
(BC_SKY) and radiation based on view factors or no radiation exchange (BC_NOSKY). 

Type Subtype Meaning 

BC_SKY 
or 
BC_NOSKY 

NIHIL Convective surface heat transfer coefficient hc defined by user 

CONVEC 
Natural convection surface-air  
(calculation of hc: cf. above BC_FREE - CONVEC, see C.1.3) 

C.1.5. Colour type TRANSMAT 

(This type requires the RADCON module, see Chapter H) 

Purpose: air cavity modelled as transparent material (radiation based on view factors, cf. 
radiosity method (EN ISO 10077-2), and equivalent thermal conductivity 𝜆𝑒𝑞 for convective heat 

transfer) 

 

Type Subtype Meaning Standard 

TRANSMAT NIHIL Thermal conductivity 𝜆 defined by user  

CAVITY 

Unventilated air cavity with given heat flow direction or 
along temperature gradient* (calculation of eq: cf. above 

EQUIMAT, CAVITY with hr = 0, because radiation is 
calculated using view factors) 

EN10077 
EN6946 

 LAYER 

Unventilated air layer with given heat flow direction 

(calculation of eq: cf. above EQUIMAT, LAYER with hr = 0, 
because radiation is calculated using view factors) 

EN6946 
EN673 

*Geometrical flow direction: DIR 

C.2. Calculation parameters 

A system calculation (Calc → Calc System) is controlled by calculation parameters. 
The menu command Edit → Calc Parameters… opens a dialog box in which the calculation 

parameters can be edited. The parameters not relevant to the current BISTRA document are 
disabled (greyed in the dialog box). 
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C.2.1. Time 

- Time step: this is the time distance between two successive dynamic system calculations 
(time format: days, hours, minutes and seconds separated by colons). 

- Start-up calculation duration: this is the time duration before the actual start of the 
calculation (where reporting starts) with the purpose to get good dynamic start values. 

The boundary condition values of time-dependent functions are taken before the time 
origin of those functions, so that the actual calculation (at the end of the start-up 

calculation duration) starts at time 0. Internal functions which are not periodic (i.e. 
functions of type STEP0 and STEP1), get the function value at time 0 during the entire 
start-up calculation duration. Periodic functions are extended for negative time values 
with the same periodic function course. For external functions the “previous function” is 
taken, as defined in the function editor FUNCEDIT (cf. Chapter F). 

- Calculation duration: duration of the dynamic calculation during which time step results 
and report items can be saved (e.g. to produce a graphic animation). 

- Calculation start: definition of the day number (between 1 and 365) and exact time of day 
to indicate the moment in the year where the calculation starts. This is important when the 
used (external) function is related to a calendar date: e.g. a test reference year, with 
hourly climatic data of a typical year in a given location. The start date of the external 
function or weather data file may be different from the start date of the calculation. 
The button “i” near the input field gives, when pressed, the day numbers for the first day of 
each month for information. 
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In case of solar radiation functions (G## and D##) using an external data file with data 
formatted as a step function (B.12.2) or a weather file (B.12.3), the time step and calculation start 
have to be defined in such a way that the simulation hits the hours precisely. If this condition is not 
met, an error message is shown when starting the calculation. 

C.2.2. Triangulation 

Contour approximation margin 

Defines the maximum allowed distance between the original bitmap colour contours and the 
approximated contours used in the triangulation. 

Normally the margin is set to 0 (e.g. for bitmaps converted from CAD drawings). 
For bitmaps from scanned images, with some scan noise, apply a small margin ≤ 1. 

C.2.3. Iterations 

Iteration cycles 
An iteration cycle is part of a system calculation (cf. section C.3), and involves building and solving 
a linear system of equations. A non-linear system is solved by stepwise linearisation. Each step 

using new linearised coefficients corresponds to an iteration cycle. This is needed for automatic 

refinement of calculated thermal properties (equivalent thermal conductivities and convective 

heat transfer coefficients) or non-linear infrared radiation. Before each new iteration cycle the 
linearised thermal resistances are recalculated based on the last available solution (i.e. from the 
previous iteration cycle). 
The given number of iteration cycles is only applied for the first time step (i.e. solution of the initial 
steady-state system, cf. section C.4). If the initial temperature differences are rather high, the 

number of iteration cycles should also be high (to get reliable start values of temperature 
dependent thermal properties). For the next time steps there is always only one single iteration 
cycle (independent of the given number of iteration cycles in the Calculation Parameters dialog 
box). 
 
Iteration stopping criteria 
The linear system of each iteration cycle is solved using an iterative method. 

The iteration process is stopped when the maximum number of iterations (given as calculation 
parameter; by default 10000) is reached, or more likely when all three following conditions are 
fulfilled: 

- Temperature difference condition 
For every system node the absolute value of the difference between the temperatures 
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obtained in the current and previous iteration step must be smaller than the parameter 

maximum temperature difference (by default 0.0001°C). 
- Energy heat balance for the total object 

The residual heat flow into or outside the object compared to the total heat flow passing 
through the object must be less than the parameter maximum heat flow divergence for 
total object (by default 0.001 %). 

- Worst energy heat balance for all control volumes 
For all system nodes the residual heat flow into or outside the control volume compared 
to total heat flow passing through the control volume must be less than the parameter 
maximum heat flow divergence for any node (by default 1 %). 

Definition of heat flow divergences: see section C.9. 

C.2.4. Radiation 

(see Chapter H for more on view factor based radiation heat transfer) 

 
Linear radiation 
The linear radiation between two black surfaces is: 
𝑞𝑟 = 𝐹𝑖𝑗 ⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑖 − 𝜃𝑗) 

𝑞𝑟 = radiation heat flux [W/m2] 
𝐹𝑖𝑗  = view factor from surface i to surface j (= fraction of radiation leaving surface i that is 

intercepted by surface j) 
ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 

𝜃𝑖 = temperature of surface i [°C] 
𝜃𝑗 = temperature of surface j [°C] 

The linear radiation between grey surfaces, having an emissivity (as defined in the Colours 

window), is derived from the radiation between the black surfaces by adding supplementary 

resistances between the grey and black surface nodes (cf. section H.2). 
The black radiation heat transfer coefficient is a calculation parameter. The default value is  
5.1 W/(m2.K) (as in EN 673). 

 
Non-linear radiation 
When non-linear radiation is wanted, the coefficient ℎ𝑟𝑏 is locally adjusted in function of the 

surface temperatures, before each new iteration cycle. The surface temperatures are known 
from the previous iteration cycle, or else from the previous existing solution file (when a 
calculation is restarted). For the first iteration cycle when no solution file is present, the calculation 

parameter “black radiation heat transfer coefficient” is used. 
The non-linear radiation model is physically more precise than the linear model (cf. section H.2). 
 
Calculation of view factors 
The view factors calculation between elementary surfaces is affected by the parameter 

Maximum number of view factor faces (per view factor zone): radiative triangle sides are 
clustered into larger view factors if the number of triangle sides in a view factor zone exceeds this 
parameter. In general, the view factor triangulation may be less fine than the system 

triangulation without loss of accuracy. The default value is 500. 

C.2.5. Automatic calculation of thermal properties 

(See section C.1 for an overview of all automatically calculated thermal properties) 
- Recalculate before each iteration cycle: the automatically calculated thermal properties 

(equivalent thermal conductivities and convective heat transfer coefficients) are 

recalculated before each iteration cycle (see C.2.3). 
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- Use solution temperatures: the automatically calculated thermal properties are updated 

using the last available solution temperatures. If this option is unchecked, default 
temperature values (mean temperature inside cavity/layer of 10°C, and fixed temperature 
difference as imposed by the relevant standard (see C.1.1, C.1.3 and C.1.5) or as defined by 
the calculation parameter Default temperature difference for hc calculation (subtype 

CONVEC) for colours not according to a standard (no value in ‘Standard’ column, see 
B.10). 

- Bitmap border is axis of symmetry: the bitmap border acts as adiabatic boundary 
condition (without absorption and only diffuse reflection, which affects the radiative heat 
transfer via the view factors for cavities adjacent to the bitmap border). 

 

During the input (i.e. editing in the Bitmap window, Measures window or Colours window) the 

automatically calculated thermal properties λeq en hc always assume default temperature values 

(mean temperature of 10°C, and fixed temperature difference as imposed by the relevant 
standard (see C.1.1, C.1.3 and C.1.5) or as defined by the calculation parameter “Default 

temperature difference for hc calculation (subtype CONVEC)” for colours not according to a 
standard (no value in ‘Standard’ column, see B.10). 
 
Contrary to BISCO, the user-defined geometric heat flow direction (X or Y, see B.10) is never 
updated according to the calculated mean temperature gradient in BISTRA. 

The geometrical heat flow direction “DIR” follows the local temperature gradient and requires 
that both calculation parameter options “Recalculate before each iteration cycle” and “Use 
solution temperatures” are checked. 

 

The updated automatically calculated thermal properties (eq, hc) at every iteration cycle (based 

on the last available solution temperatures) are not refreshed in the Colours window (as opposed 

to BISCO). The changed values can only be viewed in a report output (cf. sections B.20 and E.4). 

C.3. System calculation 

After the input of data is finished, a calculation can be started with the command Calc → Calc 

System. First the automatic triangulation and calculation of view factors (if required) are executed 
(as in BISCO), then the dynamic system calculation is started. During the system calculation a 

monitor is shown containing the current time step, the iteration parameters (as in BISCO) for the 
current time step, the number of system nodes, triangles and view factors. 

 

  
 
If a start-up calculation is requested, first the start-up time steps are shown (from time 
0000:00:00:00 up to the total start-up duration). Neither reporting nor solution saving is done 
during the start-up duration. After finishing the start-up calculation, the normal calculation 
duration begins. The time steps of the normal calculation duration are shown again starting from 
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time 0000:00:00:00. During the normal calculation, reporting and solution saving are possible. 

 
At the end of the calculation a report file is written, when at least 1 report item is defined in the 

Report Definition window (cf. sections B.20 and B.21). The content is the same as in the Report 

output (cf. section E.4). The report file has the same file name as the data file, and has the 
extension .txt. 
 
A calculation can be interrupted at any time by pressing the <Esc> key. If the “Save step solutions 

to disk” option is enabled in the Save Frequency dialog box (cf. section B.22), the solution files up 

to the last calculated time step can be viewed in the Graphics Output window and Text Output 

window. If a report definition is given (cf. section B.20), the report records up to the last calculated 

time step can be viewed in the Text Output window. 

 
If a calculation is restarted after it has been interrupted, the calculation restarts from the very 
beginning without reuse of the already calculated time step solutions. 

It is possible to start from a predefined solution file StartBistra.sol (cf. next section), to get an initial 
temperature distribution. 

C.4. Calculation principles 

For the first time step (of the start-up calculation duration if requested, else of the normal 
calculation duration) a steady-state system (as in BISCO) based on the boundary condition 

function values evaluated at the initial time is set up and solved. Multiple iteration cycles (as 
defined as calculation parameter) are used to get good initial temperature dependent 
properties. If the initial temperature differences of the steady-state system are high, the number 

of iteration cycles should also be high (so that the temperature dependent thermal properties 
converge to stable values). 
 

If a start solution (defined as .sol file) should be adopted at the first time step (of the start-up 
calculation duration if requested, else of the normal calculation duration), this solution should be 

renamed to the fixed file name StartBistra.sol in the directory of the .bst input data file. 
The start solution is only used if this solution is compatible with the current triangulation (i.e. same 
number of nodes, same number of triangles, same number of boundary condition edges). 

Delete the file StartBistra.sol after the calculation, otherwise it will be reused as start solution (if 
compatible with the triangulation) in all following calculations. 
 

For the next time steps the boundary condition function values are updated and the material 
volume capacity is taken into account. The Cranck-Nicolson finite difference method is used to 
formulate the energy balance for all control volumes around material nodes. For all other nodes 
without capacity (e.g. black surface nodes, radiation and convection nodes of a boundary 
condition) the energy balance at the current time step is formulated. 
Only 1 iteration cycle per next time step is considered, even if the calculation parameter “number 
of iteration cycles” has a higher value. This supposes fluent boundary condition changes (no 

abrupt discontinuities) during the calculation period. 

 
When the thermal conductivity and/or specific heat of some materials are defined as 
temperature dependent functions, those properties are adapted before each new iteration cycle 
(of the steady-state system for the first time step) and each next iteration step based on the 
obtained temperatures in the previous iteration cycle or previous time step. 
 

Automatically calculated thermal properties are recalculated (if required by the corresponding 
setting in the Calculation Parameters dialog box, see C.2.5) before each iteration cycle or time 
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step, and can be reported in the output report (see variables of type λeq and hc in the report 

definition; cf. section B.20), but the initial values in the Colours window are not updated (as 

opposed to what happens in BISCO, where the recalculated values are refreshed in the Colours 

window). 

C.5. Automatic triangulation 

Before starting the triangulation, the BISTRA data are saved to a BST file. 

The result of the triangulation is written to a TRI file in the same directory of the BST file. 
The resolution of the coordinates of the triangulation vertices is 16 times finer than the pixel 
resolution of the bitmap. 
When a TRI file with the same file name as the BST file name already exists, the user is asked to 
keep this TRI file (and skip the triangulation, which is valid when the geometry is not modified) or 
to redo the triangulation (and overwrite the existing TRI file). 
 
The following parameters are used for the triangulation: 

- The contour approximation margin (calculation parameter). 

- The triangulation mesh sizes (per material colour, defined in the Measures window). 
The triangulation consists of the following steps: 

- Contouring. 
- Straightening contours. 
- Calculation of inner nodes. 

- Creation of the triangulation mesh. 

C.5.1. Contouring 

Contouring is the process of finding the borderlines between the colour zones in the bitmap, and 
connecting them into polygons. Only the contours of the colours assigned to materials (type 
MATERIAL, EQUIMAT and TRANSMAT) are created. 
Step lines in the bitmap are converted into slanting lines. The contouring is done in a reversible 
way, so that rasterising the contours would yield the original bitmap. 

C.5.2. Straightening contours 

The purpose of straightening is to reduce the number of contour edges by skipping redundant 
vertices, so that the new contours lay within the contour approximation margin  (defined as 
calculation parameter; cf. section C.2.2) with respect to the original contours. 

 
Sometimes straightening can cause problems, when self-intersecting contour edges are created. 
That is why the contour approximation margin  should not be chosen too large. 
For bitmaps derived from CAD drawings, straightening normally should not be applied ( = 0). 
For bitmaps of scanned images, where scan noise may be present, apply a small margin:  ≤ 1. 
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C.5.3. Calculation of inner nodes 

Inner nodes are positioned within each material upon a hexagonal grid (in order to obtain 
equilateral triangles). 
Each contour line longer than the triangulation mesh size (for the two colours at both sides of the 
contour line) is split into shorter segments by inserting new nodes on the contour line. 

C.5.4. Creation of the triangulation mesh 

The contour nodes and inner nodes are used to form triangles so that the smallest triangle angle 
occurring is maximal. This principle (Delaunay triangulation) assures the best possible 
triangulation mesh for finite element analysis. A good triangulation mesh allows to generate a 
well-conditioned system, which guarantees a fast and stable solution. 

 

C.6. Unlinking air temperatures in cavities of type BC_FRE_S or BC_FREE 

A cavity or layer (filled with air or any other fluid) can be modelled using several (adjacent) blocks 
having different colours. These colours can have different thermal properties (e.g. surface heat 
transfer coefficient), but must have the same type (i.e. all BC_FRE_S or all BC_FREE). Otherwise 
the calculation is immediately stopped, with the error message “BC (colour …) touches other BC of 

different type”. 
 
The default implementation is to assume that all these adjacent colours making up the cavity or 

layer are linked. 
- If the cavity is modelled with colours all of type BC_FRE_S, then this means that all colours 

get the same (unknown) environmental temperature, which is calculated solving the 
system. Possible convective heat powers for the individual colours in the same air cavity 

(column Pc in the Colours window) are cumulated and allocated to the central convection 

node (having the single environmental temperature). 
- If the cavity is modelled with colours all of type BC_FREE (only possible with the RADCON 

module), then the radiative heat transfer is calculated taking together all these colours 
forming one zone in which all view factors are calculated. The convective heat transfer is 
calculated with reference to one central convection node (having an unknown air 
temperature). 
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This default behaviour can be changed. An air cavity can contain more than 1 convection node by 

using several colours in that cavity and unlinking those colours. For each unlinked colour and for 
the remaining block of not unlinked colours in the same air cavity a separate convection 
temperature will be calculated using separate convective heat balances (based on the surface 
temperatures and convective heat transfer coefficients of the adjacent material surfaces, and on 

the injected convective heat power). The radiative heat balance (in case of BC_FREE cavity) 
remains unchanged, i.e. considering the global air cavity in which all view factors are 
determined. 
 
A colour can be manually unlinked by adding per colour (that you want to unlink) a text line at the 
end of the BISTRA data file (with extension .bst) using a text editor (e.g. Windows Notepad). The 

syntax of this line is: 
 
unlk=c 

 
where c = colour number (0..255) for unlinked colour. 
 
When considering ventilation flows through different air zones (cf. section B.19 and C.7), the air 
temperatures of these zones are automatically made unlinked. 

C.7. Processing ventilation flows 

When ventilation flows are present in the input data, the system matrix is not symmetrical 

anymore, and therefore each iteration cycle is split in two successive subtasks: 
- First the solution of a small subsystem of only convection nodes into which ventilation 

flows are injected. The number of these ventilation nodes is always less than or equal to 
the number of colours of type BC_FRE_S or BC_FREE (so  256). The surface 
temperatures that affect the convection nodes are considered as fixed boundary 
condition values (as obtained by the solution of the second subtask). 
The ventilation subsystem has an unsymmetrical system matrix, but has a limited number 
of unknowns (i.e. the temperatures of the ventilation nodes, always  256), and is solved 
using a direct solution method. 

- Secondly the solution of the ventilation replaced system, i.e. the whole system in which the 
calculated temperatures of the ventilation nodes are considered as fixed boundary 

conditions. This system has a symmetrical system matrix, and can be solved using an 
optimised iterative method. 
The calculated surface temperatures adjacent to ventilation zones are taken as fixed 
boundary condition values in the next ventilation subsystem to solve. 

 
In the very first iteration cycle (i.e. of the first time step) no initial values of the surface 
temperatures are known (as required by the first subtask). The complete system is then solved 
without any ventilation flows to get start values for the surface temperatures for the first subtask 
of the next iteration cycle. 

 
When ventilation flows are present, a variable number of iteration cycles is executed per iteration 
step independent of the given maximum number of iteration cycles as defined in the Calculation 
Parameters dialog box. The number of iteration cycles per iteration step is automatically stopped 
when all temperature differences between the calculated temperatures in the ventilation nodes 
of the current and previous iteration cycle are smaller than the given maximum temperature 
difference in the Calculation Parameters dialog box (a typical value is 0.0001°C, see C.2.3). 

However it may be possible (dependent on the input data) that there will be no convergence. In 
this case the iteration cycles are also stopped when any temperature difference of a ventilation 
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node between the current and previous iteration cycle is greater than 1000000°C. The program 

resets all node temperatures of the whole system to 0°C, and the user is prompted to inspect and 
alter the input data. 

C.8. Solar radiation processing 

The solar processor is activated when: 

1. A solar zone is present: i.e. a colour of type BC_SIMPL or BC_SKY with sun flag set (defined in 

Colours window, column “Sun”, toggle value set to YES). 

2. Solar radiation data are present: both a function G01 and a function D01 must be defined in 

the Functions window (B.12) in case of a real sun path (B.15.1); and a function I01 must be 

defined in the Functions window (B.12) in case of a fixed sun position with variable radiation 

(see B.15.2). 

G01 refers to a function for the global solar radiation (in W/m2) on a horizontal surface. 
D01 refers to a function for the diffuse solar radiation (in W/m2) on a horizontal surface. 
I01 refers to a function for the total solar radiation (in W/m²) in a user-defined direction. 

 
Input parameters with respect to the solar processor: 

- The solar data as defined in the Solar Data dialog box (see B.15) 
- Per material: solar reflection factor, specular part of the direct solar radiation 

reflection, and solar transmission factor (see C.8.1).  

These material properties are defined in the last three columns of the Colours 

window (see B.10). 
A solar reflection factor function is referenced by R##, with ## = 01 to 99, and 

refers to the Functions window (see B.12.2). 

- Calculation start day and time (Edit → Calc Parameters…, cf. section C.2.1). A 
calculation may be preceded by a pre-calculation period (to get dynamic start 
values of the node temperatures). 

- Sun obstacles: shadow zones of other objects around the input bitmap, defined by 
spherical angular coordinates in the horizontal coordinate system (Edit → Sun 
Obstacles, cf. section B.16). 

 
At every time step the solar load, calculated in 3D, on the 2D object model is calculated (see C.8.2 

for external surfaces, C.8.5 for internal surfaces, and C.8.6 for opaque surfaces behind 
transparent materials). The solar load is expressed as a calculated node power (in W/m) per 
system node. These node powers are used as supplementary boundary conditions of the thermal 
system besides the other boundary conditions (e.g. the external temperature). 

C.8.1. Definition of solar properties ρs and τs for MATERIAL 

For each colour of type MATERIAL, the solar reflection factor (𝜌𝑠) and the solar transmission 

factor (𝑠) need to be defined in the Colours window (see B.10). 

 
For incident direct solar radiation the actual value of 𝜌𝑠 may be dependent on the angle of 
incidence, if defined by a solar reflection factor function referenced by R## (see B.12.2). 
 
There are two important calculation aspects to consider when quantifying these solar properties 
as inputs for a colour of type MATERIAL: 

1. The solar reflection factor (𝜌𝑠) and solar transmission factor (𝑠) are applied at the contact 

of a surface with a zone. 
A zone in this context is either a solar zone (BC_SIMPL or BC_SKY) or an internal zone 
with detailed radiation calculation (BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT). 
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If a colour of type MATERIAL in contact to the source zone from which the radiation enters 

has a solar transmission factor 𝑠 equal to 0, it is an opaque material (see C.8.5). 

 
A transparent construction element in BISTRA consists of a single colour of type MATERIAL 

with 𝑠 > 0 or a system of adjacent transparent colour layers of type MATERIAL with 𝑠 > 

0 or of type EQUIMAT (always assumed 𝑠 = 1).  

 
Within a system of adjacent transparent colour layers from a zone up to the next zone, 

only 𝜌𝑠 and 𝑠 at the outer surface of the first colour layer (in contact to the source zone 

from which the radiation enters) are considered. 𝑠 can thus be understood as a property 

of the entire system of adjacent material layers and not just the material layer in contact 

to the source zone, it is good practice to give all adjacent enclosed material layers the 

same 𝑠 value in the Colours window. 

 

 
 
A system of adjacent transparent material layers can alternatively be placed between a 

source zone from which the radiation enters and an opaque material (𝑠 = 0). This is 

discussed in C.8.6. 
 

2. The solar transmission factor 𝑠 in BISTRA is applied after subtraction of the solar 

reflection (which can be dependent on the angle of incidence of solar radiation). 

 
Typically, the solar reflection, transmission and absorption are defined relative to the total 
incoming radiation, so 
𝜌 +  𝜏 +  𝛼 = 1 
Or for normal incidence (angle of incidence 0°): 
𝜌0 + 𝜏0 +  𝛼0 = 1 

 

However, for the input value of 𝜏𝑠 in BISTRA, after subtraction of reflection 𝜌𝑠, applies: 
𝜏𝑠 +  𝛼𝑠 = 1. 

 
The input value of 𝜏𝑠 in BISTRA can be calculated from the typical solar properties at 
normal incidence (angle of incidence 0°) 𝜌0 and 𝜏0: 

𝜏0 = (1 − 𝜌0) ∙ 𝜏𝑠    or    𝜏𝑠 =
𝜏0

1−𝜌0
 

C.8.2. Irradiance: solar load to external surfaces 

An external surface is a surface of an object (with colour type MATERIAL) in direct contact with a 

solar zone (colour type BC_SIMPL or BC_SKY, and sun flag set in column “Sun” in the Colours 

window). 

 

Colour 1 Colour 2 Colour 3
Zone 1 Zone 2

of entire construction element = 

of entire construction element = 
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The position of the sun is calculated at the current simulation time (day of year, clock time) and 

the geographical location (latitude, longitude, time zone) 6. Daylight savings time is not taken into 
account. The position of the sun is located by two angular measures: azimuth (horizontal 
clockwise angle between the sun position and south) and altitude (angle between the sun position 
and the horizon). The azimuth of the sun at a fixed clock time may differ for different days of the 

year due to the irregular movement of the sun (defined by the equation of time): e.g. the azimuth 
at 12 a.m. solar mean time for every day fluctuates around 0° (= south direction). 
 
For the current time step the actual global solar radiation and diffuse solar radiation (in W/m2) on 
a horizontal surface are derived from the corresponding external data files (see B.12.2) or 
weather data files (see B.12.3). Typically these weather data files contain hourly values. 

Values at simulation times are derived through simple linear interpolation in case of an external 
data file with linear function format (see B.12.2). 
 

In case of an external data file with step function format (see B.12.2) or a weather data file (see 
B.12.3), the values in the external data file are converted to instantaneous values at simulation 
times using a mathematical algorithm7. This algorithm takes the empirically calculated times of 
sunrise and sunset into account and produces instantaneous solar radiation values for any 
defined time step. The resulting solar radiation profiles ensure that the total solar radiation 
received matches the information in the data file, and have ‘realistic’ (though obviously 

estimated) shapes without discontinuities. 

 
All produced instantaneous solar radiation values at simulation times are used in BISTRA as 
average values over the simulation time step, where the simulation time is understood as the 
middle of the simulation time step (since the solar angles are calculated at each simulation time). 
 
For each external surface the angular position against the north direction is computed: 
orientation (compass direction) and tilt (height above horizon). From the global and diffuse solar 
radiation on a horizontal surface, the direct and diffuse solar irradiance on the area around each 
node of the external surface is calculated. 

 
The direct solar irradiance is derived from the direct solar radiation on a horizontal surface and 

the position of the sun. If the sun is not hidden by any sun obstacle (as defined in the Sun 

Obstacles window), a test ray from the surface node towards the sun is inspected on possible 
intersections with other (non-transparent) object surfaces (present in the bitmap). When there are 

 
6 Roy G. et al., A note on solar declination and the equation of time, Architectural Science Review, Vol. 32, p. 

43-51 (1989) 
7 McDowell T. et al., A new method for determining sub-hourly solar radiation from hourly data, 

Proceedings of the 2018 Building Performance Analysis Conference and Simbuild, p. 518-252 (2018) 

0

5

10

15

20

25

30

6 7 8 9 10 11 12 13 14 15 16 17 18

To
ta

l s
o

la
r 

ra
d

ia
ti

o
n

 [
W

/m
²]

Time of the day [h]

January 1st (Berlin Tempelhof) 

Hourly data (EPW)

Calculated instantaneous data (10 min time step)



54 Manual BISTRA v5.0 

no intersections, the node is sunlit. Otherwise the node is shaded and the direct solar irradiance 

on the area around the node is cancelled. 
 
The estimation of the diffuse solar irradiance on the area around the node of the external surface 
is more complex. 

- First the sky visibility from the elementary area around the node is used as 
reduction factor of the diffuse radiation. The sky visibility is calculated using 100 
test rays from the node with random direction on the hemisphere above horizon. 
For all directions at the front side of the surface, the sky visibility is estimated as the 
fraction of the test rays not shaded by any sun obstacle or other (non-transparent) 
object in the bitmap. This is a good estimation of the view factor to the open sky 

from the elementary area around the node. 
- Secondly the diffuse radiation depends on the tilt of the surface. 

 In an isotropic diffuse model the diffuse radiation on a sloped surface is 

 proportional to the square of the cosine of half the tilt angle. E.g. the diffuse 
 radiation on a vertical surface is half the diffuse radiation on a horizontal surface 
 (i.e. the surface only sees half of the sky dome). 
 BISTRA uses the more correct anisotropic diffuse model developed by Muneer8, 
 which also distinguishes between shaded and sunlit surfaces and between 
 overcast and non-overcast conditions of the sunlit surfaces. The required 

 parameters can be derived from sun position, slope, orientation, day of year, sunlit 
 status, sky visibility, global and diffuse solar radiation data on a horizontal surface. 

- Finally radiation reflected from the ground in front of the surface, must be added. 

This radiation is assumed isotropic, and is a function of the global solar radiation 
on a horizontal surface, the tilt of the surface, and the ground reflection factor, 
which is an input parameter in the Solar Data dialog box (normal value = 0.2). The 

ground reflected radiation on a vertical surface is half the ground reflected 
radiation on a horizontal downward surface. 

 

If the solar zone is of type BC_SIMPL, then the reflected (direct or diffuse) solar radiation from an 
external surface is further ignored. If the solar zone is of type BC_SKY, this reflected solar 
radiation is further processed (see C.8.4). 

C.8.3. Absorption of solar radiation 

For an opaque external surface (with solar transmission factor equal to 0, see C.8.1), the radiation 
that is not reflected is absorbed. The absorbed solar radiation is converted to node powers in the 
surface nodes. 
For a transparent external surface (with solar transmission factor greater than 0, see C.8.1), some 

part of the solar radiation is transmitted to internal zones (see C.8.5) or to an opaque surface 
behind the transparent construction (see C.8.6). The remainder of the solar radiation is absorbed. 
The absorbed solar radiation is equally distributed as additional node powers over all nodes 
(limited to 10000) nearest to the normal of the external surface up to the opposite contact surface 
with an internal zone or opaque surface. The triangulation size should thus not be too small, 

because transmitted solar radiation can only pass through a limited number of 10000 of adjacent 

material triangles from surface to surface. Note also that if the transparent construction element 
consists of a number of adjacent transparent colour layers (see C.8.1), a different triangulation 

mesh size of the colour layers (as defined in the Measures window, see B.9) will result in unevenly 

distributed absorbed solar radiation over the thickness of the transparent construction element, 
as each node receives the same amount. 

 
8 Muneer T., Algorithms for estimating hourly solar irradiation on slopes, Building Serv. Eng. Res. Technol. 

10(2), p. 81-83 (1989) 
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The report outputs Qsol and qsol or absorbed solar heat flow and flux (see B.20) are always 

given for the colour for which the relevant solar property 𝑠 is defined (see C.8.1). In case of a 

transparent construction element consisting of a number of adjacent transparent colour layers, 
only the colours in contact to the source zone from which the radiation enters thus will have non-
zero Qsol and qsol outputs, even though the absorbed radiation is distributed over the entire 
thickness of the transparent construction element consisting of a number of adjacent transparent 
colour layers for the thermal solution. 

C.8.4. Processing of reflection 

Reflection is only processed in zones with detailed radiation calculation (BC_FREE, BC_SKY, 

BC_NOSKY or TRANSMAT), so not in solar zones of type BC_SIMPL. 
 

For direct radiation, if the reflection factor 𝜌𝑠 of the surface is angle dependent (cf. definition of 

the material colour in the Colours window, see B.10), then this factor is determined through 
interpolation between the values in the solar reflection function file for the actual angle of 

incidence (angle between direct solar radiation and surface normal). 
The reflection factor for diffuse radiation is the weighted mean value of the reflection factors for 
all possible angles of incidence. 

 
If the specular part of the direct solar radiation reflection of the surface is greater than 0% (cf. 

definition of the material colour in the Colours window, see B.10), then this specular reflection of a 

direct solar radiation ray that hits the object surface is propagated following the mirroring 
direction (with angle of reflection equal to angle of incidence, and in the same plane of incident 
ray and object surface normal) up to the next object material surface, where the same process is 
repeated. If the specular reflection ray hits no object, this radiation is lost. Once a reflected direct 
solar radiation ray is smaller than 0.001 W, it is further ignored (as a stop criterium of the ray 
tracing method). Alternatively, after a maximum of 1000 tracing iterations of a ray, the ray tracing 
is stopped. 

 
Diffusely reflected radiation originates from either incoming diffuse radiation or incoming direct 
radiation if the specular part of the direct solar radiation reflection of the surface is smaller than 

100% (cf. definition of the material colour in the Colours window, see B.10). This reflected radiation 
is ideal diffuse (following Lambert’s cosine law) and is again reflected, transmitted and absorbed. 
The final contributions of additional absorption on all surfaces are calculated using the radiosity 

method. 
The radiosity of each elementary surface equals the amount of energy that is given off. The 
energy incident on the surface (which we consider as unknown of the system) equals the sum of 
all reflected and transmitted energy from other surfaces, multiplied by the view factors from 

those surfaces to the first surface. The reflected energy from another surface equals the energy 
incident on that surface (which is an unknown of the system) multiplied by the (diffuse) reflection 
factor plus the known reflected energy (at the initial state of the radiosity system). The transmitted 
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energy equals the energy incident on the opposite side of that wall (which is an unknown of the 

system) multiplied by the transmission factor at that side. The transmission factor must first be 
corrected for the reflection at that side (because the transmission factor in BISTRA is defined after 
deduction of reflection, see C.8.1). Finally this leads to a set of linear equations.  
The radiosity method implies that every time step a supplementary linear system of equations 

must be formulated and solved. This system is global for all zones (based on view factors), 
because these zones may be linked with one another via transparent walls. 

C.8.5. Transmission to internal zone: solar load to internal surfaces 

If the transmitted solar radiation reaches a boundary condition of type BC_FREE, BC_SKY, 
BC_NOSKY or TRANSMAT, then the corresponding zone is called an internal zone, through which 

the solar radiation is further propagated9. The material surfaces bordering an internal zone are 
internal surfaces. A zone of type BC_FREE has view factor based radiation and convection with a 
balanced unknown air temperature. This type is normally used for rooms or larger air cavities. 
A zone of type TRANSMAT has view factor based radiation and conduction using a given thermal 
conductivity (of still air or another gas). This type is normally used for smaller cavities, e.g. the 
cavity of a double glazing. 
 
The transmitted direct solar radiation in a node of an internal surface is projected along the 

direction of direct sun light (without refraction) upon the closest internal surface (of the same 
internal zone opposite to the emitter internal surface), forming the solar spot. When the projected 
power would cause a flux (i.e. power divided by area) that is greater than the solar radiation on 

an external surface with the same orientation, then this power excess is spread over adjacent 
boundary edges. 
Part of the incident direct solar radiation on an internal surface is reflected, using the reflection 
factor of the surface material colour (see C.8.1). This reflection factor may be dependent on the 
angle of incidence (when the reflection factor is defined by a reflection factor function). The 
reflected radiation is treated as described in section C.8.4. 
The remainder of the incident direct solar radiation on the internal surface is transmitted and 
absorbed. The transmitted and absorbed direct radiation are treated in the same way as 
transmitted and absorbed direct solar radiation on an external surface (cf. section C.8.2 and 
C.8.3). 
 
The transmitted diffuse solar radiation is projected upon the other boundary edges (of the same 
internal zone) proportional to the view factors from the emitter surface to the receiver surfaces. 
Part of the incident diffuse solar radiation on an internal surface is reflected, using the reflection 
factor for diffuse radiation. The reflected diffuse radiation is treated as described in section C.8.4. 
The remainder of the incident diffuse solar radiation on an internal surface is transmitted and 

absorbed analogously to transmitted and absorbed diffuse solar radiation on an external surface 
(cf. section C.8.2 and C.8.3). 

C.8.6. Solar load to opaque surfaces behind transparent materials 

In previous versions of BISTRA (BISTRA v4 and before), in case a transparent construction element 

was placed in front of an opaque colour (𝑠 = 0), the radiation transmitted through the 
transparent construction element was ignored. If the user wanted to account for absorption and 
reflection of radiation by the opaque surface behind a transparent construction element, a very 
thin layer representing a virtual zone needed to be drawn manually between the transparent 

 
9 Note that if the colour behind the transparent construction is of type BC_SIMPL, the transmitted solar 

radiation cannot be accounted for because BC_SIMPL is not a view factor zone. The amount of solar 

radiation that would be transmitted is thus disregarded in the thermal calculation. 
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construction element and the opaque surface. From BISTRA v5, this manual work-around is no 

longer necessary, as it is integrated in the calculation. 
 
An infinitely thin gap (0 pixels thickness) is assumed in the calculation between a transparent 
construction element and an opaque material surface, with view factor between both opposite 

surfaces (which is the contact surface) equal to 1. 
These infinitely thin gaps are treated as additional view factor zones (1 zone for each contact line 
in the triangulation of object nodes), thus similar to internal zones, as described in section C.8.5. 
The direct and diffuse transmitted solar radiation that hits an opaque material behind a 
transparent material is added to the radiosity system for redistribution of diffuse radiation, based 
on diffuse reflection, absorption and transmission coefficients of the two opposite surfaces. The 

direct transmitted solar radiation is thus considered as additional diffuse transmitted solar 
radiation, so that it can be included in the radiosity system. 
The absorbed radiation at the opaque material surface, resulting from the solution of the 

radiosity system, is then converted to system node powers on the opaque material surface. 

C.9. Heat flow divergences 

The quality of the solution is mainly determined by the heat flow divergence of the total object, 
called in short object divergence. It is defined as the sum of all heat flows (positive and negative) 
entering the object, divided by half the sum of the absolute values of all these heat flows: 

𝑂𝐷 =
|𝛷𝑖𝑛,𝑜 − 𝛷𝑜𝑢𝑡,𝑜|

0.5 ⋅ (|𝛷𝑖𝑛,𝑜| + |𝛷𝑜𝑢𝑡,𝑜|)
⋅ 100 

with 𝑂𝐷  = object divergence [%] 
𝛷𝑖𝑛,𝑜 = total incoming heat flow for the object [W] 

𝛷𝑜𝑢𝑡,𝑜 = total outgoing heat flow for the object [W] 

 

By using the factor 0.5 in the denominator, the denominator can be interpreted as the heat flow 
"passing" the object. 
The maximum possible object divergence is 200 %, i.e. when there are only incoming heat flows 

and no outgoing heat flows: 𝛷𝑖𝑛,𝑜 > 0 and 𝛷𝑜𝑢𝑡,𝑜 = 0 (or vice versa 𝛷𝑖𝑛,𝑜 = 0 and 𝛷𝑜𝑢𝑡,𝑜 > 0). 

An object divergence tolerance (cf. calculation parameter “Maximum heat flow divergence for 

total object”, see C.2.3) of 0.001 % is recommended as reliable stopping criterion. According to EN 

ISO 10211 the object divergence should be less than 0.1 %. 
 
In BISTRA also a second heat flow divergence is used as stopping criterion: the maximum heat 

flow divergence for all nodes, called in short node divergence. It is defined in a similar way as the 
object divergence: 

𝑁𝐷 = 𝑚𝑎𝑥𝑛(
|𝛷𝑖𝑛,𝑛 − 𝛷𝑜𝑢𝑡,𝑛|

0.5 ⋅ (|𝛷𝑖𝑛,𝑛| + |𝛷𝑜𝑢𝑡,𝑛|)
⋅ 100) 

with 𝑁𝐷  = node divergence [%] 
𝛷𝑖𝑛,𝑛 = total incoming heat flow for the control volume around node n [W] 

𝛷𝑜𝑢𝑡,𝑛 = total outgoing heat flow for the control volume around node n [W] 

 
In BISTRA the default node divergence tolerance is 1 % (cf. calculation parameter “Maximum heat 

flow divergence for any node”). 
Sometimes it happens that the node divergence does not decrease during the calculation. This is 
caused by an “unlucky” node, that is connected to its neighbouring nodes in an “unfavourable” 
way (due to obtuse triangles and/or strongly different thermal conductivities). Then a higher node 

divergence tolerance should be set. 
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Cancel the node divergence test by using a node divergence tolerance of 201 % (which is higher 

than the theoretical 200 %, to be safe for possible numerical rounding errors). 

C.10. Batch calculation 

The user can launch a batch calculation for several data files (with extension .bst) in the same 
folder. The calculations are executed one after the other without any intervention of the user. 
To start a batch calculation call the command File → Batch Calculation…, select the data files in 

the Batch Calculation dialog box (hold down the <Ctrl> key to select more than one file) and 
press the Start button. It is not possible to select several data files located in different directories. 
 

Per data file a report file is written to disk, containing the output report corresponding to the 

report definition of the data file (cf. sections B.20 and B.21). The report file has the same file name 
as the data file, and has the extension .txt. 

When graphic output (i.e. snapshots at given time points and/or animation files of given time 
periods) is wanted afterwards, the data file should specify that step solutions must be saved to 
disk (cf. section B.22). 

C.11. Command line program execution 

BISTRA can be run from another application with a data file path (including directory and file 
extension .bst) as parameter. 

Then no further user action is required. The program starts and ends automatically, and the 

output is a report file and/or a series of graphic snapshots (as in a batch calculation, cf. section 
C.9). 
The switch “/Automation” is required to activate the batch calculation. 

 
Example of command line launch: 
 

Run → “c:\...\Physibel\BISTRA5\BISTRA.exe” “..\Documents\Physibel\BISTRA5\Demofiles\1 – 
SUMMER – THERMAL STRESS\flat_roof_solar.bst” /Automation 
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CHAPTER D GRAPHIC OUTPUT 

D.1. Graphic Output window 

The Graphic Output window (which covers the complete BISTRA application window) is opened 

with the command Output → Graphic Output. 

To return to the main BISTRA window, choose the command File → Exit. 

 

  

D.2. Animate functions 

The animate functions are available through the Animate submenu. 

 

   
 
The next functions are only available when solution files (*.sol) of a calculation are present on disk 

(see section B.22): 
First Time Step Loads the first solution file (for the start of the calculation duration, after 

the precalculation duration). 

Next Time Step Loads the next solution file. 
Previous Time Step Loads the previous solution file. 
Go To… Loads the solution file of a time step (of the calculation duration) 

entered by the user. 
Play Shows successively all solution files starting from the current time step. 

The playing can be stopped by pressing the <Esc> key. 
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D.3. Save animation images 

Menu command: File → Save Animation Images… 

A sequence of all animation images (as a result of the command Animate → Play) can be saved 

on disk as separate .png files. 
 
A Save As dialog box is opened to prompt for a file name. 
The image size of saved bitmap and font size of legend text are defined via Settings → Image 

Size…. 
 
The solution files are loaded consecutively (started with the first solution at time 0000:00:00:00), 

shown in the Graphics Output window and saved. A 4 digit number (starting from 0000) is 

appended to the chosen file name to generate the different PNG files. 
Saving animation images can be interrupted by pressing the <Esc> key. 

D.4. Zoom commands 

 
 

Compared to the main input menu (see B.8), 2 additional zoom commands are available (Zoom 

→  Rotate and Zoom → Perspective Numbers…). These are only available when viewing the sun 
position (see D.7). 

D.5. View submenu 

 
 

- View → Object Lines: show contours of material colours. 
- View → Triangulation Mesh: show triangles of triangulation. 

- View → Isothermal Lines: show isothermal lines conform to the temperature range 

parameters (Settings → Temperature Range…). 
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 Only possible when a calculation solution is available. 

 
- View → Fill Bitmap: show original bitmap. 

If View → Legend is selected, labels with colour numbers are added. 
- View → Fill Materials: fill object materials using the bitmap colours. 

- View → Fill Boundary Conditions: fill boundary conditions using the bitmap colours. 
- View → Fill Temperatures: fill object with temperature colours conform to the temperature 

range parameters (Settings → Temperature Range…). 
Only possible when a calculation solution is available. 

- View → Fill Absorbed Solar Fluxes: show absorbed solar fluxes of MATERIAL type colours 
at contact surface with solar zone or internal zone with detailed radiation calculation (so 

absorbed solar flux at opaque surfaces behind transparent materials, see C.8.6, is not 
shown). 

- View → Fill Off: switch off filling. 

 
- View → Sun Position: see D.7 
- View → Sun Obstacles: toggle for showing the sun obstacles (see B.16) in grey in the sun 

position view. 

 
- View → Legend: show a legend bar at the right side of the figure (exception: show colour 

labels for View → Fill Bitmap). 

 
Remark 
For temperature dependent thermal conductivities the values that are shown in the legend (when 
the view option View → Fill Materials is chosen), are all taken at 10°C. 

D.6. Settings 

 
 

Settings → Temperature Range… 
- Minimum temperature [°C] in graphic output. 
- Maximum temperature [°C] in graphic output. 

- First (or minor) increment [°C].  
Used for temperature filling (View → Fill Temperatures) and isothermal lines  
(View → Isothermal Lines). 

- Second (or major) increment [°C] (must be a multiple of first increment).  
Only used with isothermal lines (View → Isothermal Lines). 

- Single temperature value [°C] (e.g. dew point).  
Only used with isothermal lines (View → Isothermal Lines). 
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Settings → Flux Range…  
 

 
 
Settings → Line Styles…  
A colour field can be edited by double clicking with the left mouse button, which opens a Colour 
dialog box in which the colour value (RGB components) can be defined. 

 
The width of isothermal lines can be set to 0 pixels to hide them. This is useful when e.g. only the 

second isothermal lines are desired in the figure. 
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Settings → Fill Colours… 

 

  
 

Colours with automatically calculated properties (see C.1) are clustered thematically in the 

Graphic Output window according to the categories of the Fill Colours dialog box, to avoid a 

potentially long list of colours of the same type (and subtype and standard) with small variations 

in the calculated thermal property. The fill colour of the clusters can be edited by double clicking 
on it with the left mouse button, which opens a Colour dialog box in which the colour can be 
defined. 

 
Settings → Image Size… 
Set bitmap size for saving PNG files (File → Save Image... and File → Save Animation Images…). 
 

   
 
The font size refers to text characters in the legend or labels. 
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D.7. Sun position 

The sun position (azimuth and altitude) in the horizontal coordinate system (in which the plane XY 
coincides with the horizon, the X axis points to the north, the Y axis points to the west, and the Z 
axis points to the zenith) at any time can be viewed with View → Sun Position. 
 

The parameters that define the position of the sun are: 
- North orientation (Edit → Solar Data…). 
- Geographic position (Edit → Solar Data…). 
- Day of year at start of calculation (Edit → Calculation Parameters…). 
- Time setting (Animate → Go To…). 

The start of calculation corresponds with time 0000:00:00:00. 

 

If the toggle View → Sun Obstacles is on, the sun obstacles as defined in the Sun Obstacles 

window (B.16) are shown in grey. 

 

 
 
The 3D image can be rotated with Zoom → Rotate (Rotate mode is activated automatically by 

holding down the mouse wheel). 
The perspective viewpoint (azimuth and altitude from the midpoint of the bitmap to the observer 

in the horizontal coordinate system) is entered with Zoom → Perspective View…. 
All other zoom functions are suppressed while the option View → Sun Position is used. 

 

           
 
Use the function Animate → Play to show the sun position changing with time. 
The time step defined in the Calculation Parameters dialog box (Edit → Calc Parameters…) is 
used as animation time step. 



Manual BISTRA v5.0 65 

CHAPTER E TEXT OUTPUT 

E.1. Text Output window 

The Text Output window (which covers the complete BISTRA application window) is opened with 

the command Output → Text Output. 

To return to the main BISTRA window, press the <Esc> key or choose the command File → Exit. 

 
Views 

Three different contents can be viewed in the Text Output window: 

- An overview of input data (shown with the command View → Input Data, see E.2). 
- The calculation results of a specific time step (shown with the command View → Time Step 

Results, see E.3). This is only available for the time steps for which the solution is saved to 
disk (see B.22). 

- A report for the items defined in the Report Definition window (cf. section B.20) (shown 

with the command View → Report Output, see E.4). 
 
Saving 

- The user can select some part in the Text Output window, and copy it into the clipboard 

(using Edit → Copy). The contents of the clipboard can then be pasted into any other 
program (e.g. Microsoft Word). 

- The text in the current view can also be saved into a DOC file (Microsoft Word document) 
using the command File → Save As…. 

- The command File → Save to CSV Files saves the following data to 3 separate CSV files for 

use in a spreadsheet program (e.g. Microsoft Excel): 

o the bitmap colour sizes (cfr. the data in the Measures window, see B.9); 

o the thermal properties (cfr. the data in the Colours window, see B.10) for the 

specified time step (see E.3) in case of automatically calculated themal properties 
(see C.1); 

o the calculation results in terms of temperatures and heat flows per colour for the 

specified time step (see E.3), if this solution is saved to disk (see B.22). 
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E.2. Input data 

The input data is shown in the Text Output window using the command View → Input Data. 

 
 
BISTRA - Input Data 

 

BISTRA data file: climate_solar_control_BISTRA.bst 

Bitmap file: climate_solar_control_BISTRA.bmp 

1 pixel = 0.01 m 

 

MEASURES 

Col.    Width     Width    Height    Height      Area     Zones  Triang.Size 

     [pixels]       [m]  [pixels]       [m]  [pixels]               [pixels] 

  2       112    1.1200       112    1.1200       144         4        10.00 

 28       100    1.0000         6    0.0600       600         1        10.00 

 29         6    0.0600       100    1.0000       600         1        10.00 

 30       100    1.0000         6    0.0600       600         1        10.00 

 31         6    0.0600       100    1.0000       600         1        10.00 

170       132    1.3200       132    1.3200      4880         1 

174       100    1.0000       100    1.0000     10000         1 

 

FUNCTIONS 

T01: FILE 

  G:\Weatherfiles\datafiles\Berlin_Tempelhof-hour.FTE 

G01: EPW 

  G:\datafiles\Berlin_Tempelhof-hour.epw 

D01: EPW 

  G:\datafiles\Berlin_Tempelhof-hour.epw 

 

THERMAL PROPERTIES 

Col. Type      Subtype   Phys.     Geom.     Name                       eps1 / eps2  lambda   eps 

                         flow      flow                                 [- / -]      [W/mK]   [-] 

2    MATERIAL                                                                         0.000  0.90 

28   MATERIAL                                North                                    1.000  0.90 

29   MATERIAL                                East                                     1.000  0.90 

30   MATERIAL                                South                                    1.000  0.90 

31   TRANSMAT  CAVITY    HOR       DIR       West                                     0.094       

170  BC_SIMPL  NIHIL                         exterior                                             

174  BC_SIMPL  NIHIL                         interior                                             

 

Col.    rho       c       t       h       q      ta      hc        Pc      tr   Sun      rs      ts  Standard 

     [kg/m3] [J/kgK]   [°C] [W/m²K]  [W/m²]    [°C] [W/m²K]     [W/m]    [°C]           [-]     [-]           

2       1.0     1.0                                                                    0.00    0.00           

28      1.0     1.0                                                                    0.00    0.00           

29      1.0     1.0                                                                    0.00    0.00           

30      1.0     1.0                                                                    0.00    0.00           

31      1.0     1.0                                                                                  EN10077  

170                     T01   10.00       0                                     YES                  NIHIL    

174                     0.0   10.00       0                                     NO                   NIHIL    

 

SOLAR DATA 

North orientation 
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1. Rotation angle of XY around Z = 0° 

2. Rotation angle of YZ around X = 0° 

3. Azimuth from X to north = 270° 

Latitude = 50.78° N 

Longitude = 4.37° E 

Time zone = 1 h E 

Horizontal global solar radiation function = G01 

Horizontal diffuse solar radiation function = D01 

Ground reflection factor = 0.20 

 

SUN OBSTACLES 

No.    Min. Azimuth [°]    Max. Azimuth [°]   Min. Altitude [°]   Max. Altitude [°] 

1              -180                 180                   0                   5 

 

CALCULATION PARAMETERS 

Time step = 0000:00:15:00 

Start-up calculation duration = 0000:00:00:00 

Calculation duration = 0001:00:00:00 

Start of calculation = 0000:12:30:00 

Contour approximation margin (triangulation) = 0 pixels 

Iteration cycles = 20 

Nonlinear radiation 

Automatic recalculation of thermal values 

Use default temperatures in recalculation of thermal values 

Default temperature difference across airspace = 10°C 

Bitmap border is no axis of symmetry 

Max. number of view factor faces per zone = 500 

Black radiation heat transfer coeff. (linear radiation) = 5.25 W/m²K 

Maximum number of iterations (per iteration cycle) = 10000 

Maximum temperature difference = 0.0001°C 

Heat flow divergence for total object = 0.001 % 

Heat flow divergence for worst node = 1 % 

E.3. Time step results 

Calculation results for a specific time step are shown using the command View → Time Step 

Results. This is only available for the time steps for which the solution is saved to disk (see B.22). 
The time step can be set using one of the first four commands in the Edit submenu, which are 

analogous as in the Animate submenu in the Graphic Output window (cf. section D.2). 

 

 
 
First Time Step Loads the first solution file (for the start of the calculation duration,  

    after the precalculation duration). 

Next Time Step Loads the next solution file. 
Previous Time Step Loads the previous solution file. 
Go To…  Loads the solution file of a time step (of the calculation duration)   
    entered by the user. 

 
BISTRA Calculation Results 

 

BISTRA data file: wooden_frame.bst 

Number of nodes = 641 

 

Time step 0000:00:00:00 

 

Col. Type      Name                           tmin      tmax        ta   flow in  flow out 

                                              [°C]      [°C]      [°C]     [W/m]     [W/m] 

  8  MATERIAL  aluminium                     18.60     18.67 

 12  MATERIAL  wood                          15.38     22.20 

 13  MATERIAL  glazing stop                  19.66     22.44 

 18  MATERIAL  glass (ext. pane)             15.30     18.60 

 19  MATERIAL  glass (int. pane)             18.76     23.26 

 20  MATERIAL  low-e coating                 18.67     23.23 

 60  MATERIAL  EPDM                          17.35     19.98 

 62  MATERIAL  silicone, pure                18.39     18.96 

170  BC_SKY    exterior                      15.30     18.14                0.00      3.15 

174  BC_SKY    interior                      19.20     23.26                3.15      0.00 

214  TRANSMAT  argon                         15.35     23.21                0.29      0.29 

215  EQUIMAT   air cavity                    18.60     18.67 

216  EQUIMAT   air cavity                    17.45     20.13 
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E.4. Report output 

For the items defined in the Report Definition window (cf. section B.20) a report can be output 

with records at a given frequency of time steps (cf. section B.21). The command View → Report 

Output shows the contents of the report written during the calculation. This report is automatically 
written to both a TXT file and CSV file in the BISTRA data file directory. 
 

In the report, per report time step one line of values is written (no value (‘-‘) is given for logically 
impossible report items). The report values are separated with tab characters in the TXT file. Each 
column in the table corresponds to a report item. The meaning of the columns is explained in the 
header. 
 
BISTRA - Report Output 

 

BISTRA data file: wooden_frame.bst 

 

Column 1: Time [dddd:hh:mm:ss] 

Column 2: Sun azimuth [°] 

Column 3: Sun altitude [°] 

Column 4: Colour 170 (exterior), air temperature [°C] 

Column 5: Colour 18 (glass (ext. pane)), absorbed solar flux [W/m²] 

Column 6: Colour 12 (wood), absorbed solar flux [W/m²] 

Column 7: Colour 18 (glass (ext. pane)), minimum temperature [°C] 

Column 8: Colour 18 (glass (ext. pane)), maximum temperature [°C] 

Column 9: Colour 12 (wood), minimum temperature [°C] 

Column 10: Colour 12 (wood), maximum temperature [°C] 

 

0000:00:00:00     0.00     0.00    14.30     0.00     0.00    15.30    18.60    15.38    22.20 

0000:00:10:00     0.00     0.00    14.18     0.00     0.00    15.26    18.60    15.33    22.20 

0000:00:20:00     0.00     0.00    14.07     0.00     0.00    15.17    18.57    15.24    22.20 

0000:00:30:00     0.00     0.00    13.95     0.00     0.00    15.08    18.53    15.15    22.20 

0000:00:40:00     0.00     0.00    13.83     0.00     0.00    14.97    18.49    15.05    22.20 

0000:00:50:00     0.00     0.00    13.72     0.00     0.00    14.87    18.44    14.96    22.20 

0000:01:00:00     0.00     0.00    13.60     0.00     0.00    14.77    18.38    14.86    22.19 

0000:01:10:00     0.00     0.00    13.48     0.00     0.00    14.66    18.32    14.76    22.18 

0000:01:20:00     0.00     0.00    13.37     0.00     0.00    14.56    18.27    14.66    22.17 

0000:01:30:00     0.00     0.00    13.25     0.00     0.00    14.45    18.20    14.56    22.15 

0000:01:40:00     0.00     0.00    13.13     0.00     0.00    14.35    18.14    14.46    22.14 

0000:01:50:00     0.00     0.00    13.02     0.00     0.00    14.24    18.08    14.35    22.12 

0000:02:00:00     0.00     0.00    12.90     0.00     0.00    14.14    18.01    14.25    22.10 
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CHAPTER F BISTRA TEMPLATE FILES 

F.1. General 

BISTRA makes use of template files containing default information for a number of functions. 
These template files are each saved in the application data folder or personal folder (see A.6) of 
the user account on the computer where BISTRA is installed. The path to the application data 
folder is C:/Users/username/Appdata/Roaming/Physibel/BISTRA5 (AppData is a hidden folder 

by default in Windows). 

 
The template files used by BISTRA are: 

- ColourDatabase.bst (F.2) 
 

The use of these template files in different BISTRA functions has been outlined throughout the 
manual. In the following sections, handling and customization of these template files is briefly 
discussed. 

F.2. Colour database 

The colour database file ColourDatabase.bst is saved in the application data folder 

(C:/Users/username/Appdata/Roaming/Physibel/BISTRA5). The colour database contains 
predefined material and boundary condition properties and is loaded at every BISTRA start-up 
(see B.2). 

 
It is advisable to add frequently used materials and boundary conditions to the colour database. 
These predefined colours of the colour database are then available for new colours in any 

document. 
The command File → Open Colour Database… allows to modify the 256 available predefined 
colours of the colour database. After editing the colour data, the file should be saved (File → 

Save) to adapt the colour database on disk. 
 
Alternatively, if a user wants to save a custom file as colour database, this is possible by saving it 

with the name ColourDatabase.bst in the application data folder (File → Save as…) thus 
overwriting the default file. In the application data folder, the default colour database is present 
as ColourDatabase_PhysibelDefault.bst. This file can be saved as ColourDatabase.bst to restore 
the original colour database. 
 
Since the colour database is a BST file, it needs to have an accompanying BMP file. For 
ColourDatabase.bst, the accompanying BMP file is Default.bmp (in the same location). This 

Default.bmp file is of no further significance, but must exist. 
 
The ColourDatabase.bst file replaces the Bistra.bst file in older versions of BISTRA. Users who had 

been working with a customised Bistra.bst file, can thus easily transfer to the new system by 
opening Bistra.bst and saving it with the name ColourDatabase.bst in the application data folder. 
The bitmap file linked to Bistra.bst (Bistra.bmp) must then be saved as Default.bmp. 
The legacy Bistra.bst file was also used to set the default bitmap pixel size and global 
triangulation size (see B.9). These properties can now be set via command Settings → Default 
Measures… (see A.9). 
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CHAPTER G PROGRAM FUNCEDIT 

G.1. Introduction 

The program FUNCEDIT is a utility program to edit and visualise external function files for use in 
non-steady state Physibel programs (BISTRA, VOLTRA), where they are used as dynamic 
boundary condition specifications (see B.12.2). 
 
After starting FUNCEDIT or creating a new function using the command File → New, a null 

temperature function of length 24 hours (with hourly values of 0°C) is displayed. 
 

 
 
An existing function file on disk is read using the command File → Open…. The function type can 

be chosen in the Open dialog box. 



Manual BISTRA v5.0 71 

G.2. Function type 

The following function types are available: 

Function type Unit ext. Use in BISTRA 

temperature [°C] .fte boundary condition temperature 

horizontal global solar radiation [W/m2] .fsg boundary condition solar zone 

horizontal diffuse solar radiation [W/m2] .fsd boundary condition solar zone 

direct solar radiation [W/m2] .fsb not used 

solar radiation [W/m2] .fse not used 

infrared radiation [W/m2] .fir boundary condition heat flux 

power [W] .ffh boundary condition power 

thermal conductivity [W/(m.K)] .fco material property 
time-dependent thermal conductivity 

surface heat transfer coefficient [W/(m².K)] .fht boundary condition 
total surface heat transfer coefficient or 
convective heat transfer coefficient 

ventilation rate [/h] .fvr ventilation volume flow rate [m3/s] 

 
Remark 
The ventilation rate in FUNCEDIT is shown with unit /h, which was used in the (now deprecated) 
Physibel program CAPSOL. However in BISTRA the same function type is used for ventilation 

volume flow rates, with unit m3/s. So for BISTRA ventilation functions the unit specifier [/h] in 

FUNCEDIT should be read as [m3/s]. 

G.3. Function parameters 

General header information of a function file is edited via the command Edit → Parameters…. 

 

 
 
A dialog box is opened where the following parameters can be edited: 

- Function type: see section G.2. 
- Comment: text description of the function. 
- Previous function and next function: file name of a function that precedes the current 

function (previous function) or comes next to the current function (next function). The 
previous and/or next function may be the same as the current function, in which case the 
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check box “the same” is marked. 

If the time span of a BISTRA simulation is larger than the time span of the function 
definition, it is necessary to know which function comes next to the current one. In case a 
start-up calculation is used, a previous function is required. If the previous and the next 
function are checked as the same, then the current function corresponds to the definition 

of an infinite periodic function, with period the length of the current function. 
- Interpolation: linear or step. Intermediate function values are either obtained by linear 

interpolation (linear function) or remain constant during the whole time step interval (step 
function). 

- Time step [dddd:hh:mm:ss]: time interval between two successive function values in the 
function data window (see section G.4). 

- Total steps: number of time steps required to span the total function length. This number is 
equal to the number of function values minus 1. The function length or duration equals the 
time step multiplied by the total number of steps. 

- Number of decimals: number of digits after the decimal point, for all function values in the 
function data window (see section G.4) and in the function file. 

- Number of columns: used in the function data window (see section G.4) and in the function 
file. 

- Day number at function start [1..365]: day number in the year on which the function starts. 
The “i” button gives information about the start days of each month. 

 

 
 

- Latitude [°N], longitude [°E] and time zone [h]: to position a function climate station on the 

globe. 
- Chart time unit and chart time format: labelling information for the time axis in the 

function chart. This information is not stored in the function file. 

G.4. Function data 

The function values at regular time step intervals can be edited in the function data window, 
opened with the command Edit → Data. The table format is controlled by the function 

parameters (see section G.3). 

 
In the left (grey) column a time indication of the first value in the row is given. The table can be 
navigated by the mouse or by the arrow keys. 
A new value can be inserted after the current one using the command Edit → Insert After or the 

Insert key. The “total steps” parameter in the function parameters dialog box is adapted 
accordingly. 
A value can be deleted using the command Edit → Delete Value or the Delete key. 

Individual table cells can be copied and pasted by using the commands Edit → Copy (or 

<Ctrl+C>) and Edit → Paste (or <Ctrl+V>). 
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G.5. Graphic parameters 

The window that is opened when a new function is created or an existing function file is read, 
contains a graphic representation of the numerical function data entered in the data window. 
The red point in the graph corresponds to the function value in the current cell of the data 
window. 

 

 
 
The parameters about the graph can be edited in the Graphic submenu. 
 

 
 
The command Graphic → Set Scale… opens a dialog box containing scale parameters. 

The view range for both axes and tick mark distances can be set. 
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When a rectangle is drawn in the graph with mouse dragging (holding down the left mouse 

button), a zoom rectangle is defined. The corresponding zoom view is drawn when the left 
mouse button is released. The initial total view (with view range as defined in the Set Scale dialog 
box) can be restored by using the command Graphic → Zoom All or pressing the Home key. 

 
The commands Graphic → Primary Grid X and Graphic → Primary Grid Y enable to show grid 

lines through the primary tick marks on both axes X and Y. 
 
The command Graphic → Right Axis allows to draw also a vertical axis with tick marks at the right 

side of the chart border. 
 
The command Graphic → Save As Bitmap (PNG) opens a dialog box where you can enter the file 

name and size of the .png file, which will be saved in the same directory as where the function is 

stored. 

G.6. Using a spreadsheet program to create functions 

A function file can also be created using Microsoft Excel or another spreadsheet program. 
The spreadsheet contains 6 header rows (starting with the keywords COM, PRV, NXT, TIM, FMT 

and DAT) followed by data rows with function values. The syntax of the input data is given in the 
table below. Save the file (as text) in the function files directory, with the extension corresponding 
to the function type (cf. section G.2). 

If an existing function file, created with FUNCEDIT, has to be modified using a spreadsheet 
program, it is recommended first to set the parameter “number of columns” in the Function 

Parameters dialog box equal to 1. Then there will be only 1 column with function values in the 
spreadsheet (as in the figure below). 
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row number code input data 

 column A column B column C column D column 

E 

column F 

1 COM comment     

2 PRV name of the 

previous function 

* 

    

3 NXT name of the next 

function * 

    

4 TIM interpolation: 

0 = linear / 1 = 

step 

time step 

(in seconds) 

total number of steps   

5 FMT total number of 

characters of the 

function values 

number of 

digits after 

decimal 

point 

number of columns 

of function values 

minimu

m 

ordinate 

maximum 

ordinate 

6 DAT date number at 

function start 

latitude longitude time 

zone 

 

7  -  ...  -  

(7 + total steps) 

function 

type** 

function 

value 

(function 

value) 

(function 

value) 

(function 

value) 

(function 

value) 

* The extension of the file name may be omitted; Omit this line to specify the same previous / next function (or use the 

name *same*). 

** The function type as described in section G.2. 
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CHAPTER H RADCON MODULE 

H.1. Purpose 

The RADCON module is a program add-on feature to simulate more realistically the heat 
transfer between material surfaces and the adjacent environments. 
The heat transfer has the following components: 
• Radiation: based on view factors and material surface emissivities. 

• Convection: based on a (calculated) convective heat transfer coefficient applied to the contact 

surface between material and environment. 
• Conduction: in a (transparent) material with given thermal conductivity. 
 
The RADCON module offers a physically more correct alternative for: 
• The global surface heat transfer coefficient. 
• The equivalent thermal conductivity of an air cavity. 
 

  
principle of view factor based radiation heat transfer 

using BC_SKY (at a surface) 
principle of view factor based radiation 

heat transfer using TRANSMAT (in a cavity) 
 

H.2. Implementation 

The following colour types require the use of the RADCON module in BISTRA: 
• TRANSMAT for a transparent material with known (or calculated) thermal conductivity 

(normally of still air or another gas) according to EN ISO 10077-2) 

Additionally to the gas conduction there is radiative heat transfer between the adjacent 
material surfaces (using their emissivities). 
If the transparent material is not fully surrounded by material surfaces, then the open side at 
the bitmap border is considered as an adiabatic surface, i.e. a radiation mirror with emissivity 
 = 0. 

If there is convection within the cavity, the thermal conductivity for still gas should be 
multiplied by the Nusselt number. 

• BC_FREE for an enclosure (normally fully surrounded by material surfaces, e.g. a cavity or a 
room) with unknown air temperature (free-floating air temperature), known surface heat flux 

(positive or negative), known (or calculated) convective heat transfer coefficient and known 
injected convective heat power (positive or negative). 
The unknown air temperature is calculated from the convective heat balance equation: 
Σ (convective heat transfer from environment to surface) = injected convective heat power. 

The radiation between the different surfaces bordering the environment are calculated based 
on view factors and surface emissivities. 
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When the environment is not completely surrounded by material surfaces, the open end (at 

the bitmap border) is considered to be a symmetry plane for heat transfer. The symmetry 
plane is simulated as a radiation mirror (with emissivity  = 0). 

• BC_SKY for an environment (normally not fully surrounded by material surfaces, i.e. open to 
the sky) with known air temperature, known radiation temperature, known surface heat flux 

(positive or negative) and known (or calculated) convective heat transfer coefficient. 
This implies there can be a resultant radiative heat flow and a resultant convective heat flow 
from the environment to the material surfaces. 

• BC_NOSKY for an environment with known air temperature, known surface heat flux (positive 
or negative) and known (or calculated) convective heat transfer coefficient. 
There is no radiation exchange with the environment (i.e. no sky radiation). The surfaces 

bordering the environment exchange radiation based on view factors and surface 
emissivities. 
The known air temperature implies there can be a resultant convective heat flow from the 

environment to the material surfaces. 
 
For use with RADCON the colour types MATERIAL and EQUIMAT also have a surface emissivity 

(defined in the Colours window), which is applied to the radiative heat transfer for the RADCON 
boundary conditions bordering the material. 
 
Combined convective and radiative heat transfer (BC_SIMPL, BC_FRE_S) 
The global (combined convective and radiative) heat flow is: 
𝑄 = ℎ ⋅ (𝜃𝑠 − 𝜃𝑏𝑐) ⋅ 𝐴 
𝑄  = global heat flow [W] 

ℎ = global heat transfer coefficient [W/(m2.K)] 
𝜃𝑠 = surface temperature [°C] 
𝜃𝑏𝑐 = environmental temperature [°C] 

𝐴 = surface area [m²] 
In this formula the environmental temperature is not defined precisely. It can be the air 
temperature, the dry resultant temperature or an interpolated value. Depending on that choice, 

an appropriate value for the global heat transfer coefficient must be chosen. 
 

Convective heat transfer (BC_FREE, BC_SKY, BC_NOSKY) 
The convective heat flow is: 
𝑄𝑐 = ℎ𝑐 ⋅ (𝜃𝑠 − 𝜃𝑎) ⋅ 𝐴 
𝑄𝑐 = convective heat flow [W] 
ℎ𝑐 = convective heat transfer coefficient [W/(m2.K)] 
𝜃𝑠 = surface temperature [°C] 
𝜃𝑎 = air temperature [°C] 
𝐴 = surface area [m²] 

The convective heat transfer coefficient ℎ𝑐 can be calculated based on the given subtype. 
 
Black radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
The radiative heat flow between two black surfaces is: 
𝑄𝑖𝑗 = 𝐴𝑖 ⋅ 𝐹𝑖𝑗 ⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑠𝑏𝑖 − 𝜃𝑠𝑏𝑗) 

𝑄𝑖𝑗 = radiative heat flow between black surface i and black surface j [W] 

𝐴𝑖 = area of surface i [m2] 
𝐹𝑖𝑗 = view factor from surface i to surface j (between 0 and 1) 

ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 
𝜃𝑠𝑏𝑖 = black surface temperature of surface i [°C] 
𝜃𝑠𝑏𝑗 = black surface temperature of surface j [°C] 
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For linear radiation the black radiation heat transfer coefficient is constant, defined as a 

calculation parameter (default value 5.1 W/(m2.K)). The value depends on the temperature range 
of the problem considered.  Section H.3 contains a table with values of ℎ𝑟𝑏, depending on the 
mean temperature 𝑚 [°C] of the surfaces i and j and the temperature difference between the 
surfaces 𝑖𝑗 [°C]. The table shows that the ℎ𝑟𝑏-value mainly depends on the mean surface 

temperature 𝑚. 

The default value 5.1 W/(m2.K) is the ℎ𝑟𝑏-value at 10°C.  
 
For non-linear radiation: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑠𝑏𝑖

2 + 𝑇𝑠𝑏𝑗
2 ) ⋅ (𝑇𝑠𝑏𝑖 + 𝑇𝑠𝑏𝑗) 

𝜎 = 5.67 10-8 W(m2.K4) (Stefan-Boltzmann constant) 
𝑇𝑠𝑏𝑖 = 𝜃𝑠𝑏𝑖 + 273.16 [K] (absolute temperature of black surface i) 
𝑇𝑠𝑏𝑗 = 𝜃𝑠𝑏𝑗 + 273.16 [K] (absolute temperature of black surface j) 

The black radiation heat transfer coefficients are recalculated at the start of each new iteration 
cycle based on the temperatures obtained in the last iteration cycle. 

 
Grey radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
Real surfaces are not black (emissivity  = 1) but grey (emissivity  < 1). 

In the RADCON module each grey surface is connected to a black surface node. All black surface 

nodes are connected to each other in a star diagram. 
The radiative heat flow between the grey surface with given emissivity and the corresponding 
black surface is: 

𝑄𝑟 = 𝐴 ⋅
𝜀

1 − 𝜀
⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑠𝑏 − 𝜃𝑠) 

𝑄𝑟 = radiative heat flow between grey surface and black surface [W] 

𝐴 = surface area [m2] 
 = surface emissivity (0 ≤ ε < 1) 

ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 
𝜃𝑠𝑏 = black surface temperature [°C] 

𝜃𝑠 = (real) surface temperature [°C] 
For non-linear radiation: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑠𝑏

2 + 𝑇𝑠
2) ⋅ (𝑇𝑠𝑏 + 𝑇𝑠) 

𝑇𝑠𝑏 = 𝜃𝑠𝑏 + 273.16  [K] 
𝑇𝑠 = 𝜃𝑠 + 273.16 [K] 

The black radiation heat transfer coefficients are recalculated at the start of each new iteration 
cycle based on the temperatures obtained in the last iteration cycle. 

 
Iteration cycles for non-linear radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
Iteration cycles are used to calculate non-linear radiative heat transfer. At the start of each 
iteration cycle the black radiation heat transfer coefficients are updated using the local 
temperatures available at that moment. 

For the first iteration cycle the black radiation heat transfer coefficients have a constant value as 
defined in the Calculation Parameters dialog box. 

The total number of iteration cycles is defined in the Calculation Parameters dialog box. Normally 
5 iteration cycles are sufficient. A low number of iteration steps in the last iteration cycle ensures 
that the number of iteration cycles is OK. 
 
View factors (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
The view factors are calculated for all elementary surfaces (corresponding to edges in the mesh 
triangulation) bordering the environment (type BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT). 

Several environments of the same type (e.g. with different convective heat transfer coefficients) 
may touch one another. The view factors are calculated for the union space of these adjacent 
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environments. 

Adjacent environments of different type are not allowed. Then an error message is displayed at 
the start of the system calculation (Calc → Calc System). 
A boundary condition of type BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT is not allowed to 
occur in different zones (separated by a material). Each zone must be considered as a separate 

environment (having a different colour). An error message is displayed at the start of the system 
calculation, when this condition is not satisfied. 
First the view factor between two (elementary) surfaces, not obstructed by other surfaces, is 
calculated using an exact analytic formula. A very small view factor (i.e. smaller than the 
calculation parameter smallest accepted view factor) is neglected (rounded to 0). Then possible 
obstruction by other surfaces is estimated using 10 test rays between random points of both 

surfaces. The number of test rays is proportional to the unobstructed view factor. 
After calculation of all view factors a correction is made to smooth away possible errors (e.g. due 
to the limited number of visibility test rays), so that the sum of view factors always equals 1, and 

the view factor reciprocities are respected. 
The total number of calculated view factors (and hence the calculation time and required 
memory space) is a quadratic function of the number of elementary surfaces (= triangulation 
edges) in the largest view factor zone. 
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H.3. Table for black radiation heat transfer coefficient 

The following table shows the black radiation heat transfer coefficient. 
The values are obtained using the formula: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑖

2 + 𝑇𝑗
2) ⋅ (𝑇𝑖 + 𝑇𝑗) 

with 𝜎 =  5.67*10-8 W/(m2.K4) (Stefan-Boltzmann constant) 

 

black radiation temperature difference between the surfaces i and j 
heat transfer 

coeff. 
ij [°C] 

hrb [W/m2K] 0.00 5.00 10.00 15.00 20.00 25.00 30.00 35.00 40.00 45.00 50.00 
 -20.00 3.68 3.68 3.68 3.68 3.69 3.69 3.69 3.70 3.70 3.71 3.72 
 -15.00 3.90 3.90 3.90 3.91 3.91 3.91 3.92 3.92 3.93 3.93 3.94 
 -10.00 4.13 4.13 4.13 4.14 4.14 4.14 4.15 4.15 4.16 4.16 4.17 

 -5.00 4.37 4.37 4.37 4.38 4.38 4.38 4.39 4.39 4.40 4.40 4.41 
mean 0.00 4.62 4.62 4.62 4.63 4.63 4.63 4.64 4.64 4.65 4.65 4.66 
temp. 5.00 4.88 4.88 4.88 4.88 4.89 4.89 4.90 4.90 4.91 4.91 4.92 
m [°C] 10.00 5.15 5.15 5.15 5.15 5.16 5.16 5.16 5.17 5.17 5.18 5.19 

 15.00 5.43 5.43 5.43 5.43 5.43 5.44 5.44 5.45 5.45 5.46 5.47 
 20.00 5.71 5.71 5.72 5.72 5.72 5.72 5.73 5.73 5.74 5.75 5.76 
 25.00 6.01 6.01 6.01 6.02 6.02 6.02 6.03 6.03 6.04 6.05 6.05 
 30.00 6.32 6.32 6.32 6.32 6.33 6.33 6.33 6.34 6.35 6.35 6.36 
 35.00 6.64 6.64 6.64 6.64 6.64 6.65 6.65 6.66 6.66 6.67 6.68 
 40.00 6.96 6.97 6.97 6.97 6.97 6.98 6.98 6.99 6.99 7.00 7.01 
 45.00 7.30 7.30 7.31 7.31 7.31 7.32 7.32 7.33 7.33 7.34 7.35 
 50.00 7.65 7.65 7.66 7.66 7.66 7.67 7.67 7.68 7.68 7.69 7.70 
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H.4. Table for emissivities 

The table below contains values of the long-wave emissivity  of some building materials taken 
from: 
• H.C. Hottel, Heat Transmission, 1954 
• J.S. Cammerer, Wärme- und Kälteschutz in der Industrie, 1962 
• Stichting Bouwresearch, Eigenschappen van bouw- en isolatiematerialen, rapport 9, 1974 

 
building material long-wave emissivity at T = 300K 

 [-] 

black surface 1 

aluminium, polished < 0.07 

aluminium, oxidised 0.11 à 0.3 

brass, polished 0.038 

copper, smoothed 0.09 

copper, oxidised 0.78 - 0.79 

cast iron 0.44 

iron, oxidised and rusted red 0.61 

lead, gray oxidised 0.28 

tin 0.043 - 0.064 

zinc, galvanised 0.23 

zinc, oxidised > 0.11 

asbestos board 0.96 

bitumen 0.92 

brick, red, rough but no gross 

irregularities 

0.92 - 0.93 

concrete 0.88 

glass 0.94 

cement-tiles > 0.85 

roofing-tiles, red 0.85 

roofing paper 0.91 

rubber, hard and glossy 0.94 

wood 0.86 

aluminium painting 0.42 

enamel, white >0.90 

metal paint, black 0.88 

water 0.95 - 0.96 

other materials (approximation) 

white, yellow, green, red, blue, grey, 

black 

0.85 à 0.95 

 
The table below contains values of the long-wave emissivity   from EN ISO 10077-2:2017: 
 

description  

 [-] 

Untreated aluminium surfaces 0.1 

Slightly oxidized aluminium surface (up 

to 5 µm) 

0.3 

Metallic surfaces (general, including 

galvanized) 

0.3 

Anodized, painted or powder coated 

surfaces 

0.9 
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H.5. Tables for convective heat transfer coefficient 

The convective heat flow density is calculated using the following formula: 

𝑞𝑐 = ℎ𝑐 ⋅ (𝜃𝑎 − 𝜃𝑠) with 𝑞𝑐= convective heat flow density [W/m2] 
ℎ𝑐 = convective heat transfer coefficient [W/(m2.K)] 
𝜃𝑎= air temperature [°C] 

𝜃𝑠 = surface temperature [°C] 

Table 1 lists values of ℎ𝑐 for air cavities according to EN ISO 10077-2, depending on the 

temperature difference  over the cavity and the depth d of the cavity. Above the bold line, the 
ℎ𝑐-value depends only on the cavity depth (same hc-values on each row), while underneath the 

bold line the ℎ𝑐-value depends only on the temperature difference over the cavity (same ℎ𝑐-
values in each column). Above the bold line there is in fact only conduction (still air). Below the line 
natural convection is considered. 

 
Table 1: convective heat transfer coefficient (surface-to-surface) for air cavities (EN ISO 10077-2) 

convective heat temperature difference over the cavity 

transfer 

coefficient 

 [°C] 

hc [W/(m2.K)] 0.500 1.000 1.500 2.000 3.000 4.000 5.000 6.000 8.000 10.000 

 0.001 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 

 0.002 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 

 0.003 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 

 0.004 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 

 0.005 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 

depth 0.006 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 

of the 0.007 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 

cavity 0.008 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 

d [m] 0.009 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 

 0.010 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 

 0.011 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 

 0.012 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 

 0.013 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 

 0.014 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 

 0.015 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 

 0.016 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.145 

 0.017 2.941 2.941 2.941 2.941 2.941 2.941 2.941 2.941 2.941 3.145 

 0.018 2.778 2.778 2.778 2.778 2.778 2.778 2.778 2.778 2.920 3.145 

 0.019 2.632 2.632 2.632 2.632 2.632 2.632 2.632 2.653 2.920 3.145 

 0.020 2.500 2.500 2.500 2.500 2.500 2.500 2.500 2.653 2.920 3.145 

 0.025 2.000 2.000 2.000 2.000 2.106 2.318 2.497 2.653 2.920 3.145 

 0.030 1.667 1.667 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.035 1.429 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.040 1.250 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.045 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.050 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.060 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.070 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.080 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.090 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.100 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 
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Table 2 lists values of ℎ𝑐 for exterior surfaces, depending on the air velocity v and the 

temperature difference  between surface and environment (from “Informatiemap voor 
bouwfysici”, 1991). 
 
Table 2: the convective heat transfer coefficient for exterior environments 

convective heat temperature difference object -

environment transfer 

coefficient 

 [°C] 

hc [W/(m2.K)] 5 10 20 40 

 0.5 7 8 9 11 

air 1 9 10 11 13 

velocity 2 12 13 15 16 

v [m/s] 3 19 20 21 23 

 4 25 26 27 28 

 5 30 31 32 34 

The following formulas define the convective heat transfer coefficient for interior environments 
(from “Element 29: Wärmeschutz und Energie im Hochbau”, 1990). Table 3 lists the ℎ𝑐-values 
according to these formulas. 

ℎ𝑐 = 1.31 ⋅ √𝛥𝜃
3

 for vertical constructions (walls) with a horizontal heat flow 

ℎ𝑐 = 1.77 ⋅ √𝛥𝜃
4

 for vertical constructions (window) with a horizontal heat flow 

ℎ𝑐 = 1.52 ⋅ √𝛥𝜃
3

 for horizontal constructions (walls) with an upward heat flow 

ℎ𝑐 = 0.59 ⋅ √𝛥𝜃
4

𝐿⁄  for horizontal constructions (walls) with a downward heat flow 

with  ℎ𝑐  = convective heat transfer coefficient [W/(m2.K)] 
 = temperature difference object - environment [°C] 
𝐿 = ½ (length x width) of the construction [m2] 

 
Table 3: the convective heat transfer coefficient for interior environments 

convective heat vertical constructions horizontal constructions 

transfer coefficient horizontal heat flow upgoing downgoing 

hc [W/(m2.K)] walls windows heat flow heat flow 

 1 1.31 1.77 1.52 0.39 

 2 1.65 2.10 1.92 0.47 

 3 1.89 2.33 2.19 0.52 

temperature 4 2.08 2.50 2.41 0.56 

difference 5 2.24 2.65 2.60 0.59 

object -  6 2.38 2.77 2.76 0.62 

environment 7 2.51 2.88 2.91 0.64 

 [°C] 8 2.62 2.98 3.04 0.66 

 9 2.72 3.07 3.16 0.68 

 10 2.82 3.15 3.27 0.70 

 11 2.91 3.22 3.38 0.72 

 12 3.00 3.29 3.48 0.73 

 13 3.08 3.36 3.57 0.75 

 14 3.16 3.42 3.66 0.76 

 15 3.23 3.48 3.75 0.78 

* using L = 5 m 
 


