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CHAPTER A INTRODUCTION 

A.1. Short description of BISCO 

BISCO is a thermal analysis program for steady state heat transfer in two-dimensional objects 
consisting of different materials and submitted to different boundary conditions. The geometry is 
defined by a coloured picture in bitmap format. BISCO requires data input for the association of 
the bitmap colours with the physical properties of materials and boundary conditions. 

BISCO calculates a triangulation for the material colours. The system nodes are located in the 

triangle vertices. The temperatures in the nodes are calculated, from which all heat flows can be 
derived. 
 
BISCO allows to calculate thermal properties as defined by European standards and the 
American National Fenestration Rating Council (NFRC): temperature factor/Condensation Index, 
linear thermal transmittance, thermal transmittance of a window frame, thermal transmittance of 
glazing. 
 
RADCON is a program add-on module to calculate infrared radiation and convection in a 
physically more realistic way. The radiation is based on view factors, surface emissivities and 
surface temperatures (radiosity method). The convection is based on empirical laws. 

A.2. Application examples 

- Thermal performance of windows, doors and shutters (EN ISO 10077-2, ISO 15099). 

- Thermal performance of glazing (EN 673, ISO 15099). 
- Thermal performance of curtain walls (EN ISO 12631). 
- Thermal bridge analysis: heat loss calculation, surface condensation (EN ISO 10211, 

ISO 13788). 

- Thermal transmittances of building components and elements (EN ISO 6946) (e.g. hollow 

brick masonry). 
- Heat transfer via the ground (ISO 13370). 

A.3. BISCO: brief history 

BISCO was first developed in 1995 as a MS-DOS program. The development was partially 

funded by a research grant of the Flemish Institute for the Promotion of Industrial Scientific and 
Technological Research (project no. VLIET/930243). 
 

• Version 1.0 was ready in January 1996. 
• The RADCON module was available from version 2.0 in January 1997. 

• The triangulation was new in version 3.0 (April 1997), which signified a great improvement 
in global calculation speed. 

• Version 4.0 (October 1997) included non-linear radiation with the RADCON module. 
• Version 5.0 (October 1999) was the first Windows version of the program, which meant 

again a significant improvement in calculation speed and ease of use. 
• Version 6.0 (2002) was a complete revision of the program introducing e.g. thermal output 

in line with European standards, border line boundary conditions, line measurements,… . 

• Version 7.0 (2004) introduced bitmap editing functions.  
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The detailed version history from BISCO v8 (2006) onwards can be found on the website: 

www.physibel.be/en/products/bisco/versions . 
 
   

A.4. Technical specifications 

BISCO is a 64-bit Windows program. BISCO is installed in C:\Program Files 
(x86)\Physibel\BISCO13. 
In this folder the executable file is BISCO.exe. 
The standard version of BISCO allows to solve systems with up to 500,000 nodes. An add-on 
feature to calculate an unlimited amount of nodes is available for purchase (feature Unlimited 

Nodes). The maximum number of nodes then depends on the RAM installed. 
BISCO relies on OpenGL for use of hardware accelerated graphics. 
OpenGL uses two system files glu32.dll and opengl32.dll in the Windows system folder. 

BISCO is protected by either a hardware key, provided by Physibel, or a software licence (A.5). 
 
The Physibel 64-bit programs need several shared libraries (.dll files) from Microsoft. 
The Microsoft Visual C++ 2017 Redistributable Package (x64) is included in the installation files of 
BISCO, but can also be downloaded from https://support.microsoft.com/en-
us/help/2977003/the-latest-supported-visual-c-downloads. 
This package installs mfc140.dll and other files in the directory C:\Windows\SysWOW64, required 

by 64-bit applications developed with Microsoft Visual C++ 2017. 

A.5. Licence 

The Physibel applications are protected by a licence, to prevent illegal use of the software. This 
can be either a hardware licence (Sentinel USB key) or a software licence. 

A.5.1. Hardware licence 

Perpetual licences are protected by a hardware licence (Sentinel USB key). The licence is locked 
to this dongle. It is strongly recommended to take a financial assurance for loss of the key by theft 
or any other incidence. 

 
Before BISCO can be used, the driver (delivered with purchase) for the hardware key needs to be 
installed. Administrator rights are needed for this installation. It might be necessary to restart your 
computer after installing the driver. 
 
During use of BISCO, the dongle needs to be attached to the computer at all times. 

A.5.2. Software licence 

Subscription licences are protected by a software licence. After first installation of BISCO, the user 
needs to activate the licence using the activation code received upon purchase of the software. 

When first opening BISCO, the Software Licence Manager will open automatically and prompt 
the user to activate the licence, or to register in the network floating database, depending on the 
licence type. The computer needs to be connected to the internet for this licence activation. 
Cloud-based floating licences need to be activated every time when opening the application. 
 
After activation, the Software Licence Manager is available from the menu for stand-alone 
licences: 
Help → Software Licence Manager… 

http://www.physibel.be/en/products/bisco/versions
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
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This allows the user to check the expiry date of the licence subscription and be redirected to 
renew the licence. 
 
Users with a floating network licence can check out a licence from the database for a maximum 

period of 3 days. 
Help → Check out/in floating licence… 
 
The software licence key for BISCO is linked to the computer where it was activated. When you 
want to move the application with a stand-alone licence to another computer, you can 
deactivate the licence in the Software Licence Manager. The licence can then be reactivated on 

a new computer. 
 
If the Software Licence Manager is unavailable from the application itself, you can also open it 

from the command prompt. You need to first change directory to the Program Files folder where 
the application is installed. Then, open the Software Licence Manager with the following 
command: 
QlmLicenseWizard.exe /settings “BISCO 12.0.lw.xml” 
 

A.6. User Account Control (UAC) 

Administrator rights are necessary to install BISCO on a computer. 

 

The installation of the application is machine-level, meaning all user accounts can access the 
application after installation. 
 

Each user account has its own copy of the colour database (see J.2J.2), colour palette (see J.3J.3), 
report template (see J.4J.4) and DXF layer definition file (see J.5J.5) to work with. These files can be 
found in the user’s application data directory 

(C:/Users/username/Appdata/Roaming/Physibel/BISCO13/). 
 
In case of a software licence, the licence for BISCO is linked to the computer, but is stored at the 
user level. Each user account on a computer has to activate the licence in order to have access to 
the licence. 

A.7. Overview of delivered files and file structure 

BISCO is installed (when the user accepts the default destination) in the directory 
C:\Program Files (x86)\Physibel. 

 
The following files are installed 
Folder File Description 

…\Physibel\BISCO13 BISCO.exe BISCO (64-bit) program 
 BiscoDxf.exe Auxiliary program 

 BiscoBmp.exe Auxiliary program 
 *.dll, *.pat, *.rgb Program resources 
 QlmLicenseWizard Software Licence Manager files 
…\Physibel\Materials *.phm Material databases 
…\Physibel\Manuals BISCOManual.pdf BISCO manual 
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The colour database file ColourDatabase.bsc and back-up ColourDatabase_Physibeldefault.bsc 

(see J.2), the bitmap colour palette file ColourPalette.bmp and back-up 
ColourPalette_Physibeldefault.bmp (J.3), the report template BiscoReportTemplate.doc (see J.4) 
and the default DXF layer definitions BiscoDxf.lay (see J.5) are installed in 
C:/ProgramData/Physibel/BISCO13 (machine-level), and copied to each user account’s 

application data folder when first opening BISCO 
(C:/Users/username/AppData/Roaming/Physibel/BISCO13), except for BiscoReportTemplate.doc, 
which is copied to the user’s personal folder (../Documents/Physibel/BISCO13). 

A.8. Logging 

When using BISCO, information is continuously written to a log file located in the user account’s 

application data folder (C:/Users/username/AppData/Roaming/Physibel/BISCO13). This file 
contains information that can help for debugging when something went wrong, and also to 
clarify or elaborate on error or warning messages shown in the application. 

A.9. Text convention 

Menu paths are printed in italic, with format Submenu → Command. 
E.g. File → Open (Open command in File submenu). 

A.10. Program settings 

Global program settings are available via the Settings submenu. 
 

 
 
The following settings can be defined: 

- Settings → Toolbar: presence of the toolbar giving access to menu commands through 
icons. 

- Settings → Status Bar: presence of the status bar at the bottom of the BISCO application 
window, containing context depending information. 

- Settings → Default Standard…: set EN ISO 10077-2, EN ISO 6946, ISO 15099 or NIHIL as 

default standard for the definition of colour types. 

- Settings → Default Measures…: set the default bitmap pixel size and global triangulation 
size (see C.9), and the resolution of the bitmap created after direct input of a DXF file (see 
H.3). 

- Settings → EN ISO 10077-2 Settings…: program parameters for the command Bitmap → 
EN ISO 10077-2 Preparation… (cf. section C.12). 

- Settings → NFRC 100/500 Settings…: program parameters for the command Bitmap → 
NFRC 100/500 Preparation… (cf. section C.12). 
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- Settings → Set Graphic Report Definition As Default: sets the current graphic report 

definition as the default for new BISCO projects (the Graphic Report Definition window, 
see G.1, must be active). 

- Settings → Language: the selected language (English, Dutch, French, German) becomes 
effective the next time the program is started. 

- Settings → Reset Settings…: sets all settings back to factory settings. 

A.11. Program parameters 

The global default values (calculation parameters, output parameters, split zone parameters, 
EN ISO 10077-2 settings, NFRC 100/500 settings, interface language, pixel size, triangulation 

measures, etc.) are saved in the file BISCO.prm in the application data folder 
(C:/Users/username/Appdata/Roaming/ Physibel/BISCO13). When the program BISCO is started, 
the program parameters are loaded from the parameter file. 
 
The program parameter default values can be changed from several input dialog boxes. When 
the button “Set As Default” in an input dialog box is clicked, the corresponding program 

parameters are saved in the program parameter file BISCO.prm at exiting BISCO. 

A.12. References 

EN ISO 6946 (2017). Building components and building elements – Thermal resistance and 

thermal transmittance – Calculation method. 

EN ISO 10077-2 (2017). Thermal performance of windows, doors and shutters. Calculation of 
thermal transmittance – Part 2: Numerical method for frames. 
EN ISO 10211 (2017). Thermal bridges in building construction – Heat flows and surface 

temperatures – Detailed calculations. 
EN 673 (2011). Glass in building – Determination of thermal transmittance (U value) – Calculation 
method. 

EN ISO 12631 (2017): Thermal performance of curtain walling - Calculation of thermal 
transmittance. 
ISO 15099 (2003): Thermal performance of windows, doors and shading devices – Detailed 

calculations. 
NFRC 100 (2023): Procedure for Determining Fenestration Product U-factors. 

NFRC 500 (2023): Procedure for Determining Fenestration Product Condensation Index Ratings. 
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CHAPTER B PROGRAM ESSENTIALS 

B.1.  The program BISCO 

BISCO is a program to calculate 2D steady state heat transfer through an object consisting of 
different materials and submitted to different boundary conditions. The geometry is described 
with a 2D drawing converted to a coloured bitmap. The colours are used to identify the materials 
and boundary conditions. 

B.2. Input 

The input of BISCO needs a 2D raster image (also called bitmap) in colour. 
The pixels of this bitmap can have 256 (= 28) different colours. 
The bitmap is stored in a 256-colours (or 8-bit) BMP file (Microsoft Windows Bitmap). 
Each colour in the bitmap will be linked to a different (homogeneous) material or boundary 
condition, having its own thermal properties. 
Each pixel of the bitmap is a square with side equal to a fixed physical length (= pixel size), to be 

defined in the Measures window of BISCO. 

 
BISCO has a tool (“BiscoDxf”) to convert a DXF drawing (e.g. from AutoCAD or Sketchup) using 

polylines in different layers into a bitmap (see Chapter HChapter H). Each layer represents a 
different material or boundary condition. BiscoDxf rasterises the polylines of each layer to a 
region of pixels of a user defined colour associated to that layer. The pixel resolution of the 

rasterisation and the bitmap extent are defined in BiscoDxf. 
If the DXF layer names have predefined thermal properties the input of a DXF file into BISCO 
data can go fast and smoothly. 

 
A line drawing (containing only two colours, i.e. the line colour and the background colour) stored 
as BMP file can be converted to a coloured bitmap using a dedicated function in BISCO (Bitmap 

→ Fill Line Drawing). For DXF files with all information in 1 layer (e.g. as 2D output from Sketchup) 

the procedure of generating a line drawing in BiscoDxf and converting it to a coloured bitmap 

can be useful (see C.6).  

B.3. Structure of the 256-colours BMP file 

A 256-colours BMP file contains a header section and an image data section. 
 

The header section contains the definition of the 256 possible colour values in the bitmap (called 
the colour palette). Each colour of the colour palette is defined by its red, green and blue 
components (or RGB values). Each colour component is an integer between 0 and 255 (having 
the range of 1 byte), which defines the intensity of that colour (0 = dark, 255 = full intensity). Using 
this colour system 256 x 256 x 256 different colour values can be created. From this colour space 

only a subset of 256 colours can be saved in the colour palette. 
 

In BISCO the individual colour values are shown in the Colours window. Each row in this window 

shows a colour number (between 0 and 255), which is the index into the colour palette, followed 
by the corresponding colour value from the colour palette. 
By default BISCO shows only the colours present in the actual loaded bitmap (which number is 

normally smaller than 256). To show all 256 possible colour values of the colour palette execute 

the command Colours → List All (which is only enabled when the Colours window is active). 
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The colour value for each colour number can be edited from the Colours window (by editing the 

RGB values). 
A BMP file generated in BiscoDxf or BISCO (see H.2.4) by default uses the colour palette of the 

ColourPalette.bmp file (see J.3). BISCO can load the colour palette of another bitmap into the 
current bitmap (see C.6, Bitmap → Load Palette…).  

 

The image data section of a 256-colours BMP file contains the pixel values of the bitmap, row by 
row (or scanline by scanline). Each pixel value is a colour number (between 0 and 255), which is 
an index into the colour palette. 
BISCO can read either uncompressed or (run-length encoded) compressed 256-colours BMP 
files. An uncompressed BMP file contains the pixel values of all individual pixels, while a 
compressed BMP file clusters pixel intervals of equal pixel value. 

 

In BISCO the image data are shown in the Bitmap window. When the Bitmap window is active, 

the bitmap coordinates (X and Y) and corresponding pixel value (colour number) of the pixel 
under the mouse cursor are displayed in the program status bar (at the bottom of the BISCO 
application window). 
 

BISCO contains a tool (“BiscoBmp”) (Bitmap → Edit using BiscoBmp) to edit and/or merge BMP 

files (see Chapter IChapter I). 

B.4. Definition of thermal properties 

Each colour number of the bitmap refers to either a material or a boundary condition. This is the 
colour type: MATERIAL, EQUIMAT (equivalent material), BC_SIMPL (simplified boundary 
condition), BC_FRE_S (simplified boundary condition with free temperature). 

The colour type and corresponding thermal properties can be edited in the Colours window. 

 
A material is defined by its thermal conductivity 𝜆, expressed in W/(m.K), which defines the heat 
transfer by conduction through the material. 
An air cavity can be replaced by an equivalent material (colour type EQUIMAT) defined by a 
single equivalent thermal conductivity according to the European Standards EN ISO 10077-2 and 
EN ISO 6946 or according to ISO 15099. BISCO allows to automatically split cavities having 

grooves and interconnections in accordance to EN ISO 10077-2 and ISO 15099. 
A gas layer inside a glazing can equally be replaced by an equivalent material (colour type 
EQUIMAT), with a single equivalent thermal conductivity according to EN 673 and ISO 15099. 

 
The space between and around materials are boundary conditions with heat transfer by 
radiation and convection. Usually a global heat transfer coefficient (for combined radiation and 
convection) along the material surfaces and a fixed environmental temperature are assumed 
(colour type BC_SIMPL). 
 
BISCO with RADCON module allows to use a physically more correct model with separate 
radiation and convection (additional colour types BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT). 
The radiation is based on view factors between surfaces with different temperatures and given 
emissivities. The convection is based on a convective heat transfer coefficient, calculated from the 
physical heat flow direction (horizontal, upward or downward), the geometrical heat flow 
direction (parallel to the X axis, the Y axis or the local temperature gradient), the dimensions of 

the boundary condition and the surface temperatures. 
The colour type BC_FREE is used for an enclosure with unknown (free-floating) air temperature, 
typically an air cavity or room. 
BC_SKY is used for an environment with known air and radiation temperature (typically the sky). 
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BC_NOSKY is used for an environment with known air temperature and no radiative exchange 

(no sky). 
TRANSMAT is an alternative to BC_FREE for air cavities, in accordance to the “radiosity method” 
of EN ISO 10077-2, where the convective heat transfer is modelled with a single equivalent 
thermal conductivity. 

B.5. Triangulation 

BISCO has a set of functions to clean up the bitmap up for a thermal calculation (see C.6, C.8 and 
I.1I.1). The raster image is then converted into a vector image, in which the staircase pixel 
boundaries are converted to approximated contour lines. The space besides the contour lines are 
triangulated using a balanced mesh with preferably equilateral triangles.  

The desired triangulation mesh size per material colour (defined in the Measures window) can be 

modified to improve the calculation quality without increasing too much the total number of 
nodes. 
In most cases a uniform triangulation mesh size for all materials will yield satisfactory results. 
The smaller the triangulation mesh size, the better the final calculation precision. 
 

   
Bitmap 

(composed of pixels) 
Vector image 

(boundary representation) 
Triangulation 

 
The vector representation of the triangulation is also better suited to account for the convective 
heat transfer, because the length of the contact surface between a material and a boundary 
condition is more precise than the measurements along the rectangular pixel boundaries. 
 
The complete triangulation information (vertices coordinates, triangle definitions per material 

colour, edge definitions per boundary condition) is saved into a text file (with same file name as 

BISCO file and extension .tri). 
 

The vertices of the triangulation mesh are the nodes of the thermal system. 

B.6. System calculation 

BISCO uses a control volume energy balance method. 

The material space is subdivided in adjacent elements (control volumes) with the system nodes as 
central points. 
For each control volume the sum of incoming heat flows should equal the sum of outgoing heat 

flows. This energy balance expresses the steady state of the system. 

The elementary heat flows are expressed as functions of the unknown temperatures of adjacent 
nodes. The functions are linearised to achieve a global linear system which can be solved using a 
fast system solver (which uses an iterative solution technique). If needed (to tackle non-linear 
phenomena such as radiation) this system solution is repeated several times with updated system 
coefficients (i.e. stepwise linearisation). The system coefficients are updated using refreshed node 

temperature results of the previous system solution. Each linear system solution is called a cycle. 
Normally 5 cycles are enough to solve most non-linear systems with adequate precision. 
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The total calculation time depends mainly on the total number of nodes. 

As the number of nodes grows, the total heat flow through the object decreases asymptotically 
towards the analytic solution. 
As result of the system calculation, we obtain the individual temperatures of all system nodes 
(saved in a .sol file). From these values isothermal lines can be constructed. 

Heat flow lines follow orthogonal directions to the isothermal lines. Heat flow function values, 
from which the heat flow lines can be constructed, are saved in a .flw file. 
The heat flow densities at each node are saved in a .flx file. 

B.7. Output 

A text output window displays a summary of input data values (pixel size, global measurements 

per colour, thermal properties, triangulation size per colour, calculation parameters) and 
calculation results (number of system nodes, obtained calculation quality, obtained temperature 
range per colour, total heat flow per boundary condition colour). 
 
Global results are shown (if applicable), as linear thermal transmittance and equivalent thermal 
transmittance, calculated based on measurements of flanking elements as marked in the bitmap 

or on heat flows from designated boundary condition colours. 
For a window frame the frame thermal transmittance is calculated based on the European 
standard EN ISO 10077-2 or standard ISO 15099. 

The temperature factor or Condensation Index (corresponding to the lowest temperature on the 
internal surface) is given, and the relative humidity above which surface condensation occurs. 

 

A graphic output window shows a picture of the input bitmap (with indication of colour numbers) 
or a vector image based on the triangulation file with calculation results (according to the chosen 

view options, with e.g. isothermal lines, heat flow lines, filled or not). The graphic output image 
can be saved into a bitmap image with user defined width and height (measured in pixels) in 
PNG format. The graphic output can be complemented with various text labels, set by the user, to 

show material properties, node temperatures, condensation zones, heat flows. 
 
BISCO offers two ways to generate a report: either a pdf document can be generated 

automatically, with customizable contents, or an external Microsoft Word document (derived 

from a predefined template document, with fixed bookmarks and macros) that contains all 
elements output by BISCO in a user defined layout and format. The MS Word report generator is 

driven by a graphic report script (for the definition of up to 8 graphic output images) and creates 
several fixed text output files. 
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Example of Graphic output menu Example of Text output menu 
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CHAPTER C INPUT COMMANDS 

C.1. BISCO input data 

The BISCO input data are available on disk in a BSC file and a BMP file, both in the same 
directory. 
The BMP file is a 256-colours (uncompressed or run-length encoded compressed) Microsoft 
Windows Bitmap. 

The BSC file is a text file containing all other input: file name of the BMP file, pixel size, 

triangulation measures, thermal properties for the different colours in the bitmap, calculation 
parameters, output parameters. 
Because the BSC file only stores the file name of the corresponding BMP file, both BSC and BMP 
files must be in the same directory. It is a good practice to give both files the same file name. 

C.2. BISCO start-up 

When BISCO is launched, the default colour database ColourDatabase.bsc is read (see J.2J.2) to 

initialise the thermal properties. Then the parameter file BISCO.prm is read (see A.11) to load 

global program settings. 
There is no visual feedback in the initial screen of BISCO to indicate if the ColourDatabase.bsc 

and/or BISCO.prm are not found and thus not read. 

C.3. File commands 

  
 
File → Open… 
Opens an existing BSC file by selecting it in the File Open dialog box. The thermal properties, pixel 
size, triangulation mesh sizes, calculation parameters and output settings from the selected BSC 

file are read. The linked BMP file is loaded and displayed in the Bitmap window. 
Thermal properties from a previous open document (of the current BISCO session) for colours not 
present in the new loaded bitmap, remain loaded in memory. 
 
File → Open DXF… 
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Opens an existing DXF file by selecting it in the File Open dialog box. The default colour database 

ColourDatabase.bsc is read first (see J.2J.2) to initialise the thermal properties. 
The DXF file can be sent to BiscoDxf to edit the conversion to a BMP file (see H.2H.2), or it can be 
converted automatically (see H.3H.3).  
 

File → Open Bitmap… 
Creates a new BISCO document by selecting an existing bitmap (BMP file). 
The new document gets the same file name as the file name of the selected bitmap. 
If no document has previously been opened, the default data from ColourDatabase.bsc and 
BISCO.prm (see C.2) are used, both of which can be customized (see J.2J.2 and A.11). 
As an alternative, a customized BSC template file could be opened before opening the BMP file, 

as the thermal properties from the previous open document remain active in memory. Use the 
same colour palette, and the same colour numbers in the new bitmap to retrieve the existing 
thermal properties. Only the thermal properties for colours not occurring in the BSC template file, 

must be defined. 
The pixel size and triangulation meshes are set according to the user-defined values in Settings 
→ Default Measures…. (see A.10). 

 
File → Open Colour Database… 
The colour database contains predefined material and boundary condition properties (stored in 
the file ColourDatabase.bsc in the application data folder, see J.2), which is loaded at every 
BISCO start-up (see C.2). It is advisable to add frequently used materials and boundary 
conditions to the colour database. 

These predefined colours of the colour database are then available for new colours in any 

document. 
 

File → Close 
Closes the active document (after a prompt to save it), but the thermal properties, pixel size and 
calculation parameters remain present in memory, for further use in the next opened document  

(File → Open Bitmap…, File → Open… or File → Open DXF…). 
 
File → Save 
Saves the current document (BMP file and BSC file). The file names are displayed in the BISCO 

application title bar (BSC file) and in the Bitmap window title bar (BMP file). The files are only 

written when there were modified, which is indicated by an asterisk after the respective file 

names. 
 

File → Save As… 
Allows to save the open document as new files (BMP file and BSC file). The file paths of the new 
BMP and BSC files can be entered in two successive File Save dialog boxes (first for the BMP file, 
then for the BSC file). Use the same data file folder for both BMP and BSC files (because the BSC 
file does not save the directory of the BMP file, but only the file name). 

 
File → Batch Processing…: run multiple simulation files (BSC) successively, see section D.7. 
 

File → DXF Batch Calculation…: generate successively run multiple simulation files (BSC) from a 
series of prepared DXF files, see section D.8. 
 
File → Exit 

Quits the current session of BISCO. 
Global program parameters are saved into the parameter file BISCO.prm. 
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C.4. BISCO program layout and input windows 

The input in BISCO is organised in several windows. When a BISCO document is opened (e.g. 
with File → Open Bitmap… or File → Open…), the following windows are opened: 

Bitmap window (top left) with an image of the BMP file. 

The BMP file name is displayed in the title bar. 

Measures window (top right) with measurements per colour present in the BMP file. 

Colours window (bottom left) with thermal properties per colour present in the BMP file. 

Border U Values window (bottom right) with U-values of wall sections at the bitmap borders. 

When borderline boundary conditions are present in the opened document, also: 

Borderline BCs window (middle right). 

The name of the current document (BSC file name) is displayed in the BISCO application title bar. 

 
The Edit submenu (or corresponding buttons in the toolbar) allows to open and activate an input 
window. The active input window has a blue title bar. 
 

   
 
Other input windows are: 

Distances window with distances in the bitmap. 

Graphic Report Definition window with options for report pictures. 

C.5. Document notes 

In the Notes dialog box (via Edit → Notes…) some comments can be written for the current 
document, e.g. project description, operator, date. These notes are saved in the BSC file. 
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C.6. Bitmap window 

The Bitmap window is automatically loaded when opening a document. 

The title bar shows the corresponding BMP file name. An asterisk after the file name indicates 
that the bitmap is modified (after a bitmap edit operation) and should be saved. 
 

The Bitmap window shows a view of the bitmap image. 

When the Bitmap window is made active (e.g. by clicking on its title bar), the coordinates of the 

mouse point in the bitmap are shown in the status bar (at the left bottom of the BISCO 

application). 
 

    
 

The following coordinates are displayed: 
- Pixel coordinates (xp,yp). 

The pixel coordinate xp is measured from the left bitmap border. 
The pixel coordinate yp is measured from the top bitmap border. 
The pixel coordinates always have integer values. 

- Colour number of the current bitmap pixel. 
- Scaled coordinates (xs,ys). 

The coordinates are scaled using the pixel size, as defined in the Measures window. 

The scaled coordinate xs is the distance from the left bitmap border. 

The scaled coordinate ys is the distance from the top bitmap border. 
The scaled coordinates have of a resolution of 0.0001 m. 

 

When the <Shift> key is held down, relative coordinates are displayed in the status bar (after a 
mouse move). 
Relative coordinates are measured against a new origin defined by the last clicked point. 

 

If another input window is active, the Bitmap window highlights the current item with dotted lines. 

C.7. Zoom commands 

Zoom submenu 

  
 

Zoom in/out via the mouse wheel 
The commands Zoom → Zoom In and Zoom → Zoom Out can also be carried out using mouse 

wheel scrolling (when the Bitmap window is active). 

Rotating forward (away from the user) zooms in with the mouse point as zoom centre. 
Rotating back (toward the user) zooms out. 
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Zoom → Select 

Enters “select mode”. A following click with the left mouse button on the bitmap selects the colour 

under the mouse point as current colour in the Colours window and Measures window. 

Colour selection can also be obtained by a right mouse button click from “pan mode”. 

From the Distances window a click using the left mouse button on the bitmap (in select mode) 
defines a distance, as explained in section C.15. 

 
Zoom → Pan 
Enters “pan mode” (only possible for a zoomed view). A following arrow key stroke (left, right, up, 
down) or mouse drag using the left mouse button recentres the view. 
Pan mode is activated automatically by holding down the mouse wheel. 

 
Zoom → Zoom Window 
Enters “zoom window mode”. Then a zoom rectangle can be drawn on the bitmap with click and 

drag, that defines the next zoom view. The zoom operation can be cancelled by pressing <Esc> 
before releasing the left mouse button. 
 
Zoom → Zoom In 

Enters “zoom in mode”. A following click using the left mouse button on the bitmap defines the 
centre point of the next zoomed view. The zoom factor is 80 %. 
Zooming in can also be obtained by rotating forward using the mouse wheel. 
 

Zoom → Zoom Out 

Zooms out using a zoom factor of 125 %, or calls Zoom → Zoom Total if the image becomes too 

small. 
Zooming out can also be obtained by a right mouse button click from “zoom window mode” or 
“zoom in mode”, or by rotating back using the mouse wheel. 

 
Zoom → Zoom Total 
Shows total bitmap (the original view). 

 
Zoom → Previous View 
Shows the previous zoom view. (More than one previous view cannot be recalled.) 

 
Zoom → Numbers… 

Opens a dialog box with the pixel coordinates of the current zoom view. By editing the 
coordinates the zoom view can be changed. A zoom view can be restored later (i.e. reset to the 
same zoom factor and position) via these zoom numbers. 

C.8. Bitmap drawing functions 

The active drawing colour is defined by the row of the current cell in the Colours window. 
 
Bitmap → Draw : enter “draw mode”. 

In draw mode pixels and lines can be drawn using the active drawing colour. 
Drawing a pixel: set the mouse point on the pixel and click the left mouse button.  
Drawing a line: hold down the <Shift> key, move the mouse (now the status bar shows the 
relative coordinates from the last painted pixel) to the end pixel of the line and click the left 
mouse button. A line is drawn from the last clicked pixel to the new clicked pixel. 
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Bitmap → Line : enter “line mode”. 

A line is drawn from the start point to the end point using click and drag with the left mouse 
button. 

 
Bitmap → Rectangle : enter “rectangle mode”. 

A rectangle is filled using click and drag with the left mouse button. 

 
Bitmap → Fill : enter “fill mode”. 

When the left mouse button is clicked, the colour zone around the pixel under the mouse point is 
filled. The flood fill stops at the border with any other colour. 

 
Bitmap → Edit using BiscoBmp : allows more extensive bitmap editing (see Chapter IChapter I). 

C.9. Measures window 

The Measures window is the input window for the pixel size and triangulation mesh sizes per 

colour. The triangulation mesh sizes are used in generating the automatic triangulation grid as 
part of a thermal system calculation. 

The current colour (defined by the row of the current cell) is highlighted in the Bitmap window by 

dotted contour lines. 
 

  
 

Dimensions 

The first line of the Measures window shows the size of 1 pixel (width = height) in the bitmap. The 

default value, used when opening a Bitmap or DXF file, can be set in Settings → Default 

Measures…. 
The second line shows the width and height of the total bitmap. 
The following lines list the width and height of the surrounding rectangle for each colour (defined 
by colour index in the colour palette) in the bitmap, and the area (= number of pixels in the 
bitmap having this colour). 
The measures are shown both in pixels (not editable) and in metres (editable). 
When any width or height is changed, all other widths and heights are modified proportionally. 
 

Colour zones 
The number of zones per colour is displayed in the column “Zones”. 

A colour zone is a connected pixel area of the same colour in the bitmap. Each colour in the 
bitmap can occur in one or more zones. The different zones of the same colour are separated 
from one another by other colours. 
Colours of type BC_FRE_S, BC_FREE, BC_SKY, BC_NOSKY and TRANSMAT must consist of only 
one zone. Use the function Bitmap → Split Zones… to split multi-zone colours. 
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Sometimes the column “Zones” in the Measures window is cleared (e.g. after a draw or fill 

operation affecting only a small number of pixels). Then call the function Bitmap → Calc Zones to 

recalculate and display the number of zones. 
 
Triangulation mesh sizes 
Per colour a triangulation mesh size can be edited. 

Only the triangulation mesh sizes of material colours (type MATERIAL, EQUIMAT or TRANSMAT) 
are enabled and used in a triangulation mesh generation. 
Editing the triangulation mesh size on the second line (for the total bitmap) modifies the 
triangulation mesh sizes of all colours. The default value, used when opening a Bitmap or DXF 
file, can be set in Settings → Default Measures…. 

The purpose of different mesh sizes is to influence the calculation accuracy and speed. 

C.10. Colours window 

The Colours window is the input window for thermal properties of materials and boundary 

conditions. Each row refers to the properties of one colour. 

The selected colour (defined by the row of the selected cell) is highlighted in the Bitmap window 

by dotted contour lines. 
 

 
 

Cells with a white background in the Colours window are directly editable by the user. If the 
background is red, this means that additional user inputs are needed via a dialog box. If the 

additional user inputs are given, the resulting property in the Colours window is in blue font. 

 
Colour number (1st column) 
Index (between 0 and 255) in the colour palette of the bitmap. 
 
Colour value (2nd column) 
Select a cell and press Enter (or double click) to edit the colour value. 

If a colour value is changed, then the colour palette of the bitmap is modified, which requires to 
save the modified BMP file. 
The colour value is edited in a Colour dialog box. 
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Type (3rd column) 
Toggle value having one of the following values (press Enter to switch), which defines the 
meaning of the colour: 

- MATERIAL: material defined by thermal conductivity. 

- EQUIMAT: equivalent material defined by a single equivalent thermal conductivity (e.g. 
air cavity or a screw). The equivalent conductivity is typically calculated from standard 
rules (D.1.1). 

- BC_SIMPL: simplified boundary condition (with known temperature and global surface 
heat transfer coefficient for combined convection and radiation). 

- BC_FRE_S: enclosure with unknown (free-floating) internal temperature, possible 
additional internal heat power, simplified surface heat transfer defined by a global 
surface heat transfer coefficient and possible additional surface heat flux. 

The unknown environmental temperature is calculated from the heat balance equation: 
Σ (convective heat transfer from environment to surface) = injected convective heat 

power. 
With the RADCON module (which supposes separate convection and radiation based on view 
factors, see Chapter KChapter K) also: 

- BC_FREE: surface boundary condition modelled as enclosure with unknown (free-

floating) air temperature, radiation between the surfaces (using the infrared emissivities of 
the adjacent materials) and convective heat transfer coefficient. 

- BC_SKY: surface boundary condition modelled as an environment with defined air and 
radiation temperature (the sky) and convective heat transfer coefficient. 

- BC_NOSKY: surface boundary condition modelled as an environment with defined air 
temperature, no radiation to the environment (no sky) and convective heat transfer 
coefficient. 

- TRANSMAT: transparent material defined by thermal conductivity, and radiation between 
the surfaces (using the infrared emissivities of the adjacent materials). 

 
Standard (last column) 
Standard used for the automatic calculation of eq or hc (cf. section D.1). 

− NIHIL: no automatic calculation of thermal properties. 
− EN10077: standard EN ISO 10077-2. 
− EN6946: standard EN ISO 6946. 
− EN12631: standard EN ISO 12631. 

− EN673: standard EN 673. 
− ISO15099: standard ISO 15099. 

Within each standard different subtypes can be chosen. 
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Subtype (4th column) 
Subtype toggle value to define automatic calculation of equivalent thermal conductivity (type 
EQUIMAT and TRANSMAT) or convective heat transfer coefficient (BC_FREE, BC_SKY and 
BC_NOSKY). The accessible subtypes are dependent on the actual type (3rd column) and 

standard (last column). 
For type EQUIMAT: 

- NIHIL: user defined thermal conductivity (no automatic calculation). 
- CAVITY: calculated equivalent thermal conductivity for unventilated air cavity (EN10077, 

EN6946 or ISO15099). 
- CAVITY_E: calculated equivalent thermal conductivity for slightly ventilated air cavity 

(EN10077 or ISO15099). 
- LAYER: calculated equivalent thermal conductivity for unventilated air/gas layer (EN6946, 

EN673 or ISO15099). 

For type BC_SIMPL: 
- NIHIL: user defined global heat surface coefficient. 
- HI_NORML: normal internal heat transfer (EN10077). 
- HI_REDUC: reduced internal heat transfer (EN10077). 
- HI: internal heat transfer (EN6946). 
- HE: external heat transfer (EN10077, EN6946 or ISO15099). 

- HI_CAV_E: slightly ventilated air cavity at the internal surface (EN10077 – radiosity 
method). 

- HE_CAV_E: slightly ventilated air cavity at the external surface (EN10077 – radiosity 

method). 
For type BC_FREE: 

- NIHIL: user defined convective heat transfer coefficient (no automatic calculation). 

- CAVITY: calculated convective heat transfer coefficient for unventilated air cavity 
(EN6946). 

- LAYER: calculated convective heat transfer coefficient for unventilated air/gas layer 

(EN6946 or EN673). 
- CONVEC: calculated convective heat transfer coefficient for large air space. 

For type BC_SKY or BC_NOSKY: 

- NIHIL: user defined convective heat transfer coefficient (no automatic calculation). 
- CONVEC: calculated convective heat transfer coefficient for natural convection (ISO15099 

or NIHIL). 
For type TRANSMAT: 

- NIHIL: user defined thermal conductivity (no automatic calculation). 
- CAVITY: calculated equivalent thermal conductivity for unventilated air cavity (EN10077, 

EN6946 or ISO15099). 
- LAYER: calculated equivalent thermal conductivity for unventilated air/gas layer (EN6946, 

EN673 or ISO15099). 

For more details on the corresponding calculation procedures see D.1. 
 
Physical heat flow direction (5th column) 

- HOR: horizontal heat flow. 

- UP: upward heat flow. 
- DOWN: downward heat flow. 
- ANY: user-defined heat flow direction (by defining the inclination angle of the construction 

element and assuming a heat flow perpendicular to the construction element) 
 

Geometric heat flow direction (6th column) 
Heat flow direction with reference to the X and Y directions of the screen: 
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- X: heat flow parallel to the X axis of the screen. 

- Y: heat flow parallel to the Y axis of the screen. 
- DIR: heat flow following the local temperature gradient. 

 
Name (7th column) 

Name of material or boundary condition. 
 
Thermal properties (next columns): 

- ε1 / ε2 [- / -]: infrared emissivities (values between 0.001 and 1) at warm and cold sides of 

cavity (type EQUIMAT). 
Editing opens a dialog box for definition of the values. 
 

  
 

If any emissivity differs from 0.9 (the default value), the corresponding grid cell in the 

Colours window is highlighted in blue. 
- λ [W/(m.K)]: thermal conductivity of material (MATERIAL), equivalent material (EQUIMAT) 

or transparent material (TRANSMAT). 

For types EQUIMAT and TRANSMAT, subtype LAYER and standard EN673 or ISO15099, 
editing opens a dialog box for definition of the glazing cavity properties (see D.1). 
For types EQUIMAT and TRANSMAT, physical flow direction ANY and standard EN6946, 

editing opens a dialog box for definition of the inclination angle (see D.1). 
 

 
 

- ε [-]: infrared emissivity (value between 0 and 1) of material surfaces (MATERIAL, 

EQUIMAT) adjacent to boundary condition or cavity with radiative heat transfer. 
- θ [°C]: temperature of simplified boundary condition (BC_SIMPL). 

- h [W/(m2.K)]: global surface heat transfer coefficient (BC_SIMPL, BC_FRE_S). 
For type BC_SIMPL, subtype HE and standard ISO15099, editing opens a dialog box for 
definition of the wind speed to determine the convective heat transfer (see D.1). 
 

 
 

- q [W/m2]: heat flux dissipated onto adjacent material surfaces (BC_SIMPL, BC_FRE_S, 
BC_FREE, - BC_SKY, BC_NOSKY). 

- θa [°C]: air temperature (BC_SKY, BC_NOSKY). 

- hc [W/(m2.K)]: convective heat transfer coefficient (BC_FREE, BC_SKY, BC_NOSKY). 
For type BC_FREE, physical flow direction ANY and standard EN6946, editing opens a 
dialog box for definition of the inclination angle (see D.1). 
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For type BC_FREE, subtype LAYER and standard EN673, editing opens a dialog box for 

definition of the glazing cavity properties (see D.1). 
For type BC_SKY, subtype CONVEC and standard ISO15099, editing opens a dialog box 
for definition of the glazing model height (and inclination angle for physical flow direction 
ANY) 

 

 
 

- Pc [W]: convective power dissipated in the environment (BC_FRE_S, BC_FREE). 
- θr [°C]: radiation temperature (BC_SKY). 

C.11. Colour functions 

The colour functions are available through the Colours submenu. 

 

  
 
Colours → List All 
List all 256 colours of the colour palette of the bitmap. 

The properties of colours not present in the bitmap are greyed. 

 
Colours → List Defined 

List all colours present in the bitmap and colours having defined thermal properties. 
Defined thermal properties of colours not present in the bitmap are greyed, and originate from 
the colour database or previous loaded BSC files. 
 
Colours → List Present (default option when opening a BISCO document) 
List only the colours present in the bitmap. 
 

Colours → Load Material… 
Load predefined material properties. 
From the Material Database dialog box choose a database file (file with extension .phm from the 

directory …\Physibel\Materials, see A.7), a material group and then a material. 
The database files (with extension .phm) can be edited using the program MatEdit.exe, also in the 
directory …\Physibel\Materials. 
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Colours → Convert To TRANSMAT 
Function that allows to switch from the “single equivalent thermal conductivity method” to the 
“radiosity method” for the definition of heat transfer within cavities according to EN ISO 10077-2; 
or from using the radiative heat transfer coefficient hr for linearized radiant heat flow to using the 
detailed radiation heat transfer calculation for the definition of heat transfer within cavities 

according to ISO 15099: 
- Convert all colours of type EQUIMAT, standard EN10077 or ISO15099, subtype CAVITY into 

type TRANSMAT. TRANSMAT cavities are separated from BC_SIMPL boundary conditions 
by a thin EQUIMAT border line. 

- Convert all colours of type EQUIMAT, standard EN10077, subtype CAVITY_E into type 
BC_SIMPL, subtype HI_CAV_E (if adjacent to colour of type BC_SIMPL, subtype 
HI_NORML or HI_REDUC) or HE_CAV_E (if adjacent to colour of type BC_SIMPL, subtype 
HE). 
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The calculation parameters “Recalculate before each iteration cycle” and “Use solution 

temperatures” are switched on (see D.2.4). 
 
Colours → Convert To EQUIMAT 

Function that allows to switch from the “radiosity method” to the “single equivalent thermal 
conductivity method” for the definition of heat transfer within cavities according to EN ISO 10077-
2; or from using the detailed radiation heat transfer calculation to using the radiative heat 
transfer coefficient hr for linearized radiant heat flow for the definition of heat transfer within 
cavities according to ISO 15099: 

- Convert all colours of type TRANSMAT, standard EN10077 or ISO15099, subtype CAVITY 
into type EQUIMAT. 

- Convert all colours of type BC_SIMPL, subtype HI_CAV_E or HE_CAV_E, standard 

EN10077 into type EQUIMAT, standard EN10077, subtype CAVITY_E. 
 
Colours → Cluster EQUIMAT… 

Reduce the number of EQUIMAT cavities (of subtype CAVITY) by clustering them for small 
differences in equivalent thermal conductivity. 
This function can be useful for geometries with a large number of air cavities with around the 
same size or when preparing a BISCO project before importing to TRISCO or SOLIDO. 

 

 
 
Colours → Copy Row and Colours → Paste Row 

Copy all properties from one colour to another colour. 
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C.12. Bitmap functions 

  
 
Bitmap → Size… 

Allows to expand or shrink the bitmap at the borders. 

In the Bitmap Size dialog box, enter the new width and height (in pixels or in metres). 
Then adjust the image placement by entering the top, bottom, left and right margins.  
These margins can be positive or negative. 

New margins are adjusted at the opposite side if the check box “Keep total dimensions when 
editing margins” is marked; otherwise the total dimension is adjusted. 
Press the command button “Apply” to update the other values after editing. Using the <tab> key 
has the same result. 
When the bitmap is extended at a border (top, bottom, left and/or right), the pixels at that border 
are copied if the check box “Use border colours” is marked. Otherwise colour number 1 is used for 
the new border margin. 
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Bitmap → Crop Bitmap Borders… 
Removes the strip of a uniform colour at the specified bitmap borders (left, right, top, bottom), if 
present. 
 

  
 

Bitmap → Insert/Delete Pixel Band… 

Allows to expand or shrink the bitmap around a given reference pixel inside the bitmap. 

The reference pixel is defined by its pixel coordinates (integer numbers). 

These coordinates are initialised by the last clicked pixel (using the left mouse button) in “select 

mode” (Zoom → Select). 

The pixel band to be inserted or deleted is vertical (i.e. parallel to Y) or horizontal (i.e. parallel to 
X). 

Insertion copies the pixel values of the pixel column (vertical band) or pixel row (horizontal band) 
through the reference pixel. 

Deletion removes the pixel columns (vertical band) or pixel rows (horizontal band) starting from 
the column or row through the reference pixel. 
The function can be useful to widen or shrink a material layer (e.g. insulation) in the bitmap. 
 



28 Manual BISCO v13.0  

  
 
Bitmap → Resize Pixel… 

Allows to enter a new (e.g. rounded) pixel size. 
The bitmap is repainted based on the new pixel size, resulting in a different bitmap width and 
height in pixels. The bitmap width and height in metres remain unchanged. 
It is recommended to use a new pixel size that is larger than the current one, because slanting 
lines can be transformed in irregular staircase lines. 
The function can be useful to simplify the BMP file before e.g. merging multiple BMP files or 
before importing the BISCO project in TRISCO for 3D analysis. 
 

  
 
Bitmap → Rotate 90° 

Rotates the entire bitmap over 90° in clockwise orientation. 
 
Bitmap → Import Bitmap… 

Imports a BMP file (to be selected from a File Open dialog box) and paints it over the existing 
bitmap with reference to a given pixel. 

The reference pixel (inside the current bitmap in the Bitmap window) is defined by its pixel 

coordinates (integer numbers). 
These coordinates are initialised by the last clicked pixel (using the left mouse button) in “select 

mode” (Zoom → Select). 

Define the position of the reference pixel against the imported bitmap (top left, top right, bottom 
left, bottom right). 
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Bitmap → Load Palette… 

Import the colour palette of another BMP file (to select in the File Open dialog box). 
All colour numbers of the original bitmap get new colour values from the imported colour palette 

(see B.3). 
 
Bitmap → Change Colour… 

Assigns a new colour number to the active colour (selected in the Colours window or Measures 

window). 

 

 
 

Bitmap → Clean Colour… 

Deletes small pixel zones of the active colour (selected in the Colours window or Measures 

window), the maximum size of which can be set by the user. The deleted pixel zones are replaced 

by the adjacent colours. Hard materials are (preferably) not expanded when a colour zone 
should be replaced by adjacent colours; adjacent soft materials (with low thermal conductivity) 
are used instead. Hard materials are defined as having a thermal conductivity above a user-
defined threshold value (“Avoid replacing with material with lambda >”). 

 

 
 
Bitmap → Merge Colours  

Merges all colours having the same properties as the active colour (selected in the Colours 

window or Measures window). 

All corresponding properties shown in the Colours window which are defined by the user must be 

exactly identical. 
The resulting unified colour receives the colour number and colour value of the original active 
colour. 
 
Bitmap → Calc Zones 

Sometimes the column “Zones” in the Measures window (containing the number of zones per 

colour) is cleared (e.g. after a draw or fill operation affecting only a small number of pixels). 

Then call this function to recalculate and display the number of zones per colour. 
 
Bitmap → Split Zones… 

Split a multi-zone colour (see “Zones” column in the Measures window with value larger than 1) 

into a set of single-zone colours with different colour numbers. 
First select the colour (using Zoom → Select and clicking upon the colour in the bitmap). 

Several subtasks can be executed using Bitmap → Split Zones…: 

1. Delete all zones of the active colour that are smaller than a given area (expressed as a 
number of pixels) and replace the deleted zones with adjacent colours with lambda greater 

than a threshold value. 
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2. Option to detect grooves and interconnections smaller than 2, 5 or 10 mm. 

This is useful when air cavities (EQUIMAT/TRANSMAT) must be split at interconnections, 
because smaller cavities have smaller equivalent thermal conductivities (cf. EN ISO 10077-2 

and ISO 15099); and to detect surface grooves with that can be treated as an unventilated 
cavity instead of being exposed to the boundary conditions (cf. EN ISO 10077-2 and ISO 

15099). 
3. All zones larger than a given area are split into single-zone colours, assigned a free colour 

number starting from a user-defined colour number (e.g. 192 which is the first grey tinted 
colour in the default palette). Zones smaller than the given area are grouped into 1 colour of 
type MATERIAL with a fixed (automatically calculated) lambda value. 

The function is useful for colours of type BC_FRE_S, BC_FREE, BC_SKY, BC_NOSKY or 
TRANSMAT, which require single-zone colours to be valid. 

In case this function is used to split of grooves at the surface of a frame from a boundary 
condition, the split-off zones are automatically set to type EQUIMAT, subtype CAVITY. 
  

 
 

Bitmap → Set Reduced Heat Transfer… 
Detects the zones with reduced heat transfer inside an interior boundary condition against a 
window frame as defined in EN ISO 10077-2. 

• Choose Zoom → Select. 
• Click inside the interior boundary condition (with colour type BC_SIMPL, subtype 

HI_NORML, standard EN10077) in the bitmap. 
• Call the function Bitmap → Set Reduced Heat Transfer…. 
• Choose the direction of the heat flow (with reference to the bitmap): leftwards, rightwards, 

upwards or downwards. 
• Define the colour number for the new zone with reduced heat transfer. 

All zones with reduced heat transfer (i.e. increased surface resistance) are coloured using the new 
colour, with colour number as defined in the dialog box. 
The new colour gets the colour type BC_SIMPL and subtype HI_REDUC. 
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Bitmap → Split Interior BC… 
Splits the interior boundary condition in 3 parts to obtain different boundary condition colours for 
the frame, the edge-of-glazing and the center-of-glazing, in order to calculate the equivalent U-

value of each part according to NFRC 100 and ISO 15099. 
 
The interior boundary condition is first split at the sightline(s) of the glazing to define where the 
frame zone begins, determined in the bitmap as the first pixel line that differs from the pixel line 
at the bitmap border of the side of the glazing(s). From there, the edge-of-glazing zone is 
defined. 

 
• Choose Zoom → Select. 
• Click inside the interior boundary condition (with colour type BC_SKY, subtype CONVEC, 

standard ISO15099) in the bitmap. 
• Call the function Bitmap → Split Interior BC…. 
• Choose the direction of the heat flow (with reference to the bitmap): leftwards, rightwards, 

upwards or downwards. 
• Select if the glazing product is in an upright position or in a 20° sloped position (see D.1.4). 

• Define the colour numbers of the interior boundary condition for the frame and for the 
edge-of-glazing, and the colour number of the window frame material (used to 
determine where to split the interior boundary condition). 

• Set the length of the edge-of-glazing zone (typically either 63.5 mm or 254 mm). 
• Select the frame type to determine the convective heat transfer coefficients of the interior 

boundary conditions at the frame according to NFRC 100. 

 

Bitmap → Fill Line Drawing (enabled if exactly two colours are present in the bitmap) 

Splits a 2-colours bitmap (formatted as 256-colours BMP file), consisting of a foreground colour 
(line drawing) and a background colour, into a multi-coloured image. The original lines are 

removed by thinning. 
In a first step all zones surrounded by lines are filled with free colours (different from the line 
colour of the line drawing). It is important that the lines in the line drawing are closed, because a 

flood fill technique is used. In a second step the original lines (with foreground colour) are 
removed by thinning. 
This function is useful when the available DXF has only 1 layer containing all different materials 

(e.g. output from Sketchup → Export → 2D Graphic). From such a DXF file a 2-colours bitmap can 

be generated by BiscoDxf.  

 
Bitmap → EN ISO 10077-2 Preparation 
Combines automatically all necessary steps to prepare a bitmap and the BISCO data to enable a 
window frame calculation according to EN ISO 10077-2. 
The parameters for this automatic preparation function can be set in Settings → EN ISO 10077-2 

Settings… (A.10). 
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The EN ISO 10077-2 Settings are saved in the parameter file BISCO.prm (see A.11) at program exit. 
 

Executing the Bitmap → EN ISO 10077-2 Preparation menu function, the following sequence of 

bitmap functions are carried out: 
- All bitmap zones of the “undefined cavities & BCs” colour smaller than the user-defined 

number of pixels are deleted (as with the function Bitmap → Clean Colour…). 

- The interior and exterior boundary conditions are filled in the bitmap (if not yet present) at 
the left and right borders (if the window frame is vertically positioned in the bitmap, and 
there is a free strip at the left and right borders of the bitmap), or at the top and bottom 
borders (if the window frame is horizontally positioned in the bitmap, and there is a free 
strip at the top and bottom borders of the bitmap). The free strips must have the 
“undefined cavities & BCs” colour. 
The colour numbers of the interior and exterior boundary conditions, and the default 

position of the interior boundary condition (left or right for heat flow parallel to X; top or 
bottom for heat flow parallel to Y) are user-defined settings. 

- All colours of type EQUIMAT standard EN10077 already present are cleaned and 
subsequently split (as with the function Bitmap → Split Zones…) into single-zone colours, 

assigned a free colour number starting from the original colour number. 
- All air cavities larger than a user-defined area of the window frame of the “undefined 

cavities & BCs” colour are split (as with the function Bitmap → Split Zones…) and assigned 

a free colour number starting from a user-defined colour number (e.g. 192 which is the 

first grey tinted colour in the default palette). The resulting cavities have either type 
EQUIMAT or type TRANSMAT. 
Zones smaller than the given area are grouped into 1 colour of type MATERIAL with a 
fixed (automatically calculated) lambda value. 
TRANSMAT cavities are separated from BC_SIMPL boundary conditions by a thin 
EQUIMAT border line. 
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- The length of the insulation panel(s) in the bitmap gets the user-defined length (e.g. 190 

mm). The function Bitmap → Size… is used to expand or shrink the bitmap. 

- At the interior side the zones of reduced heat transfer are delimited (cf. Bitmap → Set 

Reduced Heat Transfer…), using the user-defined colour number of “Interior (reduced)”. 
- If no distances are yet defined, two distances representing the projected length of the 

frame and the length of the insulation panel are defined. 

- The properties of the Derived Thermal Properties (see D.10.2) are set to report the U-value 
of the window frame (including the ‘f’ subscript).  

 
Bitmap → NFRC 100/500 Preparation 
Combines automatically all necessary steps to prepare a bitmap and the BISCO data to enable a 
window frame calculation according to NFRC 100/500. 

The parameters for this automatic preparation function can be set in Settings → NFRC 100/500 

Settings… (A.10). 
 

 
 
The NFRC 100/500 Settings are saved in the parameter file BISCO.prm (see A.11) at program exit. 
 
Executing the Bitmap → NFRC 100/500 Preparation menu function, the following sequence of 

bitmap functions are carried out: 
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- All bitmap zones of the “undefined cavities & BCs” colour smaller than the user-defined 

number of pixels are deleted (as with the function Bitmap → Clean Colour…). 

- The interior and exterior boundary conditions are filled in the bitmap (if not yet present) at 

the left and right borders (if the window frame is vertically positioned in the bitmap, and 
there is a free strip at the left and right borders of the bitmap), or at the top and bottom 
borders (if the window frame is horizontally positioned in the bitmap, and there is a free 
strip at the top and bottom borders of the bitmap). The free strips must have the 
“undefined cavities & BCs” colour. 
The colour numbers of the interior (glass) and exterior boundary conditions, and the 

default position of the interior boundary condition (left or right for heat flow parallel to X; 
top or bottom for heat flow parallel to Y) are user-defined settings. 

- All air cavities larger than a user-defined area of the window frame of the “undefined 

cavities & BCs” colour are split (as with the function Bitmap → Split Zones…) and assigned 

a free colour number starting from a user-defined colour number (e.g. 192 which is the 
first grey tinted colour in the default palette). The resulting cavities have either type 

EQUIMAT or type TRANSMAT. 
Zones smaller than the given area are grouped into 1 colour of type MATERIAL with a 
fixed (automatically calculated) lambda value. 
TRANSMAT cavities are separated from BC_SIMPL boundary conditions by a thin 

EQUIMAT border line. 

- The length of the glazing in the bitmap gets the user-defined length (e.g. 150 mm). The 

function Bitmap → Size… is used to expand or shrink the bitmap. 

- If no distances are yet defined, three distances representing the projected lengths of the 

frame, the edge-of-glazing zone (defined by the user, typically either 63.5 mm or 254 
mm) and center-of-glazing zone. 

- At the interior side the boundary condition is split into 3 parts to obtain different boundary 
condition colours for the frame, the edge-of-glazing and the center-of-glazing, in order 
to calculate the equivalent U-value of each part according to NFRC 100 and ISO 15099 

(see Bitmap → Split Interior BC…). 

- The properties of the Derived Thermal Properties (see D.10.3 and 0) are set to report the 
U-value of the window frame (including the ‘fr’ subscript), the U-value of the edge-of-
glazing (including the ‘eg’ subscript) and the Condensation Index. 

- The calculation parameter linear radiation (D.2.3) is set to false and Recalculate before 

each iteration cycle and Use solution temperatures (D.2.4) are set to true and the model 
properties (D.2.5) are set according to the user-defined inputs. 

C.13. Border U Values window 

The Border U Values window allows to derive 1D U-values at the bitmap’s borders, which are 

used in the calculation of derived thermal properties (linear thermal transmittance and thermal 
transmittance (see D.10). 
 

The Border U Values window automatically calculates the U-values at the bitmap borders based 

on 1D heat transfer through material layers of type MATERIAL, EQUIMAT or TRANSMAT, or cavity 

layers of type BC_FREE between two different boundary conditions of type BC_SIMPL (or 

BC_FRE_S) or BC_SKY along the outermost pixel strip at the bitmap borders. 
For TRANSMAT and BC_FREE layers, the U-value shown is calculated assuming linear radiation 
using the black linear radiation coefficient ℎ𝑟𝑏 as defined in the Calculation Parameters dialog 
box (D.2.3), so the thermal resistance 𝑅 of such a layer is calculated as: 

𝑅 =
1

(ℎ𝑐 + ℎ𝑟)
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ℎ𝑟 = ℎ𝑟𝑏 ⋅
1

1

𝜀1
+

1

𝜀2
−1

  

Where 𝜀1 and 𝜀2 are the surface emissivities of the colours bordering the TRANSMAT/BC_FREE 
layer. 
For BC_SKY boundary conditions, the U-value shown is calculated assuming linear radiation 
using the black linear radiation coefficient ℎ𝑟𝑏 as defined in the Calculation Parameters dialog 
box (D.2.3): 
ℎ𝑟 = ℎ𝑟𝑏 ⋅ 𝜀𝑠 
Where 𝜀𝑠 is the surface emissivity of the colour bordering the BC_SKY boundary condition. 
The field is blank if the U-value calculation fails. 
 
This value can be overruled for use in the formulas for linear thermal transmittance and thermal 
transmittance (see D.10). by entering a different value in the column “Enforced U value”. 
 
Note: when the abovementioned sequence of types occurs at a bitmap border, the 
corresponding 1D U-value will be shown in the Border U Values window. This however doesn’t 
necessarily correspond with a relevant quantity (e.g. left border U-value in the below figure).  

 

C.14. Borderline BCs window 

The Borderline BCs window allows to input borderline boundary conditions. 

A borderline boundary condition imposes a fixed temperature or fixed heat flux in the borderline 
between two different colours. 
The selected borderline boundary condition (defined by the row of the selected cell) is highlighted 

in the Bitmap window by dotted lines. 
 
Application example 
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A borderline boundary condition is typically used to impose a fixed heat flux to simulate internal 

solar absorption (e.g. in a semi-transparent façade). 
 
Edit → Insert Row 
Insert a new borderline boundary condition. 

 
Edit → Delete Row 
Delete the current borderline boundary condition. 
 

 
For each borderline boundary condition, enter: 
Colour numbers of two adjacent colours. 
Invalid colour numbers (not present or not adjacent in the bitmap) cannot be entered. 
Type: “TEMP” (fixed temperature) or “FLUX” (fixed heat flux). 
Temperature (if type = TEMP). 

Heat flux (if type = FLUX). 

C.15. Distances window 

The Distances window allows to get distances (and U-values along the distance) in the bitmap, 

which are used in the calculation of derived thermal properties (see D.10). 

The selected distance (corresponding to the active cell) is highlighted in the Bitmap window by a 

dotted line. 

 
Edit → Insert Row 

Insert a new distance. 
 
Edit → Delete Row 

Delete the current distance. 
 

 
 
Mode (toggle) 
SELECT: input of other fields enabled 
LOCKED: input of other fields disabled 
 

Direction (toggle) 
X: distance parallel to X axis 
Y: distance parallel to Y axis 
ANY: distance can have any (slanting) direction 
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Extent (toggle; disabled if Direction = ANY) 

MIN: next clicked point in bitmap (in Zoom → Select mode) defines distance (parallel to X or Y 

axis) up to first colour change at both ends along the given direction. 

MAX: next clicked point in bitmap (in Zoom → Select mode) defines distance (parallel to X or Y 

axis) up to maximum extent of all pixels in the bitmap having that colour. 
FREE (cannot be obtained by toggling the input field): if coordinates of end points X1, Y1, X2, Y2 

are modified, so that MIN or MAX extent are not valid (for X or Y direction). 
 
State (toggle; disabled if Direction = ANY) 
NORMAL 
INVERSE: complement of line against total bitmap length (parallel to X or Y) 
 

Length (not editable) 
Distance length in pixels (only if Direction = X or Y) or metres 
 

X1, Y1, X2, Y2 
Pixel coordinates of distance end points 
 
The coordinates can also be entered graphically by drawing a line or clicking a point in the 

bitmap (in Zoom → Select mode). 
The effect of clicking a point depends on the chosen direction, extent and the position of the 
active cell: 

Direction = X or Y: 
− Active cell = X1, Y1, X2 or Y2: change only that coordinate (and extent becomes FREE) 

− Other active cell: change (X1,Y1) and (X2,Y2), depending on extent (FREE becomes MIN) 
Direction = ANY: 

− Active cell = X1 or Y1: define new point (X1,Y1) 

− Active cell = X2 or Y2: define new point (X2,Y2) 
− Other active cell: modify closest point (X1,Y1) or (X2,Y2) 

 

U (not editable) 
Calculated U-value along distance line. 
The U-value calculation is based on 1D heat transfer through material layers of type MATERIAL, 

EQUIMAT or TRANSMAT, or cavity layers of type BC_FREE between two different boundary 

conditions of type BC_SIMPL (or BC_FRE_S) or BC_SKY along the outermost pixel strip at the 
bitmap borders. 
For TRANSMAT and BC_FREE layers, the U-value shown is calculated assuming linear radiation 

using the black linear radiation coefficient ℎ𝑟𝑏 as defined in the Calculation Parameters dialog 
box (D.2.3), so the thermal resistance 𝑅 of such a layer is calculated as: 

𝑅 =
1

(ℎ𝑐 + ℎ𝑟)
 

ℎ𝑟 = ℎ𝑟𝑏 ⋅
1

1

𝜀1
+

1

𝜀2
−1

  

Where 𝜀1 and 𝜀2 are the surface emissivities of the colours bordering the TRANSMAT/BC_FREE 
layer. 
For BC_SKY boundary conditions, the U-value shown is calculated assuming linear radiation 
using the black linear radiation coefficient ℎ𝑟𝑏 as defined in the Calculation Parameters dialog 
box (D.2.3): 
ℎ𝑟 = ℎ𝑟𝑏 ⋅ 𝜀𝑠 
Where 𝜀𝑠 is the surface emissivity of the colour bordering the BC_SKY boundary condition. 
The field is blank if the U-value calculation fails. 
 
Enforced U 
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U-value entered by the user for use in the formulas for linear thermal transmittance and thermal 

transmittance (see D.10), overruling the value in the column “U” if present. 

C.16. General editing commands 

Copy – paste 
Edit → Copy Cell: copies the value from the current input cell into the clipboard. 

Edit → Paste Cell: copies the value from the clipboard into the current input cell. 
 
Undo – redo 

Edit → Undo 
Undoes the last edit action (to cancel a mistake). 
This command can be repeated to undo more edit actions. 

Only the last 100 edit actions are stored for possible later recovery using Edit → Redo. 
The undo command is impossible after saving a file (File → Save and File → Save As…), closing 
the current file (File → Close, also File → Open Bitmap…, File → Open…, File → Open DXF…) or 
starting a calculation (Calc → Calc System, File → Batch Calculation… and File → DXF Batch 
Calculation…). 
Edit → Redo 
Restores the previous edit action that was made undone using Edit → Undo. 

This command can be repeated to restore more edit actions that were made undone. 
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CHAPTER D CALCULATION 

D.1.  Automatic calculation of thermal properties 

In the Colours window colour types and subtypes can be selected which contain an automatic 

calculation of thermal properties. 
Whenever this automatic calculation (or definition) of thermal properties is according to an 

international standard, the relevant standard is denoted in the Standard column in the Colours 

window. 

Some standards explain how to determine the thermal resistance of air/gas cavities and layers, 
but not how to model them (EN ISO 6946 and EN 673, namely1). In this case, modelling them as 
equivalent materials (EQUIMAT, TRANSMAT) or modelling them as an enclosure with a single 
convective air/gas node (BC_FREE) are both possible in BISCO. 
Conversely, standards EN ISO 10077-2 and ISO 15099 explicitly state that air cavities should be 

modelled as an equivalent material, either including convection and radiation (EQUIMAT) or only 
including convection and modelling radiation explicitly (TRANSMAT). 

D.1.1. Colour type EQUIMAT 

Colour modelled as equivalent material (with single equivalent thermal conductivity 𝜆𝑒𝑞 for 

combined convective and radiation heat transfer) 
 

Type Subtype Meaning Standard 

EQUIMAT NIHIL Thermal conductivity defined by user  

CAVITY 
Unventilated (internal) air cavity with given heat flow 

direction 

EN10077 
EN6946 

ISO15099 

CAVITY_E 
Ventilated (external) air cavity with given heat flow 
direction 

EN10077 
ISO15099 

 LAYER Unventilated air/gas layer with given heat flow direction 
EN6946 
EN673 
ISO15099 

 SCREW Screw along X or Y 
EN12631 

ISO15099 

 
Characteristic dimensions 
The characteristic dimensions for a rectangular air cavity are its depth (𝑑, parallel to the heat 
flow direction) and width (𝑏, perpendicular to the heat flow direction). 
A non-rectangular air cavity is transformed into a rectangular air cavity, using the same ratio of 
depth to width for the surrounding rectangle of the non-rectangular air cavity and the new 

rectangular air cavity (both oriented along the heat flow direction):  

 
1 Note that standard EN ISO 10211 states that air/gas cavities and layers should be considered as 

homogeneous materials with an equivalent thermal conductivity based on the thermal resistance 

determined by EN ISO 6946 or EN 673, i.e. type EQUIMAT. 
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The characteristic dimensions 𝑑 and 𝑏 (of the rectangular air cavity) are further used in the 
formulas below. 
The characteristic dimension of an air or gas layer is the depth (𝑑, parallel to the heat flow 
direction), as a layer is typically assumed to be infinitely wide for calculation purposes (thus 
neglecting any influence of the edges on the heat transfer by convection and radiation in the 
air/gas layer). 
 

Equivalent thermal conductivity of unventilated air cavity (subtype CAVITY) 
𝜆𝑒𝑞 = (ℎ𝑐 + ℎ𝑟) ∙ 𝑑 

- ℎ𝑐 = convective heat transfer coefficient (from warm surface to cold surface) 
o EN ISO 10077-2 and EN ISO 6496: 

if 𝑏 < 0.005 m (for EN ISO 10077-2), then 

ℎ𝑐 =
𝐶1

𝑑
 

if 𝑏 ≥ 0.005 m (for EN ISO 10077-2) or for any 𝑏 (EN ISO 6946), then 

ℎ𝑐 = 𝑚𝑎𝑥 {
𝐶1

𝑑
, 𝐶2 ⋅ (𝛥𝜃𝑠𝑠)𝐶3} 

𝛥𝜃𝑠𝑠 = maximum surface temperature difference in air cavity (𝛥𝜃𝑠𝑠 ≥ 5°C for EN 
ISO 6946) 
or 𝛥𝜃𝑠𝑠  = 𝛥𝜃𝑠𝑠,𝑑𝑒𝑓𝑎𝑢𝑙𝑡 (see table below and D.2.4) 

 

Standard Heat flow direction C1 C2 C3 𝛥𝜃𝑠𝑠,𝑑𝑒𝑓𝑎𝑢𝑙𝑡 

EN ISO 10077-2 horizontal 0.025 0.73 0.333333 10°C 

EN ISO 6946 horizontal 0.025 0.73 0.333333 5°C 

upward 0.025 1.14 0.333333 5°C 

downward 0.025 0.09∙𝑑-0.44 0.187 5°C 

 

o ISO 15099: 

ℎ𝑐 = 𝑁𝑢
𝜆𝑎𝑖

𝑑
 

𝜆𝑎𝑖 = 2.873 ∙ 10−3 + 7.760 ∙ 10−5 ∙ (𝑇𝑚 + 273.16)       [W/(mK)] 

𝑇𝑚 =
𝑇𝑐ℎ + 𝑇𝑐𝑐

2
 

𝑇𝑐ℎ = mean temperature of the hot side of the air cavity (10°C by default) 
𝑇𝑐𝑐 = mean temperature of the cold side of the air cavity (0°C by default) 

𝑁𝑢 = Nusselt number, depends on the physical heat flow direction and on the 
largest cavity dimensions in the horizontal direction (𝐿ℎ) and the vertical - or 

upward/downward – direction (𝐿𝑣): 
▪ Downward heat flow direction: 𝑁𝑢 = 1  
▪ Upward heat flow direction (𝐿ℎ = 𝑏 and 𝐿𝑣 = 𝑑): 

For 
𝐿ℎ

𝐿𝑣
≤ 1: 𝑁𝑢 = 1 

For 1 <
𝐿ℎ

𝐿𝑣
≤ 5:  
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𝑁𝑢 = 1 + (1 −
𝑅𝑎𝑐𝑟

𝑅𝑎
)

∎

[𝑘1 + 2(𝑘2)1−ln(𝑘2)] + 

[(
𝑅𝑎

5830
)

1
3

− 1]

∎

[1 − 𝑒
−0.95((

𝑅𝑎𝑐𝑟
𝑅𝑎

)

1
3

−1)

∎

] 

With: 
𝑘1 = 1.40 

𝑘2 =  
𝑅𝑎

1
3

450.5
 

(𝑋)∎ =
𝑋 + |𝑋|

2
 

𝑅𝑎𝑐𝑟 = 𝑒
(0.721

𝐿𝑣
𝐿ℎ

)+7.46
 

𝑅𝑎 =
𝜌𝑎𝑖

2 𝐿𝑣
3 𝑔𝑐𝑝,𝑎𝑖(𝑇𝑐ℎ − 𝑇𝑐𝑐)

𝜇𝑎𝑖𝜆𝑎𝑖(𝑇𝑚 + 273.16)
 

𝑔 = 9.81        [m/s²] 

𝜌𝑎𝑖 =  
101300∙28.97

8314.5∙(𝑇𝑚+273.16)
      [kg/m³] 

𝑐𝑝,𝑎𝑖 = 1002.737 + 1.2324 ∙ 10−2 ∙ (𝑇𝑚 + 273.16)  [J/(kg∙K)] 

𝜇𝑎𝑖 = 3.723 ∙ 10−6 + 4.94 ∙ 10−8 ∙ (𝑇𝑚 + 273.16)  [Pa∙s] 

For 
𝐿ℎ

𝐿𝑣
> 5:  

𝑁𝑢 = 1 + 1.44(1 −
1708

𝑅𝑎
)∎ + [(

𝑅𝑎

5830
)

1
3

− 1]

∎

 

▪ Horizontal heat flow direction (𝐿ℎ = 𝑑 and 𝐿𝑣 = 𝑏 for a head or sill section, 

but 𝐿𝑣 equals the jamb height for a jamb section, see D.2.5): 

For 
𝐿𝑣

𝐿ℎ
≤

1

2
: 

 𝑁𝑢 = 1 + {[2.756 ∙ 10−6𝑅𝑎2(
𝐿𝑣

𝐿ℎ
)8]

−0.386
+ [0.623𝑅𝑎

1

5(
𝐿ℎ

𝐿𝑣
)

2

5]
−0.386

}

−2.59

 

With: 

𝑅𝑎 =
𝜌𝑎𝑖

2 𝐿ℎ
3 𝑔𝑐𝑝,𝑎𝑖(𝑇𝑐ℎ − 𝑇𝑐𝑐)

𝜇𝑎𝑖𝜆𝑎𝑖(𝑇𝑚 + 273.16)
 

For 
𝐿𝑣

𝐿ℎ
> 5: 

𝑁𝑢 equals the maximum of 𝑁𝑢1, 𝑁𝑢2 and 𝑁𝑢3 

𝑁𝑢1 = {1 + (
0.104𝑅𝑎0.293

1 + (
6310

𝑅𝑎 )1.36
)3}

1
3

 

𝑁𝑢2 = 0.242(𝑅𝑎
𝐿ℎ

𝐿𝑣
)0.273 

𝑁𝑢3 = 0.0605𝑅𝑎
1
3 

 

For 
1

2
<

𝐿ℎ

𝐿𝑣
≤ 5, 𝑁𝑢 is found using a linear interpolation between the 

endpoints of the cases above. 
 

- ℎ𝑟 = radiative heat transfer coefficient 
EN ISO 10077-2: ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 ∙ 𝐸 ∙ 𝐹 

EN ISO 6946 and ISO 15099: ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 (
1

𝐸
+

1

𝐹
− 1)⁄  
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𝐸 =
1

1
𝜀1

+
1
𝜀2

− 1
 

𝐹 = (1 + √1 + (
𝑑

𝑏
)

2

−
𝑑

𝑏
) 2⁄  

𝜃𝑚 =
𝜃𝑠,𝑚𝑖𝑛 + 𝜃𝑠,𝑚𝑎𝑥

2
 

𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in air cavity [°C] 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in air cavity [°C] 

or 𝜃𝑚 = 10°C for EN ISO 10077-2 and EN ISO 6946; and 𝜃𝑚 = 5°C for ISO 15099 (see D.2.4) 

 1 , 2 = emissivities at warm and cold sides of air cavity (default values: 1 = 2 = 0.9) 
 
Equivalent thermal conductivity of slightly ventilated air cavity (subtype CAVITY_E) 
An air cavity is considered to be slightly ventilated when there is an open connection to an 
exterior or interior boundary condition with a slit between 2 and 10 mm, and 𝑑  𝑏. 
𝜆𝑒𝑞 = 2 ∙ (𝜆𝑒𝑞 of unventilated air cavity). 

 

Equivalent thermal conductivity of air/gas layer (subtype LAYER) 
- Standard EN ISO 6946: in the formula above for subtype CAVITY, set d/b = 0 for hr. 

- Standard EN 673: 

𝜆𝑒𝑞 = (ℎ𝑐 + ℎ𝑟) ∙ 𝑑 

• ℎ𝑐 = convective heat transfer coefficient 

ℎ𝑐 = 𝑁𝑢
𝜆

𝑑
  

With: 
 𝑁𝑢 = max (1, 𝐴 ∙ (𝐺𝑟 ∙ 𝑃𝑟)𝑛) or 𝑁𝑢 = 0 in case of vacuum 

 𝐺𝑟 =
9.81𝑑3𝛥𝜃𝑠𝑠𝜌2

𝑇𝑚𝜇²
 

 𝑃𝑟 =
𝜇𝑐

𝜆
 

𝛥𝜃𝑠𝑠 = maximum surface temperature difference in layer 
or 𝛥𝜃𝑠𝑠  = 15°C (see D.2.4) 

𝑇𝑚 =
𝜃𝑠,𝑚𝑖𝑛 + 𝜃𝑠,𝑚𝑎𝑥

2
+ 273.16 

𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in layer [°C] 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in layer [°C] 

or 𝜃𝑚 = 10°C (default mean temperature, see D.2.4) 
 

Heat flow direction Inclination angle 𝐴 𝑛 

Downward >90° 0 N.A. 
Horizontal 90° 0.035 0.38 

 45° 0.10 0.31 

Upward 0° 0.16 0.28 

 (Values for ℎ𝑐 are interpolated for intermediate heat flow directions) 
  

Gas 𝜌 𝜇 𝜆 𝑐 

Air 1.232 1.761·10-5 2.496·10-2 1.008·10³ 

Argon 1.699 2.164·10-5 1.684·10-2 0.519·10³ 

SF6 6.360 1.459·10-5 1.275·10-2 0.614·10³ 

Xenon 5.689 2.226·10-5 0.529·10-2 0.161·10³ 

Krypton 3.560 2.400·10-5 0.900·10-2 0.245·10³ 
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 (In case of a gas mix, the gas properties are proportioned in the ratio of the 

 user-defined volume fractions)
 

 
 

• ℎ𝑟 = radiative heat transfer coefficient 
ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 ∙ 𝐸 

𝐸 =
1

1
𝜀1

+
1
𝜀2

− 1
 

1 , 2 = emissivities at warm and cold sides of layer (default values: 1 = 2 = 0.9) 
 

- Standard ISO 15099: 

𝜆𝑒𝑞 = (ℎ𝑐 + ℎ𝑟) ∙ 𝑑 

• ℎ𝑐 = convective heat transfer coefficient 

ℎ𝑐 = 𝑁𝑢
𝜆𝑔𝑣

𝑑
  

With: 

𝑁𝑢 dependent on the tilt angle 𝛾 (see below) or 𝑁𝑢 = 0 in case of vacuum  

𝑅𝑎 =
𝜌𝑔𝑣

2 𝑑3𝑔𝑐𝑝,𝑔𝑣(𝑇𝑐ℎ − 𝑇𝑐𝑐)

𝜇𝑔𝑣𝜆𝑔𝑣(𝑇𝑚 + 273.16)
 

𝑇𝑚 =
𝑇𝑐ℎ + 𝑇𝑐𝑐

2
 

𝑇𝑐ℎ = maximum temperature of the hot side of the gas layer (15° by default) 
𝑇𝑐𝑐 = minimum temperature of the cold side of the gas layer (-15° by default) 

𝐴𝑔𝑣 =
𝐻

𝑑
 with 𝐻 equal to the height of the gas layer 

▪ Glazing inclined at 0° ≤  𝛾 < 60° 

𝑁𝑢 = 1 + 1.44(1 −
1708

𝑅𝑎 cos (𝛾)
)∎ [1 −

1708sin1.6(1.8𝛾)

𝑅𝑎 cos (𝛾)
]

+ [(
𝑅𝑎 cos (𝛾)

5830
)

1
3

− 1]

∎

 

With: (𝑋)∎ =
𝑋+|𝑋|

2
 

▪ Glazing inclined at 𝛾 = 60° 
𝑁𝑢 equals the maximum of 𝑁𝑢1 and 𝑁𝑢2 
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𝑁𝑢1 = {1 + (
0.093𝑅𝑎0.314

1 + 𝐺
)7}

1
7

 

𝑁𝑢2 = (0.104 +
0.175

𝐴𝑔𝑣
)𝑅𝑎0.283 

With 𝐺 =
0.5

[1+(
𝑅𝑎

3160
)

20.6
]

0.1 

▪ Glazing inclined at 60° < 𝛾 < 90° 
𝑁𝑢 is found using a linear interpolation between the results for inclination 
angles of 60° and 90° 

▪ Glazing inclined at 𝛾 = 90° (vertical glazing) 
𝑁𝑢 equals the maximum of 𝑁𝑢1 and 𝑁𝑢2 

𝑁𝑢1 = 0.067383𝑅𝑎
1

3    if 5 ∙ 104 < 𝑅𝑎 
𝑁𝑢1 = 0.028154𝑅𝑎0.4134   if 104 < 𝑅𝑎 ≤ 5 ∙ 104 
𝑁𝑢1 = 1 + 1.7596678 ∙ 10−10𝑅𝑎2.2984755 if 𝑅𝑎 ≤ 104 

𝑁𝑢2 = 0.242 (
𝑅𝑎

𝐴𝑔𝑣
)

0.272

 

▪ Glazing inclined at 90° <  𝛾 ≤ 180° 
𝑁𝑢 = 1 + (𝑁𝑢90° − 1) sin 𝛾 
 

The thermal properties of the fill gases are determined as a function of the mean 

temperature 𝑇𝑚, the density (𝜌) based on the ideal gas law and the specific heat 
capacity (𝑐), the dynamic viscosity (𝜇) and the thermal conductivity (𝜆) as linear 

functions of the form 𝑎 + 𝑏𝑇𝑚. 

𝜌 =
𝑃𝑀̂

ℜ(𝑇𝑚+273.16)
  

With: 𝑃 = 101300 [Pa] 
ℜ = 8314.5 [m3∙Pa∙K-1∙kmol-1] 

𝑀̂ = molecular mass [kg/kmol] 
 

Gas 𝑀̂ 𝜇 𝜆 𝑐 

a b a b a b 

Air 28.97 3.723·10-6 4.94·10-8 2.873·10-3 7.760·10-5 1002.737 1.232·10-2 

Argon 39.948 3.379·10-6 6.451·10-8 2.285·10-3 5.149·10-5 521.9285 0 

Krypton 83.80 2.213·10-6 7.777·10-8 9.443·10-4 2.826·10-5 248.0907 0 

Xenon 131.30 1.069·10-6 1.069·10-8 4.538·10-4 1.723·10-5 158.3397 0 

 
The thermal properties of gas mixes are calculated as a function of the individual 

constituents: 

𝑀̂𝑚𝑖𝑥 = ∑ 𝑚𝑖𝑀̂𝑖

𝑣

𝑖=1

 

 With: 𝑚𝑖 = mole fraction of gas component i in mixture 

𝑐𝑝,𝑚𝑖𝑥 =
𝑐̂𝑝,𝑚𝑖𝑥

𝑀̂𝑚𝑖𝑥

 

With: 𝑐̂𝑝,𝑚𝑖𝑥 = ∑ 𝑚𝑖 𝑐̂𝑝,𝑖
𝑣
𝑖=1  

 𝑐̂𝑝,𝑖 = 𝑐𝑝,𝑖𝑀̂𝑖 

𝜇𝑚𝑖𝑥 = ∑
1

(1 + ∑ 𝛿𝑖𝑗𝜙𝑖,𝑗
𝜇 𝑚𝑗

𝑚𝑖

𝑣
𝑗=1 )

𝑣

𝑖=1
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 With: 𝜙𝑖,𝑗
𝜇

=

[1+(
𝜇𝑖
𝜇𝑗

)

1
2

(
𝑀̂𝑗

𝑀̂𝑖
)

1
4

]

2

2√2[1+
𝑀̂𝑖
𝑀̂𝑗

]

1
2

 

𝜆𝑚𝑖𝑥 = 𝜆′𝑚𝑖𝑥 + 𝜆′′𝑚𝑖𝑥 

 With: 𝜆′𝑚𝑖𝑥 = ∑
𝜆′𝑖

(1+∑ 𝛿𝑖𝑗Ψ𝑖,𝑗

𝑚𝑗

𝑚𝑖

𝑣
𝑗=1 )

𝑣
𝑖=1  

  Ψ𝑖,𝑗 =

[1+(
𝜆′𝑖
𝜆′𝑗

)

1
2

(
𝑀̂𝑖
𝑀̂𝑗

)

1
4

]

2

2√2[1+
𝑀̂𝑖
𝑀̂𝑗

]

1
2

∙ [1 + 2.41
(𝑀̂𝑖−𝑀̂𝑗)(𝑀̂𝑖−0.142𝑀̂𝑗

(𝑀̂𝑖+𝑀̂𝑗)
2 ] 

  𝜆′′𝑚𝑖𝑥 = ∑
𝜆′′𝑖

(1+∑ 𝛿𝑖𝑗ϕ𝑖,𝑗
𝜆 𝑚𝑗

𝑚𝑖

𝑣
𝑗=1 )

𝑣
𝑖=1  

  𝜙𝑖,𝑗
𝜆 =

[1+(
𝜆′𝑖
𝜆′𝑗

)

1
2

(
𝑀̂𝑖
𝑀̂𝑗

)

1
4

]

2

2√2[1+
𝑀̂𝑖
𝑀̂𝑗

]

1
2

 

  𝜆′𝑖 =
15

4

ℜ

𝑀̂𝑖
𝜇𝑖 

  𝜆′′𝑖 = 𝜆𝑖 − 𝜆′𝑖 

 
Adiabatic boundaries 

An adiabatic boundary (i.e. a boundary through which there is no heat transfer) can be 
considered as a symmetry axis (with symmetric heat flow pattern). 
When there is an adiabatic boundary at one side of the width direction, the equivalent width b is 
automatically doubled for subtype CAVITY. 
When there are adiabatic boundaries at both sides of the width direction, the equivalent width b 
is automatically considered to be infinite for subtype CAVITY (so d/b = 0, as for subtype LAYER). 
If the air cavity touches a bitmap border, then the calculation parameter “Bitmap border is axis of 
symmetry” decides whether it is an adiabatic boundary (see D.2.4). 
 
Screw (subtype SCREW (EN ISO 12631 and ISO 15099)) 

The longitudinal direction of the screw is defined by the geometrical direction (X or Y). 
Initially the equivalent thermal conductivity is set to a very high value (𝜆 = 1000 W/(m.K)), and in 

the Colours window on a red background. Edit this value to open a dialog box with screw 

parameters. 
The bitmap pixels of the screw must fulfil the following conditions: 

- The screw must be a rectangle. 
- The screw must only pass through colours of type MATERIAL or EQUIMAT (subtype NIHIL). 
- The screw must have the same layers along both sides (thermal resistances along both 

sides of the screw may differ at most 50 %). 
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Enter the screw parameters: 
Distance (perpendicular to the bitmap) between screws (𝑙𝑠) 

Thermal conductivity of the screw material (𝜆𝑠) 
 
The equivalent conductivity of the screw is calculated according to EN ISO 12631: 
𝜋

4
⋅

𝑑𝑠

𝑙𝑠
⋅ (𝜆𝑠 − 𝜆𝑟,𝑒𝑞) + 𝜆𝑟,𝑒𝑞     

with 
𝑑𝑠 = screw diameter (= width of screw in the bitmap) 
𝑙𝑠 = distance between screws 
𝜆𝑟,𝑒𝑞 = reference equivalent thermal conductivity of the materials replaced by the screw 

(calculated from thermal resistance alongside the screw) 

 
Note: see knowledge base document “3D AND 2D Simulation of fixings – validation of EN ISO 
12631:2017 ANNEX E.pdf” for an example 

D.1.2. Colour type BC_SIMPL or BC_FRE_S 

Purpose: simplified surface boundary condition (using a global surface heat transfer coefficient). 
For BC_SIMPL, the environment temperature is defined by the user. For BC_FRE_S, the 
environment temperature is unknown (free-floating). 
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Type Standard Subtype 
Physical  

heat flow 
Meaning 

BC_SIMPL 

NIHIL 

NIHIL 

 Global surface heat transfer  
coefficient h and temperature θ defined 

by user 

HI 

 Global surface heat transfer  
coefficient h and temperature θ at 

interior surface defined by user 
(for internal surface relative humidity 
calculations, see 0) 

EN10077 

HI_NORML horizontal 
Normal h at interior surface:  
h = 7.7 W/(m2.K), θi = 20°C 

HI_REDUC horizontal 
Reduced h at interior surface:  
h = 5 W/(m2.K) , θi = 20°C 

HE  
h at exterior surface:  
h = 25 W/(m2.K), θe = 0°C 

HI_CAV_E horizontal 
Slightly ventilated air cavity: 
h = 3.33 W/(m2.K), θi = 20°C 

HE_CAV_E horizontal 
Slightly ventilated air cavity: 
h = 3.33 W/(m2.K), θe = 0°C 

EN6946 

HI 

horizontal 
h at interior surface:  

h = 7.7 W/(m2.K) 

upward 
h at interior surface:  
h = 10 W/(m2.K) 

downward 
h at interior surface:  

h = 5.9 W/(m2.K) 

HE 
 h at exterior surface:  

h = 25 W/(m2.K) 

 

ISO15099 

HE 

 h at exterior surface: 

Automatically calculated depending on 
wind speed (see below) 

 
Automatic calculation of h for HE ISO15099: 

ℎ = ℎ𝑐 + ℎ𝑟 W/(m²K) 

ℎ𝑐 = 4 + 4 ∙ 𝑉𝑠 (forced convection) 
 with: 𝑉𝑠 = (user-defined) wind speed [m/s] 

 
ℎ𝑟 = 0.9 ∙ 5.67 ∙ 10−8(𝑇𝑠

2 + 𝑇𝑟
2)(𝑇𝑠 + 𝑇𝑟) 

 with: 𝑇𝑠 =
𝑇𝑠,𝑚𝑎𝑥+𝑇𝑠,𝑚𝑖𝑛

2
 = average external surface temperature [K] 

𝑇𝑟 = 𝜃 + 273.16 = external radiation temperature, assumed equal to 

environment temperature defined in Colours window [K] 

D.1.3. Colour type BC_FREE 

(This type requires the RADCON module, see Chapter K) 

Purpose: enclosure with unknown (free-floating) air temperature (single thermal node) to be 
calculated from convective heat balance (surface to air) and radiation based on view factors. 
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Modelling the enclosure with a single thermal node representing the air assumes perfectly mixed 
air. 

Type Subtype Meaning Standard 

BC_FREE NIHIL Thermal conductivity 𝜆 defined by user NIHIL 

CONVEC Large air space, without preferential heat flow direction* NIHIL 

CAVITY Unventilated (internal) air cavity with given heat flow direction EN6946 

 LAYER Unventilated air/gas layer with given heat flow direction 
EN6946 
EN673 

*typically larger than 0.3m 

 

CAVITY and LAYER: 
The CAVITY subtype is to be used when a global heat flow direction is assumed (surface-to-
surface heat transfer with an air temperature in between temperature of ‘hot’ and ‘cold’ surface 
temperatures, e.g. typically used for a cavity in a façade). 
 
ℎ𝑐 = convective surface heat transfer coefficient (surface to air) 
ℎ𝑐 = 2 ∙ ℎ𝑐,𝐸𝑄𝑈𝐼𝑀𝐴𝑇 

ℎ𝑐,𝐸𝑄𝑈𝐼𝑀𝐴𝑇 = convective surface heat transfer coefficient (surface to surface), as calculated in D.1.1 

 
CONVEC: 
The subtype CONVEC must be used when no global heat flow direction can be assumed in the 

enclosure (surface-to-air heat transfer with an air temperature higher or lower than surface 
temperatures, e.g. typically used for a room). 

ℎ𝑐= convective surface heat transfer coefficient (surface to air) 
ℎ𝑐 = 2 ∙ 𝐶2 ∙ (𝛥𝜃𝑠𝑎)𝐶3 
𝛥𝜃𝑠𝑎= greatest difference between air temperature and surface temperature 

𝛥𝜃𝑠𝑎 = max (|𝜃𝑎 − 𝜃𝑠,𝑚𝑖𝑛|, |𝜃𝑎 − 𝜃𝑠,𝑚𝑎𝑥|) 

𝜃𝑎 = air temperature 
𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in contact with given boundary condition colour 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in contact with given boundary condition colour 

or 𝛥𝜃𝑠𝑎= calculation parameter “Default temperature difference for hc calculation” (see D.2.4) 
 

Heat flow direction C2 C3 

horizontal 0.73 0.333333 

upward 1.14 0.333333 

downward 0.09 0.187 

D.1.4. Colour type BC_SKY or BC_NOSKY 

(This type requires the RADCON module, see Chapter K) 

Purpose: environment with known air temperature and either user defined radiation temperature 

(BC_SKY) and radiation based on view factors or no radiation exchange (BC_NOSKY). 

Type Subtype Meaning Standard 

BC_SKY 
or 
BC_NOSKY 

NIHIL 
Convective surface heat transfer coefficient ℎ𝑐 defined by 
user 

NIHIL 

CONVEC 
Natural convection surface-air  
(calculation of ℎ𝑐: see above BC_FREE – CONVEC, D.1.3) 

NIHIL 
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BC_SKY CONVEC 
Natural convection surface-air (automatic calculation of ℎ𝑐: 

see below) 

ISO15099 

 

Automatic calculation of ℎ𝑐 for BC_SKY CONVEC ISO15099: 

ℎ𝑐 = 𝑁𝑢
𝜆𝑎𝑖𝑟

𝐻
 

With: 
𝑁𝑢 dependent on the tilt angle 𝛾 (see below)  

𝑅𝑎𝐻 =
𝜌𝑎𝑖𝑟

2 𝐻3𝑔𝑐𝑝,𝑎𝑖𝑟(𝑇𝑠 − 𝜃𝑎)

𝜇𝑎𝑖𝑟𝜆𝑎𝑖𝑟(𝑇𝑚,𝑓 + 273.16)
 

𝑇𝑠 =
𝑇𝑠,𝑚𝑎𝑥+𝑇𝑠,𝑚𝑖𝑛

2
 = average external surface temperature    [°C] 

𝑇𝑚,𝑓 = 𝜃𝑎 +
1

4
(𝑇𝑠 − 𝜃𝑎) = mean film temperature    [°C] 

𝜃𝑎 = user defined environment air temperature     [°C] 
𝜆𝑎𝑖𝑟 = 2.873 ∙ 10−3 + 7.760 ∙ 10−5 ∙ (𝑇𝑚,𝑓 + 273.16)        [W/(mK)] 

𝜌𝑎𝑖𝑟 =  
101300∙28.97

8314.5∙(𝑇𝑚,𝑓+273.16)
        [kg/m³] 

𝑐𝑝,𝑎𝑖𝑟 = 1002.737 + 1.2324 ∙ 10−2 ∙ (𝑇𝑚,𝑓 + 273.16)    [J/(kg∙K)] 

𝜇𝑎𝑖𝑟 = 3.723 ∙ 10−6 + 4.94 ∙ 10−8 ∙ (𝑇𝑚,𝑓 + 273.16)    [Pa∙s] 

 

▪ Window inclined at 0° ≤  𝛾 < 15° 

𝑁𝑢 = 0.13𝑅𝑎𝐻

1
3  

▪ Window inclined at 15° ≤  𝛾 ≤ 90° 

𝑁𝑢 = 0.56(𝑅𝑎𝐻 sin 𝛾)
1

4     if  𝑅𝑎𝐻 ≤ 𝑅𝑎𝑐𝑣 

𝑁𝑢 = 0.13 (𝑅𝑎𝐻

1

3 − 𝑅𝑎𝑐𝑣

1

3 ) + 0.56(𝑅𝑎𝑐𝑣 sin 𝛾)
1

4  if  𝑅𝑎𝐻 > 𝑅𝑎𝑐𝑣  

With 𝑅𝑎𝑐𝑣 = 2.5 ∙ 105 (
𝑒0.72𝛾

sin 𝛾
)

1

5
 

▪ Window inclined at 90° < 𝛾 ≤ 179° 

𝑁𝑢 = 0.56(𝑅𝑎𝐻 sin 𝛾)
1
4 

▪ Window inclined at 179° <  𝛾 ≤ 180° 

𝑁𝑢 = 0.58𝑅𝑎𝐻

1
5  

D.1.5. Colour type TRANSMAT 

(This type requires the RADCON module, see Chapter K) 

Purpose: air cavity modelled as transparent material (radiation based on view factors, cf. 
radiosity method (EN ISO 10077-2)) 
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Standard Subtype Meaning 

EN10077 CAVITY 

Unventilated air cavity with heat flow direction along temperature 

gradient* (calculation of eq: cf. above EQUIMAT, EN ISO 10077-2, 
CAVITY with hr = 0, because radiation is calculated using view 
factors) 

EN6946 

CAVITY 
Unventilated air cavity (calculation of eq: cf. above EQUIMAT, EN 
ISO 6946, CAVITY with hr = 0, because radiation is calculated 
using view factors) 

LAYER 
Unventilated air layer (calculation of eq: cf. above EQUIMAT, EN 
ISO 6946, CAVITY with hr = 0, because radiation is calculated 
using view factors) 

EN673 LAYER 

Unventilated air/gas layer (calculation of eq: cf. above EQUIMAT, 

EN 673, CAVITY with hr = 0, because radiation is calculated using 
view factors) 

ISO15099 

CAVITY 
Unventilated air cavity (calculation of eq: cf. above EQUIMAT, ISO 
15099, CAVITY with hr = 0, because radiation is calculated using 
view factors) 

LAYER 

Unventilated air/gas layer (calculation of eq: cf. above EQUIMAT, 

ISO 15099, CAVITY with hr = 0, because radiation is calculated 
using view factors) 

NIHIL NIHIL Thermal conductivity defined by user 

*Geometrical flow direction: DIR 

D.2. Calculation parameters 

A system calculation (Calc → Calc System) is controlled by calculation parameters. 
The menu command Edit → Calc Parameters… opens a dialog box in which the calculation 
parameters can be edited. The parameters not relevant to the current BISCO document are 

disabled (greyed in the dialog box). 
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D.2.1. Triangulation 

Contour approximation margin 
Defines the maximum allowed distance between the original bitmap colour contours and the 
approximated contours used in the triangulation (cf. section D.4.2). 
Normally the margin is set to 0 (e.g. for bitmaps converted from CAD drawings). 

For bitmaps from scanned images, with some scan noise, apply a small margin ≤ 1. 

D.2.2. Iteration 

Iteration cycles 
An iteration cycle is part of a system calculation (cf. section D.3), and involves building and solving 
a linear system of equations. A non-linear system is solved by stepwise linearisation. Each step 
using new linearised coefficients corresponds to an iteration cycle. This is needed for automatic 
refinement of calculated thermal properties (equivalent thermal conductivities and convective 
heat transfer coefficients) or non-linear infrared radiation. Before each new iteration cycle the 

linearised thermal resistances are recalculated based on the last available solution (i.e. from the 
previous iteration cycle). 

Normally 5 iteration cycles are enough to solve most non-linear systems with adequate precision. 
 
Iteration stopping criteria 
The linear system of each iteration cycle is solved using an iterative method. 
The iteration process is stopped when the maximum number of iterations (given as calculation 
parameter; by default 10000) is reached, or more likely when all three following conditions are 
fulfilled: 
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- Temperature difference condition 
For every system node the absolute value of the difference between the temperatures 
obtained in the current and previous iteration step must be smaller than the parameter 
maximum temperature difference (by default 0.0001°C). 

- Energy heat balance for the total object 

The residual energy heat flow into or outside the object compared to the total heat flow 
passing through the object must be less than the parameter maximum heat flow 
divergence for total object (by default 0.001 %). 

- Worst energy heat balance for all control volumes 
For all system nodes the residual energy flow into or outside the control volume 
compared to total heat flow passing through the control volume must be less than the 
parameter maximum heat flow divergence for any node (by default 1 %). 

Definition of heat flow divergences: see section D.6. 

D.2.3. Radiation 

Linear radiation (requires RADCON, see Chapter K) 
The linear radiation between two black surfaces is: 
𝑞𝑟 = 𝐹𝑖𝑗 ⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑖 − 𝜃𝑗) 

𝑞𝑟 = radiation heat flux [W/m2] 
𝐹𝑖𝑗  = view factor from surface I to surface j (= fraction of radiation leaving surface i that is 

intercepted by surface j) 
ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 

𝜃𝑖 = temperature of surface i [°C] 
𝜃𝑗 = temperature of surface j [°C] 

The linear radiation between grey surfaces, having an emissivity (as defined in the Colours 

window), is derived from the radiation between the black surfaces by adding supplementary 

resistances between the grey and black surface nodes (cf. section K.2). 
The black radiation heat transfer coefficient is a calculation parameter. The default value is  
5.1 W/(m2.K) (as in EN 673). 

 
Non-linear radiation (requires RADCON, see Chapter K) 
When non-linear radiation is wanted, the coefficient ℎ𝑟𝑏 is locally adjusted in function of the 

surface temperatures, before each new iteration cycle. The surface temperatures are known 
from the previous iteration cycle, or else from the previous existing solution file (when a 
calculation is restarted). For the first iteration cycle when no solution file is present, the calculation 

parameter “black radiation heat transfer coefficient” is used. 
The non-linear radiation model is physically more precise than the linear model (cf. section K.2). 
 
Calculation of view factors (requires RADCON, see Chapter K) 
The view factors calculation between elementary surfaces is affected by the parameter 

Maximum number of view factor faces (per view factor zone): radiative triangle sides are 
clustered into larger view factors if the number of triangle sides in a view factor zone exceeds this 
parameter. In general, the view factor triangulation may be less fine than the system 

triangulation without loss of accuracy. The default value is 500. 
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D.2.4. Automatic calculation of thermal properties 

(See section D.1 for an overview of all automatically calculated thermal properties) 
- Recalculate before each iteration cycle: the automatically calculated thermal properties 

(equivalent thermal conductivities and convective heat transfer coefficients) are 
recalculated before each iteration cycle. 

- Use solution temperatures: the automatically calculated thermal properties are updated 

using the last available solution temperatures. If this option is unchecked, default 
temperature values from the relevant standard (see D.1) or as defined by the calculation 
parameter Default temperature difference for hc calculation for colours not according to 
a standard (no value in ‘Standard’ column, see C.10). 

- Bitmap border is axis of symmetry: the bitmap border acts as adiabatic boundary 
condition (without absorption and only diffuse reflection, which affects the radiative heat 
transfer via the view factors for cavities adjacent to the bitmap border). 

 

During the input (i.e. editing in the Bitmap window, Measures window or Colours window) the 
automatically calculated thermal properties λeq en hc always assume default temperature values 

(mean temperature of 10°C, and fixed temperature difference as imposed by the relevant 
standard (see D.1) or as defined by the calculation parameter “Default temperature difference for 
hc calculation” for colours not according to a standard (no value in ‘Standard’ column, see C.10). 
 

During a system calculation (launched by Calc → Calc System) the automatic calculation of 
thermal properties starts from the solution temperatures, obtained by the last iteration cycle, 

when both calculation parameter options “Recalculate before each iteration cycle” and “Use 

solution temperatures” are checked. The recalculated values are refreshed in the Colours window 
before each iteration cycle. 

 
When the calculation option “Recalculate before each iteration cycle” is checked, also the 
geometric heat flow direction is updated (between X and Y). The new heat flow direction 

depends on the largest component (parallel to X or Y) of the mean temperature gradient, except 
in case of ISO 15099 cavities. In the latter case, the new heat flow direction is determined based 
on the largest of the differences of average surface temperature of either the top and bottom, or 

the left and right sides of the equivalent cavity. 

 
The geometrical heat flow direction “DIR” follows the local temperature gradient and requires 

that both calculation parameter options “Recalculate before each iteration cycle” and “Use 
solution temperatures” are checked. 

D.2.5. Model properties (for ISO 15099) 

The calculation of the equivalent thermal conductivity of frame cavities assuming horizontal heat 
transfer depends, amongst others, on the largest cavity dimension in the physically vertical 
direction Lv. For a sill or head section, the value of Lv can deduced from the bitmap geometry. For 

a jamb section however, the value of LV is the jamb section height. This value needs to be defined 
by the user. 

In case the calculation parameter is set jamb section to and at least one colour with standard 
ISO15099 is present in the bitmap, the “jamb section” label is shown in the status bar. 

D.3. System calculation 

Menu command: Calc → Calc System. 
The following steps are executed: 
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- Automatic triangulation to set up a mesh of object nodes. 

- Calculation of view factors (if required). 
- Per iteration cycle setting up and solving a system of linear equations. 

A linear problem can be handled using 1 iteration cycle. 
A non-linear problem (e.g. non-linear radiation) requires several iteration cycles. 

- Save the solution. 

D.4. Automatic triangulation 

Before starting the triangulation, the BISCO data are saved to a BSC file. 
The result of the triangulation is written to a TRI file in the same directory of the BSC file. 
The resolution of the coordinates of the triangulation vertices is 16 times finer than the pixel 

resolution of the bitmap. 
When a TRI file with the same file name as the BSC file name already exists, the user is asked to 
keep this TRI file (and skip the triangulation, which is valid when the geometry is not modified) or 

to redo the triangulation (and overwrite the existing TRI file). 
 
The following parameters are used for the triangulation: 

- The contour approximation margin (calculation parameter). 

- The triangulation mesh sizes (per material colour, defined in the Measures window). 
 
The triangulation consists of the following steps: 

- Contouring. 
- Straightening contours. 

- Calculation of inner nodes. 
- Creation of the triangulation mesh. 

D.4.1. Contouring 

Contouring is the process of finding the borderlines between the colour zones in the bitmap, and 
connecting them into polygons. Only the contours of the colours assigned to materials (type 
MATERIAL, EQUIMAT and TRANSMAT) are created. 

Step lines in the bitmap are converted into slanting lines. The contouring is done in a reversible 
way, so that rasterising the contours would yield the original bitmap. 

D.4.2. Straightening contours 

The purpose of straightening is to reduce the number of contour edges by skipping redundant 

vertices, so that the new contours lay within the contour approximation margin  (defined as 
calculation parameter; cf. section D.2.1) with respect to the original contours. 

 
Sometimes straightening can cause problems, when self-intersecting contour edges are created. 
That is why the contour approximation margin  should not be chosen too large. 
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For bitmaps derived from CAD drawings, straightening normally should not be applied ( = 0). 
For bitmaps of scanned images, where scan noise may be present, apply a small margin:  ≤ 1. 

D.4.3. Calculation of inner nodes 

Inner nodes are positioned within each material upon a hexagonal grid (in order to obtain 

equilateral triangles). 
Each contour line longer than the triangulation mesh size (for the two colours at both sides of the 
contour line) is split into shorter segments by inserting new nodes on the contour line. 

D.4.4. Creation of the triangulation mesh 

The contour nodes and inner nodes are used to form triangles so that the smallest triangle angle 
occurring is maximal. This principle (Delaunay triangulation) assures the best possible 
triangulation mesh for finite element analysis. A good triangulation mesh allows to generate a 
well-conditioned system, which guarantees a fast and stable solution. 

 

D.5. Solving the system 

When the triangulation is finished, the iterative system solution is started. 
The calculation process can be followed on the calculation monitor. 
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Calculation of view factors (requires RADCON, see Chapter K) 

When at least one colour of type BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT is present, all 
geometric view factors between radiative surfaces are calculated. The number of calculated view 
factors is shown on the calculation monitor. The view factors between elementary surfaces (i.e. 
edges of the triangles in the triangulation) are calculated using analytic formulas. The visibility 

between the surfaces (i.e. possible obstruction by other surfaces) is estimated by 100 test rays 
between random points on both surfaces, and the corresponding view factors are reduced 
accordingly. Afterwards the view factors are rebalanced so that all geometric laws (sum of view 
factors equals 1, and view factor reciprocity law for each pair of surfaces) are satisfied. 
 
Remark on adjacent colours of type BC_FREE or BC_FRE_S 

A cavity or layer can be modelled using several adjacent colours having different thermal properties (e.g. 

surface heat transfer coefficient), though must all have the same type (i.e. all BC_FREE or all BC_FRE_S). 

In the implementation of BISCO, all these adjacent colours are assumed to be linked, meaning they are 

represented by a single convective node in the thermal system. Possible convective heat powers for the 

individual colours in the same cavity (column Pc in the Colours window) are cumulated and allocated to the 

single convective node. 

In case of colours of type BC_FRE_S, this means all colours get the same calculated environmental 

temperature.  

In case of colours of type BC_FREE, this means all colours get the same calculated air temperature. The 

radiative heat transfer is calculated taking together all these colours forming one zone in which all view 

factors are calculated. 

 
Thermal system 

Per control volume around a node an energy balance is written: the sum of incoming heat flows 
equals the sum of outgoing heat flows, because of the steady state. The heat flows are expressed 

as linear functions of the unknown temperatures of adjacent nodes. This results in a linear system 
of equations. 
The linear system is solved using a fast and stable iterative method. 

 
Calculation monitor 
The iteration process can be followed on the calculation monitor: cycle, iteration step, largest 

temperature difference for all nodes between the last two iteration steps, heat flow divergence 
for total object, maximum node heat flow divergence, together with the corresponding 
tolerances (i.e. stopping criteria). The monitor also displays the number of calculated view 

factors, the number of system nodes and the number of triangles in the triangulation. 
 
Solution files 
The calculation is finished when the stopping criteria are met, defined by the calculation 

parameters (cf. section D.2). 
The final node temperatures are saved in a SOL file (extension .sol). 
The heat flow function values at the triangle vertices of the triangulation (used to draw heat flow 
lines) are saved in a FLW file (extension .flw). 
The heat flow densities in the object nodes are saved in a FLX file (extension .flx). 
The solution files have the same file name as the BSC input data file and are saved in the same 
directory. 

 
Temperatures out of range 

Sometimes it is possible that some calculated node temperatures fall outside the range of 
boundary condition temperatures. This is due to the control volume method. The differences 
become smaller by decreasing the triangulation mesh sizes. 
 



Manual BISCO v13.0 57 

Calculation interruption 

The calculations can be stopped at any time by pressing <Esc>. When the iteration process has 
already started, the intermediate temperatures are saved in a SOL file. When restarting the 
calculation, these intermediate temperatures are reloaded as new starting values. 

D.6. Heat flow divergences 

The quality of the solution is mainly determined by the heat flow divergence of the total object, 
called in short object divergence. It is defined as the sum of all heat flows (positive and negative) 
entering the object, divided by half the sum of the absolute values of all these heat flows: 

𝑂𝐷 =
|𝛷𝑖𝑛,𝑜 − 𝛷𝑜𝑢𝑡,𝑜|

0.5 ⋅ (|𝛷𝑖𝑛,𝑜| + |𝛷𝑜𝑢𝑡,𝑜|)
⋅ 100 

with 𝑂𝐷 = object divergence [%] 
𝛷𝑖𝑛,𝑜= total incoming heat flow for the object [W] 

𝛷𝑜𝑢𝑡,𝑜= total outgoing heat flow for the object [W] 

 
By using the factor 0.5 in the denominator, the denominator can be interpreted as the heat flow 
"passing" the object. 
The maximum possible object divergence is 200 %, i.e. when there are only incoming heat flows 

and no outgoing heat flows: 𝛷𝑖𝑛,𝑜 > 0 and 𝛷𝑜𝑢𝑡,𝑜 = 0 (or vice versa 𝛷𝑖𝑛,𝑜= 0 and 𝛷𝑜𝑢𝑡,𝑜> 0). 

An object divergence tolerance (cf. calculation parameter “Maximum heat flow divergence for 
total object”) of 0.001 % is recommended as reliable stopping criterion. According to EN ISO 10211 
the object divergence should be less than 0.1 %. 
 
In BISCO also a second heat flow divergence is used as stopping criterion: the maximum heat 
flow divergence for all nodes, called in short node divergence. It is defined in a similar way as the 
object divergence: 

𝑁𝐷 = 𝑚𝑎𝑥𝑛(
|𝛷𝑖𝑛,𝑛 − 𝛷𝑜𝑢𝑡,𝑛|

0.5 ⋅ (|𝛷𝑖𝑛,𝑛| + |𝛷𝑜𝑢𝑡,𝑛|)
⋅ 100) 

with 𝑁𝐷  = node divergence [%] 
𝛷𝑖𝑛,𝑛= total incoming heat flow for the control volume around node n [W] 

𝛷𝑜𝑢𝑡,𝑛 = total outgoing heat flow for the control volume around node n [W] 

 
In BISCO the default node divergence tolerance is 1 % (cf. calculation parameter “Maximum heat 

flow divergence for any node”). 
Sometimes it happens that the node divergence does not decrease during the calculation. This is 

caused by an “unlucky” node, that is connected to its neighbouring nodes in an “unfavourable” 
way (due to obtuse triangles and/or strongly different thermal conductivities). Then a higher node 
divergence tolerance should be set. 
Cancel the node divergence test by using a node divergence tolerance of 201 % (which is higher 
than the theoretical 200 %, to be safe for possible numerical rounding errors). 

D.7. Batch processing 

Command: File → Batch Processing… 
 
In the Batch Processing dialog box you can choose which BSC files to handle, and which actions 
to execute. 
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Add BSC files by pressing the Add button and selecting one or more BSC files from the same data 
file folder (hold down the <Ctrl> key or <Shift> key to select more than one file). You can do this 

multiple times to select files in different directories. 
Note that for each BSC file a corresponding BMP file must be present in the same directory as the 
BSC file. 
 
Select one or more actions to execute on each file: 

- (Re)triangulate (only enabled if (Re)calculate is checked): forces triangulation even if a 

triangulation is already available in a TRI file. 
- (Re)calculate: If checked the thermal calculation is done, as with the command Calc → 

Calc System. The calculation results are saved in SOL, FLX and FLW files. 

- Generate Word report: creates all report files as with the command Calc → Make Report, 

cf. G.2. 
- Generate PDF report: as with the command Calc → Make PDF Report, cf. G.3. For each 

BSC file it uses the file’s PDF settings if a PDF has been made manually before, otherwise 
it uses the default PDF settings. 

- Generate PDF summary report: as with the command Calc → Make PDF Report, selecting 

the summary report. 

 
If a solution file is not yet available, checking Generate Word report and/or checking Generate 
PDF report will automatically trigger a calculation and (re)triangulation. 

 
A word of caution: all generated files overwrite existing files with the same name, without 
warning. 

D.8. DXF batch processing 

Command: File → DXF Batch Processing… 
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Add DXF files by pressing the Add button and selecting one or more BSC files from the same data 
file folder (hold down the <Ctrl> key or <Shift> key to select more than one file). You can do this 
multiple times to select files in different directories. 
 
A bitmap file is created based on the layer definition file (with extension .lay), or colour numbers 

and fill modes, as defined in the DXF layer names (format “xxx_y_name”, cf. section H.3). 
The colour palette originates from the default bitmap ColourPalette.bmp (see section J.3). 
The thermal properties originate from the default data file ColourDatabase.bsc  
(cf. section J.3). 

 

The user can decide if, after creation, the bitmap is to be prepared for EN ISO 10077-2 (See 
Bitmap → NFRC 100/500 Preparation) or NFRC 100/500 (Bitmap → NFRC 100/500 Preparation). 

 
The following actions are available: 

- Triangulate and Calculate: if checked the triangulation and thermal calculation is done, as 
with the command Calc → Calc System. The calculation results are saved in SOL, FLX and 

FLW files.  

- Generate Word report: creates all report files as with the command Calc → Make Report, 

cf. G.2 (only available if Triangulate and Calculate is checked). 
- Generate PDF report: as with the command Calc → Make PDF Report, cf. G.3. For each 

BSC file it uses the file’s PDF settings if a PDF has been made manually before, otherwise 

it uses the default PDF settings (only available if Triangulate and Calculate is checked). 
- Generate PDF summary report: as with the command Calc → Make PDF Report, selecting 

the summary report. 

 
A word of caution: all generated files overwrite existing files with the same name, without 
warning. 

D.9. Command line program execution 

BISCO can be run from the command line prompt with a data file path (including directory and 
file extension .bsc, .bmp or .dxf) as parameter to open that file. When a DXF file is opened from 
the command line, the BMP and BSC files created (H.3) are automatically saved. 

 
Example of command line launching of BISCO and opening a file: 
Run → “c:\…\Physibel\BISCO13\BISCO.exe” “…\Documents\Physibel\BISCO13\Demofiles\1 – 

WINDOWS & DOORS\alu_1_frame_panel_prepared.dxf” 
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Flags can be added to the command line prompt determining which actions need to be taken 
after opening the file (BSC, DXF or BMP), analogous to the choices offered in the Batch 
Processing dialog box (D.7 and D.8): 

- Either “/EN10077” or “/NFRC” for preparation for EN ISO 10077-2 or NFRC 100/500, 

respectively. 
- “/triangulate” to force retriangulation. 
- “/calculate” for the thermal calculation. 
- “/word”, “/csv”, “/pdf” and/or “/pdf_summary” for the different types of reports. 

 
Example of command line launch: 

Run → “c:\…\Physibel\BISCO13\BISCO.exe” “…\Documents\Physibel\BISCO13\Demofiles\1 – 

WINDOWS & DOORS\ alu_1_frame_panel_prepared.dxf” /EN10077 /calculate /pdf 
 
Alternatively to adding flags, the legacy system adding the switch  “/Automation” is still available 
to prepare according to EN ISO 10077-2, triangulate, start calculation and make MS WORD 
report files, as in a batch processing (cf. section D.7 and D.8). 

 
Example of command line launch: 
Run → “c:\…\Physibel\BISCO13\BISCO.exe” “…\Documents\Physibel\BISCO13\Demofiles\1 – 

WINDOWS & DOORS\shutter_box.bsc” /Automation 

D.10. Derived thermal properties 

The following derived thermal properties can be reported in the Text Output window or the 

reports after executing the system calculation and using the definition of distances (in the 

Distances window) and, if relevant, border U-values (in the Border U Values window). 

Check the desired thermal properties in the Derived Thermal Properties dialog box (via Edit → 
Derived Thermal Properties…). Not applicable items are greyed (i.e. disabled). 
 
The derived thermal properties are either thermal transmittances (D.10.1 - D.10.3) or related to 
surface condensation (D.10.4 and 0). 



Manual BISCO v13.0 61 
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D.10.1. Linear thermal transmittance 

This quantity can only be reported if two boundary conditions with different temperatures apply 

and at least one distance is defined in the Distances window. 

 
The linear thermal transmittance (𝛹 or psi-value) is a correction term for the 2-D influence of a 
thermal bridge when calculating the heat flow (per unit temperature difference between both 

environments) from 1-D thermal transmittances (or U-values) of flanking elements. The user can 
add a subscript to the name freely (e.g. 𝛹𝑇𝐽 for the linear thermal transmittance of a Thermal 

Joint according to EN ISO 12631). 
 

The applied formulas (cf. EN ISO 10211) are: 

𝛹 =
𝛷

𝜃𝑖 − 𝜃𝑒
− 𝑈1 × 𝑙1 − 𝑈2 × 𝑙2 − 𝑈3 × 𝑙3 

 
with 𝛹 = linear thermal transmittance [W/(m.K)] 

𝛷 = total heat flow through object [W/m] 
𝜃𝑖 = internal boundary condition temperature [°C] 
𝜃𝑒 = external boundary condition temperature [°C] 
𝑈1 = thermal transmittance of first flanking element [W/(m².K)] 

𝑙1 = width of first flanking element [m] 
𝑈2 = thermal transmittance of second flanking element [W/(m².K)] 
𝑙2 = width of second flanking element [m]  

 𝑈3 = thermal transmittance of third flanking element [W/(m².K)] 
𝑙3 = width of third flanking element [m] 

 
The U-values of the flanking elements are determined along the left, right, top or bottom border 

of the bitmap, or along a distance in the Distances window, as specified in the Derived Thermal 

Properties dialog box. The presence of a U-value assumes that both boundary conditions occur 

at the opposite ends and in between are (equivalent) material layers, so that the U-value can be 
calculated. If this is not the case at some bitmap border sides, those sides are disabled in the 
dialog box. 
The automatically calculated U-values of the flanking elements used in the equation for 𝛹 can 

differ slightly from the values shown in the Border U Values window (C.13) and the Distances 
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window (C.15), because the calculated surface temperatures are used for the coefficient ℎ𝑟𝑏 (non-

linear radiation) for types TRANSMAT, BC_FREE and BC_SKY. 

The widths of the flanking elements are defined by distances in the Distances window, up to two 

per element. 
If the check box of the second flanking element is not marked in the dialog box, then 𝑈2 = 𝑙2 = 0 is 
assumed in the formulas above, and likewise for the third flanking element. 

D.10.2. Equivalent thermal transmittance (U) – based on flanking elements with 1-D U-values 

BISCO allows to calculate the equivalent thermal transmittance of an element, based on 
subtracting the influence of flanking elements with known 1D U-values from the calculated total 
heat flow through the entire object. This is only possible when two boundary conditions with 

different temperatures apply and at least one distance is defined in the Distances window.  

 
The user can add a subscript to the name freely (e.g. 𝑈𝑓 for the thermal transmittance of a 

window frame according to EN ISO 10077-2). 
 
The following formula is used: 

𝑈 =

𝛷
𝜃𝑖 − 𝜃𝑒

− 𝑈1 × 𝑙1 − 𝑈2 × 𝑙2 − 𝑈3 × 𝑙3

𝑙
 

with 𝑈 = equivalent thermal transmittance of element  [W/(m².K)] 
𝛷 = total heat flow through object  [W/m] 

𝜃𝑖 = internal boundary condition temperature  [°C] 
𝜃𝑒 = external boundary condition temperature  [°C] 

𝑈1 = thermal transmittance of first flanking element  [W/(m².K)] 
𝑙1 = width of first flanking element  [m] 
𝑈2 = thermal transmittance of second flanking element  [W/(m².K)] 

𝑙2 = width of second flanking element  [m] 
 𝑈3 = thermal transmittance of third flanking element  [W/(m².K)] 

𝑙3 = width of third flanking element  [m] 

𝑙 = width of element  [m]  
 
The U-values of the flanking elements are determined along the left, right, top or bottom border 

of the bitmap, or along a distance in the Distances window, as specified in the Derived Thermal 

Properties dialog box. The presence of a U-value assumes that both boundary conditions occur 

at the opposite ends and in between are (equivalent) material layers, so that the U-value can be 
calculated. If this is not the case at some bitmap border sides, those sides are disabled in the 
dialog box. 
The automatically calculated U-values of the flanking elements used in the equation for 𝑈 can 

differ slightly from the values shown in the Border U Values window (C.13) and the Distances 

window (C.15), because the calculated surface temperatures are used for the coefficient ℎ𝑟𝑏 (non-

linear radiation) for types TRANSMAT, BC_FREE and BC_SKY. 

The widths of the flanking elements are defined by distances in the Distances window, as is the 

width of the element for which the equivalent U-value is calculated itself, which can consist of up 
to two distances. 
If the check box of the second flanking element is not marked in the dialog box, then 𝑈2 = 𝑙2 = 0 is 

assumed in the equation above, and likewise for the third flanking element. 
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D.10.3. Equivalent thermal transmittance (U) – based on incoming heat flow from boundary 
condition 

An alternative way to D.10.2 for defining the equivalent thermal transmittance of an element is to 
assess the heat flowing into that element from the boundary condition. This is only possible when 
two boundary conditions with different temperatures apply and at least one distance is defined in 

the Distances window. 

 
The user can add a subscript to the name freely (e.g. 𝑈𝑒𝑔 for the thermal transmittance of an 

edge-of-glazing zone according to NFRC 100 and ISO 15099). 
 

The following formula is used: 

𝑈 =

𝛷1 + 𝛷2
𝜃𝑖 − 𝜃𝑒

𝑙
 

with 𝑈 = equivalent thermal transmittance of element  [W/(m².K)] 
𝛷1 = heat flow into object from boundary condition 1  [W/m] 
𝛷2 = heat flow into object from boundary condition 2  [W/m] 

𝜃𝑖 = internal boundary condition temperature  [°C] 
𝜃𝑒 = external boundary condition temperature  [°C] 
𝑙 = width of element  [m]  

 

The equivalent thermal transmittance of up to 3 elements can be determined simultaneously. For 
each element, the incoming heat flow of up to 2 user-defined interior boundary condition colours 

can be taken into account and the width of the element can consist of up to two distances 

defined in the Distances window. If the check box for the second boundary condition is not 
marked in the dialog box, then 𝛷2 = 0 in the equation above. 

D.10.4. Temperature factor or CI (Condensation Index) 

The temperature factor is a dimensionless expression of the minimum internal surface 

temperature in order to assess the risk of surface condensation. It can only be evaluated if two 
boundary conditions with different temperatures apply: the external temperature and the internal 
temperature. 

The user can select which nomenclature is used in reporting for this derived thermal property: 
temperature factor (cfr. EN ISO 10211) or Condensation Index (cfr. NFRC 500). 
 

The evaluation formula for the temperature factor f (cf. EN ISO 10211 and EN ISO 13788) is: 

𝑓 =
𝜃𝑠𝑖,𝑚𝑖𝑛 − 𝜃𝑒

𝜃𝑖 − 𝜃𝑒
 

with 𝑓  = temperature factor [-] 

 𝜃𝑖 = internal boundary condition temperature [°C] 
 𝜃𝑒 = external boundary condition temperature [°C] 
 𝜃𝑠𝑖,𝑚𝑖𝑛 = minimum internal surface temperature [°C] 

 

The Condensation Index (CI) is calculated as2:  

𝐶𝐼 =
𝜃𝑠𝑖,𝑚𝑖𝑛 − 𝜃𝑒

𝜃𝑖 − 𝜃𝑒
∙ 100 

 

 
2 Note that the Condensation Index is thus calculated based on the lowest internal surface temperature 

occurring in the entire model. This differs on the safe side from the formal definition of CI in NFRC 500, 

where a designated zone around the frame-to-glass junction is not evaluated. 
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The output also reports: 

- The internal heat transfer coefficient ℎ𝑖[W/(m2.K)] and internal surface resistance 𝑅𝑠𝑖 
[m2.K/W] where 𝜃𝑠𝑖,𝑚𝑖𝑛 applies. 

- The relative humidity above which surface condensation occurs for the air at the internal 
boundary condition temperature. 

 
The temperature factor can only be validly calculated for temperatures in a range of -30°C up to 
100°C.Internal surface relative humidity 

In the Graphic Output window, the zones at the internal surface where a defined surface relative 
humidity is met or exceeded, given the inside zone relative humidity (as first input parameter), 
can be indicated. Two options are available: 

• Indicate the zones where internal surface condensation occurs (i.e. internal surface 
relative humidity = 100 %). 

• Indicate the zones where the internal surface relative humidity exceeds a user-defined 

value (between 0 % and 100 %) 
 
The internal surface relative humidity can only be calculated on surfaces adjacent to a boundary 
condition of subtype ‘HI’ (or variants, such as ‘HI_NORML’ and ‘HI_REDUC’) or of type BC_SKY, 
subtype CONVEC (for ISO 15099).  
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CHAPTER E TEXT OUTPUT 

The Text Output window is opened using the command Output → Text Output. The main BISCO 

application window is replaced by a new window with a new menu bar and toolbar. Return to 
the main input window by choosing the command File → Exit or pressing <Esc>. 

 

Views 

Two different contents can be viewed in the Text Output window: 

- An overview of input data (shown with the command View → Input Data). 

- An overview of calculation results (shown with the command View → Calculation Results). 

 
Saving 

The user can select any part in the Text Output window and copy it into the clipboard (using Edit 

→ Copy). The contents of the clipboard can then be pasted into any other program (e.g. 

Microsoft Word). 
The text in the current view can also be saved into a DOC file (Microsoft Word document) using 
the command File → Save As…. 

The command File → Save to CSV Files saves the text output to CSV files for use in a spreadsheet 

program (e.g. Microsoft Excel). 
 

 

E.1. Input data 

The Input Data view (View → Input Data) displays: 

- Document notes. 
- BSC file name + BMP file name. 
- Pixel size. 
- Colour measures + triangulation sizes. 
- Thermal properties (per colour). 
- Borderline boundary conditions. 
- Calculation parameters. 
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E.2. Calculation results 

The Calculation Results view (View → Calculation Results) displays: 

- BSC file name. 
- Number of system nodes, resulting object divergence and node divergence. 
- Derived thermal properties (cf. section D.10). 
- List of minimum and maximum temperatures per colour, (air) temperature per BC_FREE 

or BC_FRE_S boundary condition, and incoming and outgoing heat flows per boundary 
condition. 

 
Output precision 
Command: Settings → Decimals…. 

Enter the number of decimals for the output of temperatures and heat flows. 
 

  
 
Remark on listed heat flows for adjacent boundary conditions 

The incoming and outgoing heat flows per boundary condition colour, as listed in the calculation results, 

are equal to the sums of elementary incoming and outgoing heat flows for all control volumes of the 

system nodes that border that boundary condition colour. This is done this way because the system solution 

is also based on energy balances containing these elementary heat flows. 

When a system node is located in between two adjacent boundary conditions, then the elementary heat 

flow is attributed to one of the adjacent boundary conditions. This implies that the total heat flow for one 

boundary condition colour is somewhat overestimated, and that the total heat flow for the other boundary 

condition colour is somewhat underestimated. The sum of heat flows of all adjacent boundary conditions 

however is correct. 
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CHAPTER F GRAPHIC OUTPUT 

 

The Graphic Output window is opened using the command Output → Graphic Output. The main 

BISCO application window is replaced by a new window with a new menu bar and toolbar. 
Return to the main input window by choosing the command File → Exit. 
 

 
 
The triangulation file (with extension .tri) and solution files (with extensions .sol, .flx, .flw) are 
loaded and all output (except for View → Fill Bitmap) is drawn using the triangulation geometry. 
The image can be zoomed using the commands in the Zoom submenu, which are identical to 
those in the main input menu. 

F.1. View options 

View submenu 

 
 

- View → Object Lines: show contours of material colours. 
- View → Triangulation Mesh: show triangles of triangulation. 
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- View → Isothermal Lines: show isothermal lines conform to the temperature range 

parameters (Settings → Temperature Range…). 
Only possible when a calculation solution is available. 

- View → Heat Flow Lines: show heat flow lines (orthogonal to the isothermal lines) conform 
to the heat flow parameters (Settings → Heat Flow Increments…). 

Only possible when a calculation solution is available. 
In the triangles of the triangulation around heat source nodes (i.e. nodes on borderline 
boundary conditions) no heat flow lines are drawn. When heat sources are present, 
discontinuities in the heat flow lines may occur. A good choice of heat flow increment (i.e. 
an integer divisor of the heat source power) may eliminate those discontinuities. 
The quality of the heat flow lines pattern is sensitive to the stopping criterion of object 

divergence. A smaller value improves the quality. 
- View → Distances: show distance lines. 

The distance number is centred on each distance line. 

- View → Humidity: show internal surface humidity zones (e.g. surface condensation) 
conform to the parameters of the derived thermal properties (Edit → Derived Thermal 
Properties… from the main menu). 

 
- View → Fill Bitmap: show original bitmap. 

If View → Legend is selected, labels with colour numbers are added. 

- View → Fill Materials: fill object materials using the bitmap colours. 
- View → Fill Boundary Conditions: fill boundary conditions using the bitmap colours. 
- View → Fill Temperatures: fill object with temperature colours conform to the temperature 

range parameters (Settings → Temperature Range…). 
Only possible when a calculation solution is available. 

- View → Fill Conductive Fluxes: fill object with conductive heat flux magnitudes conform to 

the flux range parameters (Settings → Flux Range…). 
Only possible when a calculation solution is available. 

- View → Infrared Radiation: show infrared radiation heat flux at surfaces with radiative 

heat transfer (TRANSMAT, BC_FREE, BC_SKY, BC_NOSKY) conform to the flux range 
parameters (Settings → Flux Range…). 
Only possible when a calculation solution is available. 

- View → Fill Off: switch off filling. 
 

- View → Legend: show a legend bar at the right side of the figure (exception: show colour 
labels for View → Fill Bitmap). 

F.2. Labels within graphic output 
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The graphic output can be clarified with text labels, set by the user. 
Click the right mouse button within the graphic output to open a popup menu with label options: 

- Label colour name: set name (as defined in Colours window) of colour under mouse point. 

- Label thermal properties: set name and local thermal conductivity or boundary condition 
properties. 

- Label X dimension of colour: set local colour width. 
- Label Y dimension of colour: set local colour height. 

- Label node temperature: set temperature of closest object node. 
- Label minimum temperature of colour: set name and minimum temperature of local 

colour. 
- Label maximum temperature of colour: set name and maximum temperature of local 

colour. 
- Label temperature factor: set temperature factor at position of minimum internal surface 

temperature. 
- Label internal surface condensation: set dew point and length of internal surface 

condensation. 

- Label internal surface humidity: set temperature and length at internal surface with user 
defined surface relative humidity (see Derived Thermal Properties, from the main menu). 

- Label heat flow through (poly)line: set heat flow through polyline between object nodes. 
The vertices of the polyline are defined using successive left mouse clicks. Press <Enter> to 
end the polyline. Press <Esc> to remove the last line segment. 

- Delete all labels: remove all labels. 

- Hide all labels: hide all labels. 
- Show all labels: show the hidden labels again. 

 

When the mouse cursor is over a label, this label can be moved to a new position by dragging. 
 
A label can be edited or deleted by clicking the right mouse button when the mouse cursor is over 

that label: 
- Edit label: edit label text. 
- Delete label: remove label. 

 
The graphic output labels cannot be saved in the data file, and should be output in a PNG image 

file (File → Save As…) before exiting the current data file. 

F.3. Settings 

  
 

Settings → Temperature Range… 

- Use boundary condition temperatures: initialise the minimum and maximum temperatures 

from the boundary condition temperatures present in the Colours window. This function is 

only enabled when exactly 2 boundary condition temperatures (type BC_SIMPL, 
BC_FRE_S or BC_SKY with θa = θr) are present in the model. 
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- Minimum temperature [°C] in graphic output. 

- Maximum temperature [°C] in graphic output. 
- First (or minor) increment [°C].  

Used for temperature filling (View → Fill Temperatures) and isothermal lines  

(View → Isothermal Lines). 

- Second (or major) increment [°C] (must be a multiple of first increment).  

Only used with isothermal lines (View → Isothermal Lines). 

- Single temperature value [°C] (e.g. dew point).  
Only used with isothermal lines (View → Isothermal Lines). 

 

  
 

Settings → Flux Range… 

 

  
 

Settings → Heat Flow Increments… 

 

  
 
Settings → Line Styles…  

 
A colour field can be edited by double clicking with the left mouse button, which opens a Colour 
dialog box in which the colour value (RGB components) can be defined. 

 
The width of isothermal lines and heat flow lines can be set to 0 pixels to hide them. This is useful 
when e.g. only the second isothermal lines are desired in the figure. 
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Settings → Fill Colours… 

 

 



Manual BISCO v13.0 73 

 

Colours with automatically calculated properties (see D.1) are clustered thematically in the 

Graphic Output window according to the categories of the Fill Colours dialog box, to avoid a 

potentially long list of colours of the same type (and subtype and standard) with small variations 
in the calculated thermal property. The fill colour of the clusters can be edited by double clicking 
on it with the left mouse button, which opens a Colour dialog box in which the colour can be 
defined. 
 

Settings → Boundary Conditions as Lines 

This is a switch option to decide if View → Fill Boundary Conditions draws the boundary 

conditions (types BC_SIMPL, BC_SKY, BC_NOSKY, BC_FREE and BC_FRE_S) as lines on the 
object lines or using filling colours as in the bitmap. 

 
Settings → Image Size… 

Set image size for saving PNG files (File → Save As…). 

 

   
 
The font size refers to text characters in the legend or labels. 
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CHAPTER G REPORT 

G.1. Graphic report definition 

The command Edit → Graphic Report Definition opens a window for the definition of (up to 8) 

graphic report files. 
 

 
 

The parameters correspond to the options of the View submenu in the Graphic Output window 
(except for Caption). Note that the defined captions are only used in the PDF report (G.3). Note 

also that only user-defined labels (see F.2) will be included in the figure when setting Labels to 
“YES”. 
The bitmap size, line types and increments correspond to the settings from the Settings submenu 

in the Graphic Output window. 

The file name of each report bitmap consists of the file name of the BSC data file appended with 
the image number (1 to 8). 

G.2. MS Word Report 

From the main menu the command Calc → Make Report generates a number of graphic files 

and text files with which a report can be created from a report template document (e.g. in 

Microsoft Word). In addition, this command copies the report template from the personal folder 
(see J.4) into the directory of the current BSC file, gives it the same name as the BSC file, 
appended with “_report” and opens it. Be careful to save the resulting report under a different 
name or in a different location if you want to repeat this process for the same BSC file, otherwise 
the report will each time be overwritten. 

All report files are written in the directory of the BSC data file. 

G.2.1. Report text files 

Up to 8 files are created (as part of Calc → Make Report). 

The BSC file name (“FileName”) is appended with fixed extensions: 

- FileName_DAT.txt: BISCO input data (as in Text Output window: View → Input Data). 

- FileName_RES.txt: calculation results (as in Text Output window: View → Calculation 

Results). 
- FileName_MAT.txt: material properties. 
- FileName_BOC.txt: boundary conditions. 
- FileName_EQM.txt: thermal conductivities of air cavities (colours of type EQUIMAT or 

TRANSMAT). 
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If the corresponding item is checked in the Derived Thermal Properties dialog box (Edit → 

Derived Thermal Properties…): 
- FileName_TFC.txt: temperature factor table (D.10.4) 

- FileName_PSI.txt: linear thermal transmittance table (D.10.1) 
- FileName_UFR.txt: equivalent thermal transmittance (based on flanking elements with 1-D 

U-values) table (D.10.2). 

G.2.2. Report index file 

The report index file “FileName.bri” (with same file name as input data file “FileName.bsc”) is 
created as part of Calc → Make Report and contains references to all other report files and 

output of numeric values. 

Each line starts with a keyword followed by the corresponding name or value: 
- GRA# FileName#.png: graphic report file (# = 1,2,…,8) 

- TDAT FileName_DAT.txt 

- TRES FileName_RES.txt 

- TMAT FileName_MAT.txt 

- TBOC FileName_BOC.txt 

- TEQM FileName_EQM.txt 

- TTFC FileName_TFC.txt 

- TPSI FileName_PSI.txt 

- TUFR FileName_UFR.txt 

- VBMP ---.bmp: file name of input bitmap 

- VPIX ---: pixel size [m] 

- VTRI ---: global triangulation size [pixels] 

- VNOD ---: number of nodes 

- VTFC ---: temperature factor [-] 

- VPSI ---: linear thermal transmittance [W/(m.K)] 

- VUEQ ---: equivalent thermal transmittance [W/(m².K)] 

- VUF1 ---: thermal transmittance of first flanking element [W/(m².K)] 

- VLF1 ---: length of first flanking element [m] 

- VUF2 ---: thermal transmittance of second flanking element [W/(m².K)] 

- VLF2 ---: length of second flanking element [m] 

- VUFR ---: thermal transmittance of frame [W/(m².K)] 

- VWFR ---: width of frame [m] 

- VUP1 ---: thermal transmittance of first insulation panel [W/(m².K)] 

- VWP1 ---: width of first insulation panel [m] 

- VUP2 ---: thermal transmittance of second insulation panel [W/(m².K)] 

- VWP2 ---: width of second insulation panel [m] 

If a value is not applicable, then the value after the keyword is omitted. 

G.2.3. Creating a MS Word report document  

The file BiscoReportTemplate.doc (in the personal folder, see J.4) contains a toolbar button with 

macro to import all report files referenced by a selected BISCO report index file (with extension 
.bri) into bookmarked locations. It is a fast method to create a report document with text 
comments and layout predefined by the user. 

 
The report template from the personal folder is automatically copied into the directory of the 
current BSC file, gives it the same name as the BSC file, appended with “_report” and opens it. Be 
careful to save the resulting report under a different name or in a different location if you want to 
repeat this process for the same BSC file, otherwise the report will each time be overwritten. 
 

In case of a security warning “Macros have been disabled” apply “Enable Content”. 
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Optionally, to visualise the bookmark signs, apply 

File → Options → Advanced → Show document content → Show bookmarks. 
Visual bookmark signs are required when changing the report layout and contents. 

 
To import data and results of only 1 BISCO simulation: 
- Run the toolbar button “BISCO Load”. 
- and select and open 1 BRI file in the BISCO data folder. 
The macro will put the BISCO graphic and text files and the relevant values in the document at 
the predefined bookmarks. 

Running the toolbar button “BISCO Clear” directly after running BISCO Load, undoes the insertion. 
 
To import data and results of multiple BISCO simulations: 

- Run the toolbar button “BISCO Load”. 
- and select and open multiple BRI files in the BISCO data folder. 
The macro will put the BISCO graphic and text files and the relevant values for each of the BISCO 
simulations at the end of the document, leaving the first pages untouched. These first pages can 
be deleted now. 

The toolbar button “BISCO Clear” cannot be used to undo the import of multiple simulations. 

G.3. PDF report 

From the main menu the command Calc → Make PDF Report opens the Report Settings Dialog. 

The dialog offers options to customize the PDF report and shows a preview. 
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To navigate to the next/previous page you can use the buttons below the preview or keyboard 

keys <PageDown> and <PageUp>. You can use <Ctrl>+ to zoom in, <Ctrl>- to zoom out and 
<Ctrl>0 to reset the zoom level. 
 
There are four report types: 

- Custom 
o All figures as defined in Graphic Report Definition (G.1), including captions and with 

size according to the Image Size settings in the Graphic Output (F.3). 
o A table with all material properties. 
o A table with all boundary conditions. 
o The derived thermal properties selected in the Derived Thermal Properties Dialog 

(D.10), insofar as they can be determined. 
- Summary 

o Single line summary of the derived thermal properties (see lower). 
o A figure with Materials fill mode and object lines (F.1), together with a table with all 

material properties. 
o A figure with Temperatures fill mode, with object lines, isothermal lines and a 

legend (F.1). 
All figures sizes are according to the Image Size settings in the Graphic Output 
(F.3), but with a minimum of 1200x900 pixels. 

o The details of the derived thermal properties selected in the Derived Thermal 
Properties Dialog (D.10), insofar as they can be determined. 

- EN ISO 10077-2 

o Single line equivalent thermal transmittance (Uf) (see lower). 
o A figure with Materials fill mode and object lines (F.1), together with a table with all 

material properties. 
o A figure with Boundary Conditions fill mode and object lines (F.1), together with a 

table with all material properties. 
o A figure with Temperatures fill mode, with object lines, isothermal lines and a 

legend (F.1). 
o A figure with object lines and heat flow lines (F.1). 

All figures sizes are according to the Image Size settings in the Graphic Output 

(F.3), but with a minimum of 1200x900 pixels. 
o The details of the equivalent thermal transmittance (Uf), insofar as it can be 

determined. 
- NFRC 100 

o Single line equivalent thermal transmittances (Ufr and Ueg) (see lower). 
o A figure with Materials fill mode and object lines (F.1), together with a table with all 

material properties. 
o A figure with Boundary Conditions fill mode and object lines (F.1), together with a 

table with all material properties. 
o A figure with Temperatures fill mode, with object lines, isothermal lines and a 

legend (F.1). 
o A figure with object lines and heat flow lines (F.1). 

All figures sizes are according to the Image Size settings in the Graphic Output 

(F.3), but with a minimum of 1200x900 pixels. 
o The details of the equivalent thermal transmittances (Ufr and Ueg) insofar as they 

can be determined. 
- NFRC 100/500 

o Identical to NFRC 100 but including the Condensation Index (see lower) in the single 

line section and detailed section of the derived thermal properties. 
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Each page has a header and a footer. The header can have three elements: an image, a title 

and a text field. The image can be used, for example, to show a company logo.  
Options: 

- Title (only customizable for the Custom report type). 
- Header Image. You can use the Browse button to select an image file (only PNG is 

supported). 
- Header Text (see below). 

 
Free Text is a text field which is only shown on the first page. 
 
In the text fields (Title, Header Text and Free Text) you can use markup (similar to html) to get 

special content or add some styling. Pressing one of the buttons with a question mark shows the 
available codes: 

- $PROJECT: the name of the current BSC data file. Using this code is especially interesting 

for batch processing (see D.7 and D.8). 
- $DATE: the current date (formatted using the operating system locale). 
- <b>this is some bold text</b> 
- <i>this is some italic text</i> 
- ‘<’ is interpreted as starting a markup code, so if you want a literal ‘<’ (less than) you have 

to use &lt; e.g. “1 &lt; 2” instead of “1 < 2” 

If there is an error in one of those text fields, such as typing a <b> but omitting the corresponding 

</b>, a red triangle will be shown. Clicking on it shows the error cause.  
 
Clicking on the button “Save As Default” saves the current settings in the application settings (A.11), 
so they will be the default settings for new projects. The other way around, clicking on the button 
“Apply Default” fills in the current settings using the default values. 
 
Clicking “Generate PDF” generates the PDF report file in the directory of the BSC data file. The 

filename is the name of the BSC data file with suffix “_report.pdf” added. Save the BSC file to 
preserve the chosen PDF settings. 
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CHAPTER H INPUT OF DXF FILES 

H.1.  General 

When opening a DXF (see C.3), the file can be either opened and converted to a BMP directly in 
BISCO, or sent to BiscoDxf. 
BiscoDxf is a tool for input of a DXF file (e.g. created in AutoCAD or Sketchup) and conversion to a 

BMP file, ready for use in BISCO. BiscoDxf can be started from the menu command File → Open 

DXF… in BISCO and click “YES”. 

H.2. Input of DXF using BiscoDxf 

The bitmap resolution (i.e. relative pixel size) and bitmap border positions (left, right, top and 
bottom borders) can be defined with reference to the DXF coordinates. Hence follows the bitmap 
size (width and height). 

The bitmap image with different colours is calculated from the definition of layers in the DXF file. 
Each layer contains the contour lines of only one material or boundary condition. Only a limited 
set of DXF commands is supported (i.e. polyline, line, arc, circle, ellipse, and blocks of these 
entities). 

In BiscoDxf a colour number is associated to each layer. The layer definitions are stored in a text 
file (with extension .lay) together with the BMP file. 

H.2.1. Input DXF file 

When making a DXF drawing create a layer per material or boundary condition (so per colour 

for BISCO). Enter a meaningful name for the layer (see H.2.3H.2.3). 
Per layer draw the contour lines using polylines. All line types supported by BiscoDxf are listed in 
section H.4H.4. Other layers (for hatch patterns, dimensions, text, other drawing information…) 

are ignored in BiscoDxf. 
 
The DXF file is read into BiscoDxf via File → Open DXF… in BISCO, select the desired DXF file and 

click “YES”. BiscoDxf automatically opens and the selected DXF is loaded. Once within BiscoDxf a 

new DXF file can be selected via File → Open… 

Only layers that contain supported line types are read. 

From these layers select the layers that also should be skipped. 
 

  



80 Manual BISCO v13.0  

  
 

The DXF drawing is visible in the DXF Drawing window. 

The layer names are shown in the Layers window (see H.2.3H.2.3). 

The lines of the current layer are highlighted in black in the DXF Drawing window. All other lines 

are in grey. Open line end points in a layer, which may cause bad colour filling (using the fill 
mode “FILL CONTOURS”), are marked as orange dots. 

The outline of the bitmap to be created is in blue. The bitmap outline is drawn based on the 
extents of the DXF drawing, ignoring the skipped layers (see above). 

H.2.2. Bitmap size 

Bitmap → Draw Bitmap Outline 
Enters “draw bitmap outline mode”. 

Draw a rectangle with the mouse (click and drag) to define the new bitmap outline (in blue). 

The drawing is zoomed in on this new bitmap outline, and the DXF Drawing window is reset to 

“zoom window mode”. 

 
Bitmap → Set Bitmap Size & Resolution… 

Allows to modify the DXF coordinates of left, right, bottom and top borders, as well as the 
resolution (or relative pixel size) of the bitmap. Hence follows the new bitmap size (width and 
height). 
After editing a value, press the Apply button to update the other values in the dialog box. 
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H.2.3. Layers window 

The Layers window lists per layer: 

- Sequence number 
- Layer name (from DXF file) 
- Fill mode 

- Colour number 
- Colour value (not individually editable) 

 

 
 
When a DXF file is opened in BiscoDxf, the properties for each layer in the DXF file as displayed in 

the Layers window are gathered automatically by BiscoDxf from different sources: 

- The information in the BiscoDxf.lay file in the application data directory containing the 
default layer definitions is read firstly (see J.5J.5). This file contains for each layer name 

within it the corresponding fill mode and colour number. For layer names in the DXF file 
corresponding exactly with layer names from the BiscoDxf.lay file, the layer properties 

from the BiscoDxf.lay file are read and displayed in the Layers window. The layer 

sequence from the BiscoDxf.lay file is used as sequence in the Layers window. 

- Subsequently, if a layer file for the opened DXF file already exists (name of the file with 
extension .lay in the same folder), the layer properties are read and displayed in the 

Layers window for layer names in the DXF file corresponding exactly with layer names 

from the layer file. The information from this project layer file takes precedence over the 
information read in the BiscoDxf.lay. 

- For layer names of the DXF file not occurring in either the BiscoDxf.lay file or the project 

layer file, default information is displayed in the Layers window, except if the layer names 
in the DXF file themselves contain information according to a naming format. 
A name with prefix of the format “xxx_y_name” forces a colour number (xxx = 1 to 3 digits, 
from 0 up to 255) and fill mode (y = 1 digit, i.e. 0 = lines, 1 = fill contours, 2 = flood fill, 3 = 
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skip) to be used for the layer. The layers of this format are displayed in the sequence in 

which they occur in the DXF file. 
 

After this procedure, each layer property can be edited individually in the Layers window in 

BiscoDxf. Alternatively, previously saved layer definitions (file with .lay extension) can be imported 
for the current DXF file using the command Layers → Load Layer Definitions….  

 
Colour number 
Enter a colour number (between 0 and 255) that will be used in the bitmap creation  
(Calc → Calc Bitmap). 

The colour value from the active colour palette is displayed in the next cell. 
The bitmap file ColourPalette.bmp in the application data directory (see J.3) contains the default 

colour palette and is read at the startup of BiscoDxf. 
The colour palette can be changed using the function Bitmap → Load Palette… and selecting a 

BMP file. 
 

Fill mode 
Defines how the polylines of the layer will be processed when the bitmap is created  
(Calc → Calc Bitmap). 

- LINES 

Rasterises the DXF polylines into raster lines using pixels of the specified colour. 
Normally used for separate lines and open polylines. 

- FILL CONTOURS 
Fills the inside of closed polylines using the specified colour. 
A parity fill algorithm is used (which does not function properly for self-overlapping 
contour lines, because the double lines switch the filling). 

- FLOOD FILL 
Fills the connected colour zone around the DXF polylines in the current layer into the 
specified flood fill colour. 
Pixels of rasterised lines (from layers with lower sequence number) adjacent to the new 
filled zone are repainted with the flood fill colour. 

- SKIP 
The polylines are not processed (i.e. skipped). 

Normally use “FILL CONTOURS” for closed polylines. 
If the result is not good (due to small gaps or self-overlapping lines), use “LINES”, and execute the 
filling in BISCO (using Bitmap → Fill). 

 

Sequence of layers 
Bitmap colouring processes the layers one after the other following the sequence order. 

The sequence order can be changed using the functions: 
- Layers → Higher Priority (moves the current layer one row down). 
- Layers → Lower Priority (moves the current layer one row up). 

 
Layers → Load Layer Definitions… 

Read fill mode and colour number for layers with exactly corresponding names from a layer 

definition file (with extension .lay). 
A layer definition file is created every time a calculated bitmap is saved (Calc → Save Bitmap…). 
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H.2.4. Bitmap creation 

Calc → Calc Bitmap 

Calculate the bitmap using current bitmap size and resolution (Bitmap → Set Bitmap Size & 

Resolution…) and layer definitions (in the Layers window). 

The DXF Drawing window is replaced by the Bitmap window with the calculated bitmap. 

Use View → DXF Drawing and View → Bitmap to switch between both views. 

Activating the Layers window automatically switches to the DXF Drawing window. 

 
Calc → Save Bitmap… 

Save the calculated bitmap into a (compressed 256-colours) BMP file. 

Also the layer definitions in the Layers window are saved into a text file with same directory and 

file name as the new BMP file, but with extension .lay. 
The .lay file is used for recovery of layer definitions when the same DXF file is reloaded (with File 
→ Open…). 

 
By closing the BiscoDxf application (File → Exit) the generated BMP file automatically opens in 

BISCO (according to File → Open Bitmap…, see C.3). 

H.3. Input of DXF directly in BISCO 

As an alternative to BiscoDxf, a DXF file can be opened directly in BISCO for automatic 

conversion to a BMP. To do this, use the command File → Open DXF… in BISCO, select the 

desired DXF file and click “NO”.  
 
When a DXF file is opened directly in BISCO, the properties for each layer in the DXF file are 

gathered automatically by from different sources, similarly as in BiscoDxf (H.2.3H.2.3): 
- The information in the BiscoDxf.lay file in the application data directory containing the 

default layer definitions is read firstly (see J.5J.5). This file contains for each layer name 

within it the corresponding fill mode and colour number. For layer names in the DXF file 
corresponding exactly with layer names from the BiscoDxf.lay file, the layer properties 

from the BiscoDxf.lay file are read. The layer sequence from the BiscoDxf.lay file is used to 
process the layers. 

- Subsequently, if a layer file for the opened DXF file already exists (name of the file with 

extension .lay in the same folder), the layer properties are read for layer names in the DXF 
file corresponding exactly with layer names from the layer file. The information from this 
project layer file takes precedence over the information read in the BiscoDxf.lay. 

- For layer names of the DXF file not occurring in either the BiscoDxf.lay file or the project 
layer file, default information from the colour database is used, except if the layer names 
in the DXF file themselves contain information according to a naming format. 
A name with prefix of the format “xxx_y_name” forces a colour number (xxx = 1 to 3 digits, 
from 0 up to 255) and fill mode (y = 1 digit, i.e. 0 = lines, 1 = fill contours, 2 = flood fill, 3 = 
skip) to be used for the layer. The layers of this format are processed in the sequence in 
which they occur in the DXF file. 

 
After reading all layer information, a bitmap is constructed automatically by first processing all 

layers with ‘fill contours’ fill mode, followed by all layers with ‘lines’ fill made and, finally, all layers 
with ‘flood fill’ fill mode. Note that this clustered approach based on fill mode differs from the 

process in BiscoDxf, where the bitmap is created following the layer sequence in the Layers 

window one by one (see H.2.3). 

 
The constructed bitmap uses the colour palette of the default ColourPalette.bmp file (see J.3J.3). 
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The resolution of the constructed bitmap, i.e. the number of pixels used to represent the original 
DXF drawing, is set automatically based on the DXF extent. The user can increase or decrease 
this resolution up to a 10-fold ratio by altering the default value of 100% in Settings → Default 

Measures…. (see A.10). 
 
The resulting BMP is only editable using bitmap commands in BISCO (C.6, C.8 and I.1I.1), so this 
automatic procedure requires a well prepared DXF file. 
 

The pixel size and triangulation meshes are set according to the user-defined values in Settings 
→ Default Measures…. (see A.10). 

H.4. Supported DXF commands 

The input DXF file must be created according to the Autodesk DXF Format Reference. 
 
Only a subset of DXF commands is read into BiscoDxf. Other commands are skipped. 
 
Only 2D coordinates (X and Y) are read. The Z values are always skipped. 
Line thicknesses, elevations and extrusion directions are skipped, except if the extrusion direction 

in the Z-direction equals -1 exactly and equals 0 in X-direction and Y-direction, then the object is 
mirrored.  
 

The following drawing DXF commands are read: 
- LINE 

(Read group codes: 8, 10, 20, 11, 21) 
- LWPOLYLINE 

Both line segments and arc segments are possible. 

(Read group codes: 8, 90, 70 (0 or 1), 10, 20, 42, 210, 220, 230) 
- POLYLINE (subclass AcDb2dPolyline) and VERTEX (subclass AcDb2dVertex) 

Both line segments and arc segments are possible. 

No curve-fit or spline-fit vertices. 
(POLYLINE group codes: 8, 70 (0 or 1); VERTEX group codes: 8, 10, 20, 42) 

- ARC 

(Read group codes: 8, 10, 20, 40, 50, 51, 210, 220, 230) 
- CIRCLE 

(Read group codes: 8, 10, 20, 40, 210, 220, 230) 

- ELLIPSE 
(Read group codes: 8, 10, 20, 11, 21, 40, 41, 42, 210, 220, 230) 

 
Block definitions (DXF command BLOCK, containing the drawing commands as above) and block 
insertions (DXF command INSERT) are possible, with the following restrictions: 

- No external references (to files). 
- BLOCK: the base point is not read (i.e. always X = 0 and Y = 0). 
- INSERT: only X and Y of the insertion point, the X scale and Y scale factor, and the rotation 

angle are read. 

(BLOCK group codes: 2, 8; INSERT group codes: 2, 8, 10, 20, 41, 42, 50)  
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CHAPTER I EDIT BMP FILES VIA BISCOBMP 

I.1. BiscoBmp 

BiscoBmp is a bitmap editor and can be opened in BISCO via the menu command Bitmap → Edit 

using BiscoBmp. 
It is possible to draw pixels, lines, fill rectangles, fill colour zones, replace colours, and define 
selections within 256 colours BMP files. 
A selection within a bitmap can be cleared, moved or copied to another location in the same or a 

different bitmap. 
The 256-colours palette of the BMP file cannot be modified in BiscoBmp. 

I.2. File commands 

- File → Open…: open a 256-colours BMP file in a new window. Several BMP files can be 
open at the same time. 

- File → Open Palette : open the colours palette of the active bitmap in a new window 
(which shows all 256 colours in a table of 16 rows and 16 columns). 

- File → Close : close the active bitmap window. 
- File → Save : save the active bitmap as BMP file (overwriting the existing BMP file). 

- File → Save As… :save the active bitmap as BMP file under a different file name. 

I.3. Edit commands 

- Edit → Copy : copy the selected subpart of the bitmap to the clipboard of BiscoBmp. 

- Edit → Paste : paste the clipboard (possibly from a different window) into the active 

window as new selection. 

- Edit → Clear : clear the bitmap within the selection. 

I.4. Bitmap commands 

- Bitmap → Size…: modify the size of the bitmap (as in BISCO). 

- Bitmap → Crop Bitmap Borders…: as in BISCO. 

- Bitmap → Insert/Delete Pixel Band…: as in BISCO. 

- Bitmap → Resize Pixel…: modify the bitmap resolution. 

When the new pixel size is greater than 100 % of the original pixel size, the bitmap size is 
reduced (with larger pixels). 
When the new pixel size is smaller than 100 % of the original pixel size, the bitmap size is 
increased (with smaller pixels). 

- Bitmap → Rotate 90° : as in BISCO. 

- Bitmap → Flip : mirror the bitmap up/down. 

- Bitmap → Mirror : mirror the bitmap left/right. 

I.5. Select commands 

- Select → Select All : select the entire bitmap. 

- Select → Deselect All : remove all selections. 

- Select → Invert : invert the current selection. 

- Select → Select Colour Zone : enter “select colour zone mode”. 

In this mode a click with the left mouse button selects the colour zone around the mouse 
pointer. 
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When the <Shift> key is held down before the left mouse button is clicked, the new colour 

zone is added to the current selection. 
When the <Ctrl> key is held down before the left mouse button is clicked, the new colour 
zone is subtracted from the current selection. 
A click with the right mouse button removes all selections (as Select → Deselect All). 

- Select → Select Window : enter “select window mode”. 

In this mode a rectangle drawn with the left mouse button (click and drag) defines a 
selection. 
When the <Shift> key is held down before the left mouse button is clicked, the new 
rectangle is added to the current selection. 
When the <Ctrl> key is held down before the left mouse button is clicked, the new 
rectangle is subtracted from the current selection. 

A click with the right mouse button removes all selections (as Select → Deselect All). 

- Select → Crop to Selection : crop the bitmap, leaving only the selected area. 

 
Moving a selection 
When the mouse cursor is inside a selection, the arrow cursor is changed into a move cursor. This 
allows to move the selection to a new location in the bitmap, using click and drag with the left 
mouse button. The original selection is cleared. Use Edit → Copy and Edit → Paste, if the original 

selection should be kept. 
 

 
 

I.6. Paint commands 

After choosing any paint command the active paint colour is shown in the left bottom of the 

active bitmap window. 
The status bar shows the pixel coordinates of the mouse point, and the colour index (between 0 
and 255) of this pixel. 
If the pixel colour under the mouse point equals the active paint colour, the status bar adds “= 
paint colour”. 
 

- Paint → Pick Colour : enter “pick colour mode”. 

Pick a colour in the bitmap with the left mouse button to set the active paint colour. 
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The active paint colour index can be used in all open bitmap windows. 

To select a paint colour which is not present in the current bitmap data, open the bitmap 
palette (File → Open Palette), which allows to choose any of the 256 colours, and return to 

the original bitmap window. 
The active paint colour can also be picked from any paint command using the right 
mouse button. 

- Paint → Draw : enter “draw mode”. 

In draw mode pixels and lines can be drawn using the active paint colour. 
Drawing a pixel: set the mouse point on the pixel and click the left mouse button.  
Drawing a line: hold down the <Shift> key, move the mouse (now the status bar shows the 
relative coordinates from the last painted pixel) to the end pixel of the line and click the 
left mouse button. A line is drawn from the last clicked pixel to the new clicked pixel. 

- Paint → Line : enter “line mode”. 

A line is drawn from the start point to the end point using click and drag with the left 
mouse button. 
To draw the line at fixed angles in increments of 45°, press and hold the <Shift> key 
before releasing the mouse. 
Keep the <Alt> key pressed before the left mouse button is clicked, to connect the new line 
to the last painted pixel. When the mouse is dragged, the <Alt> key may be released 
before the mouse is released. 

- Paint → Rectangle : enter “rectangle mode”. 

A rectangle is filled using click and drag with the left mouse button. 

- Paint → Fill : enter “fill mode”. 

When the left mouse button is clicked, the colour zone around the pixel under the mouse 
point is filled using the active paint colour. The flood fill stops at the border with any other 

colour or at the border of the current selection. 
- Paint → Replace Colour : enter “replace colour mode”. 

When the left mouse button is clicked, all pixels in the bitmap with the same colour as the 
colour under the mouse point are repainted using the active paint colour. 

 



88 Manual BISCO v13.0  

CHAPTER J BISCO TEMPLATE FILES 

J.1. General 

BISCO makes use of template files containing default information for a number of functions. 
These template files are each saved in the application data folder or personal folder (see A.7) of 
the user account on the computer where BISCO is installed. The path to the application data 
folder is C:/Users/username/Appdata/Roaming/Physibel/BISCO13 (AppData is a hidden folder 

by default in Windows). 

 
The template files used by BISCO are: 

- ColourDatabase.bsc 
- ColourPalette.bmp 
- BiscoReportTemplate.doc 
- BiscoDxf.lay 

 
The use of these template files in different BISCO functions has been outlined throughout the 
manual. In the following sections, handling and customization of these template files is briefly 
discussed. 

J.2. Colour database 

The colour database file ColourDatabase.bsc is saved in the application data folder 

(C:/Users/username/Appdata/Roaming/Physibel/BISCO13). The colour database contains 
predefined material and boundary condition properties and is loaded at every BISCO start-up 
(see C.2).  

 
It is advisable to add frequently used materials and boundary conditions to the colour database. 
These predefined colours of the colour database are then available for new colours in any 

document. 
The command File → Open Colour Database… allows to modify the 256 available predefined 

colours of the colour database. After editing the colour data, the file should be saved (File → 

Save) to adapt the colour database on disk. 
 
Alternatively, if a user wants to save a custom file as colour database, this is possible by saving it 

with the name ColourDatabase.bsc in the application data folder (File → Save as…) thus 
overwriting the default file. In the application data folder, the default colour database is present 
as ColourDatabase_PhysibelDefault.bsc. This file can be saved as ColourDatabase.bsc to restore 
the original colour database. 
 

The ColourDatabase.bsc file replaces the Bisco.bsc file in older versions of BISCO. Users who had 
been working with a customised Bisco.bsc file, can thus easily transfer to the new system by 
opening Bisco.bsc and saving it with the name ColourDatabase.bsc in the application data 
folder. The bitmap file linked to Bisco.bsc (Bisco.bmp) must then be saved as ColourPalette.bmp 
(see J.3J.3) to ensure the transfer of a customized colour palette to the new template. 
The legacy Bisco.bsc file was also used to set the default bitmap pixel size and global 
triangulation size (see C.9). These properties can now be set via command Settings → Default 

Measures… (see A.10). 
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J.3. Colour palette 

The colour palette file ColourPalette.bmp is saved in the application data folder 
(C:/Users/username/Appdata/Roaming/Physibel/BISCO13). The colour palette file’s header 
section contains the definition of the 256 possible colour values in the bitmap (called the colour 
palette). 

If a user wants to change a colour in the colour palette, this is possible by opening the colour 
database (see J.2), changing the colour by opening the Colour dialog box (see C.10) and saving. 
If a user wants to save a custom file as colour palette, this is possible by saving it with the name 
ColourPalette.bmp in the application data folder thus overwriting the default file. In the 
application data folder, the default colour palette is present as 

ColourPalette_PhysibelDefault.bmp. This file can be saved as ColourPalette.bmp to restore the 

original colour palette. 
 

The ColourPalette.bmp file replaces the Bisco.bmp and BiscoDxf.bmp files in older versions of 
BISCO. Users who had been working with a customised palette file, can thus easily transfer to the 
new system saving it with the name ColourPalette.bmp in the application data folder. 

J.4. MS Word Report 

The report template file BiscoReportTemplate.doc is saved in the personal folder (../Documents/ 
Physibel/BISCO13). When a report is created in BISCO, the report template is copied from the 
personal folder into the directory of the current BSC file and given the same name as the BSC file, 

appended with “_report”. 

 
Editing the template document can be useful to create a new template document with another 
layout (own company style) and with other (typically less) contents. 

 
When a bookmark is removed the corresponding item (graphic file, text file or value) will not be 
imported when applying the BISCO Load macro. 

To reinstall a bookmark, a name listed in the table of bookmarks should be used. 

J.5. DXF layer definitions 

The default layer definition file BiscoDxf.lay is saved in the application data folder 
(C:/Users/username/Appdata/Roaming/ Physibel/BISCO13). This file contains for each layer 
name within it the corresponding fill mode and colour number for creating of a BMP file based 
on layers in a DXF file (see Chapter HChapter H). The layer definitions in BiscoDxf.lay are read 
every time a new DXF file is opened to initialise the layer sequence, fill modes and colour 

numbers in the Layers window, in order to minimise input. 

 
After installation, a BiscoDxf.lay file with very limited information is present. To create a 

customized BiscoDxf.lay file, it is recommended to start from a generic DXF file which contains all 
possible layer names (for all possible materials and boundary conditions) in order to obtain a file 

BiscoDxf.lay with maximal usability. Open this DXF file in BiscoDxf, set all properties in the Layers 

window and save the layer definition as the default layer definition (Layers -> Save as default 
layers definition). Afterwards, always use the same layer names for identical materials and 
boundary conditions in new DXF files. 
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CHAPTER K RADCON MODULE 

K.1. Purpose 

The RADCON module for BISCO is a program add-on feature to simulate more realistically the 

heat transfer between material surfaces and the adjacent environments. 
The heat transfer has the following components: 

- Radiation: based on view factors and material surface emissivities. 
- Convection: based on a (calculated) convective heat transfer coefficient applied to the 

contact surface between material and environment. 

- Conduction: in a (transparent) material with given thermal conductivity. 
 
The RADCON module offers a physically more correct alternative for: 

- The global surface heat transfer coefficient. 

- The equivalent thermal conductivity of an air cavity. 
 

  
principle of view factor based radiation heat transfer 

using BC_SKY (at a surface) 
principle of view factor based radiation 

heat transfer using TRANSMAT (in a cavity) 
 

K.2. Implementation 

Without the RADCON module, BISCO has the following colour types (defined in the Colours 

window, see C.10 and D.1 for more information): 
- MATERIAL  

- EQUIMAT  
- BC_SIMPL  
- BC_FRE_S 

 
With the RADCON module, BISCO has the following additional colour types: 

- TRANSMAT for a transparent material with known (or calculated) thermal conductivity 
(normally of still air or another gas according to a standard) 
Additionally to the gas conduction there is radiative heat transfer between the adjacent 

material surfaces (using their emissivities). 
If the transparent material is not fully surrounded by material surfaces, then the open side 
at the bitmap border is considered as an adiabatic surface, i.e. a radiation mirror with 
emissivity  = 0. 
If there is convection within the cavity, the thermal conductivity for still gas should be 
multiplied by the Nusselt number. This is done automatically for subtype CAVITY (see 
D.1.5). 
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- BC_FREE for an enclosure (normally fully surrounded by material surfaces, e.g. a cavity or 

a room) with unknown air temperature (free-floating air temperature), known surface 
heat flux (positive or negative), known (or calculated) convective heat transfer coefficient 
and known injected convective heat power (positive or negative). 
The unknown air temperature is calculated from the convective heat balance equation: 
Σ (convective heat transfer from environment to surface) = injected convective heat 

power. 
The radiation between the different surfaces bordering the environment are calculated 
based on view factors and surface emissivities. 
When the environment is not completely surrounded by material surfaces, the open end 
(at the bitmap border) is considered to be a symmetry plane for heat transfer. The 
symmetry plane is simulated as a radiation mirror (with emissivity  = 0). 

- BC_SKY for an environment (normally not fully surrounded by material surfaces, i.e. open 
to the sky) with known air temperature, known radiation temperature, known surface heat 
flux (positive or negative) and known (or calculated) convective heat transfer coefficient. 
This implies there can be a resultant radiative heat flow and a resultant convective heat 
flow from the environment to the material surfaces. 

- BC_NOSKY for an environment with known air temperature, known surface heat flux 

(positive or negative) and known (or calculated) convective heat transfer coefficient. 
There is no radiation exchange with the environment (i.e. no sky radiation). The surfaces 
bordering the environment exchange radiation based on view factors and surface 
emissivities. 
The known air temperature implies there can be a resultant convective heat flow from the 

environment to the material surfaces. 

 
With RADCON the colour types MATERIAL and EQUIMAT also have a surface emissivity (defined 

in the Colours window), which is applied to the radiative heat transfer for the RADCON boundary 

conditions bordering the material. 
 
Combined convective and radiative heat transfer (BC_SIMPL, BC_FRE_S) 

The global (combined convective and radiative) heat flow is: 
𝑄 = ℎ ⋅ (𝜃𝑠 − 𝜃𝑏𝑐) ⋅ 𝐴 
𝑄  = global heat flow [W] 

ℎ = global heat transfer coefficient [W/(m2.K)] 
𝜃𝑠 = surface temperature [°C] 
𝜃𝑏𝑐 = environmental temperature [°C] 

𝐴 = surface area [m²] 
In this formula the environmental temperature is not defined precisely. It can be the air 
temperature, the dry resultant temperature or an interpolated value. Depending on that choice, 
an appropriate value for the global heat transfer coefficient must be chosen. 
 

Convective heat transfer (BC_FREE, BC_SKY, BC_NOSKY) 
The convective heat flow is: 
𝑄𝑐 = ℎ𝑐 ⋅ (𝜃𝑠 − 𝜃𝑎) ⋅ 𝐴 
𝑄𝑐 = convective heat flow [W] 

ℎ𝑐 = convective heat transfer coefficient [W/(m2.K)] 
𝜃𝑠 = surface temperature [°C] 

𝜃𝑎 = air temperature [°C] 
𝐴 = surface area [m²] 
The convective heat transfer coefficient ℎ𝑐 can be calculated based on the given subtype (cf. 
section D.1.3 and D.1.4). 
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Black radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 

The radiative heat flow between two black surfaces is: 
𝑄𝑖𝑗 = 𝐴𝑖 ⋅ 𝐹𝑖𝑗 ⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑠𝑏𝑖 − 𝜃𝑠𝑏𝑗) 

𝑄𝑖𝑗 = radiative heat flow between black surface i and black surface j [W] 

𝐴𝑖 = area of surface i [m2] 
𝐹𝑖𝑗 = view factor from surface i to surface j (between 0 and 1) 

ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 
𝜃𝑠𝑏𝑖 = black surface temperature of surface i [°C] 
𝜃𝑠𝑏𝑗 = black surface temperature of surface j [°C] 

 
For linear radiation the black radiation heat transfer coefficient is constant, defined as a 
calculation parameter (default value 5.1 W/(m2.K)). The value depends on the temperature range 
of the problem considered.  Section K.3 contains a table with values of ℎ𝑟𝑏, depending on the 
mean temperature 𝑚 [°C] of the surfaces i and j and the temperature difference between the 
surfaces 𝑖𝑗 [°C]. The table shows that the ℎ𝑟𝑏-value mainly depends on the mean surface 

temperature 𝑚. 
The default value 5.1 W/(m2.K) is the ℎ𝑟𝑏-value at 10°C.  
 
For non-linear radiation: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑠𝑏𝑖

2 + 𝑇𝑠𝑏𝑗
2 ) ⋅ (𝑇𝑠𝑏𝑖 + 𝑇𝑠𝑏𝑗) 

𝜎 = 5.67 10-8 W(m2.K4) (Stefan-Boltzmann constant) 
𝑇𝑠𝑏𝑖 = 𝜃𝑠𝑏𝑖 + 273.16 [K] (absolute temperature of black surface i) 
𝑇𝑠𝑏𝑗 = 𝜃𝑠𝑏𝑗 + 273.16 [K] (absolute temperature of black surface j) 

The black radiation heat transfer coefficients are recalculated at the start of each new iteration 
cycle based on the temperatures obtained in the last iteration cycle. 

 
Grey radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
Real surfaces are not black (emissivity  = 1) but grey (emissivity  < 1). 

In the RADCON module each grey surface is connected to a black surface node. All black surface 
nodes are connected to each other in a star diagram. 

The radiative heat flow between the grey surface with given emissivity and the corresponding 
black surface is: 

𝑄𝑟 = 𝐴 ⋅
𝜀

1 − 𝜀
⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑠𝑏 − 𝜃𝑠) 

𝑄𝑟 = radiative heat flow between grey surface and black surface [W] 
𝐴 = surface area [m2] 
 = surface emissivity (0 ≤ ε < 1) 

ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 
𝜃𝑠𝑏 = black surface temperature [°C] 
𝜃𝑠 = (real) surface temperature [°C] 
For non-linear radiation: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑠𝑏

2 + 𝑇𝑠
2) ⋅ (𝑇𝑠𝑏 + 𝑇𝑠) 

𝑇𝑠𝑏 = 𝜃𝑠𝑏 + 273.16  [K] 
𝑇𝑠 = 𝜃𝑠 + 273.16 [K] 
The black radiation heat transfer coefficients are recalculated at the start of each new iteration 
cycle based on the temperatures obtained in the last iteration cycle. 
 
Iteration cycles for non-linear radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
Iteration cycles are used to calculate non-linear radiative heat transfer. At the start of each 
iteration cycle the black radiation heat transfer coefficients are updated using the local 
temperatures available at that moment. 

For the first iteration cycle the black radiation heat transfer coefficients have a constant value as 
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defined in the Calculation Parameters dialog box. 

The total number of iteration cycles is defined in the Calculation Parameters dialog box. Normally 
5 iteration cycles are sufficient. A low number of iteration steps in the last iteration cycle ensures 
that the number of iteration cycles is OK. 
 

View factors (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
The view factors are calculated for all elementary surfaces (corresponding to edges in the mesh 
triangulation) bordering the environment (type BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT). 
Several environments of the same type (e.g. with different convective heat transfer coefficients) 
may touch one another. The view factors are calculated for the union space of these adjacent 
environments. 

Adjacent environments of different type are not allowed. Then an error message is displayed at 

the start of the system calculation (Calc → Calc System). 

A boundary condition of type BC_FREE, BC_SKY, BC_NOSKY or TRANSMAT is not allowed to 
occur in different zones (separated by a material). Each zone must be considered as a separate 
environment (having a different colour). An error message is displayed at the start of the system 
calculation, when this condition is not satisfied. 

First the view factor between two (elementary) surfaces, not obstructed by other surfaces, is 
calculated using an exact analytic formula. A very small view factor (i.e. smaller than the 
calculation parameter smallest accepted view factor) is neglected (rounded to 0). Then possible 
obstruction by other surfaces is estimated using 100 test rays between random points of both 
surfaces. The number of test rays is proportional to the unobstructed view factor. 
After calculation of all view factors a correction is made to smooth away possible errors (e.g. due 

to the limited number of visibility test rays), so that the sum of view factors always equals 1, and 

the view factor reciprocities are respected. 
The total number of calculated view factors (and hence the calculation time and required 

memory space) is a quadratic function of the number of elementary surfaces (= triangulation 
edges) in the largest view factor zone. 
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K.3. Table for black radiation heat transfer coefficient 

The following table shows the black radiation heat transfer coefficient. 
The values are obtained using the formula: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑖

2 + 𝑇𝑗
2) ⋅ (𝑇𝑖 + 𝑇𝑗) 

with 𝜎 =  5.67*10-8 W/(m2.K4) (Stefan-Boltzmann constant) 

 

black radiation temperature difference between the surfaces i and j 
heat transfer 

coeff. 
ij [°C] 

hrb [W/m2K] 0.00 5.00 10.00 15.00 20.00 25.00 30.00 35.00 40.00 45.00 50.00 
 -20.00 3.68 3.68 3.68 3.68 3.69 3.69 3.69 3.70 3.70 3.71 3.72 
 -15.00 3.90 3.90 3.90 3.91 3.91 3.91 3.92 3.92 3.93 3.93 3.94 
 -10.00 4.13 4.13 4.13 4.14 4.14 4.14 4.15 4.15 4.16 4.16 4.17 

 -5.00 4.37 4.37 4.37 4.38 4.38 4.38 4.39 4.39 4.40 4.40 4.41 
mean 0.00 4.62 4.62 4.62 4.63 4.63 4.63 4.64 4.64 4.65 4.65 4.66 
temp. 5.00 4.88 4.88 4.88 4.88 4.89 4.89 4.90 4.90 4.91 4.91 4.92 
m [°C] 10.00 5.15 5.15 5.15 5.15 5.16 5.16 5.16 5.17 5.17 5.18 5.19 

 15.00 5.43 5.43 5.43 5.43 5.43 5.44 5.44 5.45 5.45 5.46 5.47 
 20.00 5.71 5.71 5.72 5.72 5.72 5.72 5.73 5.73 5.74 5.75 5.76 
 25.00 6.01 6.01 6.01 6.02 6.02 6.02 6.03 6.03 6.04 6.05 6.05 
 30.00 6.32 6.32 6.32 6.32 6.33 6.33 6.33 6.34 6.35 6.35 6.36 
 35.00 6.64 6.64 6.64 6.64 6.64 6.65 6.65 6.66 6.66 6.67 6.68 
 40.00 6.96 6.97 6.97 6.97 6.97 6.98 6.98 6.99 6.99 7.00 7.01 
 45.00 7.30 7.30 7.31 7.31 7.31 7.32 7.32 7.33 7.33 7.34 7.35 
 50.00 7.65 7.65 7.66 7.66 7.66 7.67 7.67 7.68 7.68 7.69 7.70 
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K.4. Table for emissivities 

The table below contains values of the long-wave emissivity  of some building materials taken 
from: 
- H.C. Hottel, Heat Transmission, 1954 
- J.S. Cammerer, Wärme- und Kälteschutz in der Industrie, 1962 
- Stichting Bouwresearch, Eigenschappen van bouw- en isolatiematerialen, rapport 9, 1974 

 
building material long-wave emissivity at T = 300K 

 [-] 

black surface 1 

aluminium, polished < 0.07 

aluminium, oxidised 0.11 à 0.3 

brass, polished 0.038 

copper, smoothed 0.09 

copper, oxidised 0.78 - 0.79 

cast iron 0.44 

iron, oxidised and rusted red 0.61 

lead, gray oxidised 0.28 

tin 0.043 - 0.064 

zinc, galvanised 0.23 

zinc, oxidised > 0.11 

asbestos board 0.96 

bitumen 0.92 

brick, red, rough but no gross 

irregularities 

0.92 - 0.93 

concrete 0.88 

glass 0.94 

cement-tiles > 0.85 

roofing-tiles, red 0.85 

roofing paper 0.91 

rubber, hard and glossy 0.94 

wood 0.86 

aluminium painting 0.42 

enamel, white >0.90 

metal paint, black 0.88 

water 0.95 - 0.96 

other materials (approximation) 

white, yellow, green, red, blue, grey, 

black 

0.85 à 0.95 

 
The table below contains values of the long-wave emissivity   from EN ISO 10077-2: 
 

description  

 [-] 

Untreated aluminium surfaces 0.1 

Slightly oxidized aluminium surface (up 

to 5 µm) 

0.3 

Metallic surfaces (general, including 

galvanized) 

0.3 

Anodized, painted or powder coated 

surfaces 

0.9 
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K.5. Tables for convective heat transfer coefficient 

The convective heat flow density is calculated using the following formula: 

𝑞𝑐 = ℎ𝑐 ⋅ (𝜃𝑎 − 𝜃𝑠) with 𝑞𝑐= convective heat flow density [W/m2] 
ℎ𝑐 = convective heat transfer coefficient [W/(m2.K)] 
𝜃𝑎= air temperature [°C] 

𝜃𝑠 = surface temperature [°C] 

Table 1 lists values of ℎ𝑐 for air cavities according to EN ISO 10077-2, depending on the 

temperature difference  over the cavity and the depth d of the cavity. Above the bold line, the 
ℎ𝑐-value depends only on the cavity depth (same hc-values on each row), while underneath the 

bold line the ℎ𝑐-value depends only on the temperature difference over the cavity (same ℎ𝑐-
values in each column). Above the bold line there is in fact only conduction (still air). Below the line 
natural convection is considered. 

 
Table 1: convective heat transfer coefficient (surface-to-surface) for air cavities (EN ISO 10077-2) 

convective heat temperature difference over the cavity 

transfer 

coefficient 

 [°C] 

hc [W/(m2.K)] 0.500 1.000 1.500 2.000 3.000 4.000 5.000 6.000 8.000 10.000 

 0.001 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 

 0.002 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 

 0.003 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 

 0.004 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 

 0.005 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 

depth 0.006 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 

of the 0.007 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 

cavity 0.008 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 

d [m] 0.009 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 

 0.010 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 

 0.011 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 

 0.012 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 

 0.013 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 

 0.014 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 

 0.015 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 

 0.016 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.145 

 0.017 2.941 2.941 2.941 2.941 2.941 2.941 2.941 2.941 2.941 3.145 

 0.018 2.778 2.778 2.778 2.778 2.778 2.778 2.778 2.778 2.920 3.145 

 0.019 2.632 2.632 2.632 2.632 2.632 2.632 2.632 2.653 2.920 3.145 

 0.020 2.500 2.500 2.500 2.500 2.500 2.500 2.500 2.653 2.920 3.145 

 0.025 2.000 2.000 2.000 2.000 2.106 2.318 2.497 2.653 2.920 3.145 

 0.030 1.667 1.667 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.035 1.429 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.040 1.250 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.045 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.050 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.060 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.070 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.080 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.090 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.100 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 
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Table 2 lists values of ℎ𝑐 for exterior surfaces, depending on the air velocity 𝑣 and the 

temperature difference  between surface and environment (from “Informatiemap voor 
bouwfysici”, 1991). 
 
Table 2: the convective heat transfer coefficient for exterior environments 

convective heat temperature difference object -

environment transfer 

coefficient 

 [°C] 

hc [W/(m2.K)] 5 10 20 40 

 0.5 7 8 9 11 

air 1 9 10 11 13 

velocity 2 12 13 15 16 

v [m/s] 3 19 20 21 23 

 4 25 26 27 28 

 5 30 31 32 34 

The following formulas define the convective heat transfer coefficient for interior environments 
(from “Element 29: Wärmeschutz und Energie im Hochbau”, 1990). Table 3 lists the ℎ𝑐-values 
according to these formulas. 

ℎ𝑐 = 1.31 ⋅ √𝛥𝜃
3

 for vertical constructions (walls) with a horizontal heat flow 

ℎ𝑐 = 1.77 ⋅ √𝛥𝜃
4

 for vertical constructions (window) with a horizontal heat flow 

ℎ𝑐 = 1.52 ⋅ √𝛥𝜃
3

 for horizontal constructions (walls) with an upward heat flow 

ℎ𝑐 = 0.59 ⋅ √𝛥𝜃
4

𝐿⁄  for horizontal constructions (walls) with a downward heat flow 

with  ℎ𝑐  = convective heat transfer coefficient [W/(m2.K)] 
 = temperature difference object - environment [°C] 
𝐿 = ½ (length x width) of the construction [m2] 

 
Table 3: the convective heat transfer coefficient for interior environments 

convective heat vertical constructions horizontal constructions 

transfer coefficient horizontal heat flow upgoing downgoing 

hc [W/(m2.K)] walls windows heat flow heat flow 

 1 1.31 1.77 1.52 0.39 

 2 1.65 2.10 1.92 0.47 

 3 1.89 2.33 2.19 0.52 

temperature 4 2.08 2.50 2.41 0.56 

difference 5 2.24 2.65 2.60 0.59 

object -  6 2.38 2.77 2.76 0.62 

environment 7 2.51 2.88 2.91 0.64 

 [°C] 8 2.62 2.98 3.04 0.66 

 9 2.72 3.07 3.16 0.68 

 10 2.82 3.15 3.27 0.70 

 11 2.91 3.22 3.38 0.72 

 12 3.00 3.29 3.48 0.73 

 13 3.08 3.36 3.57 0.75 

 14 3.16 3.42 3.66 0.76 

 15 3.23 3.48 3.75 0.78 

* using L = 5 m 
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