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CHAPTER A INTRODUCTION 

A.1. Short description of TRISCO 

TRISCO is a thermal analysis program for steady state heat transfer in three-dimensional 
rectangular objects consisting of different materials and submitted to different boundary 
conditions. The geometry is described with a list of rectangular blocks, the vertices of which lie on 
grid points of a rectangular grid. Materials and surface boundary conditions with different 

thermal properties are identified using separate colours. Each geometry block is part of either a 
material or a surface boundary condition region, and has a reference to one of these colours. 
Node boundary conditions with fixed temperature or power are possible, and can be placed in 
grid point locations. Also border face boundary conditions in the interface between two colour 
regions with fixed temperature or heat flux, or material boundary conditions with fixed 
temperature or heat power density are possible. 
 
After the input of geometry and thermal properties a system of linear equations is calculated 
based on the energy balance technique, and solved using a fast iterative method. Non-linear 
problems are solved using different cycles of adjusted linear systems. 
 
RADCON is a program add-on module to calculate infrared radiation and convection in a 

physically more realistic way The RADCON module allows simulation of the separate heat 

transfer by radiation and convection in enclosures and between material objects and the 
environment. Without the RADCON module, simplified combined convection and radiation is 
supposed, characterised by a global heat transfer coefficient. 

A.2. TRISCO: brief history 

The first roots of KOBRU86 (the discontinued 2D version of TRISCO, now replaced by Trisco2D) 
and TRISCO descend from research for a doctoral thesis on 2D and 3D heat transport in building 

physics (by Piet Standaert in 1984). 
The first commercial version of KOBRU86 on PC was ready in 1986. The program name stems 
from the Dutch term for thermal bridge: koudebrug. 

 
• Version 1.0 was ready in 1989. 
• version 5.0 (November 1995) introduced a calculation based on iterations. Also much 

larger systems with more unknowns could be solved. 
• The RADCON module was available from version 6.0 in January 1997. 
• Version 7.0 (October 1997) contained non-linear radiation with RADCON. 
• Version 8.0 (December 2000) is the first true Windows version and offered again faster 

calculations a higher node capacity (>106). 
• Version 9.0 (July 2001) introduced a built-in converter to import data from BISCO and 

equivalent thermal conductivities for convective heat transfer. 
 

The detailed version history from TRISCO v10 (2002) onwards can be found on the website: 
www.physibel.be/en/products/trisco/versions. 
 

http://www.physibel.be/en/products/trisco/versions
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A.3. Technical specifications 

− TRISCO is a 64-bit Windows program. TRISCO is installed in C:\Program Files 
(x86)\Physibel\TRISCO16. 
In this folder the executable file is TRISCO.exe. 

− The standard version of TRISCO allows to solve systems with up to 5,000,000 nodes. An add-
on feature to calculate an unlimited amount of nodes is available for purchase (feature 
Unlimited Nodes). The maximum number of nodes then depends on the RAM installed. For 

example, 8 Gb RAM allows to solve about 25,000,000 nodes, 16 Gb RAM allows to solve about 
50,000,000 nodes. 

− TRISCO relies on OpenGL for use of hardware accelerated graphics. 
− TRISCO is protected by either a hardware key, provided by Physibel, or a software licence 

(A.4). 
 
The Physibel 64-bit programs need several shared libraries (.dll files) from Microsoft. 
The Microsoft Visual C++ 2017 Redistributable Package (x64) is included in the installation files of 

TRISCO, but can also be downloaded from https://learn.microsoft.com/en-
us/cpp/windows/latest-supported-vc-redist?view=msvc-170. 
This package installs Microsoft C and C++ (MSVC) runtime libraries, required by 64-bit 
applications developed with Microsoft Visual C++ 2022. 

A.4. Licence 

The Physibel applications are protected by a licence, to prevent illegal use of the software. This 

can be either a hardware licence (Sentinel USB key) or a software licence. 

A.4.1. Hardware licence 

Perpetual licences are protected by a hardware licence (Sentinel USB key). The licence is locked 
to this dongle. It is strongly recommended to take a financial assurance for loss of the key by theft 
or any other incidence. 

 
Before TRISCO can be used, the driver (delivered with purchase) for the hardware key needs to be 
installed. Administrator rights are needed for this installation. It might be necessary to restart your 

computer after installing the driver. 
 

During use of TRISCO, the dongle needs to be attached to the computer at all times. 

A.4.2. Software licence 

Subscription licences are protected by a software licence. After first installation of TRISCO, the 
user needs to activate the licence using the activation code received upon purchase of the 
software. When first opening TRISCO, the Software Licence Manager will open automatically and 
prompt the user to activate the licence, or to register in the network floating database, depending 

on the licence type. The computer needs to be connected to the internet for this licence activation. 
Cloud-based floating licences are activated every time when opening the application. 

 
After activation, the Software Licence Manager is available from the menu for stand-alone 
licences: 
Help → Software Licence Manager… 
 
Users with a floating network licence can check out a licence from the database for a maximum 
period of 3 days. 

https://learn.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170
https://learn.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170
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Help → Check out/in floating licence… 

 
The software licence key for TRISCO is linked to the computer where it was activated. When you 
want to move the application with a stand-alone licence to another computer, you can 
deactivate the licence in the Software Licence Manager. The licence can then be reactivated on 

a new computer. 
 
If the Software Licence Manager is unavailable from the application itself, you can also open it 
from the command prompt. You need to first change directory to the Program Files folder where 
the application is installed. Then, open the Software Licence Manager with the following 
command: 

QlmLicenseWizard.exe /settings “TRISCO 16.0.lw.xml” 

A.5. User Account Control (UAC) 

Administrator rights are necessary to install TRISCO on a computer. 
 
The installation of the application is machine-level, meaning all user accounts can access the 
application after installation. 
 

Each user account has its own copy of the colour database (see I.2), colour palette (see I.5), 
report template (see I.3) and DXF layer definition file (see I.4) to work with. These files can be 

found in the user’s application data directory 

(C:/Users/username/Appdata/Roaming/Physibel/TRISCO16/). 
 
In case of a software licence, the licence for TRISCO is linked to the computer, but is stored at the 
user level. Each user account on a computer has to activate the licence in order to have access to 
the licence. 

A.6. Overview of delivered files and file structure 

TRISCO is installed (when the user accepts the default destination) in the folder C:\Program Files 

(x86)\Physibel. 
 
The following files are installed: 
Folder File Description 
…\Physibel\TRISCO16 TRISCO.exe TRISCO (64-bit) program 

 TriscoDxf64.exe Auxiliary program 
 *.dll, *.pat, *.rgb Program resources 
 QlmLicenseWizard Software Licence Manager files 
…\Physibel\Materials *.phm Material databases 
…\Physibel\Manuals TRISCOManual.pdf TRISCO manual 
 
The colour database file ColourDatabase.trc and back-up ColourDatabase_Physibeldefault.trc 

(see I.2), the bitmap colour palette file ColourPalette.bmp and back-up 
ColourPalette_Physibeldefault.bmp (I.5), the report template TriscoReportTemplate.doc (see I.3) 

and the default DXF layer definitions TriscoDxf.lay (see I.4), together with the parameter file 
TRISCO.prm (see A.10), are installed in C:/ProgramData/Physibel/TRISCO16 (machine-level), and 
copied to each user account’s application data folder when first opening TRISCO 
(C:/Users/username/AppData/Roaming/Physibel/TRISCO16), except for 
TriscoReportTemplate.doc, which is copied to the user’s personal folder 
(../Documents/Physibel/TRISCO16). 
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A.7. Text convention 

Menu paths are printed in italic, with format Submenu → Command. 
E.g. File → Open (Open command in File submenu). 

A.8. Program settings 

Global program settings can be edited via the main menu (Settings → …). 
 

  
 

− Settings → Disable Condensation Calculation (requires Interstitial Condensation module, see 
Chapter K): to hide all input data related to the interstitial condensation calculation in the 

Colours window and disable the Monthly Mean Climate Data window and Initial Moisture 

window and the interstitial condensation calculation and its outputs; and enable the Node BCs 

window, Borderface BCs window and Material BCs window. 

− Settings → Show RCL: to change the coordinate system from XYZ (right-handed Cartesian 
coordinate system, using axes X, Y en Z) to RCL (coordinate system using rows, columns and 
layers – as defined in the initial version of TRISCO). 

The XYZ system is the default system for new TRISCO data (from File → New). 

Settings → Show XYZ: to change the coordinate system from RCL to XYZ. 
− Settings → Thermal Palette…: to select the thermal palette used to visualize the temperature 

gradient in the solution. 

 
The user can choose between the traditional Physibel ‘Rainbow’ thermal colour palette, or the 

‘Ironbow’ thermal colour palette, which is often used by IR camera’s. 
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− Settings → Drag Mode...: to define how the view of an object (in the Image window or the 

Graphic Output window) changes as a result of a rotate or pan command (using the mouse 
or an arrow key), see C.2. 

 
”Drag object” moves the viewpoint position with respect to the object. ”Drag viewpoint” 
moves the object with respect to the viewpoint. 
The selected drag mode is saved in the program parameter file (see A.10). 

− Settings → Zoom Factor…: to customise the zooming factor of the mouse scroll wheel. The 

selected zoom factor is saved in the program parameter file (see A.10). 

 
− Settings → Default Standard…: set EN ISO 10077-2, EN ISO 6946 or NIHIL as default standard 

for the definition of colour types. 

 
− Settings → Flanking Elements…: to define whether areas are initialised based on external 

dimensions or on internal dimensions (cf. section B.18). 

 
− Settings → Set Graphic Report Definition as Default: to save the current parameters in the 

Graphic Report Definition window (cf. section G.2) in the parameter file (TRISCO.prm, see 

A.10) at program exit (File → Exit). 
− Settings → Toolbar: presence of the toolbar giving access to menu commands through icons. 
− Settings → Status Bar: presence of the status bar at the bottom of the TRISCO application 

window, containing context depending information. 

− Settings → Language…: to select the user interface language (English, Dutch, French, German). 

The selected language is saved in the parameter file (TRISCO.prm). After exiting TRISCO (File 

→ Exit) and restarting TRISCO, the new language is active. 

A.9. General editing commands 

Copy – paste 

− Edit → Copy Value: copies the value from the active input cell into the clipboard. 

− Edit → Paste Value: copies the value from the clipboard into the active input cell. 
 

Undo – redo 

− Edit → Undo 

Undoes the last edit action (e.g. to cancel a mistake). 
This command can be repeated to undo more previous edit actions. 
Only the last 100 edit actions are stored for undo. 
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The undo command is impossible after saving a file, closing the current file or starting a 

calculation. 

− Edit → Redo 

Restores the previous edit action that was made undone using Edit → Undo. 
In other words: "redo" undoes "undo". 
This command can be repeated to restore more edit actions that were made undone. 

A.10. Program parameters 

The global default values (calculation parameters, output parameters, interface language, 
graphic report definition, grid unit etc.) are saved in the file TRISCO.prm in the application data 
folder (C:/Users/username/Appdata/Roaming/ Physibel/TRISCO16). When the program TRISCO 

is started, the program parameters are loaded from the parameter file. 
 
The program parameter default values can be changed from several input dialog boxes. When 
the button “Set As Default” in an input dialog box is clicked, the corresponding program 
parameters are saved in the program parameter file TRISCO.prm at exiting TRISCO. 

A.11. References 

− EN ISO 6946 (July 2017). Building components and building elements - Thermal resistance and 
thermal transmittance - Calculation methods.  

− EN ISO 10211 (July 2017). Thermal bridges in building construction – Heat flows and surface 
temperatures – Detailed calculations 

− EN ISO 10077-2 (July 2017). Thermal performance of windows, doors and shutters. Calculation 

of thermal transmittance – Part 2: Numerical method for frames. 
− EN 10456 (December 2007). Building materials and products – Hygrothermal properties – 

Tabulated design values and procedures for determining declared and design thermal 

values. 
− EN ISO 13788 (February 2013). Hygrothermal performance of building components and 

building elements - Internal surface temperature to avoid critical surface humidity and 

interstitial condensation - Calculation methods. 
− Piet Standaert, Twee- en drie-dimensionale warmteoverdracht: numerieke methoden, 

experimentele studie en bouwfysische toepassingen. Doctoral dissertation, K.U. Leuven, 1984 

(in Dutch). 
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CHAPTER B EDITING INPUT DATA 

B.1. TRISCO program layout 

− The input in TRISCO is organised in several windows. 
Normally the following windows are open (e.g. after the command File → New or File → 

Open …): 

− The Image window, with a graphical representation of the model. In this window the object 
can be interactively rotated and zoomed in. 

− The Grid window, with the distances between the successive grid planes in three dimensions. 

− The Blocks window, with a list of all building blocks of the geometry. 

All coordinates refer to the grid numbers in the Grid window. 

− The Colours window, with the thermal data of all materials and surface boundary conditions. 

Each block in the Blocks window refers to a colour in the Colours window. 

 

  
 

A window can be activated by clicking with the left mouse button on its title bar or in its client 
area (when the window is already open and visible on the screen), or the window can be opened 
and activated by selecting the corresponding command in the Edit submenu. 
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Upper part of Edit submenu 

  
 

Other windows can be opened to edit or view input data: 

− The Coordinates window, to view the absolute coordinates of the grid planes (which are 

orthogonal to the coordinate axes). 

− The Minimum Grid window, for the definition of minimum grid mesh widths. 

− The Node BCs window, for the definition of node boundary conditions. 

− The Borderface BCs window, for the definition of boundary conditions in border faces 
between two colours (fixed temperature or fixed heat flux). 

− The Material BCs window, for the definition of boundary conditions inside material colours 

(fixed temperature or fixed volumetric heat power density). 

− The Clip Object window, for the definition of cut-off planes to get a clipped detail (of the total 

object) in the Image window. 

− The Clip Colours window, for the definition of colours to cut away in the Image window. 

− The Areas window, for the definition of areas related to the grid. 

− The U Values window, to get U values of specified wall sections. 

− The Monthly Mean Climate Data window (requires Interstitial Condensation module, see 

Chapter K), for the definition of monthly mean temperatures and relative humidities as 
boundary conditions for the interstitial condensation calculation. 

− The Initial Moisture window (requires Interstitial Condensation module, see Chapter K), to 

define moisture already present at the interface of 2 colours before the interstitial 
condensation calculation. 

− The Graphic Report Definition window, for the definition of images in a report output. 

 
Some dialog boxes (also opened via the Edit submenu) contain additional TRISCO input data: 

− The Calculation Parameters dialog box. 

− The Derived Thermal Properties dialog box, to request additional output in the Text Output 

window, derived from a calculation solution and the defined areas and U values. 

− The Notes dialog box, to enter text comments about the data. 
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B.2. TRISCO start up 

When TRISCO is launched, the parameter file TRISCO.prm is read (if present) to load global 
program settings (cf. section A.10). 
Then the default colour database ColourDatabase.trc is read (see I.2) to initialise material and 

surface boundary condition properties of the Colours window, which is useful to minimise the 

input for new data files. 
There is no visual feedback in the initial screen of TRISCO to indicate that TRISCO.prm and/or 
ColourDatabase.trc are loaded. 

B.3. File functions 

File submenu 

 

B.3.1. New project 

Menu command: File → New 

This command opens a new project, after closing the current open project (if present). 

The new project starts off with a single cubic block with sides equal to the grid unit (see B.5.3). 
All parameters are reset to their default values (as stored in the parameter file TRISCO.prm), 

except for the colour definitions. This allows to reuse the colour definitions of the previous open 
file. 

B.3.2. Open project 

Menu command: File → Open... 
After closing the current open project (if present), a File Open dialog box appears. 
Select a TRISCO data file (with extension .trc) from the list in the current folder or another folder. 

A preview of the current file is shown at the bottom of the dialog box. 
 

When a file is opened, all parameters are reset to their default values (as stored in the parameter 
file TRISCO.prm), except for the colour definitions. This allows to reuse the colour definitions of the 
previous open file (cf. File → New). Then all data from the chosen TRISCO data file are read and 
loaded into memory. Colour definitions that are not present in the data file, remain untouched. 
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When a solution (.sol file, possibly also .flx file) is present on disk (in the same folder as the data 

file) and this solution is compatible with the current TRISCO data file (e.g. same number of nodes), 
then this solution is automatically loaded after reading the .trc file. 

B.3.3. Open DXF file 

Menu command: File → Open DXF... 
Opens an existing DXF file by selecting it in the File Open dialog box. 

The DXF file is then sent to TriscoDxf to edit the conversion to a BMP file (see H.2), which is 
subsequentially imported automatically in TRISCO (see B.3.7). 

B.3.4. Open the colour database 

Menu command: File → Open Colour Database... 
The colour database contains predefined material and boundary condition properties (stored in 
the file ColourDatabase.trc in the application data folder, see I.2), which is loaded at every 
TRISCO start-up (see B.2). It is advisable to add frequently used materials and boundary 
conditions to the colour database. 

These predefined colours of the colour database are then available for new colours in any 
document. 

B.3.5. Import Trisco2D data files 

Menu command: File → Import Data... 
Files of type: Trisco2D (*.tr2) 
 

 
 

The two-dimensional Trisco2D object can be set in XY, XZ or YZ. The two-dimensional data of 
Trisco2D are extruded, because TRISCO always requires three dimensions. The third dimension is 
made of 1 grid mesh, the size of which is a user input (Object depth).  
The grid unit, object width and height are read from the Trisco2D data file and shown for 
information. 

The thermal properties of the colours are copied from the data in the tr2-file. 

B.3.6. Import BISCO data files 

Menu command: File → Import Data... 
Files of type: BISCO Data Files (*.bsc) 
 

Data files created from BISCO version 5.0 or higher, can be imported. 
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A BSC file contains a link to a bitmap file (256 colours BMP file). The bitmap is extruded (to get a 

third dimension) and converted into a list of blocks defined in a minimum grid (i.e. having grid 
planes only at pixel changes in the bitmap). The grid unit corresponds to the pixel size of the 
bitmap, as determined in BISCO. The bitmap can be set in XY, XZ or YZ. The third dimension is 
made of 1 grid mesh, the size of which is a user input (Object depth). 

The grid unit, object width and height are read from the BISCO data file and shown for 
information. 
 

 
 

The new blocks can use either superposition (with possible overlaps of blocks, which normally 
minimises the number of blocks) or juxtaposition (without any overlap of blocks), dependent on 
the user’s answer to the prompt “Use superposition of blocks ?”. 
The thermal properties of the colours in the bitmap are copied from the data in the BSC file. 
 

 
 

Before starting a calculation do not forget to refine the minimum grid. The calculation results in 
BISCO (for the original bitmap) and TRISCO (for the imported BISCO data file) may be different, 
due to the different triangulation (in BISCO) and grid (in TRISCO). Step lines are converted in 
BISCO to oblique lines, while in TRISCO the steps consisting of short horizontal and vertical lines 
remain unchanged. It is not recommended to calculate a BISCO data file for a bitmap with 
irregular shapes using the program TRISCO instead of using the program BISCO. Imported 
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BISCO data can be useful as starting data for a more complex 3D model (e.g. using the function 

Blocks → Revolve 90°…). 

B.3.7. Import bitmap files 

Menu command: File → Import Data... 

Files of type: Bitmap Files (*.bmp) 
 

A 256 colours BMP file (i.e. the same format as required by BISCO) can be imported in TRISCO. 
The bitmap is extruded over a constant depth made of 1 grid mesh, the size of which is a user 
input (Object depth). 

The bitmap is set in XY, XZ or YZ, with either superposition or juxtaposition of blocks (cf. section 
B.3.6). 
The bitmap pixel size, which translates into the grid unit in TRISCO, is to be determined by the 

user. To help determine the correct grid unit, the total width and height of the 2D bitmap object 
are given in the grid unit as currently defined. 
 

 

B.4. Grid window 

Menu command: Edit → Grid 

The Grid window is the input window for grid mesh sizes of a rectangular 3D grid. 

 

   
 

The grid 
The three orthogonal directions of the grid correspond to the axes of the coordinate system. 
This is either XYZ (a right-handed Cartesian coordinate system) or RCL (consisting of rows, 
columns and layers, as in a 3D matrix). Use the commands Settings → Show XYZ and Settings → 



16 Manual TRISCO v16.0 

Show RCL to switch between both systems (see A.8). Always choose the Z axis (or the layer 

direction) along the physical vertical direction (because otherwise the function Image → Rotate 
works unnaturally). 
The positions of the object blocks (cf. section B.7) are expressed in integer numbers referring to 
the sequence numbers of the grid planes in the three main directions. 

− In XYZ the grid plane positions are numbered 0,1,2,… 
− In RCL the grid plane positions are numbered 1,3,5,… (the even numbers refer to space 

intervals between two consecutive grid planes). 
The intersection points of three orthogonal grid planes inside or at the surface of material blocks 
are nodes of the system with unknown temperature. 
 

Grid meshes 

The meshes, or distances between successive grid planes in any of the three axis directions, are 

editable in the Grid window. 

The background colours of the grid meshes editable in the Grid window alternate indicating the 

underlying minimum grid (cf. section B.6). 
The grid unit is set in the dialog box opened with the command Grid → Grid Unit… (see B.5.3). 

B.5. Grid functions 

Lower part of Edit submenu 

 

Grid submenu 

 

B.5.1. Insert mesh 

− Edit → Insert Before 

Insert a new mesh (with size = 1 grid unit) before the active mesh. 

− Edit → Insert After 
Insert a new mesh (with size = 1 grid unit) after the active mesh. 

B.5.2. Grid mesh selections 

Individual grid meshes can be selected to perform global actions (split, merge). 

The selected meshes are marked in turquoise (light or dark dependent on the underlying 
minimum grid). 
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Meshes can be selected by clicking (left mouse button) the cell while holding the <Ctrl> key. A 
selection range can be defined by holding the <Shift> key. All meshes within the same column ΔX 

or ΔY can by selected by clicking (left mouse button) the column header.  

Alternatively, menu functions can be used to select meshes.  

 
From the Edit submenu: 

− Edit → Switch Select 
Switch on/off the selection for the active mesh. 

− Edit → Switch Select Downward 

Switch on/off the selection of the active mesh and all next meshes (on the same axis) with 

equal selection mode. 

− Edit → Switch Select Upward 

Switch on/off the selection of the active mesh and all previous meshes (on the same axis) with 
equal selection mode. 

− Edit → Select All 
Select all meshes on the same axis as the active mesh. 

− Edit → Deselect All  

Deselect all meshes (on all three axes). 
From the Grid submenu: 

− Grid → Select All (3x) 

Select all meshes (on all three axes). 

B.5.3. Grid unit 

Menu command: Grid → Grid Unit… 
 

    
 

The grid unit can be set in the dialog box. When the unit is altered, the user has the option to 
transform the grid widths, i.e. to keep the same physical dimensions of the model, or to keep the 
grid widths and thus scale the model according to the change in grid unit. 
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B.5.4. Create minimum grid 

Menu command: Grid → Create Minimum Grid… 

 

 
 

Creates a minimum grid in the indicated directions. 
All grid coordinates (and grid meshes) are rounded off to three decimal places. 

The meshes of the minimum grid only pass through borders of blocks (as defined in the Blocks 

window) and points in which node boundary conditions are defined (in the Node BCs window). 
 

The functions Blocks → Transform Coordinates… and Blocks → Insert File… (see B.7) automatically 
create a minimum grid in all three axis directions. 

B.5.5. Split (selected) mesh(es) 

Menu command: Grid → Split... 

 

Split either the selected meshes or the active mesh (when no selection is defined) into smaller 
parts according to the given method. 

Method: Geometric 

Each mesh is split into the specified number of subdivisions using a geometric series (i.e. a series 
with a constant ratio between successive terms) with specified split ratio. 

- When the split ratio = 1, then all created submeshes are equal. 
- When the split ratio < 1, then the submeshes have decreasing mesh widths. 
- When the split ratio > 1, then the submeshes have increasing mesh widths. 
A negative or zero split ratio is not allowed. 

 
Method: Maximum 

All submeshes have a constant mesh width (as defined by the parameter Mesh width in the 
dialog box), except for the last submesh, for which the width equals the remainder after division. 

This last submesh can however never be smaller than 0.1 % of the maximum mesh width. 
 
Method: Border 1 
Each mesh is split into two parts, when the original mesh size is greater than the given mesh 
width (parameter Mesh width in dialog box). The first submesh (border 1) gets the size of the 

given mesh width, the second submesh gets the size of the remainder. 
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Method: Border 2 

Each mesh is split into two parts, when the original mesh size is greater than the given mesh 
width (parameter Mesh width in dialog box). The second submesh (border 2) gets the size of the 

given mesh width, the first submesh gets the size of the remainder. 
 
Method: Border 1 & 2 

Calls successively: split using border 2, then split using border 1. 
So each mesh is split into three parts (when the original mesh size is large enough): both outer 
submeshes get the size of the given mesh width, the middle submesh gets the size of the 
remainder. 

B.5.6. Auto split 

Menu command: Grid → Auto Split… 

 

 
 

Split all meshes in the specified directions (X, Y, Z) into smaller parts. 
For originally smaller meshes (up to a given mesh size), the mesh is split into submeshes having a 
given split distance, and possibly a last submesh with width equal to the remainder after division 

(cf. Method: Maximum in section B.5.5). 
The other (larger) meshes are split using a geometric subdivision using a given split ratio (cf. 
Method: Geometric in section B.5.5) starting with the split distance used for smaller meshes at 

both ends of the original mesh. 
The function “Auto Split” is intended to achieve a reliable grid refinement suitable for calculation 
using only one function call (with well-chosen parameters in the dialog box) starting from the 
minimum grid. 

B.5.7. Merge selected meshes 

Menu command: Grid → Merge 

Merge each group of consecutive selected meshes into larger meshes (which width equals the 
sum of the widths of the original meshes). Meshes at both sides of a block border (or a node BC) 
cannot be merged. The grid planes of the minimum grid are always preserved. 

B.6. Minimum Grid window 

Menu command: Edit → Minimum Grid 

The Minimum Grid window shows the meshes of the minimum grid (through block borders and 

node BCs) without touching the actual grid (defined in the Grid window). This is thus not to be 

confused with creating a minimum grid (see B.5.4). 
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When a mesh size in the Minimum Grid window is edited, all underlying meshes of the Grid 

window are resized proportionally. 

B.7. Blocks window 

Menu command: Edit → Blocks 

 

 
 

 
 

The object geometry is defined by blocks in the Blocks window. 

 

Each block has the following parameters: 
 

Colour number (between 0 and 255) referring to the Colours window. 

The parameter “type” in the Colours window determines whether the block is massive or hollow. 
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- A material block (colour type MATERIAL, EQUIMAT or TRANSMAT) is massive and is 

added to the object geometry. 

- A boundary condition block (colour type BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY or 
BC_NOSKY) is hollow and is subtracted from the object geometry. 
 

6 coordinates of block borders (i.e. minimum and maximum coordinate per axis). 

The coordinates are grid plane numbers, which positions are defined in the Grid window. 
In the coordinate system XYZ the grid plane numbers are integers starting from 0. 
In the coordinate system RCL the grid plane numbers are odd numbers starting from 1. 
The background colour is light red, light green or light blue for a material block, and white for a 
boundary condition block. 

 

The size of the active block (width x depth x height) is visible in the status bar. 
 
Blocks with higher sequence number have priority over (i.e. overwrite the common parts of) 
blocks with lower sequence number. This is called the superposition rule. 

B.8. Block functions 

Lower part of Edit submenu 

 

Blocks submenu 

 

B.8.1. Insert block 

− Edit → Insert Before 

Insert a new block before the active block. 

− Edit → Insert After 
Insert a new block after the active block. 

 

The new block gets the following initial values: 
− The colour of the last edited block colour. 
− Block coordinates: 

− In XYZ: Xmin = 0, Xmax = 1, Ymin = 0, Ymax = 1, Zmin = 0, Zmax = 1. 
− In RCL: Rmin = 1, Rmax = 3, Cmin = 1, Cmax = 3, Lmin = 1, Lmax = 3. 
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B.8.2. Block selections 

 
 

Individual blocks can be selected to perform global actions (delete, copy, move, transform). 
The selected blocks are marked in (light or dark) turquoise. 
Blocks can be selected by clicking (left mouse button) the row number. Holding the <Shift> and 
<Ctrl> keys, a selection range can be defined.  
Alternatively, menu functions can be used to select blocks. 
 

Block selection functions: 

− Edit → Switch Select 

Switch on/off the selection for the active block. 

− Edit → Switch Select Downward 

Switch on/off the selection of the active block and all next blocks with equal selection mode. 

− Edit → Switch Select Upward 

Switch on/off the selection of the active block and all previous blocks with equal selection 

mode. 

− Edit → Select All 
Select all blocks. 

− Edit → Deselect All 

Deselect all blocks. 
 

A useful function to make block selections is the view option: 

− Blocks → List Same Colour 

This function only shows in the Blocks window all blocks having the same colour as the active 
block. 
 

 
 

− The block sequence numbers are the original sequence numbers (as in the normal view 
option Blocks → List All). 
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− The colour number cannot be edited. 

− The block coordinates can be edited. 
− Block selection is possible (but restricted to the displayed blocks, e.g. for Edit → Select All). 

− All other block functions are disabled. 
To enable these functions again, return to Blocks → List All. (All active block selections 
remain preserved.) 
 

− Blocks → List All 
List all blocks again, to terminate the view option Blocks → List Same Colour. 

B.8.3. Delete, copy, move 

The following functions have no effect on the active grid (as defined in the Grid window). 

 

− Edit → Delete 

Delete selected block(s), otherwise (in absence of a block selection) delete the active block. 
 

− Blocks → Copy After 
Copy selected block(s) to a new position in the blocks list. 

If there is no block selection, the active block is copied after itself. 
If there is a block selection, the selected blocks are copied immediately after the active block. 
After the copy operation the copied blocks become the new block selection. 

 

− Blocks → Move Selection Before 

Move selected block(s) to a new position in the blocks list. 
If there is no block selection, this function is disabled 
If there is a block selection, the selected blocks are moved immediately before the active 
block. 
After the move operation the selected blocks remain selected. 

 

− Blocks → Move Selection After 
Move selected block(s) to a new position in the blocks list. 
If there is no block selection, this function is disabled 

If there is a block selection, the selected blocks are moved immediately after the active block. 
After the move operation the selected blocks remain selected. 

B.8.4. Transform; insert file 

The following functions create new coordinates, and so have an effect on the current grid. 
After the block operation, a minimum grid is automatically created (with grid planes through the 
block borders). 
 

− Blocks → Transform Coordinates… 

Transform selected block(s), otherwise (in absence of a block selection) transform the active 

block. 
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There are three types of transformations: 

− Translation: over a given translation vector. 
− Rotation: over a right angle (90°, 180° or 270°) around a rotation axis parallel to X, Y or Z 

through the current origin (Coord → Set Origin, see C.11). 

− Scaling: using given scaling factors. 
The origin (Coord → Set Origin, see C.11) is the centre of the scaling. 
A mirror transformation is possible using a negative scaling factor. 
E.g. mirror X corresponds to the scaling factors –1, 1, 1. 
 

− Blocks → Insert File… 

The blocks of a TRISCO data file (extension .trc) are inserted after the active block. 

The new blocks are positioned from the current origin (Coord → Set Origin, see C.11). 

Colour definitions for not yet present colours (in the Colours window) are also read from the 
.trc file. 
After the operation the inserted blocks are selected. 

B.8.5. Revolve 

Menu command: Blocks → Revolve 90°… 

Only enabled for a 2D geometry (i.e. with only 1 mesh in X, Y or Z). 
 

Turns the 2D geometry around an axis parallel to X, Y or Z over 90° to form a 3D corner joint with 

the 2D geometry as profile section. This corresponds to a rectangular revolution around the axis. 
The axis lies at the negative or positive end of the bounding box of the 2D geometry (specified as 
axis position X- or X+, Y- or Y+, Z- or Z+ in the dialog box). 
The grid is extended in the third dimension (with originally 1 mesh) as a copy of the grid meshes in 

the direction perpendicular to the axis of revolution. 
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B.8.6. Arrange blocks 

Menu command: Blocks → Arrange Blocks… 

 

 
 

This function recalculates the list of blocks in the Blocks window based on the final object 

geometry and boundary conditions geometry in the Image window (viewed with Image → Show 

Materials and Image → Show BCs). The grid data in the Grid window remain unchanged. 

The blocks are generated using an algorithm that tries to minimise the number of blocks. 
The new list of blocks may be longer than the original list of blocks. 
There are two options: 
− Superposition of blocks: with possible overlaps of successive blocks in order to minimise the 

number of new blocks. 
− Juxtapostion of blocks: all new blocks are positioned adjacent to one another, without any 

overlaps of blocks. 

B.8.7. Reduce blocks to clipped object and colours 

Menu command: Blocks → Reduce to Clip… 

 

 
 

The answer “No” cancels the operation. “Yes” confirms the operation. 
The blocks are recalculated (using block arrangement with superposition; cf. section B.8.6) for the 

object and boundary condition geometry (as visible in the Image window) restricted to the active 

object clipping (cf. section C.9) and colours clipping (cf. section C.10). 
Afterwards clip object and clip colours are reset. 
A minimum grid is automatically created (with grid planes through the new block borders). 
The node boundary conditions, borderface boundary conditions, material boundary conditions, 

areas in Areas window, and U values in U Values window are cleared. 

B.8.8. Detect void (adiabatic) spaces within object 

Menu command: Blocks → Convert Void to Blocks… 

This function is only enabled if there are void spaces (not covered by object or boundary 

condition blocks) present in the 3D grid space. Void spaces are not directly visible in the Image 

window. Void spaces should normally be avoided in the grid space, because they imply implicitly 

adiabatic boundary conditions for all adjacent object surfaces. 
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This function allows to make them visible in the Image window and convert the voids to blocks 

with a certain colour number. 
It is advisable to choose a colour number not yet present in the model (B.10.1). 
 

 
 

All void spaces in the 3D grid space are converted to blocks having the chosen (new) colour 

number. All blocks are then recalculated using block arrangement with superposition (cf. section 

B.8.6). If the active cell is moved to the new colour in the Colours window (use type = MATERIAL), 

the outline of the void spaces becomes visible in the Image window. 

B.8.9. Redefine colour globally 

Menu command: Blocks → Change Colour… 

 

 
 

All blocks having the same colour number as the active block (with the active cell in the Blocks 

window) get a new colour number (as defined in the dialog box). 

B.9. Colours window 

Menu command: Edit → Colours 

 

 
 

The Colours window defines of the colours associated to the blocks in the Blocks window. 

Via the colours the thermal properties of the blocks are set. 

B.9.1. Colour number 

Each colour is identified by a colour number or colour index: an integer between 0 and 255. 
Thus a maximum of 256 colours can occur in a TRISCO data file. 
 

The fill colour belonging to each colour number can be changed. Position the active cell 
(surrounded by thick black lines) onto the second column (showing the actual colour), and double 
click (with the left mouse button) or press Enter. Choose a new colour in the standard Colour 

dialog box. 
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When TRISCO is started up, the default colour values are loaded from the file MatColor.rgb. 
This file contains the red, green and blue components (as numbers between 0 and 255) for all 

256 colour numbers. 
The (edited) colours for a specific TRISCO data file are stored in the file data (as RGB values), and 
are automatically loaded when the file is read. 

B.9.2. Colour type 

Each colour stands for a material or a surface boundary condition dependent on the colour type. 
 

The following types are always available (with or without the RADCON module): 

− MATERIAL: material defined by thermal conductivity. 
The material name and λ-value can be loaded from a material database (see B.10.2). 

− EQUIMAT: equivalent material defined by a single equivalent thermal conductivity (e.g. air 
cavity). The equivalent conductivity is typically calculated from standard rules (D.1.1). 

− BC_SIMPL: simplified surface boundary condition, defined by a global surface heat transfer 
coefficient (for combined convection and radiation), environmental temperature and possible 
additional surface heat flux. 

− BC_FRE_S: enclosure with unknown (free-floating) internal temperature, possible additional 
internal heat power, simplified surface heat transfer defined by a global surface heat transfer 

coefficient and possible additional surface heat flux. 
 

The following types are only available with the RADCON module (which supposes separate 
calculation of radiation, based on view factors, and convection, see Chapter J): 
− BC_FREE: surface boundary condition modelled as enclosure with unknown (free-floating) air 

temperature, radiation between the surfaces (using the infrared emissivities of the adjacent 

materials) and convective heat transfer coefficient. 

− BC_SKY: surface boundary condition modelled as an environment with defined air and 
radiation temperature (the sky) and convective heat transfer coefficient. 

− BC_NOSKY: surface boundary condition modelled as an environment with defined air 
temperature, no radiation to the environment (no sky) and convective heat transfer 
coefficient. 

− TRANSMAT: transparent material defined by thermal conductivity, and radiation between the 
surfaces (using the infrared emissivities of the adjacent materials). 
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The following table shows the different mechanisms of heat transfer. 
 

 Conduction 
(λ) 

Global convection + 
radiation (h) 

Convection 
(hc, θa) 

Radiation 
(view factors, ε) 

MATERIAL Fixed    

EQUIMAT Calculated    

BC_SIMPL  Fixed   

BC_FRE_S  Fixed   

BC_FREE   Calculated Calculated 

BC_SKY   Calculated Calculated 

BC_NOSKY   Calculated Calculated 

TRANSMAT Calculated   Calculated 

 
For an interstitial condensation calculation (requires Interstitial Condensation module, see 
Chapter K), models consisting of colours of type MATERIAL (user defined vapour resistance factor 
or μ-value) and EQUIMAT or TRANSMAT (vapour resistance factor of air, see Calculation 

Parameters, D.2.2) with boundary conditions of type BC_SIMPL, BC_SKY or BC_NOSKY (user 
defined relative humidity) can be configured. 

B.9.3. Standard (last column) 

Standard used for the automatic calculation of eq or hc (cf. section D.1). 

− NIHIL: no automatic calculation of thermal properties. 
− EN10077: standard EN ISO 10077-2. 
− EN6946: standard EN ISO 6946. 

− EN13788: standard EN ISO 13788. 
Within each standard different subtypes can be chosen. 

B.9.4. Colour subtype 

Subtype toggle value to define automatic calculation of equivalent thermal conductivity (type 
EQUIMAT and TRANSMAT) or convective heat transfer coefficient (BC_FREE, BC_SKY and 

BC_NOSKY). The accessible subtypes are dependent on the actual type (3rd column) and 
standard (last column). 
For type EQUIMAT: 
− NIHIL: user defined thermal conductivity and vapour resistance factor (no automatic 

calculation). 
− CAVITY: calculated equivalent thermal conductivity for unventilated air cavity (EN10077 or 

EN6946). 

− CAVITY_E: calculated equivalent thermal conductivity for slightly ventilated air cavity 
(EN 10077). 

− LAYER: calculated equivalent thermal conductivity for unventilated air layer (EN 6946). 
For type BC_SIMPL: 

− NIHIL: user defined global heat surface coefficient. 

− HI_NORML: normal internal heat transfer (EN10077). 
− HI_REDUC: reduced internal heat transfer (EN10077). 

− HI: internal heat transfer (EN6946 or EN13788). 
− HE: external heat transfer (EN10077, EN6946 or EN13788). 
− HI_CAV_E: slightly ventilated air cavity at the internal surface (EN10077 – radiosity method). 
− HE_CAV_E: slightly ventilated air cavity at the external surface (EN10077 – radiosity method). 
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− CLIM_I: use internal monthly mean climate data (temperature and relative humidity) for 

interstitial condensation calculations, from Monthly Mean Climate Data window) 
− CLIM_E: use external monthly mean climate data (temperature and relative humidity) for 

interstitial condensation calculations, from Monthly Mean Climate Data window) 

For type BC_FREE: 
− NIHIL: user defined convective heat transfer coefficient (no automatic calculation). 

− CAVITY: calculated convective heat transfer coefficient for unventilated air cavity. 
− CONVEC: calculated convective heat transfer coefficient for large air space. 
For type BC_SKY or BC_NOSKY: 
− NIHIL: user defined convective heat transfer coefficient (no automatic calculation). 
− CONVEC: calculated convective heat transfer coefficient for natural convection. 

For type TRANSMAT: 
− NIHIL: user defined thermal conductivity (no automatic calculation). 
− CAVITY: calculated thermal conductivity for unventilated air cavity. 

For more details on the corresponding calculation procedures see D.1. 

B.9.5. Colour physical heat flow direction 

Heat flow direction with reference to the physical reality: 
− HOR: horizontal heat flow. 
− UP: upward heat flow. 

− DOWN: downward heat flow. 
− CORNER: reduced heat flow at interior surface due to the effect of corners, furniture, curtains 

or suspended ceiling. 

B.9.6. Colour geometric heat flow direction 

Heat flow direction with reference to the grid XYZ coordinate system (see B.4): 
− X: heat flow parallel to the X axis. 
− Y: heat flow parallel to the Y axis. 

− Z: heat flow parallel to the Z axis. 
− Xy: heat flow parallel to the X axis and cavity width parallel to the Y axis. 
− Xz: heat flow parallel to the X axis and cavity width parallel to the Z axis. 

− Yx: heat flow parallel to the Y axis and cavity width parallel to the X axis. 

− Yz: heat flow parallel to the Y axis and cavity width parallel to the Z axis. 
− Zx: heat flow parallel to the Z axis and cavity width parallel to the X axis. 

− Zy: heat flow parallel to the Z axis and cavity width parallel to the Y axis. 

B.9.7. Colour name 

Enter a name for the material or boundary condition. The name should not exceed 25 characters. 
The status bar shows the volume of all blocks having this colour. 

B.9.8. Physical properties 

The relevant thermal properties for each colour type (that are used in a calculation) are shown in 

the Colours window. Values on a white background can be edited. Values on a yellow 

background are automatically calculated. Empty cells refer to irrelevant properties for the active 
colour type. 
 

The following physical properties are possible: 

− ε1 / ε2 [- / -]: infrared emissivities (values between 0.001 and 1) at warm and cold sides of 

cavity (type EQUIMAT). 
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Editing opens a dialog box for definition of the values. If any emissivity differs from 0.9 (the 

default value), the corresponding grid cell in the Colours window is highlighted in blue. 
 

  
 

− λ [W/(m.K)]: thermal conductivity of material (MATERIAL), equivalent material (EQUIMAT) or 

transparent material (TRANSMAT). 
− ε [-]: infrared emissivity (value between 0 and 1) of material surfaces (MATERIAL, EQUIMAT) 

adjacent to boundary condition or cavity with radiative heat transfer. 
− μ [-]: vapour resistance factor of material (MATERIAL), equivalent material (EQUIMAT) or 

transparent material (TRANSMAT). 
− θ [°C]: environmental temperature (BC_SIMPL). 

− RH [%] : environment relative humidity (BC_SIMPL, BC_SKY, BC_NOSKY) 

− h [W/(m2.K)]: global surface heat transfer coefficient (BC_SIMPL, BC_FRE_S). 

− q [W/m²]: surface heat flux (BC_SIMPL, BC_FRE_S, BC_FREE, BC_SKY, BC_NOSKY). 
− θa [°C]: air temperature (BC_SKY, BC_NOSKY). 

− hc [W/(m2.K)]: convective heat transfer coefficient (BC_FREE, BC_SKY, BC_NOSKY). 
− Pc [W]: convective power dissipated in the environment (BC_FRE_S, BC_FREE). 
− θr [°C]: radiation temperature (BC_SKY). 

B.10. Colour functions 

Colours submenu 

 

B.10.1. List colours 

All or part of the maximum of 256 colours can be shown in the Colours window: 

 

− Colours → List All 
List all available 256 colours. 

The edit fields for colour numbers not referenced from the Blocks window are disabled (grey 
text). 

The list is useful in choosing new colour numbers for blocks in the Blocks window. 
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− Colours → List Defined 

List all defined colours. 

This option displays besides all present colours (i.e. referenced from the Blocks window), the 

colour definitions from the colour database and from files previously opened in the current 

TRISCO session, which are still present in memory. 

The edit fields for colour numbers not referenced from the Blocks window are disabled (grey 

text). 
 

− Colours → List Present 

List all colours referenced from the Blocks window. 

This is the default setting when a new project file is opened. 

B.10.2. Load material properties 

Menu command: Colours → Load Material... 
 

The Material Database dialog box allows to select a material from a group of materials in a 
selected database. 

The available databases contain the thermal conductivities of different materials according to 
several European standards, and are stored in the files with extension .phm in the data folder 
...\Physibel\Materials (see A.6). The files can be edited using the program MatEdit.exe in the 

same folder. 
 

After selecting a material and pressing the OK button, the corresponding properties are loaded 
for the active colour number. 
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B.10.3. Recalculate thermal properties 

Menu command: Colours → Recalc Thermal Properties 

(Only enabled from the active Colours window) 

 
This function allows to update the automatically calculated thermal properties depending on the 

solution temperatures if a solution is available (after a system calculation or after reading an 
existing solution from disk).  
 

See section D.1. for more information. 

B.10.4. Split zones 

Menu command: Colours → Split Zones… 

(Only enabled from the active Colours window) 
 

Split all blocks of the active colour (i.e. where the cursor is located in the Colours window) into 

blocks of different new colours, so that each new colour represents a single zone (i.e. united and 
not separated by any other colour). 
The first new colour must be entered in the dialog box. 

 

 
 

Only colours not yet present in the Colours window are used. 

The new colours get the thermal properties from the original active colour. 
The original active colour is not reused as new colour. 
A warning appears when there are not enough free colours for all zones. 
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The function is useful for colours (e.g. of type BC_FRE_S, BC_FREE, TRANSMAT) which require 

single-zone colours to be valid in the calculation model. 

B.10.5. Copy - paste 

The functions Colours → Copy Row and Colours → Paste Row allow to copy all properties from 
one colour number to another colour number. 

B.11. Node BCs window 

Menu command: Edit → Node BCs 

 

 
 

A node boundary condition (“node BC”) is a grid node inside the object (defined by three grid 
number coordinates) with either a fixed temperature (type TEMP) or a fixed heat power (type 
POWER). 

Add a new node BC using Edit → Insert Before or Edit → Insert After. 

Delete a node BC using Edit → Delete. 
 
Remark 
This window is disabled when the Interstitial Calculation is enabled (A.8), which requires the 
interstitial Condensation module (see Chapter K). 

B.12. Borderface BCs window 

Menu command: Edit → Borderface BCs 

 

 
 

A border face boundary condition (“borderface BC”) imposes either a fixed temperature (type 

TEMP) or a fixed heat flux (type FLUX) in all interfaces between object blocks (in the final object 

composition as shown in the Image window) having different fixed colours. 

The position of the interfaces for the active borderface BC is highlighted in the Image window (if 

the option Image → Hide Outline is not active). 
 

Edit fields 
− Col.1: colour number (between 0 and 255) of object blocks at one side of the interface. 
− Col.2: colour number (between 0 and 255) of object blocks at the other side of the interface. 

− Type: TEMP or FLUX. 
− θ: temperature (in °C). 

− q: heat flux (in W/m2). 
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Remarks 

− When a colour number is entered that does not occur in the Colours window, then this input is 
not accepted (the input field is cleared). 

− To be valid at least one of both colour numbers must reference a material (type MATERIAL, 
EQUIMAT or TRANSMAT). 

− This window is disabled when the Interstitial Calculation is enabled (A.8), which requires the 
interstitial Condensation module (see Chapter K). 

 

Edit commands 

− Edit → Insert After: add a new borderface BC. 

− Edit → Delete: delete a borderface BC. 
 

This window is disabled when the Interstitial Calculation is enabled (A.8), which requires the 
interstitial Condensation module (see Chapter K). 

B.13. Material BCs window 

Menu command: Edit → Material BCs  

 

 
 

A material boundary condition (“material BC”) imposes either a fixed temperature (type TEMP) or 

a fixed heat power density (type POWER) in all object blocks (in the final object composition as 
shown in the Image window) having a given colour number. 

The outline of the object blocks related to the active material BC are highlighted in the Image 

window (if the option Image → Hide Outline is not active). 

 

Edit commands 

− Edit > Insert After: add a new material BC. 

− Edit > Delete: delete a material BC. 
 

Remarks 
− A drawback of this kind of boundary condition is that the total heat flow into all object blocks 

of the given colour number cannot be output (in the Text window). 

− This window is disabled when the Interstitial Calculation is enabled (A.8), which requires the 
interstitial Condensation module (see Chapter K). 

B.14. Areas window 

Menu command: Edit → Areas 
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The Areas window allows to define (up to) three rectangles in space and view the areas (in m2). 
The areas are used in the calculation of global thermal transmittances (see D.9). 
The rectangles must be parallel to a coordinate face, else the area is reset to 0 m2. 

This requires: 
− In XYZ: Xmin = Xmax or Ymin = Ymax or Zmin = Zmax 
− In RCL: Rmin = Rmax or Cmin = Cmax or Lmin = Lmax 

B.15. U Values window 

Menu command: Edit → U Values 

 

 
 

The U Values window allows to define three lines along which the thermal transmittance (U value) 

is calculated. The U values of flanking elements of a thermal bridge can be used in the 
calculation of global thermal transmittances (see D.9). If an enforced U value is entered (to 
override the calculated U value), this enforced U value is used in the global thermal 

transmittances as U value of the flanking element. 
 

The line must satisfy the following conditions, else the U value is reset to 0 W/(m2.K): 

− The line must be parallel to a coordinate axis (the line in the Image window will be coloured in 

the axis’ colour if this condition is met). 

In XYZ: either Xmin = Xmax and Ymin = Ymax and Zmin < Zmax, or 
Xmin = Xmax and Ymin < Ymax and Zmin = Zmax, or 
Xmin < Xmax and Ymin = Ymax and Zmin = Zmax. 
In RCL: use only odd numbers, and either 
Rmin = Rmax and Cmin = Cmax and Lmin < Lmax, or 

Rmin = Rmax and Cmin < Cmax and Lmin = Lmax, or 
Rmin < Rmax and Cmin = Cmax and Lmin = Lmax. 

− Both end points must lie in (or touch) different boundary conditions of type BC_SIMPL or 

BC_FRE_S with surface heat transfer coefficient h > 0 W/(m2.K). 
− The line must not enter other boundary conditions, but should only pass through material 

layers. 
− The line must not lie in the interface between two different colour blocks to avoid any possible 

ambiguity in the crossed colour blocks. 
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B.16. Mean Monthly Climate Data window 

Menu command: Edit → Monthly Mean Climate Data 
 
(requires Interstitial Condensation module, see Chapter K). 
 

 
 

The Monthly Mean Climate Data window allows to define monthly temperatures and relative 

humidity for internal and external environments which can be used with type BC_SIMPLE, 

subtypes CLIM_I and CLIM_E for interstitial condensation calculations spanning multiple months 
see D.5). 

B.17. Initial Moisture window 

Menu command: Edit → Initial Moisture 

 
(requires Interstitial Condensation module, see Chapter K). 
 

 
 

The Initial Moisture window allows to define an amount of moisture present at an interface of 2 

colours as initial conditions for an interstitial condensation calculation. 

B.18. Initialise Areas & U Values 

Menu command: Calc → Init Areas & U Values  

 

For new data the areas and U values are automatically initialised as soon as one of these items is 

requested (i.e. when opening the Areas window or U Values window, or when requesting output 
containing areas and/or U values). 
Once the areas and U values are defined (e.g. for an existing data file), these values remain fixed 

and are stored in the .trc data file when it is saved. They can be reinitialised again by calling 
explicitly the function Calc → Init Areas & U Values. 
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The initialisation is only possible if two different boundary conditions of type BC_SIMPL (with 

different temperatures: the lower temperature is called the external temperature, the higher 
temperature is called the internal temperature) are present. The initialisation of areas is based on 
either external or internal dimensions (external dimensions at the side of the external 
temperature, internal dimensions at the side of the internal temperature), dependent on the 

setting defined in Settings → Flanking Elements…. 

Always check the result of the automatic areas and U values initialisation (by viewing the Areas 

window and U Values window), because the underlying algorithm has its limits. 
The location of all areas and U values can be shown in the graphic output (cf. section E.5). 

B.19. Notes window 

Menu command: Edit → Notes… 

 

 
 

In the Notes dialog box some comments (max. 10 lines) can be written for the current document, 
e.g. project description, operator, date. These notes are saved in the TRC file are shown in the 

text output. 
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CHAPTER C VIEWING THE MODEL 

C.1. Image submenu 

The object model as defined in the Blocks window and Colours window is shown in the Image 

window. The view of the object in the Image window can be altered using image functions. In the 

bottom left corner of the Image window, the 3 main coordinate axes are shown for reference 

(red for X or R, green for Y or C, and blue for Z or L). 
 

     
 

The active view mode (Rotate, Pan, Zoom Window or Zoom In) and active object appearance 
(Show Materials, Show Transparent, Show BCs, Show Temperatures or Show Single 

Temperature) are checked in the Image submenu (see check mark in front of menu commands). 

C.2. Viewpoint 

The viewpoint can be rotated or panned (i.e. moved laterally). 
− Image → Rotate 

Enters rotate mode. Mouse dragging or pressing arrow keys (left, right, up, down, with Image 

window active) rotates the relative position of the viewpoint with respect to the object centre. 

The Z axis of the XYZ coordinate system should point upwards to the sky (or the layer axis of 
the RCL system should point downwards) to get a good behaviour of the rotate function. 

Rotate mode is activated automatically by holding down the mouse wheel when the Image 

window perspective (3D) projection is active (C.4). 
− Image → Pan 

Enters pan mode (only possible when the current view is already zoomed in). Mouse 

dragging or pressing arrow keys (with Image window active) moves the relative position of 
viewpoint and object centre parallel to the projection plane. 

Pan mode is activated automatically by holding down the mouse wheel when the Image 

window 2D orthogonal projection is active (C.4). 
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The command Settings → Drag Mode allows to define the relative movement of viewpoint and 

object (as either “drag viewpoint” or “drag object”, cf. section A.8). 

C.3. Zoom commands 

− Image → Zoom Window 

Enters “zoom window” mode. This allows to draw a zoom rectangle using the mouse in the 

Image window, which defines the borders of a zoomed view. 
Press Esc to cancel the current zoom rectangle (before releasing the left mouse button). 

− Image → Zoom In 

Enters “zoom in” mode. A following click using the left mouse button in the Image window 
defines the centre point of the next zoomed view. The zoom factor can be defined with 

Settings → Zoom Factor… (see A.8). 

Zooming in is also possible using forward scrolling with the mouse wheel (when the Image 

window is active). 

− Image → Zoom Out 
Zooms out. The zoom factor can be defined with Settings → Zoom Factor… (see A.8). 

Zooming out is also possible using backward scrolling with the mouse wheel (when the Image 

window is active). 

− Image → Zoom Total 
Shows total object. 

− Image → Previous View 

Shows the previous zoom view. (More than one previous view cannot be recalled.) 

− Image → Zoom Numbers… 

Opens a dialog box with the current zoom parameters. 
Enter new parameters to change the view. Use preferably rounded numbers to facilitate 

restoring the same view at a later moment. 
 

 

C.4. Projection 

Projection submenu 

 
 

The projection of the model in the Image window can be toggled between  

− Projection → Perspective: perspective view of the 3D model. 
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− Projection → Xmin…: 2D orthogonal view of the model onto the YZ plane with minimum X 

coordinates, looking in the positive X direction. 
− Projection → Xmax…: 2D orthogonal view of the model onto the YZ plane with maximum X 

coordinates, looking in the negative X direction. 
− Projection → Ymin…: 2D orthogonal view of the model onto the XZ plane with minimum Y 

coordinates, looking in the positive Y direction. 
− Projection → Ymax…: 2D orthogonal view of the model onto the XZ plane with maximum Y 

coordinates, looking in the negative Y direction. 
− Projection → Zmin…: 2D orthogonal view of the model onto the XY plane with minimum Z 

coordinates, looking in the positive Z direction. 

− Projection → Zmax…: 2D orthogonal view of the model onto the XY plane with maximum Z 
coordinates, looking in the negative Z direction. 

C.5. Object appearance 

Object compilation 

The object appearing in the Image window is the result of processing the blocks list in the Blocks 

window. 

Each block has a colour. The colour (defined in the Colours window) refers to either a material 

(type MATERIAL, EQUIMAT or TRANSMAT) or a boundary condition (type BC_SIMPL, BC_FRE_S, 
BC_FREE, BC_SKY or BC_NOSKY). 
A material block (which refers to a material colour) is added to the resulted object. 

A boundary condition block (which refers to a boundary condition block) is subtracted from the 
resulted object. The boundary condition is active on all object surfaces adjacent to the boundary 

condition block. 

The superposition rule in the Blocks window makes that blocks with higher sequence number 
overwrite the common parts of blocks with lower sequence number. 
 

View options 

The colour of the surfaces of the material blocks of the object in the Image window can be 

modified: 
− Image → Show Materials 

Shows the material colours of the material blocks in the object. 

− Image → Show Transparent 
Shows the object with transparent materials, so that the inside of the object can be viewed. 

    
− Image → Show BCs 

Shows the colours of the boundary conditions which are active on the material blocks in the 
object. 
When there are no explicit boundary conditions active on a material block surface, then an 
adiabatic boundary condition (i.e. without any heat transfer) is supposed. This implicit 

adiabatic boundary condition is coloured light yellow on the material blocks. 



42 Manual TRISCO v16.0 

− Image → Show Temperatures 

Shows the calculated temperatures on the material blocks in the object. 

This option is only available if a calculation solution is present. 
The thermal palette making up the colours of the temperature scale are interpolated from 
values defined in a .rgb file (see A.8). This is a text file containing red, green and blue 
components (values from 0 up to 255) for increasing temperature values. 

The legend of used colours can only be made visible in the Graphics Output window 

(cf. section E.5). 
The temperature scale is defined in Image → Temperature Range…. 

− Image → Show Single Temperature 
Shows the 3D temperature surface of the “single value” defined in the Temperature Range 
dialog box (Image → Temperature Range…) within the transparent object. 

− Image → Temperature Range… 

Opens a dialog box to define the parameters of a temperature view. 
The option “Use boundary condition temperatures” initialises the minimum and maximum 
temperatures from the boundary condition temperatures of types BC_SIMPL present in the 

Colours window. 

The first increment is used as step value in Image → Temperature Range…. 

(The second increment is only used with isothermal lines in the Graphics Output window) 

This command is only enabled when the menu option “Show Temperatures” is checked. 
 

 
 

Remark: 

Before starting a calculation, it is advised to check carefully the surface boundary conditions 
active on the object surface using the command Image → Show BCs. 

C.6. Quick block selection using the mouse 

It is possible to select a block in the Blocks window from the Image window using the mouse. 
The current object appearance mode should be: 
−  “Show Materials” (activated through Image → Show Materials) to select a material block; 
−  “Show BCs” (Image → Show BCs) to select a boundary condition block. 

Point to the desired surface in the Image window and click (double click with left mouse button, or 

single click with right mouse button) to move to the underlying block in the Blocks window. 

C.7. Active item feedback in the Image window 

The active item of the current input window is highlighted in the Image window: 

− From the Blocks window: edges of current block (in wireframe). 

Example: see figure below left. 

− From the Colours window: object parts corresponding to the current colour (in wireframe).  

Example: see figure below centre. 
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The volume of all blocks having the current colour is shown in the status bar when the active 

cell is upon the colour name.  

− From the Grid window: edges of box surrounding the current mesh (in wireframe). 

Example: see figure below right. 
The colours of object surfaces not intersecting the grid mesh box are dimmed. 
The edges of the surrounding box of the entire grid space closest to the coordinate axes are 
coloured red (X or R), green (Y or C) and blue (Z or L). 

    
 

Analogous feedback for the current item in the Image window is available from the other input 

windows. 
The feedback lines can be removed by clicking the toggle Image → Hide Outline. Click this 
command again to show the feedback again. 

C.8. Pick temperature using the mouse 

When the Image window is active (i.e. its title bar is blue) and the temperatures are shown (Image 
→ Show Temperatures), then the surface temperature at the mouse cursor is displayed in the 
status bar (bottom left of the screen). 

The number of decimals can be modified via the Decimals dialog box from the Text Output 

window (cf. section F.5.1). 

C.9. Object clipping 

Menu command: Edit → Clip Object 
 

   
 

Part of the object can be shown in the Image window by clipping off all object parts outside a 
grid interval in any of the three coordinate directions. In this way cross-sections through all grid 
planes can be shown. 
 

The clip borders are defined in the Clip Object window (opened with Edit → Clip Object). Editing 

the clip borders is immediately reflected in the Image window. 
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Clipping can be reset (to view the total object) with the command Image → Clip Off. 
 
The object clip settings have no effect on the calculation. The calculation is always executed on 
the total object. 

It is possible to reduce the object to the current clip settings with the command Blocks → Reduce 
to Clip… (cf. section B.8.7). 

C.10. Colour clipping 

Menu command: Edit → Clip Colours 

 

  
 

Object parts of each colour can be clipped off in the Image window. The visibility status is 

defined in the Clip Colours window (opened with Edit → Clip Colours). This function can come in 

handy for example to visualise the temperatures in parts of the model which are otherwise 

hidden. 
 

The colour clip settings are also applied in the Graphic Output window. 

 
Colour clipping has no effect on the calculation. The calculation is always executed on the total 
object. 

It is possible to reduce the object to the current clip settings with the command Blocks → Reduce 
to Clip… (cf. section B.8.7). 

C.11. Coordinates window 

Menu command: Edit → Coordinates 

 

The Coordinates window shows the absolute coordinates for all grid planes. 

The coordinate system is XYZ or RCL (see A.8). 
The origin on each axis can be moved to any grid plane position via Coord → Set Origin. The 
origin is used as anchor point for coordinate transformations (Blocks → Transform Coordinates…: 

rotation, scaling) and file insertion (Blocks → Insert File…). 

The coordinate values cannot be edited in the Coordinates window. Coordinates are modified 

via the Grid window (Edit → Grid). 
The background colours of the coordinates modify according to the underlying minimum grid (cf. 
section B.6). 
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The position of the origin and coordinate axes (X or R in red, Y or C in green, Z or L in blue) are 

shown in the Image window. The position of the current coordinate is at the transition to the 
dimmed block colours (using Image → Show Materials or Image → Show BCs). 
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CHAPTER D CALCULATION 

D.1. Automatic calculation of thermal properties 

In the Colours window colour types and subtypes can be selected which contain an automatic 

calculation of thermal properties in accordance with international standards (equivalent thermal 
conductivity or convective heat transfer coefficient). 
 

During the input of new data the calculation is based on the default temperature values from the 
relevant standards, or on the default temperature difference across airspace as defined by the 

user in the Calculation Parameters dialog box (see D.2.1) if the calculated thermal property is not 
standardized. 
 

During a system calculation the thermal properties are recalculated based on the real 
temperature values, obtained by the global thermal calculation. The non-linear calculation is split 
in several iteration cycles. Each iteration cycle solves a linear system. The linear system is based 
on updated thermal properties derived from the temperatures available from the solution of the 

previous iteration cycle. The recalculated thermal properties are updated in the Colours window 
at the start of each new iteration cycle. 
 

After a system calculation (or after reading an existing solution from disk) the thermal properties 

can be updated using the last available temperature solution with the function Colours → Recalc 
Thermal Properties. With a good solution the values will not change significantly. 
 

An existing system solution loaded in memory is cancelled after each edit operation (which alters 

the input data). The thermal properties are then recalculated again based on the default 
temperature values. 

D.1.1. Colour type EQUIMAT 

Colour modelled as equivalent material (with single equivalent thermal conductivity 𝜆𝑒𝑞 for 

combined convective and radiation heat transfer) 

 

Type Subtype Meaning Standard 

EQUIMAT NIHIL Thermal conductivity defined by user  

CAVITY 
Unventilated (internal) air cavity with given heat flow 
direction 

EN10077 
EN6946 

CAVITY_E 
Ventilated (external) air cavity with given heat flow 

direction 

EN10077 

 LAYER Unventilated air layer with given heat flow direction EN6946 

 

Characteristic dimensions 
Consider a characteristic 2D section of the air cavity, containing the heat flow direction (parallel 

to a coordinate axis) and the smaller of the other two directions of the cavity. The characteristic 
dimensions in the 2D section are called depth (parallel to the heat flow direction) and width 
(orthogonal to the heat flow direction). 
 

If the air cavity is not a rectangular parallelepiped (or cuboid) shape, the depth and width are 

calculated from an equivalent rectangular parallelepiped with the same aspect ratio: 



Manual TRISCO v16.0 47 

𝑑′ = size of surrounding box of air cavity in depth direction 

𝑏′ = size of surrounding box of air cavity in width direction 
𝑉′ = volume of surrounding box of air cavity 
𝑉 = real volume of air cavity 
𝑑 =  𝑑′ ∙ 𝑠 
𝑏 =  𝑏′ ∙  𝑠 

𝑠 =  √
𝑉

𝑉′
 

 
If the air cavity has a uniform length in the third dimension (perpendicular to depth and width), 
then the calculation corresponds to the 2D calculation rule in EN ISO 10077-2. 
 

 
The calculated dimensions d and b are further used in the formulas below. 
 

Equivalent thermal conductivity of unventilated air cavity (subtype CAVITY) 
𝜆𝑒𝑞 = (ℎ𝑐 + ℎ𝑟) ∙ 𝑑 

- ℎ𝑐 = convective heat transfer coefficient (from warm surface to cold surface) 

if 𝑏 < 0.005 m (for EN ISO 10077-2), then 

ℎ𝑐 =
𝐶1

𝑑
 

if 𝑏 ≥ 0.005 m (for EN ISO 10077-2) or for any 𝑏 (EN ISO 6946), then 

ℎ𝑐 = 𝑚𝑎𝑥 {
𝐶1

𝑑
, 𝐶2 ⋅ (𝛥𝜃𝑠𝑠)𝐶3} 

𝛥𝜃𝑠𝑠 = maximum surface temperature difference in air cavity (𝛥𝜃𝑠𝑠 ≥ 5°C for EN ISO 6946) 
or 𝛥𝜃𝑠𝑠  = 𝛥𝜃𝑠𝑠,𝑑𝑒𝑓𝑎𝑢𝑙𝑡 (see D.2) 

 

Standard Heat flow direction C1 C2 C3 𝛥𝜃𝑠𝑠,𝑑𝑒𝑓𝑎𝑢𝑙𝑡 

EN10077 horizontal 0.025 0.73 0.333333 10°C 

EN6946 horizontal 0.025 0.73 0.333333 5°C 

upward 0.025 1.14 0.333333 5°C 

downward 0.025 0.09 ⋅ 𝑑−0.44 0.187 5°C 

 
- ℎ𝑟 = radiative heat transfer coefficient 

EN ISO 10077-2: ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 ∙ 𝐸 ∙ 𝐹 

EN ISO 6946: ℎ𝑟 = 4 ∙ 5.67 ∙ 10−8 ∙ (𝜃𝑚 + 273.16)3 (
1

𝐸
+

1

𝐹
− 1)⁄  

𝐸 =
1

1
𝜀1

+
1
𝜀2

− 1
 

𝐹 = (1 + √1 + (
𝑑

𝑏
)

2

−
𝑑

𝑏
) 2⁄  
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𝜃𝑚 =
𝜃𝑠,𝑚𝑖𝑛 + 𝜃𝑠,𝑚𝑎𝑥

2
 

𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in air cavity [°C] 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in air cavity [°C] 

or 𝜃𝑚 = 10°C (default mean temperature, see D.2) 
 1 , 2 = emissivities at warm and cold sides of air cavity (default values: 1 = 2 = 0.9) 
 

Equivalent thermal conductivity of slightly ventilated air cavity (subtype CAVITY_E, standard 
EN10077) 
An air cavity is considered to be slightly ventilated when there is an open connection to an 

exterior or interior boundary condition with a slit between 2 and 10 mm, and 𝑑  𝑏. 
𝜆𝑒𝑞 = 2 ∙ (𝜆𝑒𝑞 of unventilated air cavity). 

 
Equivalent thermal conductivity of air layer (subtype LAYER, standard EN6946) 

In the formula above for subtype CAVITY set 𝑑/𝑏 = 0 for ℎ𝑟. 
 

Adiabatic boundaries 
An adiabatic boundary (i.e. a boundary through which there is no heat transfer) can be 
considered as a symmetry axis (with symmetric heat flow pattern). 
When there is an adiabatic boundary at one side of the width direction, the equivalent width b is 
automatically doubled for subtype CAVITY. 

When there are adiabatic boundaries at both sides of the width direction, the equivalent width b 
is automatically considered to be infinite for subtype CAVITY (so d/b = 0, as for subtype LAYER). 

 
Vapour diffusion-equivalent qir layer thickness (subtypes CAVITY, LAYER and CAVITY_E) 
(requires Interstitial Condensation module, see Chapter K). 

For air layers and cavities, the vapour diffusion-equivalent air layer thickness 𝑠𝑑 is calculated 
automatically and translated in a 𝜇-value using the depth 𝑑. 

𝑠𝑑 = 𝜇 ∙ 𝑑 
Assuming the Sherwood number is equivalent to the Nusselt number (thus assuming the 
boundary layers for heat transfer and vapour transfer are identical): 

𝜇 =
𝜆𝑎𝑖𝑟

ℎ𝑐 ∙ 𝑑
 

𝜆𝑎𝑖𝑟 = 0.025 W/m²K 

D.1.2. Colour type BC_SIMPL or BC_FRE_S 

Purpose: simplified surface boundary condition (using a global surface heat transfer coefficient). 
For BC_SIMPL, the environment temperature is defined by the user. For BC_FRE_S, the 
environment temperature is unknown (free-floating). 
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Type Standard Subtype 
Physical  

heat flow 
Meaning 

BC_SIMPL 

NIHIL 

NIHIL 

 Global surface heat transfer  
coefficient h, temperature θ and RH 

defined by user 

CLIM_I, 
CLIM_E 

 Global surface heat transfer  
coefficient h defined by user 

EN10077 

HI_NORML horizontal 
Normal h at interior surface:  
h = 7.7 W/(m2.K), θi = 20°C 

HI_REDUC horizontal 
Reduced h at interior surface:  
h = 5 W/(m2.K) , θi = 20°C 

HE  
h at exterior surface:  
h = 25 W/(m2.K), θe = 0°C 

HI_CAV_E horizontal 
Slightly ventilated air cavity: 
h = 3.33 W/(m2.K), θi = 20°C 

HE_CAV_E horizontal 
Slightly ventilated air cavity: 
h = 3.33 W/(m2.K), θe = 0°C 

EN6946 

HI 

horizontal 
h at interior surface:  
h = 7.7 W/(m2.K) 

upward 
h at interior surface:  

h = 10 W/(m2.K) 

downward 
h at interior surface:  
h = 5.9 W/(m2.K) 

HE 
 h at exterior surface:  

h = 25 W/(m2.K) 

EN13788 

HI, CLIM_I 

horizontal h at interior surface:  
h = 7.7 W/(m2.K) 

upward h at interior surface:  
h = 7.7 W/(m2.K) 

downward h at interior surface:  
h = 7.7 W/(m2.K) 

corner h at interior surface:  
h = 4.0 W/(m2.K) 

HE, CLIM_E 
 h at exterior surface:  

h = 25 W/(m2.K) 

 

D.1.3. Colour type BC_FREE 

(This type requires the RADCON module, see Chapter J) 

Purpose: enclosure with unknown (free-floating) air temperature to be calculated from 
convective heat balance and radiation based on view factors. 

Type Subtype Meaning 

BC_FREE NIHIL Convective surface heat transfer coefficient hc defined by user 

CAVITY Air cavity with given heat flow direction 
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CONVEC Large air space, without preferential heat flow direction* 

*typically larger than 0.3m 

 
CAVITY: 
The CAVITY subtype is to be used when a global heat flow direction is assumed (surface-to-
surface heat transfer with an air temperature in between temperature of ‘hot’ and ‘cold’ surface 
temperatures, e.g. typically used for a cavity in a façade). 
The characteristic dimensions of the air cavity, d (= depth, parallel to heat flow) and b (= width), 

are calculated as for colour type EQUIMAT (see above). 
The values calculated according to the different standards in D.1.1 are defined however as 
surface-to-surface. Since the convective surface heat transfer coefficient ℎ𝑐 for BC_FREE is 

surface-to-air, the values calculated in D.1.1 are doubled. 
ℎ𝑐 = convective surface heat transfer coefficient (surface-to-air) 
ℎ𝑐 = 2 ∙ (ℎ𝑐,𝐸𝑄𝑈𝐼𝑀𝐴𝑇) 

 
CONVEC: 
The subtype CONVEC must be used when no global heat flow direction can be assumed in the 
enclosure (surface-to-air heat transfer with an air temperature higher or lower than surface 
temperatures, e.g. typically used for a room). 
ℎ𝑐= convective surface heat transfer coefficient (surface to air) 
ℎ𝑐 = 2 ∙ 𝐶2 ∙ (𝛥𝜃𝑠𝑎)𝐶3 
𝛥𝜃𝑠𝑎= greatest difference between air temperature and surface temperature 

𝛥𝜃𝑠𝑎 = max (|𝜃𝑎 − 𝜃𝑠,𝑚𝑖𝑛|, |𝜃𝑎 − 𝜃𝑠,𝑚𝑎𝑥|) 

𝜃𝑎 = air temperature 
𝜃𝑠,𝑚𝑖𝑛 = minimum surface temperature in contact with given boundary condition colour 

𝜃𝑠,𝑚𝑎𝑥 = maximum surface temperature in contact with given boundary condition colour 

or 𝛥𝜃𝑠𝑎= calculation parameter “Default temperature difference across airspace” (see D.2) 

 

Heat flow direction C2 C3 

horizontal 0.73 0.333333 

upward 1.14 0.333333 

downward 0.09 0.187 

D.1.4. Colour type BC_SKY or BC_NOSKY 

(This type requires the RADCON module, see Chapter J) 

Purpose: environment with known air temperature and relative humidity and either user defined 
radiation temperature (BC_SKY) and radiation based on view factors or no radiation exchange 
(BC_NOSKY). 

Type Subtype Meaning 

BC_SKY 
or 

BC_NOSKY 

NIHIL Convective surface heat transfer coefficient hc defined by user 

CONVEC 
Natural convection surface-air  
(calculation of hc: cf. above BC_FREE - CONVEC, see D.1.3) 

D.1.5. Colour type TRANSMAT 

(This type requires the RADCON module, see Chapter J) 
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Purpose: air cavity modelled as transparent material (radiation based on view factors, cf. 

radiosity method (EN ISO 10077-2) , and equivalent thermal conductivity 𝜆𝑒𝑞 for convective heat 

transfer) 

Type Subtype Meaning 

TRANSMAT NIHIL Thermal conductivity defined by user 

CAVITY 
Unventilated air cavity (calculation of eq and 𝑠𝑑 cf. above 
EQUIMAT, CAVITY with hr = 0, because radiation is calculated using 
view factors) 

D.2. Calculation parameters 

Menu command: Edit → Calc Parameters… 

D.2.1. Thermal 

 
 

The calculation parameters control the thermal system calculation (Calc → Calc System) and 

view factors calculation (Calc → Calc Viewfactors). 

The factors that are not relevant to the current data file are not editable (disabled input fields in 
grey). 
 

Iteration cycles 
A non-linear problem (e.g. radiation or due to temperature dependent properties) is solved by 
splitting the problem in a sequence of linear problems. 
Each linear problem is called an iteration cycle. 
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At the start of each iteration cycle the non-linear thermal properties are updated based on the 

calculation results of the previous iteration cycle to achieve renewed linear properties that can be 
used in the linear problem. 
The iteration cycle is then solved using an iterative method. 
At the end of the iteration cycle the new solution is compared to the solution of the previous 

iteration cycle to check the convergence. 
Parameters: 
− Maximum number of iteration cycles: this is a limit on the total number of iteration cycles 

(needed when there is no convergence). 
Normally 5 iteration cycles are sufficient to solve most non-linear systems with adequate 
precision. 

− Maximum temperature difference between iteration cycles: this is the maximum allowed 
temperature difference in any node between the previous and the current iteration cycle 
solution. 

When the temperature differences in all nodes are smaller, then the iteration cycles are 
stopped. 

 

Iterative solution per iteration cycle 
− Maximum number of iterations: this is a limit on the total number of iteration steps (needed 

when the other stopping criteria fail). 

− Maximum temperature difference: this is the maximum allowed temperature difference in any 

node between the previous and the current iteration step. 
− Maximum heat flow divergence for total object: this is the maximum allowed relative energy 

balance error for the total object (as union of all elementary control volumes). 
(ISO 10211 requires max. 0.01 %) 

− Maximum heat flow divergence for any node: this is the maximum allowed relative energy 

balance error for the worst elementary control volume. 
(Sometimes this condition is too severe; in that case enter 200 %, or better 200.1 % to avoid 
problems due to numerical rounding errors, see D.6) 

The iteration stops when the last three conditions are satisfied. The first condition (maximum 
number of iterations) acts as an emergency break. 
 

Radiation (requires RADCON module, see Chapter J) 
The radiation between two black surfaces is expressed as: 
𝑞𝑟 = 𝐹𝑖𝑗 ⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑖 − 𝜃𝑗) 

𝑞𝑟= radiation heat flux [W/m2] 
𝐹𝑖𝑗= view factor from surface i to surface j (= fraction of radiation leaving surface i that is 

intercepted by surface j) 
ℎ𝑟𝑏= black radiation heat transfer coefficient [W/(m2.K)] 
𝜃𝑖 = temperature of surface i [°C] 
𝜃𝑗 = temperature of surface j [°C] 

The radiation between grey surfaces, having an emissivity (as defined in the Colours window), is 
derived from the radiation between the black surfaces by adding supplementary resistances 
between the grey and black surface nodes. 

Radiation calculation parameters: 
− Linear radiation: the black radiation heat transfer coefficient is constant (and defined as a 

calculation parameter). 
− Non-linear radiation: the black radiation heat transfer coefficient is locally adjusted in function 

of the surface temperatures, before each new iteration cycle. 
− Black radiation heat transfer coefficient: parameter used for linear radiation or when no 

surface temperatures are available (i.e. for first iteration cycle in case of non-linear radiation). 
Normal value: 5.1 W/(m2.K) (for mean temperature = 10°C). 
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The view factors calculation between elementary surfaces is affected by the parameter 
Maximum number of view factor faces (per view factor zone): radiative surfaces are clustered 
into larger view factors if the number of surfaces in a view factor zone exceeds this parameter. 
 

Thermal values 
− Recalculation of thermal values: yes or no. 

If yes: the automatically calculated thermal properties in the Colours window (equivalent 

thermal conductivity and convective heat transfer coefficient, see D.1) are recalculated before 
each new iteration cycle. 

− Default temperature difference across airspace: parameter used in automatic calculation of 
thermal properties when no temperature solution and no default temperature difference 
according to the relevant standard are available (see D.1). 

D.2.2. Condensation 

(This requires the Interstitial Condensation module, see Chapter K). 
 

 
 

Iteration cycles 
The water vapour diffusion system is solved iteratively (see D.5 for more details). If the resulting 
water vapour pressures in the material nodes nowhere exceed the corresponding water vapour 
saturation pressures, no interstitial condensation occurs and the calculation is done. 
 
Otherwise, the water vapour diffusion system is recalculated with additional node boundary 
conditions with fixed water vapour saturation pressure (as a function of the node temperatures). 
The number and position of additional node boundary conditions is determined in an iterative 
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process, to obtain a continuous gradual moisture transport between neighbouring nodes. The 

number of additional node boundary conditions per cycle is defined by the parameter 
“percentage of condensation nodes kept per calculation cycle” (see further). If no additional 
condensation nodes are found in a cycle, the calculation is done. 
 

At the end of each iteration cycle the new solution is compared to the solution of the previous 
iteration cycle to check the convergence. 
 
Parameters: 
− Maximum number of iteration cycles: this is a limit on the total number of iteration cycles 

(needed when there is no convergence). 

− Maximum vapour pressure difference between iteration cycles: this is the maximum allowed 
vapour pressure difference in any node between the previous and the current iteration cycle 
solution. 

When the vapour pressure differences in all nodes are smaller, then the iteration cycles are 
stopped. 
 

Iterative solution per iteration cycle 
− Maximum number of iterations: this is a limit on the total number of iteration steps (needed 

when the other stopping criteria fail). 

− Maximum vapour pressure difference: this is the maximum allowed vapour pressure 
difference in any node between the previous and the current iteration step. 

− Maximum vapour flow divergence for total object: this is the maximum allowed relative 

moisture balance error for the total object (as union of all elementary control volumes). 
− Maximum vapour flow divergence for any node: this is the maximum allowed relative 

moisture balance error for the worst elementary control volume. 

 
The iteration stops when the last three conditions are satisfied. The first condition (maximum 
number of iterations) acts as an emergency break. 

 
Condensation calculation method (see D.5 and K.2 for more details) 
− Interstitial condensation only at material interfaces: when this option is enabled, nodes 

boundary conditions with fixed vapour pressure equal to the vapour saturation pressure (i.e. 
condensation nodes) can only be set at interfaces between different colours. 

− Number of condensation nodes kept per cycle: this parameter determines the percentage of 
nodes in which condensation was found in each calculation cycle that is carried over to the 

next cycle as node boundary conditions with fixed vapour pressure equal to the vapour 
saturation pressure. Lowering this parameter will increase the simulation time, but it must be 
low enough to avoid the physically impossible occurrence of evaporation nodes next to the 
node boundary conditions with fixed vapour saturation pressure. The default value is 10%. 

− Minimum drying period: the minimum calculation period used when the drying period of an 

initially wet node is smaller than the standard calculation period of 30 days for an interstitial 
condensation calculation. 

 
Vapour permeability of air 

The vapour permeability of a material (needed in the calculations, see D.5) is typically expressed 
as the vapour permeability of air divided by the vapour resistance factor of the material (μ, see 

B.9.8). 

D.3. Calculation of view factors 

Menu command: Calc → Calc View Factors 
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(This requires the RADCON module, see Chapter J) 
 

A monitor shows the progress of the calculation. 

 
 

Zones 
The view factor boundary condition blocks (of colour type BC_FREE, BC_SKY, BC_NOSKY, 
TRANSMAT) are classified in separate zones. Adjacent boundary condition blocks of different 

colours must have the same type and are combined in the same view factor zone. 
The same colour (of a view factor BC) is not allowed to occur in different zones (otherwise an 
error message appears when starting the calculation). 

In each zone the number of elementary surfaces (defined by the grid meshes in the Grid window) 
is determined. The number of view factors in that zone is proportional to the square of the 

number of faces. 
 

View factor formulas 
The geometric view factors between two (elementary) surfaces are calculated using analytic 

formulas. There are different formulas for a 2D and a 3D problem. 
 

2D problem 
A problem is considered to be two-dimensional when (at least) one coordinate direction of the 
input geometry consists of only 1 grid mesh. 
If the Z direction consists of 1 grid mesh, the relevant 2D section is XY; 
else if the Y direction consists of 1 grid mesh, the relevant 2D section is XZ; 

else if the X direction consists of 1 grid mesh, the relevant 2D section is YZ. 

In a 2D problem the third dimension is considered to be infinite (despite the finite dimension in the 

object description and representation in the Image window). All calculations are carried out in 2D 

(considering only the 2D section). 
 

Visibility 
The visibility between the surfaces (i.e. possible obstruction by other surfaces) is checked by 200 

test rays between random points on both surfaces. 
The calculated unobstructed view factors are reduced proportional to the number of obstructed 
test rays. 
Afterwards the view factors are rebalanced so that the geometric laws are satisfied: 

− ∑ 𝐹𝑖𝑗𝑖 = 1 

− 𝐴𝑖𝐹𝑖𝑗 = 𝐴𝑗𝐹𝑗𝑖 

The view factors are saved in a (text) file with the same name as the input data file, extension 
.vwf, and in the same file folder as the input data file. 
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View factor grid and system grid 

In general, the view factor grid may be less fine than the system grid without loss of accuracy. 
Very small grid meshes do not bring significantly better results when the surfaces are at a 
relatively large distance from one another, although the calculation time is much larger. 
 

Defining a maximum number of view factor per view factor zone clusters radiative surfaces (see 
D.2.1), resulting automatically in a view factor grid that is less refined than (but compatible with) 
the system grid. 
 
Alternatively, a grid can be chosen manually for the view factor calculation which is less refined 
than the grid for the system calculation (Calc → Calc System). It is however very important that 

the system grid is a refinement of the view factor grid, i.e. all grid coordinates of the view factor 
grid must also be present in the system grid. 
The required view factors in the system calculation (using the system grid) are interpolated from 

the view factors obtained from the view factor calculation (using the view factor grid). The view 
factors (from the view factor calculation) are read from the file with extension .vwf and with the 
same name as the input data file (used for the system calculation). This means that the same file 
name is used for both calculations: 
− First the view factor calculation with a rough grid (results stored in .vwf file). 
− Then grid refinement as required for the system calculation. 

(Of course this step is not obligatory, when the user accepts that view factor grid and system 
grid are equal.) 

− Finally the system calculation (using the fine grid and view factor interpolation). 

D.4. Thermal system calculation 

Menu command: Calc → Calc Thermal System 
 
For a standard version of TRISCO, the number of nodes is limited to 5 000 000. When the 
calculation of a model with a higher number of nodes is started, a warning appears and the 
calculation is not performed. The add-on feature ‘Unlimited Nodes’ removes this limitation on the 
number of nodes. 
 

 
 

A monitor shows the progress of the calculation. 
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Step 1: The input data is saved on disk (file extension .trc). 

When there are no boundary conditions that require the calculation of view factors (colour type 
BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) go to step 3. 
 
Step 2: View factor calculation 
If a view factor file (extension .vwf) exists with the same file name as the input data, a prompt 
message asks the user to recalculate the existing view factors. 

The view factor file may have been calculated using a different grid (D.3). The user may force to 

interpolate the system view factors from the data of the existing .vwf file, in which case answer 
“no” to the question “Recalculate view factors ?”. 

Otherwise (if the answer is “yes” or there is no .vwf file) the view factors are (re)calculated using 
the current system grid, and a (new) .vwf file is written. 

 

Step 3: Break down non-linear problems 

A non-linear problem (e.g. radiation or due to temperature dependent properties) is solved by 
splitting the problem in a sequence of linear problems. 
Each linear problem is called an iteration cycle. 

At the start of each iteration cycle the automatically calculated thermal properties are updated 

based on the calculation results of the previous iteration cycle (see D.1). 
The number of required iteration cycles is controlled by calculation parameters (see D.2). 
 

Step 4: Define equations of linear system (per iteration cycle) 
The equations express an energy balance for the control volume around each system node. 
All heat flows in the energy balance are expressed as linear functions of neighbouring node 
temperatures. 
The extent of the control volume within the object is half the grid mesh in each of the three 
coordinate directions. 
The equations for radiation and convection are explained in the chapter on RADCON (see 

Chapter J). 
The required view factors are interpolated from the values in the view factor file. 

For a 2D problem all heat flows and corresponding equations are expressed in 2D (see D.3). 
 

Step 5: Solve the linear system 
A fast and stable iterative method is used. 
The iteration process is controlled by calculation parameters (see D.2). 
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Interrupt calculation 

The calculations can be stopped at any time by pressing the <Esc> key. The obtained 
temperatures at that moment are saved in a .sol file. When restarting the calculation, the saved 
intermediate solution is loaded from the .sol file and the iteration continues. 
 

Step 6: Save solution 
When the calculation is finished, the calculated node temperatures are saved in a file with 
extension .sol (same name as data file). The heat flux values in the surface nodes bordering 
boundary conditions of type BC_FREE, BC_SKY, BC_NOSKY are saved in a file with extension .flx. 
Both files are saved in the same folder of the input data file (extension .trc). 
 

Temperatures out of range 

Sometimes it is possible that some calculated node temperatures lay outside the range of 
boundary condition temperatures. This is not a calculation error, but a “feature” of the solution 
technique used: the energy balances are not applied for the isolated system nodes, but for the 
surfaces of a finite control volume around the nodes. Due to this discretisation such small 
overflows in calculated node temperatures may occur. The overflow is made smaller by refining 
the grid. 

D.5. Interstitial condensation calculation 

Menu command: Calc → Calc Interstitial Condensation 
 

Colours of type BC_FRE_S and BC_FREE are not allowed in the system. 

 
Calculation span 
If a boundary condition (of type BC_SIMPL, BC_SKY or BC_NOSKY) is present with standard 

EN13788 and subtype CLIM_I or CLIM_E, the user is prompted to choose the starting month and 
set the number of successive months to be calculated. 

 
 

The data in the Monthly Mean Climate Data window are used for the definition of (air) 

temperature and relative humidity. For each month the external and internal (air) temperatures 
and relative humidities are copied to the boundary conditions of subtype CLIM_E and CLIM_I in 

the Colours window, and the additional interstitial condensation or evaporation is calculated. 
January, March, May, July, August, October, and December have 31 days. February has 28 days. 
April, June, September, and November have 30 days. 
 

If no boundary conditions with standard EN13788 and subtype CLIM_I or CLIM_E are present, the 
calculation is done for a single calculation period of 1 month (30 days). 
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For each month in the calculation span, the following steps are taken: 

 
Step 1: Determination of vapour saturation pressure 
The thermal system is first solved to determine the water vapour saturation pressure in each 
material node (see K.2). 

 
Step 2: Solve the vapour diffusion system (cycle 1) 
The equations express a moisture balance for the control volume around each system node. 
All moisture transfer is assumed to be pure water vapour diffusion. All vapour flows in the 
moisture balance are expressed as linear functions of neighbouring node vapour pressures (see 
K.2). 

The extent of the control volume within the object is half the grid mesh in each of the three 
coordinate directions. 
The water vapour diffusion system (EN ISO 13788, paragraph 6 and K.2) is set up with the water 

vapour resistance factors (μ in Colours window) of the material colours (type MATERIAL, 

EQUIMAT and TRANSMAT), the water vapour permeability of air with respect to partial vapour 

pressure (δ0, see D.2.2) and relative humidity (RH in Colours window) of the boundary condition 

colours (type BC_SIMPL, BC_SKY and BC_NOSKY). 
This system is solved using a fast and stable iterative method. The iteration process is controlled 
by the calculation parameters (see D.2.2).  
If the resulted water vapour pressures in the material nodes nowhere exceed the corresponding 
water vapour saturation pressures, no interstitial condensation occurs and the calculation is done, 

otherwise, go to step 3. 

 

Step 3: Adding node boundary conditions (next cycles) 
The water vapour diffusion system is recalculated (next cycle) with additional node boundary 
conditions with fixed water vapour saturation pressure (as a function of the node temperatures). 

These node boundary conditions can possibly cause forced evaporation in neighbouring free 
nodes, which is not realistic in a natural balanced system. Therefore, the number and position of 
additional node boundary conditions is determined in an iterative process, to obtain a continuous 

gradual moisture transport between neighbouring nodes. The number of additional node 
boundary conditions is a calculation parameter (see D.2.2). This parameter should be chosen as 

small as possible (e.g. 1, 5, 10, 50 or 100 %), despite the necessary additional calculation cycles. 

The fixed condensation nodes are selected according to greatest difference between calculated 
water vapour pressure and corresponding water vapour saturation pressure. 

The user can request that the fixed condensation nodes can only be set at material colour 
interfaces (see D.2.2). 
 

Step 4: Save solution 
At the end of the interstitial condensation calculation for each month (or shorter calculation 

period, see below) the steady-state water vapour flow rate (positive for condensation, negative 
for evaporation) and accumulated moisture content per material node are saved in the .sol 
solution data file. Each .sol solution data file replaces the previous, so when the entire calculation 
is done the solution data file contains the water vapour flow rate and accumulated moisture 
content per material node of the last calculation cycle of the last calculation period. 
 

Drying of wet nodes 

A node can initially be wet due to the definition of initial moisture content (in the Initial Moisture 

window, B.17), or else due to accumulated moisture from the previous month, if multiple months 
are calculated. 
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Wet nodes imply that in those nodes the water vapour saturation pressure as a function of 

temperature is imposed. For each wet node the required drying time is calculated based on the 
evaporation rate derived from the water vapour diffusion system solution (see K.2). 
If this drying time is shorter than the month’s duration, then the shortest drying time of any wet 
node, rounded up to an integer number of hours and at least equal to the minimum drying time 

calculation parameter (see D.2.2), is taken as current calculation period. After this time that wet 
node (and maybe other wet nodes) is dry, and the assumed water vapour saturation pressure is 
no longer valid for the desiccated nodes. 
For the remaining hours of the initial calculation period (number of days in the month) a new 
water vapour diffusion calculation cycle is executed. This new cycle starts with the accumulated 
moisture at the end of the previous calculation cycle. This recursive process of calculation cycles 

continues until the number of days of the original calculation period is reached. 

D.6. Divergences 

The quality of the solution is mainly determined by the divergence of the total object, called in 
short object divergence (displayed in the calculation monitor). 
 
For the thermal calculation, the object divergence is defined as the sum of all elementary heat 
flows entering the object (outgoing heat flows have a negative sign), divided by half the sum of 
the absolute values of all heat flows: 

𝑂𝐷 =
|𝛷𝑖𝑛,𝑜 − 𝛷𝑜𝑢𝑡,𝑜|

0.5 ⋅ (|𝛷𝑖𝑛,𝑜| + |𝛷𝑜𝑢𝑡,𝑜|)
⋅ 100 

with 𝑂𝐷 = object divergence [%] 
 𝛷𝑖𝑛,𝑜 = total incoming heat flow for the object [W] 

 𝛷𝑜𝑢𝑡,𝑜= total outgoing heat flow for the object [W] 
 

By using the factor 0.5 in the denominator, the denominator can be interpreted as the heat flow 
"passing" the object. 
The maximum possible object divergence is 200 %, i.e. when there are only incoming heat flows 

and no outgoing heat flows: 𝛷𝑖𝑛,𝑜 > 0 and 𝛷𝑜𝑢𝑡,𝑜 = 0 (or vice versa 𝛷𝑖𝑛,𝑜= 0 and 𝛷𝑜𝑢𝑡,𝑜 > 0). 

An object divergence tolerance of 0.001 % is recommended as reliable stopping criterion. 
According to ISO 10211 the object divergence should be less than 0.01 %. 
 

Also a second heat flow divergence is used as stopping criterion: the maximum heat flow 
divergence for all nodes, called in short node divergence (also displayed in the calculation 
monitor). It is defined in a similar way as the object divergence: 

𝑁𝐷 = 𝑚𝑎𝑥𝑛(
|𝛷𝑖𝑛,𝑛 − 𝛷𝑜𝑢𝑡,𝑛|

0.5 ⋅ (|𝛷𝑖𝑛,𝑛| + |𝛷𝑜𝑢𝑡,𝑛|)
⋅ 100) 

with 𝑁𝐷 = node divergence [%] 
 𝛷𝑖𝑛,𝑛 = total incoming heat flow for the control volume around node n [W] 

 𝛷𝑜𝑢𝑡,𝑛= total outgoing heat flow for the control volume around node n [W] 

 
The default node divergence tolerance is 1 %. 

Sometimes it happens that the node divergence does not decrease during the calculation. This is 
caused by an “unlucky” node, that is connected to its neighbouring nodes in an “unfavourable” 
way (due to strongly different mesh widths and/or strongly different thermal conductivities). Then 
a node divergence tolerance of 200 % (or a slightly higher value, due to possible rounding errors) 

may be necessary to suppress the node divergence stopping criterion. 
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For the interstitial condensation calculation (requires Interstitial Condensation module, see 

Chapter K), the definition of the object and node divergence is entirely analogous, but with 
vapour flow instead of heat flow. 

D.7. Batch calculation 

Menu command: File → Batch Calculation… 
 

The user can launch a batch calculation for several data files (with extension .trc) in the same 
folder. The calculations are executed one after the other without any intervention of the user. 
To start a batch calculation use the command File → Batch Calculation…, select the data files in 
the Batch Calculation dialog box (hold down the <Ctrl> key to select more than one file) and 
press the Start button. It is not possible to select several .trc files located in different directories. 
The batch calculation is limited to thermal calculations, interstitial condensation calculations are 
not possible in batch. 
 
At the end of the calculation for each data file the calculation results are written in a text file 
(FileName_RES.txt, with FileName the name of the data file; cf. section G.3). 

D.8. Command line program execution 

TRISCO can be run from the command line prompt with a data file path (including directory and 
file extension .trc) as parameter. 

The additional switch “/Automation” is required to activate the batch calculation function. 
Then this data file is solved without further user action, as in a batch calculation (cf. section D.7). 

 
Example of command line launch: 
Run → “c:\…\Physibel\TRISCO16\TRISCO16.exe” “…\Documents\Physibel\TRISCO16\Demofiles\1 - 

BUILDING COMPONENTS\concrete_floor.trc” /Automation 

D.9. Derived thermal properties 

Menu command: Edit → Derived Thermal Properties… 

 

 
 

Set a check mark for the wanted properties. 

The properties are listed in the Text Output window (see Chapter F). The output requires that the 

calculation solution is available. 
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The properties can only be evaluated if two boundary conditions with different temperatures 

apply: an external temperature and an internal temperature. 

D.9.1. Temperature factor 

The temperature factor is a dimensionless expression of the minimum internal surface 
temperature, in order to assess the risk of surface condensation. 
 

The evaluation formula (cf. standards ISO 10211 and EN ISO 13788) is: 

𝑓 =
𝜃𝑠𝑖,𝑚𝑖𝑛

𝜃𝑖 − 𝜃𝑒
 

𝑓 = temperature factor [-] 

𝜃𝑖 = internal boundary condition temperature [°C] 
𝜃𝑒 = external boundary condition temperature [°C] 
𝜃𝑠𝑖,𝑚𝑖𝑛 = minimum internal surface temperature [°C] 

 

The output also reports: 
− The internal heat transfer coefficient ℎ𝑖 [W/(m2.K)] and internal surface resistance 𝑅𝑠𝑖  [m2.K/W] 

where 𝜃𝑠𝑖,𝑚𝑖𝑛 applies. 

− The relative humidity above which surface condensation occurs for the air at the internal 
boundary condition temperature. 

D.9.2. 2D/3D surplus thermal transmittance / Linear thermal transmittance 

The 2D/3D surplus thermal transmittance is a correction term for the 2D and 3D effects of a 

thermal bridge compared to the area weighted 1D thermal transmittances of the flanking 
elements. For a 2D problem the definition corresponds to the linear thermal transmittance. 
 
The applied formula (cf. norm ISO 10211) is: 

𝛥𝐿 =
𝛷

𝜃𝑖 − 𝜃𝑒
− 𝑈1 ∗ 𝐴1 − 𝑈2 ∗ 𝐴2 − 𝑈3 ∗ 𝐴3 

𝛥𝐿  = 2D/3D surplus thermal transmittance [W/K] 
𝛷  = total heat flow through object [W] 
𝜃𝑖 = internal boundary condition temperature [°C] 
𝜃𝑒 = external boundary condition temperature [°C] 

𝑈1, 𝑈2, 𝑈3 = 1D thermal transmittances of flanking elements [W/(m².K)] 

𝐴1, 𝐴2, 𝐴3 = areas of flanking elements [m²] 
 

The areas and U values of the flanking elements must be defined in the Areas window (see B.14) 

and U Values window (see B.15). 

 
In case of a 2D problem the linear thermal transmittance or psi-value 𝛹 [W/(m.K)] is obtained by 

dividing 𝛥𝐿 by the single mesh width of the third dimension. 

D.9.3. Equivalent thermal transmittance 

The equivalent thermal transmittance is the U value of an 1D element, that is thermally equivalent 
to the calculated object, with the same heat flow going through that element for a user defined 
reference wall area. 

𝑈𝑒𝑞 =
𝛷

(𝜃𝑖 − 𝜃𝑒) ∗ (𝐴1 + 𝐴2 + 𝐴3)
 

𝑈𝑒𝑞 = equivalent thermal transmittance [W/(m2.K)] 

𝛷 = total heat flow through object [W] 
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𝜃𝑖 = internal boundary condition temperature [°C] 

𝜃𝑒 = external boundary condition temperature [°C] 

𝐴1, 𝐴2, 𝐴3 = areas of flanking elements [m2] 

The areas of the flanking elements must be defined in the Areas window (see B.14). 

D.9.4. Thermal transmittance of element 

𝑈𝑒𝑙𝑒𝑚 =

𝛷
𝜃𝑖 − 𝜃𝑒

− 𝑈2 ∗ 𝐴2 − 𝑈3 ∗ 𝐴3

𝐴1
 

𝑈𝑒𝑙𝑒𝑚 = thermal transmittance of element [W/(m2.K)] 

(the name “𝑈𝑒𝑙𝑒𝑚”, as it appears in the output, e.g. “Ufloor”, “Uwall” or another name, is defined in 

the Derived Thermal Properties dialog box) 
𝛷 = total heat flow through object [W] 

𝜃𝑖 = internal boundary condition temperature [°C] 
𝜃𝑒 = external boundary condition temperature [°C] 

𝑈2, 𝑈3 = 1D thermal transmittances of flanking elements [W/(m2.K)] 

𝐴1, 𝐴2, 𝐴3 = areas of current element and of flanking elements [m2] 

The areas and U values of the flanking elements must be defined in the Areas window (see B.14) 

and U Values window (see B.15). 
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CHAPTER E GRAPHIC OUTPUT 

E.1. Graphic Output window 

Menu command: Output → Graphic Output 
A new full-screen window with its own menu, toolbar and status bar are displayed. 
To return to the main TRISCO window, choose File → Exit or press the <Esc> key. 
 

 
 

No viewpoint depending object shading is used in the Graphics Output window as is done in the 

Image window. All colours are flat and are explained in the legend bar at the right. 

Object depth is suggested with contour lines. 
The status bar shows (dependent on the view option) the material colour, boundary condition 

colour, temperature or heat flux under the mouse cursor. 

E.2. File commands 

File submenu 

 
 

Menu command: File → Save As… 

Save the graphic output as a PNG file, for which the image size and font size of legend text are 

defined via the image size settings (see E.7). 
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E.3. Projections and clip object 

Projection submenu 

 

Clip submenu 

 

 

− Projection → Perspective: same 3D perspective view as in Image window (see C.4). 

− Projection → Section …: section view through object along grid coordinate. 

The clip object boundaries as defined in either the Clip Object window from the main window (cf. 

section C.9) or the Clip Object dialog box (Clip → Clip Object… from the Graphics Output window) 

are used as section definitions. 
The view directions for the sections through the minimum and maximum clip coordinates are 
facing each other (i.e. viewing towards the clipped object). 
 

 
 

By editing the clip coordinates, cross sections through all grid planes are possible. 
If a clipping plane does not intersect the object, then the corresponding section view is empty. 
Individual colours can also be clipped from the object (Clip → Clip Colour), similarly as in the 

main window (C.10). 
Reset all clip coordinates using Clip → Clip Off. 

E.4. Zoom commands 

Zoom submenu 

 
 

The zoom commands are identical to those of the Image window in the main menu (see C.3). 
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However a mouse drag movement in rotate or pan mode works not dynamically as in the Image 

window (because the Graphic Output window does not make use of OpenGL hardware 
acceleration). A rubber-band vector is drawn, and after releasing the left mouse button the new 
view is painted. 
Zooming in and out is also possible via scrolling forward and backward of the mouse wheel. 

E.5. View options 

View submenu (for 3D problem) 

 

View submenu (for 2D problem) 

 
 

A check mark in front of a command shows that the option is enabled. 
Any change in the view options is immediately reflected in the image. 

  
The first 4 options can be switched on or off independently: 
− View → Object Lines: show object contour lines. 

− View → Grid Lines: show grid lines on object surfaces. 
− View → Isothermal Lines: show isothermal lines conform to the temperature range parameters 

(cf. section E.6). 
Only possible when a calculation solution is available. 
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− View → Isoflux Lines (only for a 3D problem): show isoflux lines conform to the flux range 

parameters (see E.6). 
Only possible when a calculation solution is available. 

− View → Heat Flow Lines (only for a 2D problem): show heat flow lines conform to the heat flow 
parameters (see E.6). 

Only possible when a calculation solution is available. 
 
One of the following fill modes is to be selected: 
 
− View → Fill Materials: fill material surfaces using the object block colours (as defined in the 

Colours window). 

The status bar shows the colour number and name of the material surface under the mouse 
cursor point. 

− View → Fill BCs: fill material surfaces using the adjacent surface boundary condition block 

colours (as defined in the Colours window). 

If no surface boundary condition is active on a material surface (i.e. an implicit adiabatic 
boundary condition is assumed), then the fill colour is light yellow. 
The status bar shows the colour number and name of the boundary condition imposed on the 
material surface under the mouse cursor point. 

− View → Fill Temperatures: fill material surfaces using temperature colours conform to the 
temperature range parameters (see E.6) and of the selected thermal palette (see A.8 and E.7). 
The status bar shows the temperature of the material surface under the mouse cursor point. 

Only possible when a calculation solution is available. 

− View → Fill Isofluxes (only for a 3D problem): fill material surfaces using isoflux colours conform 
to the flux range parameters (see E.6). 
Only possible when a calculation solution is available. 

− View → Fill Heat Flows (only for a 2D problem): fill material surfaces showing heat flow 
channels conform to the heat flow parameters (see E.6). Only possible when a calculation 
solution is available. 

− View → Relative Humidity (This requires the Interstitial Condensation module, see Chapter K): 
fill material surfaces using colours conform the relative humidity range parameters (see E.6) 
of the selected thermal palette (see A.8 and E.7). 

The status bar shows the relative humidity (RH) of the material surface under the mouse 
cursor point. 

Only possible when a calculation solution is available. 

− View → Fill Interstitial Condensation Rate (This requires the Interstitial Condensation module, 
see Chapter K): fill material surfaces where condensation (in blue) or evaporation (in red) 

occurs in the last condensation calculation cycle (see D.5). The colour intensity indicates the 
condensation/evaporation rate magnitude, the legend is relative and scaled from -100 
(maximum evaporation occurring) to +100 (maximum condensation occurring). 
The status bar shows: 
o the volumetric condensation rate (or evaporation rate when negative) for the last 

condensation calculation cycle, of the node volume under the mouse cursor point; 

o the total condensation amount for the last condensation calculation cycle, of the zone of 

condensation node volumes connected to the node volume under the mouse cursor point; 

o the total evaporation amount for the last condensation calculation cycle, of the zone of 

evaporation node volumes connected to the node volume under the mouse cursor point. 

Only possible when a calculation solution is available. 
− View Fill Accumulated Interstitial Condensation (This requires the Interstitial Condensation 

module, see Chapter K): fill material surfaces where accumulated moisture (in blue) is found 
after the last condensation calculation cycle (see D.5). The colour intensity indicates the 
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accumulated moisture quantity, the legend is relative and scaled from 0 (no moisture) to 100 

(maximum amount of moisture occurring). 
The status bar shows: 
o the volumetric accumulated moisture after the last condensation calculation cycle, of the 

node volume under mouse cursor point; 

o the total accumulated moisture after the last condensation calculation cycle, of the zone 

of wet node volumes connected to the node volume under the mouse cursor point. 

Only possible when a calculation solution is available. 

− View → Fill Areas: show areas (as defined in Areas window) and lines along which U values 

are determined (as defined in U Values window). Each couple of corresponding area and U 

value (as in the formulas of derived thermal transmittances) has a different colour (red, green 

or blue). 

 

 
− View → Fill Off: switch off filling. 
 

The legend can be shown or hidden with: 
− View → Legend 
 

Isofluxes (only possible for a 3D problem) 

The view options View → Isoflux Lines and View → Fill Isofluxes allow to visualise the local heat 
flux vector components (in W/m2) perpendicular to the object surface. 

It is possible to show isofluxes not only at surface boundary conditions, but also within material 
sections. 
Local U values can be represented on wall components between two surface boundary 
conditions when the imposed temperature difference between the boundary conditions equals 
1°C. The flux unit should then be read as W/(m2.K). 
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Heat flow lines (only possible for a 2D object) 

Heat flow lines show the directions of the local heat flux vectors. 
The density of the heat flow lines is proportional to the local heat flow magnitude. 
The isotherms and heat flow lines form orthogonal fields. 
 

 
 

The number of heat flow lines through a given line multiplied by the heat flow increment equals 
the total heat flow through that line. 
In the filled heat flow lines figure each colour strip corresponds to a heat flow equal to the heat 
flow increment. 

Every first heat flow increment there is a minor colour change. 
Every second heat flow increment there is a major colour change. 
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In the grid cells around heat sources (node BCs, borderface BCs, material BCs) no heat flow lines 
are represented. 
When heat sources are present, discontinuities in the heat flow lines can occur. A good choice of 
the heat flow increment (i.e. an integer divisor of the heat source power) may eliminate the 

discontinuities. 
The quality of the heat flow lines is very sensitive to the achieved object divergence. A smaller 
value improves the quality. 

E.6. Temperature profile along a grid line 

For any user defined grid line a temperature graph through the intersected material layers can 
be drawn. 
First the desired grid line must be defined using the command View → Temperature Profile Line 

Definition… 
 

 
 

In the dialog box choose the grid line direction: 
− X, Y or Z (in the XYZ coordinate system), or 

− R, C or L (in the RCL coordinate system). 
Then define the grid coordinates of the starting node (“from”) and ending node (“to”) of the line. 
 

The toggle command View → Temperature Profile shows the temperature graph. 
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The horizontal axis shows the grid coordinates along the chosen grid direction. 
The vertical axis shows the temperature scale (conform to the settings in E.7). 
The blue function line corresponds to the temperature solution at the current time step. 

All other view commands are disabled until the temperature profile is cancelled by pressing the 
toggle command View → Temperature Profile again. 

E.7. Settings 

Settings submenu 

  
 

Settings → Temperature Range… 

The parameters in this dialog box are synchronised with those in the Image window (see C.5). 
− The option “Use boundary condition temperatures” initialises the minimum and maximum 

temperatures from the boundary condition temperatures of types BC_SIMPL present in the 

Colours window. 
− Minimum temperature [°C] in graphic output. 
− Maximum temperature [°C] in graphic output. 
− First (or minor) increment [°C]. 



72 Manual TRISCO v16.0 

− Second (or major) increment [°C] (must be a multiple of first increment). 

The second increment is only used with isothermal lines. 
− Single temperature value [°C] (e.g. dew point). 
 

 
 

Settings → Heat Flux Range… 

Only enabled for a 3D problem. 
The second increment (which must be a multiple of the first increment) is only used with isoflux 

lines (see E.5). 
The maximum flux in the current view of the results is shown for information. 
 

 
 

Settings → Heat Flow Increments… 

Only enabled for a 2D problem. 
The used unit is W and not W/m, because the object always is 3D. 
 

 
 

Settings → Relative Humidity Range… 

(requires Interstitial Condensation module, see Chapter K). 
− Minimum relative humidity (RH) [%] in graphic output. 

− Maximum relative humidity (RH) [%]  in graphic output. 
− Increment [%]. 
 
The user can opt to only show the material surfaces where surface condensation occurs. 
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Settings → Line Styles… 

 

 
 

A colour field can be edited by double clicking on it with the left mouse button, which opens a 
Colour dialog box in which the colour can be defined. 
The width of isothermal lines, isoflux lines and heat flow lines can be set to 0 pixels to hide them. 

This is useful when e.g. only the second isothermal lines are desired. 
 

Settings → Fill Colours… 

 

 
 

Colours with automatically calculated properties (see D.1) are clustered thematically in the 

Graphic Output window according to the categories of the Fill Colours dialog box, to avoid a 

potentially long list of colours of the same type (and subtype and standard) with small variations 
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in the calculated thermal property. The fill colour of the clusters can be edited by double clicking 

on it with the left mouse button, which opens a Colour dialog box in which the colour can be 
defined. 
 

Settings → Thermal palette… 
 

 
 

The selection of the thermal palette is synchronised with that selected in the main window (see 

A.8). 
 

Settings → Image Size… 

Set image size for saving (see E.2) or creating graphic report files (see Chapter G). 
 

  
 

− The font size for text must be chosen in proportion to the image size. 
− The file format is always PNG. 
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CHAPTER F TEXT OUTPUT 

F.1. Text Output window 

Menu command: Settings → Text Output 
A new full-screen window with its own menu and toolbar are displayed. 
To return to the main TRISCO window, choose File → Exit or press the <Esc> key. 
 

 
 

The text within the Text Output window can be edited. 

F.2. File commands 

File submenu 

 
 

− File → Save As… 

Save the whole text in the current Text Output window into a Microsoft Word document 

(extension .doc) on disk. 

− File → Save to CSV Files 

Save the text output to CSV files for use in a spreadsheet program (e.g. Microsoft Excel). 

− File → Exit 
Return to main TRISCO window. 

F.3. Edit command 

Edit submenu 
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Edit → Copy 

Copy the selected text (selected using the mouse or the arrow keys with the <Shift> key held 
down) into the clipboard (so that it can be pasted in an external text editor). 

F.4. View options 

View submenu 

 

F.4.1. Input data 

Menu command: View → Input Data 

 

Output 
− Document notes (see B.19) 

− TRISCO data file name 
− Grid data: grid unit; grid mesh widths along X,Y,Z or R,C,L 
− Blocks: block colour, block coordinates (grid numbers & absolute coordinates) 
− Colours: all present colours with colour type and thermal properties 
− Node BCs 
− Borderface BCs 
− Monthly mean climatic data 
− Initial moisture at interfaces 
− Calculation parameters 
 

Example 
 

TRISCO - Input Data 

 

Pilot example of the TRISCO manual 

Three-dimensional corner of a room 

 

TRISCO data file: Pilotex.trc 

 

GRID 

No.            X         Y         Z   _ 

Sum          140.000   140.000   130.000 

0-1           10.000    10.000    50.000 

1-2            2.500     2.500    20.000 

2-3            2.500     2.500    10.000 

3-4            2.500     2.500     5.000 

4-5            2.500     2.500     5.000 

5-6            2.500     2.500     5.000 

6-7            2.500     2.500     2.500 

7-8            2.500     2.500     2.500 

8-9            2.500     2.500     2.500 

9-10           2.500     2.500     2.500 

10-11          2.500     2.500     2.500 

11-12          2.500     2.500     2.500 

12-13          2.500     2.500     2.500 

13-14          2.500     2.500     2.500 

14-15          2.500     2.500     2.500 

15-16          5.000     5.000     2.500 

16-17          5.000     5.000    10.000 

17-18          5.000     5.000 
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18-19         10.000     5.000 

19-20         20.000     5.000 

20-21         50.000     5.000 

21-22                    5.000 

22-23                   10.000 

23-24                   20.000 

24-25                   30.000 

 

BLOCKS 

No.   Col.    Xmin  Xmax  Ymin  Ymax  Zmin  Zmax 

1       2        0    21     0    25     0    17 

2       4        1    21     1    25     0     8 

3       5        5    21     5    25     0     8 

4       6        7    21     7    25     0     8 

5       3       13    21    13    25     0     8 

6       7        7    13     7    20     0     8 

7       7        1    21     1    25     8    14 

8       9        1    21     1    25    14    16 

 

No.   Col.        Xmin      Ymax      Zmin      Xmax      Ymin      Zmax 

1       2        0.000   140.000     0.000   140.000     0.000   130.000 

2       4       10.000   140.000    10.000   140.000     0.000   100.000 

3       5       20.000   140.000    20.000   140.000     0.000   100.000 

4       6       25.000   140.000    25.000   140.000     0.000   100.000 

5       3       40.000   140.000    40.000   140.000     0.000   100.000 

6       7       25.000    40.000    25.000    70.000     0.000   100.000 

7       7       10.000   140.000    10.000   140.000   100.000   115.000 

8       9       10.000   140.000    10.000   140.000   115.000   120.000 

 

COLOURS 

Col. Type      Subtype   Phys.     Geom.     Name                       eps1 / eps2 

                         flow      flow                                 [- / -]     

2    BC_SIMPL  NIHIL                         exterior                               

3    BC_SIMPL  NIHIL                         interior                               

4    MATERIAL                                outer_leaf_cavity_wall                 

5    MATERIAL                                wall_insulation                        

6    MATERIAL                                inner_leaf_cavity_wall                 

7    MATERIAL                                concrete                               

9    MATERIAL                                roof_insulation                        

 

Col.  lambda   eps     t       h         q     ta      hc        Pc     tr  Standard 

      [W/mK]   [-]  [°C] [W/m²K]    [W/m²]   [°C] [W/m²K]     [W/m]   [°C]           

2                    0.0   25.00         0                                  NIHIL    

3                   20.0    5.00         0                                  NIHIL    

4     1.000                                                                          

5     0.035                                                                          

6     0.700                                                                          

7     2.500                                                                          

9     0.030   
 

THERMAL CALCULATION PARAMETERS 

Iteration cycles = 5 

Maximum number of iterations (within each iteration cycle) = 10000 

Maximum temperature difference (within each iteration cycle) = 0.0001°C 

Maximum temperature difference (between iteration cycles) = 0.001°C 

Maximum heat flow divergence for total object = 0.001 % 

Maximum heat flow divergence for any node = 1 % 

Automatic recalculation of thermal values 

Default temperature difference across airspace = 5°C 

F.4.2. Thermal calculation results 

Menu command: View → Thermal Calculation Results 

 

Output 

− TRISCO data file name 
− Number of nodes 
− Iteration quality numbers for last executed iteration cycle: 

heat flow divergence for total object and for worst node 
− Temperature factor (see D.9.1) 

− 2D/3D surplus thermal transmittance + equivalent thermal transmittance 
(see D.9.2 and D.9.3) 

− Thermal transmittance of element (see D.9.4) 



78 Manual TRISCO v16.0 

− List of minimum and maximum temperatures per colour (and corresponding X,Y,Z or R,C,L 

coordinates) 
− List of total heat flows (in and out of object) per surface boundary condition 

+ calculated air temperature (for BC_FRE_S and BC_FREE) 
 

Remark on listed heat flows 
The incoming and outgoing heat flows per surface boundary condition colour, as listed in the 
calculation results, are equal to the sums of elementary incoming and outgoing heat flows for all 
control volumes around the system nodes touching that surface boundary condition colour. This is 
done this way because the system solution is also based on energy balances containing these 
heat flows through the control volumes. 

Sometimes some system nodes belong to more than one surface boundary condition colour. This 

happens whenever two surface boundary condition colours touch each other. TRISCO requires 
that those surface boundary condition colours must have the same type (both being BC_SIMPL, 

BC_FRE_S, BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT), otherwise an error message appears 
when starting the calculation. 
In that case the control volume of such a system node is attributed to any arbitrary bordering 
surface boundary condition colour (as determined by the sequence taken by the computer 
algorithm). 
This implies that some total heat flows per surface boundary condition colour can be 

underestimated or overestimated. Note however that the sums of the incoming and outgoing 

heat flows of all adjacent surface boundary condition colours are always correct. The 
underestimation or overestimation error can be decreased by applying smaller grid mesh widths 

at both sides of the contact nodes of the bordering surface boundary condition colours. 
 

Example 
 

TRISCO – Thermal Calculation Results 

 

TRISCO data file: Pilotex.trc 

 

Number of nodes = 8157 

Heat flow divergence for total object = 0.000344464 % 

Heat flow divergence for worst node = 0.00788821 % 

 

Temperature factor (EN ISO 10211) = 0.452 

  hi = 5.00 W/(m².K) 

  Rsi = 0.20 m².K/W 

Surface condensation if RH > 49 % (at 20.0000°C) 

 

2D/3D surplus thermal transmittance 

dL = Q/(ti-te) - U1*A1 - U2*A2 - U3*A3 = 1.404 W/K 

Equivalent thermal transmittance 

Ueq = Q/((ti-te)*(A1+A2+A3)) = 0.974 W/(m².K) 

  Q = 58.427 W 

  ti = 20.0000°C 

  te = 0.0000°C 

  U1 = 0.504 W/(m².K) 

       Xmin=1 Xmax=13 Ymin=25 Ymax=25 Zmin=0 Zmax=0 

  A1 = 1 m² 

       Xmin=13 Xmax=13 Ymin=13 Ymax=25 Zmin=0 Zmax=8 

  U2 = 0.504 W/(m².K) 

       Xmin=21 Xmax=21 Ymin=1 Ymax=13 Zmin=0 Zmax=0 

  A2 = 1 m² 

       Xmin=13 Xmax=21 Ymin=13 Ymax=13 Zmin=0 Zmax=8 

  U3 = 0.508 W/(m².K) 

       Xmin=21 Xmax=21 Ymin=25 Ymax=25 Zmin=8 Zmax=16 

  A3 = 1 m² 

       Xmin=13 Xmax=21 Ymin=13 Ymax=25 Zmin=8 Zmax=8 

 

Col. Type      Name                           tmin    X    Y    Z      tmax    X    Y    Z 

                                              [°C]                     [°C]              _ 

2    BC_SIMPL  exterior                    -0.2072   21    1   15    2.4601   21    1   12 

3    BC_SIMPL  interior                     9.0481   13   13    8   17.9903   21   13    0 

4    MATERIAL  outer_leaf_cavity_wall       0.0395    1    1    2    4.8907    5   25    8 

5    MATERIAL  wall_insulation              0.4888    5    5    2   15.9051    7   19    0 
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6    MATERIAL  inner_leaf_cavity_wall       5.6551   14    7    8   17.9903   21   13    0 

7    MATERIAL  concrete                     0.3067    1    1    8   17.5196   21   25    8 

9    MATERIAL  roof_insulation             -0.2072   21    1   15   16.8214   21   25   14 

 

Col. Type      Name                             ta   Flow in  Flow out 

                                              [°C]       [W]       [W] 

2    BC_SIMPL  exterior                               0.2699   58.6972 

3    BC_SIMPL  interior                              58.4275    0.0000 

F.4.3. Temperatures in corner nodes 

Menu command: View → Corner Nodes 

 

Output 

Per object corner: X,Y,Z or R,C,L grid coordinates + calculated temperature 

 
View all node temperatures 
See SOL file, lines starting with letter N: node temperature + X,Y,Z grid coordinates 
 
Example 

 

TRISCO - Temperatures in corner nodes 

 

TRISCO data file: Pilotex.trc 

 

     X     Y     Z         t 

                        [°C] 

     1     1     0      0.05 

     1     1    16      0.01 

     1    25     0      0.40 

     1    25    16      0.02 

    13    13     0     15.92 

    13    13     8      9.05 

    13    25     0     17.98 

    13    25     8     12.01 

    21     1     0      0.40 

    21     1    16      0.02 

    21    13     0     17.99 

    21    13     8     12.00 

    21    25     8     17.52 

    21    25    16      0.40 

F.4.4. Temperatures of node BCs 

Menu command: View → Node BCs 

 

Output 
Per node BCs of type POWER: node temperature 
 

Hint 
To get the temperature in a specific grid point, add a dummy node BC with fixed power = 0 W. 

F.4.5. View factors 

Menu command: View → View factors 
 

Output 
− View factors file (extension .vwf) 
− Per pair of surface colours (adjacent to boundary condition of type BC_FREE, BC_SKY, 

BC_NOSKY, TRANSMAT): area of 1st surface (the radiation sender) + 
global view factor from 1st surface colour to 2nd surface colour 

 

Example 
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TRISCO - View Factors 

 

View factor file: Examp_radcon2.vwf 

 

From     To      Sender     View 

col.    col.       [m²]     factor 

  7       7        17.1     0.0937 

  7       9        17.1     0.1663 

  7      12        17.1     0.1821 

  7      19        17.1     0.1823 

  9       7         7.8     0.3645 

  9      12         7.8     0.1796 

  9      19         7.8     0.1799 

 12       7        8.06     0.3864 

 12       9        8.06     0.1738 

 12      19        8.06     0.1812 

 19       7        8.06     0.3869 

 19       9        8.06     0.1741 

 19      12        8.06     0.1812 

 

F.4.6. Interstitial condensation calculation results 

Menu command: View → Interstitial Condensation Calculation Results 
 

(requires Interstitial Condensation module, see Chapter K) 
 

Output 
− TRISCO data file name 
− Number of nodes 
− Iteration quality numbers for last executed iteration cycle: 

heat flow divergence for total object and for worst node 
− Net interstitial condensation rate (condensation minus evaporation) of the last condensation 

calculation cycle for the entire object 

 
Example 
 

TRISCO - Interstitial Condensation Calculation Results 

 

TRISCO data file: CondensationExample.trc 

 

Number of nodes = 819 

Vapour flow divergence for total object = 0.000161717 % 

Vapour flow divergence for worst node = 0.108982 % 

 

Net interstitial condensation rate in entire object (last calculation period) 

Condensation - evaporation = 296.253 g/(31 days) 

F.4.7. Interstitial moisture accumulation 

Menu command: View → Interstitial Moisture Accumulation 

 
(requires Interstitial Condensation module, see Chapter K) 

 
In case of a condensation calculation spanning several months (see D.5), the number of days and 

calculation periods per month, the net condensation rate and the moisture accumulation per 
successive month are shown. 
 
Example 
 

TRISCO - Interstitial Moisture Accumulation 

 

    Month              #Days   #Calculation   Condensation   Accumulated 

                                periods             [g]           [g]  _ 

1   September           30           1            0.000         0.000 
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2   October             31           1            0.000         0.000 

3   November            30           1            2.832         2.832 

4   December            31           1           35.522        38.354 

5   January             31           1           36.645        75.000 

6   February            28           1           27.209       102.209 

7   March               31           2            5.656       107.865 

8   April               30           3          -38.221        69.644 

9   May                 31           7          -61.340         8.304 

10  June                30           5           -8.304         0.000 

11  July                31           1            0.000         0.000 

12  August              31           1            0.000         0.000 

F.5. Settings 

Settings submenu 

 

F.5.1. Output precision 

Menu command: Settings → Decimals… 
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CHAPTER G REPORT GENERATION 

G.1. Operation 

From the main menu the command Output → Make Report generates a number of graphic files 
and text files with which a report can be created from a report template document (e.g. in 
Microsoft Word). 
All report files are written in the directory of the .trc data file. 

G.2. Graphic report definition 

The command Edit → Graphic Report Definition opens a window for the definition of (up to 8) 
graphic report files. 
 

 
 

The toggle in the column “Create” allows to activate or deactivate a graphic report file. 
The file name of the report file consists of the file name of the .trc data file appended with the 
image number (1 to 8). 
The projection (PERSP, XMIN, XMAX, YMIN, YMAX, ZMIN or ZMAX) corresponds to one of the 

possibilities in the Projection submenu in the Graphic Output window (see E.3). 

For a perspective projection (PERSP) the initial azimuth and altitude correspond to the current 

viewpoint in the Image window. 

The other following parameters correspond to the options of the View submenu in the Graphic 

Output window (see E.5). 
The image size, line types and increments correspond to the settings from the Settings submenu 

in the Graphic Output window (see E.7). 

 

The current settings in the Graphic Report Definition window can be saved as default settings 

(see A.8) using Settings → Set As Default. 

G.3. Report text files 

Up to 10 text files are created (as part of Output → Make Report). 
The .trc file name (“FileName”) is appended with fixed extensions: 

− FileName_DAT.txt: TRISCO input data (as in Text Output window: View → Input Data). 

− FileName_RES.txt: calculation results (as in Text Output window: View → Results). 

− FileName_COR.txt: temperatures in corner nodes (as in Text Output window: View → Corner 

Nodes). 
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− FileName_NOT.txt: temperatures in nodes with known powers, defined in Node BCs window 

(as in Text Output window: View → Node BCs). 

− FileName_VFC.txt: view factors between surfaces with different colours (as in Text Output 

window: View → View Factors). 

− FileName_MAT.txt: material properties (for colours of type MATERIAL, EQUIMAT and 
TRANSMAT). 

− FileName_BOC.txt: boundary conditions (for colours of type BC_SIMPL, BC_FRE_S, BC_FREE, 
BC_SKY, BC_NOSKY). 
 

If the corresponding item is checked in the Derived Thermal Properties dialog box (see D.9): 
− FileName_TFC.txt: temperature factor table. 
− FileName_PSI.txt: linear thermal transmittance and equivalent thermal transmittance. 

− FileName_UEL.txt: element thermal transmittance. 

G.4. Report index file 

The report index file “FileName.trx” (with same file name as input data file “FileName.trc”) is 
created as part of Output → Make Report and contains references to all other report files and 

output of numeric values. 
Each line starts with a keyword followed by the corresponding name or value: 
GRA# FileName#.ext: graphic report file (# = 1,2,…,8; .ext = .png or .bmp) 

TDAT FileName_DAT.txt 

TRES FileName_RES.txt 

TCOR FileName_COR.txt 

TNOT FileName_NOT.txt 

TVFC FileName_VFC.txt 

TMAT FileName_MAT.txt 

TBOC FileName_BOC.txt 

TTFC FileName_TFC.txt 

TPSI FileName_PSI.txt 

TUEL FileName_UEL.txt 

VFIL ---.trc: data file name (with extension .trc) 

VNOD ---: number of nodes 

VTFC ---: temperature factor [-] 

VPSI ---: (Q/(ti-te) – U1*A1 – U2*A2 – U3*A3)/L  (2D grid) [W/(m.K)] 

VDEL ---: Q/(ti-te) – U1*A1 – U2*A2 – U3*A3  (3D grid) [W/K] 

VUEQ ---: Q/((ti-te) * (A1+A2+A3))  [W/(m².K)] 

VUEL ---: (Q/(ti-te) – U2*A2 – U3*A3)/A1  [W/(m².K)] 

VUF1 ---: thermal transmittance of 1st flanking element [W/(m².K)] 

VAF1 ---: area of 1st flanking element [m²] 

VUF2 ---: thermal transmittance of 2nd flanking element [W/(m².K)] 

VAF2 ---: area of 2nd flanking element [m²] 

VUF3 ---: thermal transmittance of 3rd flanking element [W/(m².K)] 

VAF3 ---: area of 3rd flanking element [m²] 

 

If a value is not applicable, then the value after the keyword is omitted. 

G.5. Creating a report document 

The file TriscoReportTemplate.doc (in the personal folder, see I.3) contains a toolbar button 
(TRISCO_Load) with macro to import all report files referenced by a selected TRISCO report 
index file (with extension .trx) into bookmarked locations. It is a fast method to create a report 
document with text comments and layout predefined by the user. 
 

The report template from the personal folder is automatically copied into the directory of the 
current .trc file, gives it the same name as the .trc file, appended with “_report” and opens it. Be 
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careful to save the resulting report under a different name or in a different location if you want to 

repeat this process for the same .trc file, otherwise the report will each time be overwritten. 
 

To import data and results of only 1 TRISCO simulation: 
- run the macro TRISCO_Load in the toolbar 

- and select and open 1 TRX file in the TRISCO data folder. 
The macro will put the TRISCO graphic and text files and the relevant values in the document at 
the predefined bookmarks. 
Running the toolbar button TRISCO_Clear directly after running TRISCO_Load, undoes the 
insertion. 
 

To import data and results of multiple TRISCO simulations: 

- run the macro TRISCO_Load in the toolbar 
- and select and open multiple TRX files in the TRISCO data folder. 

The macro will put the TRISCO graphic and text files and the relevant values for each of the 
TRISCO simulations at the end of the document, leaving the first pages untouched. These first 
pages can be deleted now. 
The toolbar button TRISCO_Clear cannot be used to undo the import of multiple simulations. 
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CHAPTER H   INPUT OF DXF FILES 

H.1. General 

DXF files (e.g. created in AutoCAD or Sketchup) can be used to be build a TRISCO model in 2 
ways.  
The first is to open the DXF file in TriscoDxf1, a tool for input of a DXF file and conversion to a BMP 
file, ready for use in TRISCO. TriscoDxf can be started from the menu command File → Open 

DXF… in TRISCO (see B.3.3). 
An alternative procedure is to use Trisco2D, where a DXF file can be imported to serve as an 
underlayer for drawing a 2D model. The 2D model and the thermal properties associated with its 
colours can then be imported in TRISCO as a .tr2 file (see B.3.5). 

H.2. Input of DXF using TriscoDxf 

The pixel size (i.e. bitmap resolution) and bitmap border positions (left, right, top and bottom 
borders) can be defined with reference to the DXF coordinates. Hence follows the bitmap size 

(width and height). 
A BMP file generated in TriscoDxf by default uses the colour palette of the ColourPalette.bmp file 
(see I.5). TriscoDxf can load the colour palette of another bitmap into the current bitmap (see 
H.2.3, Bitmap → Load Palette…).  

The bitmap image with different colours is calculated from the definition of layers in the DXF file. 
Each layer contains the contour lines of only one material or boundary condition. Only a limited 

set of DXF commands are supported (i.e. polyline, line, arc, circle, ellipse, and blocks of these 
entities). 
In TriscoDxf a colour number is associated to each layer. The layer definitions are stored in a text 

file (with extension .lay) together with the BMP file. 

H.2.1. Input DXF file 

When making a DXF drawing create a layer per material or boundary condition (so per colour 

for TRISCO). Enter a meaningful name for the layer (see H.2.3). 
Per layer draw the contour lines using polylines. All line types supported by TriscoDxf are listed in 
section H.4. Other layers (for hatch patterns, dimensions, text, other drawing information…) may 
be present, but will be ignored in TriscoDxf. 
 

The DXF file is read into TriscoDxf via File → Open… (this dialog box opens automatically when 
calling TriscoDxf from TRISCO, see B.3.3). 
Only layers that contain supported line types are read. 
From these layers select the layers that also should be skipped. 

 

 
1 TriscoDxf.exe is completely analogous to BiscoDxf.exe, which is used to input a DXF file into BISCO (the 

Physibel program to calculate 2D steady state heat transfer in free-form objects). 
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The layer names are shown in the Layers window (see H.2.3). 
 

 
 

The DXF drawing is visible in the DXF Drawing window. 
 

 
 
The lines of the active layer are highlighted in black in the DXF Drawing window. All other lines 

are in grey. Open line end points in a layer, which may cause bad colour filling (using the fill 
mode “FILL CONTOURS”), are marked as orange dots. 
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The outline of the bitmap to be created is in blue. The bitmap outline is drawn based on the 

extents of the DXF drawing, ignoring the skipped layers (see above). 

H.2.2. Bitmap size 

Bitmap → Draw Bitmap Outline 
Enters “draw bitmap outline mode”. 
Draw a rectangle with the mouse (click and drag) to define the new bitmap outline (in blue). 

The drawing is zoomed in on this new bitmap outline, and the DXF Drawing window is reset to 
“zoom window mode”. 
 

Bitmap → Set Bitmap & Resolution… 
Allows to modify the DXF coordinates of left, right, bottom and top borders, as well as the pixel 

size (or resolution) of the bitmap. Hence follows the new bitmap size (width and height). 
After editing a value, press the Apply button to update the other values in the dialog box. 
 

 

H.2.3. Layers window 

The Layers window lists per layer: 

− Sequence number 
− Layer name (from DXF file) 
− Fill mode 

− Colour number 
− Colour value (not individually editable) 
 

 
 

When a DXF file is opened in TriscoDxf, the properties for each layer in the DXF file as displayed 

in the Layers window are gathered automatically by TriscoDxf from different sources: 
- The information in the TriscoDxf.lay file in the application data directory containing the 

default layer definitions is read firstly (see I.4). This file contains for each layer name within 
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it the corresponding fill mode and colour number. For layer names in the DXF file 

corresponding exactly with layer names from the TriscoDxf.lay file, the layer properties 

from the TriscoDxf.lay file are read and displayed in the Layers window. The layer 

sequence from the TriscoDxf.lay file is used as sequence in the Layers window. 

- Subsequently, if a layer file for the opened DXF file already exists (name of the file with 
extension .lay in the same folder), the layer properties are read and displayed in the 

Layers window for layer names in the DXF file corresponding exactly with layer names 

from the layer file. The information from this project layer file takes precedence over the 
information read in the TriscoDxf.lay. 

- For layer names of the DXF file not occurring in either the TriscoDxf.lay file or the project 

layer file, default information is displayed in the Layers window, except if the layer names 

in the DXF file themselves contain information according to a naming format. 
A name with prefix of the format “xxx_y_name” forces a colour number (xxx = 3 digits, 
from 000 up to 255) and fill mode (y = 1 digit, i.e. 0 = lines, 1 = fill contours, 2 = flood fill, 3 = 
skip) to be used for the layer. The layers of this format are displayed in the sequence in 

which they occur in the DXF file. 
 

After this procedure, each layer property can be edited individually in the Layers window in 

TriscoDxf. Alternatively, previously saved layer definitions (file with .lay extension) can be 
imported for the current DXF file using the command Layers → Load Layer Definitions….  
 

Colour number 
Enter a colour number (between 0 and 255) that will be used in the bitmap creation  
(Calc → Calc Bitmap). 

The colour value from the active colour palette is displayed in the next cell. 
The bitmap file ColourPalette.bmp in the application data directory (see I.5) contains the default 

colour palette and is read at the startup of TriscoDxf. 
The colour palette can be changed using the function Bitmap → Load Palette… and selecting a 
BMP file. 
 

Fill mode 
Defines how the polylines of the layer will be processed when the bitmap is created  

(Calc → Calc Bitmap). 
− LINES 

Rasterises the DXF polylines into raster lines using pixels of the specified colour. 
Normally used for separate lines and open polylines. 

− FILL CONTOURS 
Fills the inside of closed polylines using the specified colour. 
A parity fill algorithm is used (which does not function properly for self-overlapping contour 
lines, because the double lines switch the filling). 

− FLOOD FILL 
Fills the connected colour zone around the DXF polylines in the current layer into the specified 
flood fill colour. 
Pixels of rasterised lines (from layers with lower sequence number) adjacent to the new filled 

zone are repainted with the flood fill colour. 
− SKIP 

The polylines are not processed (i.e. skipped). 
Normally use “FILL CONTOURS” for closed polylines. 
 

Sequence of layers 
Bitmap colouring processes the layers one after the other following the sequence order. 
The sequence order can be changed using the functions: 
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− Layers → Higher Priority (moves the current layer one row down). 
− Layers → Lower Priority (moves the current layer one row up). 
 

Layers → Load Layer Definitions… 
Read fill mode and colour number for layers with exactly corresponding names from a layer 

definition file (with extension .lay). 
A layer definition file is created every time a calculated bitmap is saved (Calc → Save Bitmap…). 

H.2.4. Bitmap creation 

Calc → Calc Bitmap 
Calculate the bitmap using current bitmap size and resolution (Bitmap → Set Bitmap & Pixel 

Size…) and layer definitions (in the Layers window). 

The DXF Drawing window is replaced by the Bitmap window with the calculated bitmap. 

Use View → DXF Drawing and View → Bitmap to switch between both views. 

Activating the Layers window automatically switches to the DXF Drawing window. 
 

Calc → Save Bitmap… 
Save the calculated bitmap into a (compressed 256-colours) BMP file. 

Also the layer definitions in the Layers window are saved into a text file with same directory and 
file name as the new BMP file, but with extension .lay. 

The .lay file is used for recovery of layer definitions when the same DXF file is reloaded (with File 
→ Open…). 
 

By closing the TriscoDxf application (File → Exit) the generated BMP file is automatically imported 

in TRISCO. 

H.3. Input of DXF as underlayer via Trisco2D 

In Trisco2D, a DXF file can be imported to serve as an underlayer when creating a geometric (2-
dimensional) model (File → Import DXF). 
 

When a DXF file for import is selected in Trisco2D, a dialog is prompted to the user allowing to 
define the DXF unit, whether horizontal and vertical gridlines will be automatically created based 
on the DXF drawing and which layers in the DXF file can be ignored. 
 
If this option is selected, the design grid lines to create the model geometry are now 
automatically recognised and drawn (though not for sloped lines) and the DXF drawing is shown 

in the Image window as an underlayer. 
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The model can then be further developed in Trisco2D, after which the .tr2 file can be imported in 

TRISCO (see B.3.5). 

H.4. Supported DXF commands 

The input DXF file must be created according to the Autodesk DXF Format Reference. 
 

Only a subset of DXF commands is read into TriscoDxf. Other commands are skipped. 
 
Only 2D coordinates (X and Y) are read. The Z values are always skipped. 
Line thicknesses, elevations and extrusion directions are skipped, except if the extrusion direction 
in the Z-direction equals -1 exactly and equals 0 in X-direction and Y-direction, then the object is 

mirrored.  
 
The following drawing DXF commands are read: 

− LINE 
(Read group codes: 8, 10, 20, 11, 21) 

− LWPOLYLINE 
Both line segments and arc segments are possible. 
(Read group codes: 8, 90, 70 (0 or 1), 10, 20, 42, 210, 220, 230) 

− POLYLINE (subclass AcDb2dPolyline) and VERTEX (subclass AcDb2dVertex) 
Both line segments and arc segments are possible. 

No curve-fit or spline-fit vertices. 

(POLYLINE group codes: 8, 70 (0 or 1); VERTEX group codes: 8, 10, 20, 42) 
− ARC 

(Read group codes: 8, 10, 20, 40, 50, 51, 210, 220, 230) 
− CIRCLE 

(Read group codes: 8, 10, 20, 40, 210, 220, 230) 
− ELLIPSE 

(Read group codes: 8, 10, 20, 11, 21, 40, 41, 42, 210, 220, 230) 
 
Block definitions (DXF command BLOCK, containing the drawing commands as above) and block 
insertions (DXF command INSERT) are possible, with the following restrictions: 
− No external references (to files). 

− BLOCK: the base point is not read (i.e. always X = 0 and Y = 0). 
− INSERT: only X and Y of the insertion point, the X scale and Y scale factor, and the rotation 

angle are read. 
(BLOCK group codes: 2, 8; INSERT group codes: 2, 8, 10, 20, 41, 42, 50) 
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CHAPTER I   TRISCO TEMPLATE FILES 

I.1. General 

TRISCO makes use of template files containing default information for a number of functions. 
These template files are each saved in the application data folder or personal folder (see A.6) of 
the user account on the computer where TRISCO is installed. The path to the application data 
folder is C:/Users/username/Appdata/Roaming/Physibel/TRISCO16 (AppData is a hidden folder 

by default in Windows). 
 
The template files used by TRISCO are: 

- ColourDatabase.trc (I.2) 
- TriscoReportTemplate.doc (I.3) 
- TriscoDxf.lay (I.4, only used by TriscoDxf, see H.2I.4) 
- ColourPalette.bmp (I.5, only used by TriscoDxf, see H.2I.4) 

 
The use of these template files in different TRISCO functions has been outlined throughout the 
manual. In the following sections, handling and customization of these template files is briefly 
discussed. 

I.2. Colour database 

The colour database file ColourDatabase.trc is saved in the application data folder 

(C:/Users/username/Appdata/Roaming/Physibel/TRISCO16). The colour database contains 
predefined material and boundary condition properties and is loaded at every TRISCO start-up 
(see B.2). 

 
It is advisable to add frequently used materials and boundary conditions to the colour database. 
These predefined colours of the colour database are then available for new colours in any 

document. 
The command File → Open Colour Database… (see B.3.4) allows to modify the 256 available 
predefined colours of the colour database. After editing the colour data, the file should be saved 

(File → Save) to adapt the colour database on disk. 
 
Alternatively, if a user wants to save a custom file as colour database, this is possible by saving it 
with the name ColourDatabase.trc in the application data folder (File → Save as…) thus 
overwriting the default file. In the application data folder, the default colour database is present 
as ColourDatabase_PhysibelDefault.trc. This file can be saved as ColourDatabase.trc to restore 
the original colour database. 
 

The ColourDatabase.trc file replaces the Trisco.trc file in older versions of TRISCO. Users who had 
been working with a customised Trisco.trc file, can thus easily transfer to the new system by 
opening Trisco.trc and saving it with the name ColourDatabase.trc in the application data folder. 

I.3. Report 

The report template file TriscoReportTemplate.doc is saved in the personal folder (../Documents/ 
Physibel/TRISCO16). When a report is created in TRISCO, the report template is copied from the 

personal folder into the directory of the current .trc file and given the same name as the .trc file, 
appended with “_report”. 
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Editing the template document can be useful to create a new template document with another 

layout (own company style) and with other (typically less) contents. 
 
When a bookmark is removed the corresponding item (graphic file, text file or value) will not be 
imported when applying the TRISCO Load macro. 

To reinstall a bookmark, a name listed in the table of bookmarks should be used. 

I.4. DXF layer definitions 

The default layer definition file TriscoDxf.lay is saved in the application data folder 
(C:/Users/username/Appdata/Roaming/ Physibel/TRISCO16). This file contains for each layer 
name within it the corresponding fill mode and colour number for creating of a BMP file based 

on layers in a DXF file in TriscoDxf (see H.2). The layer definitions in TriscoDxf.lay are read every 
time a new DXF file is opened in TriscoDxf to initialise the layer sequence, fill modes and colour 

numbers in the Layers window, in order to minimise input. 

 
After installation, a TriscoDxf.lay file with very limited information is present. To create a 
customized TriscoDxf.lay file, it is recommended to start from a generic DXF file which contains all 

possible layer names (for all possible materials and boundary conditions) in order to obtain a file 

TriscoDxf.lay with maximal usability. Open this DXF file in TriscoDxf, set all properties in the Layers 

window and save the layer definition as the default layer definition (Layers -> Save as default 

layers definition). Afterwards, always use the same layer names for identical materials and 
boundary conditions in new DXF files. 

I.5. Colour palette 

The colour palette file ColourPalette.bmp is saved in the application data folder 
(C:/Users/username/Appdata/Roaming/ Physibel/TRISCO16). The colour palette file’s header 

section contains the definition of the 256 possible colour values in the bitmap (called the colour 
palette) as used in TriscoDxf (see H.2). 
If a user wants to save a custom file as colour palette, this is possible by saving it with the name 

ColourPalette.bmp in the application data folder thus overwriting the default file. In the 
application data folder, the default colour palette is present as 

ColourPalette_PhysibelDefault.bmp. This file can be saved as ColourPalette.bmp to restore the 

original colour palette. 
 
The ColourPalette.bmp file replaces BiscoDxf.bmp files in older versions of TRISCO. Users who 

had been working with a customised palette file, can thus easily transfer to the new system 
saving it with the name ColourPalette.bmp in the application data folder. 
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CHAPTER J RADCON MODULE 

J.1. Purpose 

The RADCON module for TRISCO is a program add-on module to simulate more realistically the 
heat transfer between material surfaces and their adjacent environments. 
The heat transfer has the following components: 
− Radiation: based on view factors and material surface emissivities. 

− Convection: based on a convective heat transfer coefficient applied to the contact surface 
between material and environment. 
For natural convection the convective heat transfer coefficient can be calculated in function of 
the maximum temperature difference between surface temperature and air temperature. 

− Conduction: in a (transparent) material with a fixed thermal conductivity coefficient. 
 
The RADCON module offers a physically more correct alternative for: 
− The global surface heat transfer coefficient. 
− The equivalent thermal conductivity of an air cavity. 

J.2. Implementation 

Without the RADCON module, TRISCO has the following colour types (defined in the Colours 

window, see B.9 and D.1 for more information): 

− MATERIAL 

− EQUIMAT 
− BC_SIMPL 

− BC_FRE_S 

 

With the RADCON module, TRISCO has the following additional colour types: 

− BC_FREE for an enclosure (normally fully surrounded by material surfaces, e.g. a cavity or a 
room) with unknown air temperature (free-floating air temperature), known surface heat flux 
(positive or negative), known (or calculated) convective heat transfer coefficient and known 

injected convective heat power (positive or negative). 
The unknown air temperature is calculated from the convective heat balance equation: 
Σ (convective heat transfer from environment to surface) = injected convective heat power. 

The radiation between the different surfaces bordering the environment are calculated based 

on view factors. When the environment is not completely surrounded by material surfaces, the 
open end is considered to be a symmetry plane for heat transfer. The symmetry plane is 
simplified by use of an additional radiation mirror node. In that way the environment is made 
closed for radiation heat transfer: i.e. for each elementary surface the sum of view factors 
equals 1 (taking into account the radiation mirror node for the rest view factor). The radiation 
heat transfer is somewhat underestimated compared to the real cavity (with double volume 
of the environment bounded by the symmetry plane). Therefore it is recommended to use 

fully enclosed environments. 

− BC_SKY for an environment (normally not fully surrounded by material surfaces, e.g. in 
contact to the sky) with known air temperature, known radiation temperature, known surface 
heat flux (positive or negative) and known (or calculated) convective heat transfer coefficient. 
This implies there can be a resultant radiation heat flow from the environment to the material 

surfaces (using view factors) and a resultant convective heat flow from the environment to the 
material surfaces. 

− BC_NOSKY for an environment with known air temperature, known surface heat flux (positive 
or negative) and known (or calculated) convective heat transfer coefficient. 
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There is no radiation to the environment (i.e. no sky radiation). The surfaces bordering the 

environment exchange radiation based on view factors. In general the sum of view factors 
from an elementary surface to the other surfaces is less than 1. 
(Note: in TRISCO up to version 10.0w there is an additional radiation mirror node in the environment, to ensure that 

the sum of view factors always equals 1, as for the type BC_FREE. From TRISCO v11.0w there is no radiation mirror 

node any more.) 

The known air temperature implies there can be a resultant convective heat flow from the 
environment to the material surfaces. 

− TRANSMAT for a transparent material with known (or calculated) thermal conductivity 
(normally of still air or another gas according to EN 10077-2). 
Additionally to the material conduction there is radiative heat transfer between the adjacent 
material surfaces (using the emissivity of the adjacent materials). 

If the environment (normally a small cavity) modelled as transparent material is not fully 
surrounded by material surfaces at the outer border of the geometry, then this border is 
considered as an adiabatic surface with emissivity 0. 
If there is convection within the cavity, the thermal conductivity for still gas should be 

multiplied by the Nusselt number. This is done automatically for subtype CAVITY (see D.1.5). 
 

With RADCON the colours of type MATERIAL or EQUIMAT also have a user defined surface 
emissivity, which is applied to the radiative heat transfer in all RADCON boundary conditions 
bordering the material. 

J.3. Formulas 

Combined convective and radiative heat transfer (BC_SIMPL, BC_FRE_S) 
The global (combined convective and radiative) heat flow is: 
𝑄 = ℎ ⋅ (𝜃𝑠 − 𝜃𝑏𝑐) ⋅ 𝐴 
𝑄 = global heat flow [W] 
ℎ  = global heat transfer coefficient [W/(m2.K)] 
𝜃𝑠 = surface temperature [°C] 

𝜃𝑏𝑐 = ambient temperature [°C] 
𝐴  = surface area [m²] 
In this formula the ambient temperature is not defined precisely. It can be the air temperature, 

the dry resultant temperature or an interpolated value. Depending on that choice, an 

appropriate value for the global heat transfer coefficient must be chosen. 
 

Convective heat transfer (BC_FREE, BC_SKY, BC_NOSKY) 

The convective heat flow is: 
𝑄𝑐 = ℎ𝑐 ⋅ (𝜃𝑠 − 𝜃𝑎) ⋅ 𝐴 
𝑄𝑐 = convective heat flow [W] 
ℎ𝑐 = convective heat transfer coefficient [W/(m2.K)] 
𝜃𝑠 = surface temperature [°C] 
𝜃𝑎 = air temperature [°C] 
𝐴 = surface area [m²] 
The convective heat transfer coefficient hc can be calculated based on the given subtype (cf. 
section D.1.3 and D.1.4). 
 

Black radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 

The radiative heat flow between two black surfaces is: 
𝑄𝑖𝑗 = 𝐴𝑖 ⋅ 𝐹𝑖𝑗 ⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑠𝑏𝑖 − 𝜃𝑠𝑏𝑗) 

𝑄𝑖𝑗 = radiative heat flow between black surface i and black surface j [W] 

𝐴𝑖 = area of surface i [m2] 
𝐹𝑖𝑗 = view factor from surface i to surface j (between 0 and 1) 
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ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 

𝜃𝑠𝑏𝑖 = black surface temperature of surface i [°C] 
𝜃𝑠𝑏𝑗 = black surface temperature of surface j [°C] 

 

For linear radiation the black radiation heat transfer coefficient is constant, defined as a 
calculation parameter (see D.2). The value depends on the temperature range of the problem 

considered. Section J.4 contains a table with the values of ℎ𝑟𝑏, depending on the mean 
temperature m [°C] of the surfaces i and j and the temperature difference between the surfaces 

𝑖𝑗 [°C]. The table shows that the ℎ𝑟𝑏-value mainly depends on the mean surface temperature 

𝑚 . The temperature difference between the surfaces has a minor influence. 
The default value is a black radiation heat transfer coefficient ℎ𝑟𝑏 = 5.25 W/(m2.K) (assuming 

𝑚  = 12°C), but the user can change this value in the Calculation Parameters dialog box. 

 
For non-linear radiation: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑠𝑏𝑖

2 + 𝑇𝑠𝑏𝑗
2 ) ⋅ (𝑇𝑠𝑏𝑖 + 𝑇𝑠𝑏𝑗) 

𝜎 = 5.67 10-8 W(m2.K4) (Stefan-Boltzmann constant) 
𝑇𝑠𝑏𝑖 = 𝜃𝑠𝑏𝑖 + 273.16 [K] (absolute temperature of black surface i) 
𝑇𝑠𝑏𝑗 = 𝜃𝑠𝑏𝑗 + 273.16 [K] (absolute temperature of black surface j) 

The black radiation heat transfer coefficients are recalculated at the start of each new iteration 
cycle based on the temperatures obtained in the last iteration cycle. 
 

Grey radiation (BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT) 
Real surfaces are not black (emissivity  = 1) but grey (emissivity  < 1). In the RADCON module 

each (grey) surface is connected to a black surface node. All black surface nodes are connected 
to each other in a star-diagram. 

The radiative heat flow between the real surface with given emissivity and the corresponding 
black surface is: 

𝑄𝑟 = 𝐴 ⋅
𝜀

1 − 𝜀
⋅ ℎ𝑟𝑏 ⋅ (𝜃𝑠𝑏 − 𝜃𝑠) 

𝑄𝑟 = radiative heat flow between grey surface and black surface [W] 
𝐴 = surface area [m2] 
 = surface emissivity (0 ≤ ε < 1) 

ℎ𝑟𝑏 = black radiation heat transfer coefficient [W/(m2.K)] 

𝜃𝑠𝑏 = black surface temperature [°C] 
𝜃𝑠 = (real) surface temperature [°C] 
For non-linear radiation: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑠𝑏

2 + 𝑇𝑠
2) ⋅ (𝑇𝑠𝑏 + 𝑇𝑠) 

𝑇𝑠𝑏 = 𝜃𝑠𝑏 + 273.16  [K] 
𝑇𝑠 = 𝜃𝑠 + 273.16 [K] 

The black radiation heat transfer coefficients are recalculated at the start of each new iteration 
cycle based on the temperatures obtained in the last iteration cycle. 
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J.4. Table of black radiation heat transfer coefficients 

The following table shows the black radiation heat transfer coefficient. 
The values are obtained using the formula: 
ℎ𝑟𝑏 = 𝜎 ⋅ (𝑇𝑖

2 + 𝑇𝑗
2) ⋅ (𝑇𝑖 + 𝑇𝑗) 

with 𝜎 =  5.67*10-8 W/(m2.K4) (Stefan-Boltzmann constant) 

 
black radiation temperature difference between the surfaces i and j 

heat transfer coeff. ij [°C] 

hrb [W/m2K] 0.00 5.00 10.00 15.00 20.00 25.00 30.00 35.00 40.00 45.00 50.00 

 -20.00 3.68 3.68 3.68 3.68 3.69 3.69 3.69 3.70 3.70 3.71 3.72 

 -15.00 3.90 3.90 3.90 3.91 3.91 3.91 3.92 3.92 3.93 3.93 3.94 

 -10.00 4.13 4.13 4.13 4.14 4.14 4.14 4.15 4.15 4.16 4.16 4.17 

 -5.00 4.37 4.37 4.37 4.38 4.38 4.38 4.39 4.39 4.40 4.40 4.41 

mean 0.00 4.62 4.62 4.62 4.63 4.63 4.63 4.64 4.64 4.65 4.65 4.66 

temp. 5.00 4.88 4.88 4.88 4.88 4.89 4.89 4.90 4.90 4.91 4.91 4.92 

m [°C] 10.00 5.15 5.15 5.15 5.15 5.16 5.16 5.16 5.17 5.17 5.18 5.19 

 15.00 5.43 5.43 5.43 5.43 5.43 5.44 5.44 5.45 5.45 5.46 5.47 

 20.00 5.71 5.71 5.72 5.72 5.72 5.72 5.73 5.73 5.74 5.75 5.76 

 25.00 6.01 6.01 6.01 6.02 6.02 6.02 6.03 6.03 6.04 6.05 6.05 

 30.00 6.32 6.32 6.32 6.32 6.33 6.33 6.33 6.34 6.35 6.35 6.36 

 35.00 6.64 6.64 6.64 6.64 6.64 6.65 6.65 6.66 6.66 6.67 6.68 

 40.00 6.96 6.97 6.97 6.97 6.97 6.98 6.98 6.99 6.99 7.00 7.01 

 45.00 7.30 7.30 7.31 7.31 7.31 7.32 7.32 7.33 7.33 7.34 7.35 

 50.00 7.65 7.65 7.66 7.66 7.66 7.67 7.67 7.68 7.68 7.69 7.70 
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J.5. Table of emissivities 

The table below contains values of the long-wave emissivity  of some building materials taken 
from: 
− H.C. Hottel, Heat Transmission, 1954 
− J.S. Cammerer, Wärme- und Kälteschutz in der Industrie, 1962 

− Stichting Bouwresearch, Eigenschappen van bouw- en isolatiematerialen, rapport 9, 1974 

 
building material long-wave emissivity at T = 300K 

 [-] 

black surface 1 

aluminium, polished < 0.07 

aluminium, oxidised 0.11 à 0.3 

brass, polished 0.038 

copper, smoothed 0.09 

copper, oxidised 0.78 - 0.79 

cast iron 0.44 

iron, oxidised and rusted red 0.61 

lead, grey oxidised 0.28 

tin 0.043 - 0.064 

zinc, galvanised 0.23 

zinc, oxidised > 0.11 

asbestos board 0.96 

bitumen 0.92 

brick, red, rough but no gross 

irregularities 

0.92 - 0.93 

concrete 0.88 

glass 0.94 

cement-tiles > 0.85 

roofing-tiles, red 0.85 

roofing paper 0.91 

rubber, hard and glossy 0.94 

wood 0.86 

aluminium painting 0.42 

enamel, white >0.90 

metal paint, black 0.88 

water 0.95 - 0.96 

other materials (approximation) 

white, yellow, green, red, blue, grey, 

black 

0.85 à 0.95 



98 Manual TRISCO v16.0 

J.6. Tables for convective heat transfer coefficients 

The convective heat flow density is calculated using the following formula: 

𝑞𝑐 = ℎ𝑐 ⋅ (𝜃𝑎 − 𝜃𝑠) with 𝑞𝑐 = convective heat flow density [W/m2] 
ℎ𝑐 = convective heat transfer coefficient [W/(m2.K)] 
𝜃𝑎 = air temperature [°C] 

𝜃𝑠 = surface temperature [°C] 

Table 1 lists values of ℎ𝑐 for air cavities according to EN ISO 10077-2, depending on the 

temperature difference  over the cavity and the depth 𝑑 of the cavity. Above the bold line, the 
ℎ𝑐-value depends only on the cavity depth (same ℎ𝑐-values on each row), while underneath the 

bold line the ℎ𝑐-value depends only on the temperature difference over the cavity (same ℎ𝑐-

values in each column). Above the bold line there is in fact only conduction (still air). Below the line 
natural convection is considered. 

 
Table 1: convective heat transfer coefficient for air cavities (EN ISO 10077-2) 

convective heat temperature difference over the cavity 

transfer coefficient  [°C] 

hc [W/(m2.K)] 0.500 1.000 1.500 2.000 3.000 4.000 5.000 6.000 8.000 10.000 

 0.001 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 50.000 

 0.002 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 25.000 

 0.003 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 16.667 

 0.004 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 12.500 

 0.005 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 10.000 

depth 0.006 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 8.333 

of the 0.007 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 7.143 

cavity 0.008 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 6.250 

d [m] 0.009 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 5.556 

 0.010 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 5.000 

 0.011 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 4.545 

 0.012 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 4.167 

 0.013 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 3.846 

 0.014 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 3.571 

 0.015 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 3.333 

 0.016 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.125 3.145 

 0.017 2.941 2.941 2.941 2.941 2.941 2.941 2.941 2.941 2.941 3.145 

 0.018 2.778 2.778 2.778 2.778 2.778 2.778 2.778 2.778 2.920 3.145 

 0.019 2.632 2.632 2.632 2.632 2.632 2.632 2.632 2.653 2.920 3.145 

 0.020 2.500 2.500 2.500 2.500 2.500 2.500 2.500 2.653 2.920 3.145 

 0.025 2.000 2.000 2.000 2.000 2.106 2.318 2.497 2.653 2.920 3.145 

 0.030 1.667 1.667 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.035 1.429 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.040 1.250 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.045 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.050 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.060 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.070 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.080 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.090 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 

 0.100 1.159 1.460 1.671 1.839 2.106 2.318 2.497 2.653 2.920 3.145 
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Table 2 lists values of ℎ𝑐 for exterior surfaces, depending on the air velocity 𝑣 and the 

temperature difference  between surface and environment (from “Informatiemap voor 
bouwfysici”, 1991). 
 
Table 2: the convective heat transfer coefficient for exterior environments 

convective heat temperature difference object -environment 

transfer coefficient  [°C] 

hc [W/(m2.K)] 5 10 20 40 

 0.5 7 8 9 11 

air 1 9 10 11 13 

velocity 2 12 13 15 16 

v [m/s] 3 19 20 21 23 

 4 25 26 27 28 

 5 30 31 32 34 

The following formulas define the convective heat transfer coefficient for interior environments 
(from “Element 29: Wärmeschutz und Energie im Hochbau”, 1990). Table 3 lists the hc-values 
according to these formulas. 

ℎ𝑐 = 1.31 ⋅ √𝛥𝜃
3

 for vertical constructions (walls) with a horizontal heat flow 

ℎ𝑐 = 1.77 ⋅ √𝛥𝜃
4

 for vertical constructions (window) with a horizontal heat flow 

ℎ𝑐 = 1.52 ⋅ √𝛥𝜃
3

 for horizontal constructions (walls) with an upgoing heat flow 

ℎ𝑐 = 0.59 ⋅ √𝛥𝜃
4

𝐿⁄  for horizontal constructions (walls) with a downgoing heat flow 

with  ℎ𝑐= convective heat transfer coefficient [W/(m2.K)] 
 = temperature difference object - environment [°C] 
𝐿 = ½ (length x width) of the construction [m2] 

 
Table 3: the convective heat transfer coefficient for interior environments 

convective heat vertical constructions horizontal constructions 

transfer coefficient horizontal heat flow upwards downwards 

hc [W/(m2.K)] walls windows heat flow heat flow * 

 1 1.31 1.77 1.52 0.39 

 2 1.65 2.10 1.92 0.47 

 3 1.89 2.33 2.19 0.52 

temperature 4 2.08 2.50 2.41 0.56 

difference 5 2.24 2.65 2.60 0.59 

object -  6 2.38 2.77 2.76 0.62 

environment 7 2.51 2.88 2.91 0.64 

 [°C] 8 2.62 2.98 3.04 0.66 

 9 2.72 3.07 3.16 0.68 

 10 2.82 3.15 3.27 0.70 

 11 2.91 3.22 3.38 0.72 

 12 3.00 3.29 3.48 0.73 

 13 3.08 3.36 3.57 0.75 

 14 3.16 3.42 3.66 0.76 

 15 3.23 3.48 3.75 0.78 

* using L = 5 m2 
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CHAPTER K INTERSTITIAL CONDENSATION MODULE 

K.1. Introduction 

The Interstitial Condensation module in TRISCO introduces a three-dimensional quasi-stationary 
heat and vapour model to estimate the risk for interstitial condensation in building envelopes2. 
The model, which is in fact a three-dimensional implementation of the Glaser method, should be 
regarded as a practical assessment tool rather than an accurate moisture transfer prediction 

tool.  

The aim of the tool is to assess the risk for annual moisture building up and/or drying under the 
same limitations as the well-known Glaser method (EN ISO 13788). This means that for 
constructions where (hygroscopic) moisture buffering, capillary moisture transport and/or air 
transport is relevant, the method proposed here cannot be safely used. 

K.2. Governing equations 

The combined steady-state heat and vapour transport is modelled with the following (simplified) 

conservation equations for energy and moisture mass: 

𝑑𝑖𝑣 (𝜆. 𝑔𝑟𝑎𝑑 𝑇) = Ф                               
𝑑𝑖𝑣 (𝛿. 𝑔𝑟𝑎𝑑 𝑝𝑣) = 𝐺𝑐                               
 

With λ = thermal conductivity [W/(m.K)] 
T = temperature [K] 
Ф = energy source/sink term [W/m3] 

δ = vapour permeability [kg/(m.s.Pa)] 
𝑝𝑣 = vapour pressure [Pa] 
𝐺𝑐 = condensation/evaporation term [kg/m³] 

 
Often the vapour permeability 𝛿 of a material is expressed as the vapour permeability of air 
divided by the material’s vapour resistance factor (𝛿0/µ). 
 

Implemented in the control volume method, the moisture transfer between nodes i and j is 1-
dimensional (and assumed purely by diffusion): 
 

𝑔 =
𝛿0

𝜇

∆𝑖𝑗𝑝𝑣

𝑑𝑖𝑗
 

With 𝑔 = density of water vapour flow rate [kg/(m²s)] 

𝛿0 = vapour permeability of air [kg/(m.s.Pa)] 
 𝜇 = vapour resistance factor [-] 

∆𝑖𝑗𝑝𝑣 = vapour pressure difference between node i and node j [Pa] 

 𝑑𝑖𝑗 = distance between node i and node j [m] 

 

Determination of the water vapour saturation pressure: 

𝑝𝑣,𝑠𝑎𝑡 = 610.5 ∙ 𝑒
17.269∙𝜃

237.3+𝜃  for 𝜃 ≥ 0°𝐶 

𝑝𝑣,𝑠𝑎𝑡 = 610.5 ∙ 𝑒
21.875∙𝜃

265.5+𝜃  for 𝜃 < 0°𝐶 

 
With 𝑝𝑣,𝑠𝑎𝑡 = water vapour saturation pressure [Pa] 

 
2 Langmans J. et al., A three-dimensional steady-state heat and vapour transport model to assess the risk 

for interstitial condensation in building enclosures, 13th Nordic Symposium on Building Physics (2023) 
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𝜃 = temperature [°C] 

K.3. Model applicability 

The objective of this section is outlining the applicability of the proposed model in comparison to 
more complex (dynamic) hygrothermal models. As mentioned in K.1 existing hygrothermal 
engineering tools range from simple 1D steady-state heat and vapour transport models (GLASER 

method) up to fully-coupled 2D and even 3D transient HAM models. 
The implemented modelling methodology is reviewed on 5 different aspects in what follows. 

K.3.1. Geometry 

The model allows the user to create either 1D, 2D or 3D geometries. 2D and 3D effects can highly 
impact the results and thus the assessment. 

K.3.2. Boundary conditions 

The model is steady-state but has the option to run consecutive simulations with monthly averaged 
boundary conditions. This allows to assess the annual accumulated moisture due to interstitial 
condensation (or drying time in case the simulation starts with an initial moisture excess). 
The model is limited to circumstances where this quasi-stationary monthly averaged approach is 
justified. It is not intended to be used for problems where (hygro)thermal inertia is important. 

K.3.3. Material properties 

The model assumes constant material properties. This basically limits its use to materials for which 
the vapour permeability is not influenced by relative humidity, such as mineral wool, glass, metals, 

EPDM, PVC,…. In case the building enclosure studied contains materials for which the vapour 
permeability is influenced by its relative humidity (wood, cellulose insulation,…) and hygric buffering 
is substantial, it is advised to move to more advanced models. Such models however, require that 

sufficiently accurate material functions are available. 

K.3.4. Physics 

The model considers the combined heat and vapour transport, but is not intended to investigate 
problems where moisture buffering and/or capillary moisture transport is important (wind-driven 
rain on masonry, capillary active insulation materials, rising damp,…).  
Further, it is also important to stress that the proposed model assumes the building enclosure to be 
perfectly airtight. When any type of air transport is relevant (e.g. wind-washing, natural convection 
in or around insulation layers, forced convection through leaks,…) the model cannot be safely used.    

K.3.5. Performance thresholds 

The model explicitly calculates the level of (accumulated) interstitial condensation which can serve 
as a direct performance threshold in the evaluation of the building enclosure. Alternatively, an initial 

moisture excess can be defined at an interface for which the drying out period can be calculated.  
In addition, the proposed method calculates the monthly temperature field and relative humidity 
field which can be used to assess the risk for mould formation. 


