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CHAPTER A INTRODUCTION 

A.1. Short description of Trisco2D  

Trisco2D is a thermal analysis program for steady state heat transfer in two-dimensional 
rectangular objects consisting of different materials and submitted to different boundary 
conditions. The geometry is described with a list of rectangular blocks, of which the vertices lie on 
grid points of a rectangular grid. The geometry can be created by intuitive drawing functions 

and/or loaded from a DXF file, automatically recognising vertical and horizontal object lines.  
Materials and surface boundary conditions with different thermal properties are identified using 
separate colours. Each geometry block is part of either a material or a surface boundary 
condition region, and has a reference to one of these colours.   
After the input of geometry and thermal properties a system of linear equations is calculated 
based on the energy balance technique, and solved using a fast-iterative method.   
The graphic and text output functions allow to generate thermal reports in line with the European 
standards. 
Main applications of Trisco2D: 

• Two-dimensional thermal bridges according to EN ISO 10211 
• Surface condensation verification according to EN ISO 13788 

A.2. Trisco2D: brief history and relation to other Physibel products  

The first roots of Trisco2D (former KOBRU86) descend from research for a doctoral thesis on 2D 

and 3D heat transport in building physics (by Piet Standaert in 1984; cf. section A.7). 
The first commercial version of TRISCO on PC was ready in 1989 and was continuously developed 
since then. 

Trisco2D is the limited version of TRISCO which allows the full steady state thermal analysis of 
three-dimensional rectangular objects. 
The table below provides a briefly comparison of the functionalities of the Physibel thermal 

steady-steady software tools: 

 

    
 Trisco2D TRISCO BISCO SOLIDO 

dimensions 2D 3D 2D 3D 

free form in limited way in limited way ✓ ✓ 

rectangular  ✓ ✓   

extension .tr2 .trc .bsc .sld 

input formats .dxf .dxf, .sld, .bsc .dxf .stl, .trc, .bsc 

detailed IR-radiation 

via view factors 

 
✓ ✓ ✓ 

fixed field 

temperature/heat 

power 

  

✓ 

 

✓ 

 

✓ 

optimised for use in 

according to 

    EN ISO 10211 

    EN ISO 6946 

    EN ISO 13788 

    EN ISO 10211 

    EN ISO 6946 

    EN ISO 13788 

    EN 673 

    EN ISO 1745 

  EN ISO 10077-2 

  EN ISO 12631 

  EN ISO 6946 

  EN ISO 10211 

  EN ISO 13788 

  EN 673 

  EN 1745 

   EN ISO 10211 

   EN ISO 6946 

   EN ISO 13788 

   EN 673 

   EN 1745 
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A.3. Technical specifications 

− Trisco2D is a 64-bit Windows program. Trisco2D is installed in C:\Program Files 
(x86)\Physibel\Trisco2D2. 
In this folder the executable file is Trisco2D2.exe. 

− The standard version of Trisco2D allows to solve systems with up to 30,000 nodes. An add-on 

feature to calculate an unlimited amount of nodes is available for purchase (feature Unlimited 
Nodes). The maximum number of nodes then depends on the RAM installed. For example, 8 
Gb RAM allows to solve about 25,000,000 nodes, 16 Gb RAM allows to solve about 
50,000,000 nodes.Trisco2D relies on OpenGL for use of hardware accelerated graphics. 

− Trisco2D is protected is protected by either a hardware key, provided by Physibel, or a 

software licence (see A.4). 

 
The Physibel 64-bit programs need several shared libraries (.dll files) from Microsoft. 

The Microsoft Visual C++ 2017 Redistributable Package (x64) is included in the installation files of 
Trisco2D, but can also be downloaded from https://support.microsoft.com/en-
us/help/2977003/the-latest-supported-visual-c-downloads. 
This package installs mfc140.dll and other files in the directory C:\Windows\SysWOW64, required 
by 64-bit applications developed with Microsoft Visual C++ 2017. 

A.4. Licence 

The Physibel applications are protected by a licence, to prevent illegal use of the software. This 

can be either a hardware licence (Sentinel USB key) or a software licence. 

A.4.1. Hardware licence 

Perpetual licences are protected by a hardware licence (Sentinel USB key). The licence is locked 
to this dongle. It is strongly recommended to take a financial assurance for loss of the key by theft 
or any other incidence. 
 
Before Trisco2D can be used, the driver (delivered with purchase) for the hardware key needs to 
be installed. Administrator rights are needed for this installation. It might be necessary to restart 
your computer after installing the driver. 

 
During use of Trisco2D, the dongle needs to be attached to the computer at all times. 

A.4.2. Software licence 

Subscription licences are protected by a software licence. After first installation of Trisco2D, the 
user needs to activate the licence using the activation code received upon purchase of the 

software. When first opening Trisco2D, the Software Licence Manager will open automatically 
and prompt the user to activate the licence, or to register in the network floating database, 
depending on the licence type. The computer needs to be connected to the internet for this 
licence activation. Cloud-based floating licences are activated every time when opening the 
application. 
 
After activation, the Software Licence Manager is available from the menu for stand-alone 
licences: 
Help → Software Licence Manager… 
 
Users with a floating network licence can check out a licence from the database for a maximum 
period of 3 days. 

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
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Help → Check out/in floating licence… 

 
The software licence key for Trisco2D is linked to the computer where it was activated. When you 
want to move the application with a stand-alone licence to another computer, you can 
deactivate the licence in the Software Licence Manager. The licence can then be reactivated on 

a new computer. 
 
If the Software Licence Manager is unavailable from the application itself, you can also open it 
from the command prompt. You need to first change directory to the Program Files folder where 
the application is installed. Then, open the Software Licence Manager with the following 
command: 

QlmLicenseWizard.exe /settings “Trisco2D 2.1.lw.xml” 

A.5. User Account Control (UAC) 

Administrator rights are necessary to install Trisco2D on a computer. 
 
The installation of the application is machine-level, meaning all user accounts can access the 
application after installation. 
 

Each user account has its own copy of the colour database (see B.3.3) to work with. The colour 
database can be found in the user’s application data directory (C:/Users/username/Appdata/ 

Roaming/Physibel/Trisco2D2/). 

 
In case of a software licence, the licence for Trisco2D is linked to the computer, but is stored at 
the user level. Each user account on a computer has to activate the licence in order to have 
access to the licence. 

A.6. Overview of delivered files and file structure 

Trisco2D is installed (when the user accepts the default destination) in the folder C:\Program Files 

(x86)\Physibel. 

 
The following files are installed: 
Folder File Description 
…\Physibel\Trisco2D Trisco2D2.exe Trisco2D (64-bit) program 

 *.dll, *.pat, *.rgb Program resources 
 QlmLicenseWizard Software Licence Manager files 

…\Physibel\Materials *.phm Material databases 
…\Physibel\Manuals Trisco2D2Manual.pdf Trisco2D manual 
 TR2***.pdf Trisco2D How to’s 

 
Trisco2D tutorials are installed in Documents/Physibel/Trisco2D2/Tutorials. 
 
The colour database file ColourDatabase.tr2 and back-up ColourDatabase_Physibeldefault.tr2 

(see B.3.3) together with the parameter file Trisco2D.prm (see A.8), are installed in 
C:/ProgramData/Physibel/Trisco2D2, (machine-level) and copied to each user account’s 
application data folder when first opening Trisco2D (C:/Users/username/AppData/Roaming/ 
Physibel/Trisco2D2). 
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A.7. References 

− EN ISO 6946 (July 2017). Building components and building elements - Thermal resistance and 
thermal transmittance - Calculation methods.  

− EN ISO 10211 (August 2017). Thermal bridges in building construction – Heat flows and surface 
temperatures – Detailed calculations 

− EN 10456 (January 2008). Building materials and products – Hygrothermal properties – 
Tabulated design values and procedures for determining declared and design thermal 
values. 

− Piet Standaert, Twee- en drie-dimensionale warmteoverdracht: numerieke methoden, 
experimentele studie en bouwfysische toepassingen. Doctoral dissertation, K.U. Leuven, 1984 

(in Dutch). 

A.8. Program settings 

Global program settings can be edited via the main menu (Settings → …). 
 

 
 

        
 
− Settings → Thermal Palette…: select the colour palette for the visualisation of the resulting 

temperatures. 
− Settings → Zoom Factor…: to customise the zooming factor of the mouse scroll wheel. The 

selected zoom factor is saved in the program parameter file (Trisco2D.prm). 

− Settings → Toolbar: toggle to show or hide the graphic toolbar just below the menu bar. 
− Settings → Status Bar: toggle to show or hide the text bar at the bottom of the Trisco2D 

application window (containing context depending information). 
− Settings → Language → …: to select the user interface language (English, Dutch, French). The 

selected language is saved in the parameter file (Trisco2D.prm). After exiting Trisco2D (File → 
Exit) and restarting Trisco2D, the new language is active. 

 
Program default options (as set by the “Set As Default” button in several program dialog boxes) 
are saved in the parameter file (Trisco2D.prm) at program exit (File → Exit). The program 
parameters of the parameter file are loaded at program start up. 

A.9. General editing commands 

Copy – paste 
− Edit → Copy Value: copies the value from the active input cell into the clipboard. 

− Edit → Paste Value: copies the value from the clipboard into the active input cell. 
 
Undo – redo 
− Edit → Undo 

Undoes the last edit action (e.g. to cancel a mistake). 
This command can be repeated to undo more previous edit actions. 
Only the last 100 edit actions are stored for undo. 

The undo command is impossible after saving a file (File → Save and File → Save As...), 
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closing the current file (File → Close, also File → New, File → Open..., File → Import Data...) or 

starting a calculation (Calc → Calc System). 
− Edit → Redo 

Restores the previous edit action that was made undone using Edit → Undo. 
In other words: "redo" undoes "undo". 

This command can be repeated to restore more edit actions that were made undone.  
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CHAPTER B INPUT DATA 

B.1. Trisco2D program layout 

The input in Trisco2D is organised in several windows: 

− Image window, with a graphical representation of the model. 

− Grid window, with the distances along X and Y between the successive grid lines. 

− Blocks window, with a list of all building blocks of the geometry. 

The coordinates refer to the grid numbers in the Grid window. 

− Colours window, with the thermal data of the materials and boundary conditions. 

Each block in the Blocks window refers to a colour in the Colours window. 

 

  
 

A window can be activated by clicking with the left mouse button on its title bar or in its client 
area (when the window is already open and visible on the screen), or the window can be opened 

and activated by selecting the corresponding command in the Edit submenu. 
 

Upper part of Edit submenu 

 
 
Other input windows: 

− Lengths of flanking elements window, with lengths defined using grid number coordinates. 

− U values of flanking elements window, with U values along lines parallel to X or Y. 
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The following dialog boxes (also opened via the Edit submenu) contain additional input data: 

− Derived Thermal Properties dialog box, to request output of temperature factor, linear 
thermal transmittance or equivalent thermal transmittance. 

− Calculation Parameters dialog box. 

− Notes dialog box, to enter text comments about the data. 

B.2. Trisco2D start-up 

When Trisco2D is launched, the parameter file Trisco2D.prm is read to load default program 
settings. 

Then the colour database ColourDatabase.tr2 is read to initialise predefined material and 

boundary condition properties in the Colours window. 

B.3. File functions 

File submenu 

 

B.3.1. New project 

Menu command: File → New 
This command opens a new project, after closing the current open project (if present). 

The new project starts off with a single square block of size 1 m. 

All parameters are reset to their default values (as stored in the parameter file Trisco2D.prm), 
except for the colour definitions. This allows to reuse the colour definitions of the previous open 

file (or of the colour database ColourDatabase.tr2 loaded at start up). 

B.3.2. Open project 

Menu command: File → Open... 
After closing the current open project (if present), an Open dialog box appears. 
Select a Trisco2D data file (with extension .tr2) from the list in the current folder or another folder. 
 

When a file is opened, all parameters are reset to their default values (as stored in the parameter 
file Trisco2D.prm), except for the colour definitions. Then all data from the chosen Trisco2D data 

file are read and loaded into memory. The colour definitions in the data file overwrite existing 
colour definitions (e.g. of the colour database) with the same colour reference number. Colour 
definitions that are not present in the data file can be reused from the colour database or the 
previous project. 
When a solution (.sol file) is present on disk (in the same folder as the data file), then this solution is 
automatically loaded after reading the .tr2 file. 
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B.3.3. Open Colour Database 

Menu command: File → Open Colour Database... 
 
The colour database contains predefined material and boundary condition properties (stored in 
the file ColourDatabase.tr2 in the application data folder), which is loaded at every Trisco2D 
start-up. It is advisable to add frequently used materials and boundary conditions to the colour 

database. 
These predefined colours of the colour database are then available in any project, as far they are 
not overwritten by colour data of the current project or a previous project. 
 
The command File → Open Colour Database… allows to modify the 256 available predefined 
colours of the colour database. After editing the colour data, the modified colours should then be 
saved (File → Save) to modify the colour database on disk. 
 
Each user account on a computer has its own copy of the colour database (see A.5) to work with. 

B.3.4. Import DXF 

Menu command: File → Import DXF… 
 
This function allows to create an object model from a DXF underlayer. 
In the dialog box “Create DXF underlayer”: 

− Define the DXF unit considering the total object size. 
Press the <tab> key to view the unit modification in the total object size.  

− Select whether horizontal and vertical grid lines should be added in the Grid window based 

on present DXF lines. 
− Select in the list of DXF layers which layers should be skipped in the creation of the DXF 

underlayer. 

 
New vertical or horizontal grid lines through DXF vertices can be added choosing the command 
Grid → Set Vertical Grid Line or Grid → Set Horizontal Grid Line and then using the mouse. 

The DXF underlayer in the Image window can be shown or hidden via the toggle command 
Image → Hide DXF Underlayer. 

B.4. Image window 

Menu command: Edit → Image 

 

The Image window shows a graphical representation of the object model. 

This window has its own toolbar. 

The view functions are described in Chapter C. 
The graphical grid functions are described in sections B.6.8 and B.6.9. 
The paint functions are described in section B.7. 

B.5. Grid window 

Menu command: Edit → Grid 
 

The Grid window is the input window for grid mesh sizes of a rectangular 2D grid. 

Initially this is a design grid for the definition of the object geometry using blocks. 
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Finally, the grid should be refined to be used as a calculation grid with system nodes upon the 

grid nodes, for which the temperatures are calculated (with Calc → Calc System). 
 

 
 
The grid 

The ∆X and ∆Y columns in the Grid window correspond to the X and Y axes of the coordinate 

system. The X axis points to the right; the Y axis points downwards. 

The positions Xmin, Xmax, Ymin and Ymax of the object blocks in the Blocks window are 

expressed as integer numbers (starting from 0) referring to the consecutive grid lines. As a result, 

material objects are always rectangular and bounded by grid lines parallel to X and Y. 

 
Grid meshes 

The distances ∆X and ∆Y between successive grid lines are the grid meshes and are editable in 

the Grid window. The corresponding bordering grid line numbers are in the first column (“No.”). 

The grid lines occurring as block borders (Xmin, Xmax, Ymin, Ymax) in the Blocks window are 

visible through background colour changes in the ∆X and ∆Y columns (resp. white/red and 
white/green backgrounds). 

B.6. Grid functions 

Lower part of Edit submenu 

 

Grid submenu 

 

B.6.1. Insert mesh 

− Edit → Insert Before 
Insert a new X or Y mesh (with size = 1 grid unit) before the active mesh. 

− Edit → Insert After 
Insert a new X or Y mesh (with size = 1 grid unit) after the active mesh. 
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B.6.2. Grid mesh selections 

Individual grid meshes can be selected to perform global actions (split, merge). 
The selected meshes are marked in turquoise. 
 

   
 
Meshes can be selected by clicking (left mouse button) the cell while holding the <Ctrl> key. A 
selection range can be defined by holding the <Shift> key. All meshes within the same column ∆X 
or ∆Y can by selected by clicking (left mouse button) the column header.  

Alternatively, menu functions can be used to select meshes. 
 

From the Edit submenu: 

− Edit → Switch Select 
Switch on/off the selection for the active mesh. 

− Edit → Switch Select Downward 

Switch on/off the selection of the active mesh and all next meshes (within the same column  
∆X or ∆Y) with equal selection mode. 

− Edit → Switch Select Upward 

Switch on/off the selection of the active mesh and all previous meshes (within the same 
column ∆X or ∆Y) with equal selection mode. 

− Edit → Select All 

Select all meshes within the same column ∆X or ∆Y. 
− Edit → Deselect All 

Deselect all meshes (in both columns ∆X and ∆Y). 
 
From the Grid submenu: 
− Grid → Select all X and Y meshes 

Select all meshes (in both columns ∆X and ∆Y). 

B.6.3. Grid unit 

Menu command: Grid → Unit… 
 

   
 
Input of the correct grid unit is important before starting the calculation of the system. 
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B.6.4. Create minimum grid 

Menu command: Grid → Create Minimum Grid 
 

 
 
Creates a minimum grid in the selected directions. 

All grid meshes are rounded off to three decimal places. 
The meshes of the minimum grid pass only through block borders. 

B.6.5. Split (selected) mesh(es) 

Menu command: Grid → Split… 

 

Split either the selected meshes or the active mesh (when no selection is defined) into smaller 
parts according to one of the following methods: 

− Geometric split 
Select method = geometric. 
Each mesh is split into the specified number of subdivisions using a geometric series with 

given ratio. 
When the split ratio = 1, then all created submeshes are equal. 
When the split ratio < 1, then the submeshes have decreasing mesh widths. 

When the split ratio > 1, then the submeshes have increasing mesh widths. 
A negative or zero split ratio is not allowed. 

− Split using maximum mesh width 
Select method = maximum. 
All submeshes have a constant mesh width (as defined by the input field “mesh width”), except 
for the last submesh (width = remainder after division). 

− Split using border size 

− Select method = border 1. 
Each mesh is split into two parts, when the original mesh size is greater than the given 

“mesh width”. The first submesh (border 1) gets the size of the given mesh width, the second 
submesh gets the size of the difference. 

− Select method = border 2. 
Each mesh is split into two parts, when the original mesh size is greater than the given” 
mesh width”. The second submesh (border 2) gets the size of the given mesh width, the first 
submesh gets the size of the difference. 
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− Select method = border 1 & 2. 

Calls successively: split using border 2, then split using border 1. 
So each mesh is split into three parts (when the original mesh size is large enough): both 
outer submeshes get the size of the given mesh width, the middle submesh gets the size of 
the difference. 

B.6.6. Merge selected meshes 

Menu command: Grid → Merge 
 
Merge each group of consecutive selected meshes into the largest possible union meshes. 
Meshes at both sides of a block border cannot be merged (otherwise the block geometry would 

change). 
When no grid meshes are selected, the active mesh is merged with the next mesh (if possible). 
When all grid meshes are selected, then the merge function creates a minimum grid. 

B.6.7. Auto split (create Calculation Grid) 

Menu command: Grid → Auto Split… (create Calculation Grid) 
 

  
 

The automatic split function creates an optimised calculation grid, e.g. starting from the design 
grid for the definition of the object blocks. 
The “grid base size” is used as smallest subdivision of smaller grid meshes. 

Larger grid meshes are split using geometric increasing submeshes (with constant split ratio = 
1.5). 

B.6.8. Move grid line 

Menu command: Grid → Move Grid Line 

 

The current grid over the object geometry in the Image window is now visualised, if not already 
visible (cf. Image → Show Grid). 

The function enables to move an individual grid line to a new position by drag and drop using the 
left mouse button. 
The X or Y coordinate of the new position is displayed on the status bar at the bottom of the 
application window (showing initial and final coordinates, as well as the new neighbouring mesh 
sizes). 
A grid line that is moved beyond an adjacent grid line, will be removed after releasing the left 
mouse button. 

B.6.9. Set vertical / horizontal grid line 

Menu commands: Grid → Set Vertical Grid Line and Grid → Set Horizontal Grid Line 
 
The current grid and DXF underlayer over the object geometry in the Image window is now 

visualised, if not already visible (cf. Image → Show Grid and Image → Hide DXF Underlayer). 
The functions enable to set a new vertical or horizontal grid line at the mouse cursor position 
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when the left mouse button is clicked. 

The coordinates of the mouse cursor are displayed on the status bar at the bottom of the 
application window. 
If a DXF underlayer is present, then the new grid line is snapped to the closest DXF vertex 
highlighted with a black square marker. 

B.7. Paint functions 

Painting allows to change the colours of grid cells in the Image window and modifies accordingly 

the blocks in the Blocks window. A grid cell in the Image window is a rectangle formed by two 

pairs of successive vertical and horizontal grid lines. 

The paint colour is the current colour in the Colours window (i.e. the colour in the row in which the 

active input cell is located). 

The current grid over the object geometry in the Image window is now visualised, if not already 
visible (cf. Image → Show Grid) and modify the mouse cursor into a crosshair cursor. 
 

 
The figure above shows a grid cell around the crosshair mouse cursor within the grid in the 

Image window 

 
There are two paint functions: 
− Paint → Draw to paint an individual grid cell or a line of grid cells    
− Paint → Fill to paint a connected region of identically coloured grid cells   

B.7.1. Draw 

Menu command: Paint → Draw 

 
This command enters the “draw modus”. 

In the draw modus each click with the left mouse button paints the individual grid cell around the 

crosshair mouse cursor in the Image window using the active colour in the Colours window. 
Hold the left mouse button down while moving the mouse to colour more individual grid cells. 
 
Draw line of grid cells 
First draw the start grid cell with the left mouse button. 

Then hold the <Shift> key down, and click with the left mouse button at the end grid cell to draw 
all intermediate grid cells of the line of grid cells. 
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In the Blocks window new blocks are added at the end, corresponding to the new painted grid 
cells. 

When the number of blocks grow, it may be useful to optimise the layout of blocks (using the 
function Blocks → Optimise Blocks…). 

B.7.2. Fill 

Menu command: Paint → Fill 
 

This command enters the “fill modus”. 
In the fill modus each click with the left mouse button fills all connected grid cells with the same 
colour as the colour of the grid cell under the crosshair mouse cursor. The grid cells are filled up 

to the boundary of grid cells with a different colour, using a flood fill algorithm. 

The layout of the blocks in the Blocks window are automatically optimised (using the function 

Blocks → Optimise Blocks…) allowing overlapping blocks. 
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B.8. Blocks window 

Menu command: Edit → Blocks 
 

 
 

The object geometry is defined by blocks in the Blocks window. 

Each block has the following parameters: 

− Colour number (between 0 and 255) referring to a colour in the Colours window. 

− Block borders: Xmin, Xmax, Ymin, Ymax. 

The block borders are grid line numbers along X and Y (integers starting from 0), which 

positions are defined in the Grid window. 

The size of the active block (width x height) is shown in the status bar. 
 
Superposition rule 
Blocks with higher sequence number have priority over (i.e. overwrite the common parts of) 

blocks with lower sequence number. 

B.9. Block functions 

Lower part of Edit submenu 

 

Blocks submenu 

 

B.9.1. Insert block 

− Edit → Insert Before 
Insert a new block before the active block. 

− Edit → Insert After 
Insert a new block after the active block. 
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B.9.2. Block selections 

 
 

Individual blocks can be selected to perform global actions (delete, copy, move). 

The selected blocks are marked in turquoise. 
Blocks can be selected by clicking (left mouse button) the row number. Holding the <Shift> and 
<Ctrl> keys, a selection range can be defined. 
Alternatively, menu functions can be used to select blocks. 
 

Block selection functions: 
− Edit → Switch Select 

Switch on/off the selection for the active block. 
− Edit → Switch Select Downward 

Switch on/off the selection of the active block and all next blocks with equal selection mode. 

− Edit → Switch Select Upward 
Switch on/off the selection of the active block and all previous blocks with equal selection 

mode. 
− Edit → Select All 

Select all blocks. 
− Edit → Deselect All 

Deselect all blocks. 

B.9.3. Block list options 

− Blocks → List Same Colour 

This function only shows in the Blocks window all blocks having the same colour as the active 

block. 
The block sequence numbers are the original sequence numbers (as in the normal view 
option Blocks → List All). 
The colour number cannot be edited. 

 

 
 

− Blocks → List All 
List all blocks again. 
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B.9.4. Delete, copy, move blocks 

− Edit → Delete 
Delete selected block(s), or delete the active block (if no selection is made). 
 

− Blocks → Copy After 
Copy selected block(s) to a new position in the blocks list. 

If there is no block selection, the active block is copied after itself. 
If there is a block selection, the selected block(s) are copied immediately after the active 
block. 
After the copy operation the copied block(s) become the new block selection. 

 
− Blocks → Move Selection After 

Move selected block(s) to a new position in the blocks list. 
If there is no block selection, this function is disabled. 
If there is a block selection, the selected block(s) are moved immediately after the active 
block. 
After the move operation the selected block(s) remain selected. 

B.9.5. Optimise blocks 

Menu command: Blocks → Optimise Blocks…  
 

 
 

This function recalculates the list of blocks in the Blocks window based on the final object 

geometry in the Image window. The grid data in the Grid window remain unchanged. 

The function tries to minimise the number of blocks. 
There are two options: 
− Use overlapping blocks (with possible superposition of blocks) in order to obtain a larger 

reduction in the final number of blocks. 
− Use only non-overlapping blocks (without any superposition of blocks). 

B.9.6. Redefine colour globally 

Menu command: Blocks → New Colour… 
 

 
 
All blocks having the same colour number as the active block get a new colour number. 
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B.10. Colours window 

Menu command: Edit → Colours 
 

  
 

The Colours window defines the colours associated to the blocks in the Blocks window. 

Via the colours the thermal properties of the blocks are set. 

B.10.1. Colour number 

Each colour is identified by a colour number or colour index: an integer between 0 and 255. 
Therefore maximum 256 colours can occur in a project. 

 
The fill colour belonging to each colour number can be changed. Position the active cell 

(surrounded by thick black lines) onto the second column (showing the actual colour), and double 
click (with the left mouse button) or press <Enter>. Choose a new colour in the standard Colour 
dialog box. 

 

 
 
When Trisco2D is started up, the default colour values are loaded from the file MatColor.rgb in 
the application folder. 
This file contains the red, green and blue components (as numbers between 0 and 255) for all 
256 colour numbers. 
The present colours in the blocks of a project are stored in the .tr2 data file (as RGB values), and 
are automatically loaded when the .tr2 data file is read. 
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B.10.2. Colour type and subtype 

Each colour stands for a material or a boundary condition dependent on the colour type. 
 
The following types are available: 
− MATERIAL: material with fixed thermal conductivity. 

The material name and λ-value can be loaded from a material database 

(Colours → Load Material…). 
− EQUIMAT: equivalent material with equivalent thermal conductivity defined by the subtype, 

physical flow direction and geometrical flow direction. 

− BC_SIMPL: simplified surface boundary condition, defined by a surface heat transfer 
coefficient (for combined convection and radiation), boundary condition temperature and 

additional surface heat flux. 

− BC_FRE_S: enclosure with unknown (free) internal temperature, simplified surface heat 
transfer (defined by a given surface heat transfer coefficient) and additional surface heat flux. 

 
Possible standards (last column) for type BC_SIMPL and EQUIMAT: 
− EN6946: thermal properties according to EN ISO 6946 (2017): Building components and 

building elements - Thermal resistance and thermal transmittance - Calculation methods. 

− NIHIL: thermal properties not based on a standard. 
 
Possible subtypes for type EQUIMAT: 
− CAVITY: unventilated air cavity, defined by physical and geometrical heat flow direction. 

− LAYER: unventilated air layer, defined by physical and geometrical heat flow direction. 
Choose LAYER when the cavity width (orthogonal to the heat flow direction) is at least 10 times 

the cavity thickness (in the heat flow direction). 
− NIHIL: thermal properties defined by the user. 
 
Possible subtypes for type BC_SIMPL and BC_FRE_S: 
− HI: internal heat transfer, defined by physical flow direction. 
− HE: external heat transfer. 

− NIHIL: global surface heat transfer coefficient defined by the user. 
 

Possible physical heat flows (with reference to the ground surface): 

− HOR: horizontal heat flow. 
− UP: upward heat flow. 

− DOWN: downward heat flow. 
 
Possible geometric heat flows (with reference to the X and Y directions of the screen): 
− X: heat flow parallel to the X axis of the screen 
− Y: heat flow parallel to the Y axis of the screen. 

B.10.3. Colour name 

Enter a name for the material or boundary condition. 

The status bar shows the total area of all blocks having this colour. 

B.10.4. Thermal properties 

The relevant thermal properties for each colour type are shown in the Colours window. 

Values on a white background can be edited. Values on a yellow background are automatically 
calculated. Empty cells refer to irrelevant properties for the active colour type. 
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The following thermal properties are possible: 
− ε1/ε2 [-]: emissivities of the warm and cold side of the cavity or layer (EQUIMAT) (cf. section 

B.11.3). 
− λ [W/(m.K)]: thermal conductivity of the material (MATERIAL, EQUIMAT). 

− θ [°C]: boundary condition temperature (BC_SIMPL). 

− h [W/(m2.K)]: surface heat transfer coefficient (BC_SIMPL, BC_FRE_S). 

− q [W/m²]: surface heat flux (BC_SIMPL, BC_FRE_S). 

B.11. Colour functions 

Colours submenu 

 

B.11.1. List colours 

All or part of the available 256 colours can be shown in the Colours window: 

 

− Colours → List All 
List all 256 colours. 

The list is useful in choosing new colour numbers for blocks in the Blocks window. 

 

 
 

− Colours → List Defined 
List all defined colours. 

This option displays besides all present colours (referenced from the Blocks window) also 

other colour definitions of the colour database (and previous loaded data files), which are still 
present in memory.  
 

− Colours → List Present 

List all colours referenced from the Blocks window. 

 
The edit fields for present colours have black text on a white background. 
The edit fields for colours which are not present in the object model (not referenced from any 

block in the Blocks window) have grey text on a white background. 
Only the properties of present colours are saved in the .tr2 data file (executing File → Save). 
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B.11.2. Load material properties 

Menu command: Colours → Load Material... 
 
The Material Database dialog box allows to select a material from a group of materials in a 
material database. 
The available material databases contain the thermal conductivities of different materials 

according to several European standards, and are stored in the files with extension .phm in the 
Materials data folder (C:/Program Files(x86)/Physibel/Materials).  
 
After selecting a material and pressing the OK button, the corresponding properties are loaded 
for the active colour number. 
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B.11.3. Cavity emissivities 

Editing the grid cell of property ‘ε1 / ε2 [- / -]’ for colours of type EQUIMAT opens a dialog box for 

definition of the values. 
 
The dialog box prompts for the emissivities of the cold and warm surfaces facing the heat flow. 
 

 
 
A valid emissivity lies between 0.001 and 1. (Otherwise the default value 0.9 is used.) 

If any emissivity differs from 0.9 (the default value), the corresponding grid cell in the Colours 

window is highlighted in blue. The equivalent thermal conductivity is recalculated based on the 

new surface emissivities. 
Calculation method: see section D.1. 

B.11.4. Copy - paste 

The functions Colours → Copy Row and Colours → Paste Row allow to copy all properties from 
one colour number to another colour number. 
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B.12. Derived thermal properties 

Menu command: Edit → Derived Thermal Properties… 
 

 
 
This dialog box defines the desired derived thermal properties in the output after the system 

calculation. 

The properties can only be evaluated if two boundary conditions with different temperatures 
occur (external and internal temperatures). 

B.13. Lengths of flanking elements window 

Menu command: Edit → Lengths of flanking elements 
 

 
 
This window allows to define three lengths L1, L2 and L3. 

Each length is defined between two nodes (X1,Y1) and (X2,Y2) in the grid. 

The coordinates refer to grid numbers (starting from 0) in the Grid window. 

The active line (defined by the input cell in the window) is highlighted in the Image window. 

The grid coordinates of the active end point of the line (defined by the X1, Y1, X2 or Y2 position in 
the window) can also be set with the left mouse button, when the grid is made visible in the 

Image window (via the toggle command Image → Show Grid) and the mouse cursor is 

highlighted as a black square (i.e. when moved onto a grid node in the Image window). 

The lengths are used in the calculation of derived thermal properties. 

B.14. U values of flanking elements window 

Menu command: Edit → U values of flanking elements 
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This window allows to define three lines along which the thermal transmittance (U1, U2, U3) is 
calculated. 
Each line is defined between two nodes (X1,Y1) and (X2,Y2) in the grid. 

The coordinates refer to grid numbers (starting from 0) in the Grid window. 

The active line (corresponding to the input cell in the window) is highlighted in the Image window. 

The grid coordinates of the active end point of the line (defined by the X1, Y1, X2 or Y2 position in 
the window) can also be set with the left mouse button, when the grid is made visible in the 

Image window (via the toggle command Image → Show Grid) and the mouse cursor is 

highlighted as a black square (i.e. when moved onto a grid node in the Image window). 

 
The line must satisfy the following conditions, else the U value is unknown (with empty cell): 
− The line must be parallel to a coordinate axis (X1 = X2 or Y1 = Y2). 
− Both end points must lie in (or touch) different boundary conditions of type BC_SIMPL or 

BC_FRE_S with a surface heat transfer coefficient h > 0 W/(m2.K). 
− The line should only pass through material layers. 

− The line must not lie on the boundary between different colour blocks to avoid any possible 
ambiguity in the traversed colour blocks. 

 

The user can enter an enforced U value (in the last column), which always has precedence over 
the calculated U value. 
The U values of flanking elements are used in the calculation of derived thermal properties. 

B.15. Notes window 

Menu command: Edit → Notes… 
 

 
 
The entered text (max. 10 lines) is shown in the text output 

(Output → Text Output, then View → Input Data). 
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CHAPTER C VIEWING THE MODEL 

C.1. Image submenu 

The object model as defined in the Blocks window and Colours window is shown in the Image 

window. The view of the object in the Image window can be altered using image functions. 

 

          
 

The current view mode (Select, Zoom Window, Pan or Zoom In), current object appearance 
(Show Materials or Show Temperatures) and view options (Show Grid and Hide DXF Underlayer) 
are checked in the Image submenu (see check mark in front of menu commands). 

C.2. Select mode 

Menu command: Image → Select 
 

In Select mode an object can be selected from the Image window with the left mouse button. 

The selected object is highlighted in the Image window. 

The kind of object (block, grid mesh, colour) is dependent on the active window (Image window, 

Blocks window, Grid window, Colours window). 

 
Press <Esc> from any other command status (Image → Zoom Window, Image → Pan, Image → 

Zoom In, Grid → Move Grid Line, Grid → Set Vertical Grid Line, Grid → Set Horizontal Grid Line, 

Paint → Draw, Paint → Fill) to return to Select mode and move the focus to the Image window. 

C.3. Zoom commands 

− Image → Zoom Window 

Enters “zoom window” mode. This allows to draw a zoom rectangle using the mouse in the 
Image window, which defines the borders of a zoomed view. 

Press <Esc> to cancel the current zoom rectangle (before releasing the left mouse button). 
− Image → Pan 

Enters pan mode (only possible when the current view is already zoomed in). Mouse 

dragging or pressing arrow keys (with Image window active) moves the view over the object. 

Pan mode is activated automatically by holding down the mouse wheel. 
− Image → Zoom In 

Enters “zoom in” mode. A following click using the left mouse button in the Image window 
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defines the centre point of the next zoomed view. The zoom factor is a program setting (see 

A.8). When in “zoom in” mode, a click using the right mouse button zooms out. 
Zooming in is also possible using forward scrolling with the mouse wheel. 

− Image → Zoom Out 
Zooms out using the current zoom factor (or restores the total zoom, when zoomed out 

enough). 
Zooming out is also possible using backward scrolling with the mouse wheel. 

− Image → Zoom Total 
Shows total object. 

− Image → Previous View 
Shows the previous zoom view. (More than one previous view cannot be recalled.) 

C.4. Object appearance 

− Image → Show Materials 

Shows the blocks of materials, cavities and boundary conditions. 
− Image → Show Temperatures 

Shows the calculated temperatures on the material blocks in the object. 
This option is only available if a calculation solution is present. 
The colours of the temperature scale can be selected from different palettes (see A.8). 

The legend of used colours can only be made visible in the Graphics Output window 

(cf. section E.4). 

The temperature scale is defined in Image → Temperature Range…. 

− Image → Temperature Range… 
Opens a dialog box to define the parameters of a temperature view. 
The option “Use boundary condition temperatures” initialises the minimum and maximum 

temperatures from the present boundary condition temperatures in the Colours window. 

The first increment is used as step value in Image → Show Temperatures. 

The second increment and single value are only used with isothermal lines in the Graphics 

Output window. 

This command is only enabled when the menu command Image → Show Temperatures is 
chosen. 
 

 
 

− Image → Show Grid 

Show/hide the current grid in the Image window. 

− Image → Hide DXF Underlayer 

Hide/show the DXF underlayer in the Image window (after File → Import DXF…). 
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C.5. Pick temperature using the mouse 

When the Image window is active (i.e. its title bar is blue) and the temperatures are shown (Image 

→ Show Temperatures), then the surface temperature at the mouse cursor is displayed in the 
status bar (bottom left of the screen). 

The number of decimals can be modified via Settings → Decimals… from the Text Output 

window (cf. section F.5 Chapter E). 
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CHAPTER D CALCULATION 

D.1.    Automatic calculation of equivalent thermal conductivity of EQUIMAT colour 

The calculation of the equivalent thermal conductivity of a colour of type EQUIMAT in the Colours 

window is dependent on the subtype (CAVITY, LAYER), physical flow direction (HOR, UP, DOWN) 
and geometrical flow direction (X, Y). The calculation formula is based on the European standard 

EN ISO 6946, as indicated in the last column of the Colours window. 

 
Characteristic dimensions 
The characteristic dimensions are called depth (parallel to the heat flow direction) and width 

(orthogonal to the heat flow direction). 
If the air cavity is not a rectangle, the depth 𝑑 and width 𝑏 are calculated from an equivalent 
rectangle (with sides parallel to X and Y) with the same aspect ratio: 
 

 
Equivalent thermal conductivity of unventilated air cavity (CAVITY) or unventilated air layer 
(LAYER) 
𝜆𝑒𝑞 = (ℎ𝑐 + ℎ𝑟) ∙ 𝑑 

 
ℎ𝑐 = convective heat transfer coefficient (from warm surface to cold surface) 

Horizontal heat flow: ℎ𝑐 = 𝑚𝑎𝑥 {
0.025

𝑑
, 1.25} 

Upward heat flow: ℎ𝑐 = 𝑚𝑎𝑥 {
0.025

𝑑
, 1.95} 

Downward heat flow: ℎ𝑐 = 𝑚𝑎𝑥 {
0.025

𝑑
, 0.12 ⋅ 𝑑−0.44} 

 
ℎ𝑟 = radiative heat transfer coefficient 

ℎ𝑟 = 4 × 5.67 × 10−8 × (𝜃𝑚 + 273.16)3 ×
1

1
𝐸 +

1
𝐹 − 1

 

𝜃𝑚 = 10°C 

𝐸 =
1

1
𝜀1

+
1
𝜀2

− 1
 

𝜀1, 𝜀2 = emissivities at warm and cold sides of cavity (default values: 𝜀1 = 𝜀2 = 0.9) 

𝐹 =
1

2
∙ (1 + √1 + (

𝑑

𝑏
)

2

−
𝑑

𝑏
) 

For a layer (type = LAYER): 𝐹 = 1 (since 𝑑/𝑏 ≈  0) 
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D.2. Calculation parameters 

Menu command: Edit → Calc Parameters… 
 

 
 
The calculation parameters control the calculation of the thermal system (Calc → Calc System), 
using iterations: 
− Maximum number of iterations: maximum allowed number of iteration steps. 
− Maximum temperature difference: maximum allowed temperature difference in any node 

between the previous and the current iteration step. 
− Maximum heat flow divergence for total object: maximum allowed relative energy balance 

error for the total object (as union of all elementary control volumes). 
− Maximum heat flow divergence for any node: maximum allowed relative energy balance 

error for the worst elementary control volume. 

The iteration stops when the last three conditions are satisfied. 

The first condition (maximum number of iterations) acts as an emergency break. 

D.3. System calculation 

Menu command: Calc → Calc System 
 

A monitor shows the progress of the calculation. 
 
First the input data are saved on disk (with file extension .tr2). 
Then a system of linear equations is set up. 
The equations express an energy balance for the control volume around each system node. 
The extent of the control volume within the object is half the grid mesh along X and Y. 

All heat flows in the energy balance are expressed as linear functions of neighbouring node 
temperatures. 

Thereafter the linear system is solved using a fast and stable iterative method. 
When the calculation is finished, the calculated node temperatures are saved in a file with 
extension .sol (same name as data file) in the same folder of the input data file. 
 
Memory requirement 
512 Mb RAM allows to solve a system of about 1,000,000 nodes. 
1 Gb RAM allows to solve about 3,000,000 nodes. 

 
Interrupt calculation 
The calculations can be stopped at any time by pressing the <Esc> key. The obtained 
temperatures at that moment are saved in a .sol file. When restarting the calculation, the saved 
intermediate solution is loaded from the .sol file and the iteration restarts. 
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Temperatures out of range 

Sometimes it is possible that some calculated node temperatures are outside the range of 
boundary condition temperatures. This is not a calculation error, but a “feature” of the solution 
technique: the energy balances are not applied for the isolated system nodes, but for the 
surfaces of a finite control volume around the nodes. Due to this discretisation such small 

overflows in calculated node temperatures may occur. The overflow is made smaller by refining 
the grid. 

D.4. Heat flow divergences 

The quality of the solution is mainly determined by the heat flow divergence of the total object, 
called in short object divergence (displayed in the calculation monitor). It is defined as the sum of 
all elementary heat flows entering the object (outgoing heat flows have a negative sign), divided 
by half the sum of the absolute values of all heat flows: 

𝑂𝐷 =
|𝛷𝑖𝑛,𝑜 − 𝛷𝑜𝑢𝑡,𝑜|

0.5 ⋅ (|𝛷𝑖𝑛,𝑜| + |𝛷𝑜𝑢𝑡,𝑜|)
⋅ 100 

with 𝑂𝐷  = object divergence [%] 
 𝛷𝑖𝑛,𝑜 = total incoming heat flow for the object [W] 

 𝛷𝑜𝑢𝑡,𝑜 = total outgoing heat flow for the object [W] 

 
By using the factor 0.5 the denominator can be interpreted as the heat flow "passing" the object. 
The maximum possible object divergence is 200 %, i.e. when there are only incoming heat flows 

and no outgoing heat flows: 𝛷𝑖𝑛,𝑜 > 0 and 𝛷𝑜𝑢𝑡,𝑜 = 0 (or vice versa 𝛷𝑖𝑛,𝑜= 0 and 𝛷𝑜𝑢𝑡,𝑜> 0). 

An object divergence tolerance of 0.001 % is recommended as reliable stopping criterion. 
According to the standard ISO 10211 the object divergence should be less than 0.01 %. 
 
Also a second heat flow divergence is used as additional stopping criterion: the maximum heat 
flow divergence for all nodes, called in short node divergence (also displayed in the calculation 

monitor). It is defined in a similar way as the object divergence: 

𝑁𝐷 = 𝑚𝑎𝑥𝑛(
|𝛷𝑖𝑛,𝑛 − 𝛷𝑜𝑢𝑡,𝑛|

0.5 ⋅ (|𝛷𝑖𝑛,𝑛| + |𝛷𝑜𝑢𝑡,𝑛|)
⋅ 100) 

with 𝑁𝐷  = node divergence  [%] 
 𝛷𝑖𝑛,𝑛= total incoming heat flow for the control volume around node n  [W] 

 𝛷𝑜𝑢𝑡,𝑛= total outgoing heat flow for the control volume around node n  [W] 

 
The default node divergence tolerance is 1 %. 

Sometimes it happens that the node divergence does not decrease during the calculation. This is 
caused by an “unlucky” node, that is connected to its neighbouring nodes in an “unfavourable” 
way (due to strongly different mesh widths and/or strongly different thermal conductivities). Then 
a node divergence tolerance of 200 % (or a slightly higher value, to compensate for possible 
rounding errors) may be necessary to suppress the node divergence stopping criterion. 
  



34 Manual Trisco2D v2.1 

D.5. Derived thermal properties 

The wanted derived thermal properties are defined using Edit → Derived Thermal Properties… 
It is supposed that there are only two environments with different temperatures. 

D.5.1. Temperature factor 

The temperature factor is calculated using the following formula (cf. ISO 10211): 

𝑓 =
𝜃𝑠𝑖,𝑚𝑖𝑛 − 𝜃𝑒

𝜃𝑖 − 𝜃𝑒
 

𝑓  = temperature factor [-] 
𝜃𝑖 = internal boundary condition temperature [°C] 

𝜃𝑒 = external boundary condition temperature [°C] 
𝜃𝑠𝑖,𝑚𝑖𝑛 = minimum internal surface temperature [°C] 

 
The output also reports: 
− The internal heat transfer coefficient ℎ𝑖 [W/(m2.K)] and internal surface resistance 𝑅𝑠𝑖 [m

2.K/W] 
where 𝜃𝑠𝑖,𝑚𝑖𝑛 applies. 

− The relative humidity above which surface condensation occurs for the air at the internal 
boundary condition temperature. 

D.5.2. Linear thermal transmittance 

The linear thermal transmittance is calculated using the following formula (cf. ISO 10211): 

Ψ =
𝛷

𝜃𝑖 − 𝜃𝑒
− 𝑈1 ∗ 𝐿1 − 𝑈2 ∗ 𝐿2 − 𝑈3 ∗ 𝐿3 

Ψ  = linear thermal transmittance [W/(m.K)] 

Ψ  = total heat flow through object [W/m] 
𝜃𝑖 = internal boundary condition temperature [°C] 
𝜃𝑒 = external boundary condition temperature [°C] 

𝑈1, 𝑈2, 𝑈3 = 1D thermal transmittances of flanking elements [W/(m2.K)] 
𝐿1, 𝐿2, 𝐿3 = lengths of flanking elements [m] 

The lengths of the flanking elements are defined in the Lengths of flanking elements window. 

The U values of the flanking elements are defined in the U Values of flanking elements window. 

D.5.3. Equivalent thermal transmittance 

The equivalent thermal transmittance is calculated using the following formula: 

𝑈𝑒𝑞 =
𝛷

(𝜃𝑖 − 𝜃𝑒) ∗ (𝐿1 + 𝐿2 + 𝐿3)
 

𝑈𝑒𝑞 = equivalent thermal transmittance [W/(m2.K)] 

𝛷  = total heat flow through object [W/m] 
𝜃𝑖 = internal boundary condition temperature [°C] 
𝜃𝑒 = external boundary condition temperature [°C] 
𝐿1, 𝐿2, 𝐿3 = lengths of flanking elements [m] 

The lengths of the flanking elements are defined in the Lengths of flanking elements window. 
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CHAPTER E GRAPHIC OUTPUT 

E.1. Graphic Output window 

Menu command: Output → Graphic Output 
 
A new full-screen window with its own menu, toolbar and status bar are displayed. 
To return to the main Trisco2D window, choose File → Exit or press the <Esc> key. 

 

 

E.2. Save image 

Menu command: File → Save As… 
 
Save the current image as a .png file (in PNG format) on disk. 
The image size (width and height) and font size for legend text are defined via the menu 
command  
Settings → Image Size…. 
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E.3. Zoom commands 

Zoom submenu 

 
 

The zoom commands are identical to those of the Image window in the main menu. 

Zooming in and out is also possible via scrolling forward and backward of the mouse wheel. 

E.4. View options 

View submenu 

 

 

 
The check marks in front of the menu commands show the current view options. 
Any change in the view options is immediately reflected in the image. 
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− View → Object Lines: show object contour lines. 
− View → Grid Lines: show grid lines. 
− View → Isothermal Lines: show isothermal lines conform to the temperature range parameters 

(Settings → Temperature Range…). 

Only possible when a calculation solution is available. 
− View → Heat Flow Lines: show heat flow lines conform to the heat flow parameters (Settings 

→ Heat Flow Increments…). 

Only possible when a calculation solution is available. 
− View → Derived Thermal Properties: show linear thermal transmittance or equivalent thermal 

transmittance (dependent on chosen option from main menu Edit → Derived Thermal 

Properties…) as text in the legend at the right of the figure. 
The defined lengths and U values are indicated in the figure. 
Only possible when a calculation solution is available. 

− View → Fill Materials: fill material blocks (of type MATERIAL or EQUIMAT) using the block 
colours. 

− View → Fill Boundary Conditions: fill boundary condition blocks (of type BC_SIMPL or 
BC_FRE_S) using the block colours. 

− View → Fill Temperatures: fill material blocks using temperature colours conform to the 
temperature range parameters (Settings → Temperature Range…). The colour palette for the 
temperatures can be selected in the main application (see A.8). 
Only possible when a calculation solution is available. 

− View → Fill Off: switch off filling. 
− View → Legend: show a legend at the right side of the figure. 
 
Heat flow lines 

Heat flow lines show the directions of the local heat flux vectors. 
The density of the heat flow lines is proportional to the local heat flow magnitude. 
The isotherms and heat flow lines form orthogonal fields. 
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The number of heat flow lines through a given line multiplied by the heat flow increment equals 

the total heat flow through that line. 

E.5. Settings 

Settings submenu 

 
 
Settings → Temperature Range… 

− Use boundary condition temperatures: initialise the minimum and maximum temperatures 

from the present boundary condition temperatures in the Colours window. 

− Minimum temperature [°C] in graphic output. 
− Maximum temperature [°C] in graphic output. 
− First (or minor) increment [°C]. 

Used for temperature filling (View → Fill Temperatures) and isothermal lines  
(View → Isothermal Lines). 

− Second (or major) increment [°C] (must be a multiple of first increment). 
Only used with isothermal lines (View → Isothermal Lines). 

− Single temperature value [°C] (e.g. dew point). 
Only used with isothermal lines (View → Isothermal Lines). 

 

 
 

Settings → Heat Flow Increments… 
Used with View → Heat Flow Lines. 
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Settings → Line Styles… 

 

 
 
A colour field can be edited by double clicking on it with the left mouse button, which opens a 
Colour dialog box in which the colour value (RGB components) can be defined. 
The width of isothermal lines and heat flow lines can be set to 0 pixels to cancel them. This is 

useful when e.g. only the second isothermal lines are desired in the figure. 
 
Rainbow colours 
The filled isotherms are coloured using a rainbow scale interpolated from values defined in the a 
.rgb-file (a text file containing the red, green and blue components with values between 0 and 
255 of the successive rainbow colours). The colours of the temperature scale can be selected 
from different palettes (see A.8). 
The files RainbowColor.rgb and Ironbow.rgb are stored in the application folder. 
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CHAPTER F TEXT OUTPUT 

F.1. Text Output window 

Menu command: Output → Text Output 
 
A new full-screen window with its own menu and toolbar are displayed. 
To return to the main Trisco2D window, choose File → Exit or press the <Esc> key. 

 

 
 

The text within the Text Output window can be edited. 

F.2.  Save text 

Menu command: File → Save As… 
 
Save the whole text in the current Text Output window into a Microsoft Word document (.doc) on 

disk. 

F.3.  Copy text 

Menu command: Edit → Copy 

 
Copy the selected text (selected using the mouse or the arrow keys with the <Shift> key held 

down) into the clipboard (so that it can be pasted in an external text editor). 

F.4. View options 

View submenu 
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F.4.1. Input data 

Menu command: View → Input Data     
 
Output 
− Document notes (defined with Edit → Notes… from the main menu) 
− Trisco2D data file name 

− Grid data: grid mesh widths along X and Y 
− Blocks: block colour, block coordinates (as grid numbers, and absolute coordinates using the 

grid unit) 
− Colours: all present colours with colour type and thermal properties 
− Calculation parameters 
 
Example 
 
Trisco2D - Input Data 

 

Trisco2D data file: wall_internal_insulation.tr2 

 

GRID 

No. X Y 

[m] [m] 

0-1 0.074 0.010 

1-2 0.076 0.010 

2-3 0.051 0.010 

3-4 0.034 0.015 

4-5 0.022 0.022 

5-6 0.015 0.012 

6-7 0.010 0.012 

7-8 0.010 0.022 

8-9 0.010 0.015 

9-10 0.010 0.010 

10-11 0.008 0.010 

11-12 0.010 0.015 

12-13 0.015 0.022 

13-14 0.022 0.034 

14-15 0.034 0.014 

15-16 0.051 0.014 

16-17 0.076 0.034 

17-18 0.072 0.022 

18-19  0.015 

19-20  0.010 

20-21  0.010 

21-22  0.010 

Sum 0.600 0.350 

 

BLOCKS 

No. Col. Xmin Xmax Ymin Ymax 

1 170 0 24 0 1 

2 57 0 24 1 3 

3 180 0 24 3 15 

4 151 0 24 15 25 

5 15 9 15 15 25 

6 145 0 24 25 27 

7 174 0 24 27 28 

 

 

No. Col. Xmin Xmax Ymin Ymax 

[m] [m] [m] [m] 

1 170 0.000 0.600 0.000 0.010 

2 57 0.000 0.600 0.010 0.020 

3 180 0.000 0.600 0.020 0.210 

4 151 0.000 0.600 0.210 0.330 

5 15 0.280 0.320 0.210 0.330 

6 145 0.000 0.600 0.330 0.340 

7 174 0.000 0.600 0.340 0.350 

 

COLOURS 

Col. Type Subtype Phys. Geom. Name  lambda t h q 

flow flow   [W/mK] [°C] [W/m²K] [W/m²] 

15 MATERIAL    softwood  0.130 

57 MATERIAL    cement_sand_render 1.000 

145 MATERIAL    gypsum_1200_kg/m³ 0.430 

151 MATERIAL    insulation_0.035 0.035 

170 BC_SIMPL HE   exterior   0.0 25.00 0 

174 BC_SIMPL HI HOR  interior  20.0 7.70 0 

180 MATERIAL    masonry_heavy 0.900 

 
CALCULATION PARAMETERS 

Maximum number of iterations = 10000 

Maximum temperature difference = 0.0001°C 
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Heat flow divergence for total object = 0.001 % 

Heat flow divergence for worst node = 1 % 

F.4.2. Calculation results 

Menu command: View → Results   
 
Output 
− Trisco2D data file name 
− Number of nodes 
− Iteration convergence quality numbers: heat flow divergence for total object and for worst 

node 
− List of minimum and maximum temperatures per colour (and corresponding X, Y grid 

numbers) 
− List of total heat flows (in and out of object) per boundary condition, 

and calculated internal temperature (for BC_FRE_S) 
− Temperature factor (if requested in Edit → Derived Thermal Properties… from main menu) 
− Linear thermal transmittance or equivalent thermal transmittance 

(cf. chosen option in Edit → Derived Thermal Properties…) 
 
Remark on listed heat flows 
The incoming and outgoing heat flows per boundary condition colour, as listed in the calculation 
results, are equal to the sums of elementary incoming and outgoing heat flows for all control 
areas around the system nodes touching that boundary condition colour. This is done this way 

because the system solution is also calculated from the energy balances containing these heat 
flows through the control areas. 
Sometimes some system nodes belong to more than one boundary condition colour. This 

happens whenever two boundary condition colours touch each other. Trisco2D requires that 
those boundary condition colours must have the same type (BC_SIMPL or BC_FRE_S), otherwise 
an error message appears when starting the calculation. The control area of such a border node 

is assigned to one of the adjacent boundary conditions. 
This implies the possibility that the total heat flow of such a boundary condition is underestimated 

or overestimated. Note however that the sums of the incoming and outgoing heat flows of all 
adjacent boundary condition colours are always correct. The underestimation or overestimation 
error can be decreased by applying smaller grid mesh widths at both sides of the contact nodes 

of the bordering boundary condition colours. 
 
Example 
 
Trisco2D - Calculation Results 

 

Trisco2D data file: roofjunction.tr2 

 

Number of nodes = 8100 

Heat flow divergence for total object = 3.29652e-05 % 

Heat flow divergence for worst node = 0.000565127 % 

 

Linear thermal transmittance (EN ISO 10211) 

psi = Q/(ti-te) - U1*L1 - U2*L2 = -0.008 W/(m.K) 

  Q = 18.812 W/m 

  ti = 20°C 

  te = 0°C 

  U1 = 0.365 W/(m².K) 

       X1=5 Y1=88 X2=26 Y2=88 

       interior_(norma   h=7.700 [(m².K)/W] 

       gypsum_900_kg/m   d=0.010[cm]   lambda=0.300 [W/mK] 

       masonry_medium_   d=0.140[cm]   lambda=0.320 [W/mK] 

       insulation_0.03   d=0.060[cm]   lambda=0.030 [W/mK] 

       masonry_heavy     d=0.090[cm]   lambda=0.900 [W/mK] 

       exterior          h=25.000 [(m².K)/W] 

  L1 = 1.3 m 

       X1=1 Y1=88 X2=1 Y2=55 

  U2 = 0.365 W/(m².K) 

       X1=76 Y1=78 X2=76 Y2=55 

       indoors,_upward   h=10.000 [(m².K)/W] 
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       gypsum_900_kg/m   d=0.010[cm]   lambda=0.300 [W/mK] 

       reinforced_conc   d=0.140[cm]   lambda=2.500 [W/mK] 

       concrete_densit   d=0.080[cm]   lambda=1.150 [W/mK] 

       insulation_0.02   d=0.060[cm]   lambda=0.025 [W/mK] 

       bitumen_sheet     d=0.010[cm]   lambda=0.230 [W/mK] 

       exterior          h=25.000 [(m².K)/W] 

  L2 = 1.3 m 

       X1=5 Y1=15 X2=76 Y2=15 

 

Col. Type      Name                 tmin    X    Y      tmax    X    Y 

                                    [°C]                [°C]         _ 

17   MATERIAL  limestone_hard       0.01    1    1      0.29   20    6 

32   MATERIAL  bitumen_sheet        0.02    5    6      2.73   25   25 

72   MATERIAL  concrete_densit     14.52   25   62     18.52   76   68 

129  MATERIAL  gypsum_900_kg/m     16.94   25   76     19.22   76   77 

133  MATERIAL  insulation_0.03      0.11   11    7     15.82   17   74 

135  MATERIAL  insulation_0.02      0.45   43   42     18.02   76   62 

136  MATERIAL  reinforced_conc     15.28   17   68     18.95   76   76 

148  MATERIAL  masonry_medium_      0.19   25    7     18.81   25   88 

170  BC_SIMPL  exterior             0.01    1    1      0.84   26   15 

174  BC_SIMPL  interior_(norma     18.16   26   78     19.05   26   88 

180  MATERIAL  masonry_heavy        0.03    5    7      1.02   11   88 

190  BC_SIMPL  indoors,_upward     17.73   26   77     19.22   76   77 

 

Col. Type      Name                    t   Flow in  Flow out 

                                    [°C]     [W/m]     [W/m] 

170  BC_SIMPL  exterior                       0.00     18.81 

174  BC_SIMPL  interior_(norma                7.72      0.00 

190  BC_SIMPL  indoors,_upward               11.09      0.00 

F.4.3. Temperatures in corner nodes 

Menu command: View → Corner Nodes   
 
Output 

Per object corner: X,Y grid numbers + calculated temperature 
 
Example 
 
Trisco2D - Temperatures in corner nodes 

 

Trisco2D data file: wall_internal_insulation.tr2 

 

X Y t 

  [°C] 

0 1 0.23 

0 27 19.33 

24 1 0.23 

24 27 19.33 

 
List of all node temperatures 

See .sol file, lines starting with letter N: node temperature + X,Y grid numbers 

F.5. Output decimals 

Menu command: Settings → Decimals… 
 

 


