
PHYSIBEL SOFTWARE TUTORIAL  1 / 17 

 

Tutorial 

Calculating the temperatures in window frame 

during a sunny day: getting started with BISTRA 

BST Tutorial a 

  
BISTRA 

 

1. Introduction                    alu_1_frame_glazed.bsc  

alu_1_frame_glazed_dynamic.bst  

This tutorial explains how to calculate the temperatures occurring in a glazed window frame 

during a sunny day with BISTRA. The tutorial uses the geometrical model of the window frame 

and glazing discussed in the BISCO tutorials BSCa1 and BSCb2. 

Key elements: 

- Weather data (EPW-format) as boundary conditions 
- Thermal properties 

- Defining glass properties 
- Definition of solar data and sun obstacles 
- Graphic output and text output 

 
2. Case study data          

This tutorial starts with the horizontal section of an aluminium window frame with double glazing 

resulting from a DXF file in the BISCO tutorials BSCa and BSCb. The window is located in Brussels 

(with Uccle climate data) and is oriented to the West. The simulation will be conducted for June 

16th, a sunny day with high solar load on a West oriented wall. 

At the inside an environment constant air and radiative temperature of 25°C is assumed. 

The tutorials illustrates how to calculate the dynamic temperature field, the maximum 

temperature within the frame and glazing panes and the maximum temperature differences in 

the two glazing panes during this day. 

   

 

1 BISCO Tutorial BSCa-Thermal transmittance of a window profile according to EN ISO 10077-2 
2 BISCO Tutorial BSCb - Linear thermal transmittance of a glazing spacer according to EN ISO 10077-2 

 

project_files/alu_1_frame_glazed.bsc
project_files/alu_1_frame_glazed_dynamic.bst
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3. Getting started                    

- Start BISTRA and open the BISCO file alu_1_frame_glazed.bsc from the directory 
…\Documents\Physibel\Bistra5\Tutorials, using the menu command File  → Open…. 
Note: The extension of a BISTRA data file is .bst, but BISTRA can also read BISCO data files 
(with extension .bsc, chosen from the field “Files of type” in the “Open” dialog box). 

- The bitmap size of alu_1_frame_glazed.bmp is 2890 x 950 pixels, with a pixel size of 0.1 
mm. 

- The triangulation size in BISCO tutorial BSCb was set to 5 pixels. For this dynamic 
simulation a somewhat bigger triangulation size is recommended. Adjust the global 
triangulation size to 15 pixels (top right in Measures Window) 

- Save the BISTRA file under a different name: File → Save as…  
(e.g. alu_1_frame_glazed_dynamic.bst) 
 

 

 

  

project_files/alu_1_frame_glazed.bsc
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4. Weather data 

- Open the Functions window (Edit → Functions).  

- Add a new Function: Edit → Insert Row. 
- For this tutorials we will create 3 functions for which we use the Type EPW: 

o G01: horizontal global solar radiation  
o D01: horizontal diffuse solar radiation  
o T01: temperature 

 
 
 

 
 
 
 

- The first function with reference G01 refers to the horizontal global solar radiation data for 
Uccle. 

- A function reference consists of a letter which refers to the function type (here “G” = 
horizontal global solar radiation) and a two-digit sequence number. 

- The Function Graph window shows the current function G01. 

The time axis shows all days of the year with the origin (abscissa 0) at day number 167 (=  

June 16th ), as defined in the Calculation Parameters dialog box (Edit → Calc Parameters…, 
day number at start of calculation = 167, see section 0). 
 

 
 

- Functions → X Scale… and select “Calculation time” as scope. 
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- The function “D01” is used for the creation of the horizontal diffuse solar radiation data of 
Uccle (see picture below left). The function “T01” shows the air temperature of Uccle (see 
picture below right). 
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5.  Boundary conditions 

- In the Colours window boundary conditions can be defined. When loading the 

alu_1_frame_glazed.bsc 3 boundary conditions with the type BC_SIMPL (global surface 

coefficient) are included (according to the rules defined in EN ISO 10077-2):  
o Colour 174: 20°C h=7.7 W/(m².K) 
o Colour 182: 20°C h=5 W/(m².K)  (reduced surface coefficient in corners) 
o Colour 170: 0°C h=25 W/(m².K) 
 

 

 

 

 

 

- For the dynamic calculations including solar radiation the boundary conditions will be 
switched to the type BC_SKY, taking into account detailed radiation. For this reason there 
is no need anymore to use the reduced global surface coefficient linked to colour 182.  

- To change colour 182 to colour 174: Activate Colour 182 by selecting it with a left mouse 

click in the bitmap or select the corresponding row in the Colours window. Bitmap → 
Change Colour… (F5) and fill in 174 and press OK. 

 
 

 

 

 

 

 

- The inside environment is located at the top of the bitmap (colour number 174). It is 
modelled as type BC_SKY with constant air temperature and radiative temperature (= 
25°C). The convective heat transfer coefficient hc = 2.5 W/(m².K) (cf. EN ISO 13792). The 

zone is marked as non-solar zone (sun = NO, in column “Sun” in Colours window). 
- The outside environment is located at the bottom of the bitmap (colour number 170). It is 

modelled as BC_SKY with air temperature and radiation temperature referring to the 

function with reference T01 as defined in the Functions window. The convective heat 
transfer coefficient hc = 8.0 W/(m².K) (cf. EN ISO 13792). The zone is marked as solar zone 

(sun = YES, in column “Sun” in Colours window). 

 

  
  

project_files/alu_1_frame_glazed.bsc
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- It is important to switch the type BC_SIMPL to BC_SKY. The BISTRA solar processor then 
considers reflected solar radiation. If it was BC_SIMPL, all reflected radiation would be 

lost (because no detailed radiation is considered for BC_SIMPL). 

- If the object surface is transparent (see following section 6.a), the amount of transmitted 
radiation is calculated from the remainder of solar radiation (after subtraction of 
reflection) and the transmission factor of the object colour in contact to the solar zone, 
and transferred to the opposite side of all adjacent transparent layers (colours of type 
MATERIAL or EQUIMAT).  The zone at this other side should be a view factor zone (type 

BC_FREE, BC_SKY, BC_NOSKY, TRANSMAT), otherwise (type BC_SIMPL, BC_FRE_S) the 
transmitted radiation is lost.  

 

6. Thermal material properties 

The Colours window also defines the material properties of the different colours in the bitmap. 

BISTRA materials (and equivalent materials) have, in addition to BISCO materials, thermal 

capacity properties (material density ρ in kg/m³ and specific heat c in J/(kg.K)), and radiative 

properties. Special attention is given in this section to the properties of the glazing cavity and the 

radiative properties of the glazing panes. 

a. Glass cavity according to EN 673 

The glazing cavity (colour 17) is as a 90% filled argon space modelled with the type TRANSMAT 

(with gas properties in line with EN 673).  

- Change the Type of Colour 17 in the Colours window to TRANSMAT. 

- Change the corresponding standard (last column) to EN 673. 
- Make sure that the geometrical (heat) flow direction is Y.  

- The thermal conductivity field in the Colours window will turn red. 

- Double click in this thermal conductivity field to define the cavity’s properties: 

   
- The equivalent thermal conductivity (considering convection) will now be calculated 

according to EN 673.  
Note: With a TRANSMAT type the infrared radiation across the cavity is calculated 
separately via view factors (see following paragraph)  
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b. Radiative properties of double glazing      

The cavity of the double glazing is modelled with TRANSMAT, which is a view factor zone. So the 

solar properties (reflection and transmission factors) on each side of the individual outer and 

inner panes must be considered. Therefore, we first split the colour used for the glass (colour 18) 

in 4 different colours by using the functions ‘Bitmap → Split Zones…’ and ‘Bitmap → Bisect…’.  

- First split glass (colour 18) in two separate colours: Select colour 18 and split in two 
separate zones (Bitmap → Split Zones…). 

- To further split each glass pane in two colours: select the function Bisect Bitmap → Bisect… 
and click on the corresponding glass colours with a horizontal split. 

 
 

 

 
 
 
 

- The resulting bitmap is: 

 
 

The next step is linking the radiative properties of the glass to the corresponding side of the glass 

via the bitmap colours in the Colours window.  

The double glazing unit consisting of two panes of 4 mm enclosing 16 mm space filled with argon 

(90%) with following properties is considered:  

 Side 1 Side 2 

 τ0 ρ0 α0 εIR τ0 ρ0 α0 εIR 

Glass 1 (outside) 0.83 0.08 0.09 0.837 0.83 0.08 0.09 0.837 

Glass 2 (inside) 0.58 0.30 0.12 0.04 0.58 0.24 0.18 0.837 

The subscript 0 refers to the incident angle = 0°, i.e. at normal angle of incidence. At the outer 

surface of the outer pane (glass 1, side 1) we consider an angle dependent reflection factor at the 

solar zone, defined by a function referred to by “R01” (cf. Functions window). 
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The function R01 is defined by the following points: 0 = 30 = 0.08, 45 = 0.089, 60 = 0.209, 

75 = 0.503, 90 = 1.0.  All other points are linearly interpolated (as shown in the function graph). 

The function file ‘glass.FRF’ is a simple text file (see above figure). 

The input value s in BISTRA is the transmission factor after subtraction of the reflection 

factor. 

From 0 + 0 + 0 = 1 and s + s = 1 (which holds after subtraction of the reflection factor s) 

follows:     

𝜏0 = (1 − 𝜌0) × 𝜏𝑠     or    𝜏𝑠 =
𝜏0

1−𝜌0
 and 0=s 

 Colour number τs ρs εIR 

Glass 1, side 1 21 0.90 0.08 (via R01) 0.837 

Glass 1, side 2 19 0.90 0.08 0.837 

Glass 2, side 1 20 0.83 0.30 0.04 

Glass 2, side2 18 0.76 0.24 0.837 

 

 

Note: If the cavity of the double glazing was modelled with EQUIMAT (equivalent material), then 

the solar properties of the global glazing system should be used at the outer and inner surface of 

the double glazing, because within adjacent material layers no separate reflection and 

transmission calculations are executed. The solar properties of adjacent material layers are thus 

not taken into account (their impact should be included in the solar properties of the first  

adjacent layer hit by the solar radiation). These solar properties of the glazing system as a whole 

are usually available from the glazing manufacturers. 
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7.  Solar data 

Upon opening the Solar Data dialog box (Edit → Solar Data…), the user can choose to simulate a 

real sun path or perform a simplified simulation with a fixed sun position. A real sun path is 

selected for this tutorial.  

The bitmap must then be positioned into the horizontal coordinate system (“North orientation”).  

This is a 3D coordinate system with the local horizon as fundamental plane XY.  The X axis points 

to the north, the Y axis points to the west, the Z axis points to the zenith. The coordinate 

transformation (from 2D bitmap XY into 3D horizontal coordinate system XYZ) is defined in the 

Solar Data dialog box. 

The first two angles define the transformation from the bitmap XbYb into a horizontal coordinate 

system XYZ without paying attention to the north direction within the local horizon plane. 

For a bitmap in a horizontal plane, i.e. representing a horizontal section view (as our example) 

the first two angles equal 0°. 

The third angle defines the north direction within the local horizon plane.  Change the value to 

180° to orientate the façade to the West.  

 

The position of the bitmap in the horizontal coordinate system can be checked within the Solar 

Data dialog box (for the sun position on June 21 at 12h). It is possible rotate the figure with the left 

mouse. 

The geographical location (latitude, longitude and time zone) are copied from these climate data 

files, and the input is not required in the Solar Data dialog box (the corresponding input fields are 

greyed). 
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8.  Sun Obstacles 

A sun obstacle is a spherical region on the sky hemisphere in the horizontal coordinate system in 

which the sun is blocked by other objects. Sun obstacles are defined in the Sun Obstacles window 

(Edit → Sun Obstacles). 

A new row can be inserted in the Sun Obstacles window via Edit → Insert Row .  

   

Each sun obstacle is a spherical rectangle defined by a minimum and maximum azimuth 

(clockwise angle with origin in the south, and ranging from –180° up to 180°) and minimum and 

maximum altitude (between 0° and 90°). 

The first sun obstacle is a zone around the horizon up to 5° high.  This obstacle is by default 

present for each new BISTRA data file to avoid numerical rounding errors for low sun positions. 

The second sun obstacle corresponds to the interior side of the building casting a shadow. 
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9. Calculation parameters 

The following dynamic calculation parameters are set in the Calculation Parameters dialog box 

(opened with Edit → Calc Parameters…):  

• Time step interval: 30 minutes. 
• Start-up calculation duration (to get dynamic start values): 0 seconds (i.e. no start-up). 

• Calculation duration: 1 day. 
• Day number at start of calculation: 167 (= 16th June), which marks the starting point in the 

weather data files (which contain 1 year of 365 days). 
 

  

10.  Report definition 

The Report Definition window (Edit → Report Definition) contains the report items that will be 

included in the text report output. Adding a new row to define an output: Edit → Insert Row  

The text report tabulates the report values at a regular time step interval (here every time step, cf. 

setting in Calc → Report Frequency…). 
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Include following items: 

• Time, using the format seconds (s). 
• Maximum temperature (max) of the window frame (colour 8) 
• Maximum temperature (max) in the inner glass pane (colours 18/20). 
• Maximum temperature difference (Δmax) in the inner glass pane (colours 18/20). 

• Maximum temperature (max) in the outer glass pane (colours 19/21). 
• Maximum temperature difference (Δmax) in the outer glass pane (colours 19/21). 

 

11. BISTRA calculation  

- Before starting the calculation, request that step solutions (.sol files and .sfx files) are saved 
during the calculation, so that afterwards graphic animations can be made in the graphic 
output section (Output → Graphic Output). 
For this example every single .sol file has a file length of 128 Kbytes, a single .sfx file 

15.5Kbytes. 
Open the Save Frequency dialog box with Calc → Save Frequency… to view the settings. 
 

 
 

- Now start the BISTRA calculation with Calc → Calc System.  
If a triangulation file (wooden_frame.tri) for the given BISTRA data file 
(alu_1_frame_glazed_dynamic.bst) already exists, the user is asked to recalculate the 

triangulation.  A recalculation of the triangulation can be necessary after a triangulation 

size is modified (in the Measures window) or a bitmap colour is modified. 

- After the triangulation the iterative solution starts. 
During the calculation a calculation monitor is displayed showing the progress (with 
current time step, current iteration step, stopping criteria, number of nodes, triangles, view 
factors). 

- For the given example, with time steps every 30 minutes and a global triangulation size of 

15 pixels, the calculation will take about 15-30 seconds. When the simulation is finished the 
calculation monitor will disappear.  

- After the calculation, output is available through the submenus via Output → Graphic 
Output or Output → Text Output.  

12. Graphic output  

- Go to Output → Graphic Output  
- Select the view option View → Fill Temperatures.  
- The temperature range (15°C – 55°C) and the temperature increment (1°C) can be 

changed in the Temperature Range dialog box, opened with Settings → Temperature 
Range…. 

- Get the results at the time step at 8 a.m. (Animate → Go To…, enter 0000:08:00:00). 



PHYSIBEL SOFTWARE TUTORIAL  13 / 17 

 

- At 17.30h we get high temperatures on the West facade. 

 

 

- Move the mouse over the image to get the temperature at the mouse point displayed in 
the status bar at the bottom of the BISTRA window. 
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- To visualise the sun position: View → Sun position  

 

 

- The absorbed solar radiation: View → Absorped Solar Fluxes   

 

- Go to File → Exit to quit the Graphic Output window. 
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- To make an animation of the field temperatures with Windows Video Editor: 
o Prepare the animatin images in BISTRA: 

▪ View → Fill Temperatures. 

▪ File → Save Animation Images… 
o Open Windows Video Editor, start new video project (e.g. Temperature_June16) 

▪ Add the generated Animation Images to the Project library in Video Editor 
and drag them thereafter to the storyboard.  

▪ Select all images in the storyboard and adjust the duration. 
▪ Finish video to export in .mp4 
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13. Text output 

- Go to Output → Text Output  
- Select View → Time Step Results, and Edit → Go To…, enter 0000:12:00:00.  The text 

window shows the time step results at 12 a.m. 
 

 

 
- Select View → Report Output       to get the report item values per time step for the report 

items defined in the Report Definition window (cf. section 10) 
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- The data can be exported to any spreadsheet application to visualize the results. 
 

 

 

 

 

- Press the <Esc> key or go to File → Exit to quit the Text Output window. 

 

 

 

 


